StructureMap Namespace

StructureMap API
StructureMap Namespace
Namespaces ► StructureMap
StructureMap API

[Missing <summary> documentation for N:StructureMap]

Declaration Syntax
C# Visual Basic Visual C++
namespace StructureMap
Namespace StructureMap
namespace StructureMap
Types
All Types Classes Interfaces Delegates
Icon | Type | Description
 | BuildSession |
 | ConfigurationExpression | Used as the argument in the Container.Configure() method to describe configuration directives and specify the sources of configuration for a Container
 | Container |
 | DefaultConstructorAttribute | Used to override the constructor of a class to be used by StructureMap to create a Pluggable object
 | ExplicitArgsExpression |
 | IBootstrapper |
 | IContainer | The main "container" object that implements the Service Locator pattern
 | IContext |
 | IExplicitProperty |
 | IInitializationExpression |
 | IInstanceFactory | Interface for a "Factory" pattern class that creates object instances of the PluginType
 | IModel | Models the state of a Container or ObjectFactory. Can be used to query for the existence of types registered with StructureMap
 | InitializationExpression |
 | InstanceBuilder | Base class for creating an object instance from an InstanceMemento. SubClasses are emitted for each concrete Plugin with constructor parameters.
 | InstanceBuilderList |
 | InstanceFactory | Default implementation of IInstanceFactory
 | InstanceFamily |
 | InstanceMemento | GoF Memento representing an Object Instance
 | MementoSource | Abstract class that is the supertype of all storage and retrieval mechanisms of InstanceMemento instances
 | MemoryInstanceMemento | An in-memory implementation of InstanceMemento.
 | MissingFactoryFunction |
 | Model |
 | Notify |
 | ObjectFactory | The main static Facade for the StructureMap container
 | PipelineGraph |
 | PluggableAttribute | Used to implicitly mark a class as a Plugin candidate for StructureMap
 | PluginFamilyAttribute | Declares a class, abstract class, or interface to be the target of a PluginFamily in the container
 | PluginGraphBuilder | Reads configuration XML documents and builds the structures necessary to initialize the Container/IInstanceFactory/InstanceBuilder/ObjectInstanceActivator objects
 | PluginTypeConfiguration | Metadata describing the registration of a PluginType
 | StructureMapConfiguration | Obsolete.
 | StructureMapException | Main exception for StructureMap. Use the ErrorCode to aid in troubleshooting StructureMap problems
 | ValidationMethodAttribute | Marks a method with no parameters as a method that validates an instance. StructureMap uses this method to validate the configuration file. If the method does not throw an exception, the object is assumed to be valid.

Send comments on this topic to jeremydmiller@yahoo.com


BuildSession Class

BuildSession Class
Namespaces ► StructureMap ► BuildSession
StructureMap API

[Missing <summary> documentation for T:StructureMap.BuildSession]

Declaration Syntax
C# Visual Basic Visual C++
public class BuildSession : IContext
Public Class BuildSession _
    Implements IContext
public ref class BuildSession : IContext
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuildSession(PipelineGraph, InterceptorLibrary) | Initializes a new instance of the BuildSession class
 | BuildSession(PluginGraph) | Initializes a new instance of the BuildSession class
 | BuildSession()()() | Initializes a new instance of the BuildSession class
 | ApplyInterception(Type, Object) |
 | BuildStack |
 | CreateInstance(Type, String) |
 | CreateInstance(Type, Instance) |
 | CreateInstance(Type) |
 | CreateInstanceArray(Type, array<Instance>[]()[]) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentType |
 | pipelineGraph |
 | RegisterDefault(Type, Object) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | BuildSession
 |  | ValidationBuildSession

Send comments on this topic to jeremydmiller@yahoo.com

Assembly: StructureMap (Module: StructureMap) Version: 2.5.0.0


BuildSession Constructor

BuildSession Constructor
Namespaces ► StructureMap ► BuildSession ► BuildSession()()()
StructureMap API
Members
Icon | Member | Description
 | BuildSession(PipelineGraph, InterceptorLibrary) | Initializes a new instance of the BuildSession class
 | BuildSession(PluginGraph) | Initializes a new instance of the BuildSession class
 | BuildSession()()() | Initializes a new instance of the BuildSession class


BuildSession Constructor

BuildSession Constructor
Namespaces ► StructureMap ► BuildSession ► BuildSession()()()
StructureMap API
Initializes a new instance of the BuildSession class
Declaration Syntax
C# Visual Basic Visual C++
public BuildSession()
Public Sub New
public:
BuildSession()


BuildSession Constructor (graph)

BuildSession Constructor (graph)
Namespaces ► StructureMap ► BuildSession ► BuildSession(PluginGraph)
StructureMap API
Initializes a new instance of the BuildSession class
Declaration Syntax
C# Visual Basic Visual C++
public BuildSession(
    PluginGraph graph
)
Public Sub New ( _
    graph As PluginGraph _
)
public:
BuildSession(
    PluginGraph^ graph
)
Parameters
graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.BuildSession.#ctor(StructureMap.Graph.PluginGraph)"]


BuildSession Constructor (pipelineGraph, interceptorLibrary)

BuildSession Constructor (pipelineGraph, interceptorLibrary)
Namespaces ► StructureMap ► BuildSession ► BuildSession(PipelineGraph, InterceptorLibrary)
StructureMap API
Initializes a new instance of the BuildSession class
Declaration Syntax
C# Visual Basic Visual C++
public BuildSession(
    PipelineGraph pipelineGraph,
    InterceptorLibrary interceptorLibrary
)
Public Sub New ( _
    pipelineGraph As PipelineGraph, _
    interceptorLibrary As InterceptorLibrary _
)
public:
BuildSession(
    PipelineGraph^ pipelineGraph,
    InterceptorLibrary^ interceptorLibrary
)
Parameters
pipelineGraph (PipelineGraph)

[Missing <param name="pipelineGraph"/> documentation for "M:StructureMap.BuildSession.#ctor(StructureMap.PipelineGraph,StructureMap.Interceptors.InterceptorLibrary)"]

interceptorLibrary (InterceptorLibrary)

[Missing <param name="interceptorLibrary"/> documentation for "M:StructureMap.BuildSession.#ctor(StructureMap.PipelineGraph,StructureMap.Interceptors.InterceptorLibrary)"]


ApplyInterception Method (pluginType, actualValue)

ApplyInterception Method (pluginType, actualValue)
Namespaces ► StructureMap ► BuildSession ► ApplyInterception(Type, Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.BuildSession.ApplyInterception(System.Type,System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public virtual Object ApplyInterception(
    Type pluginType,
    Object actualValue
)
Public Overridable Function ApplyInterception ( _
    pluginType As Type, _
    actualValue As Object _
) As Object
public:
virtual Object^ ApplyInterception(
    Type^ pluginType,
    Object^ actualValue
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.BuildSession.ApplyInterception(System.Type,System.Object)"]

actualValue (Object)

[Missing <param name="actualValue"/> documentation for "M:StructureMap.BuildSession.ApplyInterception(System.Type,System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.BuildSession.ApplyInterception(System.Type,System.Object)]


BuildStack Property

BuildStack Property
Namespaces ► StructureMap ► BuildSession ► BuildStack
StructureMap API

[Missing <summary> documentation for P:StructureMap.BuildSession.BuildStack]

Declaration Syntax
C# Visual Basic Visual C++
public BuildStack BuildStack { get; }
Public ReadOnly Property BuildStack As BuildStack
public:
virtual property BuildStack^ BuildStack {
    BuildStack^ get () sealed;
}


CreateInstance Method

CreateInstance Method
Namespaces ► StructureMap ► BuildSession ► CreateInstance()()()
StructureMap API
Members
Icon | Member | Description
 | CreateInstance(Type, String) |
 | CreateInstance(Type, Instance) |
 | CreateInstance(Type) |


CreateInstance Method (pluginType)

CreateInstance Method (pluginType)
Namespaces ► StructureMap ► BuildSession ► CreateInstance(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.BuildSession.CreateInstance(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public virtual Object CreateInstance(
    Type pluginType
)
Public Overridable Function CreateInstance ( _
    pluginType As Type _
) As Object
public:
virtual Object^ CreateInstance(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.BuildSession.CreateInstance(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.BuildSession.CreateInstance(System.Type)]


CreateInstance Method (pluginType, instance)

CreateInstance Method (pluginType, instance)
Namespaces ► StructureMap ► BuildSession ► CreateInstance(Type, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.BuildSession.CreateInstance(System.Type,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public virtual Object CreateInstance(
    Type pluginType,
    Instance instance
)
Public Overridable Function CreateInstance ( _
    pluginType As Type, _
    instance As Instance _
) As Object
public:
virtual Object^ CreateInstance(
    Type^ pluginType,
    Instance^ instance
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.BuildSession.CreateInstance(System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.BuildSession.CreateInstance(System.Type,StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.BuildSession.CreateInstance(System.Type,StructureMap.Pipeline.Instance)]


CreateInstance Method (pluginType, name)

CreateInstance Method (pluginType, name)
Namespaces ► StructureMap ► BuildSession ► CreateInstance(Type, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.BuildSession.CreateInstance(System.Type,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public virtual Object CreateInstance(
    Type pluginType,
    string name
)
Public Overridable Function CreateInstance ( _
    pluginType As Type, _
    name As String _
) As Object
public:
virtual Object^ CreateInstance(
    Type^ pluginType,
    String^ name
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.BuildSession.CreateInstance(System.Type,System.String)"]

name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.BuildSession.CreateInstance(System.Type,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.BuildSession.CreateInstance(System.Type,System.String)]


CreateInstanceArray Method (pluginType, instances)

CreateInstanceArray Method (pluginType, instances)
Namespaces ► StructureMap ► BuildSession ► CreateInstanceArray(Type, array<Instance>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.BuildSession.CreateInstanceArray(System.Type,StructureMap.Pipeline.Instance[])]

Declaration Syntax
C# Visual Basic Visual C++
public virtual Array CreateInstanceArray(
    Type pluginType,
    Instance[] instances
)
Public Overridable Function CreateInstanceArray ( _
    pluginType As Type, _
    instances As Instance() _
) As Array
public:
virtual Array^ CreateInstanceArray(
    Type^ pluginType,
    array<Instance^>^ instances
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.BuildSession.CreateInstanceArray(System.Type,StructureMap.Pipeline.Instance[])"]

instances (array< Instance >[]()[])

[Missing <param name="instances"/> documentation for "M:StructureMap.BuildSession.CreateInstanceArray(System.Type,StructureMap.Pipeline.Instance[])"]

Return Value

[Missing <returns> documentation for M:StructureMap.BuildSession.CreateInstanceArray(System.Type,StructureMap.Pipeline.Instance[])]


ParentType Property

ParentType Property
Namespaces ► StructureMap ► BuildSession ► ParentType
StructureMap API

[Missing <summary> documentation for P:StructureMap.BuildSession.ParentType]

Declaration Syntax
C# Visual Basic Visual C++
public Type ParentType { get; }
Public ReadOnly Property ParentType As Type
public:
virtual property Type^ ParentType {
    Type^ get () sealed;
}


pipelineGraph Property

pipelineGraph Property
Namespaces ► StructureMap ► BuildSession ► pipelineGraph
StructureMap API

[Missing <summary> documentation for P:StructureMap.BuildSession.pipelineGraph]

Declaration Syntax
C# Visual Basic Visual C++
protected PipelineGraph pipelineGraph { get; }
Protected ReadOnly Property pipelineGraph As PipelineGraph
protected:
property PipelineGraph^ pipelineGraph {
    PipelineGraph^ get ();
}


RegisterDefault Method (pluginType, defaultObject)

RegisterDefault Method (pluginType, defaultObject)
Namespaces ► StructureMap ► BuildSession ► RegisterDefault(Type, Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.BuildSession.RegisterDefault(System.Type,System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public virtual void RegisterDefault(
    Type pluginType,
    Object defaultObject
)
Public Overridable Sub RegisterDefault ( _
    pluginType As Type, _
    defaultObject As Object _
)
public:
virtual void RegisterDefault(
    Type^ pluginType,
    Object^ defaultObject
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.BuildSession.RegisterDefault(System.Type,System.Object)"]

defaultObject (Object)

[Missing <param name="defaultObject"/> documentation for "M:StructureMap.BuildSession.RegisterDefault(System.Type,System.Object)"]


ConfigurationExpression Class

ConfigurationExpression Class
Namespaces ► StructureMap ► ConfigurationExpression
StructureMap API
Used as the argument in the Container.Configure() method to describe configuration directives and specify the sources of configuration for a Container
Declaration Syntax
C# Visual Basic Visual C++
public class ConfigurationExpression : Registry
Public Class ConfigurationExpression _
    Inherits Registry
public ref class ConfigurationExpression : public Registry
Members
All Members | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | _log |
 | _parserBuilder |
 | AddConfigurationFromNode(XmlNode) | Imports configuration directly from an XmlNode. This method was intended for scenarios like Xml being embedded into an assembly. The node must be a 'StructureMap' node
 | AddConfigurationFromXmlFile(String) | Imports configuration from an Xml file. The fileName must point to an Xml file with valid StructureMap configuration
 | AddRegistry<(Of <(T>)>)()()() | Creates and adds a Registry object of type T.
 | AddRegistry(Registry) | Imports all the configuration from a Registry object
 | Build()()() | Uses the configuration expressions of this Registry to create a PluginGraph object that could be used to initialize a Container. This method is mostly for internal usage, but might be helpful for diagnostics (Inherited from Registry.)
 | BuildInstancesOf<(Of <(PLUGINTYPE>)>)()()() | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms (Inherited from Registry.)
 | configure()()() | You can overide this method as a place to put the Registry DSL declarations. This is not mandatory. (Inherited from Registry.)
 | CreateProfile(String) | Expression Builder to define the defaults for a named Profile. Each call to CreateProfile is additive. (Inherited from Registry.)
 | CreateProfile(String, Action<(Of <(ProfileExpression>)>)) | An alternative way to use CreateProfile that uses ProfileExpression as a Nested Closure. This usage will result in cleaner code for multiple declarations (Inherited from Registry.)
 | Equals(Registry) | (Inherited from Registry.)
 | Equals(Object) | (Inherited from Registry.)
 | FillAllPropertiesOfType<(Of <(PLUGINTYPE>)>)()()() | Directs StructureMap to always inject dependencies into any and all public Setter properties of the type PLUGINTYPE. (Inherited from Registry.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | ForConcreteType<(Of <(T>)>)()()() | This method is a shortcut for specifying the default constructor and setter arguments for a ConcreteType. ForConcreteType is shorthand for: ForRequestedType[T]().TheDefault.Is.OfConcreteType[T].************** when the PluginType and ConcreteType are the same Type (Inherited from Registry.)
 | ForRequestedType(Type) | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. This method is specifically meant for registering open generic types (Inherited from Registry.)
 | ForRequestedType<(Of <(PLUGINTYPE>)>)()()() | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms (Inherited from Registry.)
 | GetHashCode()()() | (Inherited from Registry.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IfTypeMatches(Predicate<(Of <(Type>)>)) | Allows you to define a TypeInterceptor inline with Lambdas or anonymous delegates (Inherited from Registry.)
 | IncludeConfigurationFromConfigFile | If true, directs StructureMap to look for configuration in the App.config. The default value is false.
 | InstanceOf<(Of <(T>)>)()()() | Adds an additional, non-Default Instance to the PluginType T. (Inherited from Registry.)
 | InstanceOf(Type) | Adds an additional, non-Default Instance to the designated pluginType This method is mostly meant for open generic types (Inherited from Registry.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | registerAction(Action) | (Inherited from Registry.)
 | RegisterInterceptor(TypeInterceptor) | Registers a new TypeInterceptor object with the Container (Inherited from Registry.)
 | Scan(Action<(Of <(IAssemblyScanner>)>)) | Designates a policy for scanning assemblies to auto register types (Inherited from Registry.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Registry
 |  | ConfigurationExpression
 |  |  | InitializationExpression


_log Field

_log Field
Namespaces ► StructureMap ► ConfigurationExpression ► _log
StructureMap API

[Missing <summary> documentation for F:StructureMap.ConfigurationExpression._log]

Declaration Syntax
C# Visual Basic Visual C++
protected readonly GraphLog _log
Protected ReadOnly _log As GraphLog
protected:
initonly GraphLog^ _log


_parserBuilder Field

_parserBuilder Field
Namespaces ► StructureMap ► ConfigurationExpression ► _parserBuilder
StructureMap API

[Missing <summary> documentation for F:StructureMap.ConfigurationExpression._parserBuilder]

Declaration Syntax
C# Visual Basic Visual C++
protected readonly ConfigurationParserBuilder _parserBuilder
Protected ReadOnly _parserBuilder As ConfigurationParserBuilder
protected:
initonly ConfigurationParserBuilder^ _parserBuilder


AddConfigurationFromNode Method (node)

AddConfigurationFromNode Method (node)
Namespaces ► StructureMap ► ConfigurationExpression ► AddConfigurationFromNode(XmlNode)
StructureMap API
Imports configuration directly from an XmlNode. This method was intended for scenarios like Xml being embedded into an assembly. The node must be a 'StructureMap' node
Declaration Syntax
C# Visual Basic Visual C++
public void AddConfigurationFromNode(
    XmlNode node
)
Public Sub AddConfigurationFromNode ( _
    node As XmlNode _
)
public:
virtual void AddConfigurationFromNode(
    XmlNode^ node
) sealed
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.ConfigurationExpression.AddConfigurationFromNode(System.Xml.XmlNode)"]


AddConfigurationFromXmlFile Method (fileName)

AddConfigurationFromXmlFile Method (fileName)
Namespaces ► StructureMap ► ConfigurationExpression ► AddConfigurationFromXmlFile(String)
StructureMap API
Imports configuration from an Xml file. The fileName must point to an Xml file with valid StructureMap configuration
Declaration Syntax
C# Visual Basic Visual C++
public void AddConfigurationFromXmlFile(
    string fileName
)
Public Sub AddConfigurationFromXmlFile ( _
    fileName As String _
)
public:
virtual void AddConfigurationFromXmlFile(
    String^ fileName
) sealed
Parameters
fileName (String)

[Missing <param name="fileName"/> documentation for "M:StructureMap.ConfigurationExpression.AddConfigurationFromXmlFile(System.String)"]


AddRegistry Method

AddRegistry Method
Namespaces ► StructureMap ► ConfigurationExpression ► AddRegistry()()()
StructureMap API
Members
Icon | Member | Description
 | AddRegistry<(Of <(T>)>)()()() | Creates and adds a Registry object of type T.
 | AddRegistry(Registry) | Imports all the configuration from a Registry object


AddRegistry Method

AddRegistry<(Of <(T>)>) Method
Namespaces ► StructureMap ► ConfigurationExpression ► AddRegistry<(Of <(T>)>)()()()
StructureMap API
Creates and adds a Registry object of type T.
Declaration Syntax
C# Visual Basic Visual C++
public void AddRegistry<T>()
where T : new(), Registry

Public Sub AddRegistry(Of T As {New, Registry})
public:
generic<typename T>
where T : gcnew(), Registry
virtual void AddRegistry() sealed
Generic Template Parameters
T
The Registry Type


AddRegistry Method (registry)

AddRegistry Method (registry)
Namespaces ► StructureMap ► ConfigurationExpression ► AddRegistry(Registry)
StructureMap API
Imports all the configuration from a Registry object
Declaration Syntax
C# Visual Basic Visual C++
public void AddRegistry(
    Registry registry
)
Public Sub AddRegistry ( _
    registry As Registry _
)
public:
virtual void AddRegistry(
    Registry^ registry
) sealed
Parameters
registry (Registry)

[Missing <param name="registry"/> documentation for "M:StructureMap.ConfigurationExpression.AddRegistry(StructureMap.Configuration.DSL.Registry)"]


IncludeConfigurationFromConfigFile Property

IncludeConfigurationFromConfigFile Property
Namespaces ► StructureMap ► ConfigurationExpression ► IncludeConfigurationFromConfigFile
StructureMap API
If true, directs StructureMap to look for configuration in the App.config. The default value is false.
Declaration Syntax
C# Visual Basic Visual C++
public bool IncludeConfigurationFromConfigFile { set; }
Public WriteOnly Property IncludeConfigurationFromConfigFile As Boolean
public:
property bool IncludeConfigurationFromConfigFile {
    void set (bool value);
}


Container Class

Container Class
Namespaces ► StructureMap ► Container
StructureMap API

[Missing <summary> documentation for T:StructureMap.Container]

Declaration Syntax
C# Visual Basic Visual C++
public class Container : TypeRules, IContainer
Public Class Container _
    Inherits TypeRules _
    Implements IContainer
public ref class Container : public TypeRules,
    IContainer
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Container(Action<(Of <(ConfigurationExpression>)>)) | Initializes a new instance of the Container class
 | Container(Registry) | Initializes a new instance of the Container class
 | Container()()() | Initializes a new instance of the Container class
 | Container(PluginGraph) | Constructor to create an Container
 | AssertConfigurationIsValid()()() | Use with caution! Does a full environment test of the configuration of this container. Will try to create every configured instance and afterward calls any methods marked with the [ValidationMethod] attribute
 | Configure(Action<(Of <(ConfigurationExpression>)>)) | Used to add additional configuration to a Container *after* the initialization.
 | EjectAllInstancesOf<(Of <(T>)>)()()() | Removes all configured instances of type T from the Container. Use with caution!
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FillDependencies<(Of <(T>)>)()()() | Obsolete.
 | FillDependencies(Type) | Obsolete.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | forType(Type) |
 | GetAllInstances(Type, ExplicitArguments) | Gets all configured instances of type T using explicitly configured arguments from the "args"
 | GetAllInstances<(Of <(T>)>)(ExplicitArguments) |
 | GetAllInstances<(Of <(T>)>)()()() | Creates or resolves all registered instances of type T
 | GetAllInstances(Type) | Creates or resolves all registered instances of the pluginType
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance<(Of <(T>)>)(String) | Creates or finds the named instance of T
 | GetInstance<(Of <(T>)>)(Instance) | Creates a new instance of the requested type T using the supplied Instance. Mostly used internally
 | GetInstance<(Of <(PLUGINTYPE>)>)(ExplicitArguments) | Gets the default instance of the pluginType using the explicitly configured arguments from the "args"
 | GetInstance(Type, ExplicitArguments) | Gets the default instance of the pluginType using the explicitly configured arguments from the "args"
 | GetInstance<(Of <(T>)>)()()() | Creates or finds the default instance of type T
 | GetInstance(Type, String) | Creates or finds the named instance of the pluginType
 | GetInstance(Type) | Creates or finds the default instance of the pluginType
 | GetInstance(Type, Instance) | Creates a new instance of the requested type using the supplied Instance. Mostly used internally
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Inject<(Of <(PLUGINTYPE>)>)(PLUGINTYPE) | Injects the given object into a Container as the default for the designated PLUGINTYPE. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | Inject<(Of <(T>)>)(String, T) | Injects the given object into a Container by name for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | Inject(Type, Object) | Injects the given object into a Container as the default for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | Inject(Type, Instance) | Sets the default instance for the PluginType
 | IsAutoFillable(Type) | (Inherited from TypeRules.)
 | IsChild(Type) | (Inherited from TypeRules.)
 | IsChildArray(Type) | (Inherited from TypeRules.)
 | IsConcrete(Type) | (Inherited from TypeRules.)
 | IsEnum(Type) | (Inherited from TypeRules.)
 | IsPrimitive(Type) | (Inherited from TypeRules.)
 | IsPrimitiveArray(Type) | (Inherited from TypeRules.)
 | IsSimple(Type) | (Inherited from TypeRules.)
 | IsString(Type) | (Inherited from TypeRules.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Model | Provides queryable access to the configured PluginType's and Instances of this Container
 | onMissingFactory |
 | PluginGraph |
 | SetDefault(Type, Instance) |
 | SetDefaultsToProfile(String) | Sets the default instance for all PluginType's to the designated Profile.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TryGetInstance(Type, String) | Creates or finds the named instance of the pluginType. Returns null if the named instance is not known to the container.
 | TryGetInstance(Type) | Creates or finds the default instance of the pluginType. Returns null if the pluginType is not known to the container.
 | TryGetInstance<(Of <(T>)>)()()() | Creates or finds the default instance of type T. Returns the default value of T if it is not known to the container.
 | TryGetInstance<(Of <(T>)>)(String) | Creates or finds the named instance of type T. Returns the default value of T if the named instance is not known to the container.
 | WhatDoIHave()()() | Returns a report detailing the complete configuration of all PluginTypes and Instances
 | With<(Of <(T>)>)(T) | Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency of type T should be "arg"
 | With(String) | Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency or primitive argument with the designated name should be the next value.
Inheritance Hierarchy
Object
 | TypeRules
 |  | Container


Container Constructor

Container Constructor
Namespaces ► StructureMap ► Container ► Container()()()
StructureMap API
Members
Icon | Member | Description
 | Container(Action<(Of <(ConfigurationExpression>)>)) | Initializes a new instance of the Container class
 | Container(Registry) | Initializes a new instance of the Container class
 | Container()()() | Initializes a new instance of the Container class
 | Container(PluginGraph) | Constructor to create an Container


Container Constructor

Container Constructor
Namespaces ► StructureMap ► Container ► Container()()()
StructureMap API
Initializes a new instance of the Container class
Declaration Syntax
C# Visual Basic Visual C++
public Container()
Public Sub New
public:
Container()


Container Constructor (registry)

Container Constructor (registry)
Namespaces ► StructureMap ► Container ► Container(Registry)
StructureMap API
Initializes a new instance of the Container class
Declaration Syntax
C# Visual Basic Visual C++
public Container(
    Registry registry
)
Public Sub New ( _
    registry As Registry _
)
public:
Container(
    Registry^ registry
)
Parameters
registry (Registry)

[Missing <param name="registry"/> documentation for "M:StructureMap.Container.#ctor(StructureMap.Configuration.DSL.Registry)"]


Container Constructor (pluginGraph)

Container Constructor (pluginGraph)
Namespaces ► StructureMap ► Container ► Container(PluginGraph)
StructureMap API
Constructor to create an Container
Declaration Syntax
C# Visual Basic Visual C++
public Container(
    PluginGraph pluginGraph
)
Public Sub New ( _
    pluginGraph As PluginGraph _
)
public:
Container(
    PluginGraph^ pluginGraph
)
Parameters
pluginGraph (PluginGraph)
PluginGraph containing the instance and type definitions for the Container


Container Constructor (action)

Container Constructor (action)
Namespaces ► StructureMap ► Container ► Container(Action<(Of <(ConfigurationExpression>)>))
StructureMap API
Initializes a new instance of the Container class
Declaration Syntax
C# Visual Basic Visual C++
public Container(
    Action<ConfigurationExpression> action
)
Public Sub New ( _
    action As Action(Of ConfigurationExpression) _
)
public:
Container(
    Action<ConfigurationExpression^>^ action
)
Parameters
action (Action <(Of <( ConfigurationExpression >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Container.#ctor(System.Action{StructureMap.ConfigurationExpression})"]


AssertConfigurationIsValid Method

AssertConfigurationIsValid Method
Namespaces ► StructureMap ► Container ► AssertConfigurationIsValid()()()
StructureMap API
Use with caution! Does a full environment test of the configuration of this container. Will try to create every configured instance and afterward calls any methods marked with the [ValidationMethod] attribute
Declaration Syntax
C# Visual Basic Visual C++
public void AssertConfigurationIsValid()
Public Sub AssertConfigurationIsValid
public:
virtual void AssertConfigurationIsValid() sealed


Configure Method (configure)

Configure Method (configure)
Namespaces ► StructureMap ► Container ► Configure(Action<(Of <(ConfigurationExpression>)>))
StructureMap API
Used to add additional configuration to a Container *after* the initialization.
Declaration Syntax
C# Visual Basic Visual C++
public void Configure(
    Action<ConfigurationExpression> configure
)
Public Sub Configure ( _
    configure As Action(Of ConfigurationExpression) _
)
public:
virtual void Configure(
    Action<ConfigurationExpression^>^ configure
) sealed
Parameters
configure (Action <(Of <( ConfigurationExpression >)>))

[Missing <param name="configure"/> documentation for "M:StructureMap.Container.Configure(System.Action{StructureMap.ConfigurationExpression})"]


EjectAllInstancesOf Method

EjectAllInstancesOf<(Of <(T>)>) Method
Namespaces ► StructureMap ► Container ► EjectAllInstancesOf<(Of <(T>)>)()()()
StructureMap API
Removes all configured instances of type T from the Container. Use with caution!
Declaration Syntax
C# Visual Basic Visual C++
public void EjectAllInstancesOf<T>()

Public Sub EjectAllInstancesOf(Of T)
public:
generic<typename T>
virtual void EjectAllInstancesOf() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Container.EjectAllInstancesOf``1"]


FillDependencies Method

FillDependencies Method
Namespaces ► StructureMap ► Container ► FillDependencies()()()
StructureMap API
Members
Icon | Member | Description
 | FillDependencies<(Of <(T>)>)()()() | Obsolete.
 | FillDependencies(Type) | Obsolete.


FillDependencies Method

FillDependencies<(Of <(T>)>) Method
Namespaces ► StructureMap ► Container ► FillDependencies<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Container.FillDependencies``1]

Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Please use GetInstance<T>() instead.")]
public T FillDependencies<T>()

<ObsoleteAttribute("Please use GetInstance<T>() instead.")> _
Public Function FillDependencies(Of T) As T
[ObsoleteAttribute(L"Please use GetInstance<T>() instead.")]
public:
generic<typename T>
virtual T FillDependencies() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Container.FillDependencies``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.FillDependencies``1]


FillDependencies Method (type)

FillDependencies Method (type)
Namespaces ► StructureMap ► Container ► FillDependencies(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Container.FillDependencies(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Please use GetInstance(Type) instead")]
public Object FillDependencies(
    Type type
)
<ObsoleteAttribute("Please use GetInstance(Type) instead")> _
Public Function FillDependencies ( _
    type As Type _
) As Object
[ObsoleteAttribute(L"Please use GetInstance(Type) instead")]
public:
virtual Object^ FillDependencies(
    Type^ type
) sealed
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Container.FillDependencies(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.FillDependencies(System.Type)]


forType Method (type)

forType Method (type)
Namespaces ► StructureMap ► Container ► forType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Container.forType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected IInstanceFactory forType(
    Type type
)
Protected Function forType ( _
    type As Type _
) As IInstanceFactory
protected:
IInstanceFactory^ forType(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Container.forType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.forType(System.Type)]


GetAllInstances Method

GetAllInstances Method
Namespaces ► StructureMap ► Container ► GetAllInstances()()()
StructureMap API
Members
Icon | Member | Description
 | GetAllInstances(Type, ExplicitArguments) | Gets all configured instances of type T using explicitly configured arguments from the "args"
 | GetAllInstances<(Of <(T>)>)(ExplicitArguments) |
 | GetAllInstances<(Of <(T>)>)()()() | Creates or resolves all registered instances of type T
 | GetAllInstances(Type) | Creates or resolves all registered instances of the pluginType


GetAllInstances Method

GetAllInstances<(Of <(T>)>) Method
Namespaces ► StructureMap ► Container ► GetAllInstances<(Of <(T>)>)()()()
StructureMap API
Creates or resolves all registered instances of type T
Declaration Syntax
C# Visual Basic Visual C++
public IList<T> GetAllInstances<T>()

Public Function GetAllInstances(Of T) As IList(Of T)
public:
generic<typename T>
virtual IList<T>^ GetAllInstances() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Container.GetAllInstances``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.GetAllInstances``1]


GetAllInstances Method (args)

GetAllInstances<(Of <(T>)>) Method (args)
Namespaces ► StructureMap ► Container ► GetAllInstances<(Of <(T>)>)(ExplicitArguments)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Container.GetAllInstances``1(StructureMap.Pipeline.ExplicitArguments)]

Declaration Syntax
C# Visual Basic Visual C++
public IList<T> GetAllInstances<T>(
    ExplicitArguments args
)

Public Function GetAllInstances(Of T) ( _
    args As ExplicitArguments _
) As IList(Of T)
public:
generic<typename T>
virtual IList<T>^ GetAllInstances(
    ExplicitArguments^ args
) sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Container.GetAllInstances``1(StructureMap.Pipeline.ExplicitArguments)"]

Parameters
args (ExplicitArguments)

[Missing <param name="args"/> documentation for "M:StructureMap.Container.GetAllInstances``1(StructureMap.Pipeline.ExplicitArguments)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.GetAllInstances``1(StructureMap.Pipeline.ExplicitArguments)]


GetAllInstances Method (pluginType)

GetAllInstances Method (pluginType)
Namespaces ► StructureMap ► Container ► GetAllInstances(Type)
StructureMap API
Creates or resolves all registered instances of the pluginType
Declaration Syntax
C# Visual Basic Visual C++
public IList GetAllInstances(
    Type pluginType
)
Public Function GetAllInstances ( _
    pluginType As Type _
) As IList
public:
virtual IList^ GetAllInstances(
    Type^ pluginType
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Container.GetAllInstances(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.GetAllInstances(System.Type)]


GetAllInstances Method (type, args)

GetAllInstances Method (type, args)
Namespaces ► StructureMap ► Container ► GetAllInstances(Type, ExplicitArguments)
StructureMap API
Gets all configured instances of type T using explicitly configured arguments from the "args"
Declaration Syntax
C# Visual Basic Visual C++
public IList GetAllInstances(
    Type type,
    ExplicitArguments args
)
Public Function GetAllInstances ( _
    type As Type, _
    args As ExplicitArguments _
) As IList
public:
virtual IList^ GetAllInstances(
    Type^ type,
    ExplicitArguments^ args
) sealed
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Container.GetAllInstances(System.Type,StructureMap.Pipeline.ExplicitArguments)"]

args (ExplicitArguments)

[Missing <param name="args"/> documentation for "M:StructureMap.Container.GetAllInstances(System.Type,StructureMap.Pipeline.ExplicitArguments)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.GetAllInstances(System.Type,StructureMap.Pipeline.ExplicitArguments)]


GetInstance Method

GetInstance Method
Namespaces ► StructureMap ► Container ► GetInstance()()()
StructureMap API
Members
Icon | Member | Description
 | GetInstance<(Of <(T>)>)(String) | Creates or finds the named instance of T
 | GetInstance<(Of <(T>)>)(Instance) | Creates a new instance of the requested type T using the supplied Instance. Mostly used internally
 | GetInstance<(Of <(PLUGINTYPE>)>)(ExplicitArguments) | Gets the default instance of the pluginType using the explicitly configured arguments from the "args"
 | GetInstance(Type, ExplicitArguments) | Gets the default instance of the pluginType using the explicitly configured arguments from the "args"
 | GetInstance<(Of <(T>)>)()()() | Creates or finds the default instance of type T
 | GetInstance(Type, String) | Creates or finds the named instance of the pluginType
 | GetInstance(Type) | Creates or finds the default instance of the pluginType
 | GetInstance(Type, Instance) | Creates a new instance of the requested type using the supplied Instance. Mostly used internally


GetInstance Method

GetInstance<(Of <(T>)>) Method
Namespaces ► StructureMap ► Container ► GetInstance<(Of <(T>)>)()()()
StructureMap API
Creates or finds the default instance of type T
Declaration Syntax
C# Visual Basic Visual C++
public T GetInstance<T>()

Public Function GetInstance(Of T) As T
public:
generic<typename T>
virtual T GetInstance() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Container.GetInstance``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.GetInstance``1]


GetInstance Method (args)

GetInstance<(Of <(PLUGINTYPE>)>) Method (args)
Namespaces ► StructureMap ► Container ► GetInstance<(Of <(PLUGINTYPE>)>)(ExplicitArguments)
StructureMap API
Gets the default instance of the pluginType using the explicitly configured arguments from the "args"
Declaration Syntax
C# Visual Basic Visual C++
public PLUGINTYPE GetInstance<PLUGINTYPE>(
    ExplicitArguments args
)

Public Function GetInstance(Of PLUGINTYPE) ( _
    args As ExplicitArguments _
) As PLUGINTYPE
public:
generic<typename PLUGINTYPE>
virtual PLUGINTYPE GetInstance(
    ExplicitArguments^ args
) sealed
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.Container.GetInstance``1(StructureMap.Pipeline.ExplicitArguments)"]

Parameters
args (ExplicitArguments)

[Missing <param name="args"/> documentation for "M:StructureMap.Container.GetInstance``1(StructureMap.Pipeline.ExplicitArguments)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.GetInstance``1(StructureMap.Pipeline.ExplicitArguments)]


GetInstance Method (instance)

GetInstance<(Of <(T>)>) Method (instance)
Namespaces ► StructureMap ► Container ► GetInstance<(Of <(T>)>)(Instance)
StructureMap API
Creates a new instance of the requested type T using the supplied Instance. Mostly used internally
Declaration Syntax
C# Visual Basic Visual C++
public T GetInstance<T>(
    Instance instance
)

Public Function GetInstance(Of T) ( _
    instance As Instance _
) As T
public:
generic<typename T>
virtual T GetInstance(
    Instance^ instance
) sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Container.GetInstance``1(StructureMap.Pipeline.Instance)"]

Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Container.GetInstance``1(StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.GetInstance``1(StructureMap.Pipeline.Instance)]


GetInstance Method (instanceKey)

GetInstance<(Of <(T>)>) Method (instanceKey)
Namespaces ► StructureMap ► Container ► GetInstance<(Of <(T>)>)(String)
StructureMap API
Creates or finds the named instance of T
Declaration Syntax
C# Visual Basic Visual C++
public T GetInstance<T>(
    string instanceKey
)

Public Function GetInstance(Of T) ( _
    instanceKey As String _
) As T
public:
generic<typename T>
virtual T GetInstance(
    String^ instanceKey
) sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Container.GetInstance``1(System.String)"]

Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Container.GetInstance``1(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.GetInstance``1(System.String)]


GetInstance Method (pluginType)

GetInstance Method (pluginType)
Namespaces ► StructureMap ► Container ► GetInstance(Type)
StructureMap API
Creates or finds the default instance of the pluginType
Declaration Syntax
C# Visual Basic Visual C++
public Object GetInstance(
    Type pluginType
)
Public Function GetInstance ( _
    pluginType As Type _
) As Object
public:
virtual Object^ GetInstance(
    Type^ pluginType
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Container.GetInstance(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.GetInstance(System.Type)]


GetInstance Method (pluginType, args)

GetInstance Method (pluginType, args)
Namespaces ► StructureMap ► Container ► GetInstance(Type, ExplicitArguments)
StructureMap API
Gets the default instance of the pluginType using the explicitly configured arguments from the "args"
Declaration Syntax
C# Visual Basic Visual C++
public Object GetInstance(
    Type pluginType,
    ExplicitArguments args
)
Public Function GetInstance ( _
    pluginType As Type, _
    args As ExplicitArguments _
) As Object
public:
virtual Object^ GetInstance(
    Type^ pluginType,
    ExplicitArguments^ args
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Container.GetInstance(System.Type,StructureMap.Pipeline.ExplicitArguments)"]

args (ExplicitArguments)

[Missing <param name="args"/> documentation for "M:StructureMap.Container.GetInstance(System.Type,StructureMap.Pipeline.ExplicitArguments)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.GetInstance(System.Type,StructureMap.Pipeline.ExplicitArguments)]


GetInstance Method (pluginType, instance)

GetInstance Method (pluginType, instance)
Namespaces ► StructureMap ► Container ► GetInstance(Type, Instance)
StructureMap API
Creates a new instance of the requested type using the supplied Instance. Mostly used internally
Declaration Syntax
C# Visual Basic Visual C++
public Object GetInstance(
    Type pluginType,
    Instance instance
)
Public Function GetInstance ( _
    pluginType As Type, _
    instance As Instance _
) As Object
public:
virtual Object^ GetInstance(
    Type^ pluginType,
    Instance^ instance
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Container.GetInstance(System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Container.GetInstance(System.Type,StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.GetInstance(System.Type,StructureMap.Pipeline.Instance)]


GetInstance Method (pluginType, instanceKey)

GetInstance Method (pluginType, instanceKey)
Namespaces ► StructureMap ► Container ► GetInstance(Type, String)
StructureMap API
Creates or finds the named instance of the pluginType
Declaration Syntax
C# Visual Basic Visual C++
public Object GetInstance(
    Type pluginType,
    string instanceKey
)
Public Function GetInstance ( _
    pluginType As Type, _
    instanceKey As String _
) As Object
public:
virtual Object^ GetInstance(
    Type^ pluginType,
    String^ instanceKey
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Container.GetInstance(System.Type,System.String)"]

instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Container.GetInstance(System.Type,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.GetInstance(System.Type,System.String)]


Inject Method

Inject Method
Namespaces ► StructureMap ► Container ► Inject()()()
StructureMap API
Members
Icon | Member | Description
 | Inject<(Of <(PLUGINTYPE>)>)(PLUGINTYPE) | Injects the given object into a Container as the default for the designated PLUGINTYPE. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | Inject<(Of <(T>)>)(String, T) | Injects the given object into a Container by name for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | Inject(Type, Object) | Injects the given object into a Container as the default for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | Inject(Type, Instance) | Sets the default instance for the PluginType


Inject Method (name, stub)

Inject<(Of <(T>)>) Method (name, stub)
Namespaces ► StructureMap ► Container ► Inject<(Of <(T>)>)(String, T)
StructureMap API
Injects the given object into a Container by name for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
Declaration Syntax
C# Visual Basic Visual C++
public void Inject<T>(
    string name,
    T stub
)

Public Sub Inject(Of T) ( _
    name As String, _
    stub As T _
)
public:
generic<typename T>
virtual void Inject(
    String^ name,
    T stub
) sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Container.Inject``1(System.String,``0)"]

Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Container.Inject``1(System.String,``0)"]

stub (T)

[Missing <param name="stub"/> documentation for "M:StructureMap.Container.Inject``1(System.String,``0)"]


Inject Method (pluginType, instance)

Inject Method (pluginType, instance)
Namespaces ► StructureMap ► Container ► Inject(Type, Instance)
StructureMap API
Sets the default instance for the PluginType
Declaration Syntax
C# Visual Basic Visual C++
public void Inject(
    Type pluginType,
    Instance instance
)
Public Sub Inject ( _
    pluginType As Type, _
    instance As Instance _
)
public:
void Inject(
    Type^ pluginType,
    Instance^ instance
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Container.Inject(System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Container.Inject(System.Type,StructureMap.Pipeline.Instance)"]


Inject Method (pluginType, stub)

Inject Method (pluginType, stub)
Namespaces ► StructureMap ► Container ► Inject(Type, Object)
StructureMap API
Injects the given object into a Container as the default for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
Declaration Syntax
C# Visual Basic Visual C++
public void Inject(
    Type pluginType,
    Object stub
)
Public Sub Inject ( _
    pluginType As Type, _
    stub As Object _
)
public:
virtual void Inject(
    Type^ pluginType,
    Object^ stub
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Container.Inject(System.Type,System.Object)"]

stub (Object)

[Missing <param name="stub"/> documentation for "M:StructureMap.Container.Inject(System.Type,System.Object)"]


Inject Method (instance)

Inject<(Of <(PLUGINTYPE>)>) Method (instance)
Namespaces ► StructureMap ► Container ► Inject<(Of <(PLUGINTYPE>)>)(PLUGINTYPE)
StructureMap API
Injects the given object into a Container as the default for the designated PLUGINTYPE. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
Declaration Syntax
C# Visual Basic Visual C++
public void Inject<PLUGINTYPE>(
    PLUGINTYPE instance
)

Public Sub Inject(Of PLUGINTYPE) ( _
    instance As PLUGINTYPE _
)
public:
generic<typename PLUGINTYPE>
virtual void Inject(
    PLUGINTYPE instance
) sealed
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.Container.Inject``1(``0)"]

Parameters
instance (PLUGINTYPE)

[Missing <param name="instance"/> documentation for "M:StructureMap.Container.Inject``1(``0)"]


Model Property

Model Property
Namespaces ► StructureMap ► Container ► Model
StructureMap API
Provides queryable access to the configured PluginType's and Instances of this Container
Declaration Syntax
C# Visual Basic Visual C++
public IModel Model { get; }
Public ReadOnly Property Model As IModel
public:
virtual property IModel^ Model {
    IModel^ get () sealed;
}


onMissingFactory Property

onMissingFactory Property
Namespaces ► StructureMap ► Container ► onMissingFactory
StructureMap API

[Missing <summary> documentation for P:StructureMap.Container.onMissingFactory]

Declaration Syntax
C# Visual Basic Visual C++
protected MissingFactoryFunction onMissingFactory { set; }
Protected WriteOnly Property onMissingFactory As MissingFactoryFunction
protected:
property MissingFactoryFunction^ onMissingFactory {
    void set (MissingFactoryFunction^ value);
}


PluginGraph Property

PluginGraph Property
Namespaces ► StructureMap ► Container ► PluginGraph
StructureMap API

[Missing <summary> documentation for P:StructureMap.Container.PluginGraph]

Declaration Syntax
C# Visual Basic Visual C++
public PluginGraph PluginGraph { get; }
Public ReadOnly Property PluginGraph As PluginGraph
public:
property PluginGraph^ PluginGraph {
    PluginGraph^ get ();
}


SetDefault Method (pluginType, instance)

SetDefault Method (pluginType, instance)
Namespaces ► StructureMap ► Container ► SetDefault(Type, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Container.SetDefault(System.Type,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetDefault(
    Type pluginType,
    Instance instance
)
Public Sub SetDefault ( _
    pluginType As Type, _
    instance As Instance _
)
public:
void SetDefault(
    Type^ pluginType,
    Instance^ instance
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Container.SetDefault(System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Container.SetDefault(System.Type,StructureMap.Pipeline.Instance)"]


SetDefaultsToProfile Method (profile)

SetDefaultsToProfile Method (profile)
Namespaces ► StructureMap ► Container ► SetDefaultsToProfile(String)
StructureMap API
Sets the default instance for all PluginType's to the designated Profile.
Declaration Syntax
C# Visual Basic Visual C++
public void SetDefaultsToProfile(
    string profile
)
Public Sub SetDefaultsToProfile ( _
    profile As String _
)
public:
virtual void SetDefaultsToProfile(
    String^ profile
) sealed
Parameters
profile (String)

[Missing <param name="profile"/> documentation for "M:StructureMap.Container.SetDefaultsToProfile(System.String)"]


TryGetInstance Method

TryGetInstance Method
Namespaces ► StructureMap ► Container ► TryGetInstance()()()
StructureMap API
Members
Icon | Member | Description
 | TryGetInstance(Type, String) | Creates or finds the named instance of the pluginType. Returns null if the named instance is not known to the container.
 | TryGetInstance(Type) | Creates or finds the default instance of the pluginType. Returns null if the pluginType is not known to the container.
 | TryGetInstance<(Of <(T>)>)()()() | Creates or finds the default instance of type T. Returns the default value of T if it is not known to the container.
 | TryGetInstance<(Of <(T>)>)(String) | Creates or finds the named instance of type T. Returns the default value of T if the named instance is not known to the container.


TryGetInstance Method

TryGetInstance<(Of <(T>)>) Method
Namespaces ► StructureMap ► Container ► TryGetInstance<(Of <(T>)>)()()()
StructureMap API
Creates or finds the default instance of type T. Returns the default value of T if it is not known to the container.
Declaration Syntax
C# Visual Basic Visual C++
public T TryGetInstance<T>()

Public Function TryGetInstance(Of T) As T
public:
generic<typename T>
virtual T TryGetInstance() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Container.TryGetInstance``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.TryGetInstance``1]


TryGetInstance Method (instanceKey)

TryGetInstance<(Of <(T>)>) Method (instanceKey)
Namespaces ► StructureMap ► Container ► TryGetInstance<(Of <(T>)>)(String)
StructureMap API
Creates or finds the named instance of type T. Returns the default value of T if the named instance is not known to the container.
Declaration Syntax
C# Visual Basic Visual C++
public T TryGetInstance<T>(
    string instanceKey
)

Public Function TryGetInstance(Of T) ( _
    instanceKey As String _
) As T
public:
generic<typename T>
virtual T TryGetInstance(
    String^ instanceKey
) sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Container.TryGetInstance``1(System.String)"]

Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Container.TryGetInstance``1(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.TryGetInstance``1(System.String)]


TryGetInstance Method (pluginType)

TryGetInstance Method (pluginType)
Namespaces ► StructureMap ► Container ► TryGetInstance(Type)
StructureMap API
Creates or finds the default instance of the pluginType. Returns null if the pluginType is not known to the container.
Declaration Syntax
C# Visual Basic Visual C++
public Object TryGetInstance(
    Type pluginType
)
Public Function TryGetInstance ( _
    pluginType As Type _
) As Object
public:
virtual Object^ TryGetInstance(
    Type^ pluginType
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Container.TryGetInstance(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.TryGetInstance(System.Type)]


TryGetInstance Method (pluginType, instanceKey)

TryGetInstance Method (pluginType, instanceKey)
Namespaces ► StructureMap ► Container ► TryGetInstance(Type, String)
StructureMap API
Creates or finds the named instance of the pluginType. Returns null if the named instance is not known to the container.
Declaration Syntax
C# Visual Basic Visual C++
public Object TryGetInstance(
    Type pluginType,
    string instanceKey
)
Public Function TryGetInstance ( _
    pluginType As Type, _
    instanceKey As String _
) As Object
public:
virtual Object^ TryGetInstance(
    Type^ pluginType,
    String^ instanceKey
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Container.TryGetInstance(System.Type,System.String)"]

instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Container.TryGetInstance(System.Type,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.TryGetInstance(System.Type,System.String)]


WhatDoIHave Method

WhatDoIHave Method
Namespaces ► StructureMap ► Container ► WhatDoIHave()()()
StructureMap API
Returns a report detailing the complete configuration of all PluginTypes and Instances
Declaration Syntax
C# Visual Basic Visual C++
public string WhatDoIHave()
Public Function WhatDoIHave As String
public:
virtual String^ WhatDoIHave() sealed
Return Value

[Missing <returns> documentation for M:StructureMap.Container.WhatDoIHave]


With Method

With Method
Namespaces ► StructureMap ► Container ► With()()()
StructureMap API
Members
Icon | Member | Description
 | With<(Of <(T>)>)(T) | Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency of type T should be "arg"
 | With(String) | Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency or primitive argument with the designated name should be the next value.


With Method (argName)

With Method (argName)
Namespaces ► StructureMap ► Container ► With(String)
StructureMap API
Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency or primitive argument with the designated name should be the next value.
Declaration Syntax
C# Visual Basic Visual C++
public IExplicitProperty With(
    string argName
)
Public Function With ( _
    argName As String _
) As IExplicitProperty
public:
virtual IExplicitProperty^ With(
    String^ argName
) sealed
Parameters
argName (String)

[Missing <param name="argName"/> documentation for "M:StructureMap.Container.With(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.With(System.String)]


With Method (arg)

With<(Of <(T>)>) Method (arg)
Namespaces ► StructureMap ► Container ► With<(Of <(T>)>)(T)
StructureMap API
Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency of type T should be "arg"
Declaration Syntax
C# Visual Basic Visual C++
public ExplicitArgsExpression With<T>(
    T arg
)

Public Function With(Of T) ( _
    arg As T _
) As ExplicitArgsExpression
public:
generic<typename T>
virtual ExplicitArgsExpression^ With(
    T arg
) sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Container.With``1(``0)"]

Parameters
arg (T)

[Missing <param name="arg"/> documentation for "M:StructureMap.Container.With``1(``0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Container.With``1(``0)]


DefaultConstructorAttribute Class

DefaultConstructorAttribute Class
Namespaces ► StructureMap ► DefaultConstructorAttribute
StructureMap API
Used to override the constructor of a class to be used by StructureMap to create a Pluggable object
Declaration Syntax
C# Visual Basic Visual C++
public class DefaultConstructorAttribute : Attribute
Public Class DefaultConstructorAttribute _
    Inherits Attribute
public ref class DefaultConstructorAttribute : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefaultConstructorAttribute()()() | Initializes a new instance of the DefaultConstructorAttribute class
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetConstructor(Type) | Examines a System.Type object and determines the ConstructorInfo to use in creating instances of the Type
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | DefaultConstructorAttribute


DefaultConstructorAttribute Constructor

DefaultConstructorAttribute Constructor
Namespaces ► StructureMap ► DefaultConstructorAttribute ► DefaultConstructorAttribute()()()
StructureMap API
Initializes a new instance of the DefaultConstructorAttribute class
Declaration Syntax
C# Visual Basic Visual C++
public DefaultConstructorAttribute()
Public Sub New
public:
DefaultConstructorAttribute()


GetConstructor Method (ExportedType)

GetConstructor Method (ExportedType)
Namespaces ► StructureMap ► DefaultConstructorAttribute ► GetConstructor(Type)
StructureMap API
Examines a System.Type object and determines the ConstructorInfo to use in creating instances of the Type
Declaration Syntax
C# Visual Basic Visual C++
public static ConstructorInfo GetConstructor(
    Type ExportedType
)
Public Shared Function GetConstructor ( _
    ExportedType As Type _
) As ConstructorInfo
public:
static ConstructorInfo^ GetConstructor(
    Type^ ExportedType
)
Parameters
ExportedType (Type)

[Missing <param name="ExportedType"/> documentation for "M:StructureMap.DefaultConstructorAttribute.GetConstructor(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.DefaultConstructorAttribute.GetConstructor(System.Type)]


ExplicitArgsExpression Class

ExplicitArgsExpression Class
Namespaces ► StructureMap ► ExplicitArgsExpression
StructureMap API

[Missing <summary> documentation for T:StructureMap.ExplicitArgsExpression]

Declaration Syntax
C# Visual Basic Visual C++
public class ExplicitArgsExpression : IExplicitProperty
Public Class ExplicitArgsExpression _
    Implements IExplicitProperty
public ref class ExplicitArgsExpression : IExplicitProperty
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllInstances<(Of <(T>)>)()()() | Gets all configured instances of type T using explicitly configured arguments
 | GetAllInstances(Type) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance<(Of <(T>)>)()()() | Gets the default instance of type T using the explicitly configured arguments from the "args"
 | GetInstance(Type) | Gets the default instance of the pluginType using the explicitly configured arguments from the "args"
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | With<(Of <(T>)>)(T) | Pass in additional arguments by type T
 | With(String) | Pass in additional arguments by name
Inheritance Hierarchy
Object
ExplicitArgsExpression


GetAllInstances Method

GetAllInstances Method
Namespaces ► StructureMap ► ExplicitArgsExpression ► GetAllInstances()()()
StructureMap API
Members
Icon | Member | Description
 | GetAllInstances<(Of <(T>)>)()()() | Gets all configured instances of type T using explicitly configured arguments
 | GetAllInstances(Type) |


GetAllInstances Method

GetAllInstances<(Of <(T>)>) Method
Namespaces ► StructureMap ► ExplicitArgsExpression ► GetAllInstances<(Of <(T>)>)()()()
StructureMap API
Gets all configured instances of type T using explicitly configured arguments
Declaration Syntax
C# Visual Basic Visual C++
public IList<T> GetAllInstances<T>()

Public Function GetAllInstances(Of T) As IList(Of T)
public:
generic<typename T>
IList<T>^ GetAllInstances()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.ExplicitArgsExpression.GetAllInstances``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.ExplicitArgsExpression.GetAllInstances``1]


GetAllInstances Method (type)

GetAllInstances Method (type)
Namespaces ► StructureMap ► ExplicitArgsExpression ► GetAllInstances(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.ExplicitArgsExpression.GetAllInstances(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public IList GetAllInstances(
    Type type
)
Public Function GetAllInstances ( _
    type As Type _
) As IList
public:
IList^ GetAllInstances(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.ExplicitArgsExpression.GetAllInstances(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.ExplicitArgsExpression.GetAllInstances(System.Type)]


GetInstance Method

GetInstance Method
Namespaces ► StructureMap ► ExplicitArgsExpression ► GetInstance()()()
StructureMap API
Members
Icon | Member | Description
 | GetInstance<(Of <(T>)>)()()() | Gets the default instance of type T using the explicitly configured arguments from the "args"
 | GetInstance(Type) | Gets the default instance of the pluginType using the explicitly configured arguments from the "args"


GetInstance Method

GetInstance<(Of <(T>)>) Method
Namespaces ► StructureMap ► ExplicitArgsExpression ► GetInstance<(Of <(T>)>)()()()
StructureMap API
Gets the default instance of type T using the explicitly configured arguments from the "args"
Declaration Syntax
C# Visual Basic Visual C++
public T GetInstance<T>()

Public Function GetInstance(Of T) As T
public:
generic<typename T>
T GetInstance()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.ExplicitArgsExpression.GetInstance``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.ExplicitArgsExpression.GetInstance``1]


GetInstance Method (type)

GetInstance Method (type)
Namespaces ► StructureMap ► ExplicitArgsExpression ► GetInstance(Type)
StructureMap API
Gets the default instance of the pluginType using the explicitly configured arguments from the "args"
Declaration Syntax
C# Visual Basic Visual C++
public Object GetInstance(
    Type type
)
Public Function GetInstance ( _
    type As Type _
) As Object
public:
Object^ GetInstance(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.ExplicitArgsExpression.GetInstance(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.ExplicitArgsExpression.GetInstance(System.Type)]


With Method

With Method
Namespaces ► StructureMap ► ExplicitArgsExpression ► With()()()
StructureMap API
Members
Icon | Member | Description
 | With<(Of <(T>)>)(T) | Pass in additional arguments by type T
 | With(String) | Pass in additional arguments by name


With Method (argName)

With Method (argName)
Namespaces ► StructureMap ► ExplicitArgsExpression ► With(String)
StructureMap API
Pass in additional arguments by name
Declaration Syntax
C# Visual Basic Visual C++
public IExplicitProperty With(
    string argName
)
Public Function With ( _
    argName As String _
) As IExplicitProperty
public:
IExplicitProperty^ With(
    String^ argName
)
Parameters
argName (String)

[Missing <param name="argName"/> documentation for "M:StructureMap.ExplicitArgsExpression.With(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.ExplicitArgsExpression.With(System.String)]


With Method (arg)

With<(Of <(T>)>) Method (arg)
Namespaces ► StructureMap ► ExplicitArgsExpression ► With<(Of <(T>)>)(T)
StructureMap API
Pass in additional arguments by type T
Declaration Syntax
C# Visual Basic Visual C++
public ExplicitArgsExpression With<T>(
    T arg
)

Public Function With(Of T) ( _
    arg As T _
) As ExplicitArgsExpression
public:
generic<typename T>
ExplicitArgsExpression^ With(
    T arg
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.ExplicitArgsExpression.With``1(``0)"]

Parameters
arg (T)

[Missing <param name="arg"/> documentation for "M:StructureMap.ExplicitArgsExpression.With``1(``0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.ExplicitArgsExpression.With``1(``0)]


IBootstrapper Interface

IBootstrapper Interface
Namespaces ► StructureMap ► IBootstrapper
StructureMap API

[Missing <summary> documentation for T:StructureMap.IBootstrapper]

Declaration Syntax
C# Visual Basic Visual C++
public interface IBootstrapper
Public Interface IBootstrapper
public interface class IBootstrapper
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BootstrapStructureMap()()() |


BootstrapStructureMap Method

BootstrapStructureMap Method
Namespaces ► StructureMap ► IBootstrapper ► BootstrapStructureMap()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.IBootstrapper.BootstrapStructureMap]

Declaration Syntax
C# Visual Basic Visual C++
void BootstrapStructureMap()
Sub BootstrapStructureMap
void BootstrapStructureMap()


IContainer Interface

IContainer Interface
Namespaces ► StructureMap ► IContainer
StructureMap API
The main "container" object that implements the Service Locator pattern
Declaration Syntax
C# Visual Basic Visual C++
public interface IContainer
Public Interface IContainer
public interface class IContainer
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AssertConfigurationIsValid()()() | Use with caution! Does a full environment test of the configuration of this container. Will try to create every configured instance and afterward calls any methods marked with the [ValidationMethod] attribute
 | Configure(Action<(Of <(ConfigurationExpression>)>)) | Used to add additional configuration to a Container *after* the initialization.
 | EjectAllInstancesOf<(Of <(T>)>)()()() | Removes all configured instances of type T from the Container. Use with caution!
 | FillDependencies<(Of <(T>)>)()()() | Obsolete.
 | FillDependencies(Type) | Obsolete.
 | GetAllInstances<(Of <(T>)>)()()() | Creates or resolves all registered instances of type T
 | GetAllInstances(Type) | Creates or resolves all registered instances of the pluginType
 | GetAllInstances<(Of <(T>)>)(ExplicitArguments) | Gets all configured instances of type T using explicitly configured arguments from the "args"
 | GetAllInstances(Type, ExplicitArguments) | Gets the default instance of type T using the explicitly configured arguments from the "args"
 | GetInstance(Type, String) | Creates or finds the named instance of the pluginType
 | GetInstance(Type) | Creates or finds the default instance of the pluginType
 | GetInstance(Type, Instance) | Creates a new instance of the requested type using the supplied Instance. Mostly used internally
 | GetInstance<(Of <(T>)>)(String) | Creates or finds the named instance of T
 | GetInstance<(Of <(T>)>)()()() | Creates or finds the default instance of type T
 | GetInstance<(Of <(T>)>)(Instance) | Creates a new instance of the requested type T using the supplied Instance. Mostly used internally
 | GetInstance<(Of <(T>)>)(ExplicitArguments) |
 | GetInstance(Type, ExplicitArguments) | Gets the default instance of the pluginType using the explicitly configured arguments from the "args"
 | Inject<(Of <(PLUGINTYPE>)>)(PLUGINTYPE) | Injects the given object into a Container as the default for the designated PLUGINTYPE. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | Inject(Type, Object) | Injects the given object into a Container as the default for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | Inject<(Of <(T>)>)(String, T) | Injects the given object into a Container by name for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | Model | Provides queryable access to the configured PluginType's and Instances of this Container
 | SetDefaultsToProfile(String) | Sets the default instance for all PluginType's to the designated Profile.
 | TryGetInstance(Type, String) | Creates or finds the named instance of the pluginType. Returns null if the named instance is not known to the container.
 | TryGetInstance(Type) | Creates or finds the default instance of the pluginType. Returns null if the pluginType is not known to the container.
 | TryGetInstance<(Of <(T>)>)()()() | Creates or finds the default instance of type T. Returns the default value of T if it is not known to the container.
 | TryGetInstance<(Of <(T>)>)(String) | Creates or finds the named instance of type T. Returns the default value of T if the named instance is not known to the container.
 | WhatDoIHave()()() | Returns a report detailing the complete configuration of all PluginTypes and Instances
 | With<(Of <(T>)>)(T) | Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency of type T should be "arg"
 | With(String) | Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency or primitive argument with the designated name should be the next value.


AssertConfigurationIsValid Method

AssertConfigurationIsValid Method
Namespaces ► StructureMap ► IContainer ► AssertConfigurationIsValid()()()
StructureMap API
Use with caution! Does a full environment test of the configuration of this container. Will try to create every configured instance and afterward calls any methods marked with the [ValidationMethod] attribute
Declaration Syntax
C# Visual Basic Visual C++
void AssertConfigurationIsValid()
Sub AssertConfigurationIsValid
void AssertConfigurationIsValid()


Configure Method (configure)

Configure Method (configure)
Namespaces ► StructureMap ► IContainer ► Configure(Action<(Of <(ConfigurationExpression>)>))
StructureMap API
Used to add additional configuration to a Container *after* the initialization.
Declaration Syntax
C# Visual Basic Visual C++
void Configure(
    Action<ConfigurationExpression> configure
)
Sub Configure ( _
    configure As Action(Of ConfigurationExpression) _
)
void Configure(
    Action<ConfigurationExpression^>^ configure
)
Parameters
configure (Action <(Of <( ConfigurationExpression >)>))

[Missing <param name="configure"/> documentation for "M:StructureMap.IContainer.Configure(System.Action{StructureMap.ConfigurationExpression})"]


EjectAllInstancesOf Method

EjectAllInstancesOf<(Of <(T>)>) Method
Namespaces ► StructureMap ► IContainer ► EjectAllInstancesOf<(Of <(T>)>)()()()
StructureMap API
Removes all configured instances of type T from the Container. Use with caution!
Declaration Syntax
C# Visual Basic Visual C++
void EjectAllInstancesOf<T>()

Sub EjectAllInstancesOf(Of T)
generic<typename T>
void EjectAllInstancesOf()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IContainer.EjectAllInstancesOf``1"]


FillDependencies Method

FillDependencies Method
Namespaces ► StructureMap ► IContainer ► FillDependencies()()()
StructureMap API
Members
Icon | Member | Description
 | FillDependencies<(Of <(T>)>)()()() | Obsolete.
 | FillDependencies(Type) | Obsolete.


FillDependencies Method

FillDependencies<(Of <(T>)>) Method
Namespaces ► StructureMap ► IContainer ► FillDependencies<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.IContainer.FillDependencies``1]

Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Please use GetInstance<T>() instead.")]
T FillDependencies<T>()

<ObsoleteAttribute("Please use GetInstance<T>() instead.")> _
Function FillDependencies(Of T) As T
[ObsoleteAttribute(L"Please use GetInstance<T>() instead.")]
generic<typename T>
T FillDependencies()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IContainer.FillDependencies``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.FillDependencies``1]


FillDependencies Method (type)

FillDependencies Method (type)
Namespaces ► StructureMap ► IContainer ► FillDependencies(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.IContainer.FillDependencies(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Please use GetInstance(Type) instead")]
Object FillDependencies(
    Type type
)
<ObsoleteAttribute("Please use GetInstance(Type) instead")> _
Function FillDependencies ( _
    type As Type _
) As Object
[ObsoleteAttribute(L"Please use GetInstance(Type) instead")]
Object^ FillDependencies(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.IContainer.FillDependencies(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.FillDependencies(System.Type)]


GetAllInstances Method

GetAllInstances Method
Namespaces ► StructureMap ► IContainer ► GetAllInstances()()()
StructureMap API
Members
Icon | Member | Description
 | GetAllInstances<(Of <(T>)>)()()() | Creates or resolves all registered instances of type T
 | GetAllInstances(Type) | Creates or resolves all registered instances of the pluginType
 | GetAllInstances<(Of <(T>)>)(ExplicitArguments) | Gets all configured instances of type T using explicitly configured arguments from the "args"
 | GetAllInstances(Type, ExplicitArguments) | Gets the default instance of type T using the explicitly configured arguments from the "args"


GetAllInstances Method

GetAllInstances<(Of <(T>)>) Method
Namespaces ► StructureMap ► IContainer ► GetAllInstances<(Of <(T>)>)()()()
StructureMap API
Creates or resolves all registered instances of type T
Declaration Syntax
C# Visual Basic Visual C++
IList<T> GetAllInstances<T>()

Function GetAllInstances(Of T) As IList(Of T)
generic<typename T>
IList<T>^ GetAllInstances()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IContainer.GetAllInstances``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.GetAllInstances``1]


GetAllInstances Method (args)

GetAllInstances<(Of <(T>)>) Method (args)
Namespaces ► StructureMap ► IContainer ► GetAllInstances<(Of <(T>)>)(ExplicitArguments)
StructureMap API
Gets all configured instances of type T using explicitly configured arguments from the "args"
Declaration Syntax
C# Visual Basic Visual C++
IList<T> GetAllInstances<T>(
    ExplicitArguments args
)

Function GetAllInstances(Of T) ( _
    args As ExplicitArguments _
) As IList(Of T)
generic<typename T>
IList<T>^ GetAllInstances(
    ExplicitArguments^ args
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IContainer.GetAllInstances``1(StructureMap.Pipeline.ExplicitArguments)"]

Parameters
args (ExplicitArguments)

[Missing <param name="args"/> documentation for "M:StructureMap.IContainer.GetAllInstances``1(StructureMap.Pipeline.ExplicitArguments)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.GetAllInstances``1(StructureMap.Pipeline.ExplicitArguments)]


GetAllInstances Method (pluginType)

GetAllInstances Method (pluginType)
Namespaces ► StructureMap ► IContainer ► GetAllInstances(Type)
StructureMap API
Creates or resolves all registered instances of the pluginType
Declaration Syntax
C# Visual Basic Visual C++
IList GetAllInstances(
    Type pluginType
)
Function GetAllInstances ( _
    pluginType As Type _
) As IList
IList^ GetAllInstances(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.IContainer.GetAllInstances(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.GetAllInstances(System.Type)]


GetAllInstances Method (type, args)

GetAllInstances Method (type, args)
Namespaces ► StructureMap ► IContainer ► GetAllInstances(Type, ExplicitArguments)
StructureMap API
Gets the default instance of type T using the explicitly configured arguments from the "args"
Declaration Syntax
C# Visual Basic Visual C++
IList GetAllInstances(
    Type type,
    ExplicitArguments args
)
Function GetAllInstances ( _
    type As Type, _
    args As ExplicitArguments _
) As IList
IList^ GetAllInstances(
    Type^ type,
    ExplicitArguments^ args
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.IContainer.GetAllInstances(System.Type,StructureMap.Pipeline.ExplicitArguments)"]

args (ExplicitArguments)

[Missing <param name="args"/> documentation for "M:StructureMap.IContainer.GetAllInstances(System.Type,StructureMap.Pipeline.ExplicitArguments)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.GetAllInstances(System.Type,StructureMap.Pipeline.ExplicitArguments)]


GetInstance Method

GetInstance Method
Namespaces ► StructureMap ► IContainer ► GetInstance()()()
StructureMap API
Members
Icon | Member | Description
 | GetInstance(Type, String) | Creates or finds the named instance of the pluginType
 | GetInstance(Type) | Creates or finds the default instance of the pluginType
 | GetInstance(Type, Instance) | Creates a new instance of the requested type using the supplied Instance. Mostly used internally
 | GetInstance<(Of <(T>)>)(String) | Creates or finds the named instance of T
 | GetInstance<(Of <(T>)>)()()() | Creates or finds the default instance of type T
 | GetInstance<(Of <(T>)>)(Instance) | Creates a new instance of the requested type T using the supplied Instance. Mostly used internally
 | GetInstance<(Of <(T>)>)(ExplicitArguments) |
 | GetInstance(Type, ExplicitArguments) | Gets the default instance of the pluginType using the explicitly configured arguments from the "args"


GetInstance Method

GetInstance<(Of <(T>)>) Method
Namespaces ► StructureMap ► IContainer ► GetInstance<(Of <(T>)>)()()()
StructureMap API
Creates or finds the default instance of type T
Declaration Syntax
C# Visual Basic Visual C++
T GetInstance<T>()

Function GetInstance(Of T) As T
generic<typename T>
T GetInstance()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IContainer.GetInstance``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.GetInstance``1]


GetInstance Method (args)

GetInstance<(Of <(T>)>) Method (args)
Namespaces ► StructureMap ► IContainer ► GetInstance<(Of <(T>)>)(ExplicitArguments)
StructureMap API

[Missing <summary> documentation for M:StructureMap.IContainer.GetInstance``1(StructureMap.Pipeline.ExplicitArguments)]

Declaration Syntax
C# Visual Basic Visual C++
T GetInstance<T>(
    ExplicitArguments args
)

Function GetInstance(Of T) ( _
    args As ExplicitArguments _
) As T
generic<typename T>
T GetInstance(
    ExplicitArguments^ args
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IContainer.GetInstance``1(StructureMap.Pipeline.ExplicitArguments)"]

Parameters
args (ExplicitArguments)

[Missing <param name="args"/> documentation for "M:StructureMap.IContainer.GetInstance``1(StructureMap.Pipeline.ExplicitArguments)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.GetInstance``1(StructureMap.Pipeline.ExplicitArguments)]


GetInstance Method (instance)

GetInstance<(Of <(T>)>) Method (instance)
Namespaces ► StructureMap ► IContainer ► GetInstance<(Of <(T>)>)(Instance)
StructureMap API
Creates a new instance of the requested type T using the supplied Instance. Mostly used internally
Declaration Syntax
C# Visual Basic Visual C++
T GetInstance<T>(
    Instance instance
)

Function GetInstance(Of T) ( _
    instance As Instance _
) As T
generic<typename T>
T GetInstance(
    Instance^ instance
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IContainer.GetInstance``1(StructureMap.Pipeline.Instance)"]

Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.IContainer.GetInstance``1(StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.GetInstance``1(StructureMap.Pipeline.Instance)]


GetInstance Method (instanceKey)

GetInstance<(Of <(T>)>) Method (instanceKey)
Namespaces ► StructureMap ► IContainer ► GetInstance<(Of <(T>)>)(String)
StructureMap API
Creates or finds the named instance of T
Declaration Syntax
C# Visual Basic Visual C++
T GetInstance<T>(
    string instanceKey
)

Function GetInstance(Of T) ( _
    instanceKey As String _
) As T
generic<typename T>
T GetInstance(
    String^ instanceKey
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IContainer.GetInstance``1(System.String)"]

Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.IContainer.GetInstance``1(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.GetInstance``1(System.String)]


GetInstance Method (pluginType)

GetInstance Method (pluginType)
Namespaces ► StructureMap ► IContainer ► GetInstance(Type)
StructureMap API
Creates or finds the default instance of the pluginType
Declaration Syntax
C# Visual Basic Visual C++
Object GetInstance(
    Type pluginType
)
Function GetInstance ( _
    pluginType As Type _
) As Object
Object^ GetInstance(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.IContainer.GetInstance(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.GetInstance(System.Type)]


GetInstance Method (pluginType, args)

GetInstance Method (pluginType, args)
Namespaces ► StructureMap ► IContainer ► GetInstance(Type, ExplicitArguments)
StructureMap API
Gets the default instance of the pluginType using the explicitly configured arguments from the "args"
Declaration Syntax
C# Visual Basic Visual C++
Object GetInstance(
    Type pluginType,
    ExplicitArguments args
)
Function GetInstance ( _
    pluginType As Type, _
    args As ExplicitArguments _
) As Object
Object^ GetInstance(
    Type^ pluginType,
    ExplicitArguments^ args
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.IContainer.GetInstance(System.Type,StructureMap.Pipeline.ExplicitArguments)"]

args (ExplicitArguments)

[Missing <param name="args"/> documentation for "M:StructureMap.IContainer.GetInstance(System.Type,StructureMap.Pipeline.ExplicitArguments)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.GetInstance(System.Type,StructureMap.Pipeline.ExplicitArguments)]


GetInstance Method (pluginType, instance)

GetInstance Method (pluginType, instance)
Namespaces ► StructureMap ► IContainer ► GetInstance(Type, Instance)
StructureMap API
Creates a new instance of the requested type using the supplied Instance. Mostly used internally
Declaration Syntax
C# Visual Basic Visual C++
Object GetInstance(
    Type pluginType,
    Instance instance
)
Function GetInstance ( _
    pluginType As Type, _
    instance As Instance _
) As Object
Object^ GetInstance(
    Type^ pluginType,
    Instance^ instance
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.IContainer.GetInstance(System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.IContainer.GetInstance(System.Type,StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.GetInstance(System.Type,StructureMap.Pipeline.Instance)]


GetInstance Method (pluginType, instanceKey)

GetInstance Method (pluginType, instanceKey)
Namespaces ► StructureMap ► IContainer ► GetInstance(Type, String)
StructureMap API
Creates or finds the named instance of the pluginType
Declaration Syntax
C# Visual Basic Visual C++
Object GetInstance(
    Type pluginType,
    string instanceKey
)
Function GetInstance ( _
    pluginType As Type, _
    instanceKey As String _
) As Object
Object^ GetInstance(
    Type^ pluginType,
    String^ instanceKey
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.IContainer.GetInstance(System.Type,System.String)"]

instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.IContainer.GetInstance(System.Type,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.GetInstance(System.Type,System.String)]


Inject Method

Inject Method
Namespaces ► StructureMap ► IContainer ► Inject()()()
StructureMap API
Members
Icon | Member | Description
 | Inject<(Of <(PLUGINTYPE>)>)(PLUGINTYPE) | Injects the given object into a Container as the default for the designated PLUGINTYPE. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | Inject(Type, Object) | Injects the given object into a Container as the default for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | Inject<(Of <(T>)>)(String, T) | Injects the given object into a Container by name for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios


Inject Method (name, instance)

Inject<(Of <(T>)>) Method (name, instance)
Namespaces ► StructureMap ► IContainer ► Inject<(Of <(T>)>)(String, T)
StructureMap API
Injects the given object into a Container by name for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
Declaration Syntax
C# Visual Basic Visual C++
void Inject<T>(
    string name,
    T instance
)

Sub Inject(Of T) ( _
    name As String, _
    instance As T _
)
generic<typename T>
void Inject(
    String^ name,
    T instance
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IContainer.Inject``1(System.String,``0)"]

Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.IContainer.Inject``1(System.String,``0)"]

instance (T)

[Missing <param name="instance"/> documentation for "M:StructureMap.IContainer.Inject``1(System.String,``0)"]


Inject Method (pluginType, stub)

Inject Method (pluginType, stub)
Namespaces ► StructureMap ► IContainer ► Inject(Type, Object)
StructureMap API
Injects the given object into a Container as the default for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
Declaration Syntax
C# Visual Basic Visual C++
void Inject(
    Type pluginType,
    Object stub
)
Sub Inject ( _
    pluginType As Type, _
    stub As Object _
)
void Inject(
    Type^ pluginType,
    Object^ stub
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.IContainer.Inject(System.Type,System.Object)"]

stub (Object)

[Missing <param name="stub"/> documentation for "M:StructureMap.IContainer.Inject(System.Type,System.Object)"]


Inject Method (instance)

Inject<(Of <(PLUGINTYPE>)>) Method (instance)
Namespaces ► StructureMap ► IContainer ► Inject<(Of <(PLUGINTYPE>)>)(PLUGINTYPE)
StructureMap API
Injects the given object into a Container as the default for the designated PLUGINTYPE. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
Declaration Syntax
C# Visual Basic Visual C++
void Inject<PLUGINTYPE>(
    PLUGINTYPE instance
)

Sub Inject(Of PLUGINTYPE) ( _
    instance As PLUGINTYPE _
)
generic<typename PLUGINTYPE>
void Inject(
    PLUGINTYPE instance
)
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.IContainer.Inject``1(``0)"]

Parameters
instance (PLUGINTYPE)

[Missing <param name="instance"/> documentation for "M:StructureMap.IContainer.Inject``1(``0)"]


Model Property

Model Property
Namespaces ► StructureMap ► IContainer ► Model
StructureMap API
Provides queryable access to the configured PluginType's and Instances of this Container
Declaration Syntax
C# Visual Basic Visual C++
IModel Model { get; }
ReadOnly Property Model As IModel
property IModel^ Model {
    IModel^ get ();
}


SetDefaultsToProfile Method (profile)

SetDefaultsToProfile Method (profile)
Namespaces ► StructureMap ► IContainer ► SetDefaultsToProfile(String)
StructureMap API
Sets the default instance for all PluginType's to the designated Profile.
Declaration Syntax
C# Visual Basic Visual C++
void SetDefaultsToProfile(
    string profile
)
Sub SetDefaultsToProfile ( _
    profile As String _
)
void SetDefaultsToProfile(
    String^ profile
)
Parameters
profile (String)

[Missing <param name="profile"/> documentation for "M:StructureMap.IContainer.SetDefaultsToProfile(System.String)"]


TryGetInstance Method

TryGetInstance Method
Namespaces ► StructureMap ► IContainer ► TryGetInstance()()()
StructureMap API
Members
Icon | Member | Description
 | TryGetInstance(Type, String) | Creates or finds the named instance of the pluginType. Returns null if the named instance is not known to the container.
 | TryGetInstance(Type) | Creates or finds the default instance of the pluginType. Returns null if the pluginType is not known to the container.
 | TryGetInstance<(Of <(T>)>)()()() | Creates or finds the default instance of type T. Returns the default value of T if it is not known to the container.
 | TryGetInstance<(Of <(T>)>)(String) | Creates or finds the named instance of type T. Returns the default value of T if the named instance is not known to the container.


TryGetInstance Method

TryGetInstance<(Of <(T>)>) Method
Namespaces ► StructureMap ► IContainer ► TryGetInstance<(Of <(T>)>)()()()
StructureMap API
Creates or finds the default instance of type T. Returns the default value of T if it is not known to the container.
Declaration Syntax
C# Visual Basic Visual C++
T TryGetInstance<T>()

Function TryGetInstance(Of T) As T
generic<typename T>
T TryGetInstance()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IContainer.TryGetInstance``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.TryGetInstance``1]


TryGetInstance Method (instanceKey)

TryGetInstance<(Of <(T>)>) Method (instanceKey)
Namespaces ► StructureMap ► IContainer ► TryGetInstance<(Of <(T>)>)(String)
StructureMap API
Creates or finds the named instance of type T. Returns the default value of T if the named instance is not known to the container.
Declaration Syntax
C# Visual Basic Visual C++
T TryGetInstance<T>(
    string instanceKey
)

Function TryGetInstance(Of T) ( _
    instanceKey As String _
) As T
generic<typename T>
T TryGetInstance(
    String^ instanceKey
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IContainer.TryGetInstance``1(System.String)"]

Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.IContainer.TryGetInstance``1(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.TryGetInstance``1(System.String)]


TryGetInstance Method (pluginType)

TryGetInstance Method (pluginType)
Namespaces ► StructureMap ► IContainer ► TryGetInstance(Type)
StructureMap API
Creates or finds the default instance of the pluginType. Returns null if the pluginType is not known to the container.
Declaration Syntax
C# Visual Basic Visual C++
Object TryGetInstance(
    Type pluginType
)
Function TryGetInstance ( _
    pluginType As Type _
) As Object
Object^ TryGetInstance(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.IContainer.TryGetInstance(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.TryGetInstance(System.Type)]


TryGetInstance Method (pluginType, instanceKey)

TryGetInstance Method (pluginType, instanceKey)
Namespaces ► StructureMap ► IContainer ► TryGetInstance(Type, String)
StructureMap API
Creates or finds the named instance of the pluginType. Returns null if the named instance is not known to the container.
Declaration Syntax
C# Visual Basic Visual C++
Object TryGetInstance(
    Type pluginType,
    string instanceKey
)
Function TryGetInstance ( _
    pluginType As Type, _
    instanceKey As String _
) As Object
Object^ TryGetInstance(
    Type^ pluginType,
    String^ instanceKey
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.IContainer.TryGetInstance(System.Type,System.String)"]

instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.IContainer.TryGetInstance(System.Type,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.TryGetInstance(System.Type,System.String)]


WhatDoIHave Method

WhatDoIHave Method
Namespaces ► StructureMap ► IContainer ► WhatDoIHave()()()
StructureMap API
Returns a report detailing the complete configuration of all PluginTypes and Instances
Declaration Syntax
C# Visual Basic Visual C++
string WhatDoIHave()
Function WhatDoIHave As String
String^ WhatDoIHave()
Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.WhatDoIHave]


With Method

With Method
Namespaces ► StructureMap ► IContainer ► With()()()
StructureMap API
Members
Icon | Member | Description
 | With<(Of <(T>)>)(T) | Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency of type T should be "arg"
 | With(String) | Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency or primitive argument with the designated name should be the next value.


With Method (argName)

With Method (argName)
Namespaces ► StructureMap ► IContainer ► With(String)
StructureMap API
Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency or primitive argument with the designated name should be the next value.
Declaration Syntax
C# Visual Basic Visual C++
IExplicitProperty With(
    string argName
)
Function With ( _
    argName As String _
) As IExplicitProperty
IExplicitProperty^ With(
    String^ argName
)
Parameters
argName (String)

[Missing <param name="argName"/> documentation for "M:StructureMap.IContainer.With(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.With(System.String)]


With Method (arg)

With<(Of <(T>)>) Method (arg)
Namespaces ► StructureMap ► IContainer ► With<(Of <(T>)>)(T)
StructureMap API
Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency of type T should be "arg"
Declaration Syntax
C# Visual Basic Visual C++
ExplicitArgsExpression With<T>(
    T arg
)

Function With(Of T) ( _
    arg As T _
) As ExplicitArgsExpression
generic<typename T>
ExplicitArgsExpression^ With(
    T arg
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IContainer.With``1(``0)"]

Parameters
arg (T)

[Missing <param name="arg"/> documentation for "M:StructureMap.IContainer.With``1(``0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContainer.With``1(``0)]


IContext Interface

IContext Interface
Namespaces ► StructureMap ► IContext
StructureMap API

[Missing <summary> documentation for T:StructureMap.IContext]

Declaration Syntax
C# Visual Basic Visual C++
public interface IContext
Public Interface IContext
public interface class IContext
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BuildStack | Gets a reference to the BuildStack for this build session
 | GetInstance<(Of <(T>)>)()()() | Get the object of type T that is valid for this build session.
 | ParentType | The concrete type of the immediate parent object in the object graph


BuildStack Property

BuildStack Property
Namespaces ► StructureMap ► IContext ► BuildStack
StructureMap API
Gets a reference to the BuildStack for this build session
Declaration Syntax
C# Visual Basic Visual C++
BuildStack BuildStack { get; }
ReadOnly Property BuildStack As BuildStack
property BuildStack^ BuildStack {
    BuildStack^ get ();
}


GetInstance Method

GetInstance<(Of <(T>)>) Method
Namespaces ► StructureMap ► IContext ► GetInstance<(Of <(T>)>)()()()
StructureMap API
Get the object of type T that is valid for this build session.
Declaration Syntax
C# Visual Basic Visual C++
T GetInstance<T>()

Function GetInstance(Of T) As T
generic<typename T>
T GetInstance()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IContext.GetInstance``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.IContext.GetInstance``1]


ParentType Property

ParentType Property
Namespaces ► StructureMap ► IContext ► ParentType
StructureMap API
The concrete type of the immediate parent object in the object graph
Declaration Syntax
C# Visual Basic Visual C++
Type ParentType { get; }
ReadOnly Property ParentType As Type
property Type^ ParentType {
    Type^ get ();
}


IExplicitProperty Interface

IExplicitProperty Interface
Namespaces ► StructureMap ► IExplicitProperty
StructureMap API

[Missing <summary> documentation for T:StructureMap.IExplicitProperty]

Declaration Syntax
C# Visual Basic Visual C++
public interface IExplicitProperty
Public Interface IExplicitProperty
public interface class IExplicitProperty
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EqualTo(Object) | Specify the value of this explicit argument


EqualTo Method (value)

EqualTo Method (value)
Namespaces ► StructureMap ► IExplicitProperty ► EqualTo(Object)
StructureMap API
Specify the value of this explicit argument
Declaration Syntax
C# Visual Basic Visual C++
ExplicitArgsExpression EqualTo(
    Object value
)
Function EqualTo ( _
    value As Object _
) As ExplicitArgsExpression
ExplicitArgsExpression^ EqualTo(
    Object^ value
)
Parameters
value (Object)

[Missing <param name="value"/> documentation for "M:StructureMap.IExplicitProperty.EqualTo(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IExplicitProperty.EqualTo(System.Object)]


IInitializationExpression Interface

IInitializationExpression Interface
Namespaces ► StructureMap ► IInitializationExpression
StructureMap API

[Missing <summary> documentation for T:StructureMap.IInitializationExpression]

Declaration Syntax
C# Visual Basic Visual C++
public interface IInitializationExpression
Public Interface IInitializationExpression
public interface class IInitializationExpression
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddConfigurationFromNode(XmlNode) | Imports configuration directly from an XmlNode. This method was intended for scenarios like Xml being embedded into an assembly. The node must be a 'StructureMap' node
 | AddConfigurationFromXmlFile(String) | Imports configuration from an Xml file. The fileName must point to an Xml file with valid StructureMap configuration
 | AddRegistry<(Of <(T>)>)()()() | Creates and adds a Registry object of type T.
 | AddRegistry(Registry) | Imports all the configuration from a Registry object
 | BuildInstancesOf<(Of <(PLUGINTYPE>)>)()()() | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms
 | CreateProfile(String) | Expression Builder to define the defaults for a named Profile. Each call to CreateProfile is additive.
 | CreateProfile(String, Action<(Of <(ProfileExpression>)>)) | An alternative way to use CreateProfile that uses ProfileExpression as a Nested Closure. This usage will result in cleaner code for multiple declarations
 | DefaultProfileName | Designate the Default Profile. This will be applied as soon as the Container is initialized.
 | FillAllPropertiesOfType<(Of <(PLUGINTYPE>)>)()()() | Directs StructureMap to always inject dependencies into any and all public Setter properties of the type PLUGINTYPE.
 | ForConcreteType<(Of <(T>)>)()()() | This method is a shortcut for specifying the default constructor and setter arguments for a ConcreteType. ForConcreteType is shorthand for: ForRequestedType[T]().TheDefault.Is.OfConcreteType[T].************** when the PluginType and ConcreteType are the same Type
 | ForRequestedType<(Of <(PLUGINTYPE>)>)()()() | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms
 | ForRequestedType(Type) | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. This method is specifically meant for registering open generic types
 | IfTypeMatches(Predicate<(Of <(Type>)>)) | Allows you to define a TypeInterceptor inline with Lambdas or anonymous delegates
 | IgnoreStructureMapConfig | If true, the StructureMap.config file will be ignored even if it exists. The default is false.
 | InstanceOf<(Of <(T>)>)()()() | Adds an additional, non-Default Instance to the PluginType T.
 | InstanceOf(Type) | Adds an additional, non-Default Instance to the designated pluginType This method is mostly meant for open generic types
 | PullConfigurationFromAppConfig | If true, directs StructureMap to look for configuration in the App.config. The default value is false.
 | RegisterInterceptor(TypeInterceptor) | Registers a new TypeInterceptor object with the Container
 | Scan(Action<(Of <(IAssemblyScanner>)>)) | Expresses a single "Scanning" action
 | UseDefaultStructureMapConfigFile | If true, makes the existence of the StructureMap.config mandatory. The default is false.


AddConfigurationFromNode Method (node)

AddConfigurationFromNode Method (node)
Namespaces ► StructureMap ► IInitializationExpression ► AddConfigurationFromNode(XmlNode)
StructureMap API
Imports configuration directly from an XmlNode. This method was intended for scenarios like Xml being embedded into an assembly. The node must be a 'StructureMap' node
Declaration Syntax
C# Visual Basic Visual C++
void AddConfigurationFromNode(
    XmlNode node
)
Sub AddConfigurationFromNode ( _
    node As XmlNode _
)
void AddConfigurationFromNode(
    XmlNode^ node
)
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.IInitializationExpression.AddConfigurationFromNode(System.Xml.XmlNode)"]


AddConfigurationFromXmlFile Method (fileName)

AddConfigurationFromXmlFile Method (fileName)
Namespaces ► StructureMap ► IInitializationExpression ► AddConfigurationFromXmlFile(String)
StructureMap API
Imports configuration from an Xml file. The fileName must point to an Xml file with valid StructureMap configuration
Declaration Syntax
C# Visual Basic Visual C++
void AddConfigurationFromXmlFile(
    string fileName
)
Sub AddConfigurationFromXmlFile ( _
    fileName As String _
)
void AddConfigurationFromXmlFile(
    String^ fileName
)
Parameters
fileName (String)

[Missing <param name="fileName"/> documentation for "M:StructureMap.IInitializationExpression.AddConfigurationFromXmlFile(System.String)"]


AddRegistry Method

AddRegistry Method
Namespaces ► StructureMap ► IInitializationExpression ► AddRegistry()()()
StructureMap API
Members
Icon | Member | Description
 | AddRegistry<(Of <(T>)>)()()() | Creates and adds a Registry object of type T.
 | AddRegistry(Registry) | Imports all the configuration from a Registry object


AddRegistry Method

AddRegistry<(Of <(T>)>) Method
Namespaces ► StructureMap ► IInitializationExpression ► AddRegistry<(Of <(T>)>)()()()
StructureMap API
Creates and adds a Registry object of type T.
Declaration Syntax
C# Visual Basic Visual C++
void AddRegistry<T>()
where T : new(), Registry

Sub AddRegistry(Of T As {New, Registry})
generic<typename T>
where T : gcnew(), Registry
void AddRegistry()
Generic Template Parameters
T
The Registry Type


AddRegistry Method (registry)

AddRegistry Method (registry)
Namespaces ► StructureMap ► IInitializationExpression ► AddRegistry(Registry)
StructureMap API
Imports all the configuration from a Registry object
Declaration Syntax
C# Visual Basic Visual C++
void AddRegistry(
    Registry registry
)
Sub AddRegistry ( _
    registry As Registry _
)
void AddRegistry(
    Registry^ registry
)
Parameters
registry (Registry)

[Missing <param name="registry"/> documentation for "M:StructureMap.IInitializationExpression.AddRegistry(StructureMap.Configuration.DSL.Registry)"]


BuildInstancesOf Method

BuildInstancesOf<(Of <(PLUGINTYPE>)>) Method
Namespaces ► StructureMap ► IInitializationExpression ► BuildInstancesOf<(Of <(PLUGINTYPE>)>)()()()
StructureMap API
Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms
Declaration Syntax
C# Visual Basic Visual C++
CreatePluginFamilyExpression<PLUGINTYPE> BuildInstancesOf<PLUGINTYPE>()

Function BuildInstancesOf(Of PLUGINTYPE) As CreatePluginFamilyExpression(Of PLUGINTYPE)
generic<typename PLUGINTYPE>
CreatePluginFamilyExpression<PLUGINTYPE>^ BuildInstancesOf()
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.IInitializationExpression.BuildInstancesOf``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.IInitializationExpression.BuildInstancesOf``1]


CreateProfile Method

CreateProfile Method
Namespaces ► StructureMap ► IInitializationExpression ► CreateProfile()()()
StructureMap API
Members
Icon | Member | Description
 | CreateProfile(String) | Expression Builder to define the defaults for a named Profile. Each call to CreateProfile is additive.
 | CreateProfile(String, Action<(Of <(ProfileExpression>)>)) | An alternative way to use CreateProfile that uses ProfileExpression as a Nested Closure. This usage will result in cleaner code for multiple declarations


CreateProfile Method (profileName)

CreateProfile Method (profileName)
Namespaces ► StructureMap ► IInitializationExpression ► CreateProfile(String)
StructureMap API
Expression Builder to define the defaults for a named Profile. Each call to CreateProfile is additive.
Declaration Syntax
C# Visual Basic Visual C++
ProfileExpression CreateProfile(
    string profileName
)
Function CreateProfile ( _
    profileName As String _
) As ProfileExpression
ProfileExpression^ CreateProfile(
    String^ profileName
)
Parameters
profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.IInitializationExpression.CreateProfile(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IInitializationExpression.CreateProfile(System.String)]


CreateProfile Method (profileName, action)

CreateProfile Method (profileName, action)
Namespaces ► StructureMap ► IInitializationExpression ► CreateProfile(String, Action<(Of <(ProfileExpression>)>))
StructureMap API
An alternative way to use CreateProfile that uses ProfileExpression as a Nested Closure. This usage will result in cleaner code for multiple declarations
Declaration Syntax
C# Visual Basic Visual C++
void CreateProfile(
    string profileName,
    Action<ProfileExpression> action
)
Sub CreateProfile ( _
    profileName As String, _
    action As Action(Of ProfileExpression) _
)
void CreateProfile(
    String^ profileName,
    Action<ProfileExpression^>^ action
)
Parameters
profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.IInitializationExpression.CreateProfile(System.String,System.Action{StructureMap.Configuration.DSL.Expressions.ProfileExpression})"]

action (Action <(Of <( ProfileExpression >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.IInitializationExpression.CreateProfile(System.String,System.Action{StructureMap.Configuration.DSL.Expressions.ProfileExpression})"]


DefaultProfileName Property

DefaultProfileName Property
Namespaces ► StructureMap ► IInitializationExpression ► DefaultProfileName
StructureMap API
Designate the Default Profile. This will be applied as soon as the Container is initialized.
Declaration Syntax
C# Visual Basic Visual C++
string DefaultProfileName { get; set; }
Property DefaultProfileName As String
property String^ DefaultProfileName {
    String^ get ();
    void set (String^ value);
}


FillAllPropertiesOfType Method

FillAllPropertiesOfType<(Of <(PLUGINTYPE>)>) Method
Namespaces ► StructureMap ► IInitializationExpression ► FillAllPropertiesOfType<(Of <(PLUGINTYPE>)>)()()()
StructureMap API
Directs StructureMap to always inject dependencies into any and all public Setter properties of the type PLUGINTYPE.
Declaration Syntax
C# Visual Basic Visual C++
CreatePluginFamilyExpression<PLUGINTYPE> FillAllPropertiesOfType<PLUGINTYPE>()

Function FillAllPropertiesOfType(Of PLUGINTYPE) As CreatePluginFamilyExpression(Of PLUGINTYPE)
generic<typename PLUGINTYPE>
CreatePluginFamilyExpression<PLUGINTYPE>^ FillAllPropertiesOfType()
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.IInitializationExpression.FillAllPropertiesOfType``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.IInitializationExpression.FillAllPropertiesOfType``1]


ForConcreteType Method

ForConcreteType<(Of <(T>)>) Method
Namespaces ► StructureMap ► IInitializationExpression ► ForConcreteType<(Of <(T>)>)()()()
StructureMap API
This method is a shortcut for specifying the default constructor and setter arguments for a ConcreteType. ForConcreteType is shorthand for: ForRequestedType[T]().TheDefault.Is.OfConcreteType[T].************** when the PluginType and ConcreteType are the same Type
Declaration Syntax
C# Visual Basic Visual C++
Registry..::.BuildWithExpression<T> ForConcreteType<T>()

Function ForConcreteType(Of T) As Registry..::.BuildWithExpression(Of T)
generic<typename T>
Registry..::.BuildWithExpression<T>^ ForConcreteType()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IInitializationExpression.ForConcreteType``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.IInitializationExpression.ForConcreteType``1]


ForRequestedType Method

ForRequestedType Method
Namespaces ► StructureMap ► IInitializationExpression ► ForRequestedType()()()
StructureMap API
Members
Icon | Member | Description
 | ForRequestedType<(Of <(PLUGINTYPE>)>)()()() | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms
 | ForRequestedType(Type) | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. This method is specifically meant for registering open generic types


ForRequestedType Method

ForRequestedType<(Of <(PLUGINTYPE>)>) Method
Namespaces ► StructureMap ► IInitializationExpression ► ForRequestedType<(Of <(PLUGINTYPE>)>)()()()
StructureMap API
Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms
Declaration Syntax
C# Visual Basic Visual C++
CreatePluginFamilyExpression<PLUGINTYPE> ForRequestedType<PLUGINTYPE>()

Function ForRequestedType(Of PLUGINTYPE) As CreatePluginFamilyExpression(Of PLUGINTYPE)
generic<typename PLUGINTYPE>
CreatePluginFamilyExpression<PLUGINTYPE>^ ForRequestedType()
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.IInitializationExpression.ForRequestedType``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.IInitializationExpression.ForRequestedType``1]


ForRequestedType Method (pluginType)

ForRequestedType Method (pluginType)
Namespaces ► StructureMap ► IInitializationExpression ► ForRequestedType(Type)
StructureMap API
Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. This method is specifically meant for registering open generic types
Declaration Syntax
C# Visual Basic Visual C++
GenericFamilyExpression ForRequestedType(
    Type pluginType
)
Function ForRequestedType ( _
    pluginType As Type _
) As GenericFamilyExpression
GenericFamilyExpression^ ForRequestedType(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.IInitializationExpression.ForRequestedType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IInitializationExpression.ForRequestedType(System.Type)]


IfTypeMatches Method (match)

IfTypeMatches Method (match)
Namespaces ► StructureMap ► IInitializationExpression ► IfTypeMatches(Predicate<(Of <(Type>)>))
StructureMap API
Allows you to define a TypeInterceptor inline with Lambdas or anonymous delegates
Declaration Syntax
C# Visual Basic Visual C++
MatchedTypeInterceptor IfTypeMatches(
    Predicate<Type> match
)
Function IfTypeMatches ( _
    match As Predicate(Of Type) _
) As MatchedTypeInterceptor
MatchedTypeInterceptor^ IfTypeMatches(
    Predicate<Type^>^ match
)
Parameters
match (Predicate <(Of <( Type >)>))

[Missing <param name="match"/> documentation for "M:StructureMap.IInitializationExpression.IfTypeMatches(System.Predicate{System.Type})"]

Return Value

[Missing <returns> documentation for M:StructureMap.IInitializationExpression.IfTypeMatches(System.Predicate{System.Type})]

Examples
IfTypeMatches( ... ).InterceptWith( o => new ObjectWrapper(o) );


IgnoreStructureMapConfig Property

IgnoreStructureMapConfig Property
Namespaces ► StructureMap ► IInitializationExpression ► IgnoreStructureMapConfig
StructureMap API
If true, the StructureMap.config file will be ignored even if it exists. The default is false.
Declaration Syntax
C# Visual Basic Visual C++
bool IgnoreStructureMapConfig { set; }
WriteOnly Property IgnoreStructureMapConfig As Boolean
property bool IgnoreStructureMapConfig {
    void set (bool value);
}


InstanceOf Method

InstanceOf Method
Namespaces ► StructureMap ► IInitializationExpression ► InstanceOf()()()
StructureMap API
Members
Icon | Member | Description
 | InstanceOf<(Of <(T>)>)()()() | Adds an additional, non-Default Instance to the PluginType T.
 | InstanceOf(Type) | Adds an additional, non-Default Instance to the designated pluginType This method is mostly meant for open generic types


InstanceOf Method

InstanceOf<(Of <(T>)>) Method
Namespaces ► StructureMap ► IInitializationExpression ► InstanceOf<(Of <(T>)>)()()()
StructureMap API
Adds an additional, non-Default Instance to the PluginType T.
Declaration Syntax
C# Visual Basic Visual C++
IsExpression<T> InstanceOf<T>()

Function InstanceOf(Of T) As IsExpression(Of T)
generic<typename T>
IsExpression<T>^ InstanceOf()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IInitializationExpression.InstanceOf``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.IInitializationExpression.InstanceOf``1]


InstanceOf Method (pluginType)

InstanceOf Method (pluginType)
Namespaces ► StructureMap ► IInitializationExpression ► InstanceOf(Type)
StructureMap API
Adds an additional, non-Default Instance to the designated pluginType This method is mostly meant for open generic types
Declaration Syntax
C# Visual Basic Visual C++
GenericIsExpression InstanceOf(
    Type pluginType
)
Function InstanceOf ( _
    pluginType As Type _
) As GenericIsExpression
GenericIsExpression^ InstanceOf(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.IInitializationExpression.InstanceOf(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IInitializationExpression.InstanceOf(System.Type)]


PullConfigurationFromAppConfig Property

PullConfigurationFromAppConfig Property
Namespaces ► StructureMap ► IInitializationExpression ► PullConfigurationFromAppConfig
StructureMap API
If true, directs StructureMap to look for configuration in the App.config. The default value is false.
Declaration Syntax
C# Visual Basic Visual C++
bool PullConfigurationFromAppConfig { set; }
WriteOnly Property PullConfigurationFromAppConfig As Boolean
property bool PullConfigurationFromAppConfig {
    void set (bool value);
}


RegisterInterceptor Method (interceptor)

RegisterInterceptor Method (interceptor)
Namespaces ► StructureMap ► IInitializationExpression ► RegisterInterceptor(TypeInterceptor)
StructureMap API
Registers a new TypeInterceptor object with the Container
Declaration Syntax
C# Visual Basic Visual C++
void RegisterInterceptor(
    TypeInterceptor interceptor
)
Sub RegisterInterceptor ( _
    interceptor As TypeInterceptor _
)
void RegisterInterceptor(
    TypeInterceptor^ interceptor
)
Parameters
interceptor (TypeInterceptor)

[Missing <param name="interceptor"/> documentation for "M:StructureMap.IInitializationExpression.RegisterInterceptor(StructureMap.Interceptors.TypeInterceptor)"]


Scan Method (action)

Scan Method (action)
Namespaces ► StructureMap ► IInitializationExpression ► Scan(Action<(Of <(IAssemblyScanner>)>))
StructureMap API
Expresses a single "Scanning" action
Declaration Syntax
C# Visual Basic Visual C++
void Scan(
    Action<IAssemblyScanner> action
)
Sub Scan ( _
    action As Action(Of IAssemblyScanner) _
)
void Scan(
    Action<IAssemblyScanner^>^ action
)
Parameters
action (Action <(Of <( IAssemblyScanner >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.IInitializationExpression.Scan(System.Action{StructureMap.Graph.IAssemblyScanner})"]

Examples
Scan(x => {
    x.Assembly("Foo.Services");
    x.WithDefaultConventions();
});


UseDefaultStructureMapConfigFile Property

UseDefaultStructureMapConfigFile Property
Namespaces ► StructureMap ► IInitializationExpression ► UseDefaultStructureMapConfigFile
StructureMap API
If true, makes the existence of the StructureMap.config mandatory. The default is false.
Declaration Syntax
C# Visual Basic Visual C++
bool UseDefaultStructureMapConfigFile { set; }
WriteOnly Property UseDefaultStructureMapConfigFile As Boolean
property bool UseDefaultStructureMapConfigFile {
    void set (bool value);
}


IInstanceFactory Interface

IInstanceFactory Interface
Namespaces ► StructureMap ► IInstanceFactory
StructureMap API
Interface for a "Factory" pattern class that creates object instances of the PluginType
Declaration Syntax
C# Visual Basic Visual C++
public interface IInstanceFactory
Public Interface IInstanceFactory
public interface class IInstanceFactory
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddInstance(Instance) |
 | AddType<(Of <(T>)>)()()() |
 | Build(BuildSession, Instance) |
 | EjectAllInstances()()() |
 | FindInstance(String) |
 | ForEachInstance(Action<(Of <(Instance>)>)) |
 | GetAllInstances(BuildSession) |
 | ImportFrom(PluginFamily) |
 | Instances |
 | PluginType |
 | Policy |


AddInstance Method (instance)

AddInstance Method (instance)
Namespaces ► StructureMap ► IInstanceFactory ► AddInstance(Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.IInstanceFactory.AddInstance(StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
void AddInstance(
    Instance instance
)
Sub AddInstance ( _
    instance As Instance _
)
void AddInstance(
    Instance^ instance
)
Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.IInstanceFactory.AddInstance(StructureMap.Pipeline.Instance)"]


AddType Method

AddType<(Of <(T>)>) Method
Namespaces ► StructureMap ► IInstanceFactory ► AddType<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.IInstanceFactory.AddType``1]

Declaration Syntax
C# Visual Basic Visual C++
Instance AddType<T>()

Function AddType(Of T) As Instance
generic<typename T>
Instance^ AddType()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IInstanceFactory.AddType``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.IInstanceFactory.AddType``1]


Build Method (session, instance)

Build Method (session, instance)
Namespaces ► StructureMap ► IInstanceFactory ► Build(BuildSession, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.IInstanceFactory.Build(StructureMap.BuildSession,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
Object Build(
    BuildSession session,
    Instance instance
)
Function Build ( _
    session As BuildSession, _
    instance As Instance _
) As Object
Object^ Build(
    BuildSession^ session,
    Instance^ instance
)
Parameters
session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.IInstanceFactory.Build(StructureMap.BuildSession,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.IInstanceFactory.Build(StructureMap.BuildSession,StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IInstanceFactory.Build(StructureMap.BuildSession,StructureMap.Pipeline.Instance)]


EjectAllInstances Method

EjectAllInstances Method
Namespaces ► StructureMap ► IInstanceFactory ► EjectAllInstances()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.IInstanceFactory.EjectAllInstances]

Declaration Syntax
C# Visual Basic Visual C++
void EjectAllInstances()
Sub EjectAllInstances
void EjectAllInstances()


FindInstance Method (name)

FindInstance Method (name)
Namespaces ► StructureMap ► IInstanceFactory ► FindInstance(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.IInstanceFactory.FindInstance(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
Instance FindInstance(
    string name
)
Function FindInstance ( _
    name As String _
) As Instance
Instance^ FindInstance(
    String^ name
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.IInstanceFactory.FindInstance(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IInstanceFactory.FindInstance(System.String)]


ForEachInstance Method (action)

ForEachInstance Method (action)
Namespaces ► StructureMap ► IInstanceFactory ► ForEachInstance(Action<(Of <(Instance>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.IInstanceFactory.ForEachInstance(System.Action{StructureMap.Pipeline.Instance})]

Declaration Syntax
C# Visual Basic Visual C++
void ForEachInstance(
    Action<Instance> action
)
Sub ForEachInstance ( _
    action As Action(Of Instance) _
)
void ForEachInstance(
    Action<Instance^>^ action
)
Parameters
action (Action <(Of <( Instance >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.IInstanceFactory.ForEachInstance(System.Action{StructureMap.Pipeline.Instance})"]


GetAllInstances Method (session)

GetAllInstances Method (session)
Namespaces ► StructureMap ► IInstanceFactory ► GetAllInstances(BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.IInstanceFactory.GetAllInstances(StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
IList GetAllInstances(
    BuildSession session
)
Function GetAllInstances ( _
    session As BuildSession _
) As IList
IList^ GetAllInstances(
    BuildSession^ session
)
Parameters
session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.IInstanceFactory.GetAllInstances(StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IInstanceFactory.GetAllInstances(StructureMap.BuildSession)]


ImportFrom Method (family)

ImportFrom Method (family)
Namespaces ► StructureMap ► IInstanceFactory ► ImportFrom(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.IInstanceFactory.ImportFrom(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
void ImportFrom(
    PluginFamily family
)
Sub ImportFrom ( _
    family As PluginFamily _
)
void ImportFrom(
    PluginFamily^ family
)
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.IInstanceFactory.ImportFrom(StructureMap.Graph.PluginFamily)"]


Instances Property

Instances Property
Namespaces ► StructureMap ► IInstanceFactory ► Instances
StructureMap API

[Missing <summary> documentation for P:StructureMap.IInstanceFactory.Instances]

Declaration Syntax
C# Visual Basic Visual C++
IEnumerable<IInstance> Instances { get; }
ReadOnly Property Instances As IEnumerable(Of IInstance)
property IEnumerable<IInstance^>^ Instances {
    IEnumerable<IInstance^>^ get ();
}


PluginType Property

PluginType Property
Namespaces ► StructureMap ► IInstanceFactory ► PluginType
StructureMap API

[Missing <summary> documentation for P:StructureMap.IInstanceFactory.PluginType]

Declaration Syntax
C# Visual Basic Visual C++
Type PluginType { get; }
ReadOnly Property PluginType As Type
property Type^ PluginType {
    Type^ get ();
}


Policy Property

Policy Property
Namespaces ► StructureMap ► IInstanceFactory ► Policy
StructureMap API

[Missing <summary> documentation for P:StructureMap.IInstanceFactory.Policy]

Declaration Syntax
C# Visual Basic Visual C++
IBuildPolicy Policy { get; }
ReadOnly Property Policy As IBuildPolicy
property IBuildPolicy^ Policy {
    IBuildPolicy^ get ();
}


IModel Interface

IModel Interface
Namespaces ► StructureMap ► IModel
StructureMap API
Models the state of a Container or ObjectFactory. Can be used to query for the existence of types registered with StructureMap
Declaration Syntax
C# Visual Basic Visual C++
public interface IModel
Public Interface IModel
public interface class IModel
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | HasDefaultImplementationFor(Type) | Can StructureMap fulfill a request to ObjectFactory.GetInstance(pluginType) from the current configuration. This does not include concrete classes that could be auto-configured upon demand
 | HasDefaultImplementationFor<(Of <(T>)>)()()() |
 | HasImplementationsFor(Type) | Does the current container have existing configuration for the "pluginType"
 | HasImplementationsFor<(Of <(T>)>)()()() | Does the current container have existing configuration for the type T
 | InstancesOf(Type) | Queryable access to all of the IInstance for a given PluginType
 | InstancesOf<(Of <(T>)>)()()() | Queryable access to all of the IInstance for a given PluginType
 | PluginTypes | Access to all the registrations


HasDefaultImplementationFor Method

HasDefaultImplementationFor Method
Namespaces ► StructureMap ► IModel ► HasDefaultImplementationFor()()()
StructureMap API
Members
Icon | Member | Description
 | HasDefaultImplementationFor(Type) | Can StructureMap fulfill a request to ObjectFactory.GetInstance(pluginType) from the current configuration. This does not include concrete classes that could be auto-configured upon demand
 | HasDefaultImplementationFor<(Of <(T>)>)()()() |


HasDefaultImplementationFor Method

HasDefaultImplementationFor<(Of <(T>)>) Method
Namespaces ► StructureMap ► IModel ► HasDefaultImplementationFor<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.IModel.HasDefaultImplementationFor``1]

Declaration Syntax
C# Visual Basic Visual C++
bool HasDefaultImplementationFor<T>()

Function HasDefaultImplementationFor(Of T) As Boolean
generic<typename T>
bool HasDefaultImplementationFor()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IModel.HasDefaultImplementationFor``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.IModel.HasDefaultImplementationFor``1]


HasDefaultImplementationFor Method (pluginType)

HasDefaultImplementationFor Method (pluginType)
Namespaces ► StructureMap ► IModel ► HasDefaultImplementationFor(Type)
StructureMap API
Can StructureMap fulfill a request to ObjectFactory.GetInstance(pluginType) from the current configuration. This does not include concrete classes that could be auto-configured upon demand
Declaration Syntax
C# Visual Basic Visual C++
bool HasDefaultImplementationFor(
    Type pluginType
)
Function HasDefaultImplementationFor ( _
    pluginType As Type _
) As Boolean
bool HasDefaultImplementationFor(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.IModel.HasDefaultImplementationFor(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IModel.HasDefaultImplementationFor(System.Type)]


HasImplementationsFor Method

HasImplementationsFor Method
Namespaces ► StructureMap ► IModel ► HasImplementationsFor()()()
StructureMap API
Members
Icon | Member | Description
 | HasImplementationsFor(Type) | Does the current container have existing configuration for the "pluginType"
 | HasImplementationsFor<(Of <(T>)>)()()() | Does the current container have existing configuration for the type T


HasImplementationsFor Method

HasImplementationsFor<(Of <(T>)>) Method
Namespaces ► StructureMap ► IModel ► HasImplementationsFor<(Of <(T>)>)()()()
StructureMap API
Does the current container have existing configuration for the type T
Declaration Syntax
C# Visual Basic Visual C++
bool HasImplementationsFor<T>()

Function HasImplementationsFor(Of T) As Boolean
generic<typename T>
bool HasImplementationsFor()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IModel.HasImplementationsFor``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.IModel.HasImplementationsFor``1]


HasImplementationsFor Method (pluginType)

HasImplementationsFor Method (pluginType)
Namespaces ► StructureMap ► IModel ► HasImplementationsFor(Type)
StructureMap API
Does the current container have existing configuration for the "pluginType"
Declaration Syntax
C# Visual Basic Visual C++
bool HasImplementationsFor(
    Type pluginType
)
Function HasImplementationsFor ( _
    pluginType As Type _
) As Boolean
bool HasImplementationsFor(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.IModel.HasImplementationsFor(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IModel.HasImplementationsFor(System.Type)]


InstancesOf Method

InstancesOf Method
Namespaces ► StructureMap ► IModel ► InstancesOf()()()
StructureMap API
Members
Icon | Member | Description
 | InstancesOf(Type) | Queryable access to all of the IInstance for a given PluginType
 | InstancesOf<(Of <(T>)>)()()() | Queryable access to all of the IInstance for a given PluginType


InstancesOf Method

InstancesOf<(Of <(T>)>) Method
Namespaces ► StructureMap ► IModel ► InstancesOf<(Of <(T>)>)()()()
StructureMap API
Queryable access to all of the IInstance for a given PluginType
Declaration Syntax
C# Visual Basic Visual C++
IEnumerable<IInstance> InstancesOf<T>()

Function InstancesOf(Of T) As IEnumerable(Of IInstance)
generic<typename T>
IEnumerable<IInstance^>^ InstancesOf()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.IModel.InstancesOf``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.IModel.InstancesOf``1]


InstancesOf Method (pluginType)

InstancesOf Method (pluginType)
Namespaces ► StructureMap ► IModel ► InstancesOf(Type)
StructureMap API
Queryable access to all of the IInstance for a given PluginType
Declaration Syntax
C# Visual Basic Visual C++
IEnumerable<IInstance> InstancesOf(
    Type pluginType
)
Function InstancesOf ( _
    pluginType As Type _
) As IEnumerable(Of IInstance)
IEnumerable<IInstance^>^ InstancesOf(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.IModel.InstancesOf(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.IModel.InstancesOf(System.Type)]


PluginTypes Property

PluginTypes Property
Namespaces ► StructureMap ► IModel ► PluginTypes
StructureMap API
Access to all the registrations
Declaration Syntax
C# Visual Basic Visual C++
IEnumerable<PluginTypeConfiguration> PluginTypes { get; }
ReadOnly Property PluginTypes As IEnumerable(Of PluginTypeConfiguration)
property IEnumerable<PluginTypeConfiguration^>^ PluginTypes {
    IEnumerable<PluginTypeConfiguration^>^ get ();
}
See Also
PluginType


InitializationExpression Class

InitializationExpression Class
Namespaces ► StructureMap ► InitializationExpression
StructureMap API

[Missing <summary> documentation for T:StructureMap.InitializationExpression]

Declaration Syntax
C# Visual Basic Visual C++
public class InitializationExpression : ConfigurationExpression,
    IInitializationExpression
Public Class InitializationExpression _
    Inherits ConfigurationExpression _
    Implements IInitializationExpression
public ref class InitializationExpression : public ConfigurationExpression,
    IInitializationExpression
Members
All Members | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | _log | (Inherited from ConfigurationExpression.)
 | _parserBuilder | (Inherited from ConfigurationExpression.)
 | AddConfigurationFromNode(XmlNode) | Imports configuration directly from an XmlNode. This method was intended for scenarios like Xml being embedded into an assembly. The node must be a 'StructureMap' node (Inherited from ConfigurationExpression.)
 | AddConfigurationFromXmlFile(String) | Imports configuration from an Xml file. The fileName must point to an Xml file with valid StructureMap configuration (Inherited from ConfigurationExpression.)
 | AddRegistry<(Of <(T>)>)()()() | Creates and adds a Registry object of type T. (Inherited from ConfigurationExpression.)
 | AddRegistry(Registry) | Imports all the configuration from a Registry object (Inherited from ConfigurationExpression.)
 | Build()()() | Uses the configuration expressions of this Registry to create a PluginGraph object that could be used to initialize a Container. This method is mostly for internal usage, but might be helpful for diagnostics (Inherited from Registry.)
 | BuildInstancesOf<(Of <(PLUGINTYPE>)>)()()() | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms (Inherited from Registry.)
 | configure()()() | You can overide this method as a place to put the Registry DSL declarations. This is not mandatory. (Inherited from Registry.)
 | CreateProfile(String) | Expression Builder to define the defaults for a named Profile. Each call to CreateProfile is additive. (Inherited from Registry.)
 | CreateProfile(String, Action<(Of <(ProfileExpression>)>)) | An alternative way to use CreateProfile that uses ProfileExpression as a Nested Closure. This usage will result in cleaner code for multiple declarations (Inherited from Registry.)
 | DefaultProfileName |
 | Equals(Registry) | (Inherited from Registry.)
 | Equals(Object) | (Inherited from Registry.)
 | FillAllPropertiesOfType<(Of <(PLUGINTYPE>)>)()()() | Directs StructureMap to always inject dependencies into any and all public Setter properties of the type PLUGINTYPE. (Inherited from Registry.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | ForConcreteType<(Of <(T>)>)()()() | This method is a shortcut for specifying the default constructor and setter arguments for a ConcreteType. ForConcreteType is shorthand for: ForRequestedType[T]().TheDefault.Is.OfConcreteType[T].************** when the PluginType and ConcreteType are the same Type (Inherited from Registry.)
 | ForRequestedType(Type) | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. This method is specifically meant for registering open generic types (Inherited from Registry.)
 | ForRequestedType<(Of <(PLUGINTYPE>)>)()()() | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms (Inherited from Registry.)
 | GetHashCode()()() | (Inherited from Registry.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IfTypeMatches(Predicate<(Of <(Type>)>)) | Allows you to define a TypeInterceptor inline with Lambdas or anonymous delegates (Inherited from Registry.)
 | IgnoreStructureMapConfig |
 | IncludeConfigurationFromConfigFile | If true, directs StructureMap to look for configuration in the App.config. The default value is false. (Inherited from ConfigurationExpression.)
 | InstanceOf<(Of <(T>)>)()()() | Adds an additional, non-Default Instance to the PluginType T. (Inherited from Registry.)
 | InstanceOf(Type) | Adds an additional, non-Default Instance to the designated pluginType This method is mostly meant for open generic types (Inherited from Registry.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PullConfigurationFromAppConfig |
 | registerAction(Action) | (Inherited from Registry.)
 | RegisterInterceptor(TypeInterceptor) | Registers a new TypeInterceptor object with the Container (Inherited from Registry.)
 | Scan(Action<(Of <(IAssemblyScanner>)>)) | Designates a policy for scanning assemblies to auto register types (Inherited from Registry.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseDefaultStructureMapConfigFile |
Inheritance Hierarchy
Object
 | Registry
 |  | ConfigurationExpression
 |  |  | InitializationExpression


DefaultProfileName Property

DefaultProfileName Property
Namespaces ► StructureMap ► InitializationExpression ► DefaultProfileName
StructureMap API

[Missing <summary> documentation for P:StructureMap.InitializationExpression.DefaultProfileName]

Declaration Syntax
C# Visual Basic Visual C++
public string DefaultProfileName { get; set; }
Public Property DefaultProfileName As String
public:
virtual property String^ DefaultProfileName {
    String^ get () sealed;
    void set (String^ value) sealed;
}


IgnoreStructureMapConfig Property

IgnoreStructureMapConfig Property
Namespaces ► StructureMap ► InitializationExpression ► IgnoreStructureMapConfig
StructureMap API

[Missing <summary> documentation for P:StructureMap.InitializationExpression.IgnoreStructureMapConfig]

Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreStructureMapConfig { set; }
Public WriteOnly Property IgnoreStructureMapConfig As Boolean
public:
virtual property bool IgnoreStructureMapConfig {
    void set (bool value) sealed;
}


PullConfigurationFromAppConfig Property

PullConfigurationFromAppConfig Property
Namespaces ► StructureMap ► InitializationExpression ► PullConfigurationFromAppConfig
StructureMap API

[Missing <summary> documentation for P:StructureMap.InitializationExpression.PullConfigurationFromAppConfig]

Declaration Syntax
C# Visual Basic Visual C++
public bool PullConfigurationFromAppConfig { set; }
Public WriteOnly Property PullConfigurationFromAppConfig As Boolean
public:
virtual property bool PullConfigurationFromAppConfig {
    void set (bool value) sealed;
}


UseDefaultStructureMapConfigFile Property

UseDefaultStructureMapConfigFile Property
Namespaces ► StructureMap ► InitializationExpression ► UseDefaultStructureMapConfigFile
StructureMap API

[Missing <summary> documentation for P:StructureMap.InitializationExpression.UseDefaultStructureMapConfigFile]

Declaration Syntax
C# Visual Basic Visual C++
public bool UseDefaultStructureMapConfigFile { set; }
Public WriteOnly Property UseDefaultStructureMapConfigFile As Boolean
public:
virtual property bool UseDefaultStructureMapConfigFile {
    void set (bool value) sealed;
}


InstanceBuilder Class

InstanceBuilder Class
Namespaces ► StructureMap ► InstanceBuilder
StructureMap API
Base class for creating an object instance from an InstanceMemento. SubClasses are emitted for each concrete Plugin with constructor parameters.
Declaration Syntax
C# Visual Basic Visual C++
public abstract class InstanceBuilder
Public MustInherit Class InstanceBuilder
public ref class InstanceBuilder abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstanceBuilder()()() | Initializes a new instance of the InstanceBuilder class
 | BuildInstance(IConfiguredInstance, BuildSession) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PluggedType |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InstanceBuilder


InstanceBuilder Constructor

InstanceBuilder Constructor
Namespaces ► StructureMap ► InstanceBuilder ► InstanceBuilder()()()
StructureMap API
Initializes a new instance of the InstanceBuilder class
Declaration Syntax
C# Visual Basic Visual C++
public InstanceBuilder()
Public Sub New
public:
InstanceBuilder()


BuildInstance Method (instance, session)

BuildInstance Method (instance, session)
Namespaces ► StructureMap ► InstanceBuilder ► BuildInstance(IConfiguredInstance, BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceBuilder.BuildInstance(StructureMap.Pipeline.IConfiguredInstance,StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
public abstract Object BuildInstance(
    IConfiguredInstance instance,
    BuildSession session
)
Public MustOverride Function BuildInstance ( _
    instance As IConfiguredInstance, _
    session As BuildSession _
) As Object
public:
virtual Object^ BuildInstance(
    IConfiguredInstance^ instance,
    BuildSession^ session
) abstract
Parameters
instance (IConfiguredInstance)

[Missing <param name="instance"/> documentation for "M:StructureMap.InstanceBuilder.BuildInstance(StructureMap.Pipeline.IConfiguredInstance,StructureMap.BuildSession)"]

session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.InstanceBuilder.BuildInstance(StructureMap.Pipeline.IConfiguredInstance,StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceBuilder.BuildInstance(StructureMap.Pipeline.IConfiguredInstance,StructureMap.BuildSession)]


PluggedType Property

PluggedType Property
Namespaces ► StructureMap ► InstanceBuilder ► PluggedType
StructureMap API

[Missing <summary> documentation for P:StructureMap.InstanceBuilder.PluggedType]

Declaration Syntax
C# Visual Basic Visual C++
public abstract Type PluggedType { get; }
Public MustOverride ReadOnly Property PluggedType As Type
public:
virtual property Type^ PluggedType {
    Type^ get () abstract;
}


InstanceBuilderList Class

InstanceBuilderList Class
Namespaces ► StructureMap ► InstanceBuilderList
StructureMap API

[Missing <summary> documentation for T:StructureMap.InstanceBuilderList]

Declaration Syntax
C# Visual Basic Visual C++
public class InstanceBuilderList
Public Class InstanceBuilderList
public ref class InstanceBuilderList
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstanceBuilderList(Type, IEnumerable<(Of <(Plugin>)>)) | Initializes a new instance of the InstanceBuilderList class
 | InstanceBuilderList(Type) | Initializes a new instance of the InstanceBuilderList class
 | Add(Plugin) |
 | Add(IEnumerable<(Of <(Plugin>)>)) |
 | BuilderCount |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindByConcreteKey(String) |
 | FindByType(Type) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InstanceBuilderList


InstanceBuilderList Constructor

InstanceBuilderList Constructor
Namespaces ► StructureMap ► InstanceBuilderList ► InstanceBuilderList()()()
StructureMap API
Members
Icon | Member | Description
 | InstanceBuilderList(Type, IEnumerable<(Of <(Plugin>)>)) | Initializes a new instance of the InstanceBuilderList class
 | InstanceBuilderList(Type) | Initializes a new instance of the InstanceBuilderList class


InstanceBuilderList Constructor (pluginType)

InstanceBuilderList Constructor (pluginType)
Namespaces ► StructureMap ► InstanceBuilderList ► InstanceBuilderList(Type)
StructureMap API
Initializes a new instance of the InstanceBuilderList class
Declaration Syntax
C# Visual Basic Visual C++
public InstanceBuilderList(
    Type pluginType
)
Public Sub New ( _
    pluginType As Type _
)
public:
InstanceBuilderList(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.InstanceBuilderList.#ctor(System.Type)"]


InstanceBuilderList Constructor (pluginType, plugins)

InstanceBuilderList Constructor (pluginType, plugins)
Namespaces ► StructureMap ► InstanceBuilderList ► InstanceBuilderList(Type, IEnumerable<(Of <(Plugin>)>))
StructureMap API
Initializes a new instance of the InstanceBuilderList class
Declaration Syntax
C# Visual Basic Visual C++
public InstanceBuilderList(
    Type pluginType,
    IEnumerable<Plugin> plugins
)
Public Sub New ( _
    pluginType As Type, _
    plugins As IEnumerable(Of Plugin) _
)
public:
InstanceBuilderList(
    Type^ pluginType,
    IEnumerable<Plugin^>^ plugins
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.InstanceBuilderList.#ctor(System.Type,System.Collections.Generic.IEnumerable{StructureMap.Graph.Plugin})"]

plugins (IEnumerable <(Of <( Plugin >)>))

[Missing <param name="plugins"/> documentation for "M:StructureMap.InstanceBuilderList.#ctor(System.Type,System.Collections.Generic.IEnumerable{StructureMap.Graph.Plugin})"]


Add Method

Add Method
Namespaces ► StructureMap ► InstanceBuilderList ► Add()()()
StructureMap API
Members
Icon | Member | Description
 | Add(Plugin) |
 | Add(IEnumerable<(Of <(Plugin>)>)) |


Add Method (plugin)

Add Method (plugin)
Namespaces ► StructureMap ► InstanceBuilderList ► Add(Plugin)
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceBuilderList.Add(StructureMap.Graph.Plugin)]

Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    Plugin plugin
)
Public Sub Add ( _
    plugin As Plugin _
)
public:
void Add(
    Plugin^ plugin
)
Parameters
plugin (Plugin)

[Missing <param name="plugin"/> documentation for "M:StructureMap.InstanceBuilderList.Add(StructureMap.Graph.Plugin)"]


Add Method (plugins)

Add Method (plugins)
Namespaces ► StructureMap ► InstanceBuilderList ► Add(IEnumerable<(Of <(Plugin>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceBuilderList.Add(System.Collections.Generic.IEnumerable{StructureMap.Graph.Plugin})]

Declaration Syntax
C# Visual Basic Visual C++
public void Add(
    IEnumerable<Plugin> plugins
)
Public Sub Add ( _
    plugins As IEnumerable(Of Plugin) _
)
public:
void Add(
    IEnumerable<Plugin^>^ plugins
)
Parameters
plugins (IEnumerable <(Of <( Plugin >)>))

[Missing <param name="plugins"/> documentation for "M:StructureMap.InstanceBuilderList.Add(System.Collections.Generic.IEnumerable{StructureMap.Graph.Plugin})"]


BuilderCount Property

BuilderCount Property
Namespaces ► StructureMap ► InstanceBuilderList ► BuilderCount
StructureMap API

[Missing <summary> documentation for P:StructureMap.InstanceBuilderList.BuilderCount]

Declaration Syntax
C# Visual Basic Visual C++
public int BuilderCount { get; }
Public ReadOnly Property BuilderCount As Integer
public:
property int BuilderCount {
    int get ();
}


FindByConcreteKey Method (concreteKey)

FindByConcreteKey Method (concreteKey)
Namespaces ► StructureMap ► InstanceBuilderList ► FindByConcreteKey(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceBuilderList.FindByConcreteKey(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public InstanceBuilder FindByConcreteKey(
    string concreteKey
)
Public Function FindByConcreteKey ( _
    concreteKey As String _
) As InstanceBuilder
public:
InstanceBuilder^ FindByConcreteKey(
    String^ concreteKey
)
Parameters
concreteKey (String)

[Missing <param name="concreteKey"/> documentation for "M:StructureMap.InstanceBuilderList.FindByConcreteKey(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceBuilderList.FindByConcreteKey(System.String)]


FindByType Method (pluggedType)

FindByType Method (pluggedType)
Namespaces ► StructureMap ► InstanceBuilderList ► FindByType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceBuilderList.FindByType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public InstanceBuilder FindByType(
    Type pluggedType
)
Public Function FindByType ( _
    pluggedType As Type _
) As InstanceBuilder
public:
InstanceBuilder^ FindByType(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.InstanceBuilderList.FindByType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceBuilderList.FindByType(System.Type)]


InstanceFactory Class

InstanceFactory Class
Namespaces ► StructureMap ► InstanceFactory
StructureMap API
Default implementation of IInstanceFactory
Declaration Syntax
C# Visual Basic Visual C++
public class InstanceFactory : IInstanceFactory
Public Class InstanceFactory _
    Implements IInstanceFactory
public ref class InstanceFactory : IInstanceFactory
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstanceFactory(Type) | Initializes a new instance of the InstanceFactory class
 | InstanceFactory(PluginFamily) | Constructor to use when troubleshooting possible configuration issues.
 | AddInstance(Instance) |
 | AddType<(Of <(T>)>)()()() | Obsolete.
 | Build(BuildSession, Instance) |
 | CreateFactoryForType(Type, ProfileManager) |
 | EjectAllInstances()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindInstance(String) |
 | ForEachInstance(Action<(Of <(Instance>)>)) |
 | GetAllInstances(BuildSession) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImportFrom(PluginFamily) |
 | Instances |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PluginType |
 | Policy |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InstanceFactory


InstanceFactory Constructor

InstanceFactory Constructor
Namespaces ► StructureMap ► InstanceFactory ► InstanceFactory()()()
StructureMap API
Members
Icon | Member | Description
 | InstanceFactory(Type) | Initializes a new instance of the InstanceFactory class
 | InstanceFactory(PluginFamily) | Constructor to use when troubleshooting possible configuration issues.


InstanceFactory Constructor (family)

InstanceFactory Constructor (family)
Namespaces ► StructureMap ► InstanceFactory ► InstanceFactory(PluginFamily)
StructureMap API
Constructor to use when troubleshooting possible configuration issues.
Declaration Syntax
C# Visual Basic Visual C++
public InstanceFactory(
    PluginFamily family
)
Public Sub New ( _
    family As PluginFamily _
)
public:
InstanceFactory(
    PluginFamily^ family
)
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.InstanceFactory.#ctor(StructureMap.Graph.PluginFamily)"]


InstanceFactory Constructor (pluginType)

InstanceFactory Constructor (pluginType)
Namespaces ► StructureMap ► InstanceFactory ► InstanceFactory(Type)
StructureMap API
Initializes a new instance of the InstanceFactory class
Declaration Syntax
C# Visual Basic Visual C++
public InstanceFactory(
    Type pluginType
)
Public Sub New ( _
    pluginType As Type _
)
public:
InstanceFactory(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.InstanceFactory.#ctor(System.Type)"]


AddInstance Method (instance)

AddInstance Method (instance)
Namespaces ► StructureMap ► InstanceFactory ► AddInstance(Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceFactory.AddInstance(StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddInstance(
    Instance instance
)
Public Sub AddInstance ( _
    instance As Instance _
)
public:
virtual void AddInstance(
    Instance^ instance
) sealed
Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.InstanceFactory.AddInstance(StructureMap.Pipeline.Instance)"]


AddType Method

AddType<(Of <(T>)>) Method
Namespaces ► StructureMap ► InstanceFactory ► AddType<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceFactory.AddType``1]

Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute]
public Instance AddType<T>()

<ObsoleteAttribute> _
Public Function AddType(Of T) As Instance
[ObsoleteAttribute]
public:
generic<typename T>
virtual Instance^ AddType() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.InstanceFactory.AddType``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceFactory.AddType``1]


Build Method (session, instance)

Build Method (session, instance)
Namespaces ► StructureMap ► InstanceFactory ► Build(BuildSession, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceFactory.Build(StructureMap.BuildSession,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public Object Build(
    BuildSession session,
    Instance instance
)
Public Function Build ( _
    session As BuildSession, _
    instance As Instance _
) As Object
public:
virtual Object^ Build(
    BuildSession^ session,
    Instance^ instance
) sealed
Parameters
session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.InstanceFactory.Build(StructureMap.BuildSession,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.InstanceFactory.Build(StructureMap.BuildSession,StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceFactory.Build(StructureMap.BuildSession,StructureMap.Pipeline.Instance)]


CreateFactoryForType Method (concreteType, profileManager)

CreateFactoryForType Method (concreteType, profileManager)
Namespaces ► StructureMap ► InstanceFactory ► CreateFactoryForType(Type, ProfileManager)
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceFactory.CreateFactoryForType(System.Type,StructureMap.Pipeline.ProfileManager)]

Declaration Syntax
C# Visual Basic Visual C++
public static InstanceFactory CreateFactoryForType(
    Type concreteType,
    ProfileManager profileManager
)
Public Shared Function CreateFactoryForType ( _
    concreteType As Type, _
    profileManager As ProfileManager _
) As InstanceFactory
public:
static InstanceFactory^ CreateFactoryForType(
    Type^ concreteType,
    ProfileManager^ profileManager
)
Parameters
concreteType (Type)

[Missing <param name="concreteType"/> documentation for "M:StructureMap.InstanceFactory.CreateFactoryForType(System.Type,StructureMap.Pipeline.ProfileManager)"]

profileManager (ProfileManager)

[Missing <param name="profileManager"/> documentation for "M:StructureMap.InstanceFactory.CreateFactoryForType(System.Type,StructureMap.Pipeline.ProfileManager)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceFactory.CreateFactoryForType(System.Type,StructureMap.Pipeline.ProfileManager)]


EjectAllInstances Method

EjectAllInstances Method
Namespaces ► StructureMap ► InstanceFactory ► EjectAllInstances()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceFactory.EjectAllInstances]

Declaration Syntax
C# Visual Basic Visual C++
public void EjectAllInstances()
Public Sub EjectAllInstances
public:
virtual void EjectAllInstances() sealed


FindInstance Method (name)

FindInstance Method (name)
Namespaces ► StructureMap ► InstanceFactory ► FindInstance(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceFactory.FindInstance(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public Instance FindInstance(
    string name
)
Public Function FindInstance ( _
    name As String _
) As Instance
public:
virtual Instance^ FindInstance(
    String^ name
) sealed
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.InstanceFactory.FindInstance(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceFactory.FindInstance(System.String)]


ForEachInstance Method (action)

ForEachInstance Method (action)
Namespaces ► StructureMap ► InstanceFactory ► ForEachInstance(Action<(Of <(Instance>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceFactory.ForEachInstance(System.Action{StructureMap.Pipeline.Instance})]

Declaration Syntax
C# Visual Basic Visual C++
public void ForEachInstance(
    Action<Instance> action
)
Public Sub ForEachInstance ( _
    action As Action(Of Instance) _
)
public:
virtual void ForEachInstance(
    Action<Instance^>^ action
) sealed
Parameters
action (Action <(Of <( Instance >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.InstanceFactory.ForEachInstance(System.Action{StructureMap.Pipeline.Instance})"]


GetAllInstances Method (session)

GetAllInstances Method (session)
Namespaces ► StructureMap ► InstanceFactory ► GetAllInstances(BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceFactory.GetAllInstances(StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
public IList GetAllInstances(
    BuildSession session
)
Public Function GetAllInstances ( _
    session As BuildSession _
) As IList
public:
virtual IList^ GetAllInstances(
    BuildSession^ session
) sealed
Parameters
session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.InstanceFactory.GetAllInstances(StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceFactory.GetAllInstances(StructureMap.BuildSession)]


ImportFrom Method (family)

ImportFrom Method (family)
Namespaces ► StructureMap ► InstanceFactory ► ImportFrom(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceFactory.ImportFrom(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
public void ImportFrom(
    PluginFamily family
)
Public Sub ImportFrom ( _
    family As PluginFamily _
)
public:
virtual void ImportFrom(
    PluginFamily^ family
) sealed
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.InstanceFactory.ImportFrom(StructureMap.Graph.PluginFamily)"]


Instances Property

Instances Property
Namespaces ► StructureMap ► InstanceFactory ► Instances
StructureMap API

[Missing <summary> documentation for P:StructureMap.InstanceFactory.Instances]

Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<IInstance> Instances { get; }
Public ReadOnly Property Instances As IEnumerable(Of IInstance)
public:
virtual property IEnumerable<IInstance^>^ Instances {
    IEnumerable<IInstance^>^ get () sealed;
}


PluginType Property

PluginType Property
Namespaces ► StructureMap ► InstanceFactory ► PluginType
StructureMap API

[Missing <summary> documentation for P:StructureMap.InstanceFactory.PluginType]

Declaration Syntax
C# Visual Basic Visual C++
public Type PluginType { get; }
Public ReadOnly Property PluginType As Type
public:
virtual property Type^ PluginType {
    Type^ get () sealed;
}


Policy Property

Policy Property
Namespaces ► StructureMap ► InstanceFactory ► Policy
StructureMap API

[Missing <summary> documentation for P:StructureMap.InstanceFactory.Policy]

Declaration Syntax
C# Visual Basic Visual C++
public IBuildPolicy Policy { get; }
Public ReadOnly Property Policy As IBuildPolicy
public:
virtual property IBuildPolicy^ Policy {
    IBuildPolicy^ get () sealed;
}


InstanceFamily Class

InstanceFamily Class
Namespaces ► StructureMap ► InstanceFamily
StructureMap API

[Missing <summary> documentation for T:StructureMap.InstanceFamily]

Declaration Syntax
C# Visual Basic Visual C++
public class InstanceFamily
Public Class InstanceFamily
public ref class InstanceFamily
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InstanceFamily()()() | Initializes a new instance of the InstanceFamily class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InstanceFamily


InstanceFamily Constructor

InstanceFamily Constructor
Namespaces ► StructureMap ► InstanceFamily ► InstanceFamily()()()
StructureMap API
Initializes a new instance of the InstanceFamily class
Declaration Syntax
C# Visual Basic Visual C++
public InstanceFamily()
Public Sub New
public:
InstanceFamily()


InstanceMemento Class

InstanceMemento Class
Namespaces ► StructureMap ► InstanceMemento
StructureMap API
GoF Memento representing an Object Instance
Declaration Syntax
C# Visual Basic Visual C++
public abstract class InstanceMemento
Public MustInherit Class InstanceMemento
public ref class InstanceMemento abstract
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstanceMemento()()() | Initializes a new instance of the InstanceMemento class
 | ConcreteKey | The named type of the object instance represented by the InstanceMemento. Translates to a concrete type
 | EMPTY_STRING |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindPlugin(PluginFamily) |
 | getChild(String) | Template method for implementation specific retrieval of the named property
 | GetChildMemento(String) | Returns the named child InstanceMemento
 | GetChildrenArray(String) | This method is made public for testing. It is not necessary for normal usage.
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | getPluggedType()()() |
 | GetProperty(String) | Retrieves the named property value as a string
 | getPropertyValue(String) | Template method for implementation specific retrieval of the named property
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | innerConcreteKey |
 | innerInstanceKey |
 | InstanceKey | The named key of the object instance represented by the InstanceMemento
 | IsDefault | Is the InstanceMemento a reference to the default instance of the plugin type?
 | IsReference | Template pattern property specifying whether the InstanceMemento is simply a reference to another named instance. Useful for child objects.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadChildInstance(String, PluginGraph, Type) |
 | readInstance(PluginGraph, Type) |
 | ReadInstance(PluginGraph, Type) |
 | ReferenceKey | Template pattern property specifying the instance key that the InstanceMemento refers to
 | Substitute(InstanceMemento) | Used to create a templated InstanceMemento
 | SUBSTITUTIONS_ATTRIBUTE |
 | TEMPLATE_ATTRIBUTE |
 | TemplateName | Gets the referred template name
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | InstanceMemento
 |  | MemoryInstanceMemento
 |  | XmlAttributeInstanceMemento
 |  | XmlNodeInstanceMemento


InstanceMemento Constructor

InstanceMemento Constructor
Namespaces ► StructureMap ► InstanceMemento ► InstanceMemento()()()
StructureMap API
Initializes a new instance of the InstanceMemento class
Declaration Syntax
C# Visual Basic Visual C++
protected InstanceMemento()
Protected Sub New
protected:
InstanceMemento()


ConcreteKey Property

ConcreteKey Property
Namespaces ► StructureMap ► InstanceMemento ► ConcreteKey
StructureMap API
The named type of the object instance represented by the InstanceMemento. Translates to a concrete type
Declaration Syntax
C# Visual Basic Visual C++
public string ConcreteKey { get; }
Public ReadOnly Property ConcreteKey As String
public:
property String^ ConcreteKey {
    String^ get ();
}


EMPTY_STRING Field

EMPTY_STRING Field
Namespaces ► StructureMap ► InstanceMemento ► EMPTY_STRING
StructureMap API

[Missing <summary> documentation for F:StructureMap.InstanceMemento.EMPTY_STRING]

Declaration Syntax
C# Visual Basic Visual C++
public const string EMPTY_STRING
Public Const EMPTY_STRING As String
public:
literal String^ EMPTY_STRING


FindPlugin Method (family)

FindPlugin Method (family)
Namespaces ► StructureMap ► InstanceMemento ► FindPlugin(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceMemento.FindPlugin(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
public virtual Plugin FindPlugin(
    PluginFamily family
)
Public Overridable Function FindPlugin ( _
    family As PluginFamily _
) As Plugin
public:
virtual Plugin^ FindPlugin(
    PluginFamily^ family
)
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.InstanceMemento.FindPlugin(StructureMap.Graph.PluginFamily)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceMemento.FindPlugin(StructureMap.Graph.PluginFamily)]


getChild Method (Key)

getChild Method (Key)
Namespaces ► StructureMap ► InstanceMemento ► getChild(String)
StructureMap API
Template method for implementation specific retrieval of the named property
Declaration Syntax
C# Visual Basic Visual C++
protected abstract InstanceMemento getChild(
    string Key
)
Protected MustOverride Function getChild ( _
    Key As String _
) As InstanceMemento
protected:
virtual InstanceMemento^ getChild(
    String^ Key
) abstract
Parameters
Key (String)

[Missing <param name="Key"/> documentation for "M:StructureMap.InstanceMemento.getChild(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceMemento.getChild(System.String)]


GetChildMemento Method (Key)

GetChildMemento Method (Key)
Namespaces ► StructureMap ► InstanceMemento ► GetChildMemento(String)
StructureMap API
Returns the named child InstanceMemento
Declaration Syntax
C# Visual Basic Visual C++
public InstanceMemento GetChildMemento(
    string Key
)
Public Function GetChildMemento ( _
    Key As String _
) As InstanceMemento
public:
InstanceMemento^ GetChildMemento(
    String^ Key
)
Parameters
Key (String)

[Missing <param name="Key"/> documentation for "M:StructureMap.InstanceMemento.GetChildMemento(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceMemento.GetChildMemento(System.String)]


GetChildrenArray Method (Key)

GetChildrenArray Method (Key)
Namespaces ► StructureMap ► InstanceMemento ► GetChildrenArray(String)
StructureMap API
This method is made public for testing. It is not necessary for normal usage.
Declaration Syntax
C# Visual Basic Visual C++
public abstract InstanceMemento[] GetChildrenArray(
    string Key
)
Public MustOverride Function GetChildrenArray ( _
    Key As String _
) As InstanceMemento()
public:
virtual array<InstanceMemento^>^ GetChildrenArray(
    String^ Key
) abstract
Parameters
Key (String)

[Missing <param name="Key"/> documentation for "M:StructureMap.InstanceMemento.GetChildrenArray(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceMemento.GetChildrenArray(System.String)]


getPluggedType Method

getPluggedType Method
Namespaces ► StructureMap ► InstanceMemento ► getPluggedType()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceMemento.getPluggedType]

Declaration Syntax
C# Visual Basic Visual C++
protected virtual string getPluggedType()
Protected Overridable Function getPluggedType As String
protected:
virtual String^ getPluggedType()
Return Value

[Missing <returns> documentation for M:StructureMap.InstanceMemento.getPluggedType]


GetProperty Method (Key)

GetProperty Method (Key)
Namespaces ► StructureMap ► InstanceMemento ► GetProperty(String)
StructureMap API
Retrieves the named property value as a string
Declaration Syntax
C# Visual Basic Visual C++
public string GetProperty(
    string Key
)
Public Function GetProperty ( _
    Key As String _
) As String
public:
String^ GetProperty(
    String^ Key
)
Parameters
Key (String)

[Missing <param name="Key"/> documentation for "M:StructureMap.InstanceMemento.GetProperty(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceMemento.GetProperty(System.String)]


getPropertyValue Method (Key)

getPropertyValue Method (Key)
Namespaces ► StructureMap ► InstanceMemento ► getPropertyValue(String)
StructureMap API
Template method for implementation specific retrieval of the named property
Declaration Syntax
C# Visual Basic Visual C++
protected abstract string getPropertyValue(
    string Key
)
Protected MustOverride Function getPropertyValue ( _
    Key As String _
) As String
protected:
virtual String^ getPropertyValue(
    String^ Key
) abstract
Parameters
Key (String)

[Missing <param name="Key"/> documentation for "M:StructureMap.InstanceMemento.getPropertyValue(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceMemento.getPropertyValue(System.String)]


innerConcreteKey Property

innerConcreteKey Property
Namespaces ► StructureMap ► InstanceMemento ► innerConcreteKey
StructureMap API

[Missing <summary> documentation for P:StructureMap.InstanceMemento.innerConcreteKey]

Declaration Syntax
C# Visual Basic Visual C++
protected abstract string innerConcreteKey { get; }
Protected MustOverride ReadOnly Property innerConcreteKey As String
protected:
virtual property String^ innerConcreteKey {
    String^ get () abstract;
}


innerInstanceKey Property

innerInstanceKey Property
Namespaces ► StructureMap ► InstanceMemento ► innerInstanceKey
StructureMap API

[Missing <summary> documentation for P:StructureMap.InstanceMemento.innerInstanceKey]

Declaration Syntax
C# Visual Basic Visual C++
protected abstract string innerInstanceKey { get; }
Protected MustOverride ReadOnly Property innerInstanceKey As String
protected:
virtual property String^ innerInstanceKey {
    String^ get () abstract;
}


InstanceKey Property

InstanceKey Property
Namespaces ► StructureMap ► InstanceMemento ► InstanceKey
StructureMap API
The named key of the object instance represented by the InstanceMemento
Declaration Syntax
C# Visual Basic Visual C++
public string InstanceKey { get; set; }
Public Property InstanceKey As String
public:
property String^ InstanceKey {
    String^ get ();
    void set (String^ value);
}


IsDefault Property

IsDefault Property
Namespaces ► StructureMap ► InstanceMemento ► IsDefault
StructureMap API
Is the InstanceMemento a reference to the default instance of the plugin type?
Declaration Syntax
C# Visual Basic Visual C++
public bool IsDefault { get; }
Public ReadOnly Property IsDefault As Boolean
public:
property bool IsDefault {
    bool get ();
}


IsReference Property

IsReference Property
Namespaces ► StructureMap ► InstanceMemento ► IsReference
StructureMap API
Template pattern property specifying whether the InstanceMemento is simply a reference to another named instance. Useful for child objects.
Declaration Syntax
C# Visual Basic Visual C++
public abstract bool IsReference { get; }
Public MustOverride ReadOnly Property IsReference As Boolean
public:
virtual property bool IsReference {
    bool get () abstract;
}


ReadChildInstance Method (name, graph, childType)

ReadChildInstance Method (name, graph, childType)
Namespaces ► StructureMap ► InstanceMemento ► ReadChildInstance(String, PluginGraph, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceMemento.ReadChildInstance(System.String,StructureMap.Graph.PluginGraph,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public virtual Instance ReadChildInstance(
    string name,
    PluginGraph graph,
    Type childType
)
Public Overridable Function ReadChildInstance ( _
    name As String, _
    graph As PluginGraph, _
    childType As Type _
) As Instance
public:
virtual Instance^ ReadChildInstance(
    String^ name,
    PluginGraph^ graph,
    Type^ childType
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.InstanceMemento.ReadChildInstance(System.String,StructureMap.Graph.PluginGraph,System.Type)"]

graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.InstanceMemento.ReadChildInstance(System.String,StructureMap.Graph.PluginGraph,System.Type)"]

childType (Type)

[Missing <param name="childType"/> documentation for "M:StructureMap.InstanceMemento.ReadChildInstance(System.String,StructureMap.Graph.PluginGraph,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceMemento.ReadChildInstance(System.String,StructureMap.Graph.PluginGraph,System.Type)]


readInstance Method (pluginGraph, pluginType)

readInstance Method (pluginGraph, pluginType)
Namespaces ► StructureMap ► InstanceMemento ► readInstance(PluginGraph, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceMemento.readInstance(StructureMap.Graph.PluginGraph,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected virtual Instance readInstance(
    PluginGraph pluginGraph,
    Type pluginType
)
Protected Overridable Function readInstance ( _
    pluginGraph As PluginGraph, _
    pluginType As Type _
) As Instance
protected:
virtual Instance^ readInstance(
    PluginGraph^ pluginGraph,
    Type^ pluginType
)
Parameters
pluginGraph (PluginGraph)

[Missing <param name="pluginGraph"/> documentation for "M:StructureMap.InstanceMemento.readInstance(StructureMap.Graph.PluginGraph,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.InstanceMemento.readInstance(StructureMap.Graph.PluginGraph,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceMemento.readInstance(StructureMap.Graph.PluginGraph,System.Type)]


ReadInstance Method (pluginGraph, pluginType)

ReadInstance Method (pluginGraph, pluginType)
Namespaces ► StructureMap ► InstanceMemento ► ReadInstance(PluginGraph, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.InstanceMemento.ReadInstance(StructureMap.Graph.PluginGraph,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public Instance ReadInstance(
    PluginGraph pluginGraph,
    Type pluginType
)
Public Function ReadInstance ( _
    pluginGraph As PluginGraph, _
    pluginType As Type _
) As Instance
public:
Instance^ ReadInstance(
    PluginGraph^ pluginGraph,
    Type^ pluginType
)
Parameters
pluginGraph (PluginGraph)

[Missing <param name="pluginGraph"/> documentation for "M:StructureMap.InstanceMemento.ReadInstance(StructureMap.Graph.PluginGraph,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.InstanceMemento.ReadInstance(StructureMap.Graph.PluginGraph,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceMemento.ReadInstance(StructureMap.Graph.PluginGraph,System.Type)]


ReferenceKey Property

ReferenceKey Property
Namespaces ► StructureMap ► InstanceMemento ► ReferenceKey
StructureMap API
Template pattern property specifying the instance key that the InstanceMemento refers to
Declaration Syntax
C# Visual Basic Visual C++
public abstract string ReferenceKey { get; }
Public MustOverride ReadOnly Property ReferenceKey As String
public:
virtual property String^ ReferenceKey {
    String^ get () abstract;
}


Substitute Method (memento)

Substitute Method (memento)
Namespaces ► StructureMap ► InstanceMemento ► Substitute(InstanceMemento)
StructureMap API
Used to create a templated InstanceMemento
Declaration Syntax
C# Visual Basic Visual C++
public virtual InstanceMemento Substitute(
    InstanceMemento memento
)
Public Overridable Function Substitute ( _
    memento As InstanceMemento _
) As InstanceMemento
public:
virtual InstanceMemento^ Substitute(
    InstanceMemento^ memento
)
Parameters
memento (InstanceMemento)

[Missing <param name="memento"/> documentation for "M:StructureMap.InstanceMemento.Substitute(StructureMap.InstanceMemento)"]

Return Value

[Missing <returns> documentation for M:StructureMap.InstanceMemento.Substitute(StructureMap.InstanceMemento)]


SUBSTITUTIONS_ATTRIBUTE Field

SUBSTITUTIONS_ATTRIBUTE Field
Namespaces ► StructureMap ► InstanceMemento ► SUBSTITUTIONS_ATTRIBUTE
StructureMap API

[Missing <summary> documentation for F:StructureMap.InstanceMemento.SUBSTITUTIONS_ATTRIBUTE]

Declaration Syntax
C# Visual Basic Visual C++
public const string SUBSTITUTIONS_ATTRIBUTE
Public Const SUBSTITUTIONS_ATTRIBUTE As String
public:
literal String^ SUBSTITUTIONS_ATTRIBUTE


TEMPLATE_ATTRIBUTE Field

TEMPLATE_ATTRIBUTE Field
Namespaces ► StructureMap ► InstanceMemento ► TEMPLATE_ATTRIBUTE
StructureMap API

[Missing <summary> documentation for F:StructureMap.InstanceMemento.TEMPLATE_ATTRIBUTE]

Declaration Syntax
C# Visual Basic Visual C++
public const string TEMPLATE_ATTRIBUTE
Public Const TEMPLATE_ATTRIBUTE As String
public:
literal String^ TEMPLATE_ATTRIBUTE


TemplateName Property

TemplateName Property
Namespaces ► StructureMap ► InstanceMemento ► TemplateName
StructureMap API
Gets the referred template name
Declaration Syntax
C# Visual Basic Visual C++
public string TemplateName { get; }
Public ReadOnly Property TemplateName As String
public:
property String^ TemplateName {
    String^ get ();
}
Return Value


MementoSource Class

MementoSource Class
Namespaces ► StructureMap ► MementoSource
StructureMap API
Abstract class that is the supertype of all storage and retrieval mechanisms of InstanceMemento instances
Declaration Syntax
C# Visual Basic Visual C++
public abstract class MementoSource
Public MustInherit Class MementoSource
public ref class MementoSource abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MementoSource()()() | Initializes a new instance of the MementoSource class
 | containsKey(String) | Template pattern method. Determines if the MementoSource contains a definition for the requested instanceKey.
 | DefaultMemento |
 | Description | String description of the MementoSource. Used in the StructureMap-Client UI.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Family |
 | fetchInternalMementos()()() |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllMementos()()() | Retrieves an array of all InstanceMemento's stored by this MementoSource
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMemento(String) | Retrieves the named InstanceMemento
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveMemento(InstanceMemento) |
 | retrieveMemento(String) | Template pattern method. Retrieves an InstanceMemento for the instanceKey
 | SourceType | The type of MementoSource
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | MementoSource
 |  | DirectoryXmlMementoSource
 |  | EmbeddedFolderXmlMementoSource
 |  | MemoryMementoSource
 |  | TemplatedMementoSource
 |  | XmlMementoSource


MementoSource Constructor

MementoSource Constructor
Namespaces ► StructureMap ► MementoSource ► MementoSource()()()
StructureMap API
Initializes a new instance of the MementoSource class
Declaration Syntax
C# Visual Basic Visual C++
protected MementoSource()
Protected Sub New
protected:
MementoSource()


containsKey Method (instanceKey)

containsKey Method (instanceKey)
Namespaces ► StructureMap ► MementoSource ► containsKey(String)
StructureMap API
Template pattern method. Determines if the MementoSource contains a definition for the requested instanceKey.
Declaration Syntax
C# Visual Basic Visual C++
protected internal abstract bool containsKey(
    string instanceKey
)
Protected Friend MustOverride Function containsKey ( _
    instanceKey As String _
) As Boolean
protected public:
virtual bool containsKey(
    String^ instanceKey
) abstract
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.MementoSource.containsKey(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.MementoSource.containsKey(System.String)]


DefaultMemento Property

DefaultMemento Property
Namespaces ► StructureMap ► MementoSource ► DefaultMemento
StructureMap API

[Missing <summary> documentation for P:StructureMap.MementoSource.DefaultMemento]

Declaration Syntax
C# Visual Basic Visual C++
public InstanceMemento DefaultMemento { get; set; }
Public Property DefaultMemento As InstanceMemento
public:
property InstanceMemento^ DefaultMemento {
    InstanceMemento^ get ();
    void set (InstanceMemento^ value);
}


Description Property

Description Property
Namespaces ► StructureMap ► MementoSource ► Description
StructureMap API
String description of the MementoSource. Used in the StructureMap-Client UI.
Declaration Syntax
C# Visual Basic Visual C++
public abstract string Description { get; }
Public MustOverride ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () abstract;
}


Family Property

Family Property
Namespaces ► StructureMap ► MementoSource ► Family
StructureMap API

[Missing <summary> documentation for P:StructureMap.MementoSource.Family]

Declaration Syntax
C# Visual Basic Visual C++
public PluginFamily Family { get; set; }
Public Property Family As PluginFamily
public:
property PluginFamily^ Family {
    PluginFamily^ get ();
    void set (PluginFamily^ value);
}


fetchInternalMementos Method

fetchInternalMementos Method
Namespaces ► StructureMap ► MementoSource ► fetchInternalMementos()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.MementoSource.fetchInternalMementos]

Declaration Syntax
C# Visual Basic Visual C++
protected abstract InstanceMemento[] fetchInternalMementos()
Protected MustOverride Function fetchInternalMementos As InstanceMemento()
protected:
virtual array<InstanceMemento^>^ fetchInternalMementos() abstract
Return Value

[Missing <returns> documentation for M:StructureMap.MementoSource.fetchInternalMementos]


GetAllMementos Method

GetAllMementos Method
Namespaces ► StructureMap ► MementoSource ► GetAllMementos()()()
StructureMap API
Retrieves an array of all InstanceMemento's stored by this MementoSource
Declaration Syntax
C# Visual Basic Visual C++
public InstanceMemento[] GetAllMementos()
Public Function GetAllMementos As InstanceMemento()
public:
array<InstanceMemento^>^ GetAllMementos()
Return Value

[Missing <returns> documentation for M:StructureMap.MementoSource.GetAllMementos]


GetMemento Method (instanceKey)

GetMemento Method (instanceKey)
Namespaces ► StructureMap ► MementoSource ► GetMemento(String)
StructureMap API
Retrieves the named InstanceMemento
Declaration Syntax
C# Visual Basic Visual C++
public InstanceMemento GetMemento(
    string instanceKey
)
Public Function GetMemento ( _
    instanceKey As String _
) As InstanceMemento
public:
InstanceMemento^ GetMemento(
    String^ instanceKey
)
Parameters
instanceKey (String)
The instanceKey of the requested InstanceMemento
Return Value

[Missing <returns> documentation for M:StructureMap.MementoSource.GetMemento(System.String)]


ResolveMemento Method (memento)

ResolveMemento Method (memento)
Namespaces ► StructureMap ► MementoSource ► ResolveMemento(InstanceMemento)
StructureMap API

[Missing <summary> documentation for M:StructureMap.MementoSource.ResolveMemento(StructureMap.InstanceMemento)]

Declaration Syntax
C# Visual Basic Visual C++
public virtual InstanceMemento ResolveMemento(
    InstanceMemento memento
)
Public Overridable Function ResolveMemento ( _
    memento As InstanceMemento _
) As InstanceMemento
public:
virtual InstanceMemento^ ResolveMemento(
    InstanceMemento^ memento
)
Parameters
memento (InstanceMemento)

[Missing <param name="memento"/> documentation for "M:StructureMap.MementoSource.ResolveMemento(StructureMap.InstanceMemento)"]

Return Value

[Missing <returns> documentation for M:StructureMap.MementoSource.ResolveMemento(StructureMap.InstanceMemento)]


retrieveMemento Method (instanceKey)

retrieveMemento Method (instanceKey)
Namespaces ► StructureMap ► MementoSource ► retrieveMemento(String)
StructureMap API
Template pattern method. Retrieves an InstanceMemento for the instanceKey
Declaration Syntax
C# Visual Basic Visual C++
protected abstract InstanceMemento retrieveMemento(
    string instanceKey
)
Protected MustOverride Function retrieveMemento ( _
    instanceKey As String _
) As InstanceMemento
protected:
virtual InstanceMemento^ retrieveMemento(
    String^ instanceKey
) abstract
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.MementoSource.retrieveMemento(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.MementoSource.retrieveMemento(System.String)]


SourceType Property

SourceType Property
Namespaces ► StructureMap ► MementoSource ► SourceType
StructureMap API
The type of MementoSource
Declaration Syntax
C# Visual Basic Visual C++
public virtual MementoSourceType SourceType { get; }
Public Overridable ReadOnly Property SourceType As MementoSourceType
public:
virtual property MementoSourceType SourceType {
    MementoSourceType get ();
}


MemoryInstanceMemento Class

MemoryInstanceMemento Class
Namespaces ► StructureMap ► MemoryInstanceMemento
StructureMap API
An in-memory implementation of InstanceMemento.
Declaration Syntax
C# Visual Basic Visual C++
public class MemoryInstanceMemento : InstanceMemento
Public Class MemoryInstanceMemento _
    Inherits InstanceMemento
public ref class MemoryInstanceMemento : public InstanceMemento
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MemoryInstanceMemento(String, String) | Constructs a MemoryInstanceMemento without properties
 | MemoryInstanceMemento(String, String, NameValueCollection) | Constructs a MemoryInstanceMemento with properties
 | MemoryInstanceMemento()()() | Initializes a new instance of the MemoryInstanceMemento class
 | AddChild(String, InstanceMemento) | Links a child InstanceMemento as a named property
 | AddChildArray(String, array<InstanceMemento>[]()[]) | Links an array of InstanceMemento's to a named array property
 | ConcreteKey | The named type of the object instance represented by the InstanceMemento. Translates to a concrete type (Inherited from InstanceMemento.)
 | CreateDefaultInstanceMemento()()() | Creates a MemoryInstanceMemento that represents a reference to the default instance of a plugin type.
 | CreateReferencedInstanceMemento(String) | Creates an instance of MemoryInstanceMemento that represents a reference to another instance.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindPlugin(PluginFamily) | (Inherited from InstanceMemento.)
 | getChild(String) | (Overrides InstanceMemento.getChild(String).)
 | GetChildMemento(String) | Returns the named child InstanceMemento (Inherited from InstanceMemento.)
 | GetChildrenArray(String) | See InstanceMemento (Overrides InstanceMemento.GetChildrenArray(String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | getPluggedType()()() | (Inherited from InstanceMemento.)
 | GetProperty(String) | Retrieves the named property value as a string (Inherited from InstanceMemento.)
 | getPropertyValue(String) | (Overrides InstanceMemento.getPropertyValue(String).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | hasProperty(String) |
 | innerConcreteKey | See InstanceMemento (Overrides InstanceMemento.innerConcreteKey.)
 | innerInstanceKey | See InstanceMemento (Overrides InstanceMemento.innerInstanceKey.)
 | InstanceKey | The named key of the object instance represented by the InstanceMemento (Inherited from InstanceMemento.)
 | IsDefault | Is the InstanceMemento a reference to the default instance of the plugin type? (Inherited from InstanceMemento.)
 | IsReference | See InstanceMemento (Overrides InstanceMemento.IsReference.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadChildInstance(String, PluginGraph, Type) | (Inherited from InstanceMemento.)
 | readInstance(PluginGraph, Type) | (Inherited from InstanceMemento.)
 | ReadInstance(PluginGraph, Type) | (Inherited from InstanceMemento.)
 | ReferenceChild(String, String) |
 | ReferenceKey | See InstanceMemento (Overrides InstanceMemento.ReferenceKey.)
 | RemoveProperty(String) | Deletes a named property from the DefaultInstanceMemento
 | SetConcreteKey(String) |
 | SetInstanceKey(String) |
 | SetProperty(String, String) | Sets the value of the named property
 | SetTemplateKey(String) |
 | Substitute(InstanceMemento) | Used to create a templated InstanceMemento (Inherited from InstanceMemento.)
 | TemplateName | Gets the referred template name (Inherited from InstanceMemento.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | InstanceMemento
 |  | MemoryInstanceMemento


MemoryInstanceMemento Constructor

MemoryInstanceMemento Constructor
Namespaces ► StructureMap ► MemoryInstanceMemento ► MemoryInstanceMemento()()()
StructureMap API
Members
Icon | Member | Description
 | MemoryInstanceMemento(String, String) | Constructs a MemoryInstanceMemento without properties
 | MemoryInstanceMemento(String, String, NameValueCollection) | Constructs a MemoryInstanceMemento with properties
 | MemoryInstanceMemento()()() | Initializes a new instance of the MemoryInstanceMemento class


MemoryInstanceMemento Constructor

MemoryInstanceMemento Constructor
Namespaces ► StructureMap ► MemoryInstanceMemento ► MemoryInstanceMemento()()()
StructureMap API
Initializes a new instance of the MemoryInstanceMemento class
Declaration Syntax
C# Visual Basic Visual C++
public MemoryInstanceMemento()
Public Sub New
public:
MemoryInstanceMemento()


MemoryInstanceMemento Constructor (concreteKey, instanceKey)

MemoryInstanceMemento Constructor (concreteKey, instanceKey)
Namespaces ► StructureMap ► MemoryInstanceMemento ► MemoryInstanceMemento(String, String)
StructureMap API
Constructs a MemoryInstanceMemento without properties
Declaration Syntax
C# Visual Basic Visual C++
public MemoryInstanceMemento(
    string concreteKey,
    string instanceKey
)
Public Sub New ( _
    concreteKey As String, _
    instanceKey As String _
)
public:
MemoryInstanceMemento(
    String^ concreteKey,
    String^ instanceKey
)
Parameters
concreteKey (String)
The concrete key of the plugin type
instanceKey (String)
The identifying instance key


MemoryInstanceMemento Constructor (concreteKey, instanceKey, properties)

MemoryInstanceMemento Constructor (concreteKey, instanceKey, properties)
Namespaces ► StructureMap ► MemoryInstanceMemento ► MemoryInstanceMemento(String, String, NameValueCollection)
StructureMap API
Constructs a MemoryInstanceMemento with properties
Declaration Syntax
C# Visual Basic Visual C++
public MemoryInstanceMemento(
    string concreteKey,
    string instanceKey,
    NameValueCollection properties
)
Public Sub New ( _
    concreteKey As String, _
    instanceKey As String, _
    properties As NameValueCollection _
)
public:
MemoryInstanceMemento(
    String^ concreteKey,
    String^ instanceKey,
    NameValueCollection^ properties
)
Parameters
concreteKey (String)
The concrete key of the plugin type
instanceKey (String)
The identifying instance key
properties (NameValueCollection)
NameValueCollection of instance properties


AddChild Method (name, Memento)

AddChild Method (name, Memento)
Namespaces ► StructureMap ► MemoryInstanceMemento ► AddChild(String, InstanceMemento)
StructureMap API
Links a child InstanceMemento as a named property
Declaration Syntax
C# Visual Basic Visual C++
public void AddChild(
    string name,
    InstanceMemento Memento
)
Public Sub AddChild ( _
    name As String, _
    Memento As InstanceMemento _
)
public:
void AddChild(
    String^ name,
    InstanceMemento^ Memento
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.MemoryInstanceMemento.AddChild(System.String,StructureMap.InstanceMemento)"]

Memento (InstanceMemento)

[Missing <param name="Memento"/> documentation for "M:StructureMap.MemoryInstanceMemento.AddChild(System.String,StructureMap.InstanceMemento)"]


AddChildArray Method (name, childMementos)

AddChildArray Method (name, childMementos)
Namespaces ► StructureMap ► MemoryInstanceMemento ► AddChildArray(String, array<InstanceMemento>[]()[])
StructureMap API
Links an array of InstanceMemento's to a named array property
Declaration Syntax
C# Visual Basic Visual C++
public void AddChildArray(
    string name,
    InstanceMemento[] childMementos
)
Public Sub AddChildArray ( _
    name As String, _
    childMementos As InstanceMemento() _
)
public:
void AddChildArray(
    String^ name,
    array<InstanceMemento^>^ childMementos
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.MemoryInstanceMemento.AddChildArray(System.String,StructureMap.InstanceMemento[])"]

childMementos (array< InstanceMemento >[]()[])

[Missing <param name="childMementos"/> documentation for "M:StructureMap.MemoryInstanceMemento.AddChildArray(System.String,StructureMap.InstanceMemento[])"]


CreateDefaultInstanceMemento Method

CreateDefaultInstanceMemento Method
Namespaces ► StructureMap ► MemoryInstanceMemento ► CreateDefaultInstanceMemento()()()
StructureMap API
Creates a MemoryInstanceMemento that represents a reference to the default instance of a plugin type.
Declaration Syntax
C# Visual Basic Visual C++
public static MemoryInstanceMemento CreateDefaultInstanceMemento()
Public Shared Function CreateDefaultInstanceMemento As MemoryInstanceMemento
public:
static MemoryInstanceMemento^ CreateDefaultInstanceMemento()
Return Value

[Missing <returns> documentation for M:StructureMap.MemoryInstanceMemento.CreateDefaultInstanceMemento]


CreateReferencedInstanceMemento Method (referenceKey)

CreateReferencedInstanceMemento Method (referenceKey)
Namespaces ► StructureMap ► MemoryInstanceMemento ► CreateReferencedInstanceMemento(String)
StructureMap API
Creates an instance of MemoryInstanceMemento that represents a reference to another instance.
Declaration Syntax
C# Visual Basic Visual C++
public static MemoryInstanceMemento CreateReferencedInstanceMemento(
    string referenceKey
)
Public Shared Function CreateReferencedInstanceMemento ( _
    referenceKey As String _
) As MemoryInstanceMemento
public:
static MemoryInstanceMemento^ CreateReferencedInstanceMemento(
    String^ referenceKey
)
Parameters
referenceKey (String)
The referenced instance key to another instance
Return Value

[Missing <returns> documentation for M:StructureMap.MemoryInstanceMemento.CreateReferencedInstanceMemento(System.String)]


getChild Method (Key)

getChild Method (Key)
Namespaces ► StructureMap ► MemoryInstanceMemento ► getChild(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.MemoryInstanceMemento.getChild(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected override InstanceMemento getChild(
    string Key
)
Protected Overrides Function getChild ( _
    Key As String _
) As InstanceMemento
protected:
virtual InstanceMemento^ getChild(
    String^ Key
) override
Parameters
Key (String)

[Missing <param name="Key"/> documentation for "M:StructureMap.MemoryInstanceMemento.getChild(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.MemoryInstanceMemento.getChild(System.String)]


GetChildrenArray Method (key)

GetChildrenArray Method (key)
Namespaces ► StructureMap ► MemoryInstanceMemento ► GetChildrenArray(String)
StructureMap API
See InstanceMemento
Declaration Syntax
C# Visual Basic Visual C++
public override InstanceMemento[] GetChildrenArray(
    string key
)
Public Overrides Function GetChildrenArray ( _
    key As String _
) As InstanceMemento()
public:
virtual array<InstanceMemento^>^ GetChildrenArray(
    String^ key
) override
Parameters
key (String)

[Missing <param name="key"/> documentation for "M:StructureMap.MemoryInstanceMemento.GetChildrenArray(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.MemoryInstanceMemento.GetChildrenArray(System.String)]


getPropertyValue Method (Key)

getPropertyValue Method (Key)
Namespaces ► StructureMap ► MemoryInstanceMemento ► getPropertyValue(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.MemoryInstanceMemento.getPropertyValue(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected override string getPropertyValue(
    string Key
)
Protected Overrides Function getPropertyValue ( _
    Key As String _
) As String
protected:
virtual String^ getPropertyValue(
    String^ Key
) override
Parameters
Key (String)

[Missing <param name="Key"/> documentation for "M:StructureMap.MemoryInstanceMemento.getPropertyValue(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.MemoryInstanceMemento.getPropertyValue(System.String)]


hasProperty Method (propertyName)

hasProperty Method (propertyName)
Namespaces ► StructureMap ► MemoryInstanceMemento ► hasProperty(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.MemoryInstanceMemento.hasProperty(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected bool hasProperty(
    string propertyName
)
Protected Function hasProperty ( _
    propertyName As String _
) As Boolean
protected:
bool hasProperty(
    String^ propertyName
)
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.MemoryInstanceMemento.hasProperty(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.MemoryInstanceMemento.hasProperty(System.String)]


innerConcreteKey Property

innerConcreteKey Property
Namespaces ► StructureMap ► MemoryInstanceMemento ► innerConcreteKey
StructureMap API
See InstanceMemento
Declaration Syntax
C# Visual Basic Visual C++
protected override string innerConcreteKey { get; }
Protected Overrides ReadOnly Property innerConcreteKey As String
protected:
virtual property String^ innerConcreteKey {
    String^ get () override;
}


innerInstanceKey Property

innerInstanceKey Property
Namespaces ► StructureMap ► MemoryInstanceMemento ► innerInstanceKey
StructureMap API
See InstanceMemento
Declaration Syntax
C# Visual Basic Visual C++
protected override string innerInstanceKey { get; }
Protected Overrides ReadOnly Property innerInstanceKey As String
protected:
virtual property String^ innerInstanceKey {
    String^ get () override;
}


IsReference Property

IsReference Property
Namespaces ► StructureMap ► MemoryInstanceMemento ► IsReference
StructureMap API
See InstanceMemento
Declaration Syntax
C# Visual Basic Visual C++
public override bool IsReference { get; }
Public Overrides ReadOnly Property IsReference As Boolean
public:
virtual property bool IsReference {
    bool get () override;
}


ReferenceChild Method (name, instanceKey)

ReferenceChild Method (name, instanceKey)
Namespaces ► StructureMap ► MemoryInstanceMemento ► ReferenceChild(String, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.MemoryInstanceMemento.ReferenceChild(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void ReferenceChild(
    string name,
    string instanceKey
)
Public Sub ReferenceChild ( _
    name As String, _
    instanceKey As String _
)
public:
void ReferenceChild(
    String^ name,
    String^ instanceKey
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.MemoryInstanceMemento.ReferenceChild(System.String,System.String)"]

instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.MemoryInstanceMemento.ReferenceChild(System.String,System.String)"]


ReferenceKey Property

ReferenceKey Property
Namespaces ► StructureMap ► MemoryInstanceMemento ► ReferenceKey
StructureMap API
See InstanceMemento
Declaration Syntax
C# Visual Basic Visual C++
public override string ReferenceKey { get; }
Public Overrides ReadOnly Property ReferenceKey As String
public:
virtual property String^ ReferenceKey {
    String^ get () override;
}


RemoveProperty Method (Name)

RemoveProperty Method (Name)
Namespaces ► StructureMap ► MemoryInstanceMemento ► RemoveProperty(String)
StructureMap API
Deletes a named property from the DefaultInstanceMemento
Declaration Syntax
C# Visual Basic Visual C++
public void RemoveProperty(
    string Name
)
Public Sub RemoveProperty ( _
    Name As String _
)
public:
void RemoveProperty(
    String^ Name
)
Parameters
Name (String)

[Missing <param name="Name"/> documentation for "M:StructureMap.MemoryInstanceMemento.RemoveProperty(System.String)"]


SetConcreteKey Method (concreteKey)

SetConcreteKey Method (concreteKey)
Namespaces ► StructureMap ► MemoryInstanceMemento ► SetConcreteKey(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.MemoryInstanceMemento.SetConcreteKey(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetConcreteKey(
    string concreteKey
)
Public Sub SetConcreteKey ( _
    concreteKey As String _
)
public:
void SetConcreteKey(
    String^ concreteKey
)
Parameters
concreteKey (String)

[Missing <param name="concreteKey"/> documentation for "M:StructureMap.MemoryInstanceMemento.SetConcreteKey(System.String)"]


SetInstanceKey Method (instanceKey)

SetInstanceKey Method (instanceKey)
Namespaces ► StructureMap ► MemoryInstanceMemento ► SetInstanceKey(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.MemoryInstanceMemento.SetInstanceKey(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetInstanceKey(
    string instanceKey
)
Public Sub SetInstanceKey ( _
    instanceKey As String _
)
public:
void SetInstanceKey(
    String^ instanceKey
)
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.MemoryInstanceMemento.SetInstanceKey(System.String)"]


SetProperty Method (name, value)

SetProperty Method (name, value)
Namespaces ► StructureMap ► MemoryInstanceMemento ► SetProperty(String, String)
StructureMap API
Sets the value of the named property
Declaration Syntax
C# Visual Basic Visual C++
public void SetProperty(
    string name,
    string value
)
Public Sub SetProperty ( _
    name As String, _
    value As String _
)
public:
void SetProperty(
    String^ name,
    String^ value
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.MemoryInstanceMemento.SetProperty(System.String,System.String)"]

value (String)

[Missing <param name="value"/> documentation for "M:StructureMap.MemoryInstanceMemento.SetProperty(System.String,System.String)"]


SetTemplateKey Method (templateName)

SetTemplateKey Method (templateName)
Namespaces ► StructureMap ► MemoryInstanceMemento ► SetTemplateKey(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.MemoryInstanceMemento.SetTemplateKey(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetTemplateKey(
    string templateName
)
Public Sub SetTemplateKey ( _
    templateName As String _
)
public:
void SetTemplateKey(
    String^ templateName
)
Parameters
templateName (String)

[Missing <param name="templateName"/> documentation for "M:StructureMap.MemoryInstanceMemento.SetTemplateKey(System.String)"]


MissingFactoryFunction Delegate

MissingFactoryFunction Delegate
Namespaces ► StructureMap ► MissingFactoryFunction
StructureMap API

[Missing <summary> documentation for T:StructureMap.MissingFactoryFunction]

Declaration Syntax
C# Visual Basic Visual C++
public delegate InstanceFactory MissingFactoryFunction(
    Type pluginType,
    ProfileManager profileManager
)
Public Delegate Function MissingFactoryFunction ( _
    pluginType As Type, _
    profileManager As ProfileManager _
) As InstanceFactory
public delegate InstanceFactory^ MissingFactoryFunction(
    Type^ pluginType,
    ProfileManager^ profileManager
)
Parameters
pluginType (Type)
profileManager (ProfileManager)


Model Class

Model Class
Namespaces ► StructureMap ► Model
StructureMap API

[Missing <summary> documentation for T:StructureMap.Model]

Declaration Syntax
C# Visual Basic Visual C++
public class Model : TypeRules, IModel
Public Class Model _
    Inherits TypeRules _
    Implements IModel
public ref class Model : public TypeRules,
    IModel
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasDefaultImplementationFor(Type) |
 | HasDefaultImplementationFor<(Of <(T>)>)()()() |
 | HasImplementationsFor(Type) |
 | HasImplementationsFor<(Of <(T>)>)()()() |
 | InstancesOf(Type) |
 | InstancesOf<(Of <(T>)>)()()() |
 | IsAutoFillable(Type) | (Inherited from TypeRules.)
 | IsChild(Type) | (Inherited from TypeRules.)
 | IsChildArray(Type) | (Inherited from TypeRules.)
 | IsConcrete(Type) | (Inherited from TypeRules.)
 | IsEnum(Type) | (Inherited from TypeRules.)
 | IsPrimitive(Type) | (Inherited from TypeRules.)
 | IsPrimitiveArray(Type) | (Inherited from TypeRules.)
 | IsSimple(Type) | (Inherited from TypeRules.)
 | IsString(Type) | (Inherited from TypeRules.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PluginTypes |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypeRules
 |  | Model


HasDefaultImplementationFor Method

HasDefaultImplementationFor Method
Namespaces ► StructureMap ► Model ► HasDefaultImplementationFor()()()
StructureMap API
Members
Icon | Member | Description
 | HasDefaultImplementationFor(Type) |
 | HasDefaultImplementationFor<(Of <(T>)>)()()() |


HasDefaultImplementationFor Method

HasDefaultImplementationFor<(Of <(T>)>) Method
Namespaces ► StructureMap ► Model ► HasDefaultImplementationFor<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Model.HasDefaultImplementationFor``1]

Declaration Syntax
C# Visual Basic Visual C++
public bool HasDefaultImplementationFor<T>()

Public Function HasDefaultImplementationFor(Of T) As Boolean
public:
generic<typename T>
virtual bool HasDefaultImplementationFor() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Model.HasDefaultImplementationFor``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Model.HasDefaultImplementationFor``1]


HasDefaultImplementationFor Method (pluginType)

HasDefaultImplementationFor Method (pluginType)
Namespaces ► StructureMap ► Model ► HasDefaultImplementationFor(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Model.HasDefaultImplementationFor(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public bool HasDefaultImplementationFor(
    Type pluginType
)
Public Function HasDefaultImplementationFor ( _
    pluginType As Type _
) As Boolean
public:
virtual bool HasDefaultImplementationFor(
    Type^ pluginType
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Model.HasDefaultImplementationFor(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Model.HasDefaultImplementationFor(System.Type)]


HasImplementationsFor Method

HasImplementationsFor Method
Namespaces ► StructureMap ► Model ► HasImplementationsFor()()()
StructureMap API
Members
Icon | Member | Description
 | HasImplementationsFor(Type) |
 | HasImplementationsFor<(Of <(T>)>)()()() |


HasImplementationsFor Method

HasImplementationsFor<(Of <(T>)>) Method
Namespaces ► StructureMap ► Model ► HasImplementationsFor<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Model.HasImplementationsFor``1]

Declaration Syntax
C# Visual Basic Visual C++
public bool HasImplementationsFor<T>()

Public Function HasImplementationsFor(Of T) As Boolean
public:
generic<typename T>
virtual bool HasImplementationsFor() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Model.HasImplementationsFor``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Model.HasImplementationsFor``1]


HasImplementationsFor Method (pluginType)

HasImplementationsFor Method (pluginType)
Namespaces ► StructureMap ► Model ► HasImplementationsFor(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Model.HasImplementationsFor(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public bool HasImplementationsFor(
    Type pluginType
)
Public Function HasImplementationsFor ( _
    pluginType As Type _
) As Boolean
public:
virtual bool HasImplementationsFor(
    Type^ pluginType
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Model.HasImplementationsFor(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Model.HasImplementationsFor(System.Type)]


InstancesOf Method

InstancesOf Method
Namespaces ► StructureMap ► Model ► InstancesOf()()()
StructureMap API
Members
Icon | Member | Description
 | InstancesOf(Type) |
 | InstancesOf<(Of <(T>)>)()()() |


InstancesOf Method

InstancesOf<(Of <(T>)>) Method
Namespaces ► StructureMap ► Model ► InstancesOf<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Model.InstancesOf``1]

Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<IInstance> InstancesOf<T>()

Public Function InstancesOf(Of T) As IEnumerable(Of IInstance)
public:
generic<typename T>
virtual IEnumerable<IInstance^>^ InstancesOf() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Model.InstancesOf``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Model.InstancesOf``1]


InstancesOf Method (pluginType)

InstancesOf Method (pluginType)
Namespaces ► StructureMap ► Model ► InstancesOf(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Model.InstancesOf(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<IInstance> InstancesOf(
    Type pluginType
)
Public Function InstancesOf ( _
    pluginType As Type _
) As IEnumerable(Of IInstance)
public:
virtual IEnumerable<IInstance^>^ InstancesOf(
    Type^ pluginType
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Model.InstancesOf(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Model.InstancesOf(System.Type)]


PluginTypes Property

PluginTypes Property
Namespaces ► StructureMap ► Model ► PluginTypes
StructureMap API

[Missing <summary> documentation for P:StructureMap.Model.PluginTypes]

Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<PluginTypeConfiguration> PluginTypes { get; }
Public ReadOnly Property PluginTypes As IEnumerable(Of PluginTypeConfiguration)
public:
virtual property IEnumerable<PluginTypeConfiguration^>^ PluginTypes {
    IEnumerable<PluginTypeConfiguration^>^ get () sealed;
}


Notify Delegate

Notify Delegate
Namespaces ► StructureMap ► Notify
StructureMap API

[Missing <summary> documentation for T:StructureMap.Notify]

Declaration Syntax
C# Visual Basic Visual C++
public delegate void Notify()
Public Delegate Sub Notify
public delegate void Notify()


ObjectFactory Class

ObjectFactory Class
Namespaces ► StructureMap ► ObjectFactory
StructureMap API
The main static Facade for the StructureMap container
Declaration Syntax
C# Visual Basic Visual C++
public class ObjectFactory
Public Class ObjectFactory
public ref class ObjectFactory
Members
All Members | Constructors | Methods | Properties | Events
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ObjectFactory()()() | Initializes a new instance of the ObjectFactory class
 | AssertConfigurationIsValid()()() | Use with caution! Does a full environment test of the configuration of this container. Will try to create every configured instance and afterward calls any methods marked with the [ValidationMethod] attribute
 | Configure(Action<(Of <(ConfigurationExpression>)>)) | Used to add additional configuration to a Container *after* the initialization.
 | EjectAllInstancesOf<(Of <(T>)>)()()() | Removes all configured instances of type T from the Container. Use with caution!
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FillDependencies(Type) | Obsolete.
 | FillDependencies<(Of <(T>)>)()()() | Obsolete.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllInstances(Type) | Creates or resolves all registered instances of the pluginType
 | GetAllInstances<(Of <(PLUGINTYPE>)>)()()() | Creates or resolves all registered instances of type T
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance(Type) | Creates or finds the default instance of the pluginType
 | GetInstance<(Of <(PLUGINTYPE>)>)()()() | Creates or finds the default instance of type T
 | GetInstance(Type, Instance) | Creates a new instance of the requested type using the supplied Instance. Mostly used internally
 | GetInstance<(Of <(T>)>)(Instance) | Creates a new instance of the requested type T using the supplied Instance. Mostly used internally
 | GetInstance<(Of <(T>)>)(ExplicitArguments) |
 | GetNamedInstance(Type, String) | Creates or finds the named instance of the pluginType
 | GetNamedInstance<(Of <(PLUGINTYPE>)>)(String) | Creates or finds the named instance of T
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Initialize(Action<(Of <(IInitializationExpression>)>)) |
 | Inject(Type, Object) | Injects the given object into a Container as the default for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | Inject<(Of <(PLUGINTYPE>)>)(PLUGINTYPE) | Injects the given object into a Container as the default for the designated PLUGINTYPE. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | Inject<(Of <(PLUGINTYPE>)>)(String, PLUGINTYPE) | Injects the given object into a Container by name for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | InjectStub(Type, Object) | Obsolete.
 | InjectStub<(Of <(PLUGINTYPE>)>)(PLUGINTYPE) | Obsolete.
 | InjectStub<(Of <(PLUGINTYPE>)>)(String, PLUGINTYPE) | Obsolete.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Model | Provides queryable access to the configured PluginType's and Instances of the inner Container
 | Profile | Sets the default instance for all PluginType's to the designated Profile.
 | Refresh |
 | ResetDefaults()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WhatDoIHave()()() | Returns a report detailing the complete configuration of all PluginTypes and Instances
 | With<(Of <(T>)>)(T) | Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency of type T should be "arg"
 | With(String) | Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency or primitive argument with the designated name should be the next value.
Inheritance Hierarchy
Object
ObjectFactory


ObjectFactory Constructor

ObjectFactory Constructor
Namespaces ► StructureMap ► ObjectFactory ► ObjectFactory()()()
StructureMap API
Initializes a new instance of the ObjectFactory class
Declaration Syntax
C# Visual Basic Visual C++
public ObjectFactory()
Public Sub New
public:
ObjectFactory()


AssertConfigurationIsValid Method

AssertConfigurationIsValid Method
Namespaces ► StructureMap ► ObjectFactory ► AssertConfigurationIsValid()()()
StructureMap API
Use with caution! Does a full environment test of the configuration of this container. Will try to create every configured instance and afterward calls any methods marked with the [ValidationMethod] attribute
Declaration Syntax
C# Visual Basic Visual C++
public static void AssertConfigurationIsValid()
Public Shared Sub AssertConfigurationIsValid
public:
static void AssertConfigurationIsValid()


Configure Method (configure)

Configure Method (configure)
Namespaces ► StructureMap ► ObjectFactory ► Configure(Action<(Of <(ConfigurationExpression>)>))
StructureMap API
Used to add additional configuration to a Container *after* the initialization.
Declaration Syntax
C# Visual Basic Visual C++
public static void Configure(
    Action<ConfigurationExpression> configure
)
Public Shared Sub Configure ( _
    configure As Action(Of ConfigurationExpression) _
)
public:
static void Configure(
    Action<ConfigurationExpression^>^ configure
)
Parameters
configure (Action <(Of <( ConfigurationExpression >)>))

[Missing <param name="configure"/> documentation for "M:StructureMap.ObjectFactory.Configure(System.Action{StructureMap.ConfigurationExpression})"]


EjectAllInstancesOf Method

EjectAllInstancesOf<(Of <(T>)>) Method
Namespaces ► StructureMap ► ObjectFactory ► EjectAllInstancesOf<(Of <(T>)>)()()()
StructureMap API
Removes all configured instances of type T from the Container. Use with caution!
Declaration Syntax
C# Visual Basic Visual C++
public static void EjectAllInstancesOf<T>()

Public Shared Sub EjectAllInstancesOf(Of T)
public:
generic<typename T>
static void EjectAllInstancesOf()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.ObjectFactory.EjectAllInstancesOf``1"]


FillDependencies Method

FillDependencies Method
Namespaces ► StructureMap ► ObjectFactory ► FillDependencies()()()
StructureMap API
Members
Icon | Member | Description
 | FillDependencies(Type) | Obsolete.
 | FillDependencies<(Of <(T>)>)()()() | Obsolete.


FillDependencies Method

FillDependencies<(Of <(T>)>) Method
Namespaces ► StructureMap ► ObjectFactory ► FillDependencies<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.ObjectFactory.FillDependencies``1]

Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Please use GetInstance<T>() instead")]
public static T FillDependencies<T>()

<ObsoleteAttribute("Please use GetInstance<T>() instead")> _
Public Shared Function FillDependencies(Of T) As T
[ObsoleteAttribute(L"Please use GetInstance<T>() instead")]
public:
generic<typename T>
static T FillDependencies()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.ObjectFactory.FillDependencies``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.ObjectFactory.FillDependencies``1]


FillDependencies Method (type)

FillDependencies Method (type)
Namespaces ► StructureMap ► ObjectFactory ► FillDependencies(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.ObjectFactory.FillDependencies(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Please use GetInstance(Type) instead")]
public static Object FillDependencies(
    Type type
)
<ObsoleteAttribute("Please use GetInstance(Type) instead")> _
Public Shared Function FillDependencies ( _
    type As Type _
) As Object
[ObsoleteAttribute(L"Please use GetInstance(Type) instead")]
public:
static Object^ FillDependencies(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.ObjectFactory.FillDependencies(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.ObjectFactory.FillDependencies(System.Type)]


GetAllInstances Method

GetAllInstances Method
Namespaces ► StructureMap ► ObjectFactory ► GetAllInstances()()()
StructureMap API
Members
Icon | Member | Description
 | GetAllInstances(Type) | Creates or resolves all registered instances of the pluginType
 | GetAllInstances<(Of <(PLUGINTYPE>)>)()()() | Creates or resolves all registered instances of type T


GetAllInstances Method

GetAllInstances<(Of <(PLUGINTYPE>)>) Method
Namespaces ► StructureMap ► ObjectFactory ► GetAllInstances<(Of <(PLUGINTYPE>)>)()()()
StructureMap API
Creates or resolves all registered instances of type T
Declaration Syntax
C# Visual Basic Visual C++
public static IList<PLUGINTYPE> GetAllInstances<PLUGINTYPE>()

Public Shared Function GetAllInstances(Of PLUGINTYPE) As IList(Of PLUGINTYPE)
public:
generic<typename PLUGINTYPE>
static IList<PLUGINTYPE>^ GetAllInstances()
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.ObjectFactory.GetAllInstances``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.ObjectFactory.GetAllInstances``1]


GetAllInstances Method (pluginType)

GetAllInstances Method (pluginType)
Namespaces ► StructureMap ► ObjectFactory ► GetAllInstances(Type)
StructureMap API
Creates or resolves all registered instances of the pluginType
Declaration Syntax
C# Visual Basic Visual C++
public static IList GetAllInstances(
    Type pluginType
)
Public Shared Function GetAllInstances ( _
    pluginType As Type _
) As IList
public:
static IList^ GetAllInstances(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.ObjectFactory.GetAllInstances(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.ObjectFactory.GetAllInstances(System.Type)]


GetInstance Method

GetInstance Method
Namespaces ► StructureMap ► ObjectFactory ► GetInstance()()()
StructureMap API
Members
Icon | Member | Description
 | GetInstance(Type) | Creates or finds the default instance of the pluginType
 | GetInstance<(Of <(PLUGINTYPE>)>)()()() | Creates or finds the default instance of type T
 | GetInstance(Type, Instance) | Creates a new instance of the requested type using the supplied Instance. Mostly used internally
 | GetInstance<(Of <(T>)>)(Instance) | Creates a new instance of the requested type T using the supplied Instance. Mostly used internally
 | GetInstance<(Of <(T>)>)(ExplicitArguments) |


GetInstance Method

GetInstance<(Of <(PLUGINTYPE>)>) Method
Namespaces ► StructureMap ► ObjectFactory ► GetInstance<(Of <(PLUGINTYPE>)>)()()()
StructureMap API
Creates or finds the default instance of type T
Declaration Syntax
C# Visual Basic Visual C++
public static PLUGINTYPE GetInstance<PLUGINTYPE>()

Public Shared Function GetInstance(Of PLUGINTYPE) As PLUGINTYPE
public:
generic<typename PLUGINTYPE>
static PLUGINTYPE GetInstance()
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.ObjectFactory.GetInstance``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.ObjectFactory.GetInstance``1]


GetInstance Method (args)

GetInstance<(Of <(T>)>) Method (args)
Namespaces ► StructureMap ► ObjectFactory ► GetInstance<(Of <(T>)>)(ExplicitArguments)
StructureMap API

[Missing <summary> documentation for M:StructureMap.ObjectFactory.GetInstance``1(StructureMap.Pipeline.ExplicitArguments)]

Declaration Syntax
C# Visual Basic Visual C++
public static T GetInstance<T>(
    ExplicitArguments args
)

Public Shared Function GetInstance(Of T) ( _
    args As ExplicitArguments _
) As T
public:
generic<typename T>
static T GetInstance(
    ExplicitArguments^ args
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.ObjectFactory.GetInstance``1(StructureMap.Pipeline.ExplicitArguments)"]

Parameters
args (ExplicitArguments)

[Missing <param name="args"/> documentation for "M:StructureMap.ObjectFactory.GetInstance``1(StructureMap.Pipeline.ExplicitArguments)"]

Return Value

[Missing <returns> documentation for M:StructureMap.ObjectFactory.GetInstance``1(StructureMap.Pipeline.ExplicitArguments)]


GetInstance Method (instance)

GetInstance<(Of <(T>)>) Method (instance)
Namespaces ► StructureMap ► ObjectFactory ► GetInstance<(Of <(T>)>)(Instance)
StructureMap API
Creates a new instance of the requested type T using the supplied Instance. Mostly used internally
Declaration Syntax
C# Visual Basic Visual C++
public static T GetInstance<T>(
    Instance instance
)

Public Shared Function GetInstance(Of T) ( _
    instance As Instance _
) As T
public:
generic<typename T>
static T GetInstance(
    Instance^ instance
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.ObjectFactory.GetInstance``1(StructureMap.Pipeline.Instance)"]

Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.ObjectFactory.GetInstance``1(StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.ObjectFactory.GetInstance``1(StructureMap.Pipeline.Instance)]


GetInstance Method (pluginType)

GetInstance Method (pluginType)
Namespaces ► StructureMap ► ObjectFactory ► GetInstance(Type)
StructureMap API
Creates or finds the default instance of the pluginType
Declaration Syntax
C# Visual Basic Visual C++
public static Object GetInstance(
    Type pluginType
)
Public Shared Function GetInstance ( _
    pluginType As Type _
) As Object
public:
static Object^ GetInstance(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.ObjectFactory.GetInstance(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.ObjectFactory.GetInstance(System.Type)]


GetInstance Method (TargetType, instance)

GetInstance Method (TargetType, instance)
Namespaces ► StructureMap ► ObjectFactory ► GetInstance(Type, Instance)
StructureMap API
Creates a new instance of the requested type using the supplied Instance. Mostly used internally
Declaration Syntax
C# Visual Basic Visual C++
public static Object GetInstance(
    Type TargetType,
    Instance instance
)
Public Shared Function GetInstance ( _
    TargetType As Type, _
    instance As Instance _
) As Object
public:
static Object^ GetInstance(
    Type^ TargetType,
    Instance^ instance
)
Parameters
TargetType (Type)

[Missing <param name="TargetType"/> documentation for "M:StructureMap.ObjectFactory.GetInstance(System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.ObjectFactory.GetInstance(System.Type,StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.ObjectFactory.GetInstance(System.Type,StructureMap.Pipeline.Instance)]


GetNamedInstance Method

GetNamedInstance Method
Namespaces ► StructureMap ► ObjectFactory ► GetNamedInstance()()()
StructureMap API
Members
Icon | Member | Description
 | GetNamedInstance(Type, String) | Creates or finds the named instance of the pluginType
 | GetNamedInstance<(Of <(PLUGINTYPE>)>)(String) | Creates or finds the named instance of T


GetNamedInstance Method (name)

GetNamedInstance<(Of <(PLUGINTYPE>)>) Method (name)
Namespaces ► StructureMap ► ObjectFactory ► GetNamedInstance<(Of <(PLUGINTYPE>)>)(String)
StructureMap API
Creates or finds the named instance of T
Declaration Syntax
C# Visual Basic Visual C++
public static PLUGINTYPE GetNamedInstance<PLUGINTYPE>(
    string name
)

Public Shared Function GetNamedInstance(Of PLUGINTYPE) ( _
    name As String _
) As PLUGINTYPE
public:
generic<typename PLUGINTYPE>
static PLUGINTYPE GetNamedInstance(
    String^ name
)
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.ObjectFactory.GetNamedInstance``1(System.String)"]

Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.ObjectFactory.GetNamedInstance``1(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.ObjectFactory.GetNamedInstance``1(System.String)]


GetNamedInstance Method (pluginType, name)

GetNamedInstance Method (pluginType, name)
Namespaces ► StructureMap ► ObjectFactory ► GetNamedInstance(Type, String)
StructureMap API
Creates or finds the named instance of the pluginType
Declaration Syntax
C# Visual Basic Visual C++
public static Object GetNamedInstance(
    Type pluginType,
    string name
)
Public Shared Function GetNamedInstance ( _
    pluginType As Type, _
    name As String _
) As Object
public:
static Object^ GetNamedInstance(
    Type^ pluginType,
    String^ name
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.ObjectFactory.GetNamedInstance(System.Type,System.String)"]

name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.ObjectFactory.GetNamedInstance(System.Type,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.ObjectFactory.GetNamedInstance(System.Type,System.String)]


Initialize Method (action)

Initialize Method (action)
Namespaces ► StructureMap ► ObjectFactory ► Initialize(Action<(Of <(IInitializationExpression>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.ObjectFactory.Initialize(System.Action{StructureMap.IInitializationExpression})]

Declaration Syntax
C# Visual Basic Visual C++
public static void Initialize(
    Action<IInitializationExpression> action
)
Public Shared Sub Initialize ( _
    action As Action(Of IInitializationExpression) _
)
public:
static void Initialize(
    Action<IInitializationExpression^>^ action
)
Parameters
action (Action <(Of <( IInitializationExpression >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.ObjectFactory.Initialize(System.Action{StructureMap.IInitializationExpression})"]


Inject Method

Inject Method
Namespaces ► StructureMap ► ObjectFactory ► Inject()()()
StructureMap API
Members
Icon | Member | Description
 | Inject(Type, Object) | Injects the given object into a Container as the default for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | Inject<(Of <(PLUGINTYPE>)>)(PLUGINTYPE) | Injects the given object into a Container as the default for the designated PLUGINTYPE. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
 | Inject<(Of <(PLUGINTYPE>)>)(String, PLUGINTYPE) | Injects the given object into a Container by name for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios


Inject Method (name, instance)

Inject<(Of <(PLUGINTYPE>)>) Method (name, instance)
Namespaces ► StructureMap ► ObjectFactory ► Inject<(Of <(PLUGINTYPE>)>)(String, PLUGINTYPE)
StructureMap API
Injects the given object into a Container by name for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
Declaration Syntax
C# Visual Basic Visual C++
public static void Inject<PLUGINTYPE>(
    string name,
    PLUGINTYPE instance
)

Public Shared Sub Inject(Of PLUGINTYPE) ( _
    name As String, _
    instance As PLUGINTYPE _
)
public:
generic<typename PLUGINTYPE>
static void Inject(
    String^ name,
    PLUGINTYPE instance
)
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.ObjectFactory.Inject``1(System.String,``0)"]

Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.ObjectFactory.Inject``1(System.String,``0)"]

instance (PLUGINTYPE)

[Missing <param name="instance"/> documentation for "M:StructureMap.ObjectFactory.Inject``1(System.String,``0)"]


Inject Method (pluginType, instance)

Inject Method (pluginType, instance)
Namespaces ► StructureMap ► ObjectFactory ► Inject(Type, Object)
StructureMap API
Injects the given object into a Container as the default for the designated pluginType. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
Declaration Syntax
C# Visual Basic Visual C++
public static void Inject(
    Type pluginType,
    Object instance
)
Public Shared Sub Inject ( _
    pluginType As Type, _
    instance As Object _
)
public:
static void Inject(
    Type^ pluginType,
    Object^ instance
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.ObjectFactory.Inject(System.Type,System.Object)"]

instance (Object)

[Missing <param name="instance"/> documentation for "M:StructureMap.ObjectFactory.Inject(System.Type,System.Object)"]


Inject Method (instance)

Inject<(Of <(PLUGINTYPE>)>) Method (instance)
Namespaces ► StructureMap ► ObjectFactory ► Inject<(Of <(PLUGINTYPE>)>)(PLUGINTYPE)
StructureMap API
Injects the given object into a Container as the default for the designated PLUGINTYPE. Mostly used for temporarily setting up return values of the Container to introduce mocks or stubs during automated testing scenarios
Declaration Syntax
C# Visual Basic Visual C++
public static void Inject<PLUGINTYPE>(
    PLUGINTYPE instance
)

Public Shared Sub Inject(Of PLUGINTYPE) ( _
    instance As PLUGINTYPE _
)
public:
generic<typename PLUGINTYPE>
static void Inject(
    PLUGINTYPE instance
)
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.ObjectFactory.Inject``1(``0)"]

Parameters
instance (PLUGINTYPE)

[Missing <param name="instance"/> documentation for "M:StructureMap.ObjectFactory.Inject``1(``0)"]


InjectStub Method

InjectStub Method
Namespaces ► StructureMap ► ObjectFactory ► InjectStub()()()
StructureMap API
Members
Icon | Member | Description
 | InjectStub(Type, Object) | Obsolete.
 | InjectStub<(Of <(PLUGINTYPE>)>)(PLUGINTYPE) | Obsolete.
 | InjectStub<(Of <(PLUGINTYPE>)>)(String, PLUGINTYPE) | Obsolete.


InjectStub Method (name, stub)

InjectStub<(Of <(PLUGINTYPE>)>) Method (name, stub)
Namespaces ► StructureMap ► ObjectFactory ► InjectStub<(Of <(PLUGINTYPE>)>)(String, PLUGINTYPE)
StructureMap API

[Missing <summary> documentation for M:StructureMap.ObjectFactory.InjectStub``1(System.String,``0)]

Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Please use Inject<PLUGINTYPE>(name) instead.")]
public static void InjectStub<PLUGINTYPE>(
    string name,
    PLUGINTYPE stub
)

<ObsoleteAttribute("Please use Inject<PLUGINTYPE>(name) instead.")> _
Public Shared Sub InjectStub(Of PLUGINTYPE) ( _
    name As String, _
    stub As PLUGINTYPE _
)
[ObsoleteAttribute(L"Please use Inject<PLUGINTYPE>(name) instead.")]
public:
generic<typename PLUGINTYPE>
static void InjectStub(
    String^ name,
    PLUGINTYPE stub
)
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.ObjectFactory.InjectStub``1(System.String,``0)"]

Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.ObjectFactory.InjectStub``1(System.String,``0)"]

stub (PLUGINTYPE)

[Missing <param name="stub"/> documentation for "M:StructureMap.ObjectFactory.InjectStub``1(System.String,``0)"]


InjectStub Method (pluginType, stub)

InjectStub Method (pluginType, stub)
Namespaces ► StructureMap ► ObjectFactory ► InjectStub(Type, Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.ObjectFactory.InjectStub(System.Type,System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Please use Inject(Type, object) instead.")]
public static void InjectStub(
    Type pluginType,
    Object stub
)
<ObsoleteAttribute("Please use Inject(Type, object) instead.")> _
Public Shared Sub InjectStub ( _
    pluginType As Type, _
    stub As Object _
)
[ObsoleteAttribute(L"Please use Inject(Type, object) instead.")]
public:
static void InjectStub(
    Type^ pluginType,
    Object^ stub
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.ObjectFactory.InjectStub(System.Type,System.Object)"]

stub (Object)

[Missing <param name="stub"/> documentation for "M:StructureMap.ObjectFactory.InjectStub(System.Type,System.Object)"]


InjectStub Method (stub)

InjectStub<(Of <(PLUGINTYPE>)>) Method (stub)
Namespaces ► StructureMap ► ObjectFactory ► InjectStub<(Of <(PLUGINTYPE>)>)(PLUGINTYPE)
StructureMap API

[Missing <summary> documentation for M:StructureMap.ObjectFactory.InjectStub``1(``0)]

Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Please use Inject() instead.")]
public static void InjectStub<PLUGINTYPE>(
    PLUGINTYPE stub
)

<ObsoleteAttribute("Please use Inject() instead.")> _
Public Shared Sub InjectStub(Of PLUGINTYPE) ( _
    stub As PLUGINTYPE _
)
[ObsoleteAttribute(L"Please use Inject() instead.")]
public:
generic<typename PLUGINTYPE>
static void InjectStub(
    PLUGINTYPE stub
)
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.ObjectFactory.InjectStub``1(``0)"]

Parameters
stub (PLUGINTYPE)

[Missing <param name="stub"/> documentation for "M:StructureMap.ObjectFactory.InjectStub``1(``0)"]


Model Property

Model Property
Namespaces ► StructureMap ► ObjectFactory ► Model
StructureMap API
Provides queryable access to the configured PluginType's and Instances of the inner Container
Declaration Syntax
C# Visual Basic Visual C++
public static IModel Model { get; }
Public Shared ReadOnly Property Model As IModel
public:
static property IModel^ Model {
    IModel^ get ();
}


Profile Property

Profile Property
Namespaces ► StructureMap ► ObjectFactory ► Profile
StructureMap API
Sets the default instance for all PluginType's to the designated Profile.
Declaration Syntax
C# Visual Basic Visual C++
public static string Profile { get; set; }
Public Shared Property Profile As String
public:
static property String^ Profile {
    String^ get ();
    void set (String^ value);
}


Refresh Event

Refresh Event
Namespaces ► StructureMap ► ObjectFactory ► Refresh
StructureMap API

[Missing <summary> documentation for E:StructureMap.ObjectFactory.Refresh]

Declaration Syntax
C# Visual Basic Visual C++
public static event Notify Refresh
Public Shared Event Refresh As Notify
public:
static  event Notify^ Refresh {
    void add (Notify^ value);
    void remove (Notify^ value);
}


ResetDefaults Method

ResetDefaults Method
Namespaces ► StructureMap ► ObjectFactory ► ResetDefaults()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.ObjectFactory.ResetDefaults]

Declaration Syntax
C# Visual Basic Visual C++
public static void ResetDefaults()
Public Shared Sub ResetDefaults
public:
static void ResetDefaults()


WhatDoIHave Method

WhatDoIHave Method
Namespaces ► StructureMap ► ObjectFactory ► WhatDoIHave()()()
StructureMap API
Returns a report detailing the complete configuration of all PluginTypes and Instances
Declaration Syntax
C# Visual Basic Visual C++
public static string WhatDoIHave()
Public Shared Function WhatDoIHave As String
public:
static String^ WhatDoIHave()
Return Value

[Missing <returns> documentation for M:StructureMap.ObjectFactory.WhatDoIHave]


With Method

With Method
Namespaces ► StructureMap ► ObjectFactory ► With()()()
StructureMap API
Members
Icon | Member | Description
 | With<(Of <(T>)>)(T) | Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency of type T should be "arg"
 | With(String) | Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency or primitive argument with the designated name should be the next value.


With Method (argName)

With Method (argName)
Namespaces ► StructureMap ► ObjectFactory ► With(String)
StructureMap API
Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency or primitive argument with the designated name should be the next value.
Declaration Syntax
C# Visual Basic Visual C++
public static IExplicitProperty With(
    string argName
)
Public Shared Function With ( _
    argName As String _
) As IExplicitProperty
public:
static IExplicitProperty^ With(
    String^ argName
)
Parameters
argName (String)

[Missing <param name="argName"/> documentation for "M:StructureMap.ObjectFactory.With(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.ObjectFactory.With(System.String)]


With Method (arg)

With<(Of <(T>)>) Method (arg)
Namespaces ► StructureMap ► ObjectFactory ► With<(Of <(T>)>)(T)
StructureMap API
Starts a request for an instance or instances with explicitly configured arguments. Specifies that any dependency of type T should be "arg"
Declaration Syntax
C# Visual Basic Visual C++
public static ExplicitArgsExpression With<T>(
    T arg
)

Public Shared Function With(Of T) ( _
    arg As T _
) As ExplicitArgsExpression
public:
generic<typename T>
static ExplicitArgsExpression^ With(
    T arg
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.ObjectFactory.With``1(``0)"]

Parameters
arg (T)

[Missing <param name="arg"/> documentation for "M:StructureMap.ObjectFactory.With``1(``0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.ObjectFactory.With``1(``0)]


PipelineGraph Class

PipelineGraph Class
Namespaces ► StructureMap ► PipelineGraph
StructureMap API

[Missing <summary> documentation for T:StructureMap.PipelineGraph]

Declaration Syntax
C# Visual Basic Visual C++
public class PipelineGraph
Public Class PipelineGraph
public ref class PipelineGraph
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PipelineGraph(PluginGraph) | Initializes a new instance of the PipelineGraph class
 | AddDefaultInstance<(Of <(PLUGINTYPE, PLUGGEDTYPE>)>)()()() |
 | AddInstance<(Of <(PLUGINTYPE, PLUGGEDTYPE>)>)()()() |
 | AddInstance<(Of <(T>)>)(Instance) |
 | createFactory(Type) |
 | CurrentProfile |
 | EjectAllInstancesOf<(Of <(T>)>)()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | ForType(Type) |
 | GetAllInstances()()() |
 | GetDefault(Type) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImportFrom(PluginGraph) |
 | Inject<(Of <(PLUGINTYPE>)>)(PLUGINTYPE) |
 | InstancesOf(Type) |
 | Log |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnMissingFactory |
 | PluginTypes |
 | registerFactory(Type, InstanceFactory) |
 | SetDefault(Type, Instance) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PipelineGraph


PipelineGraph Constructor (graph)

PipelineGraph Constructor (graph)
Namespaces ► StructureMap ► PipelineGraph ► PipelineGraph(PluginGraph)
StructureMap API
Initializes a new instance of the PipelineGraph class
Declaration Syntax
C# Visual Basic Visual C++
public PipelineGraph(
    PluginGraph graph
)
Public Sub New ( _
    graph As PluginGraph _
)
public:
PipelineGraph(
    PluginGraph^ graph
)
Parameters
graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.PipelineGraph.#ctor(StructureMap.Graph.PluginGraph)"]


AddDefaultInstance Method

AddDefaultInstance<(Of <(PLUGINTYPE, PLUGGEDTYPE>)>) Method
Namespaces ► StructureMap ► PipelineGraph ► AddDefaultInstance<(Of <(PLUGINTYPE, PLUGGEDTYPE>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.PipelineGraph.AddDefaultInstance``2]

Declaration Syntax
C# Visual Basic Visual C++
public void AddDefaultInstance<PLUGINTYPE, PLUGGEDTYPE>()

Public Sub AddDefaultInstance(Of PLUGINTYPE, PLUGGEDTYPE)
public:
generic<typename PLUGINTYPE, typename PLUGGEDTYPE>
void AddDefaultInstance()
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.PipelineGraph.AddDefaultInstance``2"]

PLUGGEDTYPE

[Missing <typeparam name="PLUGGEDTYPE"/> documentation for "M:StructureMap.PipelineGraph.AddDefaultInstance``2"]


AddInstance Method

AddInstance Method
Namespaces ► StructureMap ► PipelineGraph ► AddInstance()()()
StructureMap API
Members
Icon | Member | Description
 | AddInstance<(Of <(PLUGINTYPE, PLUGGEDTYPE>)>)()()() |
 | AddInstance<(Of <(T>)>)(Instance) |


AddInstance Method

AddInstance<(Of <(PLUGINTYPE, PLUGGEDTYPE>)>) Method
Namespaces ► StructureMap ► PipelineGraph ► AddInstance<(Of <(PLUGINTYPE, PLUGGEDTYPE>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.PipelineGraph.AddInstance``2]

Declaration Syntax
C# Visual Basic Visual C++
public Instance AddInstance<PLUGINTYPE, PLUGGEDTYPE>()

Public Function AddInstance(Of PLUGINTYPE, PLUGGEDTYPE) As Instance
public:
generic<typename PLUGINTYPE, typename PLUGGEDTYPE>
Instance^ AddInstance()
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.PipelineGraph.AddInstance``2"]

PLUGGEDTYPE

[Missing <typeparam name="PLUGGEDTYPE"/> documentation for "M:StructureMap.PipelineGraph.AddInstance``2"]

Return Value

[Missing <returns> documentation for M:StructureMap.PipelineGraph.AddInstance``2]


AddInstance Method (instance)

AddInstance<(Of <(T>)>) Method (instance)
Namespaces ► StructureMap ► PipelineGraph ► AddInstance<(Of <(T>)>)(Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.PipelineGraph.AddInstance``1(StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddInstance<T>(
    Instance instance
)

Public Sub AddInstance(Of T) ( _
    instance As Instance _
)
public:
generic<typename T>
void AddInstance(
    Instance^ instance
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.PipelineGraph.AddInstance``1(StructureMap.Pipeline.Instance)"]

Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.PipelineGraph.AddInstance``1(StructureMap.Pipeline.Instance)"]


createFactory Method (pluggedType)

createFactory Method (pluggedType)
Namespaces ► StructureMap ► PipelineGraph ► createFactory(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.PipelineGraph.createFactory(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected virtual InstanceFactory createFactory(
    Type pluggedType
)
Protected Overridable Function createFactory ( _
    pluggedType As Type _
) As InstanceFactory
protected:
virtual InstanceFactory^ createFactory(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.PipelineGraph.createFactory(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.PipelineGraph.createFactory(System.Type)]


CurrentProfile Property

CurrentProfile Property
Namespaces ► StructureMap ► PipelineGraph ► CurrentProfile
StructureMap API

[Missing <summary> documentation for P:StructureMap.PipelineGraph.CurrentProfile]

Declaration Syntax
C# Visual Basic Visual C++
public string CurrentProfile { get; set; }
Public Property CurrentProfile As String
public:
property String^ CurrentProfile {
    String^ get ();
    void set (String^ value);
}


EjectAllInstancesOf Method

EjectAllInstancesOf<(Of <(T>)>) Method
Namespaces ► StructureMap ► PipelineGraph ► EjectAllInstancesOf<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.PipelineGraph.EjectAllInstancesOf``1]

Declaration Syntax
C# Visual Basic Visual C++
public void EjectAllInstancesOf<T>()

Public Sub EjectAllInstancesOf(Of T)
public:
generic<typename T>
void EjectAllInstancesOf()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.PipelineGraph.EjectAllInstancesOf``1"]


ForType Method (pluginType)

ForType Method (pluginType)
Namespaces ► StructureMap ► PipelineGraph ► ForType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.PipelineGraph.ForType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public IInstanceFactory ForType(
    Type pluginType
)
Public Function ForType ( _
    pluginType As Type _
) As IInstanceFactory
public:
IInstanceFactory^ ForType(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.PipelineGraph.ForType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.PipelineGraph.ForType(System.Type)]


GetAllInstances Method

GetAllInstances Method
Namespaces ► StructureMap ► PipelineGraph ► GetAllInstances()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.PipelineGraph.GetAllInstances]

Declaration Syntax
C# Visual Basic Visual C++
public List<IInstance> GetAllInstances()
Public Function GetAllInstances As List(Of IInstance)
public:
List<IInstance^>^ GetAllInstances()
Return Value

[Missing <returns> documentation for M:StructureMap.PipelineGraph.GetAllInstances]


GetDefault Method (pluginType)

GetDefault Method (pluginType)
Namespaces ► StructureMap ► PipelineGraph ► GetDefault(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.PipelineGraph.GetDefault(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public virtual Instance GetDefault(
    Type pluginType
)
Public Overridable Function GetDefault ( _
    pluginType As Type _
) As Instance
public:
virtual Instance^ GetDefault(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.PipelineGraph.GetDefault(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.PipelineGraph.GetDefault(System.Type)]


ImportFrom Method (graph)

ImportFrom Method (graph)
Namespaces ► StructureMap ► PipelineGraph ► ImportFrom(PluginGraph)
StructureMap API

[Missing <summary> documentation for M:StructureMap.PipelineGraph.ImportFrom(StructureMap.Graph.PluginGraph)]

Declaration Syntax
C# Visual Basic Visual C++
public void ImportFrom(
    PluginGraph graph
)
Public Sub ImportFrom ( _
    graph As PluginGraph _
)
public:
void ImportFrom(
    PluginGraph^ graph
)
Parameters
graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.PipelineGraph.ImportFrom(StructureMap.Graph.PluginGraph)"]


Inject Method (instance)

Inject<(Of <(PLUGINTYPE>)>) Method (instance)
Namespaces ► StructureMap ► PipelineGraph ► Inject<(Of <(PLUGINTYPE>)>)(PLUGINTYPE)
StructureMap API

[Missing <summary> documentation for M:StructureMap.PipelineGraph.Inject``1(``0)]

Declaration Syntax
C# Visual Basic Visual C++
public void Inject<PLUGINTYPE>(
    PLUGINTYPE instance
)

Public Sub Inject(Of PLUGINTYPE) ( _
    instance As PLUGINTYPE _
)
public:
generic<typename PLUGINTYPE>
void Inject(
    PLUGINTYPE instance
)
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.PipelineGraph.Inject``1(``0)"]

Parameters
instance (PLUGINTYPE)

[Missing <param name="instance"/> documentation for "M:StructureMap.PipelineGraph.Inject``1(``0)"]


InstancesOf Method (pluginType)

InstancesOf Method (pluginType)
Namespaces ► StructureMap ► PipelineGraph ► InstancesOf(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.PipelineGraph.InstancesOf(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<IInstance> InstancesOf(
    Type pluginType
)
Public Function InstancesOf ( _
    pluginType As Type _
) As IEnumerable(Of IInstance)
public:
IEnumerable<IInstance^>^ InstancesOf(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.PipelineGraph.InstancesOf(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.PipelineGraph.InstancesOf(System.Type)]


Log Property

Log Property
Namespaces ► StructureMap ► PipelineGraph ► Log
StructureMap API

[Missing <summary> documentation for P:StructureMap.PipelineGraph.Log]

Declaration Syntax
C# Visual Basic Visual C++
public GraphLog Log { get; }
Public ReadOnly Property Log As GraphLog
public:
property GraphLog^ Log {
    GraphLog^ get ();
}


OnMissingFactory Property

OnMissingFactory Property
Namespaces ► StructureMap ► PipelineGraph ► OnMissingFactory
StructureMap API

[Missing <summary> documentation for P:StructureMap.PipelineGraph.OnMissingFactory]

Declaration Syntax
C# Visual Basic Visual C++
public MissingFactoryFunction OnMissingFactory { set; }
Public WriteOnly Property OnMissingFactory As MissingFactoryFunction
public:
property MissingFactoryFunction^ OnMissingFactory {
    void set (MissingFactoryFunction^ value);
}


PluginTypes Property

PluginTypes Property
Namespaces ► StructureMap ► PipelineGraph ► PluginTypes
StructureMap API

[Missing <summary> documentation for P:StructureMap.PipelineGraph.PluginTypes]

Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<PluginTypeConfiguration> PluginTypes { get; }
Public ReadOnly Property PluginTypes As IEnumerable(Of PluginTypeConfiguration)
public:
property IEnumerable<PluginTypeConfiguration^>^ PluginTypes {
    IEnumerable<PluginTypeConfiguration^>^ get ();
}


registerFactory Method (pluginType, factory)

registerFactory Method (pluginType, factory)
Namespaces ► StructureMap ► PipelineGraph ► registerFactory(Type, InstanceFactory)
StructureMap API

[Missing <summary> documentation for M:StructureMap.PipelineGraph.registerFactory(System.Type,StructureMap.InstanceFactory)]

Declaration Syntax
C# Visual Basic Visual C++
protected void registerFactory(
    Type pluginType,
    InstanceFactory factory
)
Protected Sub registerFactory ( _
    pluginType As Type, _
    factory As InstanceFactory _
)
protected:
void registerFactory(
    Type^ pluginType,
    InstanceFactory^ factory
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.PipelineGraph.registerFactory(System.Type,StructureMap.InstanceFactory)"]

factory (InstanceFactory)

[Missing <param name="factory"/> documentation for "M:StructureMap.PipelineGraph.registerFactory(System.Type,StructureMap.InstanceFactory)"]


SetDefault Method (pluginType, instance)

SetDefault Method (pluginType, instance)
Namespaces ► StructureMap ► PipelineGraph ► SetDefault(Type, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.PipelineGraph.SetDefault(System.Type,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetDefault(
    Type pluginType,
    Instance instance
)
Public Sub SetDefault ( _
    pluginType As Type, _
    instance As Instance _
)
public:
void SetDefault(
    Type^ pluginType,
    Instance^ instance
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.PipelineGraph.SetDefault(System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.PipelineGraph.SetDefault(System.Type,StructureMap.Pipeline.Instance)"]


PluggableAttribute Class

PluggableAttribute Class
Namespaces ► StructureMap ► PluggableAttribute
StructureMap API
Used to implicitly mark a class as a Plugin candidate for StructureMap
Declaration Syntax
C# Visual Basic Visual C++
public class PluggableAttribute : Attribute
Public Class PluggableAttribute _
    Inherits Attribute
public ref class PluggableAttribute : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PluggableAttribute(String) | Initializes a new instance of the PluggableAttribute class
 | ConcreteKey | The ConcreteKey alias of the Type
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InstanceOf(Type) | Gets an instance of PluggableAttribute from a Type object
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | MarkedAsPluggable(Type) | Determines whether a Type object is marked as Pluggable
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | PluggableAttribute


PluggableAttribute Constructor (concreteKey)

PluggableAttribute Constructor (concreteKey)
Namespaces ► StructureMap ► PluggableAttribute ► PluggableAttribute(String)
StructureMap API
Initializes a new instance of the PluggableAttribute class
Declaration Syntax
C# Visual Basic Visual C++
public PluggableAttribute(
    string concreteKey
)
Public Sub New ( _
    concreteKey As String _
)
public:
PluggableAttribute(
    String^ concreteKey
)
Parameters
concreteKey (String)

[Missing <param name="concreteKey"/> documentation for "M:StructureMap.PluggableAttribute.#ctor(System.String)"]


ConcreteKey Property

ConcreteKey Property
Namespaces ► StructureMap ► PluggableAttribute ► ConcreteKey
StructureMap API
The ConcreteKey alias of the Type
Declaration Syntax
C# Visual Basic Visual C++
public string ConcreteKey { get; set; }
Public Property ConcreteKey As String
public:
property String^ ConcreteKey {
    String^ get ();
    void set (String^ value);
}


InstanceOf Method (objectType)

InstanceOf Method (objectType)
Namespaces ► StructureMap ► PluggableAttribute ► InstanceOf(Type)
StructureMap API
Gets an instance of PluggableAttribute from a Type object
Declaration Syntax
C# Visual Basic Visual C++
public static PluggableAttribute InstanceOf(
    Type objectType
)
Public Shared Function InstanceOf ( _
    objectType As Type _
) As PluggableAttribute
public:
static PluggableAttribute^ InstanceOf(
    Type^ objectType
)
Parameters
objectType (Type)

[Missing <param name="objectType"/> documentation for "M:StructureMap.PluggableAttribute.InstanceOf(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.PluggableAttribute.InstanceOf(System.Type)]


MarkedAsPluggable Method (objectType)

MarkedAsPluggable Method (objectType)
Namespaces ► StructureMap ► PluggableAttribute ► MarkedAsPluggable(Type)
StructureMap API
Determines whether a Type object is marked as Pluggable
Declaration Syntax
C# Visual Basic Visual C++
public static bool MarkedAsPluggable(
    Type objectType
)
Public Shared Function MarkedAsPluggable ( _
    objectType As Type _
) As Boolean
public:
static bool MarkedAsPluggable(
    Type^ objectType
)
Parameters
objectType (Type)

[Missing <param name="objectType"/> documentation for "M:StructureMap.PluggableAttribute.MarkedAsPluggable(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.PluggableAttribute.MarkedAsPluggable(System.Type)]


PluginFamilyAttribute Class

PluginFamilyAttribute Class
Namespaces ► StructureMap ► PluginFamilyAttribute
StructureMap API
Declares a class, abstract class, or interface to be the target of a PluginFamily in the container
Declaration Syntax
C# Visual Basic Visual C++
public class PluginFamilyAttribute : Attribute
Public Class PluginFamilyAttribute _
    Inherits Attribute
public ref class PluginFamilyAttribute : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PluginFamilyAttribute()()() | Initializes a new instance of the PluginFamilyAttribute class
 | PluginFamilyAttribute(String) | Initializes a new instance of the PluginFamilyAttribute class
 | Configure(IPluginFamily) |
 | ConfigureFamily(IPluginFamily) |
 | DefaultKey | InstanceKey of the default instance. Used to implicitly define the default without declaring the instance in StructureMap.config
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | IsSingleton | Declares the target to be built by StructureMap as a Singleton. One object instance will be created for each named instance
 | MarkedAsPluginFamily(Type) | Determines if a Type object is marked as a PluginFamily
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Scope | If set, determines the shared "scope" of the instance -- PerRequest, Singleton, ThreadLocal, HttpContext, etc.
 | SourceType |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | PluginFamilyAttribute


PluginFamilyAttribute Constructor

PluginFamilyAttribute Constructor
Namespaces ► StructureMap ► PluginFamilyAttribute ► PluginFamilyAttribute()()()
StructureMap API
Members
Icon | Member | Description
 | PluginFamilyAttribute()()() | Initializes a new instance of the PluginFamilyAttribute class
 | PluginFamilyAttribute(String) | Initializes a new instance of the PluginFamilyAttribute class


PluginFamilyAttribute Constructor

PluginFamilyAttribute Constructor
Namespaces ► StructureMap ► PluginFamilyAttribute ► PluginFamilyAttribute()()()
StructureMap API
Initializes a new instance of the PluginFamilyAttribute class
Declaration Syntax
C# Visual Basic Visual C++
public PluginFamilyAttribute()
Public Sub New
public:
PluginFamilyAttribute()


PluginFamilyAttribute Constructor (DefaultKey)

PluginFamilyAttribute Constructor (DefaultKey)
Namespaces ► StructureMap ► PluginFamilyAttribute ► PluginFamilyAttribute(String)
StructureMap API
Initializes a new instance of the PluginFamilyAttribute class
Declaration Syntax
C# Visual Basic Visual C++
public PluginFamilyAttribute(
    string DefaultKey
)
Public Sub New ( _
    DefaultKey As String _
)
public:
PluginFamilyAttribute(
    String^ DefaultKey
)
Parameters
DefaultKey (String)

[Missing <param name="DefaultKey"/> documentation for "M:StructureMap.PluginFamilyAttribute.#ctor(System.String)"]


Configure Method (family)

Configure Method (family)
Namespaces ► StructureMap ► PluginFamilyAttribute ► Configure(IPluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.PluginFamilyAttribute.Configure(StructureMap.Graph.IPluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
public void Configure(
    IPluginFamily family
)
Public Sub Configure ( _
    family As IPluginFamily _
)
public:
void Configure(
    IPluginFamily^ family
)
Parameters
family (IPluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.PluginFamilyAttribute.Configure(StructureMap.Graph.IPluginFamily)"]


ConfigureFamily Method (family)

ConfigureFamily Method (family)
Namespaces ► StructureMap ► PluginFamilyAttribute ► ConfigureFamily(IPluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.PluginFamilyAttribute.ConfigureFamily(StructureMap.Graph.IPluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
public static void ConfigureFamily(
    IPluginFamily family
)
Public Shared Sub ConfigureFamily ( _
    family As IPluginFamily _
)
public:
static void ConfigureFamily(
    IPluginFamily^ family
)
Parameters
family (IPluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.PluginFamilyAttribute.ConfigureFamily(StructureMap.Graph.IPluginFamily)"]


DefaultKey Property

DefaultKey Property
Namespaces ► StructureMap ► PluginFamilyAttribute ► DefaultKey
StructureMap API
InstanceKey of the default instance. Used to implicitly define the default without declaring the instance in StructureMap.config
Declaration Syntax
C# Visual Basic Visual C++
public string DefaultKey { get; }
Public ReadOnly Property DefaultKey As String
public:
property String^ DefaultKey {
    String^ get ();
}


IsSingleton Property

IsSingleton Property
Namespaces ► StructureMap ► PluginFamilyAttribute ► IsSingleton
StructureMap API
Declares the target to be built by StructureMap as a Singleton. One object instance will be created for each named instance
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSingleton { get; set; }
Public Property IsSingleton As Boolean
public:
property bool IsSingleton {
    bool get ();
    void set (bool value);
}


MarkedAsPluginFamily Method (objectType)

MarkedAsPluginFamily Method (objectType)
Namespaces ► StructureMap ► PluginFamilyAttribute ► MarkedAsPluginFamily(Type)
StructureMap API
Determines if a Type object is marked as a PluginFamily
Declaration Syntax
C# Visual Basic Visual C++
public static bool MarkedAsPluginFamily(
    Type objectType
)
Public Shared Function MarkedAsPluginFamily ( _
    objectType As Type _
) As Boolean
public:
static bool MarkedAsPluginFamily(
    Type^ objectType
)
Parameters
objectType (Type)

[Missing <param name="objectType"/> documentation for "M:StructureMap.PluginFamilyAttribute.MarkedAsPluginFamily(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.PluginFamilyAttribute.MarkedAsPluginFamily(System.Type)]


Scope Property

Scope Property
Namespaces ► StructureMap ► PluginFamilyAttribute ► Scope
StructureMap API
If set, determines the shared "scope" of the instance -- PerRequest, Singleton, ThreadLocal, HttpContext, etc.
Declaration Syntax
C# Visual Basic Visual C++
public InstanceScope Scope { get; set; }
Public Property Scope As InstanceScope
public:
property InstanceScope Scope {
    InstanceScope get ();
    void set (InstanceScope value);
}


SourceType Property

SourceType Property
Namespaces ► StructureMap ► PluginFamilyAttribute ► SourceType
StructureMap API

[Missing <summary> documentation for P:StructureMap.PluginFamilyAttribute.SourceType]

Declaration Syntax
C# Visual Basic Visual C++
public Type SourceType { get; set; }
Public Property SourceType As Type
public:
property Type^ SourceType {
    Type^ get ();
    void set (Type^ value);
}


PluginGraphBuilder Class

PluginGraphBuilder Class
Namespaces ► StructureMap ► PluginGraphBuilder
StructureMap API
Reads configuration XML documents and builds the structures necessary to initialize the Container/IInstanceFactory/InstanceBuilder/ObjectInstanceActivator objects
Declaration Syntax
C# Visual Basic Visual C++
public class PluginGraphBuilder
Public Class PluginGraphBuilder
public ref class PluginGraphBuilder
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PluginGraphBuilder(ConfigurationParser) | Initializes a new instance of the PluginGraphBuilder class
 | PluginGraphBuilder(array<ConfigurationParser>[]()[], array<Registry>[]()[], GraphLog) | Initializes a new instance of the PluginGraphBuilder class
 | Build()()() | Reads the configuration information and returns the PluginGraph definition of plugin families and plugin's
 | BuildFromXml(XmlDocument) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PluginGraphBuilder


PluginGraphBuilder Constructor

PluginGraphBuilder Constructor
Namespaces ► StructureMap ► PluginGraphBuilder ► PluginGraphBuilder()()()
StructureMap API
Members
Icon | Member | Description
 | PluginGraphBuilder(ConfigurationParser) | Initializes a new instance of the PluginGraphBuilder class
 | PluginGraphBuilder(array<ConfigurationParser>[]()[], array<Registry>[]()[], GraphLog) | Initializes a new instance of the PluginGraphBuilder class


PluginGraphBuilder Constructor (parser)

PluginGraphBuilder Constructor (parser)
Namespaces ► StructureMap ► PluginGraphBuilder ► PluginGraphBuilder(ConfigurationParser)
StructureMap API
Initializes a new instance of the PluginGraphBuilder class
Declaration Syntax
C# Visual Basic Visual C++
public PluginGraphBuilder(
    ConfigurationParser parser
)
Public Sub New ( _
    parser As ConfigurationParser _
)
public:
PluginGraphBuilder(
    ConfigurationParser^ parser
)
Parameters
parser (ConfigurationParser)

[Missing <param name="parser"/> documentation for "M:StructureMap.PluginGraphBuilder.#ctor(StructureMap.Configuration.ConfigurationParser)"]


PluginGraphBuilder Constructor (parsers, registries, log)

PluginGraphBuilder Constructor (parsers, registries, log)
Namespaces ► StructureMap ► PluginGraphBuilder ► PluginGraphBuilder(array<ConfigurationParser>[]()[], array<Registry>[]()[], GraphLog)
StructureMap API
Initializes a new instance of the PluginGraphBuilder class
Declaration Syntax
C# Visual Basic Visual C++
public PluginGraphBuilder(
    ConfigurationParser[] parsers,
    Registry[] registries,
    GraphLog log
)
Public Sub New ( _
    parsers As ConfigurationParser(), _
    registries As Registry(), _
    log As GraphLog _
)
public:
PluginGraphBuilder(
    array<ConfigurationParser^>^ parsers,
    array<Registry^>^ registries,
    GraphLog^ log
)
Parameters
parsers (array< ConfigurationParser >[]()[])

[Missing <param name="parsers"/> documentation for "M:StructureMap.PluginGraphBuilder.#ctor(StructureMap.Configuration.ConfigurationParser[],StructureMap.Configuration.DSL.Registry[],StructureMap.Diagnostics.GraphLog)"]

registries (array< Registry >[]()[])

[Missing <param name="registries"/> documentation for "M:StructureMap.PluginGraphBuilder.#ctor(StructureMap.Configuration.ConfigurationParser[],StructureMap.Configuration.DSL.Registry[],StructureMap.Diagnostics.GraphLog)"]

log (GraphLog)

[Missing <param name="log"/> documentation for "M:StructureMap.PluginGraphBuilder.#ctor(StructureMap.Configuration.ConfigurationParser[],StructureMap.Configuration.DSL.Registry[],StructureMap.Diagnostics.GraphLog)"]


Build Method

Build Method
Namespaces ► StructureMap ► PluginGraphBuilder ► Build()()()
StructureMap API
Reads the configuration information and returns the PluginGraph definition of plugin families and plugin's
Declaration Syntax
C# Visual Basic Visual C++
public PluginGraph Build()
Public Function Build As PluginGraph
public:
PluginGraph^ Build()
Return Value

[Missing <returns> documentation for M:StructureMap.PluginGraphBuilder.Build]


BuildFromXml Method (document)

BuildFromXml Method (document)
Namespaces ► StructureMap ► PluginGraphBuilder ► BuildFromXml(XmlDocument)
StructureMap API

[Missing <summary> documentation for M:StructureMap.PluginGraphBuilder.BuildFromXml(System.Xml.XmlDocument)]

Declaration Syntax
C# Visual Basic Visual C++
public static PluginGraph BuildFromXml(
    XmlDocument document
)
Public Shared Function BuildFromXml ( _
    document As XmlDocument _
) As PluginGraph
public:
static PluginGraph^ BuildFromXml(
    XmlDocument^ document
)
Parameters
document (XmlDocument)

[Missing <param name="document"/> documentation for "M:StructureMap.PluginGraphBuilder.BuildFromXml(System.Xml.XmlDocument)"]

Return Value

[Missing <returns> documentation for M:StructureMap.PluginGraphBuilder.BuildFromXml(System.Xml.XmlDocument)]


PluginTypeConfiguration Class

PluginTypeConfiguration Class
Namespaces ► StructureMap ► PluginTypeConfiguration
StructureMap API
Metadata describing the registration of a PluginType
Declaration Syntax
C# Visual Basic Visual C++
public class PluginTypeConfiguration
Public Class PluginTypeConfiguration
public ref class PluginTypeConfiguration
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PluginTypeConfiguration()()() | Initializes a new instance of the PluginTypeConfiguration class
 | Default | The "instance" that will be used when Container.GetInstance(PluginType) is called. See IInstance for more information
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instances | All of the IInstance's registered for this PluginType
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PluginType |
 | Policy | The build "policy" for this PluginType. Used by the WhatDoIHave() diagnostics methods
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PluginTypeConfiguration


PluginTypeConfiguration Constructor

PluginTypeConfiguration Constructor
Namespaces ► StructureMap ► PluginTypeConfiguration ► PluginTypeConfiguration()()()
StructureMap API
Initializes a new instance of the PluginTypeConfiguration class
Declaration Syntax
C# Visual Basic Visual C++
public PluginTypeConfiguration()
Public Sub New
public:
PluginTypeConfiguration()


Default Property

Default Property
Namespaces ► StructureMap ► PluginTypeConfiguration ► Default
StructureMap API
The "instance" that will be used when Container.GetInstance(PluginType) is called. See IInstance for more information
Declaration Syntax
C# Visual Basic Visual C++
public IInstance Default { get; set; }
Public Property Default As IInstance
public:
property IInstance^ Default {
    IInstance^ get ();
    void set (IInstance^ value);
}


Instances Property

Instances Property
Namespaces ► StructureMap ► PluginTypeConfiguration ► Instances
StructureMap API
All of the IInstance's registered for this PluginType
Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<IInstance> Instances { get; set; }
Public Property Instances As IEnumerable(Of IInstance)
public:
property IEnumerable<IInstance^>^ Instances {
    IEnumerable<IInstance^>^ get ();
    void set (IEnumerable<IInstance^>^ value);
}


PluginType Property

PluginType Property
Namespaces ► StructureMap ► PluginTypeConfiguration ► PluginType
StructureMap API

[Missing <summary> documentation for P:StructureMap.PluginTypeConfiguration.PluginType]

Declaration Syntax
C# Visual Basic Visual C++
public Type PluginType { get; set; }
Public Property PluginType As Type
public:
property Type^ PluginType {
    Type^ get ();
    void set (Type^ value);
}


Policy Property

Policy Property
Namespaces ► StructureMap ► PluginTypeConfiguration ► Policy
StructureMap API
The build "policy" for this PluginType. Used by the WhatDoIHave() diagnostics methods
Declaration Syntax
C# Visual Basic Visual C++
public IBuildPolicy Policy { get; set; }
Public Property Policy As IBuildPolicy
public:
property IBuildPolicy^ Policy {
    IBuildPolicy^ get ();
    void set (IBuildPolicy^ value);
}


StructureMapConfiguration Class

StructureMapConfiguration Class
Namespaces ► StructureMap ► StructureMapConfiguration
StructureMap API

[Missing <summary> documentation for T:StructureMap.StructureMapConfiguration]

Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Please use the ObjectFactory.Initialize() method for configuring the container and put configuration into Registry classes")]
public static class StructureMapConfiguration
<ObsoleteAttribute("Please use the ObjectFactory.Initialize() method for configuring the container and put configuration into Registry classes")> _
Public NotInheritable Class StructureMapConfiguration
[ObsoleteAttribute(L"Please use the ObjectFactory.Initialize() method for configuring the container and put configuration into Registry classes")]
public ref class StructureMapConfiguration abstract sealed
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddRegistry(Registry) | Directs StructureMap to use a Registry class to construct the PluginGraph
 | BuildInstancesOf<(Of <(PLUGINTYPE>)>)()()() | Direct StructureMap to create instances of Type T
 | CreateProfile(String) | Starts the definition of a configuration Profile.
 | ForRequestedType<(Of <(PLUGINTYPE>)>)()()() | Direct StructureMap to create instances of Type T
 | ForRequestedType(Type) |
 | GetStructureMapConfigurationPath()()() | Obsolete. Returns the path to the StructureMap.config file
 | IgnoreStructureMapConfig |
 | IncludeConfigurationFromFile(String) | Directs StructureMap to include Xml configuration information from a separate file
 | IncludeConfigurationFromNode(XmlNode, String) | Programmatically adds a <StructureMap> node containing Xml configuration
 | PullConfigurationFromAppConfig |
 | RegisterInterceptor(TypeInterceptor) |
 | ResetAll()()() | Clears StructureMapConfiguration of all configuration options. Returns StructureMap to only using the default StructureMap.config file for configuration.
 | Scan(Action<(Of <(IAssemblyScanner>)>)) | Programmatically determine Assembly's to be scanned for attribute configuration
 | TheDefaultProfileIs(String) |
 | UseDefaultStructureMapConfigFile | Flag to enable or disable the usage of the default StructureMap.config If set to false, StructureMap will not look for a StructureMap.config file
Inheritance Hierarchy
Object
StructureMapConfiguration


AddRegistry Method (registry)

AddRegistry Method (registry)
Namespaces ► StructureMap ► StructureMapConfiguration ► AddRegistry(Registry)
StructureMap API
Directs StructureMap to use a Registry class to construct the PluginGraph
Declaration Syntax
C# Visual Basic Visual C++
public static void AddRegistry(
    Registry registry
)
Public Shared Sub AddRegistry ( _
    registry As Registry _
)
public:
static void AddRegistry(
    Registry^ registry
)
Parameters
registry (Registry)

[Missing <param name="registry"/> documentation for "M:StructureMap.StructureMapConfiguration.AddRegistry(StructureMap.Configuration.DSL.Registry)"]


BuildInstancesOf Method

BuildInstancesOf<(Of <(PLUGINTYPE>)>) Method
Namespaces ► StructureMap ► StructureMapConfiguration ► BuildInstancesOf<(Of <(PLUGINTYPE>)>)()()()
StructureMap API
Direct StructureMap to create instances of Type T
Declaration Syntax
C# Visual Basic Visual C++
public static CreatePluginFamilyExpression<PLUGINTYPE> BuildInstancesOf<PLUGINTYPE>()

Public Shared Function BuildInstancesOf(Of PLUGINTYPE) As CreatePluginFamilyExpression(Of PLUGINTYPE)
public:
generic<typename PLUGINTYPE>
static CreatePluginFamilyExpression<PLUGINTYPE>^ BuildInstancesOf()
Generic Template Parameters
PLUGINTYPE
The Type to build
Return Value

[Missing <returns> documentation for M:StructureMap.StructureMapConfiguration.BuildInstancesOf``1]


CreateProfile Method (profileName)

CreateProfile Method (profileName)
Namespaces ► StructureMap ► StructureMapConfiguration ► CreateProfile(String)
StructureMap API
Starts the definition of a configuration Profile.
Declaration Syntax
C# Visual Basic Visual C++
public static ProfileExpression CreateProfile(
    string profileName
)
Public Shared Function CreateProfile ( _
    profileName As String _
) As ProfileExpression
public:
static ProfileExpression^ CreateProfile(
    String^ profileName
)
Parameters
profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.StructureMapConfiguration.CreateProfile(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.StructureMapConfiguration.CreateProfile(System.String)]


ForRequestedType Method

ForRequestedType Method
Namespaces ► StructureMap ► StructureMapConfiguration ► ForRequestedType()()()
StructureMap API
Members
Icon | Member | Description
 | ForRequestedType<(Of <(PLUGINTYPE>)>)()()() | Direct StructureMap to create instances of Type T
 | ForRequestedType(Type) |


ForRequestedType Method

ForRequestedType<(Of <(PLUGINTYPE>)>) Method
Namespaces ► StructureMap ► StructureMapConfiguration ► ForRequestedType<(Of <(PLUGINTYPE>)>)()()()
StructureMap API
Direct StructureMap to create instances of Type T
Declaration Syntax
C# Visual Basic Visual C++
public static CreatePluginFamilyExpression<PLUGINTYPE> ForRequestedType<PLUGINTYPE>()

Public Shared Function ForRequestedType(Of PLUGINTYPE) As CreatePluginFamilyExpression(Of PLUGINTYPE)
public:
generic<typename PLUGINTYPE>
static CreatePluginFamilyExpression<PLUGINTYPE>^ ForRequestedType()
Generic Template Parameters
PLUGINTYPE
The Type to build
Return Value

[Missing <returns> documentation for M:StructureMap.StructureMapConfiguration.ForRequestedType``1]


ForRequestedType Method (pluginType)

ForRequestedType Method (pluginType)
Namespaces ► StructureMap ► StructureMapConfiguration ► ForRequestedType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.StructureMapConfiguration.ForRequestedType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public static GenericFamilyExpression ForRequestedType(
    Type pluginType
)
Public Shared Function ForRequestedType ( _
    pluginType As Type _
) As GenericFamilyExpression
public:
static GenericFamilyExpression^ ForRequestedType(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.StructureMapConfiguration.ForRequestedType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.StructureMapConfiguration.ForRequestedType(System.Type)]


GetStructureMapConfigurationPath Method

GetStructureMapConfigurationPath Method
Namespaces ► StructureMap ► StructureMapConfiguration ► GetStructureMapConfigurationPath()()()
StructureMap API
Returns the path to the StructureMap.config file
Declaration Syntax
C# Visual Basic Visual C++
[ObsoleteAttribute("Use ConfigurationParserBuilder.GetStructureMapConfigurationPath() instead.")]
public static string GetStructureMapConfigurationPath()
<ObsoleteAttribute("Use ConfigurationParserBuilder.GetStructureMapConfigurationPath() instead.")> _
Public Shared Function GetStructureMapConfigurationPath As String
[ObsoleteAttribute(L"Use ConfigurationParserBuilder.GetStructureMapConfigurationPath() instead.")]
public:
static String^ GetStructureMapConfigurationPath()
Return Value

[Missing <returns> documentation for M:StructureMap.StructureMapConfiguration.GetStructureMapConfigurationPath]


IgnoreStructureMapConfig Property

IgnoreStructureMapConfig Property
Namespaces ► StructureMap ► StructureMapConfiguration ► IgnoreStructureMapConfig
StructureMap API

[Missing <summary> documentation for P:StructureMap.StructureMapConfiguration.IgnoreStructureMapConfig]

Declaration Syntax
C# Visual Basic Visual C++
public static bool IgnoreStructureMapConfig { get; set; }
Public Shared Property IgnoreStructureMapConfig As Boolean
public:
static property bool IgnoreStructureMapConfig {
    bool get ();
    void set (bool value);
}


IncludeConfigurationFromFile Method (filename)

IncludeConfigurationFromFile Method (filename)
Namespaces ► StructureMap ► StructureMapConfiguration ► IncludeConfigurationFromFile(String)
StructureMap API
Directs StructureMap to include Xml configuration information from a separate file
Declaration Syntax
C# Visual Basic Visual C++
public static void IncludeConfigurationFromFile(
    string filename
)
Public Shared Sub IncludeConfigurationFromFile ( _
    filename As String _
)
public:
static void IncludeConfigurationFromFile(
    String^ filename
)
Parameters
filename (String)

[Missing <param name="filename"/> documentation for "M:StructureMap.StructureMapConfiguration.IncludeConfigurationFromFile(System.String)"]


IncludeConfigurationFromNode Method (node, description)

IncludeConfigurationFromNode Method (node, description)
Namespaces ► StructureMap ► StructureMapConfiguration ► IncludeConfigurationFromNode(XmlNode, String)
StructureMap API
Programmatically adds a <StructureMap> node containing Xml configuration
Declaration Syntax
C# Visual Basic Visual C++
public static void IncludeConfigurationFromNode(
    XmlNode node,
    string description
)
Public Shared Sub IncludeConfigurationFromNode ( _
    node As XmlNode, _
    description As String _
)
public:
static void IncludeConfigurationFromNode(
    XmlNode^ node,
    String^ description
)
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.StructureMapConfiguration.IncludeConfigurationFromNode(System.Xml.XmlNode,System.String)"]

description (String)
A description of this node source for troubleshooting purposes


PullConfigurationFromAppConfig Property

PullConfigurationFromAppConfig Property
Namespaces ► StructureMap ► StructureMapConfiguration ► PullConfigurationFromAppConfig
StructureMap API

[Missing <summary> documentation for P:StructureMap.StructureMapConfiguration.PullConfigurationFromAppConfig]

Declaration Syntax
C# Visual Basic Visual C++
public static bool PullConfigurationFromAppConfig { get; set; }
Public Shared Property PullConfigurationFromAppConfig As Boolean
public:
static property bool PullConfigurationFromAppConfig {
    bool get ();
    void set (bool value);
}


RegisterInterceptor Method (interceptor)

RegisterInterceptor Method (interceptor)
Namespaces ► StructureMap ► StructureMapConfiguration ► RegisterInterceptor(TypeInterceptor)
StructureMap API

[Missing <summary> documentation for M:StructureMap.StructureMapConfiguration.RegisterInterceptor(StructureMap.Interceptors.TypeInterceptor)]

Declaration Syntax
C# Visual Basic Visual C++
public static void RegisterInterceptor(
    TypeInterceptor interceptor
)
Public Shared Sub RegisterInterceptor ( _
    interceptor As TypeInterceptor _
)
public:
static void RegisterInterceptor(
    TypeInterceptor^ interceptor
)
Parameters
interceptor (TypeInterceptor)

[Missing <param name="interceptor"/> documentation for "M:StructureMap.StructureMapConfiguration.RegisterInterceptor(StructureMap.Interceptors.TypeInterceptor)"]


ResetAll Method

ResetAll Method
Namespaces ► StructureMap ► StructureMapConfiguration ► ResetAll()()()
StructureMap API
Clears StructureMapConfiguration of all configuration options. Returns StructureMap to only using the default StructureMap.config file for configuration.
Declaration Syntax
C# Visual Basic Visual C++
public static void ResetAll()
Public Shared Sub ResetAll
public:
static void ResetAll()


Scan Method (action)

Scan Method (action)
Namespaces ► StructureMap ► StructureMapConfiguration ► Scan(Action<(Of <(IAssemblyScanner>)>))
StructureMap API
Programmatically determine Assembly's to be scanned for attribute configuration
Declaration Syntax
C# Visual Basic Visual C++
public static void Scan(
    Action<IAssemblyScanner> action
)
Public Shared Sub Scan ( _
    action As Action(Of IAssemblyScanner) _
)
public:
static void Scan(
    Action<IAssemblyScanner^>^ action
)
Parameters
action (Action <(Of <( IAssemblyScanner >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.StructureMapConfiguration.Scan(System.Action{StructureMap.Graph.IAssemblyScanner})"]

Return Value


TheDefaultProfileIs Method (profileName)

TheDefaultProfileIs Method (profileName)
Namespaces ► StructureMap ► StructureMapConfiguration ► TheDefaultProfileIs(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.StructureMapConfiguration.TheDefaultProfileIs(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static void TheDefaultProfileIs(
    string profileName
)
Public Shared Sub TheDefaultProfileIs ( _
    profileName As String _
)
public:
static void TheDefaultProfileIs(
    String^ profileName
)
Parameters
profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.StructureMapConfiguration.TheDefaultProfileIs(System.String)"]


UseDefaultStructureMapConfigFile Property

UseDefaultStructureMapConfigFile Property
Namespaces ► StructureMap ► StructureMapConfiguration ► UseDefaultStructureMapConfigFile
StructureMap API
Flag to enable or disable the usage of the default StructureMap.config If set to false, StructureMap will not look for a StructureMap.config file
Declaration Syntax
C# Visual Basic Visual C++
public static bool UseDefaultStructureMapConfigFile { get; set; }
Public Shared Property UseDefaultStructureMapConfigFile As Boolean
public:
static property bool UseDefaultStructureMapConfigFile {
    bool get ();
    void set (bool value);
}


StructureMapException Class

StructureMapException Class
Namespaces ► StructureMap ► StructureMapException
StructureMap API
Main exception for StructureMap. Use the ErrorCode to aid in troubleshooting StructureMap problems
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class StructureMapException : ApplicationException
<SerializableAttribute> _
Public Class StructureMapException _
    Inherits ApplicationException
[SerializableAttribute]
public ref class StructureMapException : public ApplicationException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StructureMapException(SerializationInfo, StreamingContext) | Initializes a new instance of the StructureMapException class
 | StructureMapException(Int32, array<Object>[]()[]) | Initializes a new instance of the StructureMapException class
 | StructureMapException(Int32, Exception, array<Object>[]()[]) | Initializes a new instance of the StructureMapException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorCode |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | (Overrides Exception.Message.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | StructureMapException


StructureMapException Constructor

StructureMapException Constructor
Namespaces ► StructureMap ► StructureMapException ► StructureMapException()()()
StructureMap API
Members
Icon | Member | Description
 | StructureMapException(SerializationInfo, StreamingContext) | Initializes a new instance of the StructureMapException class
 | StructureMapException(Int32, array<Object>[]()[]) | Initializes a new instance of the StructureMapException class
 | StructureMapException(Int32, Exception, array<Object>[]()[]) | Initializes a new instance of the StructureMapException class


StructureMapException Constructor (ErrorCode, InnerException, args)

StructureMapException Constructor (ErrorCode, InnerException, args)
Namespaces ► StructureMap ► StructureMapException ► StructureMapException(Int32, Exception, array<Object>[]()[])
StructureMap API
Initializes a new instance of the StructureMapException class
Declaration Syntax
C# Visual Basic Visual C++
public StructureMapException(
    int ErrorCode,
    Exception InnerException,
    params Object[] args
)
Public Sub New ( _
    ErrorCode As Integer, _
    InnerException As Exception, _
    ParamArray args As Object() _
)
public:
StructureMapException(
    int ErrorCode,
    Exception^ InnerException,
    ... array<Object^>^ args
)
Parameters
ErrorCode (Int32)

[Missing <param name="ErrorCode"/> documentation for "M:StructureMap.StructureMapException.#ctor(System.Int32,System.Exception,System.Object[])"]

InnerException (Exception)

[Missing <param name="InnerException"/> documentation for "M:StructureMap.StructureMapException.#ctor(System.Int32,System.Exception,System.Object[])"]

args (array< Object >[]()[])

[Missing <param name="args"/> documentation for "M:StructureMap.StructureMapException.#ctor(System.Int32,System.Exception,System.Object[])"]


StructureMapException Constructor (ErrorCode, args)

StructureMapException Constructor (ErrorCode, args)
Namespaces ► StructureMap ► StructureMapException ► StructureMapException(Int32, array<Object>[]()[])
StructureMap API
Initializes a new instance of the StructureMapException class
Declaration Syntax
C# Visual Basic Visual C++
public StructureMapException(
    int ErrorCode,
    params Object[] args
)
Public Sub New ( _
    ErrorCode As Integer, _
    ParamArray args As Object() _
)
public:
StructureMapException(
    int ErrorCode,
    ... array<Object^>^ args
)
Parameters
ErrorCode (Int32)

[Missing <param name="ErrorCode"/> documentation for "M:StructureMap.StructureMapException.#ctor(System.Int32,System.Object[])"]

args (array< Object >[]()[])

[Missing <param name="args"/> documentation for "M:StructureMap.StructureMapException.#ctor(System.Int32,System.Object[])"]


StructureMapException Constructor (info, context)

StructureMapException Constructor (info, context)
Namespaces ► StructureMap ► StructureMapException ► StructureMapException(SerializationInfo, StreamingContext)
StructureMap API
Initializes a new instance of the StructureMapException class
Declaration Syntax
C# Visual Basic Visual C++
protected StructureMapException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
StructureMapException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)

[Missing <param name="info"/> documentation for "M:StructureMap.StructureMapException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context (StreamingContext)

[Missing <param name="context"/> documentation for "M:StructureMap.StructureMapException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]


ErrorCode Property

ErrorCode Property
Namespaces ► StructureMap ► StructureMapException ► ErrorCode
StructureMap API

[Missing <summary> documentation for P:StructureMap.StructureMapException.ErrorCode]

Declaration Syntax
C# Visual Basic Visual C++
public int ErrorCode { get; }
Public ReadOnly Property ErrorCode As Integer
public:
property int ErrorCode {
    int get ();
}


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► StructureMap ► StructureMapException ► GetObjectData(SerializationInfo, StreamingContext)
StructureMap API

[Missing <summary> documentation for M:StructureMap.StructureMapException.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)]

Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)

[Missing <param name="info"/> documentation for "M:StructureMap.StructureMapException.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context (StreamingContext)

[Missing <param name="context"/> documentation for "M:StructureMap.StructureMapException.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]


Message Property

Message Property
Namespaces ► StructureMap ► StructureMapException ► Message
StructureMap API

[Missing <summary> documentation for P:StructureMap.StructureMapException.Message]

Declaration Syntax
C# Visual Basic Visual C++
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
public:
virtual property String^ Message {
    String^ get () override;
}


ValidationMethodAttribute Class

ValidationMethodAttribute Class
Namespaces ► StructureMap ► ValidationMethodAttribute
StructureMap API
Marks a method with no parameters as a method that validates an instance. StructureMap uses this method to validate the configuration file. If the method does not throw an exception, the object is assumed to be valid.
Declaration Syntax
C# Visual Basic Visual C++
public class ValidationMethodAttribute : Attribute
Public Class ValidationMethodAttribute _
    Inherits Attribute
public ref class ValidationMethodAttribute : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidationMethodAttribute()()() | Initializes a new instance of the ValidationMethodAttribute class
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | GetValidationMethods(Type) | Returns an array of any MethodInfo's on a Type that are marked as ValidationMethod
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | ValidationMethodAttribute


ValidationMethodAttribute Constructor

ValidationMethodAttribute Constructor
Namespaces ► StructureMap ► ValidationMethodAttribute ► ValidationMethodAttribute()()()
StructureMap API
Initializes a new instance of the ValidationMethodAttribute class
Declaration Syntax
C# Visual Basic Visual C++
public ValidationMethodAttribute()
Public Sub New
public:
ValidationMethodAttribute()


GetValidationMethods Method (objectType)

GetValidationMethods Method (objectType)
Namespaces ► StructureMap ► ValidationMethodAttribute ► GetValidationMethods(Type)
StructureMap API
Returns an array of any MethodInfo's on a Type that are marked as ValidationMethod
Declaration Syntax
C# Visual Basic Visual C++
public static MethodInfo[] GetValidationMethods(
    Type objectType
)
Public Shared Function GetValidationMethods ( _
    objectType As Type _
) As MethodInfo()
public:
static array<MethodInfo^>^ GetValidationMethods(
    Type^ objectType
)
Parameters
objectType (Type)
CLR Type to search for validation methods
Return Value

[Missing <returns> documentation for M:StructureMap.ValidationMethodAttribute.GetValidationMethods(System.Type)]


StructureMap.Attributes Namespace

StructureMap.Attributes Namespace
Namespaces ► StructureMap.Attributes
StructureMap API

[Missing <summary> documentation for N:StructureMap.Attributes]

Declaration Syntax
C# Visual Basic Visual C++
namespace StructureMap.Attributes
Namespace StructureMap.Attributes
namespace StructureMap.Attributes
Types
All Types Classes Enumerations
Icon | Type | Description
 | InstanceScope |
 | SetterPropertyAttribute | Marks a Property in a Pluggable class as filled by setter injection


InstanceScope Enumeration

InstanceScope Enumeration
Namespaces ► StructureMap.Attributes ► InstanceScope
StructureMap API

[Missing <summary> documentation for T:StructureMap.Attributes.InstanceScope]

Declaration Syntax
C# Visual Basic Visual C++
public enum InstanceScope
Public Enumeration InstanceScope
public enum class InstanceScope
Members
Member | Description
PerRequest |
Singleton |
ThreadLocal |
HttpContext |
Hybrid |


SetterPropertyAttribute Class

SetterPropertyAttribute Class
Namespaces ► StructureMap.Attributes ► SetterPropertyAttribute
StructureMap API
Marks a Property in a Pluggable class as filled by setter injection
Declaration Syntax
C# Visual Basic Visual C++
public class SetterPropertyAttribute : Attribute
Public Class SetterPropertyAttribute _
    Inherits Attribute
public ref class SetterPropertyAttribute : public Attribute
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetterPropertyAttribute()()() | Initializes a new instance of the SetterPropertyAttribute class
 | Equals(Object) | Returns a value that indicates whether this instance is equal to a specified object. (Inherited from Attribute.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindMarkedProperties(Type) |
 | GetHashCode()()() | Returns the hash code for this instance. (Inherited from Attribute.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsDefaultAttribute()()() | When overridden in a derived class, indicates whether the value of this instance is the default value for the derived class. (Inherited from Attribute.)
 | Match(Object) | When overridden in a derived class, returns a value that indicates whether this instance equals a specified object. (Inherited from Attribute.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeId | When implemented in a derived class, gets a unique identifier for this Attribute. (Inherited from Attribute.)
Inheritance Hierarchy
Object
 | Attribute
 |  | SetterPropertyAttribute


SetterPropertyAttribute Constructor

SetterPropertyAttribute Constructor
Namespaces ► StructureMap.Attributes ► SetterPropertyAttribute ► SetterPropertyAttribute()()()
StructureMap API
Initializes a new instance of the SetterPropertyAttribute class
Declaration Syntax
C# Visual Basic Visual C++
public SetterPropertyAttribute()
Public Sub New
public:
SetterPropertyAttribute()


FindMarkedProperties Method (pluggedType)

FindMarkedProperties Method (pluggedType)
Namespaces ► StructureMap.Attributes ► SetterPropertyAttribute ► FindMarkedProperties(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Attributes.SetterPropertyAttribute.FindMarkedProperties(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public static PropertyInfo[] FindMarkedProperties(
    Type pluggedType
)
Public Shared Function FindMarkedProperties ( _
    pluggedType As Type _
) As PropertyInfo()
public:
static array<PropertyInfo^>^ FindMarkedProperties(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Attributes.SetterPropertyAttribute.FindMarkedProperties(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Attributes.SetterPropertyAttribute.FindMarkedProperties(System.Type)]


StructureMap.Configuration Namespace

StructureMap.Configuration Namespace
Namespaces ► StructureMap.Configuration
StructureMap API

[Missing <summary> documentation for N:StructureMap.Configuration]

Declaration Syntax
C# Visual Basic Visual C++
namespace StructureMap.Configuration
Namespace StructureMap.Configuration
namespace StructureMap.Configuration
Types
All Types Classes Interfaces
Icon | Type | Description
 | ConfigurationConstants |
 | ConfigurationParser |
 | ConfigurationParserBuilder |
 | DictionaryReader |
 | FamilyParser |
 | GraphBuilder |
 | XmlExtensions..::.HasXmlElementExpression |
 | IConfigurationParserBuilder |
 | IGraphBuilder |
 | IProfileBuilder |
 | ITypeReader |
 | PrimitiveArrayReader |
 | ProfileAndMachineParser |
 | ProfileBuilder |
 | StructureMapConfigurationSection |
 | TypeReaderFactory |
 | XmlConstants | Constants for the names of Xml nodes and attributes in the StructureMap.config file
 | XmlExtensions |
 | XmlExtensions..::.XmlNodeExpression |
 | XmlExtensions..::.XmlTextExpression |


ConfigurationConstants Class

ConfigurationConstants Class
Namespaces ► StructureMap.Configuration ► ConfigurationConstants
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.ConfigurationConstants]

Declaration Syntax
C# Visual Basic Visual C++
public static class ConfigurationConstants
Public NotInheritable Class ConfigurationConstants
public ref class ConfigurationConstants abstract sealed
Members
All Members | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CONFIGURED_DEFAULT_KEY_CANNOT_BE_FOUND |
 | COULD_NOT_CREATE_INSTANCE |
 | COULD_NOT_CREATE_MEMENTO_SOURCE |
 | COULD_NOT_LOAD_ASSEMBLY |
 | COULD_NOT_LOAD_TYPE |
 | FATAL_ERROR |
 | INVALID_ENUMERATION_VALUE |
 | INVALID_PLUGIN |
 | INVALID_PLUGIN_FAMILY |
 | INVALID_PROPERTY_CAST |
 | INVALID_SETTER |
 | MEMENTO_PROPERTY_IS_MISSING |
 | MEMENTO_SOURCE_CANNOT_RETRIEVE |
 | MISSING_CHILD |
 | MISSING_INSTANCE_KEY |
 | MISSING_TEMPLATE_VALUE |
 | NO_DEFAULT_INSTANCE_CONFIGURED |
 | NO_MATCHING_INSTANCE_CONFIGURED |
 | PLUGIN_CANNOT_READ_CONSTRUCTOR_PROPERTIES |
 | PLUGIN_FAMILY_CANNOT_BE_FOUND_FOR_INSTANCE |
 | PLUGIN_IS_MISSING_CONCRETE_KEY |
 | UNKNOWN_PLUGIN_PROBLEM |
 | VALIDATION_METHOD_FAILURE |
Inheritance Hierarchy
Object
ConfigurationConstants


CONFIGURED_DEFAULT_KEY_CANNOT_BE_FOUND Field

CONFIGURED_DEFAULT_KEY_CANNOT_BE_FOUND Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► CONFIGURED_DEFAULT_KEY_CANNOT_BE_FOUND
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.CONFIGURED_DEFAULT_KEY_CANNOT_BE_FOUND]

Declaration Syntax
C# Visual Basic Visual C++
public const string CONFIGURED_DEFAULT_KEY_CANNOT_BE_FOUND
Public Const CONFIGURED_DEFAULT_KEY_CANNOT_BE_FOUND As String
public:
literal String^ CONFIGURED_DEFAULT_KEY_CANNOT_BE_FOUND


COULD_NOT_CREATE_INSTANCE Field

COULD_NOT_CREATE_INSTANCE Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► COULD_NOT_CREATE_INSTANCE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.COULD_NOT_CREATE_INSTANCE]

Declaration Syntax
C# Visual Basic Visual C++
public const string COULD_NOT_CREATE_INSTANCE
Public Const COULD_NOT_CREATE_INSTANCE As String
public:
literal String^ COULD_NOT_CREATE_INSTANCE


COULD_NOT_CREATE_MEMENTO_SOURCE Field

COULD_NOT_CREATE_MEMENTO_SOURCE Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► COULD_NOT_CREATE_MEMENTO_SOURCE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.COULD_NOT_CREATE_MEMENTO_SOURCE]

Declaration Syntax
C# Visual Basic Visual C++
public const string COULD_NOT_CREATE_MEMENTO_SOURCE
Public Const COULD_NOT_CREATE_MEMENTO_SOURCE As String
public:
literal String^ COULD_NOT_CREATE_MEMENTO_SOURCE


COULD_NOT_LOAD_ASSEMBLY Field

COULD_NOT_LOAD_ASSEMBLY Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► COULD_NOT_LOAD_ASSEMBLY
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.COULD_NOT_LOAD_ASSEMBLY]

Declaration Syntax
C# Visual Basic Visual C++
public const string COULD_NOT_LOAD_ASSEMBLY
Public Const COULD_NOT_LOAD_ASSEMBLY As String
public:
literal String^ COULD_NOT_LOAD_ASSEMBLY


COULD_NOT_LOAD_TYPE Field

COULD_NOT_LOAD_TYPE Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► COULD_NOT_LOAD_TYPE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.COULD_NOT_LOAD_TYPE]

Declaration Syntax
C# Visual Basic Visual C++
public const string COULD_NOT_LOAD_TYPE
Public Const COULD_NOT_LOAD_TYPE As String
public:
literal String^ COULD_NOT_LOAD_TYPE


FATAL_ERROR Field

FATAL_ERROR Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► FATAL_ERROR
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.FATAL_ERROR]

Declaration Syntax
C# Visual Basic Visual C++
public const string FATAL_ERROR
Public Const FATAL_ERROR As String
public:
literal String^ FATAL_ERROR


INVALID_ENUMERATION_VALUE Field

INVALID_ENUMERATION_VALUE Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► INVALID_ENUMERATION_VALUE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.INVALID_ENUMERATION_VALUE]

Declaration Syntax
C# Visual Basic Visual C++
public const string INVALID_ENUMERATION_VALUE
Public Const INVALID_ENUMERATION_VALUE As String
public:
literal String^ INVALID_ENUMERATION_VALUE


INVALID_PLUGIN Field

INVALID_PLUGIN Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► INVALID_PLUGIN
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.INVALID_PLUGIN]

Declaration Syntax
C# Visual Basic Visual C++
public const string INVALID_PLUGIN
Public Const INVALID_PLUGIN As String
public:
literal String^ INVALID_PLUGIN


INVALID_PLUGIN_FAMILY Field

INVALID_PLUGIN_FAMILY Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► INVALID_PLUGIN_FAMILY
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.INVALID_PLUGIN_FAMILY]

Declaration Syntax
C# Visual Basic Visual C++
public const string INVALID_PLUGIN_FAMILY
Public Const INVALID_PLUGIN_FAMILY As String
public:
literal String^ INVALID_PLUGIN_FAMILY


INVALID_PROPERTY_CAST Field

INVALID_PROPERTY_CAST Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► INVALID_PROPERTY_CAST
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.INVALID_PROPERTY_CAST]

Declaration Syntax
C# Visual Basic Visual C++
public const string INVALID_PROPERTY_CAST
Public Const INVALID_PROPERTY_CAST As String
public:
literal String^ INVALID_PROPERTY_CAST


INVALID_SETTER Field

INVALID_SETTER Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► INVALID_SETTER
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.INVALID_SETTER]

Declaration Syntax
C# Visual Basic Visual C++
public const string INVALID_SETTER
Public Const INVALID_SETTER As String
public:
literal String^ INVALID_SETTER


MEMENTO_PROPERTY_IS_MISSING Field

MEMENTO_PROPERTY_IS_MISSING Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► MEMENTO_PROPERTY_IS_MISSING
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.MEMENTO_PROPERTY_IS_MISSING]

Declaration Syntax
C# Visual Basic Visual C++
public const string MEMENTO_PROPERTY_IS_MISSING
Public Const MEMENTO_PROPERTY_IS_MISSING As String
public:
literal String^ MEMENTO_PROPERTY_IS_MISSING


MEMENTO_SOURCE_CANNOT_RETRIEVE Field

MEMENTO_SOURCE_CANNOT_RETRIEVE Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► MEMENTO_SOURCE_CANNOT_RETRIEVE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.MEMENTO_SOURCE_CANNOT_RETRIEVE]

Declaration Syntax
C# Visual Basic Visual C++
public const string MEMENTO_SOURCE_CANNOT_RETRIEVE
Public Const MEMENTO_SOURCE_CANNOT_RETRIEVE As String
public:
literal String^ MEMENTO_SOURCE_CANNOT_RETRIEVE


MISSING_CHILD Field

MISSING_CHILD Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► MISSING_CHILD
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.MISSING_CHILD]

Declaration Syntax
C# Visual Basic Visual C++
public const string MISSING_CHILD
Public Const MISSING_CHILD As String
public:
literal String^ MISSING_CHILD


MISSING_INSTANCE_KEY Field

MISSING_INSTANCE_KEY Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► MISSING_INSTANCE_KEY
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.MISSING_INSTANCE_KEY]

Declaration Syntax
C# Visual Basic Visual C++
public const string MISSING_INSTANCE_KEY
Public Const MISSING_INSTANCE_KEY As String
public:
literal String^ MISSING_INSTANCE_KEY


MISSING_TEMPLATE_VALUE Field

MISSING_TEMPLATE_VALUE Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► MISSING_TEMPLATE_VALUE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.MISSING_TEMPLATE_VALUE]

Declaration Syntax
C# Visual Basic Visual C++
public const string MISSING_TEMPLATE_VALUE
Public Const MISSING_TEMPLATE_VALUE As String
public:
literal String^ MISSING_TEMPLATE_VALUE


NO_DEFAULT_INSTANCE_CONFIGURED Field

NO_DEFAULT_INSTANCE_CONFIGURED Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► NO_DEFAULT_INSTANCE_CONFIGURED
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.NO_DEFAULT_INSTANCE_CONFIGURED]

Declaration Syntax
C# Visual Basic Visual C++
public const string NO_DEFAULT_INSTANCE_CONFIGURED
Public Const NO_DEFAULT_INSTANCE_CONFIGURED As String
public:
literal String^ NO_DEFAULT_INSTANCE_CONFIGURED


NO_MATCHING_INSTANCE_CONFIGURED Field

NO_MATCHING_INSTANCE_CONFIGURED Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► NO_MATCHING_INSTANCE_CONFIGURED
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.NO_MATCHING_INSTANCE_CONFIGURED]

Declaration Syntax
C# Visual Basic Visual C++
public const string NO_MATCHING_INSTANCE_CONFIGURED
Public Const NO_MATCHING_INSTANCE_CONFIGURED As String
public:
literal String^ NO_MATCHING_INSTANCE_CONFIGURED


PLUGIN_CANNOT_READ_CONSTRUCTOR_PROPERTIES Field

PLUGIN_CANNOT_READ_CONSTRUCTOR_PROPERTIES Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► PLUGIN_CANNOT_READ_CONSTRUCTOR_PROPERTIES
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.PLUGIN_CANNOT_READ_CONSTRUCTOR_PROPERTIES]

Declaration Syntax
C# Visual Basic Visual C++
public const string PLUGIN_CANNOT_READ_CONSTRUCTOR_PROPERTIES
Public Const PLUGIN_CANNOT_READ_CONSTRUCTOR_PROPERTIES As String
public:
literal String^ PLUGIN_CANNOT_READ_CONSTRUCTOR_PROPERTIES


PLUGIN_FAMILY_CANNOT_BE_FOUND_FOR_INSTANCE Field

PLUGIN_FAMILY_CANNOT_BE_FOUND_FOR_INSTANCE Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► PLUGIN_FAMILY_CANNOT_BE_FOUND_FOR_INSTANCE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.PLUGIN_FAMILY_CANNOT_BE_FOUND_FOR_INSTANCE]

Declaration Syntax
C# Visual Basic Visual C++
public const string PLUGIN_FAMILY_CANNOT_BE_FOUND_FOR_INSTANCE
Public Const PLUGIN_FAMILY_CANNOT_BE_FOUND_FOR_INSTANCE As String
public:
literal String^ PLUGIN_FAMILY_CANNOT_BE_FOUND_FOR_INSTANCE


PLUGIN_IS_MISSING_CONCRETE_KEY Field

PLUGIN_IS_MISSING_CONCRETE_KEY Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► PLUGIN_IS_MISSING_CONCRETE_KEY
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.PLUGIN_IS_MISSING_CONCRETE_KEY]

Declaration Syntax
C# Visual Basic Visual C++
public const string PLUGIN_IS_MISSING_CONCRETE_KEY
Public Const PLUGIN_IS_MISSING_CONCRETE_KEY As String
public:
literal String^ PLUGIN_IS_MISSING_CONCRETE_KEY


UNKNOWN_PLUGIN_PROBLEM Field

UNKNOWN_PLUGIN_PROBLEM Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► UNKNOWN_PLUGIN_PROBLEM
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.UNKNOWN_PLUGIN_PROBLEM]

Declaration Syntax
C# Visual Basic Visual C++
public const string UNKNOWN_PLUGIN_PROBLEM
Public Const UNKNOWN_PLUGIN_PROBLEM As String
public:
literal String^ UNKNOWN_PLUGIN_PROBLEM


VALIDATION_METHOD_FAILURE Field

VALIDATION_METHOD_FAILURE Field
Namespaces ► StructureMap.Configuration ► ConfigurationConstants ► VALIDATION_METHOD_FAILURE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationConstants.VALIDATION_METHOD_FAILURE]

Declaration Syntax
C# Visual Basic Visual C++
public const string VALIDATION_METHOD_FAILURE
Public Const VALIDATION_METHOD_FAILURE As String
public:
literal String^ VALIDATION_METHOD_FAILURE


ConfigurationParser Class

ConfigurationParser Class
Namespaces ► StructureMap.Configuration ► ConfigurationParser
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.ConfigurationParser]

Declaration Syntax
C# Visual Basic Visual C++
public class ConfigurationParser : XmlConstants
Public Class ConfigurationParser _
    Inherits XmlConstants
public ref class ConfigurationParser : public XmlConstants
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationParser(XmlNode) | Initializes a new instance of the ConfigurationParser class
 | Description |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FilePath |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | ForEachFile(GraphLog, Action<(Of <(String>)>)) |
 | FromFile(String) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Id |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse(IGraphBuilder) |
 | ParseAssemblies(IGraphBuilder) |
 | ParseProfilesAndMachines(IGraphBuilder) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | XmlConstants
 |  | ConfigurationParser


ConfigurationParser Constructor (structureMapNode)

ConfigurationParser Constructor (structureMapNode)
Namespaces ► StructureMap.Configuration ► ConfigurationParser ► ConfigurationParser(XmlNode)
StructureMap API
Initializes a new instance of the ConfigurationParser class
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationParser(
    XmlNode structureMapNode
)
Public Sub New ( _
    structureMapNode As XmlNode _
)
public:
ConfigurationParser(
    XmlNode^ structureMapNode
)
Parameters
structureMapNode (XmlNode)

[Missing <param name="structureMapNode"/> documentation for "M:StructureMap.Configuration.ConfigurationParser.#ctor(System.Xml.XmlNode)"]


Description Field

Description Field
Namespaces ► StructureMap.Configuration ► ConfigurationParser ► Description
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.ConfigurationParser.Description]

Declaration Syntax
C# Visual Basic Visual C++
public string Description
Public Description As String
public:
String^ Description


FilePath Property

FilePath Property
Namespaces ► StructureMap.Configuration ► ConfigurationParser ► FilePath
StructureMap API

[Missing <summary> documentation for P:StructureMap.Configuration.ConfigurationParser.FilePath]

Declaration Syntax
C# Visual Basic Visual C++
public string FilePath { get; set; }
Public Property FilePath As String
public:
property String^ FilePath {
    String^ get ();
    void set (String^ value);
}


ForEachFile Method (log, action)

ForEachFile Method (log, action)
Namespaces ► StructureMap.Configuration ► ConfigurationParser ► ForEachFile(GraphLog, Action<(Of <(String>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ConfigurationParser.ForEachFile(StructureMap.Diagnostics.GraphLog,System.Action{System.String})]

Declaration Syntax
C# Visual Basic Visual C++
public void ForEachFile(
    GraphLog log,
    Action<string> action
)
Public Sub ForEachFile ( _
    log As GraphLog, _
    action As Action(Of String) _
)
public:
void ForEachFile(
    GraphLog^ log,
    Action<String^>^ action
)
Parameters
log (GraphLog)

[Missing <param name="log"/> documentation for "M:StructureMap.Configuration.ConfigurationParser.ForEachFile(StructureMap.Diagnostics.GraphLog,System.Action{System.String})"]

action (Action <(Of <( String >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.ConfigurationParser.ForEachFile(StructureMap.Diagnostics.GraphLog,System.Action{System.String})"]


FromFile Method (filename)

FromFile Method (filename)
Namespaces ► StructureMap.Configuration ► ConfigurationParser ► FromFile(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ConfigurationParser.FromFile(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static ConfigurationParser FromFile(
    string filename
)
Public Shared Function FromFile ( _
    filename As String _
) As ConfigurationParser
public:
static ConfigurationParser^ FromFile(
    String^ filename
)
Parameters
filename (String)

[Missing <param name="filename"/> documentation for "M:StructureMap.Configuration.ConfigurationParser.FromFile(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.ConfigurationParser.FromFile(System.String)]


Id Property

Id Property
Namespaces ► StructureMap.Configuration ► ConfigurationParser ► Id
StructureMap API

[Missing <summary> documentation for P:StructureMap.Configuration.ConfigurationParser.Id]

Declaration Syntax
C# Visual Basic Visual C++
public string Id { get; }
Public ReadOnly Property Id As String
public:
property String^ Id {
    String^ get ();
}


Parse Method (builder)

Parse Method (builder)
Namespaces ► StructureMap.Configuration ► ConfigurationParser ► Parse(IGraphBuilder)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ConfigurationParser.Parse(StructureMap.Configuration.IGraphBuilder)]

Declaration Syntax
C# Visual Basic Visual C++
public void Parse(
    IGraphBuilder builder
)
Public Sub Parse ( _
    builder As IGraphBuilder _
)
public:
void Parse(
    IGraphBuilder^ builder
)
Parameters
builder (IGraphBuilder)

[Missing <param name="builder"/> documentation for "M:StructureMap.Configuration.ConfigurationParser.Parse(StructureMap.Configuration.IGraphBuilder)"]


ParseAssemblies Method (builder)

ParseAssemblies Method (builder)
Namespaces ► StructureMap.Configuration ► ConfigurationParser ► ParseAssemblies(IGraphBuilder)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ConfigurationParser.ParseAssemblies(StructureMap.Configuration.IGraphBuilder)]

Declaration Syntax
C# Visual Basic Visual C++
public void ParseAssemblies(
    IGraphBuilder builder
)
Public Sub ParseAssemblies ( _
    builder As IGraphBuilder _
)
public:
void ParseAssemblies(
    IGraphBuilder^ builder
)
Parameters
builder (IGraphBuilder)

[Missing <param name="builder"/> documentation for "M:StructureMap.Configuration.ConfigurationParser.ParseAssemblies(StructureMap.Configuration.IGraphBuilder)"]


ParseProfilesAndMachines Method (builder)

ParseProfilesAndMachines Method (builder)
Namespaces ► StructureMap.Configuration ► ConfigurationParser ► ParseProfilesAndMachines(IGraphBuilder)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ConfigurationParser.ParseProfilesAndMachines(StructureMap.Configuration.IGraphBuilder)]

Declaration Syntax
C# Visual Basic Visual C++
public void ParseProfilesAndMachines(
    IGraphBuilder builder
)
Public Sub ParseProfilesAndMachines ( _
    builder As IGraphBuilder _
)
public:
void ParseProfilesAndMachines(
    IGraphBuilder^ builder
)
Parameters
builder (IGraphBuilder)

[Missing <param name="builder"/> documentation for "M:StructureMap.Configuration.ConfigurationParser.ParseProfilesAndMachines(StructureMap.Configuration.IGraphBuilder)"]


ConfigurationParserBuilder Class

ConfigurationParserBuilder Class
Namespaces ► StructureMap.Configuration ► ConfigurationParserBuilder
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.ConfigurationParserBuilder]

Declaration Syntax
C# Visual Basic Visual C++
public class ConfigurationParserBuilder : IConfigurationParserBuilder
Public Class ConfigurationParserBuilder _
    Implements IConfigurationParserBuilder
public ref class ConfigurationParserBuilder : IConfigurationParserBuilder
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfigurationParserBuilder(GraphLog) | Initializes a new instance of the ConfigurationParserBuilder class
 | DefaultConfigurationFilename | The name of the default configuration file. The value is always StructurMap.config
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetParsers()()() |
 | GetParsers(XmlNode, GraphLog) |
 | GetStructureMapConfigurationPath()()() | Returns the absolute path to the StructureMap.config file
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IgnoreDefaultFile |
 | IncludeFile(String) |
 | IncludeNode(XmlNode, String) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PullConfigurationFromAppConfig |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | UseAndEnforceExistenceOfDefaultFile |
Inheritance Hierarchy
Object
ConfigurationParserBuilder


ConfigurationParserBuilder Constructor (log)

ConfigurationParserBuilder Constructor (log)
Namespaces ► StructureMap.Configuration ► ConfigurationParserBuilder ► ConfigurationParserBuilder(GraphLog)
StructureMap API
Initializes a new instance of the ConfigurationParserBuilder class
Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationParserBuilder(
    GraphLog log
)
Public Sub New ( _
    log As GraphLog _
)
public:
ConfigurationParserBuilder(
    GraphLog^ log
)
Parameters
log (GraphLog)

[Missing <param name="log"/> documentation for "M:StructureMap.Configuration.ConfigurationParserBuilder.#ctor(StructureMap.Diagnostics.GraphLog)"]


DefaultConfigurationFilename Field

DefaultConfigurationFilename Field
Namespaces ► StructureMap.Configuration ► ConfigurationParserBuilder ► DefaultConfigurationFilename
StructureMap API
The name of the default configuration file. The value is always StructurMap.config
Declaration Syntax
C# Visual Basic Visual C++
public static readonly string DefaultConfigurationFilename
Public Shared ReadOnly DefaultConfigurationFilename As String
public:
static initonly String^ DefaultConfigurationFilename


GetParsers Method

GetParsers Method
Namespaces ► StructureMap.Configuration ► ConfigurationParserBuilder ► GetParsers()()()
StructureMap API
Members
Icon | Member | Description
 | GetParsers()()() |
 | GetParsers(XmlNode, GraphLog) |


GetParsers Method

GetParsers Method
Namespaces ► StructureMap.Configuration ► ConfigurationParserBuilder ► GetParsers()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ConfigurationParserBuilder.GetParsers]

Declaration Syntax
C# Visual Basic Visual C++
public ConfigurationParser[] GetParsers()
Public Function GetParsers As ConfigurationParser()
public:
array<ConfigurationParser^>^ GetParsers()
Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.ConfigurationParserBuilder.GetParsers]


GetParsers Method (node, log)

GetParsers Method (node, log)
Namespaces ► StructureMap.Configuration ► ConfigurationParserBuilder ► GetParsers(XmlNode, GraphLog)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ConfigurationParserBuilder.GetParsers(System.Xml.XmlNode,StructureMap.Diagnostics.GraphLog)]

Declaration Syntax
C# Visual Basic Visual C++
public static ConfigurationParser[] GetParsers(
    XmlNode node,
    GraphLog log
)
Public Shared Function GetParsers ( _
    node As XmlNode, _
    log As GraphLog _
) As ConfigurationParser()
public:
static array<ConfigurationParser^>^ GetParsers(
    XmlNode^ node,
    GraphLog^ log
)
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.Configuration.ConfigurationParserBuilder.GetParsers(System.Xml.XmlNode,StructureMap.Diagnostics.GraphLog)"]

log (GraphLog)

[Missing <param name="log"/> documentation for "M:StructureMap.Configuration.ConfigurationParserBuilder.GetParsers(System.Xml.XmlNode,StructureMap.Diagnostics.GraphLog)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.ConfigurationParserBuilder.GetParsers(System.Xml.XmlNode,StructureMap.Diagnostics.GraphLog)]


GetStructureMapConfigurationPath Method

GetStructureMapConfigurationPath Method
Namespaces ► StructureMap.Configuration ► ConfigurationParserBuilder ► GetStructureMapConfigurationPath()()()
StructureMap API
Returns the absolute path to the StructureMap.config file
Declaration Syntax
C# Visual Basic Visual C++
public static string GetStructureMapConfigurationPath()
Public Shared Function GetStructureMapConfigurationPath As String
public:
static String^ GetStructureMapConfigurationPath()
Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.ConfigurationParserBuilder.GetStructureMapConfigurationPath]


IgnoreDefaultFile Property

IgnoreDefaultFile Property
Namespaces ► StructureMap.Configuration ► ConfigurationParserBuilder ► IgnoreDefaultFile
StructureMap API

[Missing <summary> documentation for P:StructureMap.Configuration.ConfigurationParserBuilder.IgnoreDefaultFile]

Declaration Syntax
C# Visual Basic Visual C++
public bool IgnoreDefaultFile { get; set; }
Public Property IgnoreDefaultFile As Boolean
public:
virtual property bool IgnoreDefaultFile {
    bool get () sealed;
    void set (bool value) sealed;
}


IncludeFile Method (filename)

IncludeFile Method (filename)
Namespaces ► StructureMap.Configuration ► ConfigurationParserBuilder ► IncludeFile(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ConfigurationParserBuilder.IncludeFile(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void IncludeFile(
    string filename
)
Public Sub IncludeFile ( _
    filename As String _
)
public:
virtual void IncludeFile(
    String^ filename
) sealed
Parameters
filename (String)

[Missing <param name="filename"/> documentation for "M:StructureMap.Configuration.ConfigurationParserBuilder.IncludeFile(System.String)"]


IncludeNode Method (node, description)

IncludeNode Method (node, description)
Namespaces ► StructureMap.Configuration ► ConfigurationParserBuilder ► IncludeNode(XmlNode, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ConfigurationParserBuilder.IncludeNode(System.Xml.XmlNode,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void IncludeNode(
    XmlNode node,
    string description
)
Public Sub IncludeNode ( _
    node As XmlNode, _
    description As String _
)
public:
virtual void IncludeNode(
    XmlNode^ node,
    String^ description
) sealed
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.Configuration.ConfigurationParserBuilder.IncludeNode(System.Xml.XmlNode,System.String)"]

description (String)

[Missing <param name="description"/> documentation for "M:StructureMap.Configuration.ConfigurationParserBuilder.IncludeNode(System.Xml.XmlNode,System.String)"]


PullConfigurationFromAppConfig Property

PullConfigurationFromAppConfig Property
Namespaces ► StructureMap.Configuration ► ConfigurationParserBuilder ► PullConfigurationFromAppConfig
StructureMap API

[Missing <summary> documentation for P:StructureMap.Configuration.ConfigurationParserBuilder.PullConfigurationFromAppConfig]

Declaration Syntax
C# Visual Basic Visual C++
public bool PullConfigurationFromAppConfig { get; set; }
Public Property PullConfigurationFromAppConfig As Boolean
public:
virtual property bool PullConfigurationFromAppConfig {
    bool get () sealed;
    void set (bool value) sealed;
}


UseAndEnforceExistenceOfDefaultFile Property

UseAndEnforceExistenceOfDefaultFile Property
Namespaces ► StructureMap.Configuration ► ConfigurationParserBuilder ► UseAndEnforceExistenceOfDefaultFile
StructureMap API

[Missing <summary> documentation for P:StructureMap.Configuration.ConfigurationParserBuilder.UseAndEnforceExistenceOfDefaultFile]

Declaration Syntax
C# Visual Basic Visual C++
public bool UseAndEnforceExistenceOfDefaultFile { get; set; }
Public Property UseAndEnforceExistenceOfDefaultFile As Boolean
public:
virtual property bool UseAndEnforceExistenceOfDefaultFile {
    bool get () sealed;
    void set (bool value) sealed;
}


DictionaryReader Class

DictionaryReader Class
Namespaces ► StructureMap.Configuration ► DictionaryReader
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.DictionaryReader]

Declaration Syntax
C# Visual Basic Visual C++
public class DictionaryReader : ITypeReader
Public Class DictionaryReader _
    Implements ITypeReader
public ref class DictionaryReader : ITypeReader
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DictionaryReader()()() | Initializes a new instance of the DictionaryReader class
 | CanProcess(Type) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Read(XmlNode, Type) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DictionaryReader


DictionaryReader Constructor

DictionaryReader Constructor
Namespaces ► StructureMap.Configuration ► DictionaryReader ► DictionaryReader()()()
StructureMap API
Initializes a new instance of the DictionaryReader class
Declaration Syntax
C# Visual Basic Visual C++
public DictionaryReader()
Public Sub New
public:
DictionaryReader()


CanProcess Method (pluginType)

CanProcess Method (pluginType)
Namespaces ► StructureMap.Configuration ► DictionaryReader ► CanProcess(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DictionaryReader.CanProcess(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public bool CanProcess(
    Type pluginType
)
Public Function CanProcess ( _
    pluginType As Type _
) As Boolean
public:
virtual bool CanProcess(
    Type^ pluginType
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Configuration.DictionaryReader.CanProcess(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DictionaryReader.CanProcess(System.Type)]


Read Method (node, pluginType)

Read Method (node, pluginType)
Namespaces ► StructureMap.Configuration ► DictionaryReader ► Read(XmlNode, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DictionaryReader.Read(System.Xml.XmlNode,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public Instance Read(
    XmlNode node,
    Type pluginType
)
Public Function Read ( _
    node As XmlNode, _
    pluginType As Type _
) As Instance
public:
virtual Instance^ Read(
    XmlNode^ node,
    Type^ pluginType
) sealed
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.Configuration.DictionaryReader.Read(System.Xml.XmlNode,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Configuration.DictionaryReader.Read(System.Xml.XmlNode,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DictionaryReader.Read(System.Xml.XmlNode,System.Type)]


FamilyParser Class

FamilyParser Class
Namespaces ► StructureMap.Configuration ► FamilyParser
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.FamilyParser]

Declaration Syntax
C# Visual Basic Visual C++
public class FamilyParser : XmlConstants
Public Class FamilyParser _
    Inherits XmlConstants
public ref class FamilyParser : public XmlConstants
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FamilyParser(IGraphBuilder, XmlMementoCreator) | Initializes a new instance of the FamilyParser class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParseDefaultElement(XmlElement) |
 | ParseFamily(XmlElement) |
 | ParseInstanceElement(XmlElement) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | XmlConstants
 |  | FamilyParser


FamilyParser Constructor (builder, mementoCreator)

FamilyParser Constructor (builder, mementoCreator)
Namespaces ► StructureMap.Configuration ► FamilyParser ► FamilyParser(IGraphBuilder, XmlMementoCreator)
StructureMap API
Initializes a new instance of the FamilyParser class
Declaration Syntax
C# Visual Basic Visual C++
public FamilyParser(
    IGraphBuilder builder,
    XmlMementoCreator mementoCreator
)
Public Sub New ( _
    builder As IGraphBuilder, _
    mementoCreator As XmlMementoCreator _
)
public:
FamilyParser(
    IGraphBuilder^ builder,
    XmlMementoCreator^ mementoCreator
)
Parameters
builder (IGraphBuilder)

[Missing <param name="builder"/> documentation for "M:StructureMap.Configuration.FamilyParser.#ctor(StructureMap.Configuration.IGraphBuilder,StructureMap.Source.XmlMementoCreator)"]

mementoCreator (XmlMementoCreator)

[Missing <param name="mementoCreator"/> documentation for "M:StructureMap.Configuration.FamilyParser.#ctor(StructureMap.Configuration.IGraphBuilder,StructureMap.Source.XmlMementoCreator)"]


ParseDefaultElement Method (element)

ParseDefaultElement Method (element)
Namespaces ► StructureMap.Configuration ► FamilyParser ► ParseDefaultElement(XmlElement)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.FamilyParser.ParseDefaultElement(System.Xml.XmlElement)]

Declaration Syntax
C# Visual Basic Visual C++
public void ParseDefaultElement(
    XmlElement element
)
Public Sub ParseDefaultElement ( _
    element As XmlElement _
)
public:
void ParseDefaultElement(
    XmlElement^ element
)
Parameters
element (XmlElement)

[Missing <param name="element"/> documentation for "M:StructureMap.Configuration.FamilyParser.ParseDefaultElement(System.Xml.XmlElement)"]


ParseFamily Method (familyElement)

ParseFamily Method (familyElement)
Namespaces ► StructureMap.Configuration ► FamilyParser ► ParseFamily(XmlElement)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.FamilyParser.ParseFamily(System.Xml.XmlElement)]

Declaration Syntax
C# Visual Basic Visual C++
public void ParseFamily(
    XmlElement familyElement
)
Public Sub ParseFamily ( _
    familyElement As XmlElement _
)
public:
void ParseFamily(
    XmlElement^ familyElement
)
Parameters
familyElement (XmlElement)

[Missing <param name="familyElement"/> documentation for "M:StructureMap.Configuration.FamilyParser.ParseFamily(System.Xml.XmlElement)"]


ParseInstanceElement Method (element)

ParseInstanceElement Method (element)
Namespaces ► StructureMap.Configuration ► FamilyParser ► ParseInstanceElement(XmlElement)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.FamilyParser.ParseInstanceElement(System.Xml.XmlElement)]

Declaration Syntax
C# Visual Basic Visual C++
public void ParseInstanceElement(
    XmlElement element
)
Public Sub ParseInstanceElement ( _
    element As XmlElement _
)
public:
void ParseInstanceElement(
    XmlElement^ element
)
Parameters
element (XmlElement)

[Missing <param name="element"/> documentation for "M:StructureMap.Configuration.FamilyParser.ParseInstanceElement(System.Xml.XmlElement)"]


GraphBuilder Class

GraphBuilder Class
Namespaces ► StructureMap.Configuration ► GraphBuilder
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.GraphBuilder]

Declaration Syntax
C# Visual Basic Visual C++
public class GraphBuilder : IGraphBuilder
Public Class GraphBuilder _
    Implements IGraphBuilder
public ref class GraphBuilder : IGraphBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GraphBuilder(array<Registry>[]()[]) | Initializes a new instance of the GraphBuilder class
 | GraphBuilder(array<Registry>[]()[], PluginGraph) | Initializes a new instance of the GraphBuilder class
 | AddAssembly(String) |
 | ConfigureFamily(TypePath, Action<(Of <(PluginFamily>)>)) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FinishFamilies()()() |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetProfileBuilder()()() |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PluginGraph |
 | PrepareSystemObjects()()() |
 | SystemGraph |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WithSystemObject<(Of <(T>)>)(InstanceMemento, String, Action<(Of <(T>)>)) |
 | WithType(TypePath, String, Action<(Of <(Type>)>)) |
Inheritance Hierarchy
Object
GraphBuilder


GraphBuilder Constructor

GraphBuilder Constructor
Namespaces ► StructureMap.Configuration ► GraphBuilder ► GraphBuilder()()()
StructureMap API
Members
Icon | Member | Description
 | GraphBuilder(array<Registry>[]()[]) | Initializes a new instance of the GraphBuilder class
 | GraphBuilder(array<Registry>[]()[], PluginGraph) | Initializes a new instance of the GraphBuilder class


GraphBuilder Constructor (registries)

GraphBuilder Constructor (registries)
Namespaces ► StructureMap.Configuration ► GraphBuilder ► GraphBuilder(array<Registry>[]()[])
StructureMap API
Initializes a new instance of the GraphBuilder class
Declaration Syntax
C# Visual Basic Visual C++
public GraphBuilder(
    Registry[] registries
)
Public Sub New ( _
    registries As Registry() _
)
public:
GraphBuilder(
    array<Registry^>^ registries
)
Parameters
registries (array< Registry >[]()[])

[Missing <param name="registries"/> documentation for "M:StructureMap.Configuration.GraphBuilder.#ctor(StructureMap.Configuration.DSL.Registry[])"]


GraphBuilder Constructor (registries, pluginGraph)

GraphBuilder Constructor (registries, pluginGraph)
Namespaces ► StructureMap.Configuration ► GraphBuilder ► GraphBuilder(array<Registry>[]()[], PluginGraph)
StructureMap API
Initializes a new instance of the GraphBuilder class
Declaration Syntax
C# Visual Basic Visual C++
public GraphBuilder(
    Registry[] registries,
    PluginGraph pluginGraph
)
Public Sub New ( _
    registries As Registry(), _
    pluginGraph As PluginGraph _
)
public:
GraphBuilder(
    array<Registry^>^ registries,
    PluginGraph^ pluginGraph
)
Parameters
registries (array< Registry >[]()[])

[Missing <param name="registries"/> documentation for "M:StructureMap.Configuration.GraphBuilder.#ctor(StructureMap.Configuration.DSL.Registry[],StructureMap.Graph.PluginGraph)"]

pluginGraph (PluginGraph)

[Missing <param name="pluginGraph"/> documentation for "M:StructureMap.Configuration.GraphBuilder.#ctor(StructureMap.Configuration.DSL.Registry[],StructureMap.Graph.PluginGraph)"]


AddAssembly Method (assemblyName)

AddAssembly Method (assemblyName)
Namespaces ► StructureMap.Configuration ► GraphBuilder ► AddAssembly(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.GraphBuilder.AddAssembly(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddAssembly(
    string assemblyName
)
Public Sub AddAssembly ( _
    assemblyName As String _
)
public:
virtual void AddAssembly(
    String^ assemblyName
) sealed
Parameters
assemblyName (String)

[Missing <param name="assemblyName"/> documentation for "M:StructureMap.Configuration.GraphBuilder.AddAssembly(System.String)"]


ConfigureFamily Method (pluginTypePath, action)

ConfigureFamily Method (pluginTypePath, action)
Namespaces ► StructureMap.Configuration ► GraphBuilder ► ConfigureFamily(TypePath, Action<(Of <(PluginFamily>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.GraphBuilder.ConfigureFamily(StructureMap.Graph.TypePath,System.Action{StructureMap.Graph.PluginFamily})]

Declaration Syntax
C# Visual Basic Visual C++
public void ConfigureFamily(
    TypePath pluginTypePath,
    Action<PluginFamily> action
)
Public Sub ConfigureFamily ( _
    pluginTypePath As TypePath, _
    action As Action(Of PluginFamily) _
)
public:
virtual void ConfigureFamily(
    TypePath^ pluginTypePath,
    Action<PluginFamily^>^ action
) sealed
Parameters
pluginTypePath (TypePath)

[Missing <param name="pluginTypePath"/> documentation for "M:StructureMap.Configuration.GraphBuilder.ConfigureFamily(StructureMap.Graph.TypePath,System.Action{StructureMap.Graph.PluginFamily})"]

action (Action <(Of <( PluginFamily >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.GraphBuilder.ConfigureFamily(StructureMap.Graph.TypePath,System.Action{StructureMap.Graph.PluginFamily})"]


FinishFamilies Method

FinishFamilies Method
Namespaces ► StructureMap.Configuration ► GraphBuilder ► FinishFamilies()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.GraphBuilder.FinishFamilies]

Declaration Syntax
C# Visual Basic Visual C++
public void FinishFamilies()
Public Sub FinishFamilies
public:
virtual void FinishFamilies() sealed


GetProfileBuilder Method

GetProfileBuilder Method
Namespaces ► StructureMap.Configuration ► GraphBuilder ► GetProfileBuilder()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.GraphBuilder.GetProfileBuilder]

Declaration Syntax
C# Visual Basic Visual C++
public IProfileBuilder GetProfileBuilder()
Public Function GetProfileBuilder As IProfileBuilder
public:
virtual IProfileBuilder^ GetProfileBuilder() sealed
Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.GraphBuilder.GetProfileBuilder]


PluginGraph Property

PluginGraph Property
Namespaces ► StructureMap.Configuration ► GraphBuilder ► PluginGraph
StructureMap API

[Missing <summary> documentation for P:StructureMap.Configuration.GraphBuilder.PluginGraph]

Declaration Syntax
C# Visual Basic Visual C++
public PluginGraph PluginGraph { get; }
Public ReadOnly Property PluginGraph As PluginGraph
public:
virtual property PluginGraph^ PluginGraph {
    PluginGraph^ get () sealed;
}


PrepareSystemObjects Method

PrepareSystemObjects Method
Namespaces ► StructureMap.Configuration ► GraphBuilder ► PrepareSystemObjects()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.GraphBuilder.PrepareSystemObjects]

Declaration Syntax
C# Visual Basic Visual C++
public void PrepareSystemObjects()
Public Sub PrepareSystemObjects
public:
virtual void PrepareSystemObjects() sealed


SystemGraph Property

SystemGraph Property
Namespaces ► StructureMap.Configuration ► GraphBuilder ► SystemGraph
StructureMap API

[Missing <summary> documentation for P:StructureMap.Configuration.GraphBuilder.SystemGraph]

Declaration Syntax
C# Visual Basic Visual C++
public PluginGraph SystemGraph { get; }
Public ReadOnly Property SystemGraph As PluginGraph
public:
virtual property PluginGraph^ SystemGraph {
    PluginGraph^ get () sealed;
}


WithSystemObject Method (memento, context, action)

WithSystemObject<(Of <(T>)>) Method (memento, context, action)
Namespaces ► StructureMap.Configuration ► GraphBuilder ► WithSystemObject<(Of <(T>)>)(InstanceMemento, String, Action<(Of <(T>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.GraphBuilder.WithSystemObject``1(StructureMap.InstanceMemento,System.String,System.Action{``0})]

Declaration Syntax
C# Visual Basic Visual C++
public void WithSystemObject<T>(
    InstanceMemento memento,
    string context,
    Action<T> action
)

Public Sub WithSystemObject(Of T) ( _
    memento As InstanceMemento, _
    context As String, _
    action As Action(Of T) _
)
public:
generic<typename T>
virtual void WithSystemObject(
    InstanceMemento^ memento,
    String^ context,
    Action<T>^ action
) sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Configuration.GraphBuilder.WithSystemObject``1(StructureMap.InstanceMemento,System.String,System.Action{``0})"]

Parameters
memento (InstanceMemento)

[Missing <param name="memento"/> documentation for "M:StructureMap.Configuration.GraphBuilder.WithSystemObject``1(StructureMap.InstanceMemento,System.String,System.Action{``0})"]

context (String)

[Missing <param name="context"/> documentation for "M:StructureMap.Configuration.GraphBuilder.WithSystemObject``1(StructureMap.InstanceMemento,System.String,System.Action{``0})"]

action (Action <(Of <(T>)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.GraphBuilder.WithSystemObject``1(StructureMap.InstanceMemento,System.String,System.Action{``0})"]


WithType Method (path, context, action)

WithType Method (path, context, action)
Namespaces ► StructureMap.Configuration ► GraphBuilder ► WithType(TypePath, String, Action<(Of <(Type>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.GraphBuilder.WithType(StructureMap.Graph.TypePath,System.String,System.Action{System.Type})]

Declaration Syntax
C# Visual Basic Visual C++
public void WithType(
    TypePath path,
    string context,
    Action<Type> action
)
Public Sub WithType ( _
    path As TypePath, _
    context As String, _
    action As Action(Of Type) _
)
public:
virtual void WithType(
    TypePath^ path,
    String^ context,
    Action<Type^>^ action
) sealed
Parameters
path (TypePath)

[Missing <param name="path"/> documentation for "M:StructureMap.Configuration.GraphBuilder.WithType(StructureMap.Graph.TypePath,System.String,System.Action{System.Type})"]

context (String)

[Missing <param name="context"/> documentation for "M:StructureMap.Configuration.GraphBuilder.WithType(StructureMap.Graph.TypePath,System.String,System.Action{System.Type})"]

action (Action <(Of <( Type >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.GraphBuilder.WithType(StructureMap.Graph.TypePath,System.String,System.Action{System.Type})"]


IConfigurationParserBuilder Interface

IConfigurationParserBuilder Interface
Namespaces ► StructureMap.Configuration ► IConfigurationParserBuilder
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.IConfigurationParserBuilder]

Declaration Syntax
C# Visual Basic Visual C++
public interface IConfigurationParserBuilder
Public Interface IConfigurationParserBuilder
public interface class IConfigurationParserBuilder
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IgnoreDefaultFile |
 | IncludeFile(String) |
 | IncludeNode(XmlNode, String) |
 | PullConfigurationFromAppConfig |
 | UseAndEnforceExistenceOfDefaultFile |


IgnoreDefaultFile Property

IgnoreDefaultFile Property
Namespaces ► StructureMap.Configuration ► IConfigurationParserBuilder ► IgnoreDefaultFile
StructureMap API

[Missing <summary> documentation for P:StructureMap.Configuration.IConfigurationParserBuilder.IgnoreDefaultFile]

Declaration Syntax
C# Visual Basic Visual C++
bool IgnoreDefaultFile { get; set; }
Property IgnoreDefaultFile As Boolean
property bool IgnoreDefaultFile {
    bool get ();
    void set (bool value);
}


IncludeFile Method (filename)

IncludeFile Method (filename)
Namespaces ► StructureMap.Configuration ► IConfigurationParserBuilder ► IncludeFile(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.IConfigurationParserBuilder.IncludeFile(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
void IncludeFile(
    string filename
)
Sub IncludeFile ( _
    filename As String _
)
void IncludeFile(
    String^ filename
)
Parameters
filename (String)

[Missing <param name="filename"/> documentation for "M:StructureMap.Configuration.IConfigurationParserBuilder.IncludeFile(System.String)"]


IncludeNode Method (node, description)

IncludeNode Method (node, description)
Namespaces ► StructureMap.Configuration ► IConfigurationParserBuilder ► IncludeNode(XmlNode, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.IConfigurationParserBuilder.IncludeNode(System.Xml.XmlNode,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
void IncludeNode(
    XmlNode node,
    string description
)
Sub IncludeNode ( _
    node As XmlNode, _
    description As String _
)
void IncludeNode(
    XmlNode^ node,
    String^ description
)
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.Configuration.IConfigurationParserBuilder.IncludeNode(System.Xml.XmlNode,System.String)"]

description (String)

[Missing <param name="description"/> documentation for "M:StructureMap.Configuration.IConfigurationParserBuilder.IncludeNode(System.Xml.XmlNode,System.String)"]


PullConfigurationFromAppConfig Property

PullConfigurationFromAppConfig Property
Namespaces ► StructureMap.Configuration ► IConfigurationParserBuilder ► PullConfigurationFromAppConfig
StructureMap API

[Missing <summary> documentation for P:StructureMap.Configuration.IConfigurationParserBuilder.PullConfigurationFromAppConfig]

Declaration Syntax
C# Visual Basic Visual C++
bool PullConfigurationFromAppConfig { get; set; }
Property PullConfigurationFromAppConfig As Boolean
property bool PullConfigurationFromAppConfig {
    bool get ();
    void set (bool value);
}


UseAndEnforceExistenceOfDefaultFile Property

UseAndEnforceExistenceOfDefaultFile Property
Namespaces ► StructureMap.Configuration ► IConfigurationParserBuilder ► UseAndEnforceExistenceOfDefaultFile
StructureMap API

[Missing <summary> documentation for P:StructureMap.Configuration.IConfigurationParserBuilder.UseAndEnforceExistenceOfDefaultFile]

Declaration Syntax
C# Visual Basic Visual C++
bool UseAndEnforceExistenceOfDefaultFile { get; set; }
Property UseAndEnforceExistenceOfDefaultFile As Boolean
property bool UseAndEnforceExistenceOfDefaultFile {
    bool get ();
    void set (bool value);
}


IGraphBuilder Interface

IGraphBuilder Interface
Namespaces ► StructureMap.Configuration ► IGraphBuilder
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.IGraphBuilder]

Declaration Syntax
C# Visual Basic Visual C++
public interface IGraphBuilder
Public Interface IGraphBuilder
public interface class IGraphBuilder
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddAssembly(String) |
 | ConfigureFamily(TypePath, Action<(Of <(PluginFamily>)>)) |
 | FinishFamilies()()() |
 | GetProfileBuilder()()() |
 | PluginGraph |
 | PrepareSystemObjects()()() |
 | SystemGraph |
 | WithSystemObject<(Of <(T>)>)(InstanceMemento, String, Action<(Of <(T>)>)) |
 | WithType(TypePath, String, Action<(Of <(Type>)>)) |


AddAssembly Method (assemblyName)

AddAssembly Method (assemblyName)
Namespaces ► StructureMap.Configuration ► IGraphBuilder ► AddAssembly(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.IGraphBuilder.AddAssembly(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
void AddAssembly(
    string assemblyName
)
Sub AddAssembly ( _
    assemblyName As String _
)
void AddAssembly(
    String^ assemblyName
)
Parameters
assemblyName (String)

[Missing <param name="assemblyName"/> documentation for "M:StructureMap.Configuration.IGraphBuilder.AddAssembly(System.String)"]


ConfigureFamily Method (pluginTypePath, action)

ConfigureFamily Method (pluginTypePath, action)
Namespaces ► StructureMap.Configuration ► IGraphBuilder ► ConfigureFamily(TypePath, Action<(Of <(PluginFamily>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.IGraphBuilder.ConfigureFamily(StructureMap.Graph.TypePath,System.Action{StructureMap.Graph.PluginFamily})]

Declaration Syntax
C# Visual Basic Visual C++
void ConfigureFamily(
    TypePath pluginTypePath,
    Action<PluginFamily> action
)
Sub ConfigureFamily ( _
    pluginTypePath As TypePath, _
    action As Action(Of PluginFamily) _
)
void ConfigureFamily(
    TypePath^ pluginTypePath,
    Action<PluginFamily^>^ action
)
Parameters
pluginTypePath (TypePath)

[Missing <param name="pluginTypePath"/> documentation for "M:StructureMap.Configuration.IGraphBuilder.ConfigureFamily(StructureMap.Graph.TypePath,System.Action{StructureMap.Graph.PluginFamily})"]

action (Action <(Of <( PluginFamily >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.IGraphBuilder.ConfigureFamily(StructureMap.Graph.TypePath,System.Action{StructureMap.Graph.PluginFamily})"]


FinishFamilies Method

FinishFamilies Method
Namespaces ► StructureMap.Configuration ► IGraphBuilder ► FinishFamilies()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.IGraphBuilder.FinishFamilies]

Declaration Syntax
C# Visual Basic Visual C++
void FinishFamilies()
Sub FinishFamilies
void FinishFamilies()


GetProfileBuilder Method

GetProfileBuilder Method
Namespaces ► StructureMap.Configuration ► IGraphBuilder ► GetProfileBuilder()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.IGraphBuilder.GetProfileBuilder]

Declaration Syntax
C# Visual Basic Visual C++
IProfileBuilder GetProfileBuilder()
Function GetProfileBuilder As IProfileBuilder
IProfileBuilder^ GetProfileBuilder()
Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.IGraphBuilder.GetProfileBuilder]


PluginGraph Property

PluginGraph Property
Namespaces ► StructureMap.Configuration ► IGraphBuilder ► PluginGraph
StructureMap API

[Missing <summary> documentation for P:StructureMap.Configuration.IGraphBuilder.PluginGraph]

Declaration Syntax
C# Visual Basic Visual C++
PluginGraph PluginGraph { get; }
ReadOnly Property PluginGraph As PluginGraph
property PluginGraph^ PluginGraph {
    PluginGraph^ get ();
}


PrepareSystemObjects Method

PrepareSystemObjects Method
Namespaces ► StructureMap.Configuration ► IGraphBuilder ► PrepareSystemObjects()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.IGraphBuilder.PrepareSystemObjects]

Declaration Syntax
C# Visual Basic Visual C++
void PrepareSystemObjects()
Sub PrepareSystemObjects
void PrepareSystemObjects()


SystemGraph Property

SystemGraph Property
Namespaces ► StructureMap.Configuration ► IGraphBuilder ► SystemGraph
StructureMap API

[Missing <summary> documentation for P:StructureMap.Configuration.IGraphBuilder.SystemGraph]

Declaration Syntax
C# Visual Basic Visual C++
PluginGraph SystemGraph { get; }
ReadOnly Property SystemGraph As PluginGraph
property PluginGraph^ SystemGraph {
    PluginGraph^ get ();
}


WithSystemObject Method (memento, context, action)

WithSystemObject<(Of <(T>)>) Method (memento, context, action)
Namespaces ► StructureMap.Configuration ► IGraphBuilder ► WithSystemObject<(Of <(T>)>)(InstanceMemento, String, Action<(Of <(T>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.IGraphBuilder.WithSystemObject``1(StructureMap.InstanceMemento,System.String,System.Action{``0})]

Declaration Syntax
C# Visual Basic Visual C++
void WithSystemObject<T>(
    InstanceMemento memento,
    string context,
    Action<T> action
)

Sub WithSystemObject(Of T) ( _
    memento As InstanceMemento, _
    context As String, _
    action As Action(Of T) _
)
generic<typename T>
void WithSystemObject(
    InstanceMemento^ memento,
    String^ context,
    Action<T>^ action
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Configuration.IGraphBuilder.WithSystemObject``1(StructureMap.InstanceMemento,System.String,System.Action{``0})"]

Parameters
memento (InstanceMemento)

[Missing <param name="memento"/> documentation for "M:StructureMap.Configuration.IGraphBuilder.WithSystemObject``1(StructureMap.InstanceMemento,System.String,System.Action{``0})"]

context (String)

[Missing <param name="context"/> documentation for "M:StructureMap.Configuration.IGraphBuilder.WithSystemObject``1(StructureMap.InstanceMemento,System.String,System.Action{``0})"]

action (Action <(Of <(T>)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.IGraphBuilder.WithSystemObject``1(StructureMap.InstanceMemento,System.String,System.Action{``0})"]


WithType Method (path, context, action)

WithType Method (path, context, action)
Namespaces ► StructureMap.Configuration ► IGraphBuilder ► WithType(TypePath, String, Action<(Of <(Type>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.IGraphBuilder.WithType(StructureMap.Graph.TypePath,System.String,System.Action{System.Type})]

Declaration Syntax
C# Visual Basic Visual C++
void WithType(
    TypePath path,
    string context,
    Action<Type> action
)
Sub WithType ( _
    path As TypePath, _
    context As String, _
    action As Action(Of Type) _
)
void WithType(
    TypePath^ path,
    String^ context,
    Action<Type^>^ action
)
Parameters
path (TypePath)

[Missing <param name="path"/> documentation for "M:StructureMap.Configuration.IGraphBuilder.WithType(StructureMap.Graph.TypePath,System.String,System.Action{System.Type})"]

context (String)

[Missing <param name="context"/> documentation for "M:StructureMap.Configuration.IGraphBuilder.WithType(StructureMap.Graph.TypePath,System.String,System.Action{System.Type})"]

action (Action <(Of <( Type >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.IGraphBuilder.WithType(StructureMap.Graph.TypePath,System.String,System.Action{System.Type})"]


IProfileBuilder Interface

IProfileBuilder Interface
Namespaces ► StructureMap.Configuration ► IProfileBuilder
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.IProfileBuilder]

Declaration Syntax
C# Visual Basic Visual C++
public interface IProfileBuilder
Public Interface IProfileBuilder
public interface class IProfileBuilder
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddMachine(String, String) |
 | AddProfile(String) |
 | OverrideMachine(TypePath, String) |
 | OverrideProfile(TypePath, String) |
 | SetDefaultProfileName(String) |


AddMachine Method (machineName, profileName)

AddMachine Method (machineName, profileName)
Namespaces ► StructureMap.Configuration ► IProfileBuilder ► AddMachine(String, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.IProfileBuilder.AddMachine(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
void AddMachine(
    string machineName,
    string profileName
)
Sub AddMachine ( _
    machineName As String, _
    profileName As String _
)
void AddMachine(
    String^ machineName,
    String^ profileName
)
Parameters
machineName (String)

[Missing <param name="machineName"/> documentation for "M:StructureMap.Configuration.IProfileBuilder.AddMachine(System.String,System.String)"]

profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Configuration.IProfileBuilder.AddMachine(System.String,System.String)"]


AddProfile Method (profileName)

AddProfile Method (profileName)
Namespaces ► StructureMap.Configuration ► IProfileBuilder ► AddProfile(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.IProfileBuilder.AddProfile(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
void AddProfile(
    string profileName
)
Sub AddProfile ( _
    profileName As String _
)
void AddProfile(
    String^ profileName
)
Parameters
profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Configuration.IProfileBuilder.AddProfile(System.String)"]


OverrideMachine Method (typePath, instanceKey)

OverrideMachine Method (typePath, instanceKey)
Namespaces ► StructureMap.Configuration ► IProfileBuilder ► OverrideMachine(TypePath, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.IProfileBuilder.OverrideMachine(StructureMap.Graph.TypePath,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
void OverrideMachine(
    TypePath typePath,
    string instanceKey
)
Sub OverrideMachine ( _
    typePath As TypePath, _
    instanceKey As String _
)
void OverrideMachine(
    TypePath^ typePath,
    String^ instanceKey
)
Parameters
typePath (TypePath)

[Missing <param name="typePath"/> documentation for "M:StructureMap.Configuration.IProfileBuilder.OverrideMachine(StructureMap.Graph.TypePath,System.String)"]

instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Configuration.IProfileBuilder.OverrideMachine(StructureMap.Graph.TypePath,System.String)"]


OverrideProfile Method (typePath, instanceKey)

OverrideProfile Method (typePath, instanceKey)
Namespaces ► StructureMap.Configuration ► IProfileBuilder ► OverrideProfile(TypePath, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.IProfileBuilder.OverrideProfile(StructureMap.Graph.TypePath,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
void OverrideProfile(
    TypePath typePath,
    string instanceKey
)
Sub OverrideProfile ( _
    typePath As TypePath, _
    instanceKey As String _
)
void OverrideProfile(
    TypePath^ typePath,
    String^ instanceKey
)
Parameters
typePath (TypePath)

[Missing <param name="typePath"/> documentation for "M:StructureMap.Configuration.IProfileBuilder.OverrideProfile(StructureMap.Graph.TypePath,System.String)"]

instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Configuration.IProfileBuilder.OverrideProfile(StructureMap.Graph.TypePath,System.String)"]


SetDefaultProfileName Method (profileName)

SetDefaultProfileName Method (profileName)
Namespaces ► StructureMap.Configuration ► IProfileBuilder ► SetDefaultProfileName(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.IProfileBuilder.SetDefaultProfileName(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
void SetDefaultProfileName(
    string profileName
)
Sub SetDefaultProfileName ( _
    profileName As String _
)
void SetDefaultProfileName(
    String^ profileName
)
Parameters
profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Configuration.IProfileBuilder.SetDefaultProfileName(System.String)"]


ITypeReader Interface

ITypeReader Interface
Namespaces ► StructureMap.Configuration ► ITypeReader
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.ITypeReader]

Declaration Syntax
C# Visual Basic Visual C++
public interface ITypeReader
Public Interface ITypeReader
public interface class ITypeReader
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CanProcess(Type) |
 | Read(XmlNode, Type) |


CanProcess Method (pluginType)

CanProcess Method (pluginType)
Namespaces ► StructureMap.Configuration ► ITypeReader ► CanProcess(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ITypeReader.CanProcess(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
bool CanProcess(
    Type pluginType
)
Function CanProcess ( _
    pluginType As Type _
) As Boolean
bool CanProcess(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Configuration.ITypeReader.CanProcess(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.ITypeReader.CanProcess(System.Type)]


Read Method (node, pluginType)

Read Method (node, pluginType)
Namespaces ► StructureMap.Configuration ► ITypeReader ► Read(XmlNode, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ITypeReader.Read(System.Xml.XmlNode,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
Instance Read(
    XmlNode node,
    Type pluginType
)
Function Read ( _
    node As XmlNode, _
    pluginType As Type _
) As Instance
Instance^ Read(
    XmlNode^ node,
    Type^ pluginType
)
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.Configuration.ITypeReader.Read(System.Xml.XmlNode,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Configuration.ITypeReader.Read(System.Xml.XmlNode,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.ITypeReader.Read(System.Xml.XmlNode,System.Type)]


PrimitiveArrayReader Class

PrimitiveArrayReader Class
Namespaces ► StructureMap.Configuration ► PrimitiveArrayReader
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.PrimitiveArrayReader]

Declaration Syntax
C# Visual Basic Visual C++
public class PrimitiveArrayReader : TypeRules,
    ITypeReader
Public Class PrimitiveArrayReader _
    Inherits TypeRules _
    Implements ITypeReader
public ref class PrimitiveArrayReader : public TypeRules,
    ITypeReader
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PrimitiveArrayReader()()() | Initializes a new instance of the PrimitiveArrayReader class
 | CanProcess(Type) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAutoFillable(Type) | (Inherited from TypeRules.)
 | IsChild(Type) | (Inherited from TypeRules.)
 | IsChildArray(Type) | (Inherited from TypeRules.)
 | IsConcrete(Type) | (Inherited from TypeRules.)
 | IsEnum(Type) | (Inherited from TypeRules.)
 | IsPrimitive(Type) | (Inherited from TypeRules.)
 | IsPrimitiveArray(Type) | (Inherited from TypeRules.)
 | IsSimple(Type) | (Inherited from TypeRules.)
 | IsString(Type) | (Inherited from TypeRules.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Read(XmlNode, Type) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypeRules
 |  | PrimitiveArrayReader


PrimitiveArrayReader Constructor

PrimitiveArrayReader Constructor
Namespaces ► StructureMap.Configuration ► PrimitiveArrayReader ► PrimitiveArrayReader()()()
StructureMap API
Initializes a new instance of the PrimitiveArrayReader class
Declaration Syntax
C# Visual Basic Visual C++
public PrimitiveArrayReader()
Public Sub New
public:
PrimitiveArrayReader()


CanProcess Method (pluginType)

CanProcess Method (pluginType)
Namespaces ► StructureMap.Configuration ► PrimitiveArrayReader ► CanProcess(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.PrimitiveArrayReader.CanProcess(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public bool CanProcess(
    Type pluginType
)
Public Function CanProcess ( _
    pluginType As Type _
) As Boolean
public:
virtual bool CanProcess(
    Type^ pluginType
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Configuration.PrimitiveArrayReader.CanProcess(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.PrimitiveArrayReader.CanProcess(System.Type)]


Read Method (node, pluginType)

Read Method (node, pluginType)
Namespaces ► StructureMap.Configuration ► PrimitiveArrayReader ► Read(XmlNode, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.PrimitiveArrayReader.Read(System.Xml.XmlNode,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public Instance Read(
    XmlNode node,
    Type pluginType
)
Public Function Read ( _
    node As XmlNode, _
    pluginType As Type _
) As Instance
public:
virtual Instance^ Read(
    XmlNode^ node,
    Type^ pluginType
) sealed
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.Configuration.PrimitiveArrayReader.Read(System.Xml.XmlNode,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Configuration.PrimitiveArrayReader.Read(System.Xml.XmlNode,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.PrimitiveArrayReader.Read(System.Xml.XmlNode,System.Type)]


ProfileAndMachineParser Class

ProfileAndMachineParser Class
Namespaces ► StructureMap.Configuration ► ProfileAndMachineParser
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.ProfileAndMachineParser]

Declaration Syntax
C# Visual Basic Visual C++
public class ProfileAndMachineParser : XmlConstants
Public Class ProfileAndMachineParser _
    Inherits XmlConstants
public ref class ProfileAndMachineParser : public XmlConstants
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProfileAndMachineParser(IGraphBuilder, XmlNode, XmlMementoCreator) | Initializes a new instance of the ProfileAndMachineParser class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parse()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | XmlConstants
 |  | ProfileAndMachineParser


ProfileAndMachineParser Constructor (graphBuilder, structureMapNode, creator)

ProfileAndMachineParser Constructor (graphBuilder, structureMapNode, creator)
Namespaces ► StructureMap.Configuration ► ProfileAndMachineParser ► ProfileAndMachineParser(IGraphBuilder, XmlNode, XmlMementoCreator)
StructureMap API
Initializes a new instance of the ProfileAndMachineParser class
Declaration Syntax
C# Visual Basic Visual C++
public ProfileAndMachineParser(
    IGraphBuilder graphBuilder,
    XmlNode structureMapNode,
    XmlMementoCreator creator
)
Public Sub New ( _
    graphBuilder As IGraphBuilder, _
    structureMapNode As XmlNode, _
    creator As XmlMementoCreator _
)
public:
ProfileAndMachineParser(
    IGraphBuilder^ graphBuilder,
    XmlNode^ structureMapNode,
    XmlMementoCreator^ creator
)
Parameters
graphBuilder (IGraphBuilder)

[Missing <param name="graphBuilder"/> documentation for "M:StructureMap.Configuration.ProfileAndMachineParser.#ctor(StructureMap.Configuration.IGraphBuilder,System.Xml.XmlNode,StructureMap.Source.XmlMementoCreator)"]

structureMapNode (XmlNode)

[Missing <param name="structureMapNode"/> documentation for "M:StructureMap.Configuration.ProfileAndMachineParser.#ctor(StructureMap.Configuration.IGraphBuilder,System.Xml.XmlNode,StructureMap.Source.XmlMementoCreator)"]

creator (XmlMementoCreator)

[Missing <param name="creator"/> documentation for "M:StructureMap.Configuration.ProfileAndMachineParser.#ctor(StructureMap.Configuration.IGraphBuilder,System.Xml.XmlNode,StructureMap.Source.XmlMementoCreator)"]


Parse Method

Parse Method
Namespaces ► StructureMap.Configuration ► ProfileAndMachineParser ► Parse()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ProfileAndMachineParser.Parse]

Declaration Syntax
C# Visual Basic Visual C++
public void Parse()
Public Sub Parse
public:
void Parse()


ProfileBuilder Class

ProfileBuilder Class
Namespaces ► StructureMap.Configuration ► ProfileBuilder
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.ProfileBuilder]

Declaration Syntax
C# Visual Basic Visual C++
public class ProfileBuilder : IProfileBuilder
Public Class ProfileBuilder _
    Implements IProfileBuilder
public ref class ProfileBuilder : IProfileBuilder
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProfileBuilder(PluginGraph, String) | Initializes a new instance of the ProfileBuilder class
 | ProfileBuilder(PluginGraph) | Initializes a new instance of the ProfileBuilder class
 | AddMachine(String, String) |
 | AddProfile(String) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMachineName()()() |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OverrideMachine(TypePath, String) |
 | OverrideMachineName(String) |
 | OverrideProfile(TypePath, String) |
 | ResetMachineName()()() |
 | SetDefaultProfileName(String) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProfileBuilder


ProfileBuilder Constructor

ProfileBuilder Constructor
Namespaces ► StructureMap.Configuration ► ProfileBuilder ► ProfileBuilder()()()
StructureMap API
Members
Icon | Member | Description
 | ProfileBuilder(PluginGraph, String) | Initializes a new instance of the ProfileBuilder class
 | ProfileBuilder(PluginGraph) | Initializes a new instance of the ProfileBuilder class


ProfileBuilder Constructor (pluginGraph)

ProfileBuilder Constructor (pluginGraph)
Namespaces ► StructureMap.Configuration ► ProfileBuilder ► ProfileBuilder(PluginGraph)
StructureMap API
Initializes a new instance of the ProfileBuilder class
Declaration Syntax
C# Visual Basic Visual C++
public ProfileBuilder(
    PluginGraph pluginGraph
)
Public Sub New ( _
    pluginGraph As PluginGraph _
)
public:
ProfileBuilder(
    PluginGraph^ pluginGraph
)
Parameters
pluginGraph (PluginGraph)

[Missing <param name="pluginGraph"/> documentation for "M:StructureMap.Configuration.ProfileBuilder.#ctor(StructureMap.Graph.PluginGraph)"]


ProfileBuilder Constructor (pluginGraph, machineName)

ProfileBuilder Constructor (pluginGraph, machineName)
Namespaces ► StructureMap.Configuration ► ProfileBuilder ► ProfileBuilder(PluginGraph, String)
StructureMap API
Initializes a new instance of the ProfileBuilder class
Declaration Syntax
C# Visual Basic Visual C++
public ProfileBuilder(
    PluginGraph pluginGraph,
    string machineName
)
Public Sub New ( _
    pluginGraph As PluginGraph, _
    machineName As String _
)
public:
ProfileBuilder(
    PluginGraph^ pluginGraph,
    String^ machineName
)
Parameters
pluginGraph (PluginGraph)

[Missing <param name="pluginGraph"/> documentation for "M:StructureMap.Configuration.ProfileBuilder.#ctor(StructureMap.Graph.PluginGraph,System.String)"]

machineName (String)

[Missing <param name="machineName"/> documentation for "M:StructureMap.Configuration.ProfileBuilder.#ctor(StructureMap.Graph.PluginGraph,System.String)"]


AddMachine Method (machineName, profileName)

AddMachine Method (machineName, profileName)
Namespaces ► StructureMap.Configuration ► ProfileBuilder ► AddMachine(String, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ProfileBuilder.AddMachine(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddMachine(
    string machineName,
    string profileName
)
Public Sub AddMachine ( _
    machineName As String, _
    profileName As String _
)
public:
virtual void AddMachine(
    String^ machineName,
    String^ profileName
) sealed
Parameters
machineName (String)

[Missing <param name="machineName"/> documentation for "M:StructureMap.Configuration.ProfileBuilder.AddMachine(System.String,System.String)"]

profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Configuration.ProfileBuilder.AddMachine(System.String,System.String)"]


AddProfile Method (profileName)

AddProfile Method (profileName)
Namespaces ► StructureMap.Configuration ► ProfileBuilder ► AddProfile(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ProfileBuilder.AddProfile(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddProfile(
    string profileName
)
Public Sub AddProfile ( _
    profileName As String _
)
public:
virtual void AddProfile(
    String^ profileName
) sealed
Parameters
profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Configuration.ProfileBuilder.AddProfile(System.String)"]


GetMachineName Method

GetMachineName Method
Namespaces ► StructureMap.Configuration ► ProfileBuilder ► GetMachineName()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ProfileBuilder.GetMachineName]

Declaration Syntax
C# Visual Basic Visual C++
public static string GetMachineName()
Public Shared Function GetMachineName As String
public:
static String^ GetMachineName()
Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.ProfileBuilder.GetMachineName]


OverrideMachine Method (typePath, instanceKey)

OverrideMachine Method (typePath, instanceKey)
Namespaces ► StructureMap.Configuration ► ProfileBuilder ► OverrideMachine(TypePath, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ProfileBuilder.OverrideMachine(StructureMap.Graph.TypePath,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void OverrideMachine(
    TypePath typePath,
    string instanceKey
)
Public Sub OverrideMachine ( _
    typePath As TypePath, _
    instanceKey As String _
)
public:
virtual void OverrideMachine(
    TypePath^ typePath,
    String^ instanceKey
) sealed
Parameters
typePath (TypePath)

[Missing <param name="typePath"/> documentation for "M:StructureMap.Configuration.ProfileBuilder.OverrideMachine(StructureMap.Graph.TypePath,System.String)"]

instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Configuration.ProfileBuilder.OverrideMachine(StructureMap.Graph.TypePath,System.String)"]


OverrideMachineName Method (machineName)

OverrideMachineName Method (machineName)
Namespaces ► StructureMap.Configuration ► ProfileBuilder ► OverrideMachineName(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ProfileBuilder.OverrideMachineName(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static void OverrideMachineName(
    string machineName
)
Public Shared Sub OverrideMachineName ( _
    machineName As String _
)
public:
static void OverrideMachineName(
    String^ machineName
)
Parameters
machineName (String)

[Missing <param name="machineName"/> documentation for "M:StructureMap.Configuration.ProfileBuilder.OverrideMachineName(System.String)"]


OverrideProfile Method (typePath, instanceKey)

OverrideProfile Method (typePath, instanceKey)
Namespaces ► StructureMap.Configuration ► ProfileBuilder ► OverrideProfile(TypePath, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ProfileBuilder.OverrideProfile(StructureMap.Graph.TypePath,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void OverrideProfile(
    TypePath typePath,
    string instanceKey
)
Public Sub OverrideProfile ( _
    typePath As TypePath, _
    instanceKey As String _
)
public:
virtual void OverrideProfile(
    TypePath^ typePath,
    String^ instanceKey
) sealed
Parameters
typePath (TypePath)

[Missing <param name="typePath"/> documentation for "M:StructureMap.Configuration.ProfileBuilder.OverrideProfile(StructureMap.Graph.TypePath,System.String)"]

instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Configuration.ProfileBuilder.OverrideProfile(StructureMap.Graph.TypePath,System.String)"]


ResetMachineName Method

ResetMachineName Method
Namespaces ► StructureMap.Configuration ► ProfileBuilder ► ResetMachineName()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ProfileBuilder.ResetMachineName]

Declaration Syntax
C# Visual Basic Visual C++
public static void ResetMachineName()
Public Shared Sub ResetMachineName
public:
static void ResetMachineName()


SetDefaultProfileName Method (profileName)

SetDefaultProfileName Method (profileName)
Namespaces ► StructureMap.Configuration ► ProfileBuilder ► SetDefaultProfileName(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.ProfileBuilder.SetDefaultProfileName(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetDefaultProfileName(
    string profileName
)
Public Sub SetDefaultProfileName ( _
    profileName As String _
)
public:
virtual void SetDefaultProfileName(
    String^ profileName
) sealed
Parameters
profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Configuration.ProfileBuilder.SetDefaultProfileName(System.String)"]


StructureMapConfigurationSection Class

StructureMapConfigurationSection Class
Namespaces ► StructureMap.Configuration ► StructureMapConfigurationSection
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.StructureMapConfigurationSection]

Declaration Syntax
C# Visual Basic Visual C++
public class StructureMapConfigurationSection : IConfigurationSectionHandler
Public Class StructureMapConfigurationSection _
    Implements IConfigurationSectionHandler
public ref class StructureMapConfigurationSection : IConfigurationSectionHandler
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | StructureMapConfigurationSection()()() | Initializes a new instance of the StructureMapConfigurationSection class
 | Create(Object, Object, XmlNode) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetStructureMapConfiguration()()() |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
StructureMapConfigurationSection


StructureMapConfigurationSection Constructor

StructureMapConfigurationSection Constructor
Namespaces ► StructureMap.Configuration ► StructureMapConfigurationSection ► StructureMapConfigurationSection()()()
StructureMap API
Initializes a new instance of the StructureMapConfigurationSection class
Declaration Syntax
C# Visual Basic Visual C++
public StructureMapConfigurationSection()
Public Sub New
public:
StructureMapConfigurationSection()


Create Method (parent, configContext, section)

Create Method (parent, configContext, section)
Namespaces ► StructureMap.Configuration ► StructureMapConfigurationSection ► Create(Object, Object, XmlNode)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.StructureMapConfigurationSection.Create(System.Object,System.Object,System.Xml.XmlNode)]

Declaration Syntax
C# Visual Basic Visual C++
public Object Create(
    Object parent,
    Object configContext,
    XmlNode section
)
Public Function Create ( _
    parent As Object, _
    configContext As Object, _
    section As XmlNode _
) As Object
public:
virtual Object^ Create(
    Object^ parent,
    Object^ configContext,
    XmlNode^ section
) sealed
Parameters
parent (Object)

[Missing <param name="parent"/> documentation for "M:StructureMap.Configuration.StructureMapConfigurationSection.Create(System.Object,System.Object,System.Xml.XmlNode)"]

configContext (Object)

[Missing <param name="configContext"/> documentation for "M:StructureMap.Configuration.StructureMapConfigurationSection.Create(System.Object,System.Object,System.Xml.XmlNode)"]

section (XmlNode)

[Missing <param name="section"/> documentation for "M:StructureMap.Configuration.StructureMapConfigurationSection.Create(System.Object,System.Object,System.Xml.XmlNode)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.StructureMapConfigurationSection.Create(System.Object,System.Object,System.Xml.XmlNode)]


GetStructureMapConfiguration Method

GetStructureMapConfiguration Method
Namespaces ► StructureMap.Configuration ► StructureMapConfigurationSection ► GetStructureMapConfiguration()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.StructureMapConfigurationSection.GetStructureMapConfiguration]

Declaration Syntax
C# Visual Basic Visual C++
public static IList<XmlNode> GetStructureMapConfiguration()
Public Shared Function GetStructureMapConfiguration As IList(Of XmlNode)
public:
static IList<XmlNode^>^ GetStructureMapConfiguration()
Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.StructureMapConfigurationSection.GetStructureMapConfiguration]


TypeReaderFactory Class

TypeReaderFactory Class
Namespaces ► StructureMap.Configuration ► TypeReaderFactory
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.TypeReaderFactory]

Declaration Syntax
C# Visual Basic Visual C++
public static class TypeReaderFactory
Public NotInheritable Class TypeReaderFactory
public ref class TypeReaderFactory abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetReader(Type) |
Inheritance Hierarchy
Object
TypeReaderFactory


GetReader Method (pluginType)

GetReader Method (pluginType)
Namespaces ► StructureMap.Configuration ► TypeReaderFactory ► GetReader(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.TypeReaderFactory.GetReader(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public static ITypeReader GetReader(
    Type pluginType
)
Public Shared Function GetReader ( _
    pluginType As Type _
) As ITypeReader
public:
static ITypeReader^ GetReader(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Configuration.TypeReaderFactory.GetReader(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.TypeReaderFactory.GetReader(System.Type)]


XmlConstants Class

XmlConstants Class
Namespaces ► StructureMap.Configuration ► XmlConstants
StructureMap API
Constants for the names of Xml nodes and attributes in the StructureMap.config file
Declaration Syntax
C# Visual Basic Visual C++
public class XmlConstants
Public Class XmlConstants
public ref class XmlConstants
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlConstants()()() | Initializes a new instance of the XmlConstants class
 | ADD_INSTANCE_NODE |
 | ASSEMBLY |
 | ATTRIBUTE_STYLE |
 | CONCRETE_KEY_ATTRIBUTE |
 | DEFAULT_INSTANCE |
 | DEFAULT_KEY_ATTRIBUTE |
 | DEFAULT_PROFILE |
 | DEPLOYMENT_ATTRIBUTE |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | INCLUDE_NODE |
 | INSTANCE_NODE |
 | INTERCEPTORS_NODE |
 | KEY_ATTRIBUTE |
 | MACHINE_NODE |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MEMENTO_SOURCE_NODE |
 | MEMENTO_STYLE |
 | NAME |
 | NODE_STYLE |
 | OVERRIDE |
 | PLUGGED_TYPE |
 | PLUGIN_FAMILY_NODE |
 | PLUGIN_NODE |
 | PLUGIN_TYPE |
 | PROFILE_NODE |
 | SCOPE |
 | STRUCTUREMAP |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TYPE_ATTRIBUTE |
Inheritance Hierarchy
Object
 | XmlConstants
 |  | ConfigurationParser
 |  | FamilyParser
 |  | ProfileAndMachineParser


XmlConstants Constructor

XmlConstants Constructor
Namespaces ► StructureMap.Configuration ► XmlConstants ► XmlConstants()()()
StructureMap API
Initializes a new instance of the XmlConstants class
Declaration Syntax
C# Visual Basic Visual C++
public XmlConstants()
Public Sub New
public:
XmlConstants()


ADD_INSTANCE_NODE Field

ADD_INSTANCE_NODE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► ADD_INSTANCE_NODE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.ADD_INSTANCE_NODE]

Declaration Syntax
C# Visual Basic Visual C++
public const string ADD_INSTANCE_NODE
Public Const ADD_INSTANCE_NODE As String
public:
literal String^ ADD_INSTANCE_NODE


ASSEMBLY Field

ASSEMBLY Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► ASSEMBLY
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.ASSEMBLY]

Declaration Syntax
C# Visual Basic Visual C++
public const string ASSEMBLY
Public Const ASSEMBLY As String
public:
literal String^ ASSEMBLY


ATTRIBUTE_STYLE Field

ATTRIBUTE_STYLE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► ATTRIBUTE_STYLE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.ATTRIBUTE_STYLE]

Declaration Syntax
C# Visual Basic Visual C++
public const string ATTRIBUTE_STYLE
Public Const ATTRIBUTE_STYLE As String
public:
literal String^ ATTRIBUTE_STYLE


CONCRETE_KEY_ATTRIBUTE Field

CONCRETE_KEY_ATTRIBUTE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► CONCRETE_KEY_ATTRIBUTE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.CONCRETE_KEY_ATTRIBUTE]

Declaration Syntax
C# Visual Basic Visual C++
public const string CONCRETE_KEY_ATTRIBUTE
Public Const CONCRETE_KEY_ATTRIBUTE As String
public:
literal String^ CONCRETE_KEY_ATTRIBUTE


DEFAULT_INSTANCE Field

DEFAULT_INSTANCE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► DEFAULT_INSTANCE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.DEFAULT_INSTANCE]

Declaration Syntax
C# Visual Basic Visual C++
public const string DEFAULT_INSTANCE
Public Const DEFAULT_INSTANCE As String
public:
literal String^ DEFAULT_INSTANCE


DEFAULT_KEY_ATTRIBUTE Field

DEFAULT_KEY_ATTRIBUTE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► DEFAULT_KEY_ATTRIBUTE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.DEFAULT_KEY_ATTRIBUTE]

Declaration Syntax
C# Visual Basic Visual C++
public const string DEFAULT_KEY_ATTRIBUTE
Public Const DEFAULT_KEY_ATTRIBUTE As String
public:
literal String^ DEFAULT_KEY_ATTRIBUTE


DEFAULT_PROFILE Field

DEFAULT_PROFILE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► DEFAULT_PROFILE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.DEFAULT_PROFILE]

Declaration Syntax
C# Visual Basic Visual C++
public const string DEFAULT_PROFILE
Public Const DEFAULT_PROFILE As String
public:
literal String^ DEFAULT_PROFILE


DEPLOYMENT_ATTRIBUTE Field

DEPLOYMENT_ATTRIBUTE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► DEPLOYMENT_ATTRIBUTE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.DEPLOYMENT_ATTRIBUTE]

Declaration Syntax
C# Visual Basic Visual C++
public const string DEPLOYMENT_ATTRIBUTE
Public Const DEPLOYMENT_ATTRIBUTE As String
public:
literal String^ DEPLOYMENT_ATTRIBUTE


INCLUDE_NODE Field

INCLUDE_NODE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► INCLUDE_NODE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.INCLUDE_NODE]

Declaration Syntax
C# Visual Basic Visual C++
public const string INCLUDE_NODE
Public Const INCLUDE_NODE As String
public:
literal String^ INCLUDE_NODE


INSTANCE_NODE Field

INSTANCE_NODE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► INSTANCE_NODE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.INSTANCE_NODE]

Declaration Syntax
C# Visual Basic Visual C++
public const string INSTANCE_NODE
Public Const INSTANCE_NODE As String
public:
literal String^ INSTANCE_NODE


INTERCEPTORS_NODE Field

INTERCEPTORS_NODE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► INTERCEPTORS_NODE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.INTERCEPTORS_NODE]

Declaration Syntax
C# Visual Basic Visual C++
public const string INTERCEPTORS_NODE
Public Const INTERCEPTORS_NODE As String
public:
literal String^ INTERCEPTORS_NODE


KEY_ATTRIBUTE Field

KEY_ATTRIBUTE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► KEY_ATTRIBUTE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.KEY_ATTRIBUTE]

Declaration Syntax
C# Visual Basic Visual C++
public const string KEY_ATTRIBUTE
Public Const KEY_ATTRIBUTE As String
public:
literal String^ KEY_ATTRIBUTE


MACHINE_NODE Field

MACHINE_NODE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► MACHINE_NODE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.MACHINE_NODE]

Declaration Syntax
C# Visual Basic Visual C++
public const string MACHINE_NODE
Public Const MACHINE_NODE As String
public:
literal String^ MACHINE_NODE


MEMENTO_SOURCE_NODE Field

MEMENTO_SOURCE_NODE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► MEMENTO_SOURCE_NODE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.MEMENTO_SOURCE_NODE]

Declaration Syntax
C# Visual Basic Visual C++
public const string MEMENTO_SOURCE_NODE
Public Const MEMENTO_SOURCE_NODE As String
public:
literal String^ MEMENTO_SOURCE_NODE


MEMENTO_STYLE Field

MEMENTO_STYLE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► MEMENTO_STYLE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.MEMENTO_STYLE]

Declaration Syntax
C# Visual Basic Visual C++
public const string MEMENTO_STYLE
Public Const MEMENTO_STYLE As String
public:
literal String^ MEMENTO_STYLE


NAME Field

NAME Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► NAME
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.NAME]

Declaration Syntax
C# Visual Basic Visual C++
public const string NAME
Public Const NAME As String
public:
literal String^ NAME


NODE_STYLE Field

NODE_STYLE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► NODE_STYLE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.NODE_STYLE]

Declaration Syntax
C# Visual Basic Visual C++
public const string NODE_STYLE
Public Const NODE_STYLE As String
public:
literal String^ NODE_STYLE


OVERRIDE Field

OVERRIDE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► OVERRIDE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.OVERRIDE]

Declaration Syntax
C# Visual Basic Visual C++
public const string OVERRIDE
Public Const OVERRIDE As String
public:
literal String^ OVERRIDE


PLUGGED_TYPE Field

PLUGGED_TYPE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► PLUGGED_TYPE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.PLUGGED_TYPE]

Declaration Syntax
C# Visual Basic Visual C++
public const string PLUGGED_TYPE
Public Const PLUGGED_TYPE As String
public:
literal String^ PLUGGED_TYPE


PLUGIN_FAMILY_NODE Field

PLUGIN_FAMILY_NODE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► PLUGIN_FAMILY_NODE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.PLUGIN_FAMILY_NODE]

Declaration Syntax
C# Visual Basic Visual C++
public const string PLUGIN_FAMILY_NODE
Public Const PLUGIN_FAMILY_NODE As String
public:
literal String^ PLUGIN_FAMILY_NODE


PLUGIN_NODE Field

PLUGIN_NODE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► PLUGIN_NODE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.PLUGIN_NODE]

Declaration Syntax
C# Visual Basic Visual C++
public const string PLUGIN_NODE
Public Const PLUGIN_NODE As String
public:
literal String^ PLUGIN_NODE


PLUGIN_TYPE Field

PLUGIN_TYPE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► PLUGIN_TYPE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.PLUGIN_TYPE]

Declaration Syntax
C# Visual Basic Visual C++
public const string PLUGIN_TYPE
Public Const PLUGIN_TYPE As String
public:
literal String^ PLUGIN_TYPE


PROFILE_NODE Field

PROFILE_NODE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► PROFILE_NODE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.PROFILE_NODE]

Declaration Syntax
C# Visual Basic Visual C++
public const string PROFILE_NODE
Public Const PROFILE_NODE As String
public:
literal String^ PROFILE_NODE


SCOPE Field

SCOPE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► SCOPE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.SCOPE]

Declaration Syntax
C# Visual Basic Visual C++
public const string SCOPE
Public Const SCOPE As String
public:
literal String^ SCOPE


STRUCTUREMAP Field

STRUCTUREMAP Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► STRUCTUREMAP
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.STRUCTUREMAP]

Declaration Syntax
C# Visual Basic Visual C++
public const string STRUCTUREMAP
Public Const STRUCTUREMAP As String
public:
literal String^ STRUCTUREMAP


TYPE_ATTRIBUTE Field

TYPE_ATTRIBUTE Field
Namespaces ► StructureMap.Configuration ► XmlConstants ► TYPE_ATTRIBUTE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Configuration.XmlConstants.TYPE_ATTRIBUTE]

Declaration Syntax
C# Visual Basic Visual C++
public const string TYPE_ATTRIBUTE
Public Const TYPE_ATTRIBUTE As String
public:
literal String^ TYPE_ATTRIBUTE


XmlExtensions Class

XmlExtensions Class
Namespaces ► StructureMap.Configuration ► XmlExtensions
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.XmlExtensions]

Declaration Syntax
C# Visual Basic Visual C++
public static class XmlExtensions
Public NotInheritable Class XmlExtensions
public ref class XmlExtensions abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ForAttributeValue(XmlNode, String, Action<(Of <(String>)>)) |
 | ForEachChild(XmlNode, String) |
 | ForTextInChild(XmlNode, String) |
 | GetAttribute(XmlNode, String, String) |
 | IfHasNode(XmlNode, String) |
Inheritance Hierarchy
Object
XmlExtensions


ForAttributeValue Method (node, attributeName, action)

ForAttributeValue Method (node, attributeName, action)
Namespaces ► StructureMap.Configuration ► XmlExtensions ► ForAttributeValue(XmlNode, String, Action<(Of <(String>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.XmlExtensions.ForAttributeValue(System.Xml.XmlNode,System.String,System.Action{System.String})]

Declaration Syntax
C# Visual Basic Visual C++
public static void ForAttributeValue(
    XmlNode node,
    string attributeName,
    Action<string> action
)
Public Shared Sub ForAttributeValue ( _
    node As XmlNode, _
    attributeName As String, _
    action As Action(Of String) _
)
public:
static void ForAttributeValue(
    XmlNode^ node,
    String^ attributeName,
    Action<String^>^ action
)
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.Configuration.XmlExtensions.ForAttributeValue(System.Xml.XmlNode,System.String,System.Action{System.String})"]

attributeName (String)

[Missing <param name="attributeName"/> documentation for "M:StructureMap.Configuration.XmlExtensions.ForAttributeValue(System.Xml.XmlNode,System.String,System.Action{System.String})"]

action (Action <(Of <( String >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.XmlExtensions.ForAttributeValue(System.Xml.XmlNode,System.String,System.Action{System.String})"]


ForEachChild Method (node, xpath)

ForEachChild Method (node, xpath)
Namespaces ► StructureMap.Configuration ► XmlExtensions ► ForEachChild(XmlNode, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.XmlExtensions.ForEachChild(System.Xml.XmlNode,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static XmlExtensions..::.XmlNodeExpression ForEachChild(
    XmlNode node,
    string xpath
)
Public Shared Function ForEachChild ( _
    node As XmlNode, _
    xpath As String _
) As XmlExtensions..::.XmlNodeExpression
public:
static XmlExtensions..::.XmlNodeExpression^ ForEachChild(
    XmlNode^ node,
    String^ xpath
)
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.Configuration.XmlExtensions.ForEachChild(System.Xml.XmlNode,System.String)"]

xpath (String)

[Missing <param name="xpath"/> documentation for "M:StructureMap.Configuration.XmlExtensions.ForEachChild(System.Xml.XmlNode,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.XmlExtensions.ForEachChild(System.Xml.XmlNode,System.String)]


ForTextInChild Method (node, xpath)

ForTextInChild Method (node, xpath)
Namespaces ► StructureMap.Configuration ► XmlExtensions ► ForTextInChild(XmlNode, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.XmlExtensions.ForTextInChild(System.Xml.XmlNode,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static XmlExtensions..::.XmlTextExpression ForTextInChild(
    XmlNode node,
    string xpath
)
Public Shared Function ForTextInChild ( _
    node As XmlNode, _
    xpath As String _
) As XmlExtensions..::.XmlTextExpression
public:
static XmlExtensions..::.XmlTextExpression^ ForTextInChild(
    XmlNode^ node,
    String^ xpath
)
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.Configuration.XmlExtensions.ForTextInChild(System.Xml.XmlNode,System.String)"]

xpath (String)

[Missing <param name="xpath"/> documentation for "M:StructureMap.Configuration.XmlExtensions.ForTextInChild(System.Xml.XmlNode,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.XmlExtensions.ForTextInChild(System.Xml.XmlNode,System.String)]


GetAttribute Method (node, attributeName, defaultValue)

GetAttribute Method (node, attributeName, defaultValue)
Namespaces ► StructureMap.Configuration ► XmlExtensions ► GetAttribute(XmlNode, String, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.XmlExtensions.GetAttribute(System.Xml.XmlNode,System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static string GetAttribute(
    XmlNode node,
    string attributeName,
    string defaultValue
)
Public Shared Function GetAttribute ( _
    node As XmlNode, _
    attributeName As String, _
    defaultValue As String _
) As String
public:
static String^ GetAttribute(
    XmlNode^ node,
    String^ attributeName,
    String^ defaultValue
)
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.Configuration.XmlExtensions.GetAttribute(System.Xml.XmlNode,System.String,System.String)"]

attributeName (String)

[Missing <param name="attributeName"/> documentation for "M:StructureMap.Configuration.XmlExtensions.GetAttribute(System.Xml.XmlNode,System.String,System.String)"]

defaultValue (String)

[Missing <param name="defaultValue"/> documentation for "M:StructureMap.Configuration.XmlExtensions.GetAttribute(System.Xml.XmlNode,System.String,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.XmlExtensions.GetAttribute(System.Xml.XmlNode,System.String,System.String)]


IfHasNode Method (node, xpath)

IfHasNode Method (node, xpath)
Namespaces ► StructureMap.Configuration ► XmlExtensions ► IfHasNode(XmlNode, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.XmlExtensions.IfHasNode(System.Xml.XmlNode,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static XmlExtensions..::.HasXmlElementExpression IfHasNode(
    XmlNode node,
    string xpath
)
Public Shared Function IfHasNode ( _
    node As XmlNode, _
    xpath As String _
) As XmlExtensions..::.HasXmlElementExpression
public:
static XmlExtensions..::.HasXmlElementExpression^ IfHasNode(
    XmlNode^ node,
    String^ xpath
)
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.Configuration.XmlExtensions.IfHasNode(System.Xml.XmlNode,System.String)"]

xpath (String)

[Missing <param name="xpath"/> documentation for "M:StructureMap.Configuration.XmlExtensions.IfHasNode(System.Xml.XmlNode,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.XmlExtensions.IfHasNode(System.Xml.XmlNode,System.String)]


XmlExtensions.HasXmlElementExpression Class

XmlExtensions..::.HasXmlElementExpression Class
Namespaces ► StructureMap.Configuration ► XmlExtensions ► XmlExtensions..::.HasXmlElementExpression
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.XmlExtensions.HasXmlElementExpression]

Declaration Syntax
C# Visual Basic Visual C++
public class HasXmlElementExpression
Public Class HasXmlElementExpression
public ref class HasXmlElementExpression
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Do(Action<(Of <(XmlElement>)>)) |
 | Else(Action) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
XmlExtensions..::.HasXmlElementExpression


Do Method (action)

Do Method (action)
Namespaces ► StructureMap.Configuration ► XmlExtensions..::.HasXmlElementExpression ► Do(Action<(Of <(XmlElement>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.XmlExtensions.HasXmlElementExpression.Do(System.Action{System.Xml.XmlElement})]

Declaration Syntax
C# Visual Basic Visual C++
public XmlExtensions..::.HasXmlElementExpression Do(
    Action<XmlElement> action
)
Public Function Do ( _
    action As Action(Of XmlElement) _
) As XmlExtensions..::.HasXmlElementExpression
public:
XmlExtensions..::.HasXmlElementExpression^ Do(
    Action<XmlElement^>^ action
)
Parameters
action (Action <(Of <( XmlElement >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.XmlExtensions.HasXmlElementExpression.Do(System.Action{System.Xml.XmlElement})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.XmlExtensions.HasXmlElementExpression.Do(System.Action{System.Xml.XmlElement})]


Else Method (action)

Else Method (action)
Namespaces ► StructureMap.Configuration ► XmlExtensions..::.HasXmlElementExpression ► Else(Action)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.XmlExtensions.HasXmlElementExpression.Else(System.Action)]

Declaration Syntax
C# Visual Basic Visual C++
public void Else(
    Action action
)
Public Sub Else ( _
    action As Action _
)
public:
void Else(
    Action^ action
)
Parameters
action (Action)

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.XmlExtensions.HasXmlElementExpression.Else(System.Action)"]


XmlExtensions.XmlNodeExpression Class

XmlExtensions..::.XmlNodeExpression Class
Namespaces ► StructureMap.Configuration ► XmlExtensions ► XmlExtensions..::.XmlNodeExpression
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.XmlExtensions.XmlNodeExpression]

Declaration Syntax
C# Visual Basic Visual C++
public class XmlNodeExpression
Public Class XmlNodeExpression
public ref class XmlNodeExpression
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Do(Action<(Of <(XmlElement>)>)) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
XmlExtensions..::.XmlNodeExpression


Do Method (action)

Do Method (action)
Namespaces ► StructureMap.Configuration ► XmlExtensions..::.XmlNodeExpression ► Do(Action<(Of <(XmlElement>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.XmlExtensions.XmlNodeExpression.Do(System.Action{System.Xml.XmlElement})]

Declaration Syntax
C# Visual Basic Visual C++
public void Do(
    Action<XmlElement> action
)
Public Sub Do ( _
    action As Action(Of XmlElement) _
)
public:
void Do(
    Action<XmlElement^>^ action
)
Parameters
action (Action <(Of <( XmlElement >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.XmlExtensions.XmlNodeExpression.Do(System.Action{System.Xml.XmlElement})"]


XmlExtensions.XmlTextExpression Class

XmlExtensions..::.XmlTextExpression Class
Namespaces ► StructureMap.Configuration ► XmlExtensions ► XmlExtensions..::.XmlTextExpression
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.XmlExtensions.XmlTextExpression]

Declaration Syntax
C# Visual Basic Visual C++
public class XmlTextExpression
Public Class XmlTextExpression
public ref class XmlTextExpression
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Do(Action<(Of <(String>)>)) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
XmlExtensions..::.XmlTextExpression


Do Method (action)

Do Method (action)
Namespaces ► StructureMap.Configuration ► XmlExtensions..::.XmlTextExpression ► Do(Action<(Of <(String>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.XmlExtensions.XmlTextExpression.Do(System.Action{System.String})]

Declaration Syntax
C# Visual Basic Visual C++
public void Do(
    Action<string> action
)
Public Sub Do ( _
    action As Action(Of String) _
)
public:
void Do(
    Action<String^>^ action
)
Parameters
action (Action <(Of <( String >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.XmlExtensions.XmlTextExpression.Do(System.Action{System.String})"]


StructureMap.Configuration.DSL Namespace

StructureMap.Configuration.DSL Namespace
Namespaces ► StructureMap.Configuration.DSL
StructureMap API

[Missing <summary> documentation for N:StructureMap.Configuration.DSL]

Declaration Syntax
C# Visual Basic Visual C++
namespace StructureMap.Configuration.DSL
Namespace StructureMap.Configuration.DSL
namespace StructureMap.Configuration.DSL
Types
All Types Classes
Icon | Type | Description
 | Registry..::.BuildWithExpression<(Of <(T>)>) | Define the constructor and setter arguments for the default T
 | ExpressionValidator |
 | Registry | A Registry class provides methods and grammars for configuring a Container or ObjectFactory. Using a Registry subclass is the recommended way of configuring a StructureMap Container.
 | ExpressionValidator..::.ValidateExpression |


ExpressionValidator Class

ExpressionValidator Class
Namespaces ► StructureMap.Configuration.DSL ► ExpressionValidator
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.DSL.ExpressionValidator]

Declaration Syntax
C# Visual Basic Visual C++
public static class ExpressionValidator
Public NotInheritable Class ExpressionValidator
public ref class ExpressionValidator abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ValidatePluggabilityOf(Type) |
Inheritance Hierarchy
Object
ExpressionValidator


ValidatePluggabilityOf Method (pluggedType)

ValidatePluggabilityOf Method (pluggedType)
Namespaces ► StructureMap.Configuration.DSL ► ExpressionValidator ► ValidatePluggabilityOf(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.ExpressionValidator.ValidatePluggabilityOf(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public static ExpressionValidator..::.ValidateExpression ValidatePluggabilityOf(
    Type pluggedType
)
Public Shared Function ValidatePluggabilityOf ( _
    pluggedType As Type _
) As ExpressionValidator..::.ValidateExpression
public:
static ExpressionValidator..::.ValidateExpression^ ValidatePluggabilityOf(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Configuration.DSL.ExpressionValidator.ValidatePluggabilityOf(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.ExpressionValidator.ValidatePluggabilityOf(System.Type)]


ExpressionValidator.ValidateExpression Class

ExpressionValidator..::.ValidateExpression Class
Namespaces ► StructureMap.Configuration.DSL ► ExpressionValidator ► ExpressionValidator..::.ValidateExpression
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.DSL.ExpressionValidator.ValidateExpression]

Declaration Syntax
C# Visual Basic Visual C++
public class ValidateExpression
Public Class ValidateExpression
public ref class ValidateExpression
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExpressionValidator..::.ValidateExpression(Type) | Initializes a new instance of the ExpressionValidator..::.ValidateExpression class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IntoPluginType(Type) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ExpressionValidator..::.ValidateExpression


ExpressionValidator.ValidateExpression Constructor (pluggedType)

ExpressionValidator..::.ValidateExpression Constructor (pluggedType)
Namespaces ► StructureMap.Configuration.DSL ► ExpressionValidator..::.ValidateExpression ► ExpressionValidator..::.ValidateExpression(Type)
StructureMap API
Initializes a new instance of the ExpressionValidator..::.ValidateExpression class
Declaration Syntax
C# Visual Basic Visual C++
public ValidateExpression(
    Type pluggedType
)
Public Sub New ( _
    pluggedType As Type _
)
public:
ValidateExpression(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Configuration.DSL.ExpressionValidator.ValidateExpression.#ctor(System.Type)"]


IntoPluginType Method (pluginType)

IntoPluginType Method (pluginType)
Namespaces ► StructureMap.Configuration.DSL ► ExpressionValidator..::.ValidateExpression ► IntoPluginType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.ExpressionValidator.ValidateExpression.IntoPluginType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public void IntoPluginType(
    Type pluginType
)
Public Sub IntoPluginType ( _
    pluginType As Type _
)
public:
void IntoPluginType(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Configuration.DSL.ExpressionValidator.ValidateExpression.IntoPluginType(System.Type)"]


Registry Class

Registry Class
Namespaces ► StructureMap.Configuration.DSL ► Registry
StructureMap API
A Registry class provides methods and grammars for configuring a Container or ObjectFactory. Using a Registry subclass is the recommended way of configuring a StructureMap Container.
Declaration Syntax
C# Visual Basic Visual C++
public class Registry
Public Class Registry
public ref class Registry
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Registry()()() | Initializes a new instance of the Registry class
 | Build()()() | Uses the configuration expressions of this Registry to create a PluginGraph object that could be used to initialize a Container. This method is mostly for internal usage, but might be helpful for diagnostics
 | BuildInstancesOf<(Of <(PLUGINTYPE>)>)()()() | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms
 | configure()()() | You can overide this method as a place to put the Registry DSL declarations. This is not mandatory.
 | CreateProfile(String) | Expression Builder to define the defaults for a named Profile. Each call to CreateProfile is additive.
 | CreateProfile(String, Action<(Of <(ProfileExpression>)>)) | An alternative way to use CreateProfile that uses ProfileExpression as a Nested Closure. This usage will result in cleaner code for multiple declarations
 | Equals(Registry) |
 | Equals(Object) | (Overrides Object.Equals(Object).)
 | FillAllPropertiesOfType<(Of <(PLUGINTYPE>)>)()()() | Directs StructureMap to always inject dependencies into any and all public Setter properties of the type PLUGINTYPE.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | ForConcreteType<(Of <(T>)>)()()() | This method is a shortcut for specifying the default constructor and setter arguments for a ConcreteType. ForConcreteType is shorthand for: ForRequestedType[T]().TheDefault.Is.OfConcreteType[T].************** when the PluginType and ConcreteType are the same Type
 | ForRequestedType(Type) | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. This method is specifically meant for registering open generic types
 | ForRequestedType<(Of <(PLUGINTYPE>)>)()()() | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms
 | GetHashCode()()() | (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IfTypeMatches(Predicate<(Of <(Type>)>)) | Allows you to define a TypeInterceptor inline with Lambdas or anonymous delegates
 | InstanceOf<(Of <(T>)>)()()() | Adds an additional, non-Default Instance to the PluginType T.
 | InstanceOf(Type) | Adds an additional, non-Default Instance to the designated pluginType This method is mostly meant for open generic types
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | registerAction(Action) |
 | RegisterInterceptor(TypeInterceptor) | Registers a new TypeInterceptor object with the Container
 | Scan(Action<(Of <(IAssemblyScanner>)>)) | Designates a policy for scanning assemblies to auto register types
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Examples
public class MyRegistry : Registry
{
    public MyRegistry()
    {
        ForRequestedType(typeof(IService)).TheDefaultIsConcreteType(typeof(Service));
    }
}
Inheritance Hierarchy
Object
 | Registry
 |  | ConfigurationExpression


Registry Constructor

Registry Constructor
Namespaces ► StructureMap.Configuration.DSL ► Registry ► Registry()()()
StructureMap API
Initializes a new instance of the Registry class
Declaration Syntax
C# Visual Basic Visual C++
public Registry()
Public Sub New
public:
Registry()


Build Method

Build Method
Namespaces ► StructureMap.Configuration.DSL ► Registry ► Build()()()
StructureMap API
Uses the configuration expressions of this Registry to create a PluginGraph object that could be used to initialize a Container. This method is mostly for internal usage, but might be helpful for diagnostics
Declaration Syntax
C# Visual Basic Visual C++
public PluginGraph Build()
Public Function Build As PluginGraph
public:
PluginGraph^ Build()
Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Registry.Build]


BuildInstancesOf Method

BuildInstancesOf<(Of <(PLUGINTYPE>)>) Method
Namespaces ► StructureMap.Configuration.DSL ► Registry ► BuildInstancesOf<(Of <(PLUGINTYPE>)>)()()()
StructureMap API
Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms
Declaration Syntax
C# Visual Basic Visual C++
public CreatePluginFamilyExpression<PLUGINTYPE> BuildInstancesOf<PLUGINTYPE>()

Public Function BuildInstancesOf(Of PLUGINTYPE) As CreatePluginFamilyExpression(Of PLUGINTYPE)
public:
generic<typename PLUGINTYPE>
virtual CreatePluginFamilyExpression<PLUGINTYPE>^ BuildInstancesOf() sealed
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.Configuration.DSL.Registry.BuildInstancesOf``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Registry.BuildInstancesOf``1]


configure Method

configure Method
Namespaces ► StructureMap.Configuration.DSL ► Registry ► configure()()()
StructureMap API
You can overide this method as a place to put the Registry DSL declarations. This is not mandatory.
Declaration Syntax
C# Visual Basic Visual C++
protected virtual void configure()
Protected Overridable Sub configure
protected:
virtual void configure()


CreateProfile Method

CreateProfile Method
Namespaces ► StructureMap.Configuration.DSL ► Registry ► CreateProfile()()()
StructureMap API
Members
Icon | Member | Description
 | CreateProfile(String) | Expression Builder to define the defaults for a named Profile. Each call to CreateProfile is additive.
 | CreateProfile(String, Action<(Of <(ProfileExpression>)>)) | An alternative way to use CreateProfile that uses ProfileExpression as a Nested Closure. This usage will result in cleaner code for multiple declarations


CreateProfile Method (profileName)

CreateProfile Method (profileName)
Namespaces ► StructureMap.Configuration.DSL ► Registry ► CreateProfile(String)
StructureMap API
Expression Builder to define the defaults for a named Profile. Each call to CreateProfile is additive.
Declaration Syntax
C# Visual Basic Visual C++
public ProfileExpression CreateProfile(
    string profileName
)
Public Function CreateProfile ( _
    profileName As String _
) As ProfileExpression
public:
virtual ProfileExpression^ CreateProfile(
    String^ profileName
) sealed
Parameters
profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Configuration.DSL.Registry.CreateProfile(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Registry.CreateProfile(System.String)]


CreateProfile Method (profileName, action)

CreateProfile Method (profileName, action)
Namespaces ► StructureMap.Configuration.DSL ► Registry ► CreateProfile(String, Action<(Of <(ProfileExpression>)>))
StructureMap API
An alternative way to use CreateProfile that uses ProfileExpression as a Nested Closure. This usage will result in cleaner code for multiple declarations
Declaration Syntax
C# Visual Basic Visual C++
public void CreateProfile(
    string profileName,
    Action<ProfileExpression> action
)
Public Sub CreateProfile ( _
    profileName As String, _
    action As Action(Of ProfileExpression) _
)
public:
virtual void CreateProfile(
    String^ profileName,
    Action<ProfileExpression^>^ action
) sealed
Parameters
profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Configuration.DSL.Registry.CreateProfile(System.String,System.Action{StructureMap.Configuration.DSL.Expressions.ProfileExpression})"]

action (Action <(Of <( ProfileExpression >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.DSL.Registry.CreateProfile(System.String,System.Action{StructureMap.Configuration.DSL.Expressions.ProfileExpression})"]


Equals Method

Equals Method
Namespaces ► StructureMap.Configuration.DSL ► Registry ► Equals()()()
StructureMap API
Members
Icon | Member | Description
 | Equals(Registry) |
 | Equals(Object) | (Overrides Object.Equals(Object).)


Equals Method (obj)

Equals Method (obj)
Namespaces ► StructureMap.Configuration.DSL ► Registry ► Equals(Registry)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Registry.Equals(StructureMap.Configuration.DSL.Registry)]

Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    Registry obj
)
Public Function Equals ( _
    obj As Registry _
) As Boolean
public:
bool Equals(
    Registry^ obj
)
Parameters
obj (Registry)

[Missing <param name="obj"/> documentation for "M:StructureMap.Configuration.DSL.Registry.Equals(StructureMap.Configuration.DSL.Registry)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Registry.Equals(StructureMap.Configuration.DSL.Registry)]


Equals Method (obj)

Equals Method (obj)
Namespaces ► StructureMap.Configuration.DSL ► Registry ► Equals(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Registry.Equals(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:StructureMap.Configuration.DSL.Registry.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Registry.Equals(System.Object)]


FillAllPropertiesOfType Method

FillAllPropertiesOfType<(Of <(PLUGINTYPE>)>) Method
Namespaces ► StructureMap.Configuration.DSL ► Registry ► FillAllPropertiesOfType<(Of <(PLUGINTYPE>)>)()()()
StructureMap API
Directs StructureMap to always inject dependencies into any and all public Setter properties of the type PLUGINTYPE.
Declaration Syntax
C# Visual Basic Visual C++
public CreatePluginFamilyExpression<PLUGINTYPE> FillAllPropertiesOfType<PLUGINTYPE>()

Public Function FillAllPropertiesOfType(Of PLUGINTYPE) As CreatePluginFamilyExpression(Of PLUGINTYPE)
public:
generic<typename PLUGINTYPE>
virtual CreatePluginFamilyExpression<PLUGINTYPE>^ FillAllPropertiesOfType() sealed
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.Configuration.DSL.Registry.FillAllPropertiesOfType``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Registry.FillAllPropertiesOfType``1]


ForConcreteType Method

ForConcreteType<(Of <(T>)>) Method
Namespaces ► StructureMap.Configuration.DSL ► Registry ► ForConcreteType<(Of <(T>)>)()()()
StructureMap API
This method is a shortcut for specifying the default constructor and setter arguments for a ConcreteType. ForConcreteType is shorthand for: ForRequestedType[T]().TheDefault.Is.OfConcreteType[T].************** when the PluginType and ConcreteType are the same Type
Declaration Syntax
C# Visual Basic Visual C++
public Registry..::.BuildWithExpression<T> ForConcreteType<T>()

Public Function ForConcreteType(Of T) As Registry..::.BuildWithExpression(Of T)
public:
generic<typename T>
virtual Registry..::.BuildWithExpression<T>^ ForConcreteType() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Configuration.DSL.Registry.ForConcreteType``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Registry.ForConcreteType``1]


ForRequestedType Method

ForRequestedType Method
Namespaces ► StructureMap.Configuration.DSL ► Registry ► ForRequestedType()()()
StructureMap API
Members
Icon | Member | Description
 | ForRequestedType(Type) | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. This method is specifically meant for registering open generic types
 | ForRequestedType<(Of <(PLUGINTYPE>)>)()()() | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms


ForRequestedType Method

ForRequestedType<(Of <(PLUGINTYPE>)>) Method
Namespaces ► StructureMap.Configuration.DSL ► Registry ► ForRequestedType<(Of <(PLUGINTYPE>)>)()()()
StructureMap API
Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms
Declaration Syntax
C# Visual Basic Visual C++
public CreatePluginFamilyExpression<PLUGINTYPE> ForRequestedType<PLUGINTYPE>()

Public Function ForRequestedType(Of PLUGINTYPE) As CreatePluginFamilyExpression(Of PLUGINTYPE)
public:
generic<typename PLUGINTYPE>
virtual CreatePluginFamilyExpression<PLUGINTYPE>^ ForRequestedType() sealed
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.Configuration.DSL.Registry.ForRequestedType``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Registry.ForRequestedType``1]


ForRequestedType Method (pluginType)

ForRequestedType Method (pluginType)
Namespaces ► StructureMap.Configuration.DSL ► Registry ► ForRequestedType(Type)
StructureMap API
Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. This method is specifically meant for registering open generic types
Declaration Syntax
C# Visual Basic Visual C++
public GenericFamilyExpression ForRequestedType(
    Type pluginType
)
Public Function ForRequestedType ( _
    pluginType As Type _
) As GenericFamilyExpression
public:
virtual GenericFamilyExpression^ ForRequestedType(
    Type^ pluginType
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Configuration.DSL.Registry.ForRequestedType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Registry.ForRequestedType(System.Type)]


GetHashCode Method

GetHashCode Method
Namespaces ► StructureMap.Configuration.DSL ► Registry ► GetHashCode()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Registry.GetHashCode]

Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Registry.GetHashCode]


IfTypeMatches Method (match)

IfTypeMatches Method (match)
Namespaces ► StructureMap.Configuration.DSL ► Registry ► IfTypeMatches(Predicate<(Of <(Type>)>))
StructureMap API
Allows you to define a TypeInterceptor inline with Lambdas or anonymous delegates
Declaration Syntax
C# Visual Basic Visual C++
public MatchedTypeInterceptor IfTypeMatches(
    Predicate<Type> match
)
Public Function IfTypeMatches ( _
    match As Predicate(Of Type) _
) As MatchedTypeInterceptor
public:
virtual MatchedTypeInterceptor^ IfTypeMatches(
    Predicate<Type^>^ match
) sealed
Parameters
match (Predicate <(Of <( Type >)>))

[Missing <param name="match"/> documentation for "M:StructureMap.Configuration.DSL.Registry.IfTypeMatches(System.Predicate{System.Type})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Registry.IfTypeMatches(System.Predicate{System.Type})]

Examples
IfTypeMatches( ... ).InterceptWith( o => new ObjectWrapper(o) );


InstanceOf Method

InstanceOf Method
Namespaces ► StructureMap.Configuration.DSL ► Registry ► InstanceOf()()()
StructureMap API
Members
Icon | Member | Description
 | InstanceOf<(Of <(T>)>)()()() | Adds an additional, non-Default Instance to the PluginType T.
 | InstanceOf(Type) | Adds an additional, non-Default Instance to the designated pluginType This method is mostly meant for open generic types


InstanceOf Method

InstanceOf<(Of <(T>)>) Method
Namespaces ► StructureMap.Configuration.DSL ► Registry ► InstanceOf<(Of <(T>)>)()()()
StructureMap API
Adds an additional, non-Default Instance to the PluginType T.
Declaration Syntax
C# Visual Basic Visual C++
public IsExpression<T> InstanceOf<T>()

Public Function InstanceOf(Of T) As IsExpression(Of T)
public:
generic<typename T>
virtual IsExpression<T>^ InstanceOf() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Configuration.DSL.Registry.InstanceOf``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Registry.InstanceOf``1]


InstanceOf Method (pluginType)

InstanceOf Method (pluginType)
Namespaces ► StructureMap.Configuration.DSL ► Registry ► InstanceOf(Type)
StructureMap API
Adds an additional, non-Default Instance to the designated pluginType This method is mostly meant for open generic types
Declaration Syntax
C# Visual Basic Visual C++
public GenericIsExpression InstanceOf(
    Type pluginType
)
Public Function InstanceOf ( _
    pluginType As Type _
) As GenericIsExpression
public:
virtual GenericIsExpression^ InstanceOf(
    Type^ pluginType
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Configuration.DSL.Registry.InstanceOf(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Registry.InstanceOf(System.Type)]


registerAction Method (action)

registerAction Method (action)
Namespaces ► StructureMap.Configuration.DSL ► Registry ► registerAction(Action)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Registry.registerAction(System.Action)]

Declaration Syntax
C# Visual Basic Visual C++
protected void registerAction(
    Action action
)
Protected Sub registerAction ( _
    action As Action _
)
protected:
void registerAction(
    Action^ action
)
Parameters
action (Action)

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.DSL.Registry.registerAction(System.Action)"]


RegisterInterceptor Method (interceptor)

RegisterInterceptor Method (interceptor)
Namespaces ► StructureMap.Configuration.DSL ► Registry ► RegisterInterceptor(TypeInterceptor)
StructureMap API
Registers a new TypeInterceptor object with the Container
Declaration Syntax
C# Visual Basic Visual C++
public void RegisterInterceptor(
    TypeInterceptor interceptor
)
Public Sub RegisterInterceptor ( _
    interceptor As TypeInterceptor _
)
public:
virtual void RegisterInterceptor(
    TypeInterceptor^ interceptor
) sealed
Parameters
interceptor (TypeInterceptor)

[Missing <param name="interceptor"/> documentation for "M:StructureMap.Configuration.DSL.Registry.RegisterInterceptor(StructureMap.Interceptors.TypeInterceptor)"]


Scan Method (action)

Scan Method (action)
Namespaces ► StructureMap.Configuration.DSL ► Registry ► Scan(Action<(Of <(IAssemblyScanner>)>))
StructureMap API
Designates a policy for scanning assemblies to auto register types
Declaration Syntax
C# Visual Basic Visual C++
public void Scan(
    Action<IAssemblyScanner> action
)
Public Sub Scan ( _
    action As Action(Of IAssemblyScanner) _
)
public:
virtual void Scan(
    Action<IAssemblyScanner^>^ action
) sealed
Parameters
action (Action <(Of <( IAssemblyScanner >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.DSL.Registry.Scan(System.Action{StructureMap.Graph.IAssemblyScanner})"]

Return Value


Registry.BuildWithExpression(T) Class

Registry..::.BuildWithExpression<(Of <(T>)>) Class
Namespaces ► StructureMap.Configuration.DSL ► Registry ► Registry..::.BuildWithExpression<(Of <(T>)>)
StructureMap API
Define the constructor and setter arguments for the default T
Declaration Syntax
C# Visual Basic Visual C++
public class BuildWithExpression<T>

Public Class BuildWithExpression(Of T)
generic<typename T>
public ref class BuildWithExpression
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:StructureMap.Configuration.DSL.Registry.BuildWithExpression`1"]

Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Registry..::.BuildWithExpression<(Of <(T>)>)(SmartInstance<(Of <(T>)>)) | Initializes a new instance of the Registry..::.BuildWithExpression<(Of <(T>)>) class
 | Configure |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Registry..::.BuildWithExpression<(Of <(T>)>)


Registry.BuildWithExpression(T) Constructor (instance)

Registry..::.BuildWithExpression<(Of <(T>)>) Constructor (instance)
Namespaces ► StructureMap.Configuration.DSL ► Registry..::.BuildWithExpression<(Of <(T>)>) ► Registry..::.BuildWithExpression<(Of <(T>)>)(SmartInstance<(Of <(T>)>))
StructureMap API
Initializes a new instance of the Registry..::.BuildWithExpression<(Of <(T>)>) class
Declaration Syntax
C# Visual Basic Visual C++
public BuildWithExpression(
    SmartInstance<T> instance
)
Public Sub New ( _
    instance As SmartInstance(Of T) _
)
public:
BuildWithExpression(
    SmartInstance<T>^ instance
)
Parameters
instance (SmartInstance <(Of <( T >)>))

[Missing <param name="instance"/> documentation for "M:StructureMap.Configuration.DSL.Registry.BuildWithExpression`1.#ctor(StructureMap.Pipeline.SmartInstance{`0})"]


Configure Property

Configure Property
Namespaces ► StructureMap.Configuration.DSL ► Registry..::.BuildWithExpression<(Of <(T>)>) ► Configure
StructureMap API

[Missing <summary> documentation for P:StructureMap.Configuration.DSL.Registry.BuildWithExpression`1.Configure]

Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<T> Configure { get; }
Public ReadOnly Property Configure As SmartInstance(Of T)
public:
property SmartInstance<T>^ Configure {
    SmartInstance<T>^ get ();
}


StructureMap.Configuration.DSL.Expressions Namespace

StructureMap.Configuration.DSL.Expressions Namespace
Namespaces ► StructureMap.Configuration.DSL.Expressions
StructureMap API

[Missing <summary> documentation for N:StructureMap.Configuration.DSL.Expressions]

Declaration Syntax
C# Visual Basic Visual C++
namespace StructureMap.Configuration.DSL.Expressions
Namespace StructureMap.Configuration.DSL.Expressions
namespace StructureMap.Configuration.DSL.Expressions
Types
All Types Classes Interfaces
Icon | Type | Description
 | CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) | Expression Builder that has grammars for defining policies at the PluginType level
 | ProfileExpression..::.GenericDefaultExpression | Expression Builder inside of a Profile creation for open generic types
 | GenericFamilyExpression | Expression Builder that has grammars for defining policies at the PluginType level. This expression is used for registering open generic types
 | GenericIsExpression | An Expression Builder to define Instances of a PluginType. This is mostly used for configuring open generic types
 | IInstanceExpression<(Of <(T>)>) | An Expression Builder that is used throughout the Registry DSL to add and define Instances
 | ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>) | Expression Builder within defining a Profile
 | InstanceExpression<(Of <(T>)>) |
 | IsExpression<(Of <(T>)>) | Expression Builder to define an Instance
 | ProfileExpression | Expression class to help define a runtime Profile


CreatePluginFamilyExpression(PLUGINTYPE) Class

CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) Class
Namespaces ► StructureMap.Configuration.DSL.Expressions ► CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>)
StructureMap API
Expression Builder that has grammars for defining policies at the PluginType level
Declaration Syntax
C# Visual Basic Visual C++
public class CreatePluginFamilyExpression<PLUGINTYPE>

Public Class CreatePluginFamilyExpression(Of PLUGINTYPE)
generic<typename PLUGINTYPE>
public ref class CreatePluginFamilyExpression
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "T:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1"]

Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>)(Registry) | Initializes a new instance of the CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) class
 | AddConcreteType<(Of <(PLUGGEDTYPE>)>)()()() | Shortcut method to add an additional Instance to this Plugin Type as just a Concrete Type. This will only work if the Concrete Type has no primitive constructor or mandatory Setter arguments.
 | AddInstances(Action<(Of <(IInstanceExpression<(Of <(PLUGINTYPE>)>)>)>)) | Add multiple Instance's to this PluginType
 | AddInstancesFrom(MementoSource) | Largely deprecated and unnecessary with the ability to add Xml configuration files
 | AsSingletons()()() | Convenience method to mark a PluginFamily as a Singleton
 | CacheBy(InstanceScope) | Sets the object creation of the instances of the PluginType. For example: PerRequest, Singleton, ThreadLocal, HttpContext, or Hybrid
 | EnrichWith(EnrichmentHandler<(Of <(PLUGINTYPE>)>)) | Register a Func to run against any object of this PluginType immediately after it is created, but before the new object is passed back to the caller. Unlike OnCreation(), EnrichWith() gives the the ability to return a different object. Use this method for runtime AOP scenarios or to return a decorator.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InterceptConstructionWith(IBuildInterceptor) | Registers an IBuildInterceptor for this Plugin Type that executes before any object of this PluginType is created. IBuildInterceptor's can be used to create a custom scope
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCreation(Action<(Of <(PLUGINTYPE>)>)) | Register an Action to run against any object of this PluginType immediately after it is created, but before the new object is passed back to the caller
 | TheDefault | Define the Default Instance for this PluginType
 | TheDefaultIsConcreteType<(Of <(CONCRETETYPE>)>)()()() | Convenience method that sets the default concrete type of the PluginType. Type T can only accept types that do not have any primitive constructor arguments. StructureMap has to know how to construct all of the constructor argument types.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>)


CreatePluginFamilyExpression(PLUGINTYPE) Constructor (registry)

CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) Constructor (registry)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) ► CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>)(Registry)
StructureMap API
Initializes a new instance of the CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) class
Declaration Syntax
C# Visual Basic Visual C++
public CreatePluginFamilyExpression(
    Registry registry
)
Public Sub New ( _
    registry As Registry _
)
public:
CreatePluginFamilyExpression(
    Registry^ registry
)
Parameters
registry (Registry)

[Missing <param name="registry"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.#ctor(StructureMap.Configuration.DSL.Registry)"]


AddConcreteType Method

AddConcreteType<(Of <(PLUGGEDTYPE>)>) Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) ► AddConcreteType<(Of <(PLUGGEDTYPE>)>)()()()
StructureMap API
Shortcut method to add an additional Instance to this Plugin Type as just a Concrete Type. This will only work if the Concrete Type has no primitive constructor or mandatory Setter arguments.
Declaration Syntax
C# Visual Basic Visual C++
public CreatePluginFamilyExpression<PLUGINTYPE> AddConcreteType<PLUGGEDTYPE>()

Public Function AddConcreteType(Of PLUGGEDTYPE) As CreatePluginFamilyExpression(Of PLUGINTYPE)
public:
generic<typename PLUGGEDTYPE>
CreatePluginFamilyExpression<PLUGINTYPE>^ AddConcreteType()
Generic Template Parameters
PLUGGEDTYPE

[Missing <typeparam name="PLUGGEDTYPE"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.AddConcreteType``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.AddConcreteType``1]


AddInstances Method (action)

AddInstances Method (action)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) ► AddInstances(Action<(Of <(IInstanceExpression<(Of <(PLUGINTYPE>)>)>)>))
StructureMap API
Add multiple Instance's to this PluginType
Declaration Syntax
C# Visual Basic Visual C++
public CreatePluginFamilyExpression<PLUGINTYPE> AddInstances(
    Action<IInstanceExpression<PLUGINTYPE>> action
)
Public Function AddInstances ( _
    action As Action(Of IInstanceExpression(Of PLUGINTYPE)) _
) As CreatePluginFamilyExpression(Of PLUGINTYPE)
public:
CreatePluginFamilyExpression<PLUGINTYPE>^ AddInstances(
    Action<IInstanceExpression<PLUGINTYPE>^>^ action
)
Parameters
action (Action <(Of <( IInstanceExpression <(Of <( PLUGINTYPE >)>)>)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.AddInstances(System.Action{StructureMap.Configuration.DSL.Expressions.IInstanceExpression{`0}})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.AddInstances(System.Action{StructureMap.Configuration.DSL.Expressions.IInstanceExpression{`0}})]


AddInstancesFrom Method (source)

AddInstancesFrom Method (source)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) ► AddInstancesFrom(MementoSource)
StructureMap API
Largely deprecated and unnecessary with the ability to add Xml configuration files
Declaration Syntax
C# Visual Basic Visual C++
public CreatePluginFamilyExpression<PLUGINTYPE> AddInstancesFrom(
    MementoSource source
)
Public Function AddInstancesFrom ( _
    source As MementoSource _
) As CreatePluginFamilyExpression(Of PLUGINTYPE)
public:
CreatePluginFamilyExpression<PLUGINTYPE>^ AddInstancesFrom(
    MementoSource^ source
)
Parameters
source (MementoSource)

[Missing <param name="source"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.AddInstancesFrom(StructureMap.MementoSource)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.AddInstancesFrom(StructureMap.MementoSource)]


AsSingletons Method

AsSingletons Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) ► AsSingletons()()()
StructureMap API
Convenience method to mark a PluginFamily as a Singleton
Declaration Syntax
C# Visual Basic Visual C++
public CreatePluginFamilyExpression<PLUGINTYPE> AsSingletons()
Public Function AsSingletons As CreatePluginFamilyExpression(Of PLUGINTYPE)
public:
CreatePluginFamilyExpression<PLUGINTYPE>^ AsSingletons()
Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.AsSingletons]


CacheBy Method (scope)

CacheBy Method (scope)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) ► CacheBy(InstanceScope)
StructureMap API
Sets the object creation of the instances of the PluginType. For example: PerRequest, Singleton, ThreadLocal, HttpContext, or Hybrid
Declaration Syntax
C# Visual Basic Visual C++
public CreatePluginFamilyExpression<PLUGINTYPE> CacheBy(
    InstanceScope scope
)
Public Function CacheBy ( _
    scope As InstanceScope _
) As CreatePluginFamilyExpression(Of PLUGINTYPE)
public:
CreatePluginFamilyExpression<PLUGINTYPE>^ CacheBy(
    InstanceScope scope
)
Parameters
scope (InstanceScope)

[Missing <param name="scope"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.CacheBy(StructureMap.Attributes.InstanceScope)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.CacheBy(StructureMap.Attributes.InstanceScope)]


EnrichWith Method (handler)

EnrichWith Method (handler)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) ► EnrichWith(EnrichmentHandler<(Of <(PLUGINTYPE>)>))
StructureMap API
Register a Func to run against any object of this PluginType immediately after it is created, but before the new object is passed back to the caller. Unlike OnCreation(), EnrichWith() gives the the ability to return a different object. Use this method for runtime AOP scenarios or to return a decorator.
Declaration Syntax
C# Visual Basic Visual C++
public CreatePluginFamilyExpression<PLUGINTYPE> EnrichWith(
    EnrichmentHandler<PLUGINTYPE> handler
)
Public Function EnrichWith ( _
    handler As EnrichmentHandler(Of PLUGINTYPE) _
) As CreatePluginFamilyExpression(Of PLUGINTYPE)
public:
CreatePluginFamilyExpression<PLUGINTYPE>^ EnrichWith(
    EnrichmentHandler<PLUGINTYPE>^ handler
)
Parameters
handler (EnrichmentHandler <(Of <( PLUGINTYPE >)>))

[Missing <param name="handler"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.EnrichWith(StructureMap.Interceptors.EnrichmentHandler{`0})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.EnrichWith(StructureMap.Interceptors.EnrichmentHandler{`0})]


InterceptConstructionWith Method (interceptor)

InterceptConstructionWith Method (interceptor)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) ► InterceptConstructionWith(IBuildInterceptor)
StructureMap API
Registers an IBuildInterceptor for this Plugin Type that executes before any object of this PluginType is created. IBuildInterceptor's can be used to create a custom scope
Declaration Syntax
C# Visual Basic Visual C++
public CreatePluginFamilyExpression<PLUGINTYPE> InterceptConstructionWith(
    IBuildInterceptor interceptor
)
Public Function InterceptConstructionWith ( _
    interceptor As IBuildInterceptor _
) As CreatePluginFamilyExpression(Of PLUGINTYPE)
public:
CreatePluginFamilyExpression<PLUGINTYPE>^ InterceptConstructionWith(
    IBuildInterceptor^ interceptor
)
Parameters
interceptor (IBuildInterceptor)

[Missing <param name="interceptor"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.InterceptConstructionWith(StructureMap.Pipeline.IBuildInterceptor)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.InterceptConstructionWith(StructureMap.Pipeline.IBuildInterceptor)]


OnCreation Method (handler)

OnCreation Method (handler)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) ► OnCreation(Action<(Of <(PLUGINTYPE>)>))
StructureMap API
Register an Action to run against any object of this PluginType immediately after it is created, but before the new object is passed back to the caller
Declaration Syntax
C# Visual Basic Visual C++
public CreatePluginFamilyExpression<PLUGINTYPE> OnCreation(
    Action<PLUGINTYPE> handler
)
Public Function OnCreation ( _
    handler As Action(Of PLUGINTYPE) _
) As CreatePluginFamilyExpression(Of PLUGINTYPE)
public:
CreatePluginFamilyExpression<PLUGINTYPE>^ OnCreation(
    Action<PLUGINTYPE>^ handler
)
Parameters
handler (Action <(Of <( PLUGINTYPE >)>))

[Missing <param name="handler"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.OnCreation(System.Action{`0})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.OnCreation(System.Action{`0})]


TheDefault Property

TheDefault Property
Namespaces ► StructureMap.Configuration.DSL.Expressions ► CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) ► TheDefault
StructureMap API
Define the Default Instance for this PluginType
Declaration Syntax
C# Visual Basic Visual C++
public IsExpression<PLUGINTYPE> TheDefault { get; }
Public ReadOnly Property TheDefault As IsExpression(Of PLUGINTYPE)
public:
property IsExpression<PLUGINTYPE>^ TheDefault {
    IsExpression<PLUGINTYPE>^ get ();
}


TheDefaultIsConcreteType Method

TheDefaultIsConcreteType<(Of <(CONCRETETYPE>)>) Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► CreatePluginFamilyExpression<(Of <(PLUGINTYPE>)>) ► TheDefaultIsConcreteType<(Of <(CONCRETETYPE>)>)()()()
StructureMap API
Convenience method that sets the default concrete type of the PluginType. Type T can only accept types that do not have any primitive constructor arguments. StructureMap has to know how to construct all of the constructor argument types.
Declaration Syntax
C# Visual Basic Visual C++
public CreatePluginFamilyExpression<PLUGINTYPE> TheDefaultIsConcreteType<CONCRETETYPE>()
where CONCRETETYPE :

Public Function TheDefaultIsConcreteType(Of CONCRETETYPE As ) As CreatePluginFamilyExpression(Of PLUGINTYPE)
public:
generic<typename CONCRETETYPE>
where CONCRETETYPE :
CreatePluginFamilyExpression<PLUGINTYPE>^ TheDefaultIsConcreteType()
Generic Template Parameters
CONCRETETYPE

[Missing <typeparam name="CONCRETETYPE"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.TheDefaultIsConcreteType``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.CreatePluginFamilyExpression`1.TheDefaultIsConcreteType``1]


GenericFamilyExpression Class

GenericFamilyExpression Class
Namespaces ► StructureMap.Configuration.DSL.Expressions ► GenericFamilyExpression
StructureMap API
Expression Builder that has grammars for defining policies at the PluginType level. This expression is used for registering open generic types
Declaration Syntax
C# Visual Basic Visual C++
public class GenericFamilyExpression
Public Class GenericFamilyExpression
public ref class GenericFamilyExpression
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GenericFamilyExpression(Type, Registry) | Initializes a new instance of the GenericFamilyExpression class
 | AddConcreteType(Type) | Shortcut method to add an additional Instance to this Plugin Type as just a Concrete Type. You can also chain other declarations after this method to add constructor and setter arguments
 | AddConcreteType(Type, String) | Shortcut method to add an additional Instance to this Plugin Type as just a Concrete Type by a specified name. You can also chain other declarations after this method to add constructor and setter arguments
 | AddType(Type) | Shortcut method to add an additional Instance to this Plugin Type as just a Concrete Type. This will only work if the Concrete Type has no primitive constructor or mandatory Setter arguments.
 | CacheBy(InstanceScope) | Sets the object creation of the instances of the PluginType. For example: PerRequest, Singleton, ThreadLocal, HttpContext, or Hybrid
 | EnrichWith(Func<(Of <(Object, Object>)>)) | Register a Func to run against any object of this PluginType immediately after it is created, but before the new object is passed back to the caller. Unlike OnCreation(), EnrichWith() gives the the ability to return a different object. Use this method for runtime AOP scenarios or to return a decorator.
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InterceptConstructionWith(IBuildInterceptor) | Registers an IBuildInterceptor for this Plugin Type that executes before any object of this PluginType is created. IBuildInterceptor's can be used to create a custom scope
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OnCreation(Action<(Of <(Object>)>)) | Register an Action to run against any object of this PluginType immediately after it is created, but before the new object is passed back to the caller
 | TheDefaultIsConcreteType(Type) | Convenience method that sets the default concrete type of the PluginType. The "concreteType" can only accept types that do not have any primitive constructor arguments. StructureMap has to know how to construct all of the constructor argument types.
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GenericFamilyExpression


GenericFamilyExpression Constructor (pluginType, registry)

GenericFamilyExpression Constructor (pluginType, registry)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► GenericFamilyExpression ► GenericFamilyExpression(Type, Registry)
StructureMap API
Initializes a new instance of the GenericFamilyExpression class
Declaration Syntax
C# Visual Basic Visual C++
public GenericFamilyExpression(
    Type pluginType,
    Registry registry
)
Public Sub New ( _
    pluginType As Type, _
    registry As Registry _
)
public:
GenericFamilyExpression(
    Type^ pluginType,
    Registry^ registry
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.#ctor(System.Type,StructureMap.Configuration.DSL.Registry)"]

registry (Registry)

[Missing <param name="registry"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.#ctor(System.Type,StructureMap.Configuration.DSL.Registry)"]


AddConcreteType Method

AddConcreteType Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► GenericFamilyExpression ► AddConcreteType()()()
StructureMap API
Members
Icon | Member | Description
 | AddConcreteType(Type) | Shortcut method to add an additional Instance to this Plugin Type as just a Concrete Type. You can also chain other declarations after this method to add constructor and setter arguments
 | AddConcreteType(Type, String) | Shortcut method to add an additional Instance to this Plugin Type as just a Concrete Type by a specified name. You can also chain other declarations after this method to add constructor and setter arguments


AddConcreteType Method (concreteType)

AddConcreteType Method (concreteType)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► GenericFamilyExpression ► AddConcreteType(Type)
StructureMap API
Shortcut method to add an additional Instance to this Plugin Type as just a Concrete Type. You can also chain other declarations after this method to add constructor and setter arguments
Declaration Syntax
C# Visual Basic Visual C++
public GenericFamilyExpression AddConcreteType(
    Type concreteType
)
Public Function AddConcreteType ( _
    concreteType As Type _
) As GenericFamilyExpression
public:
GenericFamilyExpression^ AddConcreteType(
    Type^ concreteType
)
Parameters
concreteType (Type)

[Missing <param name="concreteType"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.AddConcreteType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.AddConcreteType(System.Type)]


AddConcreteType Method (concreteType, instanceName)

AddConcreteType Method (concreteType, instanceName)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► GenericFamilyExpression ► AddConcreteType(Type, String)
StructureMap API
Shortcut method to add an additional Instance to this Plugin Type as just a Concrete Type by a specified name. You can also chain other declarations after this method to add constructor and setter arguments
Declaration Syntax
C# Visual Basic Visual C++
public GenericFamilyExpression AddConcreteType(
    Type concreteType,
    string instanceName
)
Public Function AddConcreteType ( _
    concreteType As Type, _
    instanceName As String _
) As GenericFamilyExpression
public:
GenericFamilyExpression^ AddConcreteType(
    Type^ concreteType,
    String^ instanceName
)
Parameters
concreteType (Type)

[Missing <param name="concreteType"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.AddConcreteType(System.Type,System.String)"]

instanceName (String)

[Missing <param name="instanceName"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.AddConcreteType(System.Type,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.AddConcreteType(System.Type,System.String)]


AddType Method (concreteType)

AddType Method (concreteType)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► GenericFamilyExpression ► AddType(Type)
StructureMap API
Shortcut method to add an additional Instance to this Plugin Type as just a Concrete Type. This will only work if the Concrete Type has no primitive constructor or mandatory Setter arguments.
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance AddType(
    Type concreteType
)
Public Function AddType ( _
    concreteType As Type _
) As ConfiguredInstance
public:
ConfiguredInstance^ AddType(
    Type^ concreteType
)
Parameters
concreteType (Type)

[Missing <param name="concreteType"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.AddType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.AddType(System.Type)]


CacheBy Method (scope)

CacheBy Method (scope)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► GenericFamilyExpression ► CacheBy(InstanceScope)
StructureMap API
Sets the object creation of the instances of the PluginType. For example: PerRequest, Singleton, ThreadLocal, HttpContext, or Hybrid
Declaration Syntax
C# Visual Basic Visual C++
public GenericFamilyExpression CacheBy(
    InstanceScope scope
)
Public Function CacheBy ( _
    scope As InstanceScope _
) As GenericFamilyExpression
public:
GenericFamilyExpression^ CacheBy(
    InstanceScope scope
)
Parameters
scope (InstanceScope)

[Missing <param name="scope"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.CacheBy(StructureMap.Attributes.InstanceScope)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.CacheBy(StructureMap.Attributes.InstanceScope)]


EnrichWith Method (func)

EnrichWith Method (func)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► GenericFamilyExpression ► EnrichWith(Func<(Of <(Object, Object>)>))
StructureMap API
Register a Func to run against any object of this PluginType immediately after it is created, but before the new object is passed back to the caller. Unlike OnCreation(), EnrichWith() gives the the ability to return a different object. Use this method for runtime AOP scenarios or to return a decorator.
Declaration Syntax
C# Visual Basic Visual C++
public GenericFamilyExpression EnrichWith(
    Func<Object, Object> func
)
Public Function EnrichWith ( _
    func As Func(Of Object, Object) _
) As GenericFamilyExpression
public:
GenericFamilyExpression^ EnrichWith(
    Func<Object^, Object^>^ func
)
Parameters
func (Func <(Of <( Object, Object >)>))

[Missing <param name="func"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.EnrichWith(System.Func{System.Object,System.Object})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.EnrichWith(System.Func{System.Object,System.Object})]


InterceptConstructionWith Method (interceptor)

InterceptConstructionWith Method (interceptor)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► GenericFamilyExpression ► InterceptConstructionWith(IBuildInterceptor)
StructureMap API
Registers an IBuildInterceptor for this Plugin Type that executes before any object of this PluginType is created. IBuildInterceptor's can be used to create a custom scope
Declaration Syntax
C# Visual Basic Visual C++
public GenericFamilyExpression InterceptConstructionWith(
    IBuildInterceptor interceptor
)
Public Function InterceptConstructionWith ( _
    interceptor As IBuildInterceptor _
) As GenericFamilyExpression
public:
GenericFamilyExpression^ InterceptConstructionWith(
    IBuildInterceptor^ interceptor
)
Parameters
interceptor (IBuildInterceptor)

[Missing <param name="interceptor"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.InterceptConstructionWith(StructureMap.Pipeline.IBuildInterceptor)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.InterceptConstructionWith(StructureMap.Pipeline.IBuildInterceptor)]


OnCreation Method (action)

OnCreation Method (action)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► GenericFamilyExpression ► OnCreation(Action<(Of <(Object>)>))
StructureMap API
Register an Action to run against any object of this PluginType immediately after it is created, but before the new object is passed back to the caller
Declaration Syntax
C# Visual Basic Visual C++
public GenericFamilyExpression OnCreation(
    Action<Object> action
)
Public Function OnCreation ( _
    action As Action(Of Object) _
) As GenericFamilyExpression
public:
GenericFamilyExpression^ OnCreation(
    Action<Object^>^ action
)
Parameters
action (Action <(Of <( Object >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.OnCreation(System.Action{System.Object})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.OnCreation(System.Action{System.Object})]


TheDefaultIsConcreteType Method (concreteType)

TheDefaultIsConcreteType Method (concreteType)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► GenericFamilyExpression ► TheDefaultIsConcreteType(Type)
StructureMap API
Convenience method that sets the default concrete type of the PluginType. The "concreteType" can only accept types that do not have any primitive constructor arguments. StructureMap has to know how to construct all of the constructor argument types.
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance TheDefaultIsConcreteType(
    Type concreteType
)
Public Function TheDefaultIsConcreteType ( _
    concreteType As Type _
) As ConfiguredInstance
public:
ConfiguredInstance^ TheDefaultIsConcreteType(
    Type^ concreteType
)
Parameters
concreteType (Type)

[Missing <param name="concreteType"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.TheDefaultIsConcreteType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.GenericFamilyExpression.TheDefaultIsConcreteType(System.Type)]


GenericIsExpression Class

GenericIsExpression Class
Namespaces ► StructureMap.Configuration.DSL.Expressions ► GenericIsExpression
StructureMap API
An Expression Builder to define Instances of a PluginType. This is mostly used for configuring open generic types
Declaration Syntax
C# Visual Basic Visual C++
public class GenericIsExpression
Public Class GenericIsExpression
public ref class GenericIsExpression
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GenericIsExpression(Action<(Of <(Instance>)>)) | Initializes a new instance of the GenericIsExpression class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Is(Type) | Shortcut to register a Concrete Type as an instance. This method supports method chaining to allow you to add constructor and setter arguments for the concrete type
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TheInstanceNamed(String) | Shortcut to simply use the Instance with the given name
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GenericIsExpression


GenericIsExpression Constructor (action)

GenericIsExpression Constructor (action)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► GenericIsExpression ► GenericIsExpression(Action<(Of <(Instance>)>))
StructureMap API
Initializes a new instance of the GenericIsExpression class
Declaration Syntax
C# Visual Basic Visual C++
public GenericIsExpression(
    Action<Instance> action
)
Public Sub New ( _
    action As Action(Of Instance) _
)
public:
GenericIsExpression(
    Action<Instance^>^ action
)
Parameters
action (Action <(Of <( Instance >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.GenericIsExpression.#ctor(System.Action{StructureMap.Pipeline.Instance})"]


Is Method (concreteType)

Is Method (concreteType)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► GenericIsExpression ► Is(Type)
StructureMap API
Shortcut to register a Concrete Type as an instance. This method supports method chaining to allow you to add constructor and setter arguments for the concrete type
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance Is(
    Type concreteType
)
Public Function Is ( _
    concreteType As Type _
) As ConfiguredInstance
public:
ConfiguredInstance^ Is(
    Type^ concreteType
)
Parameters
concreteType (Type)

[Missing <param name="concreteType"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.GenericIsExpression.Is(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.GenericIsExpression.Is(System.Type)]


TheInstanceNamed Method (name)

TheInstanceNamed Method (name)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► GenericIsExpression ► TheInstanceNamed(String)
StructureMap API
Shortcut to simply use the Instance with the given name
Declaration Syntax
C# Visual Basic Visual C++
public ReferencedInstance TheInstanceNamed(
    string name
)
Public Function TheInstanceNamed ( _
    name As String _
) As ReferencedInstance
public:
ReferencedInstance^ TheInstanceNamed(
    String^ name
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.GenericIsExpression.TheInstanceNamed(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.GenericIsExpression.TheInstanceNamed(System.String)]


IInstanceExpression(T) Interface

IInstanceExpression<(Of <(T>)>) Interface
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>)
StructureMap API
An Expression Builder that is used throughout the Registry DSL to add and define Instances
Declaration Syntax
C# Visual Basic Visual C++
public interface IInstanceExpression<T> : IsExpression<T>

Public Interface IInstanceExpression(Of T) _
    Implements IsExpression(Of T)
generic<typename T>
public interface class IInstanceExpression : IsExpression<T>
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1"]

Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsThis(Instance) | (Inherited from .)
 | ConstructedBy(Func<(Of <(T>)>)) | Create an Instance that builds an object by calling a Lambda or an anonymous delegate with no arguments
 | ConstructedBy(Func<(Of <(IContext, T>)>)) | Create an Instance that builds an object by calling a Lambda or an anonymous delegate with the IContext representing the current object graph.
 | Instance(Instance) | Register a previously built Instance. This provides a "catch all" method to attach custom Instance objects. Synonym for IsThis()
 | Is | Gives you full access to all the different ways to specify an "Instance" (Inherited from IsExpression<(Of <(T>)>).)
 | IsThis(Instance) | Register a previously built Instance. This provides a "catch all" method to attach custom Instance objects. Synonym for Instance()
 | IsThis(T) | Inject this object directly. Synonym to Object()
 | IsThis(Instance) | Shortcut to specify a prebuilt Instance Shortcut to specify a prebuilt Instance (Inherited from IsExpression<(Of <(T>)>).)
 | LoadControlFrom(String) | Creates an Instance that will load an ASCX user control from the url
 | Object(T) | Inject this object directly. Synonym to IsThis()
 | OfConcreteType<(Of <(PLUGGEDTYPE>)>)()()() | Build the Instance with the constructor function and setter arguments. Starts the definition of a SmartInstance
 | OfConcreteType(Type) | Build the Instance with the constructor function and setter arguments. Use this method for open generic types, and favor the generic version of OfConcreteType for all other types
 | PrototypeOf(T) | Creates an Instance that stores this object of type T, and returns a cloned copy of the template.
 | SerializedCopyOf(T) | Caches template as a serialized byte stream. Uses deserialization to create copies when the Instance is built.
 | TheDefault()()() | Use the default Instance of this PluginType. This is generally only used while configuring child dependencies within a deep object graph
 | TheInstanceNamed(String) | Use the Instance of this PluginType with the specified name. This is generally only used while configuring child dependencies within a deep object graph


ConstructedBy Method

ConstructedBy Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► ConstructedBy()()()
StructureMap API
Members
Icon | Member | Description
 | ConstructedBy(Func<(Of <(T>)>)) | Create an Instance that builds an object by calling a Lambda or an anonymous delegate with no arguments
 | ConstructedBy(Func<(Of <(IContext, T>)>)) | Create an Instance that builds an object by calling a Lambda or an anonymous delegate with the IContext representing the current object graph.


ConstructedBy Method (func)

ConstructedBy Method (func)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► ConstructedBy(Func<(Of <(T>)>))
StructureMap API
Create an Instance that builds an object by calling a Lambda or an anonymous delegate with no arguments
Declaration Syntax
C# Visual Basic Visual C++
ConstructorInstance<T> ConstructedBy(
    Func<T> func
)
Function ConstructedBy ( _
    func As Func(Of T) _
) As ConstructorInstance(Of T)
ConstructorInstance<T>^ ConstructedBy(
    Func<T>^ func
)
Parameters
func (Func <(Of <( T >)>))

[Missing <param name="func"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.ConstructedBy(System.Func{`0})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.ConstructedBy(System.Func{`0})]


ConstructedBy Method (func)

ConstructedBy Method (func)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► ConstructedBy(Func<(Of <(IContext, T>)>))
StructureMap API
Create an Instance that builds an object by calling a Lambda or an anonymous delegate with the IContext representing the current object graph.
Declaration Syntax
C# Visual Basic Visual C++
ConstructorInstance<T> ConstructedBy(
    Func<IContext, T> func
)
Function ConstructedBy ( _
    func As Func(Of IContext, T) _
) As ConstructorInstance(Of T)
ConstructorInstance<T>^ ConstructedBy(
    Func<IContext^, T>^ func
)
Parameters
func (Func <(Of <( IContext, T >)>))

[Missing <param name="func"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.ConstructedBy(System.Func{StructureMap.IContext,`0})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.ConstructedBy(System.Func{StructureMap.IContext,`0})]


Instance Method (instance)

Instance Method (instance)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► Instance(Instance)
StructureMap API
Register a previously built Instance. This provides a "catch all" method to attach custom Instance objects. Synonym for IsThis()
Declaration Syntax
C# Visual Basic Visual C++
void Instance(
    Instance instance
)
Sub Instance ( _
    instance As Instance _
)
void Instance(
    Instance^ instance
)
Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.Instance(StructureMap.Pipeline.Instance)"]


IsThis Method

IsThis Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► IsThis()()()
StructureMap API
Members
Icon | Member | Description
 | IsThis(Instance) |
 | IsThis(Instance) | Register a previously built Instance. This provides a "catch all" method to attach custom Instance objects. Synonym for Instance()
 | IsThis(T) | Inject this object directly. Synonym to Object()
 | IsThis(Instance) | Shortcut to specify a prebuilt Instance Shortcut to specify a prebuilt Instance


IsThis Method (instance)

IsThis Method (instance)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► IsThis(Instance)
StructureMap API
Register a previously built Instance. This provides a "catch all" method to attach custom Instance objects. Synonym for Instance()
Declaration Syntax
C# Visual Basic Visual C++
void IsThis(
    Instance instance
)
Sub IsThis ( _
    instance As Instance _
)
void IsThis(
    Instance^ instance
)
Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.IsThis(StructureMap.Pipeline.Instance)"]


IsThis Method (obj)

IsThis Method (obj)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► IsThis(T)
StructureMap API
Inject this object directly. Synonym to Object()
Declaration Syntax
C# Visual Basic Visual C++
LiteralInstance IsThis(
    T obj
)
Function IsThis ( _
    obj As T _
) As LiteralInstance
LiteralInstance^ IsThis(
    T obj
)
Parameters
obj (T)

[Missing <param name="obj"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.IsThis(`0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.IsThis(`0)]


LoadControlFrom Method (url)

LoadControlFrom Method (url)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► LoadControlFrom(String)
StructureMap API
Creates an Instance that will load an ASCX user control from the url
Declaration Syntax
C# Visual Basic Visual C++
UserControlInstance LoadControlFrom(
    string url
)
Function LoadControlFrom ( _
    url As String _
) As UserControlInstance
UserControlInstance^ LoadControlFrom(
    String^ url
)
Parameters
url (String)

[Missing <param name="url"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.LoadControlFrom(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.LoadControlFrom(System.String)]


Object Method (theObject)

Object Method (theObject)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► Object(T)
StructureMap API
Inject this object directly. Synonym to IsThis()
Declaration Syntax
C# Visual Basic Visual C++
LiteralInstance Object(
    T theObject
)
Function Object ( _
    theObject As T _
) As LiteralInstance
LiteralInstance^ Object(
    T theObject
)
Parameters
theObject (T)

[Missing <param name="theObject"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.Object(`0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.Object(`0)]


OfConcreteType Method

OfConcreteType Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► OfConcreteType()()()
StructureMap API
Members
Icon | Member | Description
 | OfConcreteType<(Of <(PLUGGEDTYPE>)>)()()() | Build the Instance with the constructor function and setter arguments. Starts the definition of a SmartInstance
 | OfConcreteType(Type) | Build the Instance with the constructor function and setter arguments. Use this method for open generic types, and favor the generic version of OfConcreteType for all other types


OfConcreteType Method

OfConcreteType<(Of <(PLUGGEDTYPE>)>) Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► OfConcreteType<(Of <(PLUGGEDTYPE>)>)()()()
StructureMap API
Build the Instance with the constructor function and setter arguments. Starts the definition of a SmartInstance
Declaration Syntax
C# Visual Basic Visual C++
SmartInstance<PLUGGEDTYPE> OfConcreteType<PLUGGEDTYPE>()
where PLUGGEDTYPE :

Function OfConcreteType(Of PLUGGEDTYPE As ) As SmartInstance(Of PLUGGEDTYPE)
generic<typename PLUGGEDTYPE>
where PLUGGEDTYPE :
SmartInstance<PLUGGEDTYPE>^ OfConcreteType()
Generic Template Parameters
PLUGGEDTYPE

[Missing <typeparam name="PLUGGEDTYPE"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.OfConcreteType``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.OfConcreteType``1]


OfConcreteType Method (type)

OfConcreteType Method (type)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► OfConcreteType(Type)
StructureMap API
Build the Instance with the constructor function and setter arguments. Use this method for open generic types, and favor the generic version of OfConcreteType for all other types
Declaration Syntax
C# Visual Basic Visual C++
ConfiguredInstance OfConcreteType(
    Type type
)
Function OfConcreteType ( _
    type As Type _
) As ConfiguredInstance
ConfiguredInstance^ OfConcreteType(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.OfConcreteType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.OfConcreteType(System.Type)]


PrototypeOf Method (template)

PrototypeOf Method (template)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► PrototypeOf(T)
StructureMap API
Creates an Instance that stores this object of type T, and returns a cloned copy of the template.
Declaration Syntax
C# Visual Basic Visual C++
PrototypeInstance PrototypeOf(
    T template
)
Function PrototypeOf ( _
    template As T _
) As PrototypeInstance
PrototypeInstance^ PrototypeOf(
    T template
)
Parameters
template (T)

[Missing <param name="template"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.PrototypeOf(`0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.PrototypeOf(`0)]


SerializedCopyOf Method (template)

SerializedCopyOf Method (template)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► SerializedCopyOf(T)
StructureMap API
Caches template as a serialized byte stream. Uses deserialization to create copies when the Instance is built.
Declaration Syntax
C# Visual Basic Visual C++
SerializedInstance SerializedCopyOf(
    T template
)
Function SerializedCopyOf ( _
    template As T _
) As SerializedInstance
SerializedInstance^ SerializedCopyOf(
    T template
)
Parameters
template (T)

[Missing <param name="template"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.SerializedCopyOf(`0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.SerializedCopyOf(`0)]


TheDefault Method

TheDefault Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► TheDefault()()()
StructureMap API
Use the default Instance of this PluginType. This is generally only used while configuring child dependencies within a deep object graph
Declaration Syntax
C# Visual Basic Visual C++
DefaultInstance TheDefault()
Function TheDefault As DefaultInstance
DefaultInstance^ TheDefault()
Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.TheDefault]


TheInstanceNamed Method (name)

TheInstanceNamed Method (name)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IInstanceExpression<(Of <(T>)>) ► TheInstanceNamed(String)
StructureMap API
Use the Instance of this PluginType with the specified name. This is generally only used while configuring child dependencies within a deep object graph
Declaration Syntax
C# Visual Basic Visual C++
ReferencedInstance TheInstanceNamed(
    string name
)
Function TheInstanceNamed ( _
    name As String _
) As ReferencedInstance
ReferencedInstance^ TheInstanceNamed(
    String^ name
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.TheInstanceNamed(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.IInstanceExpression`1.TheInstanceNamed(System.String)]


InstanceExpression(T) Class

InstanceExpression<(Of <(T>)>) Class
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>)
StructureMap API

[Missing <summary> documentation for T:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1]

Declaration Syntax
C# Visual Basic Visual C++
public class InstanceExpression<T> : IInstanceExpression<T>,
    IsExpression<T>

Public Class InstanceExpression(Of T) _
    Implements IInstanceExpression(Of T), IsExpression(Of T)
generic<typename T>
public ref class InstanceExpression : IInstanceExpression<T>,
    IsExpression<T>
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1"]

Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConstructedBy(Func<(Of <(T>)>)) |
 | ConstructedBy(Func<(Of <(IContext, T>)>)) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance(Instance) |
 | IsThis(Instance) |
 | IsThis(T) |
 | LoadControlFrom(String) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Object(T) |
 | OfConcreteType<(Of <(PLUGGEDTYPE>)>)()()() |
 | OfConcreteType(Type) |
 | PrototypeOf(T) |
 | SerializedCopyOf(T) |
 | TheDefault()()() |
 | TheInstanceNamed(String) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InstanceExpression<(Of <(T>)>)


ConstructedBy Method

ConstructedBy Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► ConstructedBy()()()
StructureMap API
Members
Icon | Member | Description
 | ConstructedBy(Func<(Of <(T>)>)) |
 | ConstructedBy(Func<(Of <(IContext, T>)>)) |


ConstructedBy Method (func)

ConstructedBy Method (func)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► ConstructedBy(Func<(Of <(T>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.ConstructedBy(System.Func{`0})]

Declaration Syntax
C# Visual Basic Visual C++
public ConstructorInstance<T> ConstructedBy(
    Func<T> func
)
Public Function ConstructedBy ( _
    func As Func(Of T) _
) As ConstructorInstance(Of T)
public:
virtual ConstructorInstance<T>^ ConstructedBy(
    Func<T>^ func
) sealed
Parameters
func (Func <(Of <( T >)>))

[Missing <param name="func"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.ConstructedBy(System.Func{`0})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.ConstructedBy(System.Func{`0})]


ConstructedBy Method (func)

ConstructedBy Method (func)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► ConstructedBy(Func<(Of <(IContext, T>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.ConstructedBy(System.Func{StructureMap.IContext,`0})]

Declaration Syntax
C# Visual Basic Visual C++
public ConstructorInstance<T> ConstructedBy(
    Func<IContext, T> func
)
Public Function ConstructedBy ( _
    func As Func(Of IContext, T) _
) As ConstructorInstance(Of T)
public:
virtual ConstructorInstance<T>^ ConstructedBy(
    Func<IContext^, T>^ func
) sealed
Parameters
func (Func <(Of <( IContext, T >)>))

[Missing <param name="func"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.ConstructedBy(System.Func{StructureMap.IContext,`0})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.ConstructedBy(System.Func{StructureMap.IContext,`0})]


Instance Method (instance)

Instance Method (instance)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► Instance(Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.Instance(StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public void Instance(
    Instance instance
)
Public Sub Instance ( _
    instance As Instance _
)
public:
virtual void Instance(
    Instance^ instance
) sealed
Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.Instance(StructureMap.Pipeline.Instance)"]


IsThis Method

IsThis Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► IsThis()()()
StructureMap API
Members
Icon | Member | Description
 | IsThis(Instance) |
 | IsThis(T) |


IsThis Method (instance)

IsThis Method (instance)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► IsThis(Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.IsThis(StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public void IsThis(
    Instance instance
)
Public Sub IsThis ( _
    instance As Instance _
)
public:
virtual void IsThis(
    Instance^ instance
) sealed
Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.IsThis(StructureMap.Pipeline.Instance)"]


IsThis Method (obj)

IsThis Method (obj)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► IsThis(T)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.IsThis(`0)]

Declaration Syntax
C# Visual Basic Visual C++
public LiteralInstance IsThis(
    T obj
)
Public Function IsThis ( _
    obj As T _
) As LiteralInstance
public:
virtual LiteralInstance^ IsThis(
    T obj
) sealed
Parameters
obj (T)

[Missing <param name="obj"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.IsThis(`0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.IsThis(`0)]


LoadControlFrom Method (url)

LoadControlFrom Method (url)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► LoadControlFrom(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.LoadControlFrom(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public UserControlInstance LoadControlFrom(
    string url
)
Public Function LoadControlFrom ( _
    url As String _
) As UserControlInstance
public:
virtual UserControlInstance^ LoadControlFrom(
    String^ url
) sealed
Parameters
url (String)

[Missing <param name="url"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.LoadControlFrom(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.LoadControlFrom(System.String)]


Object Method (theObject)

Object Method (theObject)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► Object(T)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.Object(`0)]

Declaration Syntax
C# Visual Basic Visual C++
public LiteralInstance Object(
    T theObject
)
Public Function Object ( _
    theObject As T _
) As LiteralInstance
public:
virtual LiteralInstance^ Object(
    T theObject
) sealed
Parameters
theObject (T)

[Missing <param name="theObject"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.Object(`0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.Object(`0)]


OfConcreteType Method

OfConcreteType Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► OfConcreteType()()()
StructureMap API
Members
Icon | Member | Description
 | OfConcreteType<(Of <(PLUGGEDTYPE>)>)()()() |
 | OfConcreteType(Type) |


OfConcreteType Method

OfConcreteType<(Of <(PLUGGEDTYPE>)>) Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► OfConcreteType<(Of <(PLUGGEDTYPE>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.OfConcreteType``1]

Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<PLUGGEDTYPE> OfConcreteType<PLUGGEDTYPE>()
where PLUGGEDTYPE :

Public Function OfConcreteType(Of PLUGGEDTYPE As ) As SmartInstance(Of PLUGGEDTYPE)
public:
generic<typename PLUGGEDTYPE>
where PLUGGEDTYPE :
virtual SmartInstance<PLUGGEDTYPE>^ OfConcreteType() sealed
Generic Template Parameters
PLUGGEDTYPE

[Missing <typeparam name="PLUGGEDTYPE"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.OfConcreteType``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.OfConcreteType``1]


OfConcreteType Method (type)

OfConcreteType Method (type)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► OfConcreteType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.OfConcreteType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance OfConcreteType(
    Type type
)
Public Function OfConcreteType ( _
    type As Type _
) As ConfiguredInstance
public:
virtual ConfiguredInstance^ OfConcreteType(
    Type^ type
) sealed
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.OfConcreteType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.OfConcreteType(System.Type)]


PrototypeOf Method (template)

PrototypeOf Method (template)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► PrototypeOf(T)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.PrototypeOf(`0)]

Declaration Syntax
C# Visual Basic Visual C++
public PrototypeInstance PrototypeOf(
    T template
)
Public Function PrototypeOf ( _
    template As T _
) As PrototypeInstance
public:
virtual PrototypeInstance^ PrototypeOf(
    T template
) sealed
Parameters
template (T)

[Missing <param name="template"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.PrototypeOf(`0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.PrototypeOf(`0)]


SerializedCopyOf Method (template)

SerializedCopyOf Method (template)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► SerializedCopyOf(T)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.SerializedCopyOf(`0)]

Declaration Syntax
C# Visual Basic Visual C++
public SerializedInstance SerializedCopyOf(
    T template
)
Public Function SerializedCopyOf ( _
    template As T _
) As SerializedInstance
public:
virtual SerializedInstance^ SerializedCopyOf(
    T template
) sealed
Parameters
template (T)

[Missing <param name="template"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.SerializedCopyOf(`0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.SerializedCopyOf(`0)]


TheDefault Method

TheDefault Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► TheDefault()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.TheDefault]

Declaration Syntax
C# Visual Basic Visual C++
public DefaultInstance TheDefault()
Public Function TheDefault As DefaultInstance
public:
virtual DefaultInstance^ TheDefault() sealed
Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.TheDefault]


TheInstanceNamed Method (name)

TheInstanceNamed Method (name)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► InstanceExpression<(Of <(T>)>) ► TheInstanceNamed(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.TheInstanceNamed(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public ReferencedInstance TheInstanceNamed(
    string name
)
Public Function TheInstanceNamed ( _
    name As String _
) As ReferencedInstance
public:
virtual ReferencedInstance^ TheInstanceNamed(
    String^ name
) sealed
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.TheInstanceNamed(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.InstanceExpression`1.TheInstanceNamed(System.String)]


IsExpression(T) Interface

IsExpression<(Of <(T>)>) Interface
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IsExpression<(Of <(T>)>)
StructureMap API
Expression Builder to define an Instance
Declaration Syntax
C# Visual Basic Visual C++
public interface IsExpression<T>

Public Interface IsExpression(Of T)
generic<typename T>
public interface class IsExpression
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:StructureMap.Configuration.DSL.Expressions.IsExpression`1"]

Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Is | Gives you full access to all the different ways to specify an "Instance"
 | IsThis(Instance) | Shortcut to specify a prebuilt Instance
 | IsThis(T) | Shortcut to directly inject an object


Is Property

Is Property
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IsExpression<(Of <(T>)>) ► Is
StructureMap API
Gives you full access to all the different ways to specify an "Instance"
Declaration Syntax
C# Visual Basic Visual C++
IInstanceExpression<T> Is { get; }
ReadOnly Property Is As IInstanceExpression(Of T)
property IInstanceExpression<T>^ Is {
    IInstanceExpression<T>^ get ();
}


IsThis Method

IsThis Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IsExpression<(Of <(T>)>) ► IsThis()()()
StructureMap API
Members
Icon | Member | Description
 | IsThis(Instance) | Shortcut to specify a prebuilt Instance
 | IsThis(T) | Shortcut to directly inject an object


IsThis Method (instance)

IsThis Method (instance)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IsExpression<(Of <(T>)>) ► IsThis(Instance)
StructureMap API
Shortcut to specify a prebuilt Instance
Declaration Syntax
C# Visual Basic Visual C++
void IsThis(
    Instance instance
)
Sub IsThis ( _
    instance As Instance _
)
void IsThis(
    Instance^ instance
)
Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.IsExpression`1.IsThis(StructureMap.Pipeline.Instance)"]


IsThis Method (obj)

IsThis Method (obj)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► IsExpression<(Of <(T>)>) ► IsThis(T)
StructureMap API
Shortcut to directly inject an object
Declaration Syntax
C# Visual Basic Visual C++
LiteralInstance IsThis(
    T obj
)
Function IsThis ( _
    obj As T _
) As LiteralInstance
LiteralInstance^ IsThis(
    T obj
)
Parameters
obj (T)

[Missing <param name="obj"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.IsExpression`1.IsThis(`0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.IsExpression`1.IsThis(`0)]


ProfileExpression Class

ProfileExpression Class
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression
StructureMap API
Expression class to help define a runtime Profile
Declaration Syntax
C# Visual Basic Visual C++
public class ProfileExpression
Public Class ProfileExpression
public ref class ProfileExpression
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProfileExpression(String, Registry) | Initializes a new instance of the ProfileExpression class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | For<(Of <(T>)>)()()() | Starts the definition of the default instance for the containing Profile. This is still valid, but Type() is recommended
 | For(Type) | Use statement to define the Profile defaults for a Generic type
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Type<(Of <(T>)>)()()() | Designate or define the Instance for a type within this Profile
Inheritance Hierarchy
Object
ProfileExpression


ProfileExpression Constructor (profileName, registry)

ProfileExpression Constructor (profileName, registry)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression ► ProfileExpression(String, Registry)
StructureMap API
Initializes a new instance of the ProfileExpression class
Declaration Syntax
C# Visual Basic Visual C++
public ProfileExpression(
    string profileName,
    Registry registry
)
Public Sub New ( _
    profileName As String, _
    registry As Registry _
)
public:
ProfileExpression(
    String^ profileName,
    Registry^ registry
)
Parameters
profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.#ctor(System.String,StructureMap.Configuration.DSL.Registry)"]

registry (Registry)

[Missing <param name="registry"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.#ctor(System.String,StructureMap.Configuration.DSL.Registry)"]


For Method

For Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression ► For()()()
StructureMap API
Members
Icon | Member | Description
 | For<(Of <(T>)>)()()() | Starts the definition of the default instance for the containing Profile. This is still valid, but Type() is recommended
 | For(Type) | Use statement to define the Profile defaults for a Generic type


For Method

For<(Of <(T>)>) Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression ► For<(Of <(T>)>)()()()
StructureMap API
Starts the definition of the default instance for the containing Profile. This is still valid, but Type() is recommended
Declaration Syntax
C# Visual Basic Visual C++
public ProfileExpression..::.InstanceDefaultExpression<T> For<T>()

Public Function For(Of T) As ProfileExpression..::.InstanceDefaultExpression(Of T)
public:
generic<typename T>
ProfileExpression..::.InstanceDefaultExpression<T>^ For()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.For``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.For``1]


For Method (pluginType)

For Method (pluginType)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression ► For(Type)
StructureMap API
Use statement to define the Profile defaults for a Generic type
Declaration Syntax
C# Visual Basic Visual C++
public ProfileExpression..::.GenericDefaultExpression For(
    Type pluginType
)
Public Function For ( _
    pluginType As Type _
) As ProfileExpression..::.GenericDefaultExpression
public:
ProfileExpression..::.GenericDefaultExpression^ For(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.For(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.For(System.Type)]


Type Method

Type<(Of <(T>)>) Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression ► Type<(Of <(T>)>)()()()
StructureMap API
Designate or define the Instance for a type within this Profile
Declaration Syntax
C# Visual Basic Visual C++
public IsExpression<T> Type<T>()

Public Function Type(Of T) As IsExpression(Of T)
public:
generic<typename T>
IsExpression<T>^ Type()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.Type``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.Type``1]


ProfileExpression.GenericDefaultExpression Class

ProfileExpression..::.GenericDefaultExpression Class
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression ► ProfileExpression..::.GenericDefaultExpression
StructureMap API
Expression Builder inside of a Profile creation for open generic types
Declaration Syntax
C# Visual Basic Visual C++
public class GenericDefaultExpression
Public Class GenericDefaultExpression
public ref class GenericDefaultExpression
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Use(Instance) | Use this Instance for the Profile Instance of this Plugin Type
 | UseConcreteType(Type) | Use this concreteType for the Instance of this Profile for the PluginType
 | UseNamedInstance(String) | Use the named Instance as the Profile Instance for this PluginType
Inheritance Hierarchy
Object
ProfileExpression..::.GenericDefaultExpression


Use Method (instance)

Use Method (instance)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression..::.GenericDefaultExpression ► Use(Instance)
StructureMap API
Use this Instance for the Profile Instance of this Plugin Type
Declaration Syntax
C# Visual Basic Visual C++
public ProfileExpression Use(
    Instance instance
)
Public Function Use ( _
    instance As Instance _
) As ProfileExpression
public:
ProfileExpression^ Use(
    Instance^ instance
)
Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.GenericDefaultExpression.Use(StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.GenericDefaultExpression.Use(StructureMap.Pipeline.Instance)]


UseConcreteType Method (concreteType)

UseConcreteType Method (concreteType)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression..::.GenericDefaultExpression ► UseConcreteType(Type)
StructureMap API
Use this concreteType for the Instance of this Profile for the PluginType
Declaration Syntax
C# Visual Basic Visual C++
public ProfileExpression UseConcreteType(
    Type concreteType
)
Public Function UseConcreteType ( _
    concreteType As Type _
) As ProfileExpression
public:
ProfileExpression^ UseConcreteType(
    Type^ concreteType
)
Parameters
concreteType (Type)

[Missing <param name="concreteType"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.GenericDefaultExpression.UseConcreteType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.GenericDefaultExpression.UseConcreteType(System.Type)]


UseNamedInstance Method (name)

UseNamedInstance Method (name)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression..::.GenericDefaultExpression ► UseNamedInstance(String)
StructureMap API
Use the named Instance as the Profile Instance for this PluginType
Declaration Syntax
C# Visual Basic Visual C++
public ProfileExpression UseNamedInstance(
    string name
)
Public Function UseNamedInstance ( _
    name As String _
) As ProfileExpression
public:
ProfileExpression^ UseNamedInstance(
    String^ name
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.GenericDefaultExpression.UseNamedInstance(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.GenericDefaultExpression.UseNamedInstance(System.String)]


ProfileExpression.InstanceDefaultExpression(T) Class

ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>) Class
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression ► ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>)
StructureMap API
Expression Builder within defining a Profile
Declaration Syntax
C# Visual Basic Visual C++
public class InstanceDefaultExpression<T>

Public Class InstanceDefaultExpression(Of T)
generic<typename T>
public ref class InstanceDefaultExpression
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:StructureMap.Configuration.DSL.Expressions.ProfileExpression.InstanceDefaultExpression`1"]

Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>)(ProfileExpression) | Initializes a new instance of the ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>) class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Use(Instance) | Define the default instance of the PluginType for the containing Profile
 | Use(Func<(Of <(T>)>)) | For this Profile, use an Instance with this Func
 | Use(T) | For this Profile, use this object
 | UseConcreteType<(Of <(CONCRETETYPE>)>)()()() | For this Profile, use the Concrete Type
 | UseNamedInstance(String) | Use a named, preconfigured instance as the default instance for this profile
Inheritance Hierarchy
Object
ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>)


ProfileExpression.InstanceDefaultExpression(T) Constructor (parent)

ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>) Constructor (parent)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>) ► ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>)(ProfileExpression)
StructureMap API
Initializes a new instance of the ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>) class
Declaration Syntax
C# Visual Basic Visual C++
public InstanceDefaultExpression(
    ProfileExpression parent
)
Public Sub New ( _
    parent As ProfileExpression _
)
public:
InstanceDefaultExpression(
    ProfileExpression^ parent
)
Parameters
parent (ProfileExpression)

[Missing <param name="parent"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.InstanceDefaultExpression`1.#ctor(StructureMap.Configuration.DSL.Expressions.ProfileExpression)"]


Use Method

Use Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>) ► Use()()()
StructureMap API
Members
Icon | Member | Description
 | Use(Instance) | Define the default instance of the PluginType for the containing Profile
 | Use(Func<(Of <(T>)>)) | For this Profile, use an Instance with this Func
 | Use(T) | For this Profile, use this object


Use Method (instance)

Use Method (instance)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>) ► Use(Instance)
StructureMap API
Define the default instance of the PluginType for the containing Profile
Declaration Syntax
C# Visual Basic Visual C++
public ProfileExpression Use(
    Instance instance
)
Public Function Use ( _
    instance As Instance _
) As ProfileExpression
public:
ProfileExpression^ Use(
    Instance^ instance
)
Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.InstanceDefaultExpression`1.Use(StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.InstanceDefaultExpression`1.Use(StructureMap.Pipeline.Instance)]


Use Method (func)

Use Method (func)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>) ► Use(Func<(Of <(T>)>))
StructureMap API
For this Profile, use an Instance with this Func
Declaration Syntax
C# Visual Basic Visual C++
public ProfileExpression Use(
    Func<T> func
)
Public Function Use ( _
    func As Func(Of T) _
) As ProfileExpression
public:
ProfileExpression^ Use(
    Func<T>^ func
)
Parameters
func (Func <(Of <( T >)>))

[Missing <param name="func"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.InstanceDefaultExpression`1.Use(System.Func{`0})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.InstanceDefaultExpression`1.Use(System.Func{`0})]


Use Method (t)

Use Method (t)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>) ► Use(T)
StructureMap API
For this Profile, use this object
Declaration Syntax
C# Visual Basic Visual C++
public ProfileExpression Use(
    T t
)
Public Function Use ( _
    t As T _
) As ProfileExpression
public:
ProfileExpression^ Use(
    T t
)
Parameters
t (T)

[Missing <param name="t"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.InstanceDefaultExpression`1.Use(`0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.InstanceDefaultExpression`1.Use(`0)]


UseConcreteType Method

UseConcreteType<(Of <(CONCRETETYPE>)>) Method
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>) ► UseConcreteType<(Of <(CONCRETETYPE>)>)()()()
StructureMap API
For this Profile, use the Concrete Type
Declaration Syntax
C# Visual Basic Visual C++
public ProfileExpression UseConcreteType<CONCRETETYPE>()

Public Function UseConcreteType(Of CONCRETETYPE) As ProfileExpression
public:
generic<typename CONCRETETYPE>
ProfileExpression^ UseConcreteType()
Generic Template Parameters
CONCRETETYPE

[Missing <typeparam name="CONCRETETYPE"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.InstanceDefaultExpression`1.UseConcreteType``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.InstanceDefaultExpression`1.UseConcreteType``1]


UseNamedInstance Method (instanceKey)

UseNamedInstance Method (instanceKey)
Namespaces ► StructureMap.Configuration.DSL.Expressions ► ProfileExpression..::.InstanceDefaultExpression<(Of <(T>)>) ► UseNamedInstance(String)
StructureMap API
Use a named, preconfigured instance as the default instance for this profile
Declaration Syntax
C# Visual Basic Visual C++
public ProfileExpression UseNamedInstance(
    string instanceKey
)
Public Function UseNamedInstance ( _
    instanceKey As String _
) As ProfileExpression
public:
ProfileExpression^ UseNamedInstance(
    String^ instanceKey
)
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.InstanceDefaultExpression`1.UseNamedInstance(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Configuration.DSL.Expressions.ProfileExpression.InstanceDefaultExpression`1.UseNamedInstance(System.String)]


StructureMap.Diagnostics Namespace

StructureMap.Diagnostics Namespace
Namespaces ► StructureMap.Diagnostics
StructureMap API

[Missing <summary> documentation for N:StructureMap.Diagnostics]

Declaration Syntax
C# Visual Basic Visual C++
namespace StructureMap.Diagnostics
Namespace StructureMap.Diagnostics
namespace StructureMap.Diagnostics
Types
All Types Classes Enumerations
Icon | Type | Description
 | BuildDependency |
 | BuildError |
 | Doctor |
 | DoctorReport |
 | DoctorResult |
 | DoctorRunner |
 | Error |
 | ErrorCollection |
 | GraphLog |
 | InstanceToken |
 | TextReportWriter |
 | GraphLog..::.TryAction |
 | ValidationBuildSession |
 | ValidationError |
 | WhatDoIHaveWriter |


BuildDependency Class

BuildDependency Class
Namespaces ► StructureMap.Diagnostics ► BuildDependency
StructureMap API

[Missing <summary> documentation for T:StructureMap.Diagnostics.BuildDependency]

Declaration Syntax
C# Visual Basic Visual C++
public class BuildDependency : IEquatable<BuildDependency>
Public Class BuildDependency _
    Implements IEquatable(Of BuildDependency)
public ref class BuildDependency : IEquatable<BuildDependency^>
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuildDependency(Type, Instance) | Initializes a new instance of the BuildDependency class
 | Equals(BuildDependency) |
 | Equals(Object) | (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PluginType |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BuildDependency


BuildDependency Constructor (pluginType, instance)

BuildDependency Constructor (pluginType, instance)
Namespaces ► StructureMap.Diagnostics ► BuildDependency ► BuildDependency(Type, Instance)
StructureMap API
Initializes a new instance of the BuildDependency class
Declaration Syntax
C# Visual Basic Visual C++
public BuildDependency(
    Type pluginType,
    Instance instance
)
Public Sub New ( _
    pluginType As Type, _
    instance As Instance _
)
public:
BuildDependency(
    Type^ pluginType,
    Instance^ instance
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Diagnostics.BuildDependency.#ctor(System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Diagnostics.BuildDependency.#ctor(System.Type,StructureMap.Pipeline.Instance)"]


Equals Method

Equals Method
Namespaces ► StructureMap.Diagnostics ► BuildDependency ► Equals()()()
StructureMap API
Members
Icon | Member | Description
 | Equals(BuildDependency) |
 | Equals(Object) | (Overrides Object.Equals(Object).)


Equals Method (buildDependency)

Equals Method (buildDependency)
Namespaces ► StructureMap.Diagnostics ► BuildDependency ► Equals(BuildDependency)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.BuildDependency.Equals(StructureMap.Diagnostics.BuildDependency)]

Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    BuildDependency buildDependency
)
Public Function Equals ( _
    buildDependency As BuildDependency _
) As Boolean
public:
virtual bool Equals(
    BuildDependency^ buildDependency
) sealed
Parameters
buildDependency (BuildDependency)

[Missing <param name="buildDependency"/> documentation for "M:StructureMap.Diagnostics.BuildDependency.Equals(StructureMap.Diagnostics.BuildDependency)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.BuildDependency.Equals(StructureMap.Diagnostics.BuildDependency)]


Equals Method (obj)

Equals Method (obj)
Namespaces ► StructureMap.Diagnostics ► BuildDependency ► Equals(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.BuildDependency.Equals(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:StructureMap.Diagnostics.BuildDependency.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.BuildDependency.Equals(System.Object)]


GetHashCode Method

GetHashCode Method
Namespaces ► StructureMap.Diagnostics ► BuildDependency ► GetHashCode()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.BuildDependency.GetHashCode]

Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.BuildDependency.GetHashCode]


Instance Field

Instance Field
Namespaces ► StructureMap.Diagnostics ► BuildDependency ► Instance
StructureMap API

[Missing <summary> documentation for F:StructureMap.Diagnostics.BuildDependency.Instance]

Declaration Syntax
C# Visual Basic Visual C++
public Instance Instance
Public Instance As Instance
public:
Instance^ Instance


PluginType Field

PluginType Field
Namespaces ► StructureMap.Diagnostics ► BuildDependency ► PluginType
StructureMap API

[Missing <summary> documentation for F:StructureMap.Diagnostics.BuildDependency.PluginType]

Declaration Syntax
C# Visual Basic Visual C++
public Type PluginType
Public PluginType As Type
public:
Type^ PluginType


BuildError Class

BuildError Class
Namespaces ► StructureMap.Diagnostics ► BuildError
StructureMap API

[Missing <summary> documentation for T:StructureMap.Diagnostics.BuildError]

Declaration Syntax
C# Visual Basic Visual C++
public class BuildError
Public Class BuildError
public ref class BuildError
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuildError(Type, Instance) | Initializes a new instance of the BuildError class
 | AddDependency(BuildDependency) |
 | Dependencies |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exception |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PluginType |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Write(StringWriter) |
Inheritance Hierarchy
Object
BuildError


BuildError Constructor (pluginType, instance)

BuildError Constructor (pluginType, instance)
Namespaces ► StructureMap.Diagnostics ► BuildError ► BuildError(Type, Instance)
StructureMap API
Initializes a new instance of the BuildError class
Declaration Syntax
C# Visual Basic Visual C++
public BuildError(
    Type pluginType,
    Instance instance
)
Public Sub New ( _
    pluginType As Type, _
    instance As Instance _
)
public:
BuildError(
    Type^ pluginType,
    Instance^ instance
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Diagnostics.BuildError.#ctor(System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Diagnostics.BuildError.#ctor(System.Type,StructureMap.Pipeline.Instance)"]


AddDependency Method (dependency)

AddDependency Method (dependency)
Namespaces ► StructureMap.Diagnostics ► BuildError ► AddDependency(BuildDependency)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.BuildError.AddDependency(StructureMap.Diagnostics.BuildDependency)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddDependency(
    BuildDependency dependency
)
Public Sub AddDependency ( _
    dependency As BuildDependency _
)
public:
void AddDependency(
    BuildDependency^ dependency
)
Parameters
dependency (BuildDependency)

[Missing <param name="dependency"/> documentation for "M:StructureMap.Diagnostics.BuildError.AddDependency(StructureMap.Diagnostics.BuildDependency)"]


Dependencies Property

Dependencies Property
Namespaces ► StructureMap.Diagnostics ► BuildError ► Dependencies
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.BuildError.Dependencies]

Declaration Syntax
C# Visual Basic Visual C++
public List<BuildDependency> Dependencies { get; }
Public ReadOnly Property Dependencies As List(Of BuildDependency)
public:
property List<BuildDependency^>^ Dependencies {
    List<BuildDependency^>^ get ();
}


Exception Property

Exception Property
Namespaces ► StructureMap.Diagnostics ► BuildError ► Exception
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.BuildError.Exception]

Declaration Syntax
C# Visual Basic Visual C++
public StructureMapException Exception { get; set; }
Public Property Exception As StructureMapException
public:
property StructureMapException^ Exception {
    StructureMapException^ get ();
    void set (StructureMapException^ value);
}


Instance Property

Instance Property
Namespaces ► StructureMap.Diagnostics ► BuildError ► Instance
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.BuildError.Instance]

Declaration Syntax
C# Visual Basic Visual C++
public Instance Instance { get; }
Public ReadOnly Property Instance As Instance
public:
property Instance^ Instance {
    Instance^ get ();
}


PluginType Property

PluginType Property
Namespaces ► StructureMap.Diagnostics ► BuildError ► PluginType
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.BuildError.PluginType]

Declaration Syntax
C# Visual Basic Visual C++
public Type PluginType { get; }
Public ReadOnly Property PluginType As Type
public:
property Type^ PluginType {
    Type^ get ();
}


Write Method (writer)

Write Method (writer)
Namespaces ► StructureMap.Diagnostics ► BuildError ► Write(StringWriter)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.BuildError.Write(System.IO.StringWriter)]

Declaration Syntax
C# Visual Basic Visual C++
public void Write(
    StringWriter writer
)
Public Sub Write ( _
    writer As StringWriter _
)
public:
void Write(
    StringWriter^ writer
)
Parameters
writer (StringWriter)

[Missing <param name="writer"/> documentation for "M:StructureMap.Diagnostics.BuildError.Write(System.IO.StringWriter)"]


Doctor Class

Doctor Class
Namespaces ► StructureMap.Diagnostics ► Doctor
StructureMap API

[Missing <summary> documentation for T:StructureMap.Diagnostics.Doctor]

Declaration Syntax
C# Visual Basic Visual C++
public class Doctor
Public Class Doctor
public ref class Doctor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Doctor()()() | Initializes a new instance of the Doctor class
 | BinaryPath |
 | BootstrapperType |
 | ConfigFile |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OutputFile |
 | RunReport()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Doctor


Doctor Constructor

Doctor Constructor
Namespaces ► StructureMap.Diagnostics ► Doctor ► Doctor()()()
StructureMap API
Initializes a new instance of the Doctor class
Declaration Syntax
C# Visual Basic Visual C++
public Doctor()
Public Sub New
public:
Doctor()


BinaryPath Property

BinaryPath Property
Namespaces ► StructureMap.Diagnostics ► Doctor ► BinaryPath
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.Doctor.BinaryPath]

Declaration Syntax
C# Visual Basic Visual C++
public string BinaryPath { get; set; }
Public Property BinaryPath As String
public:
property String^ BinaryPath {
    String^ get ();
    void set (String^ value);
}


BootstrapperType Property

BootstrapperType Property
Namespaces ► StructureMap.Diagnostics ► Doctor ► BootstrapperType
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.Doctor.BootstrapperType]

Declaration Syntax
C# Visual Basic Visual C++
public string BootstrapperType { get; set; }
Public Property BootstrapperType As String
public:
property String^ BootstrapperType {
    String^ get ();
    void set (String^ value);
}


ConfigFile Property

ConfigFile Property
Namespaces ► StructureMap.Diagnostics ► Doctor ► ConfigFile
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.Doctor.ConfigFile]

Declaration Syntax
C# Visual Basic Visual C++
public string ConfigFile { get; set; }
Public Property ConfigFile As String
public:
property String^ ConfigFile {
    String^ get ();
    void set (String^ value);
}


OutputFile Property

OutputFile Property
Namespaces ► StructureMap.Diagnostics ► Doctor ► OutputFile
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.Doctor.OutputFile]

Declaration Syntax
C# Visual Basic Visual C++
public string OutputFile { get; set; }
Public Property OutputFile As String
public:
property String^ OutputFile {
    String^ get ();
    void set (String^ value);
}


RunReport Method

RunReport Method
Namespaces ► StructureMap.Diagnostics ► Doctor ► RunReport()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.Doctor.RunReport]

Declaration Syntax
C# Visual Basic Visual C++
public DoctorReport RunReport()
Public Function RunReport As DoctorReport
public:
DoctorReport^ RunReport()
Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.Doctor.RunReport]


DoctorReport Class

DoctorReport Class
Namespaces ► StructureMap.Diagnostics ► DoctorReport
StructureMap API

[Missing <summary> documentation for T:StructureMap.Diagnostics.DoctorReport]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class DoctorReport
<SerializableAttribute> _
Public Class DoctorReport
[SerializableAttribute]
public ref class DoctorReport
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DoctorReport()()() | Initializes a new instance of the DoctorReport class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorMessages |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Result |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WhatDoIHave |
Inheritance Hierarchy
Object
DoctorReport


DoctorReport Constructor

DoctorReport Constructor
Namespaces ► StructureMap.Diagnostics ► DoctorReport ► DoctorReport()()()
StructureMap API
Initializes a new instance of the DoctorReport class
Declaration Syntax
C# Visual Basic Visual C++
public DoctorReport()
Public Sub New
public:
DoctorReport()


ErrorMessages Field

ErrorMessages Field
Namespaces ► StructureMap.Diagnostics ► DoctorReport ► ErrorMessages
StructureMap API

[Missing <summary> documentation for F:StructureMap.Diagnostics.DoctorReport.ErrorMessages]

Declaration Syntax
C# Visual Basic Visual C++
public string ErrorMessages
Public ErrorMessages As String
public:
String^ ErrorMessages


Result Field

Result Field
Namespaces ► StructureMap.Diagnostics ► DoctorReport ► Result
StructureMap API

[Missing <summary> documentation for F:StructureMap.Diagnostics.DoctorReport.Result]

Declaration Syntax
C# Visual Basic Visual C++
public DoctorResult Result
Public Result As DoctorResult
public:
DoctorResult Result


WhatDoIHave Field

WhatDoIHave Field
Namespaces ► StructureMap.Diagnostics ► DoctorReport ► WhatDoIHave
StructureMap API

[Missing <summary> documentation for F:StructureMap.Diagnostics.DoctorReport.WhatDoIHave]

Declaration Syntax
C# Visual Basic Visual C++
public string WhatDoIHave
Public WhatDoIHave As String
public:
String^ WhatDoIHave


DoctorResult Enumeration

DoctorResult Enumeration
Namespaces ► StructureMap.Diagnostics ► DoctorResult
StructureMap API

[Missing <summary> documentation for T:StructureMap.Diagnostics.DoctorResult]

Declaration Syntax
C# Visual Basic Visual C++
public enum DoctorResult
Public Enumeration DoctorResult
public enum class DoctorResult
Members
Member | Description
BootstrapperFailure |
BootstrapperCouldNotBeFound |
Success |
ConfigurationErrors |
ValidationErrors |
BuildErrors |


DoctorRunner Class

DoctorRunner Class
Namespaces ► StructureMap.Diagnostics ► DoctorRunner
StructureMap API

[Missing <summary> documentation for T:StructureMap.Diagnostics.DoctorRunner]

Declaration Syntax
C# Visual Basic Visual C++
public class DoctorRunner : MarshalByRefObject
Public Class DoctorRunner _
    Inherits MarshalByRefObject
public ref class DoctorRunner : public MarshalByRefObject
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DoctorRunner()()() | Initializes a new instance of the DoctorRunner class
 | CreateObjRef(Type) | Creates an object that contains all the relevant information required to generate a proxy used to communicate with a remote object. (Inherited from MarshalByRefObject.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetLifetimeService()()() | Retrieves the current lifetime service object that controls the lifetime policy for this instance. (Inherited from MarshalByRefObject.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InitializeLifetimeService()()() | (Overrides MarshalByRefObject.InitializeLifetimeService()()().)
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object. (Inherited from MarshalByRefObject.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RunReport(String) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | MarshalByRefObject
 |  | DoctorRunner


DoctorRunner Constructor

DoctorRunner Constructor
Namespaces ► StructureMap.Diagnostics ► DoctorRunner ► DoctorRunner()()()
StructureMap API
Initializes a new instance of the DoctorRunner class
Declaration Syntax
C# Visual Basic Visual C++
public DoctorRunner()
Public Sub New
public:
DoctorRunner()


InitializeLifetimeService Method

InitializeLifetimeService Method
Namespaces ► StructureMap.Diagnostics ► DoctorRunner ► InitializeLifetimeService()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.DoctorRunner.InitializeLifetimeService]

Declaration Syntax
C# Visual Basic Visual C++
public override Object InitializeLifetimeService()
Public Overrides Function InitializeLifetimeService As Object
public:
virtual Object^ InitializeLifetimeService() override
Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.DoctorRunner.InitializeLifetimeService]


RunReport Method (bootstrapperTypeName)

RunReport Method (bootstrapperTypeName)
Namespaces ► StructureMap.Diagnostics ► DoctorRunner ► RunReport(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.DoctorRunner.RunReport(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public DoctorReport RunReport(
    string bootstrapperTypeName
)
Public Function RunReport ( _
    bootstrapperTypeName As String _
) As DoctorReport
public:
DoctorReport^ RunReport(
    String^ bootstrapperTypeName
)
Parameters
bootstrapperTypeName (String)

[Missing <param name="bootstrapperTypeName"/> documentation for "M:StructureMap.Diagnostics.DoctorRunner.RunReport(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.DoctorRunner.RunReport(System.String)]


Error Class

Error Class
Namespaces ► StructureMap.Diagnostics ► Error
StructureMap API

[Missing <summary> documentation for T:StructureMap.Diagnostics.Error]

Declaration Syntax
C# Visual Basic Visual C++
public class Error : IEquatable<Error>
Public Class Error _
    Implements IEquatable(Of Error)
public ref class Error : IEquatable<Error^>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Error(Int32, array<Object>[]()[]) | Initializes a new instance of the Error class
 | Error(Int32, Exception, array<Object>[]()[]) | Initializes a new instance of the Error class
 | Error(StructureMapException) | Initializes a new instance of the Error class
 | Code |
 | Equals(Error) |
 | Equals(Object) | (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FromMessage(Int32, String) |
 | GetHashCode()()() | (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Source |
 | ToString()()() | (Overrides Object.ToString()()().)
 | Write(StringWriter) |
Inheritance Hierarchy
Object
Error


Error Constructor

Error Constructor
Namespaces ► StructureMap.Diagnostics ► Error ► Error()()()
StructureMap API
Members
Icon | Member | Description
 | Error(Int32, array<Object>[]()[]) | Initializes a new instance of the Error class
 | Error(Int32, Exception, array<Object>[]()[]) | Initializes a new instance of the Error class
 | Error(StructureMapException) | Initializes a new instance of the Error class


Error Constructor (exception)

Error Constructor (exception)
Namespaces ► StructureMap.Diagnostics ► Error ► Error(StructureMapException)
StructureMap API
Initializes a new instance of the Error class
Declaration Syntax
C# Visual Basic Visual C++
public Error(
    StructureMapException exception
)
Public Sub New ( _
    exception As StructureMapException _
)
public:
Error(
    StructureMapException^ exception
)
Parameters
exception (StructureMapException)

[Missing <param name="exception"/> documentation for "M:StructureMap.Diagnostics.Error.#ctor(StructureMap.StructureMapException)"]


Error Constructor (errorCode, ex, args)

Error Constructor (errorCode, ex, args)
Namespaces ► StructureMap.Diagnostics ► Error ► Error(Int32, Exception, array<Object>[]()[])
StructureMap API
Initializes a new instance of the Error class
Declaration Syntax
C# Visual Basic Visual C++
public Error(
    int errorCode,
    Exception ex,
    params Object[] args
)
Public Sub New ( _
    errorCode As Integer, _
    ex As Exception, _
    ParamArray args As Object() _
)
public:
Error(
    int errorCode,
    Exception^ ex,
    ... array<Object^>^ args
)
Parameters
errorCode (Int32)

[Missing <param name="errorCode"/> documentation for "M:StructureMap.Diagnostics.Error.#ctor(System.Int32,System.Exception,System.Object[])"]

ex (Exception)

[Missing <param name="ex"/> documentation for "M:StructureMap.Diagnostics.Error.#ctor(System.Int32,System.Exception,System.Object[])"]

args (array< Object >[]()[])

[Missing <param name="args"/> documentation for "M:StructureMap.Diagnostics.Error.#ctor(System.Int32,System.Exception,System.Object[])"]


Error Constructor (errorCode, args)

Error Constructor (errorCode, args)
Namespaces ► StructureMap.Diagnostics ► Error ► Error(Int32, array<Object>[]()[])
StructureMap API
Initializes a new instance of the Error class
Declaration Syntax
C# Visual Basic Visual C++
public Error(
    int errorCode,
    params Object[] args
)
Public Sub New ( _
    errorCode As Integer, _
    ParamArray args As Object() _
)
public:
Error(
    int errorCode,
    ... array<Object^>^ args
)
Parameters
errorCode (Int32)

[Missing <param name="errorCode"/> documentation for "M:StructureMap.Diagnostics.Error.#ctor(System.Int32,System.Object[])"]

args (array< Object >[]()[])

[Missing <param name="args"/> documentation for "M:StructureMap.Diagnostics.Error.#ctor(System.Int32,System.Object[])"]


Code Property

Code Property
Namespaces ► StructureMap.Diagnostics ► Error ► Code
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.Error.Code]

Declaration Syntax
C# Visual Basic Visual C++
public int Code { get; }
Public ReadOnly Property Code As Integer
public:
property int Code {
    int get ();
}


Equals Method

Equals Method
Namespaces ► StructureMap.Diagnostics ► Error ► Equals()()()
StructureMap API
Members
Icon | Member | Description
 | Equals(Error) |
 | Equals(Object) | (Overrides Object.Equals(Object).)


Equals Method (error)

Equals Method (error)
Namespaces ► StructureMap.Diagnostics ► Error ► Equals(Error)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.Error.Equals(StructureMap.Diagnostics.Error)]

Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    Error error
)
Public Function Equals ( _
    error As Error _
) As Boolean
public:
virtual bool Equals(
    Error^ error
) sealed
Parameters
error (Error)

[Missing <param name="error"/> documentation for "M:StructureMap.Diagnostics.Error.Equals(StructureMap.Diagnostics.Error)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.Error.Equals(StructureMap.Diagnostics.Error)]


Equals Method (obj)

Equals Method (obj)
Namespaces ► StructureMap.Diagnostics ► Error ► Equals(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.Error.Equals(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:StructureMap.Diagnostics.Error.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.Error.Equals(System.Object)]


FromMessage Method (code, message)

FromMessage Method (code, message)
Namespaces ► StructureMap.Diagnostics ► Error ► FromMessage(Int32, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.Error.FromMessage(System.Int32,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static Error FromMessage(
    int code,
    string message
)
Public Shared Function FromMessage ( _
    code As Integer, _
    message As String _
) As Error
public:
static Error^ FromMessage(
    int code,
    String^ message
)
Parameters
code (Int32)

[Missing <param name="code"/> documentation for "M:StructureMap.Diagnostics.Error.FromMessage(System.Int32,System.String)"]

message (String)

[Missing <param name="message"/> documentation for "M:StructureMap.Diagnostics.Error.FromMessage(System.Int32,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.Error.FromMessage(System.Int32,System.String)]


GetHashCode Method

GetHashCode Method
Namespaces ► StructureMap.Diagnostics ► Error ► GetHashCode()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.Error.GetHashCode]

Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.Error.GetHashCode]


Instance Field

Instance Field
Namespaces ► StructureMap.Diagnostics ► Error ► Instance
StructureMap API

[Missing <summary> documentation for F:StructureMap.Diagnostics.Error.Instance]

Declaration Syntax
C# Visual Basic Visual C++
public InstanceToken Instance
Public Instance As InstanceToken
public:
InstanceToken^ Instance


Source Field

Source Field
Namespaces ► StructureMap.Diagnostics ► Error ► Source
StructureMap API

[Missing <summary> documentation for F:StructureMap.Diagnostics.Error.Source]

Declaration Syntax
C# Visual Basic Visual C++
public string Source
Public Source As String
public:
String^ Source


ToString Method

ToString Method
Namespaces ► StructureMap.Diagnostics ► Error ► ToString()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.Error.ToString]

Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.Error.ToString]


Write Method (writer)

Write Method (writer)
Namespaces ► StructureMap.Diagnostics ► Error ► Write(StringWriter)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.Error.Write(System.IO.StringWriter)]

Declaration Syntax
C# Visual Basic Visual C++
public void Write(
    StringWriter writer
)
Public Sub Write ( _
    writer As StringWriter _
)
public:
void Write(
    StringWriter^ writer
)
Parameters
writer (StringWriter)

[Missing <param name="writer"/> documentation for "M:StructureMap.Diagnostics.Error.Write(System.IO.StringWriter)"]


ErrorCollection Class

ErrorCollection Class
Namespaces ► StructureMap.Diagnostics ► ErrorCollection
StructureMap API

[Missing <summary> documentation for T:StructureMap.Diagnostics.ErrorCollection]

Declaration Syntax
C# Visual Basic Visual C++
public class ErrorCollection
Public Class ErrorCollection
public ref class ErrorCollection
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ErrorCollection()()() | Initializes a new instance of the ErrorCollection class
 | BuildErrors |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Type, String) |
 | ForEach(Action<(Of <(BuildError>)>)) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | LogError(Instance, Type, StructureMapException, IEnumerable<(Of <(BuildDependency>)>)) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ErrorCollection


ErrorCollection Constructor

ErrorCollection Constructor
Namespaces ► StructureMap.Diagnostics ► ErrorCollection ► ErrorCollection()()()
StructureMap API
Initializes a new instance of the ErrorCollection class
Declaration Syntax
C# Visual Basic Visual C++
public ErrorCollection()
Public Sub New
public:
ErrorCollection()


BuildErrors Property

BuildErrors Property
Namespaces ► StructureMap.Diagnostics ► ErrorCollection ► BuildErrors
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.ErrorCollection.BuildErrors]

Declaration Syntax
C# Visual Basic Visual C++
public BuildError[] BuildErrors { get; }
Public ReadOnly Property BuildErrors As BuildError()
public:
property array<BuildError^>^ BuildErrors {
    array<BuildError^>^ get ();
}


Find Method (pluginType, name)

Find Method (pluginType, name)
Namespaces ► StructureMap.Diagnostics ► ErrorCollection ► Find(Type, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.ErrorCollection.Find(System.Type,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public BuildError Find(
    Type pluginType,
    string name
)
Public Function Find ( _
    pluginType As Type, _
    name As String _
) As BuildError
public:
BuildError^ Find(
    Type^ pluginType,
    String^ name
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Diagnostics.ErrorCollection.Find(System.Type,System.String)"]

name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Diagnostics.ErrorCollection.Find(System.Type,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.ErrorCollection.Find(System.Type,System.String)]


ForEach Method (action)

ForEach Method (action)
Namespaces ► StructureMap.Diagnostics ► ErrorCollection ► ForEach(Action<(Of <(BuildError>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.ErrorCollection.ForEach(System.Action{StructureMap.Diagnostics.BuildError})]

Declaration Syntax
C# Visual Basic Visual C++
public void ForEach(
    Action<BuildError> action
)
Public Sub ForEach ( _
    action As Action(Of BuildError) _
)
public:
void ForEach(
    Action<BuildError^>^ action
)
Parameters
action (Action <(Of <( BuildError >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Diagnostics.ErrorCollection.ForEach(System.Action{StructureMap.Diagnostics.BuildError})"]


LogError Method (instance, pluginType, ex, dependencies)

LogError Method (instance, pluginType, ex, dependencies)
Namespaces ► StructureMap.Diagnostics ► ErrorCollection ► LogError(Instance, Type, StructureMapException, IEnumerable<(Of <(BuildDependency>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.ErrorCollection.LogError(StructureMap.Pipeline.Instance,System.Type,StructureMap.StructureMapException,System.Collections.Generic.IEnumerable{StructureMap.Diagnostics.BuildDependency})]

Declaration Syntax
C# Visual Basic Visual C++
public void LogError(
    Instance instance,
    Type pluginType,
    StructureMapException ex,
    IEnumerable<BuildDependency> dependencies
)
Public Sub LogError ( _
    instance As Instance, _
    pluginType As Type, _
    ex As StructureMapException, _
    dependencies As IEnumerable(Of BuildDependency) _
)
public:
void LogError(
    Instance^ instance,
    Type^ pluginType,
    StructureMapException^ ex,
    IEnumerable<BuildDependency^>^ dependencies
)
Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Diagnostics.ErrorCollection.LogError(StructureMap.Pipeline.Instance,System.Type,StructureMap.StructureMapException,System.Collections.Generic.IEnumerable{StructureMap.Diagnostics.BuildDependency})"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Diagnostics.ErrorCollection.LogError(StructureMap.Pipeline.Instance,System.Type,StructureMap.StructureMapException,System.Collections.Generic.IEnumerable{StructureMap.Diagnostics.BuildDependency})"]

ex (StructureMapException)

[Missing <param name="ex"/> documentation for "M:StructureMap.Diagnostics.ErrorCollection.LogError(StructureMap.Pipeline.Instance,System.Type,StructureMap.StructureMapException,System.Collections.Generic.IEnumerable{StructureMap.Diagnostics.BuildDependency})"]

dependencies (IEnumerable <(Of <( BuildDependency >)>))

[Missing <param name="dependencies"/> documentation for "M:StructureMap.Diagnostics.ErrorCollection.LogError(StructureMap.Pipeline.Instance,System.Type,StructureMap.StructureMapException,System.Collections.Generic.IEnumerable{StructureMap.Diagnostics.BuildDependency})"]


GraphLog Class

GraphLog Class
Namespaces ► StructureMap.Diagnostics ► GraphLog
StructureMap API

[Missing <summary> documentation for T:StructureMap.Diagnostics.GraphLog]

Declaration Syntax
C# Visual Basic Visual C++
public class GraphLog
Public Class GraphLog
public ref class GraphLog
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GraphLog()()() | Initializes a new instance of the GraphLog class
 | AssertFailures()()() |
 | AssertHasError(Int32, String) |
 | AssertHasError(Int32) |
 | AssertHasNoError(Int32) |
 | BuildFailureMessage()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | ErrorCount |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterError(IDiagnosticInstance, Int32, array<Object>[]()[]) |
 | RegisterError(Int32, array<Object>[]()[]) |
 | RegisterError(Int32, Exception, array<Object>[]()[]) |
 | RegisterError(StructureMapException) |
 | Sources |
 | StartSource(String) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Try(Action) |
 | WithType(TypePath, String, Action<(Of <(Type>)>)) |
Inheritance Hierarchy
Object
GraphLog


GraphLog Constructor

GraphLog Constructor
Namespaces ► StructureMap.Diagnostics ► GraphLog ► GraphLog()()()
StructureMap API
Initializes a new instance of the GraphLog class
Declaration Syntax
C# Visual Basic Visual C++
public GraphLog()
Public Sub New
public:
GraphLog()


AssertFailures Method

AssertFailures Method
Namespaces ► StructureMap.Diagnostics ► GraphLog ► AssertFailures()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.GraphLog.AssertFailures]

Declaration Syntax
C# Visual Basic Visual C++
public void AssertFailures()
Public Sub AssertFailures
public:
void AssertFailures()


AssertHasError Method

AssertHasError Method
Namespaces ► StructureMap.Diagnostics ► GraphLog ► AssertHasError()()()
StructureMap API
Members
Icon | Member | Description
 | AssertHasError(Int32, String) |
 | AssertHasError(Int32) |


AssertHasError Method (errorCode)

AssertHasError Method (errorCode)
Namespaces ► StructureMap.Diagnostics ► GraphLog ► AssertHasError(Int32)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.GraphLog.AssertHasError(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public void AssertHasError(
    int errorCode
)
Public Sub AssertHasError ( _
    errorCode As Integer _
)
public:
void AssertHasError(
    int errorCode
)
Parameters
errorCode (Int32)

[Missing <param name="errorCode"/> documentation for "M:StructureMap.Diagnostics.GraphLog.AssertHasError(System.Int32)"]


AssertHasError Method (errorCode, message)

AssertHasError Method (errorCode, message)
Namespaces ► StructureMap.Diagnostics ► GraphLog ► AssertHasError(Int32, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.GraphLog.AssertHasError(System.Int32,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void AssertHasError(
    int errorCode,
    string message
)
Public Sub AssertHasError ( _
    errorCode As Integer, _
    message As String _
)
public:
void AssertHasError(
    int errorCode,
    String^ message
)
Parameters
errorCode (Int32)

[Missing <param name="errorCode"/> documentation for "M:StructureMap.Diagnostics.GraphLog.AssertHasError(System.Int32,System.String)"]

message (String)

[Missing <param name="message"/> documentation for "M:StructureMap.Diagnostics.GraphLog.AssertHasError(System.Int32,System.String)"]


AssertHasNoError Method (errorCode)

AssertHasNoError Method (errorCode)
Namespaces ► StructureMap.Diagnostics ► GraphLog ► AssertHasNoError(Int32)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.GraphLog.AssertHasNoError(System.Int32)]

Declaration Syntax
C# Visual Basic Visual C++
public void AssertHasNoError(
    int errorCode
)
Public Sub AssertHasNoError ( _
    errorCode As Integer _
)
public:
void AssertHasNoError(
    int errorCode
)
Parameters
errorCode (Int32)

[Missing <param name="errorCode"/> documentation for "M:StructureMap.Diagnostics.GraphLog.AssertHasNoError(System.Int32)"]


BuildFailureMessage Method

BuildFailureMessage Method
Namespaces ► StructureMap.Diagnostics ► GraphLog ► BuildFailureMessage()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.GraphLog.BuildFailureMessage]

Declaration Syntax
C# Visual Basic Visual C++
public string BuildFailureMessage()
Public Function BuildFailureMessage As String
public:
String^ BuildFailureMessage()
Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.GraphLog.BuildFailureMessage]


ErrorCount Property

ErrorCount Property
Namespaces ► StructureMap.Diagnostics ► GraphLog ► ErrorCount
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.GraphLog.ErrorCount]

Declaration Syntax
C# Visual Basic Visual C++
public int ErrorCount { get; }
Public ReadOnly Property ErrorCount As Integer
public:
property int ErrorCount {
    int get ();
}


RegisterError Method

RegisterError Method
Namespaces ► StructureMap.Diagnostics ► GraphLog ► RegisterError()()()
StructureMap API
Members
Icon | Member | Description
 | RegisterError(IDiagnosticInstance, Int32, array<Object>[]()[]) |
 | RegisterError(Int32, array<Object>[]()[]) |
 | RegisterError(Int32, Exception, array<Object>[]()[]) |
 | RegisterError(StructureMapException) |


RegisterError Method (instance, code, args)

RegisterError Method (instance, code, args)
Namespaces ► StructureMap.Diagnostics ► GraphLog ► RegisterError(IDiagnosticInstance, Int32, array<Object>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.GraphLog.RegisterError(StructureMap.Pipeline.IDiagnosticInstance,System.Int32,System.Object[])]

Declaration Syntax
C# Visual Basic Visual C++
public void RegisterError(
    IDiagnosticInstance instance,
    int code,
    params Object[] args
)
Public Sub RegisterError ( _
    instance As IDiagnosticInstance, _
    code As Integer, _
    ParamArray args As Object() _
)
public:
void RegisterError(
    IDiagnosticInstance^ instance,
    int code,
    ... array<Object^>^ args
)
Parameters
instance (IDiagnosticInstance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Diagnostics.GraphLog.RegisterError(StructureMap.Pipeline.IDiagnosticInstance,System.Int32,System.Object[])"]

code (Int32)

[Missing <param name="code"/> documentation for "M:StructureMap.Diagnostics.GraphLog.RegisterError(StructureMap.Pipeline.IDiagnosticInstance,System.Int32,System.Object[])"]

args (array< Object >[]()[])

[Missing <param name="args"/> documentation for "M:StructureMap.Diagnostics.GraphLog.RegisterError(StructureMap.Pipeline.IDiagnosticInstance,System.Int32,System.Object[])"]


RegisterError Method (ex)

RegisterError Method (ex)
Namespaces ► StructureMap.Diagnostics ► GraphLog ► RegisterError(StructureMapException)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.GraphLog.RegisterError(StructureMap.StructureMapException)]

Declaration Syntax
C# Visual Basic Visual C++
public void RegisterError(
    StructureMapException ex
)
Public Sub RegisterError ( _
    ex As StructureMapException _
)
public:
void RegisterError(
    StructureMapException^ ex
)
Parameters
ex (StructureMapException)

[Missing <param name="ex"/> documentation for "M:StructureMap.Diagnostics.GraphLog.RegisterError(StructureMap.StructureMapException)"]


RegisterError Method (code, ex, args)

RegisterError Method (code, ex, args)
Namespaces ► StructureMap.Diagnostics ► GraphLog ► RegisterError(Int32, Exception, array<Object>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.GraphLog.RegisterError(System.Int32,System.Exception,System.Object[])]

Declaration Syntax
C# Visual Basic Visual C++
public void RegisterError(
    int code,
    Exception ex,
    params Object[] args
)
Public Sub RegisterError ( _
    code As Integer, _
    ex As Exception, _
    ParamArray args As Object() _
)
public:
void RegisterError(
    int code,
    Exception^ ex,
    ... array<Object^>^ args
)
Parameters
code (Int32)

[Missing <param name="code"/> documentation for "M:StructureMap.Diagnostics.GraphLog.RegisterError(System.Int32,System.Exception,System.Object[])"]

ex (Exception)

[Missing <param name="ex"/> documentation for "M:StructureMap.Diagnostics.GraphLog.RegisterError(System.Int32,System.Exception,System.Object[])"]

args (array< Object >[]()[])

[Missing <param name="args"/> documentation for "M:StructureMap.Diagnostics.GraphLog.RegisterError(System.Int32,System.Exception,System.Object[])"]


RegisterError Method (code, args)

RegisterError Method (code, args)
Namespaces ► StructureMap.Diagnostics ► GraphLog ► RegisterError(Int32, array<Object>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.GraphLog.RegisterError(System.Int32,System.Object[])]

Declaration Syntax
C# Visual Basic Visual C++
public void RegisterError(
    int code,
    params Object[] args
)
Public Sub RegisterError ( _
    code As Integer, _
    ParamArray args As Object() _
)
public:
void RegisterError(
    int code,
    ... array<Object^>^ args
)
Parameters
code (Int32)

[Missing <param name="code"/> documentation for "M:StructureMap.Diagnostics.GraphLog.RegisterError(System.Int32,System.Object[])"]

args (array< Object >[]()[])

[Missing <param name="args"/> documentation for "M:StructureMap.Diagnostics.GraphLog.RegisterError(System.Int32,System.Object[])"]


Sources Property

Sources Property
Namespaces ► StructureMap.Diagnostics ► GraphLog ► Sources
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.GraphLog.Sources]

Declaration Syntax
C# Visual Basic Visual C++
public string[] Sources { get; }
Public ReadOnly Property Sources As String()
public:
property array<String^>^ Sources {
    array<String^>^ get ();
}


StartSource Method (description)

StartSource Method (description)
Namespaces ► StructureMap.Diagnostics ► GraphLog ► StartSource(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.GraphLog.StartSource(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void StartSource(
    string description
)
Public Sub StartSource ( _
    description As String _
)
public:
void StartSource(
    String^ description
)
Parameters
description (String)

[Missing <param name="description"/> documentation for "M:StructureMap.Diagnostics.GraphLog.StartSource(System.String)"]


Try Method (action)

Try Method (action)
Namespaces ► StructureMap.Diagnostics ► GraphLog ► Try(Action)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.GraphLog.Try(System.Action)]

Declaration Syntax
C# Visual Basic Visual C++
public GraphLog..::.TryAction Try(
    Action action
)
Public Function Try ( _
    action As Action _
) As GraphLog..::.TryAction
public:
GraphLog..::.TryAction^ Try(
    Action^ action
)
Parameters
action (Action)

[Missing <param name="action"/> documentation for "M:StructureMap.Diagnostics.GraphLog.Try(System.Action)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.GraphLog.Try(System.Action)]


WithType Method (path, context, action)

WithType Method (path, context, action)
Namespaces ► StructureMap.Diagnostics ► GraphLog ► WithType(TypePath, String, Action<(Of <(Type>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.GraphLog.WithType(StructureMap.Graph.TypePath,System.String,System.Action{System.Type})]

Declaration Syntax
C# Visual Basic Visual C++
public void WithType(
    TypePath path,
    string context,
    Action<Type> action
)
Public Sub WithType ( _
    path As TypePath, _
    context As String, _
    action As Action(Of Type) _
)
public:
void WithType(
    TypePath^ path,
    String^ context,
    Action<Type^>^ action
)
Parameters
path (TypePath)

[Missing <param name="path"/> documentation for "M:StructureMap.Diagnostics.GraphLog.WithType(StructureMap.Graph.TypePath,System.String,System.Action{System.Type})"]

context (String)

[Missing <param name="context"/> documentation for "M:StructureMap.Diagnostics.GraphLog.WithType(StructureMap.Graph.TypePath,System.String,System.Action{System.Type})"]

action (Action <(Of <( Type >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Diagnostics.GraphLog.WithType(StructureMap.Graph.TypePath,System.String,System.Action{System.Type})"]


GraphLog.TryAction Class

GraphLog..::.TryAction Class
Namespaces ► StructureMap.Diagnostics ► GraphLog ► GraphLog..::.TryAction
StructureMap API

[Missing <summary> documentation for T:StructureMap.Diagnostics.GraphLog.TryAction]

Declaration Syntax
C# Visual Basic Visual C++
public class TryAction
Public Class TryAction
public ref class TryAction
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AndLogAnyErrors()()() |
 | AndReportErrorAs(Int32, array<Object>[]()[]) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GraphLog..::.TryAction


AndLogAnyErrors Method

AndLogAnyErrors Method
Namespaces ► StructureMap.Diagnostics ► GraphLog..::.TryAction ► AndLogAnyErrors()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.GraphLog.TryAction.AndLogAnyErrors]

Declaration Syntax
C# Visual Basic Visual C++
public void AndLogAnyErrors()
Public Sub AndLogAnyErrors
public:
void AndLogAnyErrors()


AndReportErrorAs Method (code, args)

AndReportErrorAs Method (code, args)
Namespaces ► StructureMap.Diagnostics ► GraphLog..::.TryAction ► AndReportErrorAs(Int32, array<Object>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.GraphLog.TryAction.AndReportErrorAs(System.Int32,System.Object[])]

Declaration Syntax
C# Visual Basic Visual C++
public void AndReportErrorAs(
    int code,
    params Object[] args
)
Public Sub AndReportErrorAs ( _
    code As Integer, _
    ParamArray args As Object() _
)
public:
void AndReportErrorAs(
    int code,
    ... array<Object^>^ args
)
Parameters
code (Int32)

[Missing <param name="code"/> documentation for "M:StructureMap.Diagnostics.GraphLog.TryAction.AndReportErrorAs(System.Int32,System.Object[])"]

args (array< Object >[]()[])

[Missing <param name="args"/> documentation for "M:StructureMap.Diagnostics.GraphLog.TryAction.AndReportErrorAs(System.Int32,System.Object[])"]


InstanceToken Class

InstanceToken Class
Namespaces ► StructureMap.Diagnostics ► InstanceToken
StructureMap API

[Missing <summary> documentation for T:StructureMap.Diagnostics.InstanceToken]

Declaration Syntax
C# Visual Basic Visual C++
public class InstanceToken : IEquatable<InstanceToken>
Public Class InstanceToken _
    Implements IEquatable(Of InstanceToken)
public ref class InstanceToken : IEquatable<InstanceToken^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstanceToken(String, String) | Initializes a new instance of the InstanceToken class
 | Description |
 | Equals(InstanceToken) |
 | Equals(Object) | (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | ToString()()() | (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
InstanceToken


InstanceToken Constructor (name, description)

InstanceToken Constructor (name, description)
Namespaces ► StructureMap.Diagnostics ► InstanceToken ► InstanceToken(String, String)
StructureMap API
Initializes a new instance of the InstanceToken class
Declaration Syntax
C# Visual Basic Visual C++
public InstanceToken(
    string name,
    string description
)
Public Sub New ( _
    name As String, _
    description As String _
)
public:
InstanceToken(
    String^ name,
    String^ description
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Diagnostics.InstanceToken.#ctor(System.String,System.String)"]

description (String)

[Missing <param name="description"/> documentation for "M:StructureMap.Diagnostics.InstanceToken.#ctor(System.String,System.String)"]


Description Property

Description Property
Namespaces ► StructureMap.Diagnostics ► InstanceToken ► Description
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.InstanceToken.Description]

Declaration Syntax
C# Visual Basic Visual C++
public string Description { get; }
Public ReadOnly Property Description As String
public:
property String^ Description {
    String^ get ();
}


Equals Method

Equals Method
Namespaces ► StructureMap.Diagnostics ► InstanceToken ► Equals()()()
StructureMap API
Members
Icon | Member | Description
 | Equals(InstanceToken) |
 | Equals(Object) | (Overrides Object.Equals(Object).)


Equals Method (instanceToken)

Equals Method (instanceToken)
Namespaces ► StructureMap.Diagnostics ► InstanceToken ► Equals(InstanceToken)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.InstanceToken.Equals(StructureMap.Diagnostics.InstanceToken)]

Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    InstanceToken instanceToken
)
Public Function Equals ( _
    instanceToken As InstanceToken _
) As Boolean
public:
virtual bool Equals(
    InstanceToken^ instanceToken
) sealed
Parameters
instanceToken (InstanceToken)

[Missing <param name="instanceToken"/> documentation for "M:StructureMap.Diagnostics.InstanceToken.Equals(StructureMap.Diagnostics.InstanceToken)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.InstanceToken.Equals(StructureMap.Diagnostics.InstanceToken)]


Equals Method (obj)

Equals Method (obj)
Namespaces ► StructureMap.Diagnostics ► InstanceToken ► Equals(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.InstanceToken.Equals(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:StructureMap.Diagnostics.InstanceToken.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.InstanceToken.Equals(System.Object)]


GetHashCode Method

GetHashCode Method
Namespaces ► StructureMap.Diagnostics ► InstanceToken ► GetHashCode()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.InstanceToken.GetHashCode]

Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.InstanceToken.GetHashCode]


Name Property

Name Property
Namespaces ► StructureMap.Diagnostics ► InstanceToken ► Name
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.InstanceToken.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}


ToString Method

ToString Method
Namespaces ► StructureMap.Diagnostics ► InstanceToken ► ToString()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.InstanceToken.ToString]

Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.InstanceToken.ToString]


TextReportWriter Class

TextReportWriter Class
Namespaces ► StructureMap.Diagnostics ► TextReportWriter
StructureMap API

[Missing <summary> documentation for T:StructureMap.Diagnostics.TextReportWriter]

Declaration Syntax
C# Visual Basic Visual C++
public class TextReportWriter
Public Class TextReportWriter
public ref class TextReportWriter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TextReportWriter(Int32) | Initializes a new instance of the TextReportWriter class
 | AddContent(String) |
 | AddDivider(Char) |
 | AddText(array<String>[]()[]) |
 | DumpToConsole()()() |
 | DumpToDebug()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Write(StringWriter) |
 | Write()()() |
Inheritance Hierarchy
Object
TextReportWriter


TextReportWriter Constructor (columnCount)

TextReportWriter Constructor (columnCount)
Namespaces ► StructureMap.Diagnostics ► TextReportWriter ► TextReportWriter(Int32)
StructureMap API
Initializes a new instance of the TextReportWriter class
Declaration Syntax
C# Visual Basic Visual C++
public TextReportWriter(
    int columnCount
)
Public Sub New ( _
    columnCount As Integer _
)
public:
TextReportWriter(
    int columnCount
)
Parameters
columnCount (Int32)

[Missing <param name="columnCount"/> documentation for "M:StructureMap.Diagnostics.TextReportWriter.#ctor(System.Int32)"]


AddContent Method (contents)

AddContent Method (contents)
Namespaces ► StructureMap.Diagnostics ► TextReportWriter ► AddContent(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.TextReportWriter.AddContent(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddContent(
    string contents
)
Public Sub AddContent ( _
    contents As String _
)
public:
void AddContent(
    String^ contents
)
Parameters
contents (String)

[Missing <param name="contents"/> documentation for "M:StructureMap.Diagnostics.TextReportWriter.AddContent(System.String)"]


AddDivider Method (character)

AddDivider Method (character)
Namespaces ► StructureMap.Diagnostics ► TextReportWriter ► AddDivider(Char)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.TextReportWriter.AddDivider(System.Char)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddDivider(
    char character
)
Public Sub AddDivider ( _
    character As Char _
)
public:
void AddDivider(
    wchar_t character
)
Parameters
character (Char)

[Missing <param name="character"/> documentation for "M:StructureMap.Diagnostics.TextReportWriter.AddDivider(System.Char)"]


AddText Method (contents)

AddText Method (contents)
Namespaces ► StructureMap.Diagnostics ► TextReportWriter ► AddText(array<String>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.TextReportWriter.AddText(System.String[])]

Declaration Syntax
C# Visual Basic Visual C++
public void AddText(
    params string[] contents
)
Public Sub AddText ( _
    ParamArray contents As String() _
)
public:
void AddText(
    ... array<String^>^ contents
)
Parameters
contents (array< String >[]()[])

[Missing <param name="contents"/> documentation for "M:StructureMap.Diagnostics.TextReportWriter.AddText(System.String[])"]


DumpToConsole Method

DumpToConsole Method
Namespaces ► StructureMap.Diagnostics ► TextReportWriter ► DumpToConsole()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.TextReportWriter.DumpToConsole]

Declaration Syntax
C# Visual Basic Visual C++
public void DumpToConsole()
Public Sub DumpToConsole
public:
void DumpToConsole()


DumpToDebug Method

DumpToDebug Method
Namespaces ► StructureMap.Diagnostics ► TextReportWriter ► DumpToDebug()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.TextReportWriter.DumpToDebug]

Declaration Syntax
C# Visual Basic Visual C++
public void DumpToDebug()
Public Sub DumpToDebug
public:
void DumpToDebug()


Write Method

Write Method
Namespaces ► StructureMap.Diagnostics ► TextReportWriter ► Write()()()
StructureMap API
Members
Icon | Member | Description
 | Write(StringWriter) |
 | Write()()() |


Write Method

Write Method
Namespaces ► StructureMap.Diagnostics ► TextReportWriter ► Write()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.TextReportWriter.Write]

Declaration Syntax
C# Visual Basic Visual C++
public string Write()
Public Function Write As String
public:
String^ Write()
Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.TextReportWriter.Write]


Write Method (writer)

Write Method (writer)
Namespaces ► StructureMap.Diagnostics ► TextReportWriter ► Write(StringWriter)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.TextReportWriter.Write(System.IO.StringWriter)]

Declaration Syntax
C# Visual Basic Visual C++
public void Write(
    StringWriter writer
)
Public Sub Write ( _
    writer As StringWriter _
)
public:
void Write(
    StringWriter^ writer
)
Parameters
writer (StringWriter)

[Missing <param name="writer"/> documentation for "M:StructureMap.Diagnostics.TextReportWriter.Write(System.IO.StringWriter)"]


ValidationBuildSession Class

ValidationBuildSession Class
Namespaces ► StructureMap.Diagnostics ► ValidationBuildSession
StructureMap API

[Missing <summary> documentation for T:StructureMap.Diagnostics.ValidationBuildSession]

Declaration Syntax
C# Visual Basic Visual C++
public class ValidationBuildSession : BuildSession
Public Class ValidationBuildSession _
    Inherits BuildSession
public ref class ValidationBuildSession : public BuildSession
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidationBuildSession(PipelineGraph, InterceptorLibrary) | Initializes a new instance of the ValidationBuildSession class
 | ValidationBuildSession(PluginGraph) | Initializes a new instance of the ValidationBuildSession class
 | ApplyInterception(Type, Object) | (Inherited from BuildSession.)
 | BuildErrorMessages()()() |
 | BuildErrors |
 | BuildStack | (Inherited from BuildSession.)
 | CreateInstance(Type, Instance) | (Overrides BuildSession.CreateInstance(Type, Instance).)
 | CreateInstance(Type, String) | (Inherited from BuildSession.)
 | CreateInstance(Type) | (Inherited from BuildSession.)
 | CreateInstanceArray(Type, array<Instance>[]()[]) | (Inherited from BuildSession.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Type, String) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasBuildErrors()()() |
 | HasValidationErrors()()() |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ParentType | (Inherited from BuildSession.)
 | PerformValidations()()() |
 | pipelineGraph | (Inherited from BuildSession.)
 | RegisterDefault(Type, Object) | (Inherited from BuildSession.)
 | Success |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | ValidationErrors |
Inheritance Hierarchy
Object
 | BuildSession
 |  | ValidationBuildSession


ValidationBuildSession Constructor

ValidationBuildSession Constructor
Namespaces ► StructureMap.Diagnostics ► ValidationBuildSession ► ValidationBuildSession()()()
StructureMap API
Members
Icon | Member | Description
 | ValidationBuildSession(PipelineGraph, InterceptorLibrary) | Initializes a new instance of the ValidationBuildSession class
 | ValidationBuildSession(PluginGraph) | Initializes a new instance of the ValidationBuildSession class


ValidationBuildSession Constructor (graph)

ValidationBuildSession Constructor (graph)
Namespaces ► StructureMap.Diagnostics ► ValidationBuildSession ► ValidationBuildSession(PluginGraph)
StructureMap API
Initializes a new instance of the ValidationBuildSession class
Declaration Syntax
C# Visual Basic Visual C++
public ValidationBuildSession(
    PluginGraph graph
)
Public Sub New ( _
    graph As PluginGraph _
)
public:
ValidationBuildSession(
    PluginGraph^ graph
)
Parameters
graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.Diagnostics.ValidationBuildSession.#ctor(StructureMap.Graph.PluginGraph)"]


ValidationBuildSession Constructor (pipelineGraph, interceptorLibrary)

ValidationBuildSession Constructor (pipelineGraph, interceptorLibrary)
Namespaces ► StructureMap.Diagnostics ► ValidationBuildSession ► ValidationBuildSession(PipelineGraph, InterceptorLibrary)
StructureMap API
Initializes a new instance of the ValidationBuildSession class
Declaration Syntax
C# Visual Basic Visual C++
public ValidationBuildSession(
    PipelineGraph pipelineGraph,
    InterceptorLibrary interceptorLibrary
)
Public Sub New ( _
    pipelineGraph As PipelineGraph, _
    interceptorLibrary As InterceptorLibrary _
)
public:
ValidationBuildSession(
    PipelineGraph^ pipelineGraph,
    InterceptorLibrary^ interceptorLibrary
)
Parameters
pipelineGraph (PipelineGraph)

[Missing <param name="pipelineGraph"/> documentation for "M:StructureMap.Diagnostics.ValidationBuildSession.#ctor(StructureMap.PipelineGraph,StructureMap.Interceptors.InterceptorLibrary)"]

interceptorLibrary (InterceptorLibrary)

[Missing <param name="interceptorLibrary"/> documentation for "M:StructureMap.Diagnostics.ValidationBuildSession.#ctor(StructureMap.PipelineGraph,StructureMap.Interceptors.InterceptorLibrary)"]


BuildErrorMessages Method

BuildErrorMessages Method
Namespaces ► StructureMap.Diagnostics ► ValidationBuildSession ► BuildErrorMessages()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.ValidationBuildSession.BuildErrorMessages]

Declaration Syntax
C# Visual Basic Visual C++
public string BuildErrorMessages()
Public Function BuildErrorMessages As String
public:
String^ BuildErrorMessages()
Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.ValidationBuildSession.BuildErrorMessages]


BuildErrors Property

BuildErrors Property
Namespaces ► StructureMap.Diagnostics ► ValidationBuildSession ► BuildErrors
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.ValidationBuildSession.BuildErrors]

Declaration Syntax
C# Visual Basic Visual C++
public BuildError[] BuildErrors { get; }
Public ReadOnly Property BuildErrors As BuildError()
public:
property array<BuildError^>^ BuildErrors {
    array<BuildError^>^ get ();
}


CreateInstance Method (pluginType, instance)

CreateInstance Method (pluginType, instance)
Namespaces ► StructureMap.Diagnostics ► ValidationBuildSession ► CreateInstance(Type, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.ValidationBuildSession.CreateInstance(System.Type,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public override Object CreateInstance(
    Type pluginType,
    Instance instance
)
Public Overrides Function CreateInstance ( _
    pluginType As Type, _
    instance As Instance _
) As Object
public:
virtual Object^ CreateInstance(
    Type^ pluginType,
    Instance^ instance
) override
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Diagnostics.ValidationBuildSession.CreateInstance(System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Diagnostics.ValidationBuildSession.CreateInstance(System.Type,StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.ValidationBuildSession.CreateInstance(System.Type,StructureMap.Pipeline.Instance)]


Find Method (pluginType, name)

Find Method (pluginType, name)
Namespaces ► StructureMap.Diagnostics ► ValidationBuildSession ► Find(Type, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.ValidationBuildSession.Find(System.Type,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public BuildError Find(
    Type pluginType,
    string name
)
Public Function Find ( _
    pluginType As Type, _
    name As String _
) As BuildError
public:
BuildError^ Find(
    Type^ pluginType,
    String^ name
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Diagnostics.ValidationBuildSession.Find(System.Type,System.String)"]

name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Diagnostics.ValidationBuildSession.Find(System.Type,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.ValidationBuildSession.Find(System.Type,System.String)]


HasBuildErrors Method

HasBuildErrors Method
Namespaces ► StructureMap.Diagnostics ► ValidationBuildSession ► HasBuildErrors()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.ValidationBuildSession.HasBuildErrors]

Declaration Syntax
C# Visual Basic Visual C++
public bool HasBuildErrors()
Public Function HasBuildErrors As Boolean
public:
bool HasBuildErrors()
Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.ValidationBuildSession.HasBuildErrors]


HasValidationErrors Method

HasValidationErrors Method
Namespaces ► StructureMap.Diagnostics ► ValidationBuildSession ► HasValidationErrors()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.ValidationBuildSession.HasValidationErrors]

Declaration Syntax
C# Visual Basic Visual C++
public bool HasValidationErrors()
Public Function HasValidationErrors As Boolean
public:
bool HasValidationErrors()
Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.ValidationBuildSession.HasValidationErrors]


PerformValidations Method

PerformValidations Method
Namespaces ► StructureMap.Diagnostics ► ValidationBuildSession ► PerformValidations()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.ValidationBuildSession.PerformValidations]

Declaration Syntax
C# Visual Basic Visual C++
public void PerformValidations()
Public Sub PerformValidations
public:
void PerformValidations()


Success Property

Success Property
Namespaces ► StructureMap.Diagnostics ► ValidationBuildSession ► Success
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.ValidationBuildSession.Success]

Declaration Syntax
C# Visual Basic Visual C++
public bool Success { get; }
Public ReadOnly Property Success As Boolean
public:
property bool Success {
    bool get ();
}


ValidationErrors Property

ValidationErrors Property
Namespaces ► StructureMap.Diagnostics ► ValidationBuildSession ► ValidationErrors
StructureMap API

[Missing <summary> documentation for P:StructureMap.Diagnostics.ValidationBuildSession.ValidationErrors]

Declaration Syntax
C# Visual Basic Visual C++
public ValidationError[] ValidationErrors { get; }
Public ReadOnly Property ValidationErrors As ValidationError()
public:
property array<ValidationError^>^ ValidationErrors {
    array<ValidationError^>^ get ();
}


ValidationError Class

ValidationError Class
Namespaces ► StructureMap.Diagnostics ► ValidationError
StructureMap API

[Missing <summary> documentation for T:StructureMap.Diagnostics.ValidationError]

Declaration Syntax
C# Visual Basic Visual C++
public class ValidationError
Public Class ValidationError
public ref class ValidationError
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ValidationError(Type, Instance, Exception, MethodInfo) | Initializes a new instance of the ValidationError class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exception |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Instance |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MethodName |
 | PluginType |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Write(StringWriter) |
Inheritance Hierarchy
Object
ValidationError


ValidationError Constructor (pluginType, instance, exception, method)

ValidationError Constructor (pluginType, instance, exception, method)
Namespaces ► StructureMap.Diagnostics ► ValidationError ► ValidationError(Type, Instance, Exception, MethodInfo)
StructureMap API
Initializes a new instance of the ValidationError class
Declaration Syntax
C# Visual Basic Visual C++
public ValidationError(
    Type pluginType,
    Instance instance,
    Exception exception,
    MethodInfo method
)
Public Sub New ( _
    pluginType As Type, _
    instance As Instance, _
    exception As Exception, _
    method As MethodInfo _
)
public:
ValidationError(
    Type^ pluginType,
    Instance^ instance,
    Exception^ exception,
    MethodInfo^ method
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Diagnostics.ValidationError.#ctor(System.Type,StructureMap.Pipeline.Instance,System.Exception,System.Reflection.MethodInfo)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Diagnostics.ValidationError.#ctor(System.Type,StructureMap.Pipeline.Instance,System.Exception,System.Reflection.MethodInfo)"]

exception (Exception)

[Missing <param name="exception"/> documentation for "M:StructureMap.Diagnostics.ValidationError.#ctor(System.Type,StructureMap.Pipeline.Instance,System.Exception,System.Reflection.MethodInfo)"]

method (MethodInfo)

[Missing <param name="method"/> documentation for "M:StructureMap.Diagnostics.ValidationError.#ctor(System.Type,StructureMap.Pipeline.Instance,System.Exception,System.Reflection.MethodInfo)"]


Exception Field

Exception Field
Namespaces ► StructureMap.Diagnostics ► ValidationError ► Exception
StructureMap API

[Missing <summary> documentation for F:StructureMap.Diagnostics.ValidationError.Exception]

Declaration Syntax
C# Visual Basic Visual C++
public Exception Exception
Public Exception As Exception
public:
Exception^ Exception


Instance Field

Instance Field
Namespaces ► StructureMap.Diagnostics ► ValidationError ► Instance
StructureMap API

[Missing <summary> documentation for F:StructureMap.Diagnostics.ValidationError.Instance]

Declaration Syntax
C# Visual Basic Visual C++
public Instance Instance
Public Instance As Instance
public:
Instance^ Instance


MethodName Field

MethodName Field
Namespaces ► StructureMap.Diagnostics ► ValidationError ► MethodName
StructureMap API

[Missing <summary> documentation for F:StructureMap.Diagnostics.ValidationError.MethodName]

Declaration Syntax
C# Visual Basic Visual C++
public string MethodName
Public MethodName As String
public:
String^ MethodName


PluginType Field

PluginType Field
Namespaces ► StructureMap.Diagnostics ► ValidationError ► PluginType
StructureMap API

[Missing <summary> documentation for F:StructureMap.Diagnostics.ValidationError.PluginType]

Declaration Syntax
C# Visual Basic Visual C++
public Type PluginType
Public PluginType As Type
public:
Type^ PluginType


Write Method (writer)

Write Method (writer)
Namespaces ► StructureMap.Diagnostics ► ValidationError ► Write(StringWriter)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.ValidationError.Write(System.IO.StringWriter)]

Declaration Syntax
C# Visual Basic Visual C++
public void Write(
    StringWriter writer
)
Public Sub Write ( _
    writer As StringWriter _
)
public:
void Write(
    StringWriter^ writer
)
Parameters
writer (StringWriter)

[Missing <param name="writer"/> documentation for "M:StructureMap.Diagnostics.ValidationError.Write(System.IO.StringWriter)"]


WhatDoIHaveWriter Class

WhatDoIHaveWriter Class
Namespaces ► StructureMap.Diagnostics ► WhatDoIHaveWriter
StructureMap API

[Missing <summary> documentation for T:StructureMap.Diagnostics.WhatDoIHaveWriter]

Declaration Syntax
C# Visual Basic Visual C++
public class WhatDoIHaveWriter
Public Class WhatDoIHaveWriter
public ref class WhatDoIHaveWriter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | WhatDoIHaveWriter(PipelineGraph) | Initializes a new instance of the WhatDoIHaveWriter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetText()()() |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
WhatDoIHaveWriter


WhatDoIHaveWriter Constructor (graph)

WhatDoIHaveWriter Constructor (graph)
Namespaces ► StructureMap.Diagnostics ► WhatDoIHaveWriter ► WhatDoIHaveWriter(PipelineGraph)
StructureMap API
Initializes a new instance of the WhatDoIHaveWriter class
Declaration Syntax
C# Visual Basic Visual C++
public WhatDoIHaveWriter(
    PipelineGraph graph
)
Public Sub New ( _
    graph As PipelineGraph _
)
public:
WhatDoIHaveWriter(
    PipelineGraph^ graph
)
Parameters
graph (PipelineGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.Diagnostics.WhatDoIHaveWriter.#ctor(StructureMap.PipelineGraph)"]


GetText Method

GetText Method
Namespaces ► StructureMap.Diagnostics ► WhatDoIHaveWriter ► GetText()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Diagnostics.WhatDoIHaveWriter.GetText]

Declaration Syntax
C# Visual Basic Visual C++
public string GetText()
Public Function GetText As String
public:
String^ GetText()
Return Value

[Missing <returns> documentation for M:StructureMap.Diagnostics.WhatDoIHaveWriter.GetText]


StructureMap.Emitting Namespace

StructureMap.Emitting Namespace
Namespaces ► StructureMap.Emitting
StructureMap API

[Missing <summary> documentation for N:StructureMap.Emitting]

Declaration Syntax
C# Visual Basic Visual C++
namespace StructureMap.Emitting
Namespace StructureMap.Emitting
namespace StructureMap.Emitting
Types
All Types Classes
Icon | Type | Description
 | ArgumentEmitter |
 | BuildInstanceMethod | Emits the IL for the InstanceBuilder.BuildInstance(InstanceMemento) method of an InstanceBuilder
 | ClassBuilder | Emits the IL for a new class Type
 | DynamicAssembly | Helper class to use to create a dynamically emitted assembly
 | InstanceBuilderAssembly | Manages the IL emitting of a dynamic assembly of InstanceBuilder classes
 | Method | Emits the IL for one method


ArgumentEmitter Class

ArgumentEmitter Class
Namespaces ► StructureMap.Emitting ► ArgumentEmitter
StructureMap API

[Missing <summary> documentation for T:StructureMap.Emitting.ArgumentEmitter]

Declaration Syntax
C# Visual Basic Visual C++
public class ArgumentEmitter : IArgumentVisitor
Public Class ArgumentEmitter _
    Implements IArgumentVisitor
public ref class ArgumentEmitter : IArgumentVisitor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ArgumentEmitter(ILGenerator) | Initializes a new instance of the ArgumentEmitter class
 | ChildArrayParameter(ParameterInfo) |
 | ChildArraySetter(PropertyInfo, Boolean) |
 | ChildParameter(ParameterInfo) |
 | ChildSetter(PropertyInfo, Boolean) |
 | EnumParameter(ParameterInfo) |
 | EnumSetter(PropertyInfo, Boolean) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrimitiveParameter(ParameterInfo) |
 | PrimitiveSetter(PropertyInfo, Boolean) |
 | StringParameter(ParameterInfo) |
 | StringSetter(PropertyInfo, Boolean) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ArgumentEmitter


ArgumentEmitter Constructor (ilgen)

ArgumentEmitter Constructor (ilgen)
Namespaces ► StructureMap.Emitting ► ArgumentEmitter ► ArgumentEmitter(ILGenerator)
StructureMap API
Initializes a new instance of the ArgumentEmitter class
Declaration Syntax
C# Visual Basic Visual C++
public ArgumentEmitter(
    ILGenerator ilgen
)
Public Sub New ( _
    ilgen As ILGenerator _
)
public:
ArgumentEmitter(
    ILGenerator^ ilgen
)
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.#ctor(System.Reflection.Emit.ILGenerator)"]


ChildArrayParameter Method (parameter)

ChildArrayParameter Method (parameter)
Namespaces ► StructureMap.Emitting ► ArgumentEmitter ► ChildArrayParameter(ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.ArgumentEmitter.ChildArrayParameter(System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void ChildArrayParameter(
    ParameterInfo parameter
)
Public Sub ChildArrayParameter ( _
    parameter As ParameterInfo _
)
public:
virtual void ChildArrayParameter(
    ParameterInfo^ parameter
) sealed
Parameters
parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.ChildArrayParameter(System.Reflection.ParameterInfo)"]


ChildArraySetter Method (property, isMandatory)

ChildArraySetter Method (property, isMandatory)
Namespaces ► StructureMap.Emitting ► ArgumentEmitter ► ChildArraySetter(PropertyInfo, Boolean)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.ArgumentEmitter.ChildArraySetter(System.Reflection.PropertyInfo,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public void ChildArraySetter(
    PropertyInfo property,
    bool isMandatory
)
Public Sub ChildArraySetter ( _
    property As PropertyInfo, _
    isMandatory As Boolean _
)
public:
virtual void ChildArraySetter(
    PropertyInfo^ property,
    bool isMandatory
) sealed
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.ChildArraySetter(System.Reflection.PropertyInfo,System.Boolean)"]

isMandatory (Boolean)

[Missing <param name="isMandatory"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.ChildArraySetter(System.Reflection.PropertyInfo,System.Boolean)"]


ChildParameter Method (parameter)

ChildParameter Method (parameter)
Namespaces ► StructureMap.Emitting ► ArgumentEmitter ► ChildParameter(ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.ArgumentEmitter.ChildParameter(System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void ChildParameter(
    ParameterInfo parameter
)
Public Sub ChildParameter ( _
    parameter As ParameterInfo _
)
public:
virtual void ChildParameter(
    ParameterInfo^ parameter
) sealed
Parameters
parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.ChildParameter(System.Reflection.ParameterInfo)"]


ChildSetter Method (property, isMandatory)

ChildSetter Method (property, isMandatory)
Namespaces ► StructureMap.Emitting ► ArgumentEmitter ► ChildSetter(PropertyInfo, Boolean)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.ArgumentEmitter.ChildSetter(System.Reflection.PropertyInfo,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public void ChildSetter(
    PropertyInfo property,
    bool isMandatory
)
Public Sub ChildSetter ( _
    property As PropertyInfo, _
    isMandatory As Boolean _
)
public:
virtual void ChildSetter(
    PropertyInfo^ property,
    bool isMandatory
) sealed
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.ChildSetter(System.Reflection.PropertyInfo,System.Boolean)"]

isMandatory (Boolean)

[Missing <param name="isMandatory"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.ChildSetter(System.Reflection.PropertyInfo,System.Boolean)"]


EnumParameter Method (parameter)

EnumParameter Method (parameter)
Namespaces ► StructureMap.Emitting ► ArgumentEmitter ► EnumParameter(ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.ArgumentEmitter.EnumParameter(System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void EnumParameter(
    ParameterInfo parameter
)
Public Sub EnumParameter ( _
    parameter As ParameterInfo _
)
public:
virtual void EnumParameter(
    ParameterInfo^ parameter
) sealed
Parameters
parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.EnumParameter(System.Reflection.ParameterInfo)"]


EnumSetter Method (property, isMandatory)

EnumSetter Method (property, isMandatory)
Namespaces ► StructureMap.Emitting ► ArgumentEmitter ► EnumSetter(PropertyInfo, Boolean)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.ArgumentEmitter.EnumSetter(System.Reflection.PropertyInfo,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public void EnumSetter(
    PropertyInfo property,
    bool isMandatory
)
Public Sub EnumSetter ( _
    property As PropertyInfo, _
    isMandatory As Boolean _
)
public:
virtual void EnumSetter(
    PropertyInfo^ property,
    bool isMandatory
) sealed
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.EnumSetter(System.Reflection.PropertyInfo,System.Boolean)"]

isMandatory (Boolean)

[Missing <param name="isMandatory"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.EnumSetter(System.Reflection.PropertyInfo,System.Boolean)"]


PrimitiveParameter Method (parameter)

PrimitiveParameter Method (parameter)
Namespaces ► StructureMap.Emitting ► ArgumentEmitter ► PrimitiveParameter(ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.ArgumentEmitter.PrimitiveParameter(System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void PrimitiveParameter(
    ParameterInfo parameter
)
Public Sub PrimitiveParameter ( _
    parameter As ParameterInfo _
)
public:
virtual void PrimitiveParameter(
    ParameterInfo^ parameter
) sealed
Parameters
parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.PrimitiveParameter(System.Reflection.ParameterInfo)"]


PrimitiveSetter Method (property, isMandatory)

PrimitiveSetter Method (property, isMandatory)
Namespaces ► StructureMap.Emitting ► ArgumentEmitter ► PrimitiveSetter(PropertyInfo, Boolean)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.ArgumentEmitter.PrimitiveSetter(System.Reflection.PropertyInfo,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public void PrimitiveSetter(
    PropertyInfo property,
    bool isMandatory
)
Public Sub PrimitiveSetter ( _
    property As PropertyInfo, _
    isMandatory As Boolean _
)
public:
virtual void PrimitiveSetter(
    PropertyInfo^ property,
    bool isMandatory
) sealed
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.PrimitiveSetter(System.Reflection.PropertyInfo,System.Boolean)"]

isMandatory (Boolean)

[Missing <param name="isMandatory"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.PrimitiveSetter(System.Reflection.PropertyInfo,System.Boolean)"]


StringParameter Method (parameter)

StringParameter Method (parameter)
Namespaces ► StructureMap.Emitting ► ArgumentEmitter ► StringParameter(ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.ArgumentEmitter.StringParameter(System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void StringParameter(
    ParameterInfo parameter
)
Public Sub StringParameter ( _
    parameter As ParameterInfo _
)
public:
virtual void StringParameter(
    ParameterInfo^ parameter
) sealed
Parameters
parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.StringParameter(System.Reflection.ParameterInfo)"]


StringSetter Method (property, isMandatory)

StringSetter Method (property, isMandatory)
Namespaces ► StructureMap.Emitting ► ArgumentEmitter ► StringSetter(PropertyInfo, Boolean)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.ArgumentEmitter.StringSetter(System.Reflection.PropertyInfo,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public void StringSetter(
    PropertyInfo property,
    bool isMandatory
)
Public Sub StringSetter ( _
    property As PropertyInfo, _
    isMandatory As Boolean _
)
public:
virtual void StringSetter(
    PropertyInfo^ property,
    bool isMandatory
) sealed
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.StringSetter(System.Reflection.PropertyInfo,System.Boolean)"]

isMandatory (Boolean)

[Missing <param name="isMandatory"/> documentation for "M:StructureMap.Emitting.ArgumentEmitter.StringSetter(System.Reflection.PropertyInfo,System.Boolean)"]


BuildInstanceMethod Class

BuildInstanceMethod Class
Namespaces ► StructureMap.Emitting ► BuildInstanceMethod
StructureMap API
Emits the IL for the InstanceBuilder.BuildInstance(InstanceMemento) method of an InstanceBuilder
Declaration Syntax
C# Visual Basic Visual C++
public class BuildInstanceMethod : Method
Public Class BuildInstanceMethod _
    Inherits Method
public ref class BuildInstanceMethod : public Method
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuildInstanceMethod(Plugin) | Initializes a new instance of the BuildInstanceMethod class
 | ArgumentList | (Overrides Method.ArgumentList.)
 | Build()()() | (Inherited from Method.)
 | CallMethod(MethodInfo) | (Inherited from Method.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Generate(ILGenerator) | (Overrides Method.Generate(ILGenerator).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MethodName | (Overrides Method.MethodName.)
 | ReturnType | (Overrides Method.ReturnType.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Method
 |  | BuildInstanceMethod


BuildInstanceMethod Constructor (plugin)

BuildInstanceMethod Constructor (plugin)
Namespaces ► StructureMap.Emitting ► BuildInstanceMethod ► BuildInstanceMethod(Plugin)
StructureMap API
Initializes a new instance of the BuildInstanceMethod class
Declaration Syntax
C# Visual Basic Visual C++
public BuildInstanceMethod(
    Plugin plugin
)
Public Sub New ( _
    plugin As Plugin _
)
public:
BuildInstanceMethod(
    Plugin^ plugin
)
Parameters
plugin (Plugin)

[Missing <param name="plugin"/> documentation for "M:StructureMap.Emitting.BuildInstanceMethod.#ctor(StructureMap.Graph.Plugin)"]


ArgumentList Property

ArgumentList Property
Namespaces ► StructureMap.Emitting ► BuildInstanceMethod ► ArgumentList
StructureMap API

[Missing <summary> documentation for P:StructureMap.Emitting.BuildInstanceMethod.ArgumentList]

Declaration Syntax
C# Visual Basic Visual C++
public override Type[] ArgumentList { get; }
Public Overrides ReadOnly Property ArgumentList As Type()
public:
virtual property array<Type^>^ ArgumentList {
    array<Type^>^ get () override;
}


Generate Method (ilgen)

Generate Method (ilgen)
Namespaces ► StructureMap.Emitting ► BuildInstanceMethod ► Generate(ILGenerator)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.BuildInstanceMethod.Generate(System.Reflection.Emit.ILGenerator)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void Generate(
    ILGenerator ilgen
)
Protected Overrides Sub Generate ( _
    ilgen As ILGenerator _
)
protected:
virtual void Generate(
    ILGenerator^ ilgen
) override
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.BuildInstanceMethod.Generate(System.Reflection.Emit.ILGenerator)"]


MethodName Property

MethodName Property
Namespaces ► StructureMap.Emitting ► BuildInstanceMethod ► MethodName
StructureMap API

[Missing <summary> documentation for P:StructureMap.Emitting.BuildInstanceMethod.MethodName]

Declaration Syntax
C# Visual Basic Visual C++
public override string MethodName { get; }
Public Overrides ReadOnly Property MethodName As String
public:
virtual property String^ MethodName {
    String^ get () override;
}


ReturnType Property

ReturnType Property
Namespaces ► StructureMap.Emitting ► BuildInstanceMethod ► ReturnType
StructureMap API

[Missing <summary> documentation for P:StructureMap.Emitting.BuildInstanceMethod.ReturnType]

Declaration Syntax
C# Visual Basic Visual C++
public override Type ReturnType { get; }
Public Overrides ReadOnly Property ReturnType As Type
public:
virtual property Type^ ReturnType {
    Type^ get () override;
}


ClassBuilder Class

ClassBuilder Class
Namespaces ► StructureMap.Emitting ► ClassBuilder
StructureMap API
Emits the IL for a new class Type
Declaration Syntax
C# Visual Basic Visual C++
public class ClassBuilder
Public Class ClassBuilder
public ref class ClassBuilder
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ClassBuilder(ModuleBuilder, String) | Initializes a new instance of the ClassBuilder class
 | ClassBuilder(ModuleBuilder, String, Type) | Initializes a new instance of the ClassBuilder class
 | AddMethod(Method) |
 | AddPluggedTypeGetter(Type) |
 | ClassName |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ClassBuilder


ClassBuilder Constructor

ClassBuilder Constructor
Namespaces ► StructureMap.Emitting ► ClassBuilder ► ClassBuilder()()()
StructureMap API
Members
Icon | Member | Description
 | ClassBuilder(ModuleBuilder, String) | Initializes a new instance of the ClassBuilder class
 | ClassBuilder(ModuleBuilder, String, Type) | Initializes a new instance of the ClassBuilder class


ClassBuilder Constructor (module, className)

ClassBuilder Constructor (module, className)
Namespaces ► StructureMap.Emitting ► ClassBuilder ► ClassBuilder(ModuleBuilder, String)
StructureMap API
Initializes a new instance of the ClassBuilder class
Declaration Syntax
C# Visual Basic Visual C++
public ClassBuilder(
    ModuleBuilder module,
    string className
)
Public Sub New ( _
    module As ModuleBuilder, _
    className As String _
)
public:
ClassBuilder(
    ModuleBuilder^ module,
    String^ className
)
Parameters
module (ModuleBuilder)

[Missing <param name="module"/> documentation for "M:StructureMap.Emitting.ClassBuilder.#ctor(System.Reflection.Emit.ModuleBuilder,System.String)"]

className (String)

[Missing <param name="className"/> documentation for "M:StructureMap.Emitting.ClassBuilder.#ctor(System.Reflection.Emit.ModuleBuilder,System.String)"]


ClassBuilder Constructor (module, ClassName, superType)

ClassBuilder Constructor (module, ClassName, superType)
Namespaces ► StructureMap.Emitting ► ClassBuilder ► ClassBuilder(ModuleBuilder, String, Type)
StructureMap API
Initializes a new instance of the ClassBuilder class
Declaration Syntax
C# Visual Basic Visual C++
public ClassBuilder(
    ModuleBuilder module,
    string ClassName,
    Type superType
)
Public Sub New ( _
    module As ModuleBuilder, _
    ClassName As String, _
    superType As Type _
)
public:
ClassBuilder(
    ModuleBuilder^ module,
    String^ ClassName,
    Type^ superType
)
Parameters
module (ModuleBuilder)

[Missing <param name="module"/> documentation for "M:StructureMap.Emitting.ClassBuilder.#ctor(System.Reflection.Emit.ModuleBuilder,System.String,System.Type)"]

ClassName (String)

[Missing <param name="ClassName"/> documentation for "M:StructureMap.Emitting.ClassBuilder.#ctor(System.Reflection.Emit.ModuleBuilder,System.String,System.Type)"]

superType (Type)

[Missing <param name="superType"/> documentation for "M:StructureMap.Emitting.ClassBuilder.#ctor(System.Reflection.Emit.ModuleBuilder,System.String,System.Type)"]


AddMethod Method (method)

AddMethod Method (method)
Namespaces ► StructureMap.Emitting ► ClassBuilder ► AddMethod(Method)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.ClassBuilder.AddMethod(StructureMap.Emitting.Method)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddMethod(
    Method method
)
Public Sub AddMethod ( _
    method As Method _
)
public:
void AddMethod(
    Method^ method
)
Parameters
method (Method)

[Missing <param name="method"/> documentation for "M:StructureMap.Emitting.ClassBuilder.AddMethod(StructureMap.Emitting.Method)"]


AddPluggedTypeGetter Method (pluggedType)

AddPluggedTypeGetter Method (pluggedType)
Namespaces ► StructureMap.Emitting ► ClassBuilder ► AddPluggedTypeGetter(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.ClassBuilder.AddPluggedTypeGetter(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddPluggedTypeGetter(
    Type pluggedType
)
Public Sub AddPluggedTypeGetter ( _
    pluggedType As Type _
)
public:
void AddPluggedTypeGetter(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Emitting.ClassBuilder.AddPluggedTypeGetter(System.Type)"]


ClassName Property

ClassName Property
Namespaces ► StructureMap.Emitting ► ClassBuilder ► ClassName
StructureMap API

[Missing <summary> documentation for P:StructureMap.Emitting.ClassBuilder.ClassName]

Declaration Syntax
C# Visual Basic Visual C++
public string ClassName { get; }
Public ReadOnly Property ClassName As String
public:
property String^ ClassName {
    String^ get ();
}


DynamicAssembly Class

DynamicAssembly Class
Namespaces ► StructureMap.Emitting ► DynamicAssembly
StructureMap API
Helper class to use to create a dynamically emitted assembly
Declaration Syntax
C# Visual Basic Visual C++
public class DynamicAssembly
Public Class DynamicAssembly
public ref class DynamicAssembly
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DynamicAssembly(String) | Initializes a new instance of the DynamicAssembly class
 | AddClass(String) |
 | AddClass(String, Type) |
 | Compile()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsCompiled |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
DynamicAssembly


DynamicAssembly Constructor (name)

DynamicAssembly Constructor (name)
Namespaces ► StructureMap.Emitting ► DynamicAssembly ► DynamicAssembly(String)
StructureMap API
Initializes a new instance of the DynamicAssembly class
Declaration Syntax
C# Visual Basic Visual C++
public DynamicAssembly(
    string name
)
Public Sub New ( _
    name As String _
)
public:
DynamicAssembly(
    String^ name
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Emitting.DynamicAssembly.#ctor(System.String)"]


AddClass Method

AddClass Method
Namespaces ► StructureMap.Emitting ► DynamicAssembly ► AddClass()()()
StructureMap API
Members
Icon | Member | Description
 | AddClass(String) |
 | AddClass(String, Type) |


AddClass Method (ClassName)

AddClass Method (ClassName)
Namespaces ► StructureMap.Emitting ► DynamicAssembly ► AddClass(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.DynamicAssembly.AddClass(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public ClassBuilder AddClass(
    string ClassName
)
Public Function AddClass ( _
    ClassName As String _
) As ClassBuilder
public:
ClassBuilder^ AddClass(
    String^ ClassName
)
Parameters
ClassName (String)

[Missing <param name="ClassName"/> documentation for "M:StructureMap.Emitting.DynamicAssembly.AddClass(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Emitting.DynamicAssembly.AddClass(System.String)]


AddClass Method (ClassName, superType)

AddClass Method (ClassName, superType)
Namespaces ► StructureMap.Emitting ► DynamicAssembly ► AddClass(String, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.DynamicAssembly.AddClass(System.String,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public ClassBuilder AddClass(
    string ClassName,
    Type superType
)
Public Function AddClass ( _
    ClassName As String, _
    superType As Type _
) As ClassBuilder
public:
ClassBuilder^ AddClass(
    String^ ClassName,
    Type^ superType
)
Parameters
ClassName (String)

[Missing <param name="ClassName"/> documentation for "M:StructureMap.Emitting.DynamicAssembly.AddClass(System.String,System.Type)"]

superType (Type)

[Missing <param name="superType"/> documentation for "M:StructureMap.Emitting.DynamicAssembly.AddClass(System.String,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Emitting.DynamicAssembly.AddClass(System.String,System.Type)]


Compile Method

Compile Method
Namespaces ► StructureMap.Emitting ► DynamicAssembly ► Compile()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.DynamicAssembly.Compile]

Declaration Syntax
C# Visual Basic Visual C++
public Assembly Compile()
Public Function Compile As Assembly
public:
Assembly^ Compile()
Return Value

[Missing <returns> documentation for M:StructureMap.Emitting.DynamicAssembly.Compile]


IsCompiled Property

IsCompiled Property
Namespaces ► StructureMap.Emitting ► DynamicAssembly ► IsCompiled
StructureMap API

[Missing <summary> documentation for P:StructureMap.Emitting.DynamicAssembly.IsCompiled]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsCompiled { get; }
Public ReadOnly Property IsCompiled As Boolean
public:
property bool IsCompiled {
    bool get ();
}


Name Property

Name Property
Namespaces ► StructureMap.Emitting ► DynamicAssembly ► Name
StructureMap API

[Missing <summary> documentation for P:StructureMap.Emitting.DynamicAssembly.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}


InstanceBuilderAssembly Class

InstanceBuilderAssembly Class
Namespaces ► StructureMap.Emitting ► InstanceBuilderAssembly
StructureMap API
Manages the IL emitting of a dynamic assembly of InstanceBuilder classes
Declaration Syntax
C# Visual Basic Visual C++
public class InstanceBuilderAssembly
Public Class InstanceBuilderAssembly
public ref class InstanceBuilderAssembly
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InstanceBuilderAssembly(IEnumerable<(Of <(Plugin>)>)) | Initializes a new instance of the InstanceBuilderAssembly class
 | Compile()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | getInstanceBuilderClassName(Type) | Gets a class name for the InstanceBuilder that will be emitted for this Plugin
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InstanceBuilderAssembly


InstanceBuilderAssembly Constructor (plugins)

InstanceBuilderAssembly Constructor (plugins)
Namespaces ► StructureMap.Emitting ► InstanceBuilderAssembly ► InstanceBuilderAssembly(IEnumerable<(Of <(Plugin>)>))
StructureMap API
Initializes a new instance of the InstanceBuilderAssembly class
Declaration Syntax
C# Visual Basic Visual C++
public InstanceBuilderAssembly(
    IEnumerable<Plugin> plugins
)
Public Sub New ( _
    plugins As IEnumerable(Of Plugin) _
)
public:
InstanceBuilderAssembly(
    IEnumerable<Plugin^>^ plugins
)
Parameters
plugins (IEnumerable <(Of <( Plugin >)>))

[Missing <param name="plugins"/> documentation for "M:StructureMap.Emitting.InstanceBuilderAssembly.#ctor(System.Collections.Generic.IEnumerable{StructureMap.Graph.Plugin})"]


Compile Method

Compile Method
Namespaces ► StructureMap.Emitting ► InstanceBuilderAssembly ► Compile()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.InstanceBuilderAssembly.Compile]

Declaration Syntax
C# Visual Basic Visual C++
public List<InstanceBuilder> Compile()
Public Function Compile As List(Of InstanceBuilder)
public:
List<InstanceBuilder^>^ Compile()
Return Value

[Missing <returns> documentation for M:StructureMap.Emitting.InstanceBuilderAssembly.Compile]


getInstanceBuilderClassName Method (pluggedType)

getInstanceBuilderClassName Method (pluggedType)
Namespaces ► StructureMap.Emitting ► InstanceBuilderAssembly ► getInstanceBuilderClassName(Type)
StructureMap API
Gets a class name for the InstanceBuilder that will be emitted for this Plugin
Declaration Syntax
C# Visual Basic Visual C++
public static string getInstanceBuilderClassName(
    Type pluggedType
)
Public Shared Function getInstanceBuilderClassName ( _
    pluggedType As Type _
) As String
public:
static String^ getInstanceBuilderClassName(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Emitting.InstanceBuilderAssembly.getInstanceBuilderClassName(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Emitting.InstanceBuilderAssembly.getInstanceBuilderClassName(System.Type)]


Method Class

Method Class
Namespaces ► StructureMap.Emitting ► Method
StructureMap API
Emits the IL for one method
Declaration Syntax
C# Visual Basic Visual C++
public abstract class Method
Public MustInherit Class Method
public ref class Method abstract
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Method()()() | Initializes a new instance of the Method class
 | ArgumentList |
 | Build()()() |
 | CallMethod(MethodInfo) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Generate(ILGenerator) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MethodName |
 | ReturnType |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Method
 |  | BuildInstanceMethod


Method Constructor

Method Constructor
Namespaces ► StructureMap.Emitting ► Method ► Method()()()
StructureMap API
Initializes a new instance of the Method class
Declaration Syntax
C# Visual Basic Visual C++
protected Method()
Protected Sub New
protected:
Method()


ArgumentList Property

ArgumentList Property
Namespaces ► StructureMap.Emitting ► Method ► ArgumentList
StructureMap API

[Missing <summary> documentation for P:StructureMap.Emitting.Method.ArgumentList]

Declaration Syntax
C# Visual Basic Visual C++
public abstract Type[] ArgumentList { get; }
Public MustOverride ReadOnly Property ArgumentList As Type()
public:
virtual property array<Type^>^ ArgumentList {
    array<Type^>^ get () abstract;
}


Build Method

Build Method
Namespaces ► StructureMap.Emitting ► Method ► Build()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Method.Build]

Declaration Syntax
C# Visual Basic Visual C++
public void Build()
Public Sub Build
public:
void Build()


CallMethod Method (methodInfo)

CallMethod Method (methodInfo)
Namespaces ► StructureMap.Emitting ► Method ► CallMethod(MethodInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Method.CallMethod(System.Reflection.MethodInfo)]

Declaration Syntax
C# Visual Basic Visual C++
protected void CallMethod(
    MethodInfo methodInfo
)
Protected Sub CallMethod ( _
    methodInfo As MethodInfo _
)
protected:
void CallMethod(
    MethodInfo^ methodInfo
)
Parameters
methodInfo (MethodInfo)

[Missing <param name="methodInfo"/> documentation for "M:StructureMap.Emitting.Method.CallMethod(System.Reflection.MethodInfo)"]


Generate Method (ilgen)

Generate Method (ilgen)
Namespaces ► StructureMap.Emitting ► Method ► Generate(ILGenerator)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Method.Generate(System.Reflection.Emit.ILGenerator)]

Declaration Syntax
C# Visual Basic Visual C++
protected abstract void Generate(
    ILGenerator ilgen
)
Protected MustOverride Sub Generate ( _
    ilgen As ILGenerator _
)
protected:
virtual void Generate(
    ILGenerator^ ilgen
) abstract
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.Method.Generate(System.Reflection.Emit.ILGenerator)"]


MethodName Property

MethodName Property
Namespaces ► StructureMap.Emitting ► Method ► MethodName
StructureMap API

[Missing <summary> documentation for P:StructureMap.Emitting.Method.MethodName]

Declaration Syntax
C# Visual Basic Visual C++
public abstract string MethodName { get; }
Public MustOverride ReadOnly Property MethodName As String
public:
virtual property String^ MethodName {
    String^ get () abstract;
}


ReturnType Property

ReturnType Property
Namespaces ► StructureMap.Emitting ► Method ► ReturnType
StructureMap API

[Missing <summary> documentation for P:StructureMap.Emitting.Method.ReturnType]

Declaration Syntax
C# Visual Basic Visual C++
public abstract Type ReturnType { get; }
Public MustOverride ReadOnly Property ReturnType As Type
public:
virtual property Type^ ReturnType {
    Type^ get () abstract;
}


StructureMap.Emitting.Parameters Namespace

StructureMap.Emitting.Parameters Namespace
Namespaces ► StructureMap.Emitting.Parameters
StructureMap API

[Missing <summary> documentation for N:StructureMap.Emitting.Parameters]

Declaration Syntax
C# Visual Basic Visual C++
namespace StructureMap.Emitting.Parameters
Namespace StructureMap.Emitting.Parameters
namespace StructureMap.Emitting.Parameters
Types
All Types Classes
Icon | Type | Description
 | ChildArrayParameterEmitter | Implementation of ParameterEmitter for a constructor argument like MyClass(IStrategy[] strategies)
 | ChildParameterEmitter | Implementation of ParameterEmitter for a non-primitive, non-array constructor argument
 | EnumParameterEmitter | Implementation of ParameterEmitter for enumeration types
 | Methods |
 | ParameterEmitter | Abstract class to provide a template for emitting the instructions for retrieving one constructor function argument from an InstanceMemento and feeding into the constructor function
 | PrimitiveParameterEmitter | Implementation of ParameterEmitter for primitive types other than strings.
 | StringParameterEmitter | Implementation of ParameterEmitter for string type constructor arguments


ChildArrayParameterEmitter Class

ChildArrayParameterEmitter Class
Namespaces ► StructureMap.Emitting.Parameters ► ChildArrayParameterEmitter
StructureMap API
Implementation of ParameterEmitter for a constructor argument like MyClass(IStrategy[] strategies)
Declaration Syntax
C# Visual Basic Visual C++
public class ChildArrayParameterEmitter : ParameterEmitter
Public Class ChildArrayParameterEmitter _
    Inherits ParameterEmitter
public ref class ChildArrayParameterEmitter : public ParameterEmitter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ChildArrayParameterEmitter()()() | Initializes a new instance of the ChildArrayParameterEmitter class
 | cast(ILGenerator, Type) | (Inherited from ParameterEmitter.)
 | Ctor(ILGenerator, ParameterInfo) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MandatorySetter(ILGenerator, PropertyInfo) | (Overrides ParameterEmitter.MandatorySetter(ILGenerator, PropertyInfo).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OptionalSetter(ILGenerator, PropertyInfo) | (Inherited from ParameterEmitter.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ParameterEmitter
 |  | ChildArrayParameterEmitter


ChildArrayParameterEmitter Constructor

ChildArrayParameterEmitter Constructor
Namespaces ► StructureMap.Emitting.Parameters ► ChildArrayParameterEmitter ► ChildArrayParameterEmitter()()()
StructureMap API
Initializes a new instance of the ChildArrayParameterEmitter class
Declaration Syntax
C# Visual Basic Visual C++
public ChildArrayParameterEmitter()
Public Sub New
public:
ChildArrayParameterEmitter()


Ctor Method (ilgen, parameter)

Ctor Method (ilgen, parameter)
Namespaces ► StructureMap.Emitting.Parameters ► ChildArrayParameterEmitter ► Ctor(ILGenerator, ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Parameters.ChildArrayParameterEmitter.Ctor(System.Reflection.Emit.ILGenerator,System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void Ctor(
    ILGenerator ilgen,
    ParameterInfo parameter
)
Public Sub Ctor ( _
    ilgen As ILGenerator, _
    parameter As ParameterInfo _
)
public:
void Ctor(
    ILGenerator^ ilgen,
    ParameterInfo^ parameter
)
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.Parameters.ChildArrayParameterEmitter.Ctor(System.Reflection.Emit.ILGenerator,System.Reflection.ParameterInfo)"]

parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Emitting.Parameters.ChildArrayParameterEmitter.Ctor(System.Reflection.Emit.ILGenerator,System.Reflection.ParameterInfo)"]


MandatorySetter Method (ilgen, property)

MandatorySetter Method (ilgen, property)
Namespaces ► StructureMap.Emitting.Parameters ► ChildArrayParameterEmitter ► MandatorySetter(ILGenerator, PropertyInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Parameters.ChildArrayParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public override void MandatorySetter(
    ILGenerator ilgen,
    PropertyInfo property
)
Public Overrides Sub MandatorySetter ( _
    ilgen As ILGenerator, _
    property As PropertyInfo _
)
public:
virtual void MandatorySetter(
    ILGenerator^ ilgen,
    PropertyInfo^ property
) override
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.Parameters.ChildArrayParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)"]

property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Emitting.Parameters.ChildArrayParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)"]


ChildParameterEmitter Class

ChildParameterEmitter Class
Namespaces ► StructureMap.Emitting.Parameters ► ChildParameterEmitter
StructureMap API
Implementation of ParameterEmitter for a non-primitive, non-array constructor argument
Declaration Syntax
C# Visual Basic Visual C++
public class ChildParameterEmitter : ParameterEmitter
Public Class ChildParameterEmitter _
    Inherits ParameterEmitter
public ref class ChildParameterEmitter : public ParameterEmitter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ChildParameterEmitter()()() | Initializes a new instance of the ChildParameterEmitter class
 | cast(ILGenerator, Type) | (Inherited from ParameterEmitter.)
 | Ctor(ILGenerator, ParameterInfo) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MandatorySetter(ILGenerator, PropertyInfo) | (Overrides ParameterEmitter.MandatorySetter(ILGenerator, PropertyInfo).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OptionalSetter(ILGenerator, PropertyInfo) | (Inherited from ParameterEmitter.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ParameterEmitter
 |  | ChildParameterEmitter


ChildParameterEmitter Constructor

ChildParameterEmitter Constructor
Namespaces ► StructureMap.Emitting.Parameters ► ChildParameterEmitter ► ChildParameterEmitter()()()
StructureMap API
Initializes a new instance of the ChildParameterEmitter class
Declaration Syntax
C# Visual Basic Visual C++
public ChildParameterEmitter()
Public Sub New
public:
ChildParameterEmitter()


Ctor Method (ilgen, parameter)

Ctor Method (ilgen, parameter)
Namespaces ► StructureMap.Emitting.Parameters ► ChildParameterEmitter ► Ctor(ILGenerator, ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Parameters.ChildParameterEmitter.Ctor(System.Reflection.Emit.ILGenerator,System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void Ctor(
    ILGenerator ilgen,
    ParameterInfo parameter
)
Public Sub Ctor ( _
    ilgen As ILGenerator, _
    parameter As ParameterInfo _
)
public:
void Ctor(
    ILGenerator^ ilgen,
    ParameterInfo^ parameter
)
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.Parameters.ChildParameterEmitter.Ctor(System.Reflection.Emit.ILGenerator,System.Reflection.ParameterInfo)"]

parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Emitting.Parameters.ChildParameterEmitter.Ctor(System.Reflection.Emit.ILGenerator,System.Reflection.ParameterInfo)"]


MandatorySetter Method (ilgen, property)

MandatorySetter Method (ilgen, property)
Namespaces ► StructureMap.Emitting.Parameters ► ChildParameterEmitter ► MandatorySetter(ILGenerator, PropertyInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Parameters.ChildParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public override void MandatorySetter(
    ILGenerator ilgen,
    PropertyInfo property
)
Public Overrides Sub MandatorySetter ( _
    ilgen As ILGenerator, _
    property As PropertyInfo _
)
public:
virtual void MandatorySetter(
    ILGenerator^ ilgen,
    PropertyInfo^ property
) override
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.Parameters.ChildParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)"]

property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Emitting.Parameters.ChildParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)"]


EnumParameterEmitter Class

EnumParameterEmitter Class
Namespaces ► StructureMap.Emitting.Parameters ► EnumParameterEmitter
StructureMap API
Implementation of ParameterEmitter for enumeration types
Declaration Syntax
C# Visual Basic Visual C++
public class EnumParameterEmitter : ParameterEmitter
Public Class EnumParameterEmitter _
    Inherits ParameterEmitter
public ref class EnumParameterEmitter : public ParameterEmitter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EnumParameterEmitter()()() | Initializes a new instance of the EnumParameterEmitter class
 | cast(ILGenerator, Type) | (Inherited from ParameterEmitter.)
 | Ctor(ILGenerator, ParameterInfo) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MandatorySetter(ILGenerator, PropertyInfo) | (Overrides ParameterEmitter.MandatorySetter(ILGenerator, PropertyInfo).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OptionalSetter(ILGenerator, PropertyInfo) | (Inherited from ParameterEmitter.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ParameterEmitter
 |  | EnumParameterEmitter


EnumParameterEmitter Constructor

EnumParameterEmitter Constructor
Namespaces ► StructureMap.Emitting.Parameters ► EnumParameterEmitter ► EnumParameterEmitter()()()
StructureMap API
Initializes a new instance of the EnumParameterEmitter class
Declaration Syntax
C# Visual Basic Visual C++
public EnumParameterEmitter()
Public Sub New
public:
EnumParameterEmitter()


Ctor Method (ilgen, parameter)

Ctor Method (ilgen, parameter)
Namespaces ► StructureMap.Emitting.Parameters ► EnumParameterEmitter ► Ctor(ILGenerator, ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Parameters.EnumParameterEmitter.Ctor(System.Reflection.Emit.ILGenerator,System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void Ctor(
    ILGenerator ilgen,
    ParameterInfo parameter
)
Public Sub Ctor ( _
    ilgen As ILGenerator, _
    parameter As ParameterInfo _
)
public:
void Ctor(
    ILGenerator^ ilgen,
    ParameterInfo^ parameter
)
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.Parameters.EnumParameterEmitter.Ctor(System.Reflection.Emit.ILGenerator,System.Reflection.ParameterInfo)"]

parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Emitting.Parameters.EnumParameterEmitter.Ctor(System.Reflection.Emit.ILGenerator,System.Reflection.ParameterInfo)"]


MandatorySetter Method (ilgen, property)

MandatorySetter Method (ilgen, property)
Namespaces ► StructureMap.Emitting.Parameters ► EnumParameterEmitter ► MandatorySetter(ILGenerator, PropertyInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Parameters.EnumParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public override void MandatorySetter(
    ILGenerator ilgen,
    PropertyInfo property
)
Public Overrides Sub MandatorySetter ( _
    ilgen As ILGenerator, _
    property As PropertyInfo _
)
public:
virtual void MandatorySetter(
    ILGenerator^ ilgen,
    PropertyInfo^ property
) override
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.Parameters.EnumParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)"]

property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Emitting.Parameters.EnumParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)"]


Methods Class

Methods Class
Namespaces ► StructureMap.Emitting.Parameters ► Methods
StructureMap API

[Missing <summary> documentation for T:StructureMap.Emitting.Parameters.Methods]

Declaration Syntax
C# Visual Basic Visual C++
public static class Methods
Public NotInheritable Class Methods
public ref class Methods abstract sealed
Members
All Members | Methods | Fields
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | CREATE_INSTANCE_ARRAY |
 | ENUM_PARSE |
 | GET_CHILD |
 | GET_CHILDREN_ARRAY |
 | GET_PROPERTY |
 | GET_TYPE_FROM_HANDLE |
 | HAS_PROPERTY |
 | ParseFor(Type) |
Inheritance Hierarchy
Object
Methods


CREATE_INSTANCE_ARRAY Field

CREATE_INSTANCE_ARRAY Field
Namespaces ► StructureMap.Emitting.Parameters ► Methods ► CREATE_INSTANCE_ARRAY
StructureMap API

[Missing <summary> documentation for F:StructureMap.Emitting.Parameters.Methods.CREATE_INSTANCE_ARRAY]

Declaration Syntax
C# Visual Basic Visual C++
public static MethodInfo CREATE_INSTANCE_ARRAY
Public Shared CREATE_INSTANCE_ARRAY As MethodInfo
public:
static MethodInfo^ CREATE_INSTANCE_ARRAY


ENUM_PARSE Field

ENUM_PARSE Field
Namespaces ► StructureMap.Emitting.Parameters ► Methods ► ENUM_PARSE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Emitting.Parameters.Methods.ENUM_PARSE]

Declaration Syntax
C# Visual Basic Visual C++
public static MethodInfo ENUM_PARSE
Public Shared ENUM_PARSE As MethodInfo
public:
static MethodInfo^ ENUM_PARSE


GET_CHILD Field

GET_CHILD Field
Namespaces ► StructureMap.Emitting.Parameters ► Methods ► GET_CHILD
StructureMap API

[Missing <summary> documentation for F:StructureMap.Emitting.Parameters.Methods.GET_CHILD]

Declaration Syntax
C# Visual Basic Visual C++
public static MethodInfo GET_CHILD
Public Shared GET_CHILD As MethodInfo
public:
static MethodInfo^ GET_CHILD


GET_CHILDREN_ARRAY Field

GET_CHILDREN_ARRAY Field
Namespaces ► StructureMap.Emitting.Parameters ► Methods ► GET_CHILDREN_ARRAY
StructureMap API

[Missing <summary> documentation for F:StructureMap.Emitting.Parameters.Methods.GET_CHILDREN_ARRAY]

Declaration Syntax
C# Visual Basic Visual C++
public static MethodInfo GET_CHILDREN_ARRAY
Public Shared GET_CHILDREN_ARRAY As MethodInfo
public:
static MethodInfo^ GET_CHILDREN_ARRAY


GET_PROPERTY Field

GET_PROPERTY Field
Namespaces ► StructureMap.Emitting.Parameters ► Methods ► GET_PROPERTY
StructureMap API

[Missing <summary> documentation for F:StructureMap.Emitting.Parameters.Methods.GET_PROPERTY]

Declaration Syntax
C# Visual Basic Visual C++
public static readonly MethodInfo GET_PROPERTY
Public Shared ReadOnly GET_PROPERTY As MethodInfo
public:
static initonly MethodInfo^ GET_PROPERTY


GET_TYPE_FROM_HANDLE Field

GET_TYPE_FROM_HANDLE Field
Namespaces ► StructureMap.Emitting.Parameters ► Methods ► GET_TYPE_FROM_HANDLE
StructureMap API

[Missing <summary> documentation for F:StructureMap.Emitting.Parameters.Methods.GET_TYPE_FROM_HANDLE]

Declaration Syntax
C# Visual Basic Visual C++
public static MethodInfo GET_TYPE_FROM_HANDLE
Public Shared GET_TYPE_FROM_HANDLE As MethodInfo
public:
static MethodInfo^ GET_TYPE_FROM_HANDLE


HAS_PROPERTY Field

HAS_PROPERTY Field
Namespaces ► StructureMap.Emitting.Parameters ► Methods ► HAS_PROPERTY
StructureMap API

[Missing <summary> documentation for F:StructureMap.Emitting.Parameters.Methods.HAS_PROPERTY]

Declaration Syntax
C# Visual Basic Visual C++
public static MethodInfo HAS_PROPERTY
Public Shared HAS_PROPERTY As MethodInfo
public:
static MethodInfo^ HAS_PROPERTY


ParseFor Method (type)

ParseFor Method (type)
Namespaces ► StructureMap.Emitting.Parameters ► Methods ► ParseFor(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Parameters.Methods.ParseFor(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public static MethodInfo ParseFor(
    Type type
)
Public Shared Function ParseFor ( _
    type As Type _
) As MethodInfo
public:
static MethodInfo^ ParseFor(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Emitting.Parameters.Methods.ParseFor(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Emitting.Parameters.Methods.ParseFor(System.Type)]


ParameterEmitter Class

ParameterEmitter Class
Namespaces ► StructureMap.Emitting.Parameters ► ParameterEmitter
StructureMap API
Abstract class to provide a template for emitting the instructions for retrieving one constructor function argument from an InstanceMemento and feeding into the constructor function
Declaration Syntax
C# Visual Basic Visual C++
public abstract class ParameterEmitter
Public MustInherit Class ParameterEmitter
public ref class ParameterEmitter abstract
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ParameterEmitter()()() | Initializes a new instance of the ParameterEmitter class
 | cast(ILGenerator, Type) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MandatorySetter(ILGenerator, PropertyInfo) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OptionalSetter(ILGenerator, PropertyInfo) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ParameterEmitter
 |  | ChildArrayParameterEmitter
 |  | ChildParameterEmitter
 |  | EnumParameterEmitter
 |  | PrimitiveParameterEmitter
 |  | StringParameterEmitter


ParameterEmitter Constructor

ParameterEmitter Constructor
Namespaces ► StructureMap.Emitting.Parameters ► ParameterEmitter ► ParameterEmitter()()()
StructureMap API
Initializes a new instance of the ParameterEmitter class
Declaration Syntax
C# Visual Basic Visual C++
protected ParameterEmitter()
Protected Sub New
protected:
ParameterEmitter()


cast Method (ilgen, parameterType)

cast Method (ilgen, parameterType)
Namespaces ► StructureMap.Emitting.Parameters ► ParameterEmitter ► cast(ILGenerator, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Parameters.ParameterEmitter.cast(System.Reflection.Emit.ILGenerator,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected void cast(
    ILGenerator ilgen,
    Type parameterType
)
Protected Sub cast ( _
    ilgen As ILGenerator, _
    parameterType As Type _
)
protected:
void cast(
    ILGenerator^ ilgen,
    Type^ parameterType
)
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.Parameters.ParameterEmitter.cast(System.Reflection.Emit.ILGenerator,System.Type)"]

parameterType (Type)

[Missing <param name="parameterType"/> documentation for "M:StructureMap.Emitting.Parameters.ParameterEmitter.cast(System.Reflection.Emit.ILGenerator,System.Type)"]


MandatorySetter Method (ilgen, property)

MandatorySetter Method (ilgen, property)
Namespaces ► StructureMap.Emitting.Parameters ► ParameterEmitter ► MandatorySetter(ILGenerator, PropertyInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Parameters.ParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public abstract void MandatorySetter(
    ILGenerator ilgen,
    PropertyInfo property
)
Public MustOverride Sub MandatorySetter ( _
    ilgen As ILGenerator, _
    property As PropertyInfo _
)
public:
virtual void MandatorySetter(
    ILGenerator^ ilgen,
    PropertyInfo^ property
) abstract
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.Parameters.ParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)"]

property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Emitting.Parameters.ParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)"]


OptionalSetter Method (ilgen, property)

OptionalSetter Method (ilgen, property)
Namespaces ► StructureMap.Emitting.Parameters ► ParameterEmitter ► OptionalSetter(ILGenerator, PropertyInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Parameters.ParameterEmitter.OptionalSetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void OptionalSetter(
    ILGenerator ilgen,
    PropertyInfo property
)
Public Sub OptionalSetter ( _
    ilgen As ILGenerator, _
    property As PropertyInfo _
)
public:
void OptionalSetter(
    ILGenerator^ ilgen,
    PropertyInfo^ property
)
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.Parameters.ParameterEmitter.OptionalSetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)"]

property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Emitting.Parameters.ParameterEmitter.OptionalSetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)"]


PrimitiveParameterEmitter Class

PrimitiveParameterEmitter Class
Namespaces ► StructureMap.Emitting.Parameters ► PrimitiveParameterEmitter
StructureMap API
Implementation of ParameterEmitter for primitive types other than strings.
Declaration Syntax
C# Visual Basic Visual C++
public class PrimitiveParameterEmitter : ParameterEmitter
Public Class PrimitiveParameterEmitter _
    Inherits ParameterEmitter
public ref class PrimitiveParameterEmitter : public ParameterEmitter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PrimitiveParameterEmitter()()() | Initializes a new instance of the PrimitiveParameterEmitter class
 | cast(ILGenerator, Type) | (Inherited from ParameterEmitter.)
 | Ctor(ILGenerator, ParameterInfo) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MandatorySetter(ILGenerator, PropertyInfo) | (Overrides ParameterEmitter.MandatorySetter(ILGenerator, PropertyInfo).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OptionalSetter(ILGenerator, PropertyInfo) | (Inherited from ParameterEmitter.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ParameterEmitter
 |  | PrimitiveParameterEmitter


PrimitiveParameterEmitter Constructor

PrimitiveParameterEmitter Constructor
Namespaces ► StructureMap.Emitting.Parameters ► PrimitiveParameterEmitter ► PrimitiveParameterEmitter()()()
StructureMap API
Initializes a new instance of the PrimitiveParameterEmitter class
Declaration Syntax
C# Visual Basic Visual C++
public PrimitiveParameterEmitter()
Public Sub New
public:
PrimitiveParameterEmitter()


Ctor Method (ilgen, parameter)

Ctor Method (ilgen, parameter)
Namespaces ► StructureMap.Emitting.Parameters ► PrimitiveParameterEmitter ► Ctor(ILGenerator, ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Parameters.PrimitiveParameterEmitter.Ctor(System.Reflection.Emit.ILGenerator,System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void Ctor(
    ILGenerator ilgen,
    ParameterInfo parameter
)
Public Sub Ctor ( _
    ilgen As ILGenerator, _
    parameter As ParameterInfo _
)
public:
void Ctor(
    ILGenerator^ ilgen,
    ParameterInfo^ parameter
)
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.Parameters.PrimitiveParameterEmitter.Ctor(System.Reflection.Emit.ILGenerator,System.Reflection.ParameterInfo)"]

parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Emitting.Parameters.PrimitiveParameterEmitter.Ctor(System.Reflection.Emit.ILGenerator,System.Reflection.ParameterInfo)"]


MandatorySetter Method (ilgen, property)

MandatorySetter Method (ilgen, property)
Namespaces ► StructureMap.Emitting.Parameters ► PrimitiveParameterEmitter ► MandatorySetter(ILGenerator, PropertyInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Parameters.PrimitiveParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public override void MandatorySetter(
    ILGenerator ilgen,
    PropertyInfo property
)
Public Overrides Sub MandatorySetter ( _
    ilgen As ILGenerator, _
    property As PropertyInfo _
)
public:
virtual void MandatorySetter(
    ILGenerator^ ilgen,
    PropertyInfo^ property
) override
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.Parameters.PrimitiveParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)"]

property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Emitting.Parameters.PrimitiveParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)"]


StringParameterEmitter Class

StringParameterEmitter Class
Namespaces ► StructureMap.Emitting.Parameters ► StringParameterEmitter
StructureMap API
Implementation of ParameterEmitter for string type constructor arguments
Declaration Syntax
C# Visual Basic Visual C++
public class StringParameterEmitter : ParameterEmitter
Public Class StringParameterEmitter _
    Inherits ParameterEmitter
public ref class StringParameterEmitter : public ParameterEmitter
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | StringParameterEmitter()()() | Initializes a new instance of the StringParameterEmitter class
 | cast(ILGenerator, Type) | (Inherited from ParameterEmitter.)
 | Ctor(ILGenerator, ParameterInfo) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MandatorySetter(ILGenerator, PropertyInfo) | (Overrides ParameterEmitter.MandatorySetter(ILGenerator, PropertyInfo).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | OptionalSetter(ILGenerator, PropertyInfo) | (Inherited from ParameterEmitter.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | ParameterEmitter
 |  | StringParameterEmitter


StringParameterEmitter Constructor

StringParameterEmitter Constructor
Namespaces ► StructureMap.Emitting.Parameters ► StringParameterEmitter ► StringParameterEmitter()()()
StructureMap API
Initializes a new instance of the StringParameterEmitter class
Declaration Syntax
C# Visual Basic Visual C++
public StringParameterEmitter()
Public Sub New
public:
StringParameterEmitter()


Ctor Method (ilgen, parameter)

Ctor Method (ilgen, parameter)
Namespaces ► StructureMap.Emitting.Parameters ► StringParameterEmitter ► Ctor(ILGenerator, ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Parameters.StringParameterEmitter.Ctor(System.Reflection.Emit.ILGenerator,System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void Ctor(
    ILGenerator ilgen,
    ParameterInfo parameter
)
Public Sub Ctor ( _
    ilgen As ILGenerator, _
    parameter As ParameterInfo _
)
public:
void Ctor(
    ILGenerator^ ilgen,
    ParameterInfo^ parameter
)
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.Parameters.StringParameterEmitter.Ctor(System.Reflection.Emit.ILGenerator,System.Reflection.ParameterInfo)"]

parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Emitting.Parameters.StringParameterEmitter.Ctor(System.Reflection.Emit.ILGenerator,System.Reflection.ParameterInfo)"]


MandatorySetter Method (ilgen, property)

MandatorySetter Method (ilgen, property)
Namespaces ► StructureMap.Emitting.Parameters ► StringParameterEmitter ► MandatorySetter(ILGenerator, PropertyInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Emitting.Parameters.StringParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public override void MandatorySetter(
    ILGenerator ilgen,
    PropertyInfo property
)
Public Overrides Sub MandatorySetter ( _
    ilgen As ILGenerator, _
    property As PropertyInfo _
)
public:
virtual void MandatorySetter(
    ILGenerator^ ilgen,
    PropertyInfo^ property
) override
Parameters
ilgen (ILGenerator)

[Missing <param name="ilgen"/> documentation for "M:StructureMap.Emitting.Parameters.StringParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)"]

property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Emitting.Parameters.StringParameterEmitter.MandatorySetter(System.Reflection.Emit.ILGenerator,System.Reflection.PropertyInfo)"]


StructureMap.Exceptions Namespace

StructureMap.Exceptions Namespace
Namespaces ► StructureMap.Exceptions
StructureMap API

[Missing <summary> documentation for N:StructureMap.Exceptions]

Declaration Syntax
C# Visual Basic Visual C++
namespace StructureMap.Exceptions
Namespace StructureMap.Exceptions
namespace StructureMap.Exceptions
Types
All Types Classes
Icon | Type | Description
 | InstancePropertyValueException | Thrown by IProperty classes when an invalid value is applied to a property of an InstanceGraph
 | MissingPluginFamilyException |
 | StructureMapConfigurationException |


InstancePropertyValueException Class

InstancePropertyValueException Class
Namespaces ► StructureMap.Exceptions ► InstancePropertyValueException
StructureMap API
Thrown by IProperty classes when an invalid value is applied to a property of an InstanceGraph
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class InstancePropertyValueException : ApplicationException
<SerializableAttribute> _
Public Class InstancePropertyValueException _
    Inherits ApplicationException
[SerializableAttribute]
public ref class InstancePropertyValueException : public ApplicationException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InstancePropertyValueException(String, Exception) | Initializes a new instance of the InstancePropertyValueException class
 | InstancePropertyValueException(SerializationInfo, StreamingContext) | Initializes a new instance of the InstancePropertyValueException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | InstancePropertyValueException


InstancePropertyValueException Constructor

InstancePropertyValueException Constructor
Namespaces ► StructureMap.Exceptions ► InstancePropertyValueException ► InstancePropertyValueException()()()
StructureMap API
Members
Icon | Member | Description
 | InstancePropertyValueException(String, Exception) | Initializes a new instance of the InstancePropertyValueException class
 | InstancePropertyValueException(SerializationInfo, StreamingContext) | Initializes a new instance of the InstancePropertyValueException class


InstancePropertyValueException Constructor (info, context)

InstancePropertyValueException Constructor (info, context)
Namespaces ► StructureMap.Exceptions ► InstancePropertyValueException ► InstancePropertyValueException(SerializationInfo, StreamingContext)
StructureMap API
Initializes a new instance of the InstancePropertyValueException class
Declaration Syntax
C# Visual Basic Visual C++
protected InstancePropertyValueException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
InstancePropertyValueException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)

[Missing <param name="info"/> documentation for "M:StructureMap.Exceptions.InstancePropertyValueException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context (StreamingContext)

[Missing <param name="context"/> documentation for "M:StructureMap.Exceptions.InstancePropertyValueException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]


InstancePropertyValueException Constructor (msg, ex)

InstancePropertyValueException Constructor (msg, ex)
Namespaces ► StructureMap.Exceptions ► InstancePropertyValueException ► InstancePropertyValueException(String, Exception)
StructureMap API
Initializes a new instance of the InstancePropertyValueException class
Declaration Syntax
C# Visual Basic Visual C++
public InstancePropertyValueException(
    string msg,
    Exception ex
)
Public Sub New ( _
    msg As String, _
    ex As Exception _
)
public:
InstancePropertyValueException(
    String^ msg,
    Exception^ ex
)
Parameters
msg (String)

[Missing <param name="msg"/> documentation for "M:StructureMap.Exceptions.InstancePropertyValueException.#ctor(System.String,System.Exception)"]

ex (Exception)

[Missing <param name="ex"/> documentation for "M:StructureMap.Exceptions.InstancePropertyValueException.#ctor(System.String,System.Exception)"]


MissingPluginFamilyException Class

MissingPluginFamilyException Class
Namespaces ► StructureMap.Exceptions ► MissingPluginFamilyException
StructureMap API

[Missing <summary> documentation for T:StructureMap.Exceptions.MissingPluginFamilyException]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class MissingPluginFamilyException : ApplicationException
<SerializableAttribute> _
Public Class MissingPluginFamilyException _
    Inherits ApplicationException
[SerializableAttribute]
public ref class MissingPluginFamilyException : public ApplicationException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MissingPluginFamilyException(String) | Initializes a new instance of the MissingPluginFamilyException class
 | MissingPluginFamilyException(SerializationInfo, StreamingContext) | Initializes a new instance of the MissingPluginFamilyException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | (Overrides Exception.GetObjectData(SerializationInfo, StreamingContext).)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | (Overrides Exception.Message.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | MissingPluginFamilyException


MissingPluginFamilyException Constructor

MissingPluginFamilyException Constructor
Namespaces ► StructureMap.Exceptions ► MissingPluginFamilyException ► MissingPluginFamilyException()()()
StructureMap API
Members
Icon | Member | Description
 | MissingPluginFamilyException(String) | Initializes a new instance of the MissingPluginFamilyException class
 | MissingPluginFamilyException(SerializationInfo, StreamingContext) | Initializes a new instance of the MissingPluginFamilyException class


MissingPluginFamilyException Constructor (info, context)

MissingPluginFamilyException Constructor (info, context)
Namespaces ► StructureMap.Exceptions ► MissingPluginFamilyException ► MissingPluginFamilyException(SerializationInfo, StreamingContext)
StructureMap API
Initializes a new instance of the MissingPluginFamilyException class
Declaration Syntax
C# Visual Basic Visual C++
protected MissingPluginFamilyException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
MissingPluginFamilyException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)

[Missing <param name="info"/> documentation for "M:StructureMap.Exceptions.MissingPluginFamilyException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context (StreamingContext)

[Missing <param name="context"/> documentation for "M:StructureMap.Exceptions.MissingPluginFamilyException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]


MissingPluginFamilyException Constructor (pluginTypeName)

MissingPluginFamilyException Constructor (pluginTypeName)
Namespaces ► StructureMap.Exceptions ► MissingPluginFamilyException ► MissingPluginFamilyException(String)
StructureMap API
Initializes a new instance of the MissingPluginFamilyException class
Declaration Syntax
C# Visual Basic Visual C++
public MissingPluginFamilyException(
    string pluginTypeName
)
Public Sub New ( _
    pluginTypeName As String _
)
public:
MissingPluginFamilyException(
    String^ pluginTypeName
)
Parameters
pluginTypeName (String)

[Missing <param name="pluginTypeName"/> documentation for "M:StructureMap.Exceptions.MissingPluginFamilyException.#ctor(System.String)"]


GetObjectData Method (info, context)

GetObjectData Method (info, context)
Namespaces ► StructureMap.Exceptions ► MissingPluginFamilyException ► GetObjectData(SerializationInfo, StreamingContext)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Exceptions.MissingPluginFamilyException.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)]

Declaration Syntax
C# Visual Basic Visual C++
public override void GetObjectData(
    SerializationInfo info,
    StreamingContext context
)
Public Overrides Sub GetObjectData ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
public:
virtual void GetObjectData(
    SerializationInfo^ info,
    StreamingContext context
) override
Parameters
info (SerializationInfo)

[Missing <param name="info"/> documentation for "M:StructureMap.Exceptions.MissingPluginFamilyException.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context (StreamingContext)

[Missing <param name="context"/> documentation for "M:StructureMap.Exceptions.MissingPluginFamilyException.GetObjectData(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]


Message Property

Message Property
Namespaces ► StructureMap.Exceptions ► MissingPluginFamilyException ► Message
StructureMap API

[Missing <summary> documentation for P:StructureMap.Exceptions.MissingPluginFamilyException.Message]

Declaration Syntax
C# Visual Basic Visual C++
public override string Message { get; }
Public Overrides ReadOnly Property Message As String
public:
virtual property String^ Message {
    String^ get () override;
}


StructureMapConfigurationException Class

StructureMapConfigurationException Class
Namespaces ► StructureMap.Exceptions ► StructureMapConfigurationException
StructureMap API

[Missing <summary> documentation for T:StructureMap.Exceptions.StructureMapConfigurationException]

Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class StructureMapConfigurationException : ApplicationException
<SerializableAttribute> _
Public Class StructureMapConfigurationException _
    Inherits ApplicationException
[SerializableAttribute]
public ref class StructureMapConfigurationException : public ApplicationException
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | StructureMapConfigurationException(String) | Initializes a new instance of the StructureMapConfigurationException class
 | StructureMapConfigurationException(SerializationInfo, StreamingContext) | Initializes a new instance of the StructureMapConfigurationException class
 | Data | Gets a collection of key/value pairs that provide additional user-defined information about the exception. (Inherited from Exception.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetBaseException()()() | When overridden in a derived class, returns the Exception that is the root cause of one or more subsequent exceptions. (Inherited from Exception.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetObjectData(SerializationInfo, StreamingContext) | When overridden in a derived class, sets the SerializationInfo with information about the exception. (Inherited from Exception.)
 | GetType()()() | Gets the runtime type of the current instance. (Inherited from Exception.)
 | HelpLink | Gets or sets a link to the help file associated with this exception. (Inherited from Exception.)
 | HResult | Gets or sets HRESULT, a coded numerical value that is assigned to a specific exception. (Inherited from Exception.)
 | InnerException | Gets the Exception instance that caused the current exception. (Inherited from Exception.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Message | Gets a message that describes the current exception. (Inherited from Exception.)
 | Source | Gets or sets the name of the application or the object that causes the error. (Inherited from Exception.)
 | StackTrace | Gets a string representation of the frames on the call stack at the time the current exception was thrown. (Inherited from Exception.)
 | TargetSite | Gets the method that throws the current exception. (Inherited from Exception.)
 | ToString()()() | Creates and returns a string representation of the current exception. (Inherited from Exception.)
Inheritance Hierarchy
Object
 | Exception
 |  | ApplicationException
 |  |  | StructureMapConfigurationException


StructureMapConfigurationException Constructor

StructureMapConfigurationException Constructor
Namespaces ► StructureMap.Exceptions ► StructureMapConfigurationException ► StructureMapConfigurationException()()()
StructureMap API
Members
Icon | Member | Description
 | StructureMapConfigurationException(String) | Initializes a new instance of the StructureMapConfigurationException class
 | StructureMapConfigurationException(SerializationInfo, StreamingContext) | Initializes a new instance of the StructureMapConfigurationException class


StructureMapConfigurationException Constructor (info, context)

StructureMapConfigurationException Constructor (info, context)
Namespaces ► StructureMap.Exceptions ► StructureMapConfigurationException ► StructureMapConfigurationException(SerializationInfo, StreamingContext)
StructureMap API
Initializes a new instance of the StructureMapConfigurationException class
Declaration Syntax
C# Visual Basic Visual C++
protected StructureMapConfigurationException(
    SerializationInfo info,
    StreamingContext context
)
Protected Sub New ( _
    info As SerializationInfo, _
    context As StreamingContext _
)
protected:
StructureMapConfigurationException(
    SerializationInfo^ info,
    StreamingContext context
)
Parameters
info (SerializationInfo)

[Missing <param name="info"/> documentation for "M:StructureMap.Exceptions.StructureMapConfigurationException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]

context (StreamingContext)

[Missing <param name="context"/> documentation for "M:StructureMap.Exceptions.StructureMapConfigurationException.#ctor(System.Runtime.Serialization.SerializationInfo,System.Runtime.Serialization.StreamingContext)"]


StructureMapConfigurationException Constructor (message)

StructureMapConfigurationException Constructor (message)
Namespaces ► StructureMap.Exceptions ► StructureMapConfigurationException ► StructureMapConfigurationException(String)
StructureMap API
Initializes a new instance of the StructureMapConfigurationException class
Declaration Syntax
C# Visual Basic Visual C++
public StructureMapConfigurationException(
    string message
)
Public Sub New ( _
    message As String _
)
public:
StructureMapConfigurationException(
    String^ message
)
Parameters
message (String)

[Missing <param name="message"/> documentation for "M:StructureMap.Exceptions.StructureMapConfigurationException.#ctor(System.String)"]


StructureMap.Graph Namespace

StructureMap.Graph Namespace
Namespaces ► StructureMap.Graph
StructureMap API

[Missing <summary> documentation for N:StructureMap.Graph]

Declaration Syntax
C# Visual Basic Visual C++
namespace StructureMap.Graph
Namespace StructureMap.Graph
namespace StructureMap.Graph
Types
All Types Classes Interfaces
Icon | Type | Description
 | AssemblyScanner |
 | Constructor |
 | DefaultConventionScanner |
 | FamilyAttributeScanner |
 | FindAllTypesFilter |
 | FindRegistriesScanner |
 | GenericsPluginGraph |
 | IArgumentVisitor |
 | IAssemblyScanner |
 | IPluginFamily |
 | IPluginGraph |
 | ITypeScanner |
 | PluggableAttributeScanner |
 | Plugin | Represents a concrete class that can be built by StructureMap as an instance of the parent PluginFamily’s PluginType. The properties of a Plugin are the CLR Type of the concrete class, and the human-friendly concrete key that StructureMap will use to identify the Type.
 | PluginCache |
 | PluginFamily | Conceptually speaking, a PluginFamily object represents a point of abstraction or variability in the system. A PluginFamily defines a CLR Type that StructureMap can build, and all of the possible Plugin’s implementing the CLR Type.
 | PluginFamilyCollection | Custom collection class for PluginFamily's
 | PluginGraph | Models the runtime configuration of a StructureMap Container
 | SetterProperty | Represents a PropertyInfo of a Plugin.PluggedType that is filled by Setter Injection
 | SetterPropertyCollection | Custom collection class for SetterProperty objects
 | TypeExtensions |
 | TypePath | Designates a CLR type that is loaded by name.
 | TypeRules |


AssemblyScanner Class

AssemblyScanner Class
Namespaces ► StructureMap.Graph ► AssemblyScanner
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.AssemblyScanner]

Declaration Syntax
C# Visual Basic Visual C++
public class AssemblyScanner : IAssemblyScanner
Public Class AssemblyScanner _
    Implements IAssemblyScanner
public ref class AssemblyScanner : IAssemblyScanner
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | AssemblyScanner()()() | Initializes a new instance of the AssemblyScanner class
 | AddAllTypesOf<(Of <(PLUGINTYPE>)>)()()() |
 | AddAllTypesOf(Type) |
 | AssembliesFromPath(String) |
 | AssembliesFromPath(String, Predicate<(Of <(Assembly>)>)) |
 | Assembly(Assembly) |
 | Assembly(String) |
 | AssemblyContainingType<(Of <(T>)>)()()() |
 | AssemblyContainingType(Type) |
 | Contains(String) |
 | Count |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exclude(Predicate<(Of <(Type>)>)) |
 | ExcludeNamespace(String) |
 | ExcludeNamespaceContainingType<(Of <(T>)>)()()() |
 | ExcludeType<(Of <(T>)>)()()() |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IgnoreStructureMapAttributes()()() |
 | Include(Predicate<(Of <(Type>)>)) |
 | IncludeNamespace(String) |
 | IncludeNamespaceContainingType<(Of <(T>)>)()()() |
 | LookForRegistries()()() |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | TheCallingAssembly()()() |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | With(ITypeScanner) |
 | With<(Of <(T>)>)()()() |
 | WithDefaultConventions()()() |
Inheritance Hierarchy
Object
AssemblyScanner


AssemblyScanner Constructor

AssemblyScanner Constructor
Namespaces ► StructureMap.Graph ► AssemblyScanner ► AssemblyScanner()()()
StructureMap API
Initializes a new instance of the AssemblyScanner class
Declaration Syntax
C# Visual Basic Visual C++
public AssemblyScanner()
Public Sub New
public:
AssemblyScanner()


AddAllTypesOf Method

AddAllTypesOf Method
Namespaces ► StructureMap.Graph ► AssemblyScanner ► AddAllTypesOf()()()
StructureMap API
Members
Icon | Member | Description
 | AddAllTypesOf<(Of <(PLUGINTYPE>)>)()()() |
 | AddAllTypesOf(Type) |


AddAllTypesOf Method

AddAllTypesOf<(Of <(PLUGINTYPE>)>) Method
Namespaces ► StructureMap.Graph ► AssemblyScanner ► AddAllTypesOf<(Of <(PLUGINTYPE>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.AddAllTypesOf``1]

Declaration Syntax
C# Visual Basic Visual C++
public void AddAllTypesOf<PLUGINTYPE>()

Public Sub AddAllTypesOf(Of PLUGINTYPE)
public:
generic<typename PLUGINTYPE>
virtual void AddAllTypesOf() sealed
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.Graph.AssemblyScanner.AddAllTypesOf``1"]


AddAllTypesOf Method (pluginType)

AddAllTypesOf Method (pluginType)
Namespaces ► StructureMap.Graph ► AssemblyScanner ► AddAllTypesOf(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.AddAllTypesOf(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddAllTypesOf(
    Type pluginType
)
Public Sub AddAllTypesOf ( _
    pluginType As Type _
)
public:
virtual void AddAllTypesOf(
    Type^ pluginType
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.AssemblyScanner.AddAllTypesOf(System.Type)"]


AssembliesFromPath Method

AssembliesFromPath Method
Namespaces ► StructureMap.Graph ► AssemblyScanner ► AssembliesFromPath()()()
StructureMap API
Members
Icon | Member | Description
 | AssembliesFromPath(String) |
 | AssembliesFromPath(String, Predicate<(Of <(Assembly>)>)) |


AssembliesFromPath Method (path)

AssembliesFromPath Method (path)
Namespaces ► StructureMap.Graph ► AssemblyScanner ► AssembliesFromPath(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.AssembliesFromPath(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void AssembliesFromPath(
    string path
)
Public Sub AssembliesFromPath ( _
    path As String _
)
public:
virtual void AssembliesFromPath(
    String^ path
) sealed
Parameters
path (String)

[Missing <param name="path"/> documentation for "M:StructureMap.Graph.AssemblyScanner.AssembliesFromPath(System.String)"]


AssembliesFromPath Method (path, assemblyFilter)

AssembliesFromPath Method (path, assemblyFilter)
Namespaces ► StructureMap.Graph ► AssemblyScanner ► AssembliesFromPath(String, Predicate<(Of <(Assembly>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.AssembliesFromPath(System.String,System.Predicate{System.Reflection.Assembly})]

Declaration Syntax
C# Visual Basic Visual C++
public void AssembliesFromPath(
    string path,
    Predicate<Assembly> assemblyFilter
)
Public Sub AssembliesFromPath ( _
    path As String, _
    assemblyFilter As Predicate(Of Assembly) _
)
public:
virtual void AssembliesFromPath(
    String^ path,
    Predicate<Assembly^>^ assemblyFilter
) sealed
Parameters
path (String)

[Missing <param name="path"/> documentation for "M:StructureMap.Graph.AssemblyScanner.AssembliesFromPath(System.String,System.Predicate{System.Reflection.Assembly})"]

assemblyFilter (Predicate <(Of <( Assembly >)>))

[Missing <param name="assemblyFilter"/> documentation for "M:StructureMap.Graph.AssemblyScanner.AssembliesFromPath(System.String,System.Predicate{System.Reflection.Assembly})"]


Assembly Method

Assembly Method
Namespaces ► StructureMap.Graph ► AssemblyScanner ► Assembly()()()
StructureMap API
Members
Icon | Member | Description
 | Assembly(Assembly) |
 | Assembly(String) |


Assembly Method (assembly)

Assembly Method (assembly)
Namespaces ► StructureMap.Graph ► AssemblyScanner ► Assembly(Assembly)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.Assembly(System.Reflection.Assembly)]

Declaration Syntax
C# Visual Basic Visual C++
public void Assembly(
    Assembly assembly
)
Public Sub Assembly ( _
    assembly As Assembly _
)
public:
virtual void Assembly(
    Assembly^ assembly
) sealed
Parameters
assembly (Assembly)

[Missing <param name="assembly"/> documentation for "M:StructureMap.Graph.AssemblyScanner.Assembly(System.Reflection.Assembly)"]


Assembly Method (assemblyName)

Assembly Method (assemblyName)
Namespaces ► StructureMap.Graph ► AssemblyScanner ► Assembly(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.Assembly(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void Assembly(
    string assemblyName
)
Public Sub Assembly ( _
    assemblyName As String _
)
public:
virtual void Assembly(
    String^ assemblyName
) sealed
Parameters
assemblyName (String)

[Missing <param name="assemblyName"/> documentation for "M:StructureMap.Graph.AssemblyScanner.Assembly(System.String)"]


AssemblyContainingType Method

AssemblyContainingType Method
Namespaces ► StructureMap.Graph ► AssemblyScanner ► AssemblyContainingType()()()
StructureMap API
Members
Icon | Member | Description
 | AssemblyContainingType<(Of <(T>)>)()()() |
 | AssemblyContainingType(Type) |


AssemblyContainingType Method

AssemblyContainingType<(Of <(T>)>) Method
Namespaces ► StructureMap.Graph ► AssemblyScanner ► AssemblyContainingType<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.AssemblyContainingType``1]

Declaration Syntax
C# Visual Basic Visual C++
public void AssemblyContainingType<T>()

Public Sub AssemblyContainingType(Of T)
public:
generic<typename T>
virtual void AssemblyContainingType() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Graph.AssemblyScanner.AssemblyContainingType``1"]


AssemblyContainingType Method (type)

AssemblyContainingType Method (type)
Namespaces ► StructureMap.Graph ► AssemblyScanner ► AssemblyContainingType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.AssemblyContainingType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public void AssemblyContainingType(
    Type type
)
Public Sub AssemblyContainingType ( _
    type As Type _
)
public:
virtual void AssemblyContainingType(
    Type^ type
) sealed
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.AssemblyScanner.AssemblyContainingType(System.Type)"]


Contains Method (assemblyName)

Contains Method (assemblyName)
Namespaces ► StructureMap.Graph ► AssemblyScanner ► Contains(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.Contains(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    string assemblyName
)
Public Function Contains ( _
    assemblyName As String _
) As Boolean
public:
bool Contains(
    String^ assemblyName
)
Parameters
assemblyName (String)

[Missing <param name="assemblyName"/> documentation for "M:StructureMap.Graph.AssemblyScanner.Contains(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.AssemblyScanner.Contains(System.String)]


Count Property

Count Property
Namespaces ► StructureMap.Graph ► AssemblyScanner ► Count
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.AssemblyScanner.Count]

Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
property int Count {
    int get ();
}


Exclude Method (exclude)

Exclude Method (exclude)
Namespaces ► StructureMap.Graph ► AssemblyScanner ► Exclude(Predicate<(Of <(Type>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.Exclude(System.Predicate{System.Type})]

Declaration Syntax
C# Visual Basic Visual C++
public void Exclude(
    Predicate<Type> exclude
)
Public Sub Exclude ( _
    exclude As Predicate(Of Type) _
)
public:
virtual void Exclude(
    Predicate<Type^>^ exclude
) sealed
Parameters
exclude (Predicate <(Of <( Type >)>))

[Missing <param name="exclude"/> documentation for "M:StructureMap.Graph.AssemblyScanner.Exclude(System.Predicate{System.Type})"]


ExcludeNamespace Method (nameSpace)

ExcludeNamespace Method (nameSpace)
Namespaces ► StructureMap.Graph ► AssemblyScanner ► ExcludeNamespace(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.ExcludeNamespace(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void ExcludeNamespace(
    string nameSpace
)
Public Sub ExcludeNamespace ( _
    nameSpace As String _
)
public:
virtual void ExcludeNamespace(
    String^ nameSpace
) sealed
Parameters
nameSpace (String)

[Missing <param name="nameSpace"/> documentation for "M:StructureMap.Graph.AssemblyScanner.ExcludeNamespace(System.String)"]


ExcludeNamespaceContainingType Method

ExcludeNamespaceContainingType<(Of <(T>)>) Method
Namespaces ► StructureMap.Graph ► AssemblyScanner ► ExcludeNamespaceContainingType<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.ExcludeNamespaceContainingType``1]

Declaration Syntax
C# Visual Basic Visual C++
public void ExcludeNamespaceContainingType<T>()

Public Sub ExcludeNamespaceContainingType(Of T)
public:
generic<typename T>
virtual void ExcludeNamespaceContainingType() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Graph.AssemblyScanner.ExcludeNamespaceContainingType``1"]


ExcludeType Method

ExcludeType<(Of <(T>)>) Method
Namespaces ► StructureMap.Graph ► AssemblyScanner ► ExcludeType<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.ExcludeType``1]

Declaration Syntax
C# Visual Basic Visual C++
public void ExcludeType<T>()

Public Sub ExcludeType(Of T)
public:
generic<typename T>
virtual void ExcludeType() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Graph.AssemblyScanner.ExcludeType``1"]


IgnoreStructureMapAttributes Method

IgnoreStructureMapAttributes Method
Namespaces ► StructureMap.Graph ► AssemblyScanner ► IgnoreStructureMapAttributes()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.IgnoreStructureMapAttributes]

Declaration Syntax
C# Visual Basic Visual C++
public void IgnoreStructureMapAttributes()
Public Sub IgnoreStructureMapAttributes
public:
virtual void IgnoreStructureMapAttributes() sealed


Include Method (predicate)

Include Method (predicate)
Namespaces ► StructureMap.Graph ► AssemblyScanner ► Include(Predicate<(Of <(Type>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.Include(System.Predicate{System.Type})]

Declaration Syntax
C# Visual Basic Visual C++
public void Include(
    Predicate<Type> predicate
)
Public Sub Include ( _
    predicate As Predicate(Of Type) _
)
public:
virtual void Include(
    Predicate<Type^>^ predicate
) sealed
Parameters
predicate (Predicate <(Of <( Type >)>))

[Missing <param name="predicate"/> documentation for "M:StructureMap.Graph.AssemblyScanner.Include(System.Predicate{System.Type})"]


IncludeNamespace Method (nameSpace)

IncludeNamespace Method (nameSpace)
Namespaces ► StructureMap.Graph ► AssemblyScanner ► IncludeNamespace(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.IncludeNamespace(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void IncludeNamespace(
    string nameSpace
)
Public Sub IncludeNamespace ( _
    nameSpace As String _
)
public:
virtual void IncludeNamespace(
    String^ nameSpace
) sealed
Parameters
nameSpace (String)

[Missing <param name="nameSpace"/> documentation for "M:StructureMap.Graph.AssemblyScanner.IncludeNamespace(System.String)"]


IncludeNamespaceContainingType Method

IncludeNamespaceContainingType<(Of <(T>)>) Method
Namespaces ► StructureMap.Graph ► AssemblyScanner ► IncludeNamespaceContainingType<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.IncludeNamespaceContainingType``1]

Declaration Syntax
C# Visual Basic Visual C++
public void IncludeNamespaceContainingType<T>()

Public Sub IncludeNamespaceContainingType(Of T)
public:
generic<typename T>
virtual void IncludeNamespaceContainingType() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Graph.AssemblyScanner.IncludeNamespaceContainingType``1"]


LookForRegistries Method

LookForRegistries Method
Namespaces ► StructureMap.Graph ► AssemblyScanner ► LookForRegistries()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.LookForRegistries]

Declaration Syntax
C# Visual Basic Visual C++
public void LookForRegistries()
Public Sub LookForRegistries
public:
virtual void LookForRegistries() sealed


TheCallingAssembly Method

TheCallingAssembly Method
Namespaces ► StructureMap.Graph ► AssemblyScanner ► TheCallingAssembly()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.TheCallingAssembly]

Declaration Syntax
C# Visual Basic Visual C++
public void TheCallingAssembly()
Public Sub TheCallingAssembly
public:
virtual void TheCallingAssembly() sealed


With Method

With Method
Namespaces ► StructureMap.Graph ► AssemblyScanner ► With()()()
StructureMap API
Members
Icon | Member | Description
 | With(ITypeScanner) |
 | With<(Of <(T>)>)()()() |


With Method

With<(Of <(T>)>) Method
Namespaces ► StructureMap.Graph ► AssemblyScanner ► With<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.With``1]

Declaration Syntax
C# Visual Basic Visual C++
public void With<T>()
where T : new(), ITypeScanner

Public Sub With(Of T As {New, ITypeScanner})
public:
generic<typename T>
where T : gcnew(), ITypeScanner
virtual void With() sealed
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Graph.AssemblyScanner.With``1"]


With Method (scanner)

With Method (scanner)
Namespaces ► StructureMap.Graph ► AssemblyScanner ► With(ITypeScanner)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.With(StructureMap.Graph.ITypeScanner)]

Declaration Syntax
C# Visual Basic Visual C++
public void With(
    ITypeScanner scanner
)
Public Sub With ( _
    scanner As ITypeScanner _
)
public:
virtual void With(
    ITypeScanner^ scanner
) sealed
Parameters
scanner (ITypeScanner)

[Missing <param name="scanner"/> documentation for "M:StructureMap.Graph.AssemblyScanner.With(StructureMap.Graph.ITypeScanner)"]


WithDefaultConventions Method

WithDefaultConventions Method
Namespaces ► StructureMap.Graph ► AssemblyScanner ► WithDefaultConventions()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.AssemblyScanner.WithDefaultConventions]

Declaration Syntax
C# Visual Basic Visual C++
public void WithDefaultConventions()
Public Sub WithDefaultConventions
public:
virtual void WithDefaultConventions() sealed


Constructor Class

Constructor Class
Namespaces ► StructureMap.Graph ► Constructor
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.Constructor]

Declaration Syntax
C# Visual Basic Visual C++
public class Constructor : TypeRules
Public Class Constructor _
    Inherits TypeRules
public ref class Constructor : public TypeRules
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Constructor(Type) | Initializes a new instance of the Constructor class
 | CanBeAutoFilled()()() |
 | Ctor |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindFirstConstructorArgumentOfType(Type) |
 | GetConstructor(Type) | Returns the System.Reflection.ConstructorInfo for the PluggedType. Uses either the "greediest" constructor with the most arguments or the constructor function marked with the [DefaultConstructor]
 | GetGreediestConstructor(Type) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasArguments()()() |
 | HasConstructors(Type) |
 | IsAutoFillable(Type) | (Inherited from TypeRules.)
 | IsChild(Type) | (Inherited from TypeRules.)
 | IsChildArray(Type) | (Inherited from TypeRules.)
 | IsConcrete(Type) | (Inherited from TypeRules.)
 | IsEnum(Type) | (Inherited from TypeRules.)
 | IsPrimitive(Type) | (Inherited from TypeRules.)
 | IsPrimitiveArray(Type) | (Inherited from TypeRules.)
 | IsSimple(Type) | (Inherited from TypeRules.)
 | IsString(Type) | (Inherited from TypeRules.)
 | IsValid()()() |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Visit(IArgumentVisitor) |
Inheritance Hierarchy
Object
 | TypeRules
 |  | Constructor


Constructor Constructor (pluggedType)

Constructor Constructor (pluggedType)
Namespaces ► StructureMap.Graph ► Constructor ► Constructor(Type)
StructureMap API
Initializes a new instance of the Constructor class
Declaration Syntax
C# Visual Basic Visual C++
public Constructor(
    Type pluggedType
)
Public Sub New ( _
    pluggedType As Type _
)
public:
Constructor(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.Constructor.#ctor(System.Type)"]


CanBeAutoFilled Method

CanBeAutoFilled Method
Namespaces ► StructureMap.Graph ► Constructor ► CanBeAutoFilled()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Constructor.CanBeAutoFilled]

Declaration Syntax
C# Visual Basic Visual C++
public bool CanBeAutoFilled()
Public Function CanBeAutoFilled As Boolean
public:
bool CanBeAutoFilled()
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Constructor.CanBeAutoFilled]


Ctor Property

Ctor Property
Namespaces ► StructureMap.Graph ► Constructor ► Ctor
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.Constructor.Ctor]

Declaration Syntax
C# Visual Basic Visual C++
public ConstructorInfo Ctor { get; }
Public ReadOnly Property Ctor As ConstructorInfo
public:
property ConstructorInfo^ Ctor {
    ConstructorInfo^ get ();
}


FindFirstConstructorArgumentOfType Method (type)

FindFirstConstructorArgumentOfType Method (type)
Namespaces ► StructureMap.Graph ► Constructor ► FindFirstConstructorArgumentOfType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Constructor.FindFirstConstructorArgumentOfType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public string FindFirstConstructorArgumentOfType(
    Type type
)
Public Function FindFirstConstructorArgumentOfType ( _
    type As Type _
) As String
public:
String^ FindFirstConstructorArgumentOfType(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.Constructor.FindFirstConstructorArgumentOfType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Constructor.FindFirstConstructorArgumentOfType(System.Type)]


GetConstructor Method (pluggedType)

GetConstructor Method (pluggedType)
Namespaces ► StructureMap.Graph ► Constructor ► GetConstructor(Type)
StructureMap API
Returns the System.Reflection.ConstructorInfo for the PluggedType. Uses either the "greediest" constructor with the most arguments or the constructor function marked with the [DefaultConstructor]
Declaration Syntax
C# Visual Basic Visual C++
public static ConstructorInfo GetConstructor(
    Type pluggedType
)
Public Shared Function GetConstructor ( _
    pluggedType As Type _
) As ConstructorInfo
public:
static ConstructorInfo^ GetConstructor(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.Constructor.GetConstructor(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Constructor.GetConstructor(System.Type)]


GetGreediestConstructor Method (pluggedType)

GetGreediestConstructor Method (pluggedType)
Namespaces ► StructureMap.Graph ► Constructor ► GetGreediestConstructor(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Constructor.GetGreediestConstructor(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public static ConstructorInfo GetGreediestConstructor(
    Type pluggedType
)
Public Shared Function GetGreediestConstructor ( _
    pluggedType As Type _
) As ConstructorInfo
public:
static ConstructorInfo^ GetGreediestConstructor(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.Constructor.GetGreediestConstructor(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Constructor.GetGreediestConstructor(System.Type)]


HasArguments Method

HasArguments Method
Namespaces ► StructureMap.Graph ► Constructor ► HasArguments()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Constructor.HasArguments]

Declaration Syntax
C# Visual Basic Visual C++
public bool HasArguments()
Public Function HasArguments As Boolean
public:
bool HasArguments()
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Constructor.HasArguments]


HasConstructors Method (pluggedType)

HasConstructors Method (pluggedType)
Namespaces ► StructureMap.Graph ► Constructor ► HasConstructors(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Constructor.HasConstructors(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool HasConstructors(
    Type pluggedType
)
Public Shared Function HasConstructors ( _
    pluggedType As Type _
) As Boolean
public:
static bool HasConstructors(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.Constructor.HasConstructors(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Constructor.HasConstructors(System.Type)]


IsValid Method

IsValid Method
Namespaces ► StructureMap.Graph ► Constructor ► IsValid()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Constructor.IsValid]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Constructor.IsValid]


Visit Method (visitor)

Visit Method (visitor)
Namespaces ► StructureMap.Graph ► Constructor ► Visit(IArgumentVisitor)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Constructor.Visit(StructureMap.Graph.IArgumentVisitor)]

Declaration Syntax
C# Visual Basic Visual C++
public void Visit(
    IArgumentVisitor visitor
)
Public Sub Visit ( _
    visitor As IArgumentVisitor _
)
public:
void Visit(
    IArgumentVisitor^ visitor
)
Parameters
visitor (IArgumentVisitor)

[Missing <param name="visitor"/> documentation for "M:StructureMap.Graph.Constructor.Visit(StructureMap.Graph.IArgumentVisitor)"]


DefaultConventionScanner Class

DefaultConventionScanner Class
Namespaces ► StructureMap.Graph ► DefaultConventionScanner
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.DefaultConventionScanner]

Declaration Syntax
C# Visual Basic Visual C++
public class DefaultConventionScanner : TypeRules,
    ITypeScanner
Public Class DefaultConventionScanner _
    Inherits TypeRules _
    Implements ITypeScanner
public ref class DefaultConventionScanner : public TypeRules,
    ITypeScanner
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | DefaultConventionScanner()()() | Initializes a new instance of the DefaultConventionScanner class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindPluginType(Type) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAutoFillable(Type) | (Inherited from TypeRules.)
 | IsChild(Type) | (Inherited from TypeRules.)
 | IsChildArray(Type) | (Inherited from TypeRules.)
 | IsConcrete(Type) | (Inherited from TypeRules.)
 | IsEnum(Type) | (Inherited from TypeRules.)
 | IsPrimitive(Type) | (Inherited from TypeRules.)
 | IsPrimitiveArray(Type) | (Inherited from TypeRules.)
 | IsSimple(Type) | (Inherited from TypeRules.)
 | IsString(Type) | (Inherited from TypeRules.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(Type, PluginGraph) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypeRules
 |  | DefaultConventionScanner


DefaultConventionScanner Constructor

DefaultConventionScanner Constructor
Namespaces ► StructureMap.Graph ► DefaultConventionScanner ► DefaultConventionScanner()()()
StructureMap API
Initializes a new instance of the DefaultConventionScanner class
Declaration Syntax
C# Visual Basic Visual C++
public DefaultConventionScanner()
Public Sub New
public:
DefaultConventionScanner()


FindPluginType Method (concreteType)

FindPluginType Method (concreteType)
Namespaces ► StructureMap.Graph ► DefaultConventionScanner ► FindPluginType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.DefaultConventionScanner.FindPluginType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public virtual Type FindPluginType(
    Type concreteType
)
Public Overridable Function FindPluginType ( _
    concreteType As Type _
) As Type
public:
virtual Type^ FindPluginType(
    Type^ concreteType
)
Parameters
concreteType (Type)

[Missing <param name="concreteType"/> documentation for "M:StructureMap.Graph.DefaultConventionScanner.FindPluginType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.DefaultConventionScanner.FindPluginType(System.Type)]


Process Method (type, graph)

Process Method (type, graph)
Namespaces ► StructureMap.Graph ► DefaultConventionScanner ► Process(Type, PluginGraph)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.DefaultConventionScanner.Process(System.Type,StructureMap.Graph.PluginGraph)]

Declaration Syntax
C# Visual Basic Visual C++
public void Process(
    Type type,
    PluginGraph graph
)
Public Sub Process ( _
    type As Type, _
    graph As PluginGraph _
)
public:
virtual void Process(
    Type^ type,
    PluginGraph^ graph
) sealed
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.DefaultConventionScanner.Process(System.Type,StructureMap.Graph.PluginGraph)"]

graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.Graph.DefaultConventionScanner.Process(System.Type,StructureMap.Graph.PluginGraph)"]


FamilyAttributeScanner Class

FamilyAttributeScanner Class
Namespaces ► StructureMap.Graph ► FamilyAttributeScanner
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.FamilyAttributeScanner]

Declaration Syntax
C# Visual Basic Visual C++
public class FamilyAttributeScanner : ITypeScanner
Public Class FamilyAttributeScanner _
    Implements ITypeScanner
public ref class FamilyAttributeScanner : ITypeScanner
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FamilyAttributeScanner()()() | Initializes a new instance of the FamilyAttributeScanner class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(Type, PluginGraph) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FamilyAttributeScanner


FamilyAttributeScanner Constructor

FamilyAttributeScanner Constructor
Namespaces ► StructureMap.Graph ► FamilyAttributeScanner ► FamilyAttributeScanner()()()
StructureMap API
Initializes a new instance of the FamilyAttributeScanner class
Declaration Syntax
C# Visual Basic Visual C++
public FamilyAttributeScanner()
Public Sub New
public:
FamilyAttributeScanner()


Process Method (type, graph)

Process Method (type, graph)
Namespaces ► StructureMap.Graph ► FamilyAttributeScanner ► Process(Type, PluginGraph)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.FamilyAttributeScanner.Process(System.Type,StructureMap.Graph.PluginGraph)]

Declaration Syntax
C# Visual Basic Visual C++
public void Process(
    Type type,
    PluginGraph graph
)
Public Sub Process ( _
    type As Type, _
    graph As PluginGraph _
)
public:
virtual void Process(
    Type^ type,
    PluginGraph^ graph
) sealed
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.FamilyAttributeScanner.Process(System.Type,StructureMap.Graph.PluginGraph)"]

graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.Graph.FamilyAttributeScanner.Process(System.Type,StructureMap.Graph.PluginGraph)"]


FindAllTypesFilter Class

FindAllTypesFilter Class
Namespaces ► StructureMap.Graph ► FindAllTypesFilter
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.FindAllTypesFilter]

Declaration Syntax
C# Visual Basic Visual C++
public class FindAllTypesFilter : TypeRules,
    ITypeScanner
Public Class FindAllTypesFilter _
    Inherits TypeRules _
    Implements ITypeScanner
public ref class FindAllTypesFilter : public TypeRules,
    ITypeScanner
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FindAllTypesFilter(Type) | Initializes a new instance of the FindAllTypesFilter class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAutoFillable(Type) | (Inherited from TypeRules.)
 | IsChild(Type) | (Inherited from TypeRules.)
 | IsChildArray(Type) | (Inherited from TypeRules.)
 | IsConcrete(Type) | (Inherited from TypeRules.)
 | IsEnum(Type) | (Inherited from TypeRules.)
 | IsPrimitive(Type) | (Inherited from TypeRules.)
 | IsPrimitiveArray(Type) | (Inherited from TypeRules.)
 | IsSimple(Type) | (Inherited from TypeRules.)
 | IsString(Type) | (Inherited from TypeRules.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(Type, PluginGraph) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypeRules
 |  | FindAllTypesFilter


FindAllTypesFilter Constructor (pluginType)

FindAllTypesFilter Constructor (pluginType)
Namespaces ► StructureMap.Graph ► FindAllTypesFilter ► FindAllTypesFilter(Type)
StructureMap API
Initializes a new instance of the FindAllTypesFilter class
Declaration Syntax
C# Visual Basic Visual C++
public FindAllTypesFilter(
    Type pluginType
)
Public Sub New ( _
    pluginType As Type _
)
public:
FindAllTypesFilter(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.FindAllTypesFilter.#ctor(System.Type)"]


Process Method (type, graph)

Process Method (type, graph)
Namespaces ► StructureMap.Graph ► FindAllTypesFilter ► Process(Type, PluginGraph)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.FindAllTypesFilter.Process(System.Type,StructureMap.Graph.PluginGraph)]

Declaration Syntax
C# Visual Basic Visual C++
public void Process(
    Type type,
    PluginGraph graph
)
Public Sub Process ( _
    type As Type, _
    graph As PluginGraph _
)
public:
virtual void Process(
    Type^ type,
    PluginGraph^ graph
) sealed
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.FindAllTypesFilter.Process(System.Type,StructureMap.Graph.PluginGraph)"]

graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.Graph.FindAllTypesFilter.Process(System.Type,StructureMap.Graph.PluginGraph)"]


FindRegistriesScanner Class

FindRegistriesScanner Class
Namespaces ► StructureMap.Graph ► FindRegistriesScanner
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.FindRegistriesScanner]

Declaration Syntax
C# Visual Basic Visual C++
public class FindRegistriesScanner : ITypeScanner
Public Class FindRegistriesScanner _
    Implements ITypeScanner
public ref class FindRegistriesScanner : ITypeScanner
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | FindRegistriesScanner()()() | Initializes a new instance of the FindRegistriesScanner class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(Type, PluginGraph) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
FindRegistriesScanner


FindRegistriesScanner Constructor

FindRegistriesScanner Constructor
Namespaces ► StructureMap.Graph ► FindRegistriesScanner ► FindRegistriesScanner()()()
StructureMap API
Initializes a new instance of the FindRegistriesScanner class
Declaration Syntax
C# Visual Basic Visual C++
public FindRegistriesScanner()
Public Sub New
public:
FindRegistriesScanner()


Process Method (type, graph)

Process Method (type, graph)
Namespaces ► StructureMap.Graph ► FindRegistriesScanner ► Process(Type, PluginGraph)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.FindRegistriesScanner.Process(System.Type,StructureMap.Graph.PluginGraph)]

Declaration Syntax
C# Visual Basic Visual C++
public void Process(
    Type type,
    PluginGraph graph
)
Public Sub Process ( _
    type As Type, _
    graph As PluginGraph _
)
public:
virtual void Process(
    Type^ type,
    PluginGraph^ graph
) sealed
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.FindRegistriesScanner.Process(System.Type,StructureMap.Graph.PluginGraph)"]

graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.Graph.FindRegistriesScanner.Process(System.Type,StructureMap.Graph.PluginGraph)"]


GenericsPluginGraph Class

GenericsPluginGraph Class
Namespaces ► StructureMap.Graph ► GenericsPluginGraph
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.GenericsPluginGraph]

Declaration Syntax
C# Visual Basic Visual C++
public class GenericsPluginGraph
Public Class GenericsPluginGraph
public ref class GenericsPluginGraph
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | GenericsPluginGraph()()() | Initializes a new instance of the GenericsPluginGraph class
 | AddFamily(PluginFamily) |
 | CanBeCast(Type, Type) |
 | CanBePluggedIntoGenericType(Type, Type, array<Type>[]()[]) |
 | CreateTemplatedClone(PluginFamily, array<Type>[]()[]) |
 | CreateTemplatedFamily(Type, ProfileManager) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Families |
 | FamilyCount |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindFamily(Type) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasFamily(Type) |
 | ImportFrom(GenericsPluginGraph) |
 | ImportFrom(PluginFamily) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
GenericsPluginGraph


GenericsPluginGraph Constructor

GenericsPluginGraph Constructor
Namespaces ► StructureMap.Graph ► GenericsPluginGraph ► GenericsPluginGraph()()()
StructureMap API
Initializes a new instance of the GenericsPluginGraph class
Declaration Syntax
C# Visual Basic Visual C++
public GenericsPluginGraph()
Public Sub New
public:
GenericsPluginGraph()


AddFamily Method (family)

AddFamily Method (family)
Namespaces ► StructureMap.Graph ► GenericsPluginGraph ► AddFamily(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.GenericsPluginGraph.AddFamily(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddFamily(
    PluginFamily family
)
Public Sub AddFamily ( _
    family As PluginFamily _
)
public:
void AddFamily(
    PluginFamily^ family
)
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Graph.GenericsPluginGraph.AddFamily(StructureMap.Graph.PluginFamily)"]


CanBeCast Method (pluginType, pluggedType)

CanBeCast Method (pluginType, pluggedType)
Namespaces ► StructureMap.Graph ► GenericsPluginGraph ► CanBeCast(Type, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.GenericsPluginGraph.CanBeCast(System.Type,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool CanBeCast(
    Type pluginType,
    Type pluggedType
)
Public Shared Function CanBeCast ( _
    pluginType As Type, _
    pluggedType As Type _
) As Boolean
public:
static bool CanBeCast(
    Type^ pluginType,
    Type^ pluggedType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.GenericsPluginGraph.CanBeCast(System.Type,System.Type)"]

pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.GenericsPluginGraph.CanBeCast(System.Type,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.GenericsPluginGraph.CanBeCast(System.Type,System.Type)]


CanBePluggedIntoGenericType Method (pluginType, pluggedType, templateTypes)

CanBePluggedIntoGenericType Method (pluginType, pluggedType, templateTypes)
Namespaces ► StructureMap.Graph ► GenericsPluginGraph ► CanBePluggedIntoGenericType(Type, Type, array<Type>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.GenericsPluginGraph.CanBePluggedIntoGenericType(System.Type,System.Type,System.Type[])]

Declaration Syntax
C# Visual Basic Visual C++
public static bool CanBePluggedIntoGenericType(
    Type pluginType,
    Type pluggedType,
    params Type[] templateTypes
)
Public Shared Function CanBePluggedIntoGenericType ( _
    pluginType As Type, _
    pluggedType As Type, _
    ParamArray templateTypes As Type() _
) As Boolean
public:
static bool CanBePluggedIntoGenericType(
    Type^ pluginType,
    Type^ pluggedType,
    ... array<Type^>^ templateTypes
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.GenericsPluginGraph.CanBePluggedIntoGenericType(System.Type,System.Type,System.Type[])"]

pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.GenericsPluginGraph.CanBePluggedIntoGenericType(System.Type,System.Type,System.Type[])"]

templateTypes (array< Type >[]()[])

[Missing <param name="templateTypes"/> documentation for "M:StructureMap.Graph.GenericsPluginGraph.CanBePluggedIntoGenericType(System.Type,System.Type,System.Type[])"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.GenericsPluginGraph.CanBePluggedIntoGenericType(System.Type,System.Type,System.Type[])]


CreateTemplatedClone Method (baseFamily, templateTypes)

CreateTemplatedClone Method (baseFamily, templateTypes)
Namespaces ► StructureMap.Graph ► GenericsPluginGraph ► CreateTemplatedClone(PluginFamily, array<Type>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.GenericsPluginGraph.CreateTemplatedClone(StructureMap.Graph.PluginFamily,System.Type[])]

Declaration Syntax
C# Visual Basic Visual C++
public static PluginFamily CreateTemplatedClone(
    PluginFamily baseFamily,
    params Type[] templateTypes
)
Public Shared Function CreateTemplatedClone ( _
    baseFamily As PluginFamily, _
    ParamArray templateTypes As Type() _
) As PluginFamily
public:
static PluginFamily^ CreateTemplatedClone(
    PluginFamily^ baseFamily,
    ... array<Type^>^ templateTypes
)
Parameters
baseFamily (PluginFamily)

[Missing <param name="baseFamily"/> documentation for "M:StructureMap.Graph.GenericsPluginGraph.CreateTemplatedClone(StructureMap.Graph.PluginFamily,System.Type[])"]

templateTypes (array< Type >[]()[])

[Missing <param name="templateTypes"/> documentation for "M:StructureMap.Graph.GenericsPluginGraph.CreateTemplatedClone(StructureMap.Graph.PluginFamily,System.Type[])"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.GenericsPluginGraph.CreateTemplatedClone(StructureMap.Graph.PluginFamily,System.Type[])]


CreateTemplatedFamily Method (templatedType, profileManager)

CreateTemplatedFamily Method (templatedType, profileManager)
Namespaces ► StructureMap.Graph ► GenericsPluginGraph ► CreateTemplatedFamily(Type, ProfileManager)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.GenericsPluginGraph.CreateTemplatedFamily(System.Type,StructureMap.Pipeline.ProfileManager)]

Declaration Syntax
C# Visual Basic Visual C++
public PluginFamily CreateTemplatedFamily(
    Type templatedType,
    ProfileManager profileManager
)
Public Function CreateTemplatedFamily ( _
    templatedType As Type, _
    profileManager As ProfileManager _
) As PluginFamily
public:
PluginFamily^ CreateTemplatedFamily(
    Type^ templatedType,
    ProfileManager^ profileManager
)
Parameters
templatedType (Type)

[Missing <param name="templatedType"/> documentation for "M:StructureMap.Graph.GenericsPluginGraph.CreateTemplatedFamily(System.Type,StructureMap.Pipeline.ProfileManager)"]

profileManager (ProfileManager)

[Missing <param name="profileManager"/> documentation for "M:StructureMap.Graph.GenericsPluginGraph.CreateTemplatedFamily(System.Type,StructureMap.Pipeline.ProfileManager)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.GenericsPluginGraph.CreateTemplatedFamily(System.Type,StructureMap.Pipeline.ProfileManager)]


Families Property

Families Property
Namespaces ► StructureMap.Graph ► GenericsPluginGraph ► Families
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.GenericsPluginGraph.Families]

Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<PluginTypeConfiguration> Families { get; }
Public ReadOnly Property Families As IEnumerable(Of PluginTypeConfiguration)
public:
property IEnumerable<PluginTypeConfiguration^>^ Families {
    IEnumerable<PluginTypeConfiguration^>^ get ();
}


FamilyCount Property

FamilyCount Property
Namespaces ► StructureMap.Graph ► GenericsPluginGraph ► FamilyCount
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.GenericsPluginGraph.FamilyCount]

Declaration Syntax
C# Visual Basic Visual C++
public int FamilyCount { get; }
Public ReadOnly Property FamilyCount As Integer
public:
property int FamilyCount {
    int get ();
}


FindFamily Method (pluginType)

FindFamily Method (pluginType)
Namespaces ► StructureMap.Graph ► GenericsPluginGraph ► FindFamily(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.GenericsPluginGraph.FindFamily(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public PluginFamily FindFamily(
    Type pluginType
)
Public Function FindFamily ( _
    pluginType As Type _
) As PluginFamily
public:
PluginFamily^ FindFamily(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.GenericsPluginGraph.FindFamily(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.GenericsPluginGraph.FindFamily(System.Type)]


HasFamily Method (pluginType)

HasFamily Method (pluginType)
Namespaces ► StructureMap.Graph ► GenericsPluginGraph ► HasFamily(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.GenericsPluginGraph.HasFamily(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public bool HasFamily(
    Type pluginType
)
Public Function HasFamily ( _
    pluginType As Type _
) As Boolean
public:
bool HasFamily(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.GenericsPluginGraph.HasFamily(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.GenericsPluginGraph.HasFamily(System.Type)]


ImportFrom Method

ImportFrom Method
Namespaces ► StructureMap.Graph ► GenericsPluginGraph ► ImportFrom()()()
StructureMap API
Members
Icon | Member | Description
 | ImportFrom(GenericsPluginGraph) |
 | ImportFrom(PluginFamily) |


ImportFrom Method (source)

ImportFrom Method (source)
Namespaces ► StructureMap.Graph ► GenericsPluginGraph ► ImportFrom(GenericsPluginGraph)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.GenericsPluginGraph.ImportFrom(StructureMap.Graph.GenericsPluginGraph)]

Declaration Syntax
C# Visual Basic Visual C++
public void ImportFrom(
    GenericsPluginGraph source
)
Public Sub ImportFrom ( _
    source As GenericsPluginGraph _
)
public:
void ImportFrom(
    GenericsPluginGraph^ source
)
Parameters
source (GenericsPluginGraph)

[Missing <param name="source"/> documentation for "M:StructureMap.Graph.GenericsPluginGraph.ImportFrom(StructureMap.Graph.GenericsPluginGraph)"]


ImportFrom Method (sourceFamily)

ImportFrom Method (sourceFamily)
Namespaces ► StructureMap.Graph ► GenericsPluginGraph ► ImportFrom(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.GenericsPluginGraph.ImportFrom(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
public void ImportFrom(
    PluginFamily sourceFamily
)
Public Sub ImportFrom ( _
    sourceFamily As PluginFamily _
)
public:
void ImportFrom(
    PluginFamily^ sourceFamily
)
Parameters
sourceFamily (PluginFamily)

[Missing <param name="sourceFamily"/> documentation for "M:StructureMap.Graph.GenericsPluginGraph.ImportFrom(StructureMap.Graph.PluginFamily)"]


IArgumentVisitor Interface

IArgumentVisitor Interface
Namespaces ► StructureMap.Graph ► IArgumentVisitor
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.IArgumentVisitor]

Declaration Syntax
C# Visual Basic Visual C++
public interface IArgumentVisitor
Public Interface IArgumentVisitor
public interface class IArgumentVisitor
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ChildArrayParameter(ParameterInfo) |
 | ChildArraySetter(PropertyInfo, Boolean) |
 | ChildParameter(ParameterInfo) |
 | ChildSetter(PropertyInfo, Boolean) |
 | EnumParameter(ParameterInfo) |
 | EnumSetter(PropertyInfo, Boolean) |
 | PrimitiveParameter(ParameterInfo) |
 | PrimitiveSetter(PropertyInfo, Boolean) |
 | StringParameter(ParameterInfo) |
 | StringSetter(PropertyInfo, Boolean) |


ChildArrayParameter Method (parameter)

ChildArrayParameter Method (parameter)
Namespaces ► StructureMap.Graph ► IArgumentVisitor ► ChildArrayParameter(ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.IArgumentVisitor.ChildArrayParameter(System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
void ChildArrayParameter(
    ParameterInfo parameter
)
Sub ChildArrayParameter ( _
    parameter As ParameterInfo _
)
void ChildArrayParameter(
    ParameterInfo^ parameter
)
Parameters
parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Graph.IArgumentVisitor.ChildArrayParameter(System.Reflection.ParameterInfo)"]


ChildArraySetter Method (property, isMandatory)

ChildArraySetter Method (property, isMandatory)
Namespaces ► StructureMap.Graph ► IArgumentVisitor ► ChildArraySetter(PropertyInfo, Boolean)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.IArgumentVisitor.ChildArraySetter(System.Reflection.PropertyInfo,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
void ChildArraySetter(
    PropertyInfo property,
    bool isMandatory
)
Sub ChildArraySetter ( _
    property As PropertyInfo, _
    isMandatory As Boolean _
)
void ChildArraySetter(
    PropertyInfo^ property,
    bool isMandatory
)
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Graph.IArgumentVisitor.ChildArraySetter(System.Reflection.PropertyInfo,System.Boolean)"]

isMandatory (Boolean)

[Missing <param name="isMandatory"/> documentation for "M:StructureMap.Graph.IArgumentVisitor.ChildArraySetter(System.Reflection.PropertyInfo,System.Boolean)"]


ChildParameter Method (parameter)

ChildParameter Method (parameter)
Namespaces ► StructureMap.Graph ► IArgumentVisitor ► ChildParameter(ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.IArgumentVisitor.ChildParameter(System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
void ChildParameter(
    ParameterInfo parameter
)
Sub ChildParameter ( _
    parameter As ParameterInfo _
)
void ChildParameter(
    ParameterInfo^ parameter
)
Parameters
parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Graph.IArgumentVisitor.ChildParameter(System.Reflection.ParameterInfo)"]


ChildSetter Method (property, isMandatory)

ChildSetter Method (property, isMandatory)
Namespaces ► StructureMap.Graph ► IArgumentVisitor ► ChildSetter(PropertyInfo, Boolean)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.IArgumentVisitor.ChildSetter(System.Reflection.PropertyInfo,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
void ChildSetter(
    PropertyInfo property,
    bool isMandatory
)
Sub ChildSetter ( _
    property As PropertyInfo, _
    isMandatory As Boolean _
)
void ChildSetter(
    PropertyInfo^ property,
    bool isMandatory
)
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Graph.IArgumentVisitor.ChildSetter(System.Reflection.PropertyInfo,System.Boolean)"]

isMandatory (Boolean)

[Missing <param name="isMandatory"/> documentation for "M:StructureMap.Graph.IArgumentVisitor.ChildSetter(System.Reflection.PropertyInfo,System.Boolean)"]


EnumParameter Method (parameter)

EnumParameter Method (parameter)
Namespaces ► StructureMap.Graph ► IArgumentVisitor ► EnumParameter(ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.IArgumentVisitor.EnumParameter(System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
void EnumParameter(
    ParameterInfo parameter
)
Sub EnumParameter ( _
    parameter As ParameterInfo _
)
void EnumParameter(
    ParameterInfo^ parameter
)
Parameters
parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Graph.IArgumentVisitor.EnumParameter(System.Reflection.ParameterInfo)"]


EnumSetter Method (property, isMandatory)

EnumSetter Method (property, isMandatory)
Namespaces ► StructureMap.Graph ► IArgumentVisitor ► EnumSetter(PropertyInfo, Boolean)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.IArgumentVisitor.EnumSetter(System.Reflection.PropertyInfo,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
void EnumSetter(
    PropertyInfo property,
    bool isMandatory
)
Sub EnumSetter ( _
    property As PropertyInfo, _
    isMandatory As Boolean _
)
void EnumSetter(
    PropertyInfo^ property,
    bool isMandatory
)
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Graph.IArgumentVisitor.EnumSetter(System.Reflection.PropertyInfo,System.Boolean)"]

isMandatory (Boolean)

[Missing <param name="isMandatory"/> documentation for "M:StructureMap.Graph.IArgumentVisitor.EnumSetter(System.Reflection.PropertyInfo,System.Boolean)"]


PrimitiveParameter Method (parameter)

PrimitiveParameter Method (parameter)
Namespaces ► StructureMap.Graph ► IArgumentVisitor ► PrimitiveParameter(ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.IArgumentVisitor.PrimitiveParameter(System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
void PrimitiveParameter(
    ParameterInfo parameter
)
Sub PrimitiveParameter ( _
    parameter As ParameterInfo _
)
void PrimitiveParameter(
    ParameterInfo^ parameter
)
Parameters
parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Graph.IArgumentVisitor.PrimitiveParameter(System.Reflection.ParameterInfo)"]


PrimitiveSetter Method (property, isMandatory)

PrimitiveSetter Method (property, isMandatory)
Namespaces ► StructureMap.Graph ► IArgumentVisitor ► PrimitiveSetter(PropertyInfo, Boolean)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.IArgumentVisitor.PrimitiveSetter(System.Reflection.PropertyInfo,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
void PrimitiveSetter(
    PropertyInfo property,
    bool isMandatory
)
Sub PrimitiveSetter ( _
    property As PropertyInfo, _
    isMandatory As Boolean _
)
void PrimitiveSetter(
    PropertyInfo^ property,
    bool isMandatory
)
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Graph.IArgumentVisitor.PrimitiveSetter(System.Reflection.PropertyInfo,System.Boolean)"]

isMandatory (Boolean)

[Missing <param name="isMandatory"/> documentation for "M:StructureMap.Graph.IArgumentVisitor.PrimitiveSetter(System.Reflection.PropertyInfo,System.Boolean)"]


StringParameter Method (parameter)

StringParameter Method (parameter)
Namespaces ► StructureMap.Graph ► IArgumentVisitor ► StringParameter(ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.IArgumentVisitor.StringParameter(System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
void StringParameter(
    ParameterInfo parameter
)
Sub StringParameter ( _
    parameter As ParameterInfo _
)
void StringParameter(
    ParameterInfo^ parameter
)
Parameters
parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Graph.IArgumentVisitor.StringParameter(System.Reflection.ParameterInfo)"]


StringSetter Method (property, isMandatory)

StringSetter Method (property, isMandatory)
Namespaces ► StructureMap.Graph ► IArgumentVisitor ► StringSetter(PropertyInfo, Boolean)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.IArgumentVisitor.StringSetter(System.Reflection.PropertyInfo,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
void StringSetter(
    PropertyInfo property,
    bool isMandatory
)
Sub StringSetter ( _
    property As PropertyInfo, _
    isMandatory As Boolean _
)
void StringSetter(
    PropertyInfo^ property,
    bool isMandatory
)
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Graph.IArgumentVisitor.StringSetter(System.Reflection.PropertyInfo,System.Boolean)"]

isMandatory (Boolean)

[Missing <param name="isMandatory"/> documentation for "M:StructureMap.Graph.IArgumentVisitor.StringSetter(System.Reflection.PropertyInfo,System.Boolean)"]


IAssemblyScanner Interface

IAssemblyScanner Interface
Namespaces ► StructureMap.Graph ► IAssemblyScanner
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.IAssemblyScanner]

Declaration Syntax
C# Visual Basic Visual C++
public interface IAssemblyScanner
Public Interface IAssemblyScanner
public interface class IAssemblyScanner
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddAllTypesOf<(Of <(PLUGINTYPE>)>)()()() | Add all concrete types of the Plugin Type as Instances of Plugin Type
 | AddAllTypesOf(Type) | Add all concrete types of the Plugin Type as Instances of Plugin Type
 | AssembliesFromPath(String) | Sweep the designated path and add any Assembly's found in this folder to the scanning operation
 | AssembliesFromPath(String, Predicate<(Of <(Assembly>)>)) | Sweep the designated path and add any Assembly's found in this folder to the scanning operation. The assemblyFilter can be used to filter or limit the Assembly's that are picked up.
 | Assembly(Assembly) | Add an Assembly to the scanning operation
 | Assembly(String) | Add an Assembly by name to the scanning operation
 | AssemblyContainingType<(Of <(T>)>)()()() | Add the Assembly that contains type T to the scanning operation
 | AssemblyContainingType(Type) | Add the Assembly that contains type to the scanning operation
 | Exclude(Predicate<(Of <(Type>)>)) | Exclude types that match the Predicate from being scanned
 | ExcludeNamespace(String) | Exclude all types in this nameSpace or its children from the scanning operation
 | ExcludeNamespaceContainingType<(Of <(T>)>)()()() | Exclude all types in this nameSpace or its children from the scanning operation
 | ExcludeType<(Of <(T>)>)()()() | Exclude this specific type from the scanning operation
 | IgnoreStructureMapAttributes()()() | Makes this scanning operation ignore all [PluginFamily] and [Pluggable] attributes
 | Include(Predicate<(Of <(Type>)>)) | Only include types matching the Predicate in the scanning operation. You can use multiple Include() calls in a single scanning operation
 | IncludeNamespace(String) | Only include types from this nameSpace or its children in the scanning operation. You can use multiple Include() calls in a single scanning operation
 | IncludeNamespaceContainingType<(Of <(T>)>)()()() | Only include types from this nameSpace or its children in the scanning operation. You can use multiple Include() calls in a single scanning operation
 | LookForRegistries()()() | Directs the scanning operation to automatically detect and include any Registry classes found in the Assembly's being scanned
 | TheCallingAssembly()()() | Add the currently executing Assembly to the scanning operation
 | With(ITypeScanner) | Adds an ITypeScanner object to the scanning operation
 | With<(Of <(T>)>)()()() | Creates and adds a new ITypeScanner of type T to this scanning operation
 | WithDefaultConventions()()() | Adds the DefaultConventionScanner to the scanning operations. I.e., a concrete class named "Something" that implements "ISomething" will be automatically added to PluginType "ISomething"


AddAllTypesOf Method

AddAllTypesOf Method
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► AddAllTypesOf()()()
StructureMap API
Members
Icon | Member | Description
 | AddAllTypesOf<(Of <(PLUGINTYPE>)>)()()() | Add all concrete types of the Plugin Type as Instances of Plugin Type
 | AddAllTypesOf(Type) | Add all concrete types of the Plugin Type as Instances of Plugin Type


AddAllTypesOf Method

AddAllTypesOf<(Of <(PLUGINTYPE>)>) Method
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► AddAllTypesOf<(Of <(PLUGINTYPE>)>)()()()
StructureMap API
Add all concrete types of the Plugin Type as Instances of Plugin Type
Declaration Syntax
C# Visual Basic Visual C++
void AddAllTypesOf<PLUGINTYPE>()

Sub AddAllTypesOf(Of PLUGINTYPE)
generic<typename PLUGINTYPE>
void AddAllTypesOf()
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.AddAllTypesOf``1"]


AddAllTypesOf Method (pluginType)

AddAllTypesOf Method (pluginType)
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► AddAllTypesOf(Type)
StructureMap API
Add all concrete types of the Plugin Type as Instances of Plugin Type
Declaration Syntax
C# Visual Basic Visual C++
void AddAllTypesOf(
    Type pluginType
)
Sub AddAllTypesOf ( _
    pluginType As Type _
)
void AddAllTypesOf(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.AddAllTypesOf(System.Type)"]


AssembliesFromPath Method

AssembliesFromPath Method
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► AssembliesFromPath()()()
StructureMap API
Members
Icon | Member | Description
 | AssembliesFromPath(String) | Sweep the designated path and add any Assembly's found in this folder to the scanning operation
 | AssembliesFromPath(String, Predicate<(Of <(Assembly>)>)) | Sweep the designated path and add any Assembly's found in this folder to the scanning operation. The assemblyFilter can be used to filter or limit the Assembly's that are picked up.


AssembliesFromPath Method (path)

AssembliesFromPath Method (path)
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► AssembliesFromPath(String)
StructureMap API
Sweep the designated path and add any Assembly's found in this folder to the scanning operation
Declaration Syntax
C# Visual Basic Visual C++
void AssembliesFromPath(
    string path
)
Sub AssembliesFromPath ( _
    path As String _
)
void AssembliesFromPath(
    String^ path
)
Parameters
path (String)

[Missing <param name="path"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.AssembliesFromPath(System.String)"]


AssembliesFromPath Method (path, assemblyFilter)

AssembliesFromPath Method (path, assemblyFilter)
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► AssembliesFromPath(String, Predicate<(Of <(Assembly>)>))
StructureMap API
Sweep the designated path and add any Assembly's found in this folder to the scanning operation. The assemblyFilter can be used to filter or limit the Assembly's that are picked up.
Declaration Syntax
C# Visual Basic Visual C++
void AssembliesFromPath(
    string path,
    Predicate<Assembly> assemblyFilter
)
Sub AssembliesFromPath ( _
    path As String, _
    assemblyFilter As Predicate(Of Assembly) _
)
void AssembliesFromPath(
    String^ path,
    Predicate<Assembly^>^ assemblyFilter
)
Parameters
path (String)

[Missing <param name="path"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.AssembliesFromPath(System.String,System.Predicate{System.Reflection.Assembly})"]

assemblyFilter (Predicate <(Of <( Assembly >)>))

[Missing <param name="assemblyFilter"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.AssembliesFromPath(System.String,System.Predicate{System.Reflection.Assembly})"]


Assembly Method

Assembly Method
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► Assembly()()()
StructureMap API
Members
Icon | Member | Description
 | Assembly(Assembly) | Add an Assembly to the scanning operation
 | Assembly(String) | Add an Assembly by name to the scanning operation


Assembly Method (assembly)

Assembly Method (assembly)
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► Assembly(Assembly)
StructureMap API
Add an Assembly to the scanning operation
Declaration Syntax
C# Visual Basic Visual C++
void Assembly(
    Assembly assembly
)
Sub Assembly ( _
    assembly As Assembly _
)
void Assembly(
    Assembly^ assembly
)
Parameters
assembly (Assembly)

[Missing <param name="assembly"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.Assembly(System.Reflection.Assembly)"]


Assembly Method (assemblyName)

Assembly Method (assemblyName)
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► Assembly(String)
StructureMap API
Add an Assembly by name to the scanning operation
Declaration Syntax
C# Visual Basic Visual C++
void Assembly(
    string assemblyName
)
Sub Assembly ( _
    assemblyName As String _
)
void Assembly(
    String^ assemblyName
)
Parameters
assemblyName (String)

[Missing <param name="assemblyName"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.Assembly(System.String)"]


AssemblyContainingType Method

AssemblyContainingType Method
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► AssemblyContainingType()()()
StructureMap API
Members
Icon | Member | Description
 | AssemblyContainingType<(Of <(T>)>)()()() | Add the Assembly that contains type T to the scanning operation
 | AssemblyContainingType(Type) | Add the Assembly that contains type to the scanning operation


AssemblyContainingType Method

AssemblyContainingType<(Of <(T>)>) Method
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► AssemblyContainingType<(Of <(T>)>)()()()
StructureMap API
Add the Assembly that contains type T to the scanning operation
Declaration Syntax
C# Visual Basic Visual C++
void AssemblyContainingType<T>()

Sub AssemblyContainingType(Of T)
generic<typename T>
void AssemblyContainingType()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.AssemblyContainingType``1"]


AssemblyContainingType Method (type)

AssemblyContainingType Method (type)
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► AssemblyContainingType(Type)
StructureMap API
Add the Assembly that contains type to the scanning operation
Declaration Syntax
C# Visual Basic Visual C++
void AssemblyContainingType(
    Type type
)
Sub AssemblyContainingType ( _
    type As Type _
)
void AssemblyContainingType(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.AssemblyContainingType(System.Type)"]


Exclude Method (exclude)

Exclude Method (exclude)
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► Exclude(Predicate<(Of <(Type>)>))
StructureMap API
Exclude types that match the Predicate from being scanned
Declaration Syntax
C# Visual Basic Visual C++
void Exclude(
    Predicate<Type> exclude
)
Sub Exclude ( _
    exclude As Predicate(Of Type) _
)
void Exclude(
    Predicate<Type^>^ exclude
)
Parameters
exclude (Predicate <(Of <( Type >)>))

[Missing <param name="exclude"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.Exclude(System.Predicate{System.Type})"]


ExcludeNamespace Method (nameSpace)

ExcludeNamespace Method (nameSpace)
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► ExcludeNamespace(String)
StructureMap API
Exclude all types in this nameSpace or its children from the scanning operation
Declaration Syntax
C# Visual Basic Visual C++
void ExcludeNamespace(
    string nameSpace
)
Sub ExcludeNamespace ( _
    nameSpace As String _
)
void ExcludeNamespace(
    String^ nameSpace
)
Parameters
nameSpace (String)

[Missing <param name="nameSpace"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.ExcludeNamespace(System.String)"]


ExcludeNamespaceContainingType Method

ExcludeNamespaceContainingType<(Of <(T>)>) Method
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► ExcludeNamespaceContainingType<(Of <(T>)>)()()()
StructureMap API
Exclude all types in this nameSpace or its children from the scanning operation
Declaration Syntax
C# Visual Basic Visual C++
void ExcludeNamespaceContainingType<T>()

Sub ExcludeNamespaceContainingType(Of T)
generic<typename T>
void ExcludeNamespaceContainingType()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.ExcludeNamespaceContainingType``1"]


ExcludeType Method

ExcludeType<(Of <(T>)>) Method
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► ExcludeType<(Of <(T>)>)()()()
StructureMap API
Exclude this specific type from the scanning operation
Declaration Syntax
C# Visual Basic Visual C++
void ExcludeType<T>()

Sub ExcludeType(Of T)
generic<typename T>
void ExcludeType()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.ExcludeType``1"]


IgnoreStructureMapAttributes Method

IgnoreStructureMapAttributes Method
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► IgnoreStructureMapAttributes()()()
StructureMap API
Makes this scanning operation ignore all [PluginFamily] and [Pluggable] attributes
Declaration Syntax
C# Visual Basic Visual C++
void IgnoreStructureMapAttributes()
Sub IgnoreStructureMapAttributes
void IgnoreStructureMapAttributes()


Include Method (predicate)

Include Method (predicate)
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► Include(Predicate<(Of <(Type>)>))
StructureMap API
Only include types matching the Predicate in the scanning operation. You can use multiple Include() calls in a single scanning operation
Declaration Syntax
C# Visual Basic Visual C++
void Include(
    Predicate<Type> predicate
)
Sub Include ( _
    predicate As Predicate(Of Type) _
)
void Include(
    Predicate<Type^>^ predicate
)
Parameters
predicate (Predicate <(Of <( Type >)>))

[Missing <param name="predicate"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.Include(System.Predicate{System.Type})"]


IncludeNamespace Method (nameSpace)

IncludeNamespace Method (nameSpace)
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► IncludeNamespace(String)
StructureMap API
Only include types from this nameSpace or its children in the scanning operation. You can use multiple Include() calls in a single scanning operation
Declaration Syntax
C# Visual Basic Visual C++
void IncludeNamespace(
    string nameSpace
)
Sub IncludeNamespace ( _
    nameSpace As String _
)
void IncludeNamespace(
    String^ nameSpace
)
Parameters
nameSpace (String)

[Missing <param name="nameSpace"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.IncludeNamespace(System.String)"]


IncludeNamespaceContainingType Method

IncludeNamespaceContainingType<(Of <(T>)>) Method
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► IncludeNamespaceContainingType<(Of <(T>)>)()()()
StructureMap API
Only include types from this nameSpace or its children in the scanning operation. You can use multiple Include() calls in a single scanning operation
Declaration Syntax
C# Visual Basic Visual C++
void IncludeNamespaceContainingType<T>()

Sub IncludeNamespaceContainingType(Of T)
generic<typename T>
void IncludeNamespaceContainingType()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.IncludeNamespaceContainingType``1"]


LookForRegistries Method

LookForRegistries Method
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► LookForRegistries()()()
StructureMap API
Directs the scanning operation to automatically detect and include any Registry classes found in the Assembly's being scanned
Declaration Syntax
C# Visual Basic Visual C++
void LookForRegistries()
Sub LookForRegistries
void LookForRegistries()


TheCallingAssembly Method

TheCallingAssembly Method
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► TheCallingAssembly()()()
StructureMap API
Add the currently executing Assembly to the scanning operation
Declaration Syntax
C# Visual Basic Visual C++
void TheCallingAssembly()
Sub TheCallingAssembly
void TheCallingAssembly()


With Method

With Method
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► With()()()
StructureMap API
Members
Icon | Member | Description
 | With(ITypeScanner) | Adds an ITypeScanner object to the scanning operation
 | With<(Of <(T>)>)()()() | Creates and adds a new ITypeScanner of type T to this scanning operation


With Method

With<(Of <(T>)>) Method
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► With<(Of <(T>)>)()()()
StructureMap API
Creates and adds a new ITypeScanner of type T to this scanning operation
Declaration Syntax
C# Visual Basic Visual C++
void With<T>()
where T : new(), ITypeScanner

Sub With(Of T As {New, ITypeScanner})
generic<typename T>
where T : gcnew(), ITypeScanner
void With()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.With``1"]


With Method (scanner)

With Method (scanner)
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► With(ITypeScanner)
StructureMap API
Adds an ITypeScanner object to the scanning operation
Declaration Syntax
C# Visual Basic Visual C++
void With(
    ITypeScanner scanner
)
Sub With ( _
    scanner As ITypeScanner _
)
void With(
    ITypeScanner^ scanner
)
Parameters
scanner (ITypeScanner)

[Missing <param name="scanner"/> documentation for "M:StructureMap.Graph.IAssemblyScanner.With(StructureMap.Graph.ITypeScanner)"]


WithDefaultConventions Method

WithDefaultConventions Method
Namespaces ► StructureMap.Graph ► IAssemblyScanner ► WithDefaultConventions()()()
StructureMap API
Adds the DefaultConventionScanner to the scanning operations. I.e., a concrete class named "Something" that implements "ISomething" will be automatically added to PluginType "ISomething"
Declaration Syntax
C# Visual Basic Visual C++
void WithDefaultConventions()
Sub WithDefaultConventions
void WithDefaultConventions()


IPluginFamily Interface

IPluginFamily Interface
Namespaces ► StructureMap.Graph ► IPluginFamily
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.IPluginFamily]

Declaration Syntax
C# Visual Basic Visual C++
public interface IPluginFamily
Public Interface IPluginFamily
public interface class IPluginFamily
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddInterceptor(IBuildInterceptor) |
 | AddMementoSource(MementoSource) |
 | DefaultInstanceKey | The InstanceKey of the default instance of the PluginFamily
 | PluginType | The CLR Type that defines the "Plugin" interface for the PluginFamily
 | SetScopeTo(InstanceScope) |


AddInterceptor Method (interceptor)

AddInterceptor Method (interceptor)
Namespaces ► StructureMap.Graph ► IPluginFamily ► AddInterceptor(IBuildInterceptor)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.IPluginFamily.AddInterceptor(StructureMap.Pipeline.IBuildInterceptor)]

Declaration Syntax
C# Visual Basic Visual C++
void AddInterceptor(
    IBuildInterceptor interceptor
)
Sub AddInterceptor ( _
    interceptor As IBuildInterceptor _
)
void AddInterceptor(
    IBuildInterceptor^ interceptor
)
Parameters
interceptor (IBuildInterceptor)

[Missing <param name="interceptor"/> documentation for "M:StructureMap.Graph.IPluginFamily.AddInterceptor(StructureMap.Pipeline.IBuildInterceptor)"]


AddMementoSource Method (source)

AddMementoSource Method (source)
Namespaces ► StructureMap.Graph ► IPluginFamily ► AddMementoSource(MementoSource)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.IPluginFamily.AddMementoSource(StructureMap.MementoSource)]

Declaration Syntax
C# Visual Basic Visual C++
void AddMementoSource(
    MementoSource source
)
Sub AddMementoSource ( _
    source As MementoSource _
)
void AddMementoSource(
    MementoSource^ source
)
Parameters
source (MementoSource)

[Missing <param name="source"/> documentation for "M:StructureMap.Graph.IPluginFamily.AddMementoSource(StructureMap.MementoSource)"]


DefaultInstanceKey Property

DefaultInstanceKey Property
Namespaces ► StructureMap.Graph ► IPluginFamily ► DefaultInstanceKey
StructureMap API
The InstanceKey of the default instance of the PluginFamily
Declaration Syntax
C# Visual Basic Visual C++
string DefaultInstanceKey { get; set; }
Property DefaultInstanceKey As String
property String^ DefaultInstanceKey {
    String^ get ();
    void set (String^ value);
}


PluginType Property

PluginType Property
Namespaces ► StructureMap.Graph ► IPluginFamily ► PluginType
StructureMap API
The CLR Type that defines the "Plugin" interface for the PluginFamily
Declaration Syntax
C# Visual Basic Visual C++
Type PluginType { get; }
ReadOnly Property PluginType As Type
property Type^ PluginType {
    Type^ get ();
}


SetScopeTo Method (scope)

SetScopeTo Method (scope)
Namespaces ► StructureMap.Graph ► IPluginFamily ► SetScopeTo(InstanceScope)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.IPluginFamily.SetScopeTo(StructureMap.Attributes.InstanceScope)]

Declaration Syntax
C# Visual Basic Visual C++
void SetScopeTo(
    InstanceScope scope
)
Sub SetScopeTo ( _
    scope As InstanceScope _
)
void SetScopeTo(
    InstanceScope scope
)
Parameters
scope (InstanceScope)

[Missing <param name="scope"/> documentation for "M:StructureMap.Graph.IPluginFamily.SetScopeTo(StructureMap.Attributes.InstanceScope)"]


IPluginGraph Interface

IPluginGraph Interface
Namespaces ► StructureMap.Graph ► IPluginGraph
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.IPluginGraph]

Declaration Syntax
C# Visual Basic Visual C++
public interface IPluginGraph
Public Interface IPluginGraph
public interface class IPluginGraph
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddType(Type, Type) | Adds the concreteType as an Instance of the pluginType
 | AddType(Type, Type, String) | Adds the concreteType as an Instance of the pluginType with a name
 | AddType(Type) | Add the pluggedType as an instance to any configured pluginType where pluggedType could be assigned to the pluginType


AddType Method

AddType Method
Namespaces ► StructureMap.Graph ► IPluginGraph ► AddType()()()
StructureMap API
Members
Icon | Member | Description
 | AddType(Type, Type) | Adds the concreteType as an Instance of the pluginType
 | AddType(Type, Type, String) | Adds the concreteType as an Instance of the pluginType with a name
 | AddType(Type) | Add the pluggedType as an instance to any configured pluginType where pluggedType could be assigned to the pluginType


AddType Method (pluggedType)

AddType Method (pluggedType)
Namespaces ► StructureMap.Graph ► IPluginGraph ► AddType(Type)
StructureMap API
Add the pluggedType as an instance to any configured pluginType where pluggedType could be assigned to the pluginType
Declaration Syntax
C# Visual Basic Visual C++
void AddType(
    Type pluggedType
)
Sub AddType ( _
    pluggedType As Type _
)
void AddType(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.IPluginGraph.AddType(System.Type)"]


AddType Method (pluginType, concreteType)

AddType Method (pluginType, concreteType)
Namespaces ► StructureMap.Graph ► IPluginGraph ► AddType(Type, Type)
StructureMap API
Adds the concreteType as an Instance of the pluginType
Declaration Syntax
C# Visual Basic Visual C++
void AddType(
    Type pluginType,
    Type concreteType
)
Sub AddType ( _
    pluginType As Type, _
    concreteType As Type _
)
void AddType(
    Type^ pluginType,
    Type^ concreteType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.IPluginGraph.AddType(System.Type,System.Type)"]

concreteType (Type)

[Missing <param name="concreteType"/> documentation for "M:StructureMap.Graph.IPluginGraph.AddType(System.Type,System.Type)"]


AddType Method (pluginType, concreteType, name)

AddType Method (pluginType, concreteType, name)
Namespaces ► StructureMap.Graph ► IPluginGraph ► AddType(Type, Type, String)
StructureMap API
Adds the concreteType as an Instance of the pluginType with a name
Declaration Syntax
C# Visual Basic Visual C++
void AddType(
    Type pluginType,
    Type concreteType,
    string name
)
Sub AddType ( _
    pluginType As Type, _
    concreteType As Type, _
    name As String _
)
void AddType(
    Type^ pluginType,
    Type^ concreteType,
    String^ name
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.IPluginGraph.AddType(System.Type,System.Type,System.String)"]

concreteType (Type)

[Missing <param name="concreteType"/> documentation for "M:StructureMap.Graph.IPluginGraph.AddType(System.Type,System.Type,System.String)"]

name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Graph.IPluginGraph.AddType(System.Type,System.Type,System.String)"]


ITypeScanner Interface

ITypeScanner Interface
Namespaces ► StructureMap.Graph ► ITypeScanner
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.ITypeScanner]

Declaration Syntax
C# Visual Basic Visual C++
public interface ITypeScanner
Public Interface ITypeScanner
public interface class ITypeScanner
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Process(Type, PluginGraph) |


Process Method (type, graph)

Process Method (type, graph)
Namespaces ► StructureMap.Graph ► ITypeScanner ► Process(Type, PluginGraph)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.ITypeScanner.Process(System.Type,StructureMap.Graph.PluginGraph)]

Declaration Syntax
C# Visual Basic Visual C++
void Process(
    Type type,
    PluginGraph graph
)
Sub Process ( _
    type As Type, _
    graph As PluginGraph _
)
void Process(
    Type^ type,
    PluginGraph^ graph
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.ITypeScanner.Process(System.Type,StructureMap.Graph.PluginGraph)"]

graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.Graph.ITypeScanner.Process(System.Type,StructureMap.Graph.PluginGraph)"]


PluggableAttributeScanner Class

PluggableAttributeScanner Class
Namespaces ► StructureMap.Graph ► PluggableAttributeScanner
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.PluggableAttributeScanner]

Declaration Syntax
C# Visual Basic Visual C++
public class PluggableAttributeScanner : ITypeScanner
Public Class PluggableAttributeScanner _
    Implements ITypeScanner
public ref class PluggableAttributeScanner : ITypeScanner
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PluggableAttributeScanner()()() | Initializes a new instance of the PluggableAttributeScanner class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(Type, PluginGraph) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PluggableAttributeScanner


PluggableAttributeScanner Constructor

PluggableAttributeScanner Constructor
Namespaces ► StructureMap.Graph ► PluggableAttributeScanner ► PluggableAttributeScanner()()()
StructureMap API
Initializes a new instance of the PluggableAttributeScanner class
Declaration Syntax
C# Visual Basic Visual C++
public PluggableAttributeScanner()
Public Sub New
public:
PluggableAttributeScanner()


Process Method (type, graph)

Process Method (type, graph)
Namespaces ► StructureMap.Graph ► PluggableAttributeScanner ► Process(Type, PluginGraph)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluggableAttributeScanner.Process(System.Type,StructureMap.Graph.PluginGraph)]

Declaration Syntax
C# Visual Basic Visual C++
public void Process(
    Type type,
    PluginGraph graph
)
Public Sub Process ( _
    type As Type, _
    graph As PluginGraph _
)
public:
virtual void Process(
    Type^ type,
    PluginGraph^ graph
) sealed
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.PluggableAttributeScanner.Process(System.Type,StructureMap.Graph.PluginGraph)"]

graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.Graph.PluggableAttributeScanner.Process(System.Type,StructureMap.Graph.PluginGraph)"]


Plugin Class

Plugin Class
Namespaces ► StructureMap.Graph ► Plugin
StructureMap API
Represents a concrete class that can be built by StructureMap as an instance of the parent PluginFamily’s PluginType. The properties of a Plugin are the CLR Type of the concrete class, and the human-friendly concrete key that StructureMap will use to identify the Type.
Declaration Syntax
C# Visual Basic Visual C++
public class Plugin : TypeRules
Public Class Plugin _
    Inherits TypeRules
public ref class Plugin : public TypeRules
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Plugin(Type, String) | Initializes a new instance of the Plugin class
 | Plugin(Type) | Initializes a new instance of the Plugin class
 | CanBeAutoFilled |
 | CanBeCreated()()() |
 | ConcreteKey | The ConcreteKey that identifies the Plugin within a PluginFamily
 | CreateImplicitInstance()()() |
 | CreateTemplatedClone(array<Type>[]()[]) |
 | DEFAULT |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindArgumentNameForType<(Of <(T>)>)()()() |
 | FindArgumentNameForType(Type) |
 | GetConstructor()()() |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasOptionalSetters()()() |
 | IsAutoFillable(Type) | (Inherited from TypeRules.)
 | IsChild(Type) | (Inherited from TypeRules.)
 | IsChildArray(Type) | (Inherited from TypeRules.)
 | IsConcrete(Type) | (Inherited from TypeRules.)
 | IsEnum(Type) | (Inherited from TypeRules.)
 | IsPrimitive(Type) | (Inherited from TypeRules.)
 | IsPrimitiveArray(Type) | (Inherited from TypeRules.)
 | IsSimple(Type) | (Inherited from TypeRules.)
 | IsString(Type) | (Inherited from TypeRules.)
 | IsValid()()() |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | MergeSetters(Plugin) |
 | PluggedType | The concrete CLR Type represented by the Plugin
 | SetFilledTypes(IList<(Of <(Type>)>)) |
 | Setters | Property's that will be filled by setter injection
 | ToString()()() | (Overrides Object.ToString()()().)
 | VisitArguments(IArgumentVisitor) |
 | VisitConstructor(IArgumentVisitor) |
 | VisitSetters(IArgumentVisitor) |
Inheritance Hierarchy
Object
 | TypeRules
 |  | Plugin


Plugin Constructor

Plugin Constructor
Namespaces ► StructureMap.Graph ► Plugin ► Plugin()()()
StructureMap API
Members
Icon | Member | Description
 | Plugin(Type, String) | Initializes a new instance of the Plugin class
 | Plugin(Type) | Initializes a new instance of the Plugin class


Plugin Constructor (pluggedType)

Plugin Constructor (pluggedType)
Namespaces ► StructureMap.Graph ► Plugin ► Plugin(Type)
StructureMap API
Initializes a new instance of the Plugin class
Declaration Syntax
C# Visual Basic Visual C++
public Plugin(
    Type pluggedType
)
Public Sub New ( _
    pluggedType As Type _
)
public:
Plugin(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.Plugin.#ctor(System.Type)"]


Plugin Constructor (pluggedType, concreteKey)

Plugin Constructor (pluggedType, concreteKey)
Namespaces ► StructureMap.Graph ► Plugin ► Plugin(Type, String)
StructureMap API
Initializes a new instance of the Plugin class
Declaration Syntax
C# Visual Basic Visual C++
public Plugin(
    Type pluggedType,
    string concreteKey
)
Public Sub New ( _
    pluggedType As Type, _
    concreteKey As String _
)
public:
Plugin(
    Type^ pluggedType,
    String^ concreteKey
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.Plugin.#ctor(System.Type,System.String)"]

concreteKey (String)

[Missing <param name="concreteKey"/> documentation for "M:StructureMap.Graph.Plugin.#ctor(System.Type,System.String)"]


CanBeAutoFilled Property

CanBeAutoFilled Property
Namespaces ► StructureMap.Graph ► Plugin ► CanBeAutoFilled
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.Plugin.CanBeAutoFilled]

Declaration Syntax
C# Visual Basic Visual C++
public bool CanBeAutoFilled { get; }
Public ReadOnly Property CanBeAutoFilled As Boolean
public:
property bool CanBeAutoFilled {
    bool get ();
}


CanBeCreated Method

CanBeCreated Method
Namespaces ► StructureMap.Graph ► Plugin ► CanBeCreated()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Plugin.CanBeCreated]

Declaration Syntax
C# Visual Basic Visual C++
public bool CanBeCreated()
Public Function CanBeCreated As Boolean
public:
bool CanBeCreated()
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Plugin.CanBeCreated]


ConcreteKey Property

ConcreteKey Property
Namespaces ► StructureMap.Graph ► Plugin ► ConcreteKey
StructureMap API
The ConcreteKey that identifies the Plugin within a PluginFamily
Declaration Syntax
C# Visual Basic Visual C++
public string ConcreteKey { get; set; }
Public Property ConcreteKey As String
public:
property String^ ConcreteKey {
    String^ get ();
    void set (String^ value);
}


CreateImplicitInstance Method

CreateImplicitInstance Method
Namespaces ► StructureMap.Graph ► Plugin ► CreateImplicitInstance()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Plugin.CreateImplicitInstance]

Declaration Syntax
C# Visual Basic Visual C++
public Instance CreateImplicitInstance()
Public Function CreateImplicitInstance As Instance
public:
Instance^ CreateImplicitInstance()
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Plugin.CreateImplicitInstance]


CreateTemplatedClone Method (types)

CreateTemplatedClone Method (types)
Namespaces ► StructureMap.Graph ► Plugin ► CreateTemplatedClone(array<Type>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Plugin.CreateTemplatedClone(System.Type[])]

Declaration Syntax
C# Visual Basic Visual C++
public Plugin CreateTemplatedClone(
    Type[] types
)
Public Function CreateTemplatedClone ( _
    types As Type() _
) As Plugin
public:
Plugin^ CreateTemplatedClone(
    array<Type^>^ types
)
Parameters
types (array< Type >[]()[])

[Missing <param name="types"/> documentation for "M:StructureMap.Graph.Plugin.CreateTemplatedClone(System.Type[])"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Plugin.CreateTemplatedClone(System.Type[])]


DEFAULT Field

DEFAULT Field
Namespaces ► StructureMap.Graph ► Plugin ► DEFAULT
StructureMap API

[Missing <summary> documentation for F:StructureMap.Graph.Plugin.DEFAULT]

Declaration Syntax
C# Visual Basic Visual C++
public static readonly string DEFAULT
Public Shared ReadOnly DEFAULT As String
public:
static initonly String^ DEFAULT


FindArgumentNameForType Method

FindArgumentNameForType Method
Namespaces ► StructureMap.Graph ► Plugin ► FindArgumentNameForType()()()
StructureMap API
Members
Icon | Member | Description
 | FindArgumentNameForType<(Of <(T>)>)()()() |
 | FindArgumentNameForType(Type) |


FindArgumentNameForType Method

FindArgumentNameForType<(Of <(T>)>) Method
Namespaces ► StructureMap.Graph ► Plugin ► FindArgumentNameForType<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Plugin.FindArgumentNameForType``1]

Declaration Syntax
C# Visual Basic Visual C++
public string FindArgumentNameForType<T>()

Public Function FindArgumentNameForType(Of T) As String
public:
generic<typename T>
String^ FindArgumentNameForType()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Graph.Plugin.FindArgumentNameForType``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Plugin.FindArgumentNameForType``1]


FindArgumentNameForType Method (type)

FindArgumentNameForType Method (type)
Namespaces ► StructureMap.Graph ► Plugin ► FindArgumentNameForType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Plugin.FindArgumentNameForType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public string FindArgumentNameForType(
    Type type
)
Public Function FindArgumentNameForType ( _
    type As Type _
) As String
public:
String^ FindArgumentNameForType(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.Plugin.FindArgumentNameForType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Plugin.FindArgumentNameForType(System.Type)]


GetConstructor Method

GetConstructor Method
Namespaces ► StructureMap.Graph ► Plugin ► GetConstructor()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Plugin.GetConstructor]

Declaration Syntax
C# Visual Basic Visual C++
public ConstructorInfo GetConstructor()
Public Function GetConstructor As ConstructorInfo
public:
ConstructorInfo^ GetConstructor()
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Plugin.GetConstructor]


HasOptionalSetters Method

HasOptionalSetters Method
Namespaces ► StructureMap.Graph ► Plugin ► HasOptionalSetters()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Plugin.HasOptionalSetters]

Declaration Syntax
C# Visual Basic Visual C++
public bool HasOptionalSetters()
Public Function HasOptionalSetters As Boolean
public:
bool HasOptionalSetters()
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Plugin.HasOptionalSetters]


IsValid Method

IsValid Method
Namespaces ► StructureMap.Graph ► Plugin ► IsValid()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Plugin.IsValid]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsValid()
Public Function IsValid As Boolean
public:
bool IsValid()
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Plugin.IsValid]


MergeSetters Method (plugin)

MergeSetters Method (plugin)
Namespaces ► StructureMap.Graph ► Plugin ► MergeSetters(Plugin)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Plugin.MergeSetters(StructureMap.Graph.Plugin)]

Declaration Syntax
C# Visual Basic Visual C++
public void MergeSetters(
    Plugin plugin
)
Public Sub MergeSetters ( _
    plugin As Plugin _
)
public:
void MergeSetters(
    Plugin^ plugin
)
Parameters
plugin (Plugin)

[Missing <param name="plugin"/> documentation for "M:StructureMap.Graph.Plugin.MergeSetters(StructureMap.Graph.Plugin)"]


PluggedType Property

PluggedType Property
Namespaces ► StructureMap.Graph ► Plugin ► PluggedType
StructureMap API
The concrete CLR Type represented by the Plugin
Declaration Syntax
C# Visual Basic Visual C++
public Type PluggedType { get; }
Public ReadOnly Property PluggedType As Type
public:
property Type^ PluggedType {
    Type^ get ();
}


SetFilledTypes Method (types)

SetFilledTypes Method (types)
Namespaces ► StructureMap.Graph ► Plugin ► SetFilledTypes(IList<(Of <(Type>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Plugin.SetFilledTypes(System.Collections.Generic.IList{System.Type})]

Declaration Syntax
C# Visual Basic Visual C++
public void SetFilledTypes(
    IList<Type> types
)
Public Sub SetFilledTypes ( _
    types As IList(Of Type) _
)
public:
void SetFilledTypes(
    IList<Type^>^ types
)
Parameters
types (IList <(Of <( Type >)>))

[Missing <param name="types"/> documentation for "M:StructureMap.Graph.Plugin.SetFilledTypes(System.Collections.Generic.IList{System.Type})"]


Setters Property

Setters Property
Namespaces ► StructureMap.Graph ► Plugin ► Setters
StructureMap API
Property's that will be filled by setter injection
Declaration Syntax
C# Visual Basic Visual C++
public SetterPropertyCollection Setters { get; }
Public ReadOnly Property Setters As SetterPropertyCollection
public:
property SetterPropertyCollection^ Setters {
    SetterPropertyCollection^ get ();
}


ToString Method

ToString Method
Namespaces ► StructureMap.Graph ► Plugin ► ToString()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Plugin.ToString]

Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.Plugin.ToString]


VisitArguments Method (visitor)

VisitArguments Method (visitor)
Namespaces ► StructureMap.Graph ► Plugin ► VisitArguments(IArgumentVisitor)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Plugin.VisitArguments(StructureMap.Graph.IArgumentVisitor)]

Declaration Syntax
C# Visual Basic Visual C++
public void VisitArguments(
    IArgumentVisitor visitor
)
Public Sub VisitArguments ( _
    visitor As IArgumentVisitor _
)
public:
void VisitArguments(
    IArgumentVisitor^ visitor
)
Parameters
visitor (IArgumentVisitor)

[Missing <param name="visitor"/> documentation for "M:StructureMap.Graph.Plugin.VisitArguments(StructureMap.Graph.IArgumentVisitor)"]


VisitConstructor Method (arguments)

VisitConstructor Method (arguments)
Namespaces ► StructureMap.Graph ► Plugin ► VisitConstructor(IArgumentVisitor)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Plugin.VisitConstructor(StructureMap.Graph.IArgumentVisitor)]

Declaration Syntax
C# Visual Basic Visual C++
public void VisitConstructor(
    IArgumentVisitor arguments
)
Public Sub VisitConstructor ( _
    arguments As IArgumentVisitor _
)
public:
void VisitConstructor(
    IArgumentVisitor^ arguments
)
Parameters
arguments (IArgumentVisitor)

[Missing <param name="arguments"/> documentation for "M:StructureMap.Graph.Plugin.VisitConstructor(StructureMap.Graph.IArgumentVisitor)"]


VisitSetters Method (arguments)

VisitSetters Method (arguments)
Namespaces ► StructureMap.Graph ► Plugin ► VisitSetters(IArgumentVisitor)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.Plugin.VisitSetters(StructureMap.Graph.IArgumentVisitor)]

Declaration Syntax
C# Visual Basic Visual C++
public void VisitSetters(
    IArgumentVisitor arguments
)
Public Sub VisitSetters ( _
    arguments As IArgumentVisitor _
)
public:
void VisitSetters(
    IArgumentVisitor^ arguments
)
Parameters
arguments (IArgumentVisitor)

[Missing <param name="arguments"/> documentation for "M:StructureMap.Graph.Plugin.VisitSetters(StructureMap.Graph.IArgumentVisitor)"]


PluginCache Class

PluginCache Class
Namespaces ► StructureMap.Graph ► PluginCache
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.PluginCache]

Declaration Syntax
C# Visual Basic Visual C++
public static class PluginCache
Public NotInheritable Class PluginCache
public ref class PluginCache abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddFilledType(Type) |
 | Compile()()() |
 | FindBuilder(Type) |
 | GetPlugin(Type) |
 | Store(Type, InstanceBuilder) |
Inheritance Hierarchy
Object
PluginCache


AddFilledType Method (type)

AddFilledType Method (type)
Namespaces ► StructureMap.Graph ► PluginCache ► AddFilledType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginCache.AddFilledType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public static void AddFilledType(
    Type type
)
Public Shared Sub AddFilledType ( _
    type As Type _
)
public:
static void AddFilledType(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.PluginCache.AddFilledType(System.Type)"]


Compile Method

Compile Method
Namespaces ► StructureMap.Graph ► PluginCache ► Compile()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginCache.Compile]

Declaration Syntax
C# Visual Basic Visual C++
public static void Compile()
Public Shared Sub Compile
public:
static void Compile()


FindBuilder Method (pluggedType)

FindBuilder Method (pluggedType)
Namespaces ► StructureMap.Graph ► PluginCache ► FindBuilder(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginCache.FindBuilder(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public static InstanceBuilder FindBuilder(
    Type pluggedType
)
Public Shared Function FindBuilder ( _
    pluggedType As Type _
) As InstanceBuilder
public:
static InstanceBuilder^ FindBuilder(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.PluginCache.FindBuilder(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginCache.FindBuilder(System.Type)]


GetPlugin Method (pluggedType)

GetPlugin Method (pluggedType)
Namespaces ► StructureMap.Graph ► PluginCache ► GetPlugin(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginCache.GetPlugin(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public static Plugin GetPlugin(
    Type pluggedType
)
Public Shared Function GetPlugin ( _
    pluggedType As Type _
) As Plugin
public:
static Plugin^ GetPlugin(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.PluginCache.GetPlugin(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginCache.GetPlugin(System.Type)]


Store Method (pluggedType, builder)

Store Method (pluggedType, builder)
Namespaces ► StructureMap.Graph ► PluginCache ► Store(Type, InstanceBuilder)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginCache.Store(System.Type,StructureMap.InstanceBuilder)]

Declaration Syntax
C# Visual Basic Visual C++
public static void Store(
    Type pluggedType,
    InstanceBuilder builder
)
Public Shared Sub Store ( _
    pluggedType As Type, _
    builder As InstanceBuilder _
)
public:
static void Store(
    Type^ pluggedType,
    InstanceBuilder^ builder
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.PluginCache.Store(System.Type,StructureMap.InstanceBuilder)"]

builder (InstanceBuilder)

[Missing <param name="builder"/> documentation for "M:StructureMap.Graph.PluginCache.Store(System.Type,StructureMap.InstanceBuilder)"]


PluginFamily Class

PluginFamily Class
Namespaces ► StructureMap.Graph ► PluginFamily
StructureMap API
Conceptually speaking, a PluginFamily object represents a point of abstraction or variability in the system. A PluginFamily defines a CLR Type that StructureMap can build, and all of the possible Plugin’s implementing the CLR Type.
Declaration Syntax
C# Visual Basic Visual C++
public class PluginFamily : TypeRules,
    IPluginFamily
Public Class PluginFamily _
    Inherits TypeRules _
    Implements IPluginFamily
public ref class PluginFamily : public TypeRules,
    IPluginFamily
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PluginFamily(Type) | Initializes a new instance of the PluginFamily class
 | PluginFamily(Type, PluginGraph) | Initializes a new instance of the PluginFamily class
 | AddDefaultMemento(InstanceMemento) |
 | AddInstance(InstanceMemento) |
 | AddInstance(Instance) |
 | AddInterceptor(IBuildInterceptor) |
 | AddMementoSource(MementoSource) |
 | AddPlugin(Type) |
 | AddPlugin(Type, String) |
 | AddType(Type) |
 | AddType(Type, String) |
 | AddTypes(List<(Of <(Type>)>)) |
 | CreateTemplatedClone(array<Type>[]()[]) |
 | DefaultInstanceKey | The InstanceKey of the default instance of the PluginFamily
 | EachInstance(Action<(Of <(Instance>)>)) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FillDefault(Profile) |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindPlugin(Type) |
 | FindPlugin(String) |
 | FirstInstance()()() |
 | GetConfiguration()()() |
 | GetDefaultInstance()()() |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetInstance(String) |
 | GetMemento(String) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasPlugin(Type) |
 | HasPlugin(String) |
 | ImportFrom(PluginFamily) |
 | InstanceCount |
 | Instances |
 | IsAutoFillable(Type) | (Inherited from TypeRules.)
 | IsChild(Type) | (Inherited from TypeRules.)
 | IsChildArray(Type) | (Inherited from TypeRules.)
 | IsConcrete(Type) | (Inherited from TypeRules.)
 | IsEnum(Type) | (Inherited from TypeRules.)
 | IsGenericTemplate |
 | IsPrimitive(Type) | (Inherited from TypeRules.)
 | IsPrimitiveArray(Type) | (Inherited from TypeRules.)
 | IsSimple(Type) | (Inherited from TypeRules.)
 | IsString(Type) | (Inherited from TypeRules.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent |
 | PluginCount |
 | PluginType | The CLR Type that defines the "Plugin" interface for the PluginFamily
 | Policy |
 | Seal()()() |
 | SetScopeTo(InstanceScope) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypeRules
 |  | PluginFamily


PluginFamily Constructor

PluginFamily Constructor
Namespaces ► StructureMap.Graph ► PluginFamily ► PluginFamily()()()
StructureMap API
Members
Icon | Member | Description
 | PluginFamily(Type) | Initializes a new instance of the PluginFamily class
 | PluginFamily(Type, PluginGraph) | Initializes a new instance of the PluginFamily class


PluginFamily Constructor (pluginType)

PluginFamily Constructor (pluginType)
Namespaces ► StructureMap.Graph ► PluginFamily ► PluginFamily(Type)
StructureMap API
Initializes a new instance of the PluginFamily class
Declaration Syntax
C# Visual Basic Visual C++
public PluginFamily(
    Type pluginType
)
Public Sub New ( _
    pluginType As Type _
)
public:
PluginFamily(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.PluginFamily.#ctor(System.Type)"]


PluginFamily Constructor (pluginType, parent)

PluginFamily Constructor (pluginType, parent)
Namespaces ► StructureMap.Graph ► PluginFamily ► PluginFamily(Type, PluginGraph)
StructureMap API
Initializes a new instance of the PluginFamily class
Declaration Syntax
C# Visual Basic Visual C++
public PluginFamily(
    Type pluginType,
    PluginGraph parent
)
Public Sub New ( _
    pluginType As Type, _
    parent As PluginGraph _
)
public:
PluginFamily(
    Type^ pluginType,
    PluginGraph^ parent
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.PluginFamily.#ctor(System.Type,StructureMap.Graph.PluginGraph)"]

parent (PluginGraph)

[Missing <param name="parent"/> documentation for "M:StructureMap.Graph.PluginFamily.#ctor(System.Type,StructureMap.Graph.PluginGraph)"]


AddDefaultMemento Method (memento)

AddDefaultMemento Method (memento)
Namespaces ► StructureMap.Graph ► PluginFamily ► AddDefaultMemento(InstanceMemento)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.AddDefaultMemento(StructureMap.InstanceMemento)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddDefaultMemento(
    InstanceMemento memento
)
Public Sub AddDefaultMemento ( _
    memento As InstanceMemento _
)
public:
void AddDefaultMemento(
    InstanceMemento^ memento
)
Parameters
memento (InstanceMemento)

[Missing <param name="memento"/> documentation for "M:StructureMap.Graph.PluginFamily.AddDefaultMemento(StructureMap.InstanceMemento)"]


AddInstance Method

AddInstance Method
Namespaces ► StructureMap.Graph ► PluginFamily ► AddInstance()()()
StructureMap API
Members
Icon | Member | Description
 | AddInstance(InstanceMemento) |
 | AddInstance(Instance) |


AddInstance Method (memento)

AddInstance Method (memento)
Namespaces ► StructureMap.Graph ► PluginFamily ► AddInstance(InstanceMemento)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.AddInstance(StructureMap.InstanceMemento)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddInstance(
    InstanceMemento memento
)
Public Sub AddInstance ( _
    memento As InstanceMemento _
)
public:
void AddInstance(
    InstanceMemento^ memento
)
Parameters
memento (InstanceMemento)

[Missing <param name="memento"/> documentation for "M:StructureMap.Graph.PluginFamily.AddInstance(StructureMap.InstanceMemento)"]


AddInstance Method (instance)

AddInstance Method (instance)
Namespaces ► StructureMap.Graph ► PluginFamily ► AddInstance(Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.AddInstance(StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddInstance(
    Instance instance
)
Public Sub AddInstance ( _
    instance As Instance _
)
public:
void AddInstance(
    Instance^ instance
)
Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Graph.PluginFamily.AddInstance(StructureMap.Pipeline.Instance)"]


AddInterceptor Method (interceptor)

AddInterceptor Method (interceptor)
Namespaces ► StructureMap.Graph ► PluginFamily ► AddInterceptor(IBuildInterceptor)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.AddInterceptor(StructureMap.Pipeline.IBuildInterceptor)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddInterceptor(
    IBuildInterceptor interceptor
)
Public Sub AddInterceptor ( _
    interceptor As IBuildInterceptor _
)
public:
virtual void AddInterceptor(
    IBuildInterceptor^ interceptor
) sealed
Parameters
interceptor (IBuildInterceptor)

[Missing <param name="interceptor"/> documentation for "M:StructureMap.Graph.PluginFamily.AddInterceptor(StructureMap.Pipeline.IBuildInterceptor)"]


AddMementoSource Method (source)

AddMementoSource Method (source)
Namespaces ► StructureMap.Graph ► PluginFamily ► AddMementoSource(MementoSource)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.AddMementoSource(StructureMap.MementoSource)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddMementoSource(
    MementoSource source
)
Public Sub AddMementoSource ( _
    source As MementoSource _
)
public:
virtual void AddMementoSource(
    MementoSource^ source
) sealed
Parameters
source (MementoSource)

[Missing <param name="source"/> documentation for "M:StructureMap.Graph.PluginFamily.AddMementoSource(StructureMap.MementoSource)"]


AddPlugin Method

AddPlugin Method
Namespaces ► StructureMap.Graph ► PluginFamily ► AddPlugin()()()
StructureMap API
Members
Icon | Member | Description
 | AddPlugin(Type) |
 | AddPlugin(Type, String) |


AddPlugin Method (pluggedType)

AddPlugin Method (pluggedType)
Namespaces ► StructureMap.Graph ► PluginFamily ► AddPlugin(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.AddPlugin(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public Plugin AddPlugin(
    Type pluggedType
)
Public Function AddPlugin ( _
    pluggedType As Type _
) As Plugin
public:
Plugin^ AddPlugin(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.PluginFamily.AddPlugin(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamily.AddPlugin(System.Type)]


AddPlugin Method (pluggedType, key)

AddPlugin Method (pluggedType, key)
Namespaces ► StructureMap.Graph ► PluginFamily ► AddPlugin(Type, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.AddPlugin(System.Type,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public Plugin AddPlugin(
    Type pluggedType,
    string key
)
Public Function AddPlugin ( _
    pluggedType As Type, _
    key As String _
) As Plugin
public:
Plugin^ AddPlugin(
    Type^ pluggedType,
    String^ key
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.PluginFamily.AddPlugin(System.Type,System.String)"]

key (String)

[Missing <param name="key"/> documentation for "M:StructureMap.Graph.PluginFamily.AddPlugin(System.Type,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamily.AddPlugin(System.Type,System.String)]


AddType Method

AddType Method
Namespaces ► StructureMap.Graph ► PluginFamily ► AddType()()()
StructureMap API
Members
Icon | Member | Description
 | AddType(Type) |
 | AddType(Type, String) |


AddType Method (concreteType)

AddType Method (concreteType)
Namespaces ► StructureMap.Graph ► PluginFamily ► AddType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.AddType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddType(
    Type concreteType
)
Public Sub AddType ( _
    concreteType As Type _
)
public:
void AddType(
    Type^ concreteType
)
Parameters
concreteType (Type)

[Missing <param name="concreteType"/> documentation for "M:StructureMap.Graph.PluginFamily.AddType(System.Type)"]


AddType Method (concreteType, name)

AddType Method (concreteType, name)
Namespaces ► StructureMap.Graph ► PluginFamily ► AddType(Type, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.AddType(System.Type,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddType(
    Type concreteType,
    string name
)
Public Sub AddType ( _
    concreteType As Type, _
    name As String _
)
public:
void AddType(
    Type^ concreteType,
    String^ name
)
Parameters
concreteType (Type)

[Missing <param name="concreteType"/> documentation for "M:StructureMap.Graph.PluginFamily.AddType(System.Type,System.String)"]

name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Graph.PluginFamily.AddType(System.Type,System.String)"]


AddTypes Method (pluggedTypes)

AddTypes Method (pluggedTypes)
Namespaces ► StructureMap.Graph ► PluginFamily ► AddTypes(List<(Of <(Type>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.AddTypes(System.Collections.Generic.List{System.Type})]

Declaration Syntax
C# Visual Basic Visual C++
public void AddTypes(
    List<Type> pluggedTypes
)
Public Sub AddTypes ( _
    pluggedTypes As List(Of Type) _
)
public:
void AddTypes(
    List<Type^>^ pluggedTypes
)
Parameters
pluggedTypes (List <(Of <( Type >)>))

[Missing <param name="pluggedTypes"/> documentation for "M:StructureMap.Graph.PluginFamily.AddTypes(System.Collections.Generic.List{System.Type})"]


CreateTemplatedClone Method (templateTypes)

CreateTemplatedClone Method (templateTypes)
Namespaces ► StructureMap.Graph ► PluginFamily ► CreateTemplatedClone(array<Type>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.CreateTemplatedClone(System.Type[])]

Declaration Syntax
C# Visual Basic Visual C++
public PluginFamily CreateTemplatedClone(
    Type[] templateTypes
)
Public Function CreateTemplatedClone ( _
    templateTypes As Type() _
) As PluginFamily
public:
PluginFamily^ CreateTemplatedClone(
    array<Type^>^ templateTypes
)
Parameters
templateTypes (array< Type >[]()[])

[Missing <param name="templateTypes"/> documentation for "M:StructureMap.Graph.PluginFamily.CreateTemplatedClone(System.Type[])"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamily.CreateTemplatedClone(System.Type[])]


DefaultInstanceKey Property

DefaultInstanceKey Property
Namespaces ► StructureMap.Graph ► PluginFamily ► DefaultInstanceKey
StructureMap API
The InstanceKey of the default instance of the PluginFamily
Declaration Syntax
C# Visual Basic Visual C++
public string DefaultInstanceKey { get; set; }
Public Property DefaultInstanceKey As String
public:
virtual property String^ DefaultInstanceKey {
    String^ get () sealed;
    void set (String^ value) sealed;
}


EachInstance Method (action)

EachInstance Method (action)
Namespaces ► StructureMap.Graph ► PluginFamily ► EachInstance(Action<(Of <(Instance>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.EachInstance(System.Action{StructureMap.Pipeline.Instance})]

Declaration Syntax
C# Visual Basic Visual C++
public void EachInstance(
    Action<Instance> action
)
Public Sub EachInstance ( _
    action As Action(Of Instance) _
)
public:
void EachInstance(
    Action<Instance^>^ action
)
Parameters
action (Action <(Of <( Instance >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Graph.PluginFamily.EachInstance(System.Action{StructureMap.Pipeline.Instance})"]


FillDefault Method (profile)

FillDefault Method (profile)
Namespaces ► StructureMap.Graph ► PluginFamily ► FillDefault(Profile)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.FillDefault(StructureMap.Pipeline.Profile)]

Declaration Syntax
C# Visual Basic Visual C++
public void FillDefault(
    Profile profile
)
Public Sub FillDefault ( _
    profile As Profile _
)
public:
void FillDefault(
    Profile^ profile
)
Parameters
profile (Profile)

[Missing <param name="profile"/> documentation for "M:StructureMap.Graph.PluginFamily.FillDefault(StructureMap.Pipeline.Profile)"]


FindPlugin Method

FindPlugin Method
Namespaces ► StructureMap.Graph ► PluginFamily ► FindPlugin()()()
StructureMap API
Members
Icon | Member | Description
 | FindPlugin(Type) |
 | FindPlugin(String) |


FindPlugin Method (concreteKey)

FindPlugin Method (concreteKey)
Namespaces ► StructureMap.Graph ► PluginFamily ► FindPlugin(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.FindPlugin(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public Plugin FindPlugin(
    string concreteKey
)
Public Function FindPlugin ( _
    concreteKey As String _
) As Plugin
public:
Plugin^ FindPlugin(
    String^ concreteKey
)
Parameters
concreteKey (String)

[Missing <param name="concreteKey"/> documentation for "M:StructureMap.Graph.PluginFamily.FindPlugin(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamily.FindPlugin(System.String)]


FindPlugin Method (pluggedType)

FindPlugin Method (pluggedType)
Namespaces ► StructureMap.Graph ► PluginFamily ► FindPlugin(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.FindPlugin(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public Plugin FindPlugin(
    Type pluggedType
)
Public Function FindPlugin ( _
    pluggedType As Type _
) As Plugin
public:
Plugin^ FindPlugin(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.PluginFamily.FindPlugin(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamily.FindPlugin(System.Type)]


FirstInstance Method

FirstInstance Method
Namespaces ► StructureMap.Graph ► PluginFamily ► FirstInstance()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.FirstInstance]

Declaration Syntax
C# Visual Basic Visual C++
public Instance FirstInstance()
Public Function FirstInstance As Instance
public:
Instance^ FirstInstance()
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamily.FirstInstance]


GetConfiguration Method

GetConfiguration Method
Namespaces ► StructureMap.Graph ► PluginFamily ► GetConfiguration()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.GetConfiguration]

Declaration Syntax
C# Visual Basic Visual C++
public PluginTypeConfiguration GetConfiguration()
Public Function GetConfiguration As PluginTypeConfiguration
public:
PluginTypeConfiguration^ GetConfiguration()
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamily.GetConfiguration]


GetDefaultInstance Method

GetDefaultInstance Method
Namespaces ► StructureMap.Graph ► PluginFamily ► GetDefaultInstance()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.GetDefaultInstance]

Declaration Syntax
C# Visual Basic Visual C++
public Instance GetDefaultInstance()
Public Function GetDefaultInstance As Instance
public:
Instance^ GetDefaultInstance()
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamily.GetDefaultInstance]


GetInstance Method (name)

GetInstance Method (name)
Namespaces ► StructureMap.Graph ► PluginFamily ► GetInstance(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.GetInstance(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public Instance GetInstance(
    string name
)
Public Function GetInstance ( _
    name As String _
) As Instance
public:
Instance^ GetInstance(
    String^ name
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Graph.PluginFamily.GetInstance(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamily.GetInstance(System.String)]


GetMemento Method (instanceKey)

GetMemento Method (instanceKey)
Namespaces ► StructureMap.Graph ► PluginFamily ► GetMemento(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.GetMemento(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public InstanceMemento GetMemento(
    string instanceKey
)
Public Function GetMemento ( _
    instanceKey As String _
) As InstanceMemento
public:
InstanceMemento^ GetMemento(
    String^ instanceKey
)
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Graph.PluginFamily.GetMemento(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamily.GetMemento(System.String)]


HasPlugin Method

HasPlugin Method
Namespaces ► StructureMap.Graph ► PluginFamily ► HasPlugin()()()
StructureMap API
Members
Icon | Member | Description
 | HasPlugin(Type) |
 | HasPlugin(String) |


HasPlugin Method (concreteKey)

HasPlugin Method (concreteKey)
Namespaces ► StructureMap.Graph ► PluginFamily ► HasPlugin(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.HasPlugin(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public bool HasPlugin(
    string concreteKey
)
Public Function HasPlugin ( _
    concreteKey As String _
) As Boolean
public:
bool HasPlugin(
    String^ concreteKey
)
Parameters
concreteKey (String)

[Missing <param name="concreteKey"/> documentation for "M:StructureMap.Graph.PluginFamily.HasPlugin(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamily.HasPlugin(System.String)]


HasPlugin Method (pluggedType)

HasPlugin Method (pluggedType)
Namespaces ► StructureMap.Graph ► PluginFamily ► HasPlugin(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.HasPlugin(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public bool HasPlugin(
    Type pluggedType
)
Public Function HasPlugin ( _
    pluggedType As Type _
) As Boolean
public:
bool HasPlugin(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.PluginFamily.HasPlugin(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamily.HasPlugin(System.Type)]


ImportFrom Method (source)

ImportFrom Method (source)
Namespaces ► StructureMap.Graph ► PluginFamily ► ImportFrom(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.ImportFrom(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
public void ImportFrom(
    PluginFamily source
)
Public Sub ImportFrom ( _
    source As PluginFamily _
)
public:
void ImportFrom(
    PluginFamily^ source
)
Parameters
source (PluginFamily)

[Missing <param name="source"/> documentation for "M:StructureMap.Graph.PluginFamily.ImportFrom(StructureMap.Graph.PluginFamily)"]


InstanceCount Property

InstanceCount Property
Namespaces ► StructureMap.Graph ► PluginFamily ► InstanceCount
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.PluginFamily.InstanceCount]

Declaration Syntax
C# Visual Basic Visual C++
public int InstanceCount { get; }
Public ReadOnly Property InstanceCount As Integer
public:
property int InstanceCount {
    int get ();
}


Instances Property

Instances Property
Namespaces ► StructureMap.Graph ► PluginFamily ► Instances
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.PluginFamily.Instances]

Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<IInstance> Instances { get; }
Public ReadOnly Property Instances As IEnumerable(Of IInstance)
public:
property IEnumerable<IInstance^>^ Instances {
    IEnumerable<IInstance^>^ get ();
}


IsGenericTemplate Property

IsGenericTemplate Property
Namespaces ► StructureMap.Graph ► PluginFamily ► IsGenericTemplate
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.PluginFamily.IsGenericTemplate]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsGenericTemplate { get; }
Public ReadOnly Property IsGenericTemplate As Boolean
public:
property bool IsGenericTemplate {
    bool get ();
}


Parent Property

Parent Property
Namespaces ► StructureMap.Graph ► PluginFamily ► Parent
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.PluginFamily.Parent]

Declaration Syntax
C# Visual Basic Visual C++
public PluginGraph Parent { get; set; }
Public Property Parent As PluginGraph
public:
property PluginGraph^ Parent {
    PluginGraph^ get ();
    void set (PluginGraph^ value);
}


PluginCount Property

PluginCount Property
Namespaces ► StructureMap.Graph ► PluginFamily ► PluginCount
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.PluginFamily.PluginCount]

Declaration Syntax
C# Visual Basic Visual C++
public int PluginCount { get; }
Public ReadOnly Property PluginCount As Integer
public:
property int PluginCount {
    int get ();
}


PluginType Property

PluginType Property
Namespaces ► StructureMap.Graph ► PluginFamily ► PluginType
StructureMap API
The CLR Type that defines the "Plugin" interface for the PluginFamily
Declaration Syntax
C# Visual Basic Visual C++
public Type PluginType { get; }
Public ReadOnly Property PluginType As Type
public:
virtual property Type^ PluginType {
    Type^ get () sealed;
}


Policy Property

Policy Property
Namespaces ► StructureMap.Graph ► PluginFamily ► Policy
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.PluginFamily.Policy]

Declaration Syntax
C# Visual Basic Visual C++
public IBuildPolicy Policy { get; set; }
Public Property Policy As IBuildPolicy
public:
property IBuildPolicy^ Policy {
    IBuildPolicy^ get ();
    void set (IBuildPolicy^ value);
}


Seal Method

Seal Method
Namespaces ► StructureMap.Graph ► PluginFamily ► Seal()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.Seal]

Declaration Syntax
C# Visual Basic Visual C++
public void Seal()
Public Sub Seal
public:
void Seal()


SetScopeTo Method (scope)

SetScopeTo Method (scope)
Namespaces ► StructureMap.Graph ► PluginFamily ► SetScopeTo(InstanceScope)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamily.SetScopeTo(StructureMap.Attributes.InstanceScope)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetScopeTo(
    InstanceScope scope
)
Public Sub SetScopeTo ( _
    scope As InstanceScope _
)
public:
virtual void SetScopeTo(
    InstanceScope scope
) sealed
Parameters
scope (InstanceScope)

[Missing <param name="scope"/> documentation for "M:StructureMap.Graph.PluginFamily.SetScopeTo(StructureMap.Attributes.InstanceScope)"]


PluginFamilyCollection Class

PluginFamilyCollection Class
Namespaces ► StructureMap.Graph ► PluginFamilyCollection
StructureMap API
Custom collection class for PluginFamily's
Declaration Syntax
C# Visual Basic Visual C++
public class PluginFamilyCollection : IEnumerable<PluginFamily>,
    IEnumerable
Public Class PluginFamilyCollection _
    Implements IEnumerable(Of PluginFamily), IEnumerable
public ref class PluginFamilyCollection : IEnumerable<PluginFamily^>,
    IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PluginFamilyCollection(PluginGraph) | Initializes a new instance of the PluginFamilyCollection class
 | Add(PluginFamily) |
 | All |
 | Contains(Type) |
 | Contains<(Of <(T>)>)()()() |
 | Count |
 | Each(Action<(Of <(PluginFamily>)>)) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetEnumerator()()() |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Item[([(Type])]) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(PluginFamily) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PluginFamilyCollection


PluginFamilyCollection Constructor (pluginGraph)

PluginFamilyCollection Constructor (pluginGraph)
Namespaces ► StructureMap.Graph ► PluginFamilyCollection ► PluginFamilyCollection(PluginGraph)
StructureMap API
Initializes a new instance of the PluginFamilyCollection class
Declaration Syntax
C# Visual Basic Visual C++
public PluginFamilyCollection(
    PluginGraph pluginGraph
)
Public Sub New ( _
    pluginGraph As PluginGraph _
)
public:
PluginFamilyCollection(
    PluginGraph^ pluginGraph
)
Parameters
pluginGraph (PluginGraph)

[Missing <param name="pluginGraph"/> documentation for "M:StructureMap.Graph.PluginFamilyCollection.#ctor(StructureMap.Graph.PluginGraph)"]


Add Method (family)

Add Method (family)
Namespaces ► StructureMap.Graph ► PluginFamilyCollection ► Add(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamilyCollection.Add(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
public PluginFamily Add(
    PluginFamily family
)
Public Function Add ( _
    family As PluginFamily _
) As PluginFamily
public:
PluginFamily^ Add(
    PluginFamily^ family
)
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Graph.PluginFamilyCollection.Add(StructureMap.Graph.PluginFamily)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamilyCollection.Add(StructureMap.Graph.PluginFamily)]


All Property

All Property
Namespaces ► StructureMap.Graph ► PluginFamilyCollection ► All
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.PluginFamilyCollection.All]

Declaration Syntax
C# Visual Basic Visual C++
public IEnumerable<PluginFamily> All { get; }
Public ReadOnly Property All As IEnumerable(Of PluginFamily)
public:
property IEnumerable<PluginFamily^>^ All {
    IEnumerable<PluginFamily^>^ get ();
}


Contains Method

Contains Method
Namespaces ► StructureMap.Graph ► PluginFamilyCollection ► Contains()()()
StructureMap API
Members
Icon | Member | Description
 | Contains(Type) |
 | Contains<(Of <(T>)>)()()() |


Contains Method

Contains<(Of <(T>)>) Method
Namespaces ► StructureMap.Graph ► PluginFamilyCollection ► Contains<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamilyCollection.Contains``1]

Declaration Syntax
C# Visual Basic Visual C++
public bool Contains<T>()

Public Function Contains(Of T) As Boolean
public:
generic<typename T>
bool Contains()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Graph.PluginFamilyCollection.Contains``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamilyCollection.Contains``1]


Contains Method (pluginType)

Contains Method (pluginType)
Namespaces ► StructureMap.Graph ► PluginFamilyCollection ► Contains(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamilyCollection.Contains(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public bool Contains(
    Type pluginType
)
Public Function Contains ( _
    pluginType As Type _
) As Boolean
public:
bool Contains(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.PluginFamilyCollection.Contains(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamilyCollection.Contains(System.Type)]


Count Property

Count Property
Namespaces ► StructureMap.Graph ► PluginFamilyCollection ► Count
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.PluginFamilyCollection.Count]

Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
property int Count {
    int get ();
}


Each Method (action)

Each Method (action)
Namespaces ► StructureMap.Graph ► PluginFamilyCollection ► Each(Action<(Of <(PluginFamily>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamilyCollection.Each(System.Action{StructureMap.Graph.PluginFamily})]

Declaration Syntax
C# Visual Basic Visual C++
public void Each(
    Action<PluginFamily> action
)
Public Sub Each ( _
    action As Action(Of PluginFamily) _
)
public:
void Each(
    Action<PluginFamily^>^ action
)
Parameters
action (Action <(Of <( PluginFamily >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Graph.PluginFamilyCollection.Each(System.Action{StructureMap.Graph.PluginFamily})"]


GetEnumerator Method

GetEnumerator Method
Namespaces ► StructureMap.Graph ► PluginFamilyCollection ► GetEnumerator()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamilyCollection.GetEnumerator]

Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginFamilyCollection.GetEnumerator]


Item Property (pluginType)

Item Property (pluginType)
Namespaces ► StructureMap.Graph ► PluginFamilyCollection ► Item[([(Type])])
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.PluginFamilyCollection.Item(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public PluginFamily this[
    Type pluginType
] { get; }
Public ReadOnly Default Property Item ( _
    pluginType As Type _
) As PluginFamily
public:
property PluginFamily^ default[Type^ pluginType] {
    PluginFamily^ get (Type^ pluginType);
}
Parameters
pluginType (Type)


Remove Method (family)

Remove Method (family)
Namespaces ► StructureMap.Graph ► PluginFamilyCollection ► Remove(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginFamilyCollection.Remove(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    PluginFamily family
)
Public Sub Remove ( _
    family As PluginFamily _
)
public:
void Remove(
    PluginFamily^ family
)
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Graph.PluginFamilyCollection.Remove(StructureMap.Graph.PluginFamily)"]


PluginGraph Class

PluginGraph Class
Namespaces ► StructureMap.Graph ► PluginGraph
StructureMap API
Models the runtime configuration of a StructureMap Container
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class PluginGraph : IPluginGraph
<SerializableAttribute> _
Public Class PluginGraph _
    Implements IPluginGraph
[SerializableAttribute]
public ref class PluginGraph : IPluginGraph
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PluginGraph()()() | Initializes a new instance of the PluginGraph class
 | PluginGraph(AssemblyScanner) | Initializes a new instance of the PluginGraph class
 | AddScanner(AssemblyScanner) |
 | AddType(Type, Type) | Adds the concreteType as an Instance of the pluginType
 | AddType(Type, Type, String) | Adds the concreteType as an Instance of the pluginType with a name
 | AddType(Type) | Add the pluggedType as an instance to any configured pluginType where pluggedType could be assigned to the pluginType
 | BuildGraphFromAssembly(Assembly) |
 | Configure(Action<(Of <(Registry>)>)) | Add configuration to a PluginGraph with the Registry DSL
 | ContainsFamily(Type) |
 | CreateFamily(Type) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FamilyCount |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindFamily(Type) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InterceptorLibrary |
 | IsSealed | Designates whether a PluginGraph has been "Sealed."
 | Log |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PluginFamilies |
 | ProfileManager |
 | Registries |
 | Scan(Action<(Of <(AssemblyScanner>)>)) | Adds an AssemblyScanner to the PluginGraph. Used for Testing.
 | Seal()()() | Closes the PluginGraph for adding or removing members. Runs all the AssemblyScanner's and attempts to attach concrete types to the proper plugin types. Calculates the Profile defaults.
 | SetDefault(String, Type, Instance) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PluginGraph


PluginGraph Constructor

PluginGraph Constructor
Namespaces ► StructureMap.Graph ► PluginGraph ► PluginGraph()()()
StructureMap API
Members
Icon | Member | Description
 | PluginGraph()()() | Initializes a new instance of the PluginGraph class
 | PluginGraph(AssemblyScanner) | Initializes a new instance of the PluginGraph class


PluginGraph Constructor

PluginGraph Constructor
Namespaces ► StructureMap.Graph ► PluginGraph ► PluginGraph()()()
StructureMap API
Initializes a new instance of the PluginGraph class
Declaration Syntax
C# Visual Basic Visual C++
public PluginGraph()
Public Sub New
public:
PluginGraph()


PluginGraph Constructor (assemblies)

PluginGraph Constructor (assemblies)
Namespaces ► StructureMap.Graph ► PluginGraph ► PluginGraph(AssemblyScanner)
StructureMap API
Initializes a new instance of the PluginGraph class
Declaration Syntax
C# Visual Basic Visual C++
public PluginGraph(
    AssemblyScanner assemblies
)
Public Sub New ( _
    assemblies As AssemblyScanner _
)
public:
PluginGraph(
    AssemblyScanner^ assemblies
)
Parameters
assemblies (AssemblyScanner)

[Missing <param name="assemblies"/> documentation for "M:StructureMap.Graph.PluginGraph.#ctor(StructureMap.Graph.AssemblyScanner)"]


AddScanner Method (scanner)

AddScanner Method (scanner)
Namespaces ► StructureMap.Graph ► PluginGraph ► AddScanner(AssemblyScanner)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginGraph.AddScanner(StructureMap.Graph.AssemblyScanner)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddScanner(
    AssemblyScanner scanner
)
Public Sub AddScanner ( _
    scanner As AssemblyScanner _
)
public:
void AddScanner(
    AssemblyScanner^ scanner
)
Parameters
scanner (AssemblyScanner)

[Missing <param name="scanner"/> documentation for "M:StructureMap.Graph.PluginGraph.AddScanner(StructureMap.Graph.AssemblyScanner)"]


AddType Method

AddType Method
Namespaces ► StructureMap.Graph ► PluginGraph ► AddType()()()
StructureMap API
Members
Icon | Member | Description
 | AddType(Type, Type) | Adds the concreteType as an Instance of the pluginType
 | AddType(Type, Type, String) | Adds the concreteType as an Instance of the pluginType with a name
 | AddType(Type) | Add the pluggedType as an instance to any configured pluginType where pluggedType could be assigned to the pluginType


AddType Method (pluggedType)

AddType Method (pluggedType)
Namespaces ► StructureMap.Graph ► PluginGraph ► AddType(Type)
StructureMap API
Add the pluggedType as an instance to any configured pluginType where pluggedType could be assigned to the pluginType
Declaration Syntax
C# Visual Basic Visual C++
public void AddType(
    Type pluggedType
)
Public Sub AddType ( _
    pluggedType As Type _
)
public:
virtual void AddType(
    Type^ pluggedType
) sealed
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.PluginGraph.AddType(System.Type)"]


AddType Method (pluginType, concreteType)

AddType Method (pluginType, concreteType)
Namespaces ► StructureMap.Graph ► PluginGraph ► AddType(Type, Type)
StructureMap API
Adds the concreteType as an Instance of the pluginType
Declaration Syntax
C# Visual Basic Visual C++
public void AddType(
    Type pluginType,
    Type concreteType
)
Public Sub AddType ( _
    pluginType As Type, _
    concreteType As Type _
)
public:
virtual void AddType(
    Type^ pluginType,
    Type^ concreteType
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.PluginGraph.AddType(System.Type,System.Type)"]

concreteType (Type)

[Missing <param name="concreteType"/> documentation for "M:StructureMap.Graph.PluginGraph.AddType(System.Type,System.Type)"]


AddType Method (pluginType, concreteType, name)

AddType Method (pluginType, concreteType, name)
Namespaces ► StructureMap.Graph ► PluginGraph ► AddType(Type, Type, String)
StructureMap API
Adds the concreteType as an Instance of the pluginType with a name
Declaration Syntax
C# Visual Basic Visual C++
public void AddType(
    Type pluginType,
    Type concreteType,
    string name
)
Public Sub AddType ( _
    pluginType As Type, _
    concreteType As Type, _
    name As String _
)
public:
virtual void AddType(
    Type^ pluginType,
    Type^ concreteType,
    String^ name
) sealed
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.PluginGraph.AddType(System.Type,System.Type,System.String)"]

concreteType (Type)

[Missing <param name="concreteType"/> documentation for "M:StructureMap.Graph.PluginGraph.AddType(System.Type,System.Type,System.String)"]

name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Graph.PluginGraph.AddType(System.Type,System.Type,System.String)"]


BuildGraphFromAssembly Method (assembly)

BuildGraphFromAssembly Method (assembly)
Namespaces ► StructureMap.Graph ► PluginGraph ► BuildGraphFromAssembly(Assembly)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginGraph.BuildGraphFromAssembly(System.Reflection.Assembly)]

Declaration Syntax
C# Visual Basic Visual C++
public static PluginGraph BuildGraphFromAssembly(
    Assembly assembly
)
Public Shared Function BuildGraphFromAssembly ( _
    assembly As Assembly _
) As PluginGraph
public:
static PluginGraph^ BuildGraphFromAssembly(
    Assembly^ assembly
)
Parameters
assembly (Assembly)

[Missing <param name="assembly"/> documentation for "M:StructureMap.Graph.PluginGraph.BuildGraphFromAssembly(System.Reflection.Assembly)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginGraph.BuildGraphFromAssembly(System.Reflection.Assembly)]


Configure Method (action)

Configure Method (action)
Namespaces ► StructureMap.Graph ► PluginGraph ► Configure(Action<(Of <(Registry>)>))
StructureMap API
Add configuration to a PluginGraph with the Registry DSL
Declaration Syntax
C# Visual Basic Visual C++
public void Configure(
    Action<Registry> action
)
Public Sub Configure ( _
    action As Action(Of Registry) _
)
public:
void Configure(
    Action<Registry^>^ action
)
Parameters
action (Action <(Of <( Registry >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Graph.PluginGraph.Configure(System.Action{StructureMap.Configuration.DSL.Registry})"]


ContainsFamily Method (pluginType)

ContainsFamily Method (pluginType)
Namespaces ► StructureMap.Graph ► PluginGraph ► ContainsFamily(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginGraph.ContainsFamily(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public bool ContainsFamily(
    Type pluginType
)
Public Function ContainsFamily ( _
    pluginType As Type _
) As Boolean
public:
bool ContainsFamily(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.PluginGraph.ContainsFamily(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginGraph.ContainsFamily(System.Type)]


CreateFamily Method (pluginType)

CreateFamily Method (pluginType)
Namespaces ► StructureMap.Graph ► PluginGraph ► CreateFamily(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginGraph.CreateFamily(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public void CreateFamily(
    Type pluginType
)
Public Sub CreateFamily ( _
    pluginType As Type _
)
public:
void CreateFamily(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.PluginGraph.CreateFamily(System.Type)"]


FamilyCount Property

FamilyCount Property
Namespaces ► StructureMap.Graph ► PluginGraph ► FamilyCount
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.PluginGraph.FamilyCount]

Declaration Syntax
C# Visual Basic Visual C++
public int FamilyCount { get; }
Public ReadOnly Property FamilyCount As Integer
public:
property int FamilyCount {
    int get ();
}


FindFamily Method (pluginType)

FindFamily Method (pluginType)
Namespaces ► StructureMap.Graph ► PluginGraph ► FindFamily(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginGraph.FindFamily(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public PluginFamily FindFamily(
    Type pluginType
)
Public Function FindFamily ( _
    pluginType As Type _
) As PluginFamily
public:
PluginFamily^ FindFamily(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.PluginGraph.FindFamily(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.PluginGraph.FindFamily(System.Type)]


InterceptorLibrary Property

InterceptorLibrary Property
Namespaces ► StructureMap.Graph ► PluginGraph ► InterceptorLibrary
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.PluginGraph.InterceptorLibrary]

Declaration Syntax
C# Visual Basic Visual C++
public InterceptorLibrary InterceptorLibrary { get; }
Public ReadOnly Property InterceptorLibrary As InterceptorLibrary
public:
property InterceptorLibrary^ InterceptorLibrary {
    InterceptorLibrary^ get ();
}


IsSealed Property

IsSealed Property
Namespaces ► StructureMap.Graph ► PluginGraph ► IsSealed
StructureMap API
Designates whether a PluginGraph has been "Sealed."
Declaration Syntax
C# Visual Basic Visual C++
public bool IsSealed { get; }
Public ReadOnly Property IsSealed As Boolean
public:
property bool IsSealed {
    bool get ();
}


Log Property

Log Property
Namespaces ► StructureMap.Graph ► PluginGraph ► Log
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.PluginGraph.Log]

Declaration Syntax
C# Visual Basic Visual C++
public GraphLog Log { get; set; }
Public Property Log As GraphLog
public:
property GraphLog^ Log {
    GraphLog^ get ();
    void set (GraphLog^ value);
}


PluginFamilies Property

PluginFamilies Property
Namespaces ► StructureMap.Graph ► PluginGraph ► PluginFamilies
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.PluginGraph.PluginFamilies]

Declaration Syntax
C# Visual Basic Visual C++
public PluginFamilyCollection PluginFamilies { get; }
Public ReadOnly Property PluginFamilies As PluginFamilyCollection
public:
property PluginFamilyCollection^ PluginFamilies {
    PluginFamilyCollection^ get ();
}


ProfileManager Property

ProfileManager Property
Namespaces ► StructureMap.Graph ► PluginGraph ► ProfileManager
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.PluginGraph.ProfileManager]

Declaration Syntax
C# Visual Basic Visual C++
public ProfileManager ProfileManager { get; }
Public ReadOnly Property ProfileManager As ProfileManager
public:
property ProfileManager^ ProfileManager {
    ProfileManager^ get ();
}


Registries Property

Registries Property
Namespaces ► StructureMap.Graph ► PluginGraph ► Registries
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.PluginGraph.Registries]

Declaration Syntax
C# Visual Basic Visual C++
public List<Registry> Registries { get; }
Public ReadOnly Property Registries As List(Of Registry)
public:
property List<Registry^>^ Registries {
    List<Registry^>^ get ();
}


Scan Method (action)

Scan Method (action)
Namespaces ► StructureMap.Graph ► PluginGraph ► Scan(Action<(Of <(AssemblyScanner>)>))
StructureMap API
Adds an AssemblyScanner to the PluginGraph. Used for Testing.
Declaration Syntax
C# Visual Basic Visual C++
public void Scan(
    Action<AssemblyScanner> action
)
Public Sub Scan ( _
    action As Action(Of AssemblyScanner) _
)
public:
void Scan(
    Action<AssemblyScanner^>^ action
)
Parameters
action (Action <(Of <( AssemblyScanner >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Graph.PluginGraph.Scan(System.Action{StructureMap.Graph.AssemblyScanner})"]


Seal Method

Seal Method
Namespaces ► StructureMap.Graph ► PluginGraph ► Seal()()()
StructureMap API
Closes the PluginGraph for adding or removing members. Runs all the AssemblyScanner's and attempts to attach concrete types to the proper plugin types. Calculates the Profile defaults.
Declaration Syntax
C# Visual Basic Visual C++
public void Seal()
Public Sub Seal
public:
void Seal()


SetDefault Method (profileName, pluginType, instance)

SetDefault Method (profileName, pluginType, instance)
Namespaces ► StructureMap.Graph ► PluginGraph ► SetDefault(String, Type, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.PluginGraph.SetDefault(System.String,System.Type,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetDefault(
    string profileName,
    Type pluginType,
    Instance instance
)
Public Sub SetDefault ( _
    profileName As String, _
    pluginType As Type, _
    instance As Instance _
)
public:
void SetDefault(
    String^ profileName,
    Type^ pluginType,
    Instance^ instance
)
Parameters
profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Graph.PluginGraph.SetDefault(System.String,System.Type,StructureMap.Pipeline.Instance)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.PluginGraph.SetDefault(System.String,System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Graph.PluginGraph.SetDefault(System.String,System.Type,StructureMap.Pipeline.Instance)"]


SetterProperty Class

SetterProperty Class
Namespaces ► StructureMap.Graph ► SetterProperty
StructureMap API
Represents a PropertyInfo of a Plugin.PluggedType that is filled by Setter Injection
Declaration Syntax
C# Visual Basic Visual C++
public class SetterProperty : TypeRules
Public Class SetterProperty _
    Inherits TypeRules
public ref class SetterProperty : public TypeRules
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetterProperty(PropertyInfo) | Initializes a new instance of the SetterProperty class
 | CanBeAutoFilled |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAutoFillable(Type) | (Inherited from TypeRules.)
 | IsChild(Type) | (Inherited from TypeRules.)
 | IsChildArray(Type) | (Inherited from TypeRules.)
 | IsConcrete(Type) | (Inherited from TypeRules.)
 | IsEnum(Type) | (Inherited from TypeRules.)
 | IsMandatory |
 | IsPrimitive(Type) | (Inherited from TypeRules.)
 | IsPrimitiveArray(Type) | (Inherited from TypeRules.)
 | IsSimple(Type) | (Inherited from TypeRules.)
 | IsString(Type) | (Inherited from TypeRules.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | Property |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Visit(IArgumentVisitor) |
Inheritance Hierarchy
Object
 | TypeRules
 |  | SetterProperty


SetterProperty Constructor (property)

SetterProperty Constructor (property)
Namespaces ► StructureMap.Graph ► SetterProperty ► SetterProperty(PropertyInfo)
StructureMap API
Initializes a new instance of the SetterProperty class
Declaration Syntax
C# Visual Basic Visual C++
public SetterProperty(
    PropertyInfo property
)
Public Sub New ( _
    property As PropertyInfo _
)
public:
SetterProperty(
    PropertyInfo^ property
)
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Graph.SetterProperty.#ctor(System.Reflection.PropertyInfo)"]


CanBeAutoFilled Property

CanBeAutoFilled Property
Namespaces ► StructureMap.Graph ► SetterProperty ► CanBeAutoFilled
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.SetterProperty.CanBeAutoFilled]

Declaration Syntax
C# Visual Basic Visual C++
public bool CanBeAutoFilled { get; }
Public ReadOnly Property CanBeAutoFilled As Boolean
public:
property bool CanBeAutoFilled {
    bool get ();
}


IsMandatory Property

IsMandatory Property
Namespaces ► StructureMap.Graph ► SetterProperty ► IsMandatory
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.SetterProperty.IsMandatory]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsMandatory { get; set; }
Public Property IsMandatory As Boolean
public:
property bool IsMandatory {
    bool get ();
    void set (bool value);
}


Name Property

Name Property
Namespaces ► StructureMap.Graph ► SetterProperty ► Name
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.SetterProperty.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}


Property Property

Property Property
Namespaces ► StructureMap.Graph ► SetterProperty ► Property
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.SetterProperty.Property]

Declaration Syntax
C# Visual Basic Visual C++
public PropertyInfo Property { get; }
Public ReadOnly Property Property As PropertyInfo
public:
property PropertyInfo^ Property {
    PropertyInfo^ get ();
}


Visit Method (visitor)

Visit Method (visitor)
Namespaces ► StructureMap.Graph ► SetterProperty ► Visit(IArgumentVisitor)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.SetterProperty.Visit(StructureMap.Graph.IArgumentVisitor)]

Declaration Syntax
C# Visual Basic Visual C++
public void Visit(
    IArgumentVisitor visitor
)
Public Sub Visit ( _
    visitor As IArgumentVisitor _
)
public:
void Visit(
    IArgumentVisitor^ visitor
)
Parameters
visitor (IArgumentVisitor)

[Missing <param name="visitor"/> documentation for "M:StructureMap.Graph.SetterProperty.Visit(StructureMap.Graph.IArgumentVisitor)"]


SetterPropertyCollection Class

SetterPropertyCollection Class
Namespaces ► StructureMap.Graph ► SetterPropertyCollection
StructureMap API
Custom collection class for SetterProperty objects
Declaration Syntax
C# Visual Basic Visual C++
public class SetterPropertyCollection : IEnumerable<SetterProperty>,
    IEnumerable
Public Class SetterPropertyCollection _
    Implements IEnumerable(Of SetterProperty), IEnumerable
public ref class SetterPropertyCollection : IEnumerable<SetterProperty^>,
    IEnumerable
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SetterPropertyCollection(Plugin) | Initializes a new instance of the SetterPropertyCollection class
 | CanBeAutoFilled()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindFirstConstructorArgumentOfType(Type) |
 | GetEnumerator()()() |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsMandatory(String) |
 | MandatoryCount |
 | MarkSetterAsMandatory(String) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(SetterPropertyCollection) |
 | OptionalCount |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Visit(IArgumentVisitor) |
Inheritance Hierarchy
Object
SetterPropertyCollection


SetterPropertyCollection Constructor (plugin)

SetterPropertyCollection Constructor (plugin)
Namespaces ► StructureMap.Graph ► SetterPropertyCollection ► SetterPropertyCollection(Plugin)
StructureMap API
Initializes a new instance of the SetterPropertyCollection class
Declaration Syntax
C# Visual Basic Visual C++
public SetterPropertyCollection(
    Plugin plugin
)
Public Sub New ( _
    plugin As Plugin _
)
public:
SetterPropertyCollection(
    Plugin^ plugin
)
Parameters
plugin (Plugin)

[Missing <param name="plugin"/> documentation for "M:StructureMap.Graph.SetterPropertyCollection.#ctor(StructureMap.Graph.Plugin)"]


CanBeAutoFilled Method

CanBeAutoFilled Method
Namespaces ► StructureMap.Graph ► SetterPropertyCollection ► CanBeAutoFilled()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.SetterPropertyCollection.CanBeAutoFilled]

Declaration Syntax
C# Visual Basic Visual C++
public bool CanBeAutoFilled()
Public Function CanBeAutoFilled As Boolean
public:
bool CanBeAutoFilled()
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.SetterPropertyCollection.CanBeAutoFilled]


FindFirstConstructorArgumentOfType Method (type)

FindFirstConstructorArgumentOfType Method (type)
Namespaces ► StructureMap.Graph ► SetterPropertyCollection ► FindFirstConstructorArgumentOfType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.SetterPropertyCollection.FindFirstConstructorArgumentOfType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public string FindFirstConstructorArgumentOfType(
    Type type
)
Public Function FindFirstConstructorArgumentOfType ( _
    type As Type _
) As String
public:
String^ FindFirstConstructorArgumentOfType(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.SetterPropertyCollection.FindFirstConstructorArgumentOfType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.SetterPropertyCollection.FindFirstConstructorArgumentOfType(System.Type)]


GetEnumerator Method

GetEnumerator Method
Namespaces ► StructureMap.Graph ► SetterPropertyCollection ► GetEnumerator()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.SetterPropertyCollection.GetEnumerator]

Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator GetEnumerator()
Public Function GetEnumerator As IEnumerator
public:
virtual IEnumerator^ GetEnumerator() sealed
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.SetterPropertyCollection.GetEnumerator]


IsMandatory Method (propertyName)

IsMandatory Method (propertyName)
Namespaces ► StructureMap.Graph ► SetterPropertyCollection ► IsMandatory(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.SetterPropertyCollection.IsMandatory(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public bool IsMandatory(
    string propertyName
)
Public Function IsMandatory ( _
    propertyName As String _
) As Boolean
public:
bool IsMandatory(
    String^ propertyName
)
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Graph.SetterPropertyCollection.IsMandatory(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.SetterPropertyCollection.IsMandatory(System.String)]


MandatoryCount Property

MandatoryCount Property
Namespaces ► StructureMap.Graph ► SetterPropertyCollection ► MandatoryCount
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.SetterPropertyCollection.MandatoryCount]

Declaration Syntax
C# Visual Basic Visual C++
public int MandatoryCount { get; }
Public ReadOnly Property MandatoryCount As Integer
public:
property int MandatoryCount {
    int get ();
}


MarkSetterAsMandatory Method (propertyName)

MarkSetterAsMandatory Method (propertyName)
Namespaces ► StructureMap.Graph ► SetterPropertyCollection ► MarkSetterAsMandatory(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.SetterPropertyCollection.MarkSetterAsMandatory(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public SetterProperty MarkSetterAsMandatory(
    string propertyName
)
Public Function MarkSetterAsMandatory ( _
    propertyName As String _
) As SetterProperty
public:
SetterProperty^ MarkSetterAsMandatory(
    String^ propertyName
)
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Graph.SetterPropertyCollection.MarkSetterAsMandatory(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.SetterPropertyCollection.MarkSetterAsMandatory(System.String)]


Merge Method (setters)

Merge Method (setters)
Namespaces ► StructureMap.Graph ► SetterPropertyCollection ► Merge(SetterPropertyCollection)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.SetterPropertyCollection.Merge(StructureMap.Graph.SetterPropertyCollection)]

Declaration Syntax
C# Visual Basic Visual C++
public void Merge(
    SetterPropertyCollection setters
)
Public Sub Merge ( _
    setters As SetterPropertyCollection _
)
public:
void Merge(
    SetterPropertyCollection^ setters
)
Parameters
setters (SetterPropertyCollection)

[Missing <param name="setters"/> documentation for "M:StructureMap.Graph.SetterPropertyCollection.Merge(StructureMap.Graph.SetterPropertyCollection)"]


OptionalCount Property

OptionalCount Property
Namespaces ► StructureMap.Graph ► SetterPropertyCollection ► OptionalCount
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.SetterPropertyCollection.OptionalCount]

Declaration Syntax
C# Visual Basic Visual C++
public int OptionalCount { get; }
Public ReadOnly Property OptionalCount As Integer
public:
property int OptionalCount {
    int get ();
}


Visit Method (visitor)

Visit Method (visitor)
Namespaces ► StructureMap.Graph ► SetterPropertyCollection ► Visit(IArgumentVisitor)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.SetterPropertyCollection.Visit(StructureMap.Graph.IArgumentVisitor)]

Declaration Syntax
C# Visual Basic Visual C++
public void Visit(
    IArgumentVisitor visitor
)
Public Sub Visit ( _
    visitor As IArgumentVisitor _
)
public:
void Visit(
    IArgumentVisitor^ visitor
)
Parameters
visitor (IArgumentVisitor)

[Missing <param name="visitor"/> documentation for "M:StructureMap.Graph.SetterPropertyCollection.Visit(StructureMap.Graph.IArgumentVisitor)"]


TypeExtensions Class

TypeExtensions Class
Namespaces ► StructureMap.Graph ► TypeExtensions
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.TypeExtensions]

Declaration Syntax
C# Visual Basic Visual C++
public static class TypeExtensions
Public NotInheritable Class TypeExtensions
public ref class TypeExtensions abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | IsInNamespace(Type, String) |
Inheritance Hierarchy
Object
TypeExtensions


IsInNamespace Method (type, nameSpace)

IsInNamespace Method (type, nameSpace)
Namespaces ► StructureMap.Graph ► TypeExtensions ► IsInNamespace(Type, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypeExtensions.IsInNamespace(System.Type,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static bool IsInNamespace(
    Type type,
    string nameSpace
)
Public Shared Function IsInNamespace ( _
    type As Type, _
    nameSpace As String _
) As Boolean
public:
static bool IsInNamespace(
    Type^ type,
    String^ nameSpace
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.TypeExtensions.IsInNamespace(System.Type,System.String)"]

nameSpace (String)

[Missing <param name="nameSpace"/> documentation for "M:StructureMap.Graph.TypeExtensions.IsInNamespace(System.Type,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypeExtensions.IsInNamespace(System.Type,System.String)]


TypePath Class

TypePath Class
Namespaces ► StructureMap.Graph ► TypePath
StructureMap API
Designates a CLR type that is loaded by name.
Declaration Syntax
C# Visual Basic Visual C++
[SerializableAttribute]
public class TypePath
<SerializableAttribute> _
Public Class TypePath
[SerializableAttribute]
public ref class TypePath
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TypePath(String, String) | Initializes a new instance of the TypePath class
 | TypePath(Type) | Initializes a new instance of the TypePath class
 | TypePath(String) | Initializes a new instance of the TypePath class
 | AssemblyName |
 | AssemblyQualifiedName |
 | ClassName |
 | CreateFromXmlNode(XmlNode) |
 | Equals(Object) | (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindType()()() |
 | GetAssemblyQualifiedName(Type) |
 | GetHashCode()()() | (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | (Overrides Object.ToString()()().)
 | WriteTypePathToXmlElement(Type, XmlElement) |
Inheritance Hierarchy
Object
TypePath


TypePath Constructor

TypePath Constructor
Namespaces ► StructureMap.Graph ► TypePath ► TypePath()()()
StructureMap API
Members
Icon | Member | Description
 | TypePath(String, String) | Initializes a new instance of the TypePath class
 | TypePath(Type) | Initializes a new instance of the TypePath class
 | TypePath(String) | Initializes a new instance of the TypePath class


TypePath Constructor (assemblyQualifiedName)

TypePath Constructor (assemblyQualifiedName)
Namespaces ► StructureMap.Graph ► TypePath ► TypePath(String)
StructureMap API
Initializes a new instance of the TypePath class
Declaration Syntax
C# Visual Basic Visual C++
public TypePath(
    string assemblyQualifiedName
)
Public Sub New ( _
    assemblyQualifiedName As String _
)
public:
TypePath(
    String^ assemblyQualifiedName
)
Parameters
assemblyQualifiedName (String)

[Missing <param name="assemblyQualifiedName"/> documentation for "M:StructureMap.Graph.TypePath.#ctor(System.String)"]


TypePath Constructor (assemblyName, className)

TypePath Constructor (assemblyName, className)
Namespaces ► StructureMap.Graph ► TypePath ► TypePath(String, String)
StructureMap API
Initializes a new instance of the TypePath class
Declaration Syntax
C# Visual Basic Visual C++
public TypePath(
    string assemblyName,
    string className
)
Public Sub New ( _
    assemblyName As String, _
    className As String _
)
public:
TypePath(
    String^ assemblyName,
    String^ className
)
Parameters
assemblyName (String)

[Missing <param name="assemblyName"/> documentation for "M:StructureMap.Graph.TypePath.#ctor(System.String,System.String)"]

className (String)

[Missing <param name="className"/> documentation for "M:StructureMap.Graph.TypePath.#ctor(System.String,System.String)"]


TypePath Constructor (type)

TypePath Constructor (type)
Namespaces ► StructureMap.Graph ► TypePath ► TypePath(Type)
StructureMap API
Initializes a new instance of the TypePath class
Declaration Syntax
C# Visual Basic Visual C++
public TypePath(
    Type type
)
Public Sub New ( _
    type As Type _
)
public:
TypePath(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.TypePath.#ctor(System.Type)"]


AssemblyName Property

AssemblyName Property
Namespaces ► StructureMap.Graph ► TypePath ► AssemblyName
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.TypePath.AssemblyName]

Declaration Syntax
C# Visual Basic Visual C++
public string AssemblyName { get; }
Public ReadOnly Property AssemblyName As String
public:
property String^ AssemblyName {
    String^ get ();
}


AssemblyQualifiedName Property

AssemblyQualifiedName Property
Namespaces ► StructureMap.Graph ► TypePath ► AssemblyQualifiedName
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.TypePath.AssemblyQualifiedName]

Declaration Syntax
C# Visual Basic Visual C++
public string AssemblyQualifiedName { get; }
Public ReadOnly Property AssemblyQualifiedName As String
public:
property String^ AssemblyQualifiedName {
    String^ get ();
}


ClassName Property

ClassName Property
Namespaces ► StructureMap.Graph ► TypePath ► ClassName
StructureMap API

[Missing <summary> documentation for P:StructureMap.Graph.TypePath.ClassName]

Declaration Syntax
C# Visual Basic Visual C++
public string ClassName { get; }
Public ReadOnly Property ClassName As String
public:
property String^ ClassName {
    String^ get ();
}


CreateFromXmlNode Method (node)

CreateFromXmlNode Method (node)
Namespaces ► StructureMap.Graph ► TypePath ► CreateFromXmlNode(XmlNode)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypePath.CreateFromXmlNode(System.Xml.XmlNode)]

Declaration Syntax
C# Visual Basic Visual C++
public static TypePath CreateFromXmlNode(
    XmlNode node
)
Public Shared Function CreateFromXmlNode ( _
    node As XmlNode _
) As TypePath
public:
static TypePath^ CreateFromXmlNode(
    XmlNode^ node
)
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.Graph.TypePath.CreateFromXmlNode(System.Xml.XmlNode)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypePath.CreateFromXmlNode(System.Xml.XmlNode)]


Equals Method (obj)

Equals Method (obj)
Namespaces ► StructureMap.Graph ► TypePath ► Equals(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypePath.Equals(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:StructureMap.Graph.TypePath.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypePath.Equals(System.Object)]


FindType Method

FindType Method
Namespaces ► StructureMap.Graph ► TypePath ► FindType()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypePath.FindType]

Declaration Syntax
C# Visual Basic Visual C++
public Type FindType()
Public Function FindType As Type
public:
Type^ FindType()
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypePath.FindType]


GetAssemblyQualifiedName Method (type)

GetAssemblyQualifiedName Method (type)
Namespaces ► StructureMap.Graph ► TypePath ► GetAssemblyQualifiedName(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypePath.GetAssemblyQualifiedName(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public static string GetAssemblyQualifiedName(
    Type type
)
Public Shared Function GetAssemblyQualifiedName ( _
    type As Type _
) As String
public:
static String^ GetAssemblyQualifiedName(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.TypePath.GetAssemblyQualifiedName(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypePath.GetAssemblyQualifiedName(System.Type)]


GetHashCode Method

GetHashCode Method
Namespaces ► StructureMap.Graph ► TypePath ► GetHashCode()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypePath.GetHashCode]

Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypePath.GetHashCode]


ToString Method

ToString Method
Namespaces ► StructureMap.Graph ► TypePath ► ToString()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypePath.ToString]

Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypePath.ToString]


WriteTypePathToXmlElement Method (type, element)

WriteTypePathToXmlElement Method (type, element)
Namespaces ► StructureMap.Graph ► TypePath ► WriteTypePathToXmlElement(Type, XmlElement)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypePath.WriteTypePathToXmlElement(System.Type,System.Xml.XmlElement)]

Declaration Syntax
C# Visual Basic Visual C++
public static void WriteTypePathToXmlElement(
    Type type,
    XmlElement element
)
Public Shared Sub WriteTypePathToXmlElement ( _
    type As Type, _
    element As XmlElement _
)
public:
static void WriteTypePathToXmlElement(
    Type^ type,
    XmlElement^ element
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.TypePath.WriteTypePathToXmlElement(System.Type,System.Xml.XmlElement)"]

element (XmlElement)

[Missing <param name="element"/> documentation for "M:StructureMap.Graph.TypePath.WriteTypePathToXmlElement(System.Type,System.Xml.XmlElement)"]


TypeRules Class

TypeRules Class
Namespaces ► StructureMap.Graph ► TypeRules
StructureMap API

[Missing <summary> documentation for T:StructureMap.Graph.TypeRules]

Declaration Syntax
C# Visual Basic Visual C++
public class TypeRules
Public Class TypeRules
public ref class TypeRules
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | TypeRules()()() | Initializes a new instance of the TypeRules class
 | CanBeCast(Type, Type) | Determines if the pluggedType can be upcast to the pluginType
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | IsAutoFillable(Type) |
 | IsChild(Type) |
 | IsChildArray(Type) |
 | IsConcrete(Type) |
 | IsEnum(Type) |
 | IsExplicitlyMarkedAsPlugin(Type, Type) | Determines if the PluggedType is a valid Plugin into the PluginType
 | IsPrimitive(Type) |
 | IsPrimitiveArray(Type) |
 | IsSimple(Type) |
 | IsString(Type) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | TypeRules
 |  | PrimitiveArrayReader
 |  | Container
 |  | Constructor
 |  | DefaultConventionScanner
 |  | FindAllTypesFilter
 |  | Plugin
 |  | PluginFamily
 |  | SetterProperty
 |  | Model


TypeRules Constructor

TypeRules Constructor
Namespaces ► StructureMap.Graph ► TypeRules ► TypeRules()()()
StructureMap API
Initializes a new instance of the TypeRules class
Declaration Syntax
C# Visual Basic Visual C++
public TypeRules()
Public Sub New
public:
TypeRules()


CanBeCast Method (pluginType, pluggedType)

CanBeCast Method (pluginType, pluggedType)
Namespaces ► StructureMap.Graph ► TypeRules ► CanBeCast(Type, Type)
StructureMap API
Determines if the pluggedType can be upcast to the pluginType
Declaration Syntax
C# Visual Basic Visual C++
public static bool CanBeCast(
    Type pluginType,
    Type pluggedType
)
Public Shared Function CanBeCast ( _
    pluginType As Type, _
    pluggedType As Type _
) As Boolean
public:
static bool CanBeCast(
    Type^ pluginType,
    Type^ pluggedType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.TypeRules.CanBeCast(System.Type,System.Type)"]

pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.TypeRules.CanBeCast(System.Type,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypeRules.CanBeCast(System.Type,System.Type)]


IsAutoFillable Method (type)

IsAutoFillable Method (type)
Namespaces ► StructureMap.Graph ► TypeRules ► IsAutoFillable(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypeRules.IsAutoFillable(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected bool IsAutoFillable(
    Type type
)
Protected Function IsAutoFillable ( _
    type As Type _
) As Boolean
protected:
bool IsAutoFillable(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.TypeRules.IsAutoFillable(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypeRules.IsAutoFillable(System.Type)]


IsChild Method (type)

IsChild Method (type)
Namespaces ► StructureMap.Graph ► TypeRules ► IsChild(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypeRules.IsChild(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected bool IsChild(
    Type type
)
Protected Function IsChild ( _
    type As Type _
) As Boolean
protected:
bool IsChild(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.TypeRules.IsChild(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypeRules.IsChild(System.Type)]


IsChildArray Method (type)

IsChildArray Method (type)
Namespaces ► StructureMap.Graph ► TypeRules ► IsChildArray(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypeRules.IsChildArray(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected bool IsChildArray(
    Type type
)
Protected Function IsChildArray ( _
    type As Type _
) As Boolean
protected:
bool IsChildArray(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.TypeRules.IsChildArray(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypeRules.IsChildArray(System.Type)]


IsConcrete Method (type)

IsConcrete Method (type)
Namespaces ► StructureMap.Graph ► TypeRules ► IsConcrete(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypeRules.IsConcrete(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected bool IsConcrete(
    Type type
)
Protected Function IsConcrete ( _
    type As Type _
) As Boolean
protected:
bool IsConcrete(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.TypeRules.IsConcrete(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypeRules.IsConcrete(System.Type)]


IsEnum Method (type)

IsEnum Method (type)
Namespaces ► StructureMap.Graph ► TypeRules ► IsEnum(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypeRules.IsEnum(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected bool IsEnum(
    Type type
)
Protected Function IsEnum ( _
    type As Type _
) As Boolean
protected:
bool IsEnum(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.TypeRules.IsEnum(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypeRules.IsEnum(System.Type)]


IsExplicitlyMarkedAsPlugin Method (pluginType, pluggedType)

IsExplicitlyMarkedAsPlugin Method (pluginType, pluggedType)
Namespaces ► StructureMap.Graph ► TypeRules ► IsExplicitlyMarkedAsPlugin(Type, Type)
StructureMap API
Determines if the PluggedType is a valid Plugin into the PluginType
Declaration Syntax
C# Visual Basic Visual C++
public static bool IsExplicitlyMarkedAsPlugin(
    Type pluginType,
    Type pluggedType
)
Public Shared Function IsExplicitlyMarkedAsPlugin ( _
    pluginType As Type, _
    pluggedType As Type _
) As Boolean
public:
static bool IsExplicitlyMarkedAsPlugin(
    Type^ pluginType,
    Type^ pluggedType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Graph.TypeRules.IsExplicitlyMarkedAsPlugin(System.Type,System.Type)"]

pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Graph.TypeRules.IsExplicitlyMarkedAsPlugin(System.Type,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypeRules.IsExplicitlyMarkedAsPlugin(System.Type,System.Type)]


IsPrimitive Method (type)

IsPrimitive Method (type)
Namespaces ► StructureMap.Graph ► TypeRules ► IsPrimitive(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypeRules.IsPrimitive(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected bool IsPrimitive(
    Type type
)
Protected Function IsPrimitive ( _
    type As Type _
) As Boolean
protected:
bool IsPrimitive(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.TypeRules.IsPrimitive(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypeRules.IsPrimitive(System.Type)]


IsPrimitiveArray Method (type)

IsPrimitiveArray Method (type)
Namespaces ► StructureMap.Graph ► TypeRules ► IsPrimitiveArray(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypeRules.IsPrimitiveArray(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected bool IsPrimitiveArray(
    Type type
)
Protected Function IsPrimitiveArray ( _
    type As Type _
) As Boolean
protected:
bool IsPrimitiveArray(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.TypeRules.IsPrimitiveArray(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypeRules.IsPrimitiveArray(System.Type)]


IsSimple Method (type)

IsSimple Method (type)
Namespaces ► StructureMap.Graph ► TypeRules ► IsSimple(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypeRules.IsSimple(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected bool IsSimple(
    Type type
)
Protected Function IsSimple ( _
    type As Type _
) As Boolean
protected:
bool IsSimple(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.TypeRules.IsSimple(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypeRules.IsSimple(System.Type)]


IsString Method (type)

IsString Method (type)
Namespaces ► StructureMap.Graph ► TypeRules ► IsString(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Graph.TypeRules.IsString(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected bool IsString(
    Type type
)
Protected Function IsString ( _
    type As Type _
) As Boolean
protected:
bool IsString(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Graph.TypeRules.IsString(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Graph.TypeRules.IsString(System.Type)]


StructureMap.Interceptors Namespace

StructureMap.Interceptors Namespace
Namespaces ► StructureMap.Interceptors
StructureMap API

[Missing <summary> documentation for N:StructureMap.Interceptors]

Declaration Syntax
C# Visual Basic Visual C++
namespace StructureMap.Interceptors
Namespace StructureMap.Interceptors
namespace StructureMap.Interceptors
Types
All Types Classes Interfaces Delegates
Icon | Type | Description
 | CompoundInterceptor |
 | EnrichmentHandler<(Of <(T>)>) |
 | EnrichmentInterceptor<(Of <(T>)>) |
 | InstanceInterceptor | An InstanceInterceptor can be registered on a per-Instance basis to act on, or even replace, the object that is created before it is passed back to the caller. This is primarily a hook for runtime AOP scenarios.
 | InterceptorLibrary |
 | MatchedTypeInterceptor |
 | NulloInterceptor |
 | PluginTypeInterceptor | A TypeInterceptor that always applies to all Instances of a given Plugin Type
 | StartupInterceptor<(Of <(T>)>) |
 | TypeInterceptor | A TypeInterceptor that is only applied if the MatchesType() method is true for a given Type


CompoundInterceptor Class

CompoundInterceptor Class
Namespaces ► StructureMap.Interceptors ► CompoundInterceptor
StructureMap API

[Missing <summary> documentation for T:StructureMap.Interceptors.CompoundInterceptor]

Declaration Syntax
C# Visual Basic Visual C++
public class CompoundInterceptor : InstanceInterceptor
Public Class CompoundInterceptor _
    Implements InstanceInterceptor
public ref class CompoundInterceptor : InstanceInterceptor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CompoundInterceptor(array<InstanceInterceptor>[]()[]) | Initializes a new instance of the CompoundInterceptor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interceptors |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(InstanceInterceptor) |
 | Process(Object) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
CompoundInterceptor


CompoundInterceptor Constructor (interceptors)

CompoundInterceptor Constructor (interceptors)
Namespaces ► StructureMap.Interceptors ► CompoundInterceptor ► CompoundInterceptor(array<InstanceInterceptor>[]()[])
StructureMap API
Initializes a new instance of the CompoundInterceptor class
Declaration Syntax
C# Visual Basic Visual C++
public CompoundInterceptor(
    InstanceInterceptor[] interceptors
)
Public Sub New ( _
    interceptors As InstanceInterceptor() _
)
public:
CompoundInterceptor(
    array<InstanceInterceptor^>^ interceptors
)
Parameters
interceptors (array< InstanceInterceptor >[]()[])

[Missing <param name="interceptors"/> documentation for "M:StructureMap.Interceptors.CompoundInterceptor.#ctor(StructureMap.Interceptors.InstanceInterceptor[])"]


Interceptors Property

Interceptors Property
Namespaces ► StructureMap.Interceptors ► CompoundInterceptor ► Interceptors
StructureMap API

[Missing <summary> documentation for P:StructureMap.Interceptors.CompoundInterceptor.Interceptors]

Declaration Syntax
C# Visual Basic Visual C++
public InstanceInterceptor[] Interceptors { get; }
Public ReadOnly Property Interceptors As InstanceInterceptor()
public:
property array<InstanceInterceptor^>^ Interceptors {
    array<InstanceInterceptor^>^ get ();
}


Merge Method (interceptor)

Merge Method (interceptor)
Namespaces ► StructureMap.Interceptors ► CompoundInterceptor ► Merge(InstanceInterceptor)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Interceptors.CompoundInterceptor.Merge(StructureMap.Interceptors.InstanceInterceptor)]

Declaration Syntax
C# Visual Basic Visual C++
public InstanceInterceptor Merge(
    InstanceInterceptor interceptor
)
Public Function Merge ( _
    interceptor As InstanceInterceptor _
) As InstanceInterceptor
public:
InstanceInterceptor^ Merge(
    InstanceInterceptor^ interceptor
)
Parameters
interceptor (InstanceInterceptor)

[Missing <param name="interceptor"/> documentation for "M:StructureMap.Interceptors.CompoundInterceptor.Merge(StructureMap.Interceptors.InstanceInterceptor)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Interceptors.CompoundInterceptor.Merge(StructureMap.Interceptors.InstanceInterceptor)]


Process Method (target)

Process Method (target)
Namespaces ► StructureMap.Interceptors ► CompoundInterceptor ► Process(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Interceptors.CompoundInterceptor.Process(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public Object Process(
    Object target
)
Public Function Process ( _
    target As Object _
) As Object
public:
virtual Object^ Process(
    Object^ target
) sealed
Parameters
target (Object)

[Missing <param name="target"/> documentation for "M:StructureMap.Interceptors.CompoundInterceptor.Process(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Interceptors.CompoundInterceptor.Process(System.Object)]


EnrichmentHandler(T) Delegate

EnrichmentHandler<(Of <(T>)>) Delegate
Namespaces ► StructureMap.Interceptors ► EnrichmentHandler<(Of <(T>)>)
StructureMap API

[Missing <summary> documentation for T:StructureMap.Interceptors.EnrichmentHandler`1]

Declaration Syntax
C# Visual Basic Visual C++
public delegate Object EnrichmentHandler<T>(
    T target
)

Public Delegate Function EnrichmentHandler(Of T) ( _
    target As T _
) As Object
generic<typename T>
public delegate Object^ EnrichmentHandler(
    T target
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:StructureMap.Interceptors.EnrichmentHandler`1"]

Parameters
target (T)


EnrichmentInterceptor(T) Class

EnrichmentInterceptor<(Of <(T>)>) Class
Namespaces ► StructureMap.Interceptors ► EnrichmentInterceptor<(Of <(T>)>)
StructureMap API

[Missing <summary> documentation for T:StructureMap.Interceptors.EnrichmentInterceptor`1]

Declaration Syntax
C# Visual Basic Visual C++
public class EnrichmentInterceptor<T> : InstanceInterceptor

Public Class EnrichmentInterceptor(Of T) _
    Implements InstanceInterceptor
generic<typename T>
public ref class EnrichmentInterceptor : InstanceInterceptor
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:StructureMap.Interceptors.EnrichmentInterceptor`1"]

Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | EnrichmentInterceptor<(Of <(T>)>)(EnrichmentHandler<(Of <(T>)>)) | Initializes a new instance of the EnrichmentInterceptor<(Of <(T>)>) class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(Object) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
EnrichmentInterceptor<(Of <(T>)>)


EnrichmentInterceptor(T) Constructor (handler)

EnrichmentInterceptor<(Of <(T>)>) Constructor (handler)
Namespaces ► StructureMap.Interceptors ► EnrichmentInterceptor<(Of <(T>)>) ► EnrichmentInterceptor<(Of <(T>)>)(EnrichmentHandler<(Of <(T>)>))
StructureMap API
Initializes a new instance of the EnrichmentInterceptor<(Of <(T>)>) class
Declaration Syntax
C# Visual Basic Visual C++
public EnrichmentInterceptor(
    EnrichmentHandler<T> handler
)
Public Sub New ( _
    handler As EnrichmentHandler(Of T) _
)
public:
EnrichmentInterceptor(
    EnrichmentHandler<T>^ handler
)
Parameters
handler (EnrichmentHandler <(Of <( T >)>))

[Missing <param name="handler"/> documentation for "M:StructureMap.Interceptors.EnrichmentInterceptor`1.#ctor(StructureMap.Interceptors.EnrichmentHandler{`0})"]


Process Method (target)

Process Method (target)
Namespaces ► StructureMap.Interceptors ► EnrichmentInterceptor<(Of <(T>)>) ► Process(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Interceptors.EnrichmentInterceptor`1.Process(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public Object Process(
    Object target
)
Public Function Process ( _
    target As Object _
) As Object
public:
virtual Object^ Process(
    Object^ target
) sealed
Parameters
target (Object)

[Missing <param name="target"/> documentation for "M:StructureMap.Interceptors.EnrichmentInterceptor`1.Process(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Interceptors.EnrichmentInterceptor`1.Process(System.Object)]


InstanceInterceptor Interface

InstanceInterceptor Interface
Namespaces ► StructureMap.Interceptors ► InstanceInterceptor
StructureMap API
An InstanceInterceptor can be registered on a per-Instance basis to act on, or even replace, the object that is created before it is passed back to the caller. This is primarily a hook for runtime AOP scenarios.
Declaration Syntax
C# Visual Basic Visual C++
public interface InstanceInterceptor
Public Interface InstanceInterceptor
public interface class InstanceInterceptor
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Process(Object) |


Process Method (target)

Process Method (target)
Namespaces ► StructureMap.Interceptors ► InstanceInterceptor ► Process(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Interceptors.InstanceInterceptor.Process(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
Object Process(
    Object target
)
Function Process ( _
    target As Object _
) As Object
Object^ Process(
    Object^ target
)
Parameters
target (Object)

[Missing <param name="target"/> documentation for "M:StructureMap.Interceptors.InstanceInterceptor.Process(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Interceptors.InstanceInterceptor.Process(System.Object)]


InterceptorLibrary Class

InterceptorLibrary Class
Namespaces ► StructureMap.Interceptors ► InterceptorLibrary
StructureMap API

[Missing <summary> documentation for T:StructureMap.Interceptors.InterceptorLibrary]

Declaration Syntax
C# Visual Basic Visual C++
public class InterceptorLibrary
Public Class InterceptorLibrary
public ref class InterceptorLibrary
Members
All Members | Constructors | Methods | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | InterceptorLibrary()()() | Initializes a new instance of the InterceptorLibrary class
 | AddInterceptor(TypeInterceptor) |
 | Empty |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindInterceptor(Type) |
 | FindInterceptors(Type) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImportFrom(InterceptorLibrary) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InterceptorLibrary


InterceptorLibrary Constructor

InterceptorLibrary Constructor
Namespaces ► StructureMap.Interceptors ► InterceptorLibrary ► InterceptorLibrary()()()
StructureMap API
Initializes a new instance of the InterceptorLibrary class
Declaration Syntax
C# Visual Basic Visual C++
public InterceptorLibrary()
Public Sub New
public:
InterceptorLibrary()


AddInterceptor Method (interceptor)

AddInterceptor Method (interceptor)
Namespaces ► StructureMap.Interceptors ► InterceptorLibrary ► AddInterceptor(TypeInterceptor)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Interceptors.InterceptorLibrary.AddInterceptor(StructureMap.Interceptors.TypeInterceptor)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddInterceptor(
    TypeInterceptor interceptor
)
Public Sub AddInterceptor ( _
    interceptor As TypeInterceptor _
)
public:
void AddInterceptor(
    TypeInterceptor^ interceptor
)
Parameters
interceptor (TypeInterceptor)

[Missing <param name="interceptor"/> documentation for "M:StructureMap.Interceptors.InterceptorLibrary.AddInterceptor(StructureMap.Interceptors.TypeInterceptor)"]


Empty Field

Empty Field
Namespaces ► StructureMap.Interceptors ► InterceptorLibrary ► Empty
StructureMap API

[Missing <summary> documentation for F:StructureMap.Interceptors.InterceptorLibrary.Empty]

Declaration Syntax
C# Visual Basic Visual C++
public static readonly InterceptorLibrary Empty
Public Shared ReadOnly Empty As InterceptorLibrary
public:
static initonly InterceptorLibrary^ Empty


FindInterceptor Method (type)

FindInterceptor Method (type)
Namespaces ► StructureMap.Interceptors ► InterceptorLibrary ► FindInterceptor(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Interceptors.InterceptorLibrary.FindInterceptor(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public CompoundInterceptor FindInterceptor(
    Type type
)
Public Function FindInterceptor ( _
    type As Type _
) As CompoundInterceptor
public:
CompoundInterceptor^ FindInterceptor(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Interceptors.InterceptorLibrary.FindInterceptor(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Interceptors.InterceptorLibrary.FindInterceptor(System.Type)]


FindInterceptors Method (type)

FindInterceptors Method (type)
Namespaces ► StructureMap.Interceptors ► InterceptorLibrary ► FindInterceptors(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Interceptors.InterceptorLibrary.FindInterceptors(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public InstanceInterceptor[] FindInterceptors(
    Type type
)
Public Function FindInterceptors ( _
    type As Type _
) As InstanceInterceptor()
public:
array<InstanceInterceptor^>^ FindInterceptors(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Interceptors.InterceptorLibrary.FindInterceptors(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Interceptors.InterceptorLibrary.FindInterceptors(System.Type)]


ImportFrom Method (source)

ImportFrom Method (source)
Namespaces ► StructureMap.Interceptors ► InterceptorLibrary ► ImportFrom(InterceptorLibrary)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Interceptors.InterceptorLibrary.ImportFrom(StructureMap.Interceptors.InterceptorLibrary)]

Declaration Syntax
C# Visual Basic Visual C++
public void ImportFrom(
    InterceptorLibrary source
)
Public Sub ImportFrom ( _
    source As InterceptorLibrary _
)
public:
void ImportFrom(
    InterceptorLibrary^ source
)
Parameters
source (InterceptorLibrary)

[Missing <param name="source"/> documentation for "M:StructureMap.Interceptors.InterceptorLibrary.ImportFrom(StructureMap.Interceptors.InterceptorLibrary)"]


MatchedTypeInterceptor Class

MatchedTypeInterceptor Class
Namespaces ► StructureMap.Interceptors ► MatchedTypeInterceptor
StructureMap API

[Missing <summary> documentation for T:StructureMap.Interceptors.MatchedTypeInterceptor]

Declaration Syntax
C# Visual Basic Visual C++
public class MatchedTypeInterceptor : TypeInterceptor,
    InstanceInterceptor
Public Class MatchedTypeInterceptor _
    Implements TypeInterceptor, InstanceInterceptor
public ref class MatchedTypeInterceptor : TypeInterceptor,
    InstanceInterceptor
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InterceptWith(Func<(Of <(Object, Object>)>)) |
 | MatchesType(Type) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(Object) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
MatchedTypeInterceptor


InterceptWith Method (interception)

InterceptWith Method (interception)
Namespaces ► StructureMap.Interceptors ► MatchedTypeInterceptor ► InterceptWith(Func<(Of <(Object, Object>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Interceptors.MatchedTypeInterceptor.InterceptWith(System.Func{System.Object,System.Object})]

Declaration Syntax
C# Visual Basic Visual C++
public void InterceptWith(
    Func<Object, Object> interception
)
Public Sub InterceptWith ( _
    interception As Func(Of Object, Object) _
)
public:
void InterceptWith(
    Func<Object^, Object^>^ interception
)
Parameters
interception (Func <(Of <( Object, Object >)>))

[Missing <param name="interception"/> documentation for "M:StructureMap.Interceptors.MatchedTypeInterceptor.InterceptWith(System.Func{System.Object,System.Object})"]


MatchesType Method (type)

MatchesType Method (type)
Namespaces ► StructureMap.Interceptors ► MatchedTypeInterceptor ► MatchesType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Interceptors.MatchedTypeInterceptor.MatchesType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public bool MatchesType(
    Type type
)
Public Function MatchesType ( _
    type As Type _
) As Boolean
public:
virtual bool MatchesType(
    Type^ type
) sealed
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Interceptors.MatchedTypeInterceptor.MatchesType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Interceptors.MatchedTypeInterceptor.MatchesType(System.Type)]


Process Method (target)

Process Method (target)
Namespaces ► StructureMap.Interceptors ► MatchedTypeInterceptor ► Process(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Interceptors.MatchedTypeInterceptor.Process(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public Object Process(
    Object target
)
Public Function Process ( _
    target As Object _
) As Object
public:
virtual Object^ Process(
    Object^ target
) sealed
Parameters
target (Object)

[Missing <param name="target"/> documentation for "M:StructureMap.Interceptors.MatchedTypeInterceptor.Process(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Interceptors.MatchedTypeInterceptor.Process(System.Object)]


NulloInterceptor Class

NulloInterceptor Class
Namespaces ► StructureMap.Interceptors ► NulloInterceptor
StructureMap API

[Missing <summary> documentation for T:StructureMap.Interceptors.NulloInterceptor]

Declaration Syntax
C# Visual Basic Visual C++
public class NulloInterceptor : InstanceInterceptor
Public Class NulloInterceptor _
    Implements InstanceInterceptor
public ref class NulloInterceptor : InstanceInterceptor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | NulloInterceptor()()() | Initializes a new instance of the NulloInterceptor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(Object) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
NulloInterceptor


NulloInterceptor Constructor

NulloInterceptor Constructor
Namespaces ► StructureMap.Interceptors ► NulloInterceptor ► NulloInterceptor()()()
StructureMap API
Initializes a new instance of the NulloInterceptor class
Declaration Syntax
C# Visual Basic Visual C++
public NulloInterceptor()
Public Sub New
public:
NulloInterceptor()


Process Method (target)

Process Method (target)
Namespaces ► StructureMap.Interceptors ► NulloInterceptor ► Process(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Interceptors.NulloInterceptor.Process(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public Object Process(
    Object target
)
Public Function Process ( _
    target As Object _
) As Object
public:
virtual Object^ Process(
    Object^ target
) sealed
Parameters
target (Object)

[Missing <param name="target"/> documentation for "M:StructureMap.Interceptors.NulloInterceptor.Process(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Interceptors.NulloInterceptor.Process(System.Object)]


PluginTypeInterceptor Class

PluginTypeInterceptor Class
Namespaces ► StructureMap.Interceptors ► PluginTypeInterceptor
StructureMap API
A TypeInterceptor that always applies to all Instances of a given Plugin Type
Declaration Syntax
C# Visual Basic Visual C++
public class PluginTypeInterceptor : TypeInterceptor,
    InstanceInterceptor
Public Class PluginTypeInterceptor _
    Implements TypeInterceptor, InstanceInterceptor
public ref class PluginTypeInterceptor : TypeInterceptor,
    InstanceInterceptor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PluginTypeInterceptor(Type, Func<(Of <(Object, Object>)>)) | Initializes a new instance of the PluginTypeInterceptor class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MatchesType(Type) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(Object) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PluginTypeInterceptor


PluginTypeInterceptor Constructor (pluginType, function)

PluginTypeInterceptor Constructor (pluginType, function)
Namespaces ► StructureMap.Interceptors ► PluginTypeInterceptor ► PluginTypeInterceptor(Type, Func<(Of <(Object, Object>)>))
StructureMap API
Initializes a new instance of the PluginTypeInterceptor class
Declaration Syntax
C# Visual Basic Visual C++
public PluginTypeInterceptor(
    Type pluginType,
    Func<Object, Object> function
)
Public Sub New ( _
    pluginType As Type, _
    function As Func(Of Object, Object) _
)
public:
PluginTypeInterceptor(
    Type^ pluginType,
    Func<Object^, Object^>^ function
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Interceptors.PluginTypeInterceptor.#ctor(System.Type,System.Func{System.Object,System.Object})"]

function (Func <(Of <( Object, Object >)>))

[Missing <param name="function"/> documentation for "M:StructureMap.Interceptors.PluginTypeInterceptor.#ctor(System.Type,System.Func{System.Object,System.Object})"]


MatchesType Method (type)

MatchesType Method (type)
Namespaces ► StructureMap.Interceptors ► PluginTypeInterceptor ► MatchesType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Interceptors.PluginTypeInterceptor.MatchesType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public bool MatchesType(
    Type type
)
Public Function MatchesType ( _
    type As Type _
) As Boolean
public:
virtual bool MatchesType(
    Type^ type
) sealed
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Interceptors.PluginTypeInterceptor.MatchesType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Interceptors.PluginTypeInterceptor.MatchesType(System.Type)]


Process Method (target)

Process Method (target)
Namespaces ► StructureMap.Interceptors ► PluginTypeInterceptor ► Process(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Interceptors.PluginTypeInterceptor.Process(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public Object Process(
    Object target
)
Public Function Process ( _
    target As Object _
) As Object
public:
virtual Object^ Process(
    Object^ target
) sealed
Parameters
target (Object)

[Missing <param name="target"/> documentation for "M:StructureMap.Interceptors.PluginTypeInterceptor.Process(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Interceptors.PluginTypeInterceptor.Process(System.Object)]


StartupInterceptor(T) Class

StartupInterceptor<(Of <(T>)>) Class
Namespaces ► StructureMap.Interceptors ► StartupInterceptor<(Of <(T>)>)
StructureMap API

[Missing <summary> documentation for T:StructureMap.Interceptors.StartupInterceptor`1]

Declaration Syntax
C# Visual Basic Visual C++
public class StartupInterceptor<T> : InstanceInterceptor

Public Class StartupInterceptor(Of T) _
    Implements InstanceInterceptor
generic<typename T>
public ref class StartupInterceptor : InstanceInterceptor
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:StructureMap.Interceptors.StartupInterceptor`1"]

Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | StartupInterceptor<(Of <(T>)>)(Action<(Of <(T>)>)) | Initializes a new instance of the StartupInterceptor<(Of <(T>)>) class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Process(Object) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
StartupInterceptor<(Of <(T>)>)


StartupInterceptor(T) Constructor (handler)

StartupInterceptor<(Of <(T>)>) Constructor (handler)
Namespaces ► StructureMap.Interceptors ► StartupInterceptor<(Of <(T>)>) ► StartupInterceptor<(Of <(T>)>)(Action<(Of <(T>)>))
StructureMap API
Initializes a new instance of the StartupInterceptor<(Of <(T>)>) class
Declaration Syntax
C# Visual Basic Visual C++
public StartupInterceptor(
    Action<T> handler
)
Public Sub New ( _
    handler As Action(Of T) _
)
public:
StartupInterceptor(
    Action<T>^ handler
)
Parameters
handler (Action <(Of <( T >)>))

[Missing <param name="handler"/> documentation for "M:StructureMap.Interceptors.StartupInterceptor`1.#ctor(System.Action{`0})"]


Process Method (target)

Process Method (target)
Namespaces ► StructureMap.Interceptors ► StartupInterceptor<(Of <(T>)>) ► Process(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Interceptors.StartupInterceptor`1.Process(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public Object Process(
    Object target
)
Public Function Process ( _
    target As Object _
) As Object
public:
virtual Object^ Process(
    Object^ target
) sealed
Parameters
target (Object)

[Missing <param name="target"/> documentation for "M:StructureMap.Interceptors.StartupInterceptor`1.Process(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Interceptors.StartupInterceptor`1.Process(System.Object)]


TypeInterceptor Interface

TypeInterceptor Interface
Namespaces ► StructureMap.Interceptors ► TypeInterceptor
StructureMap API
A TypeInterceptor that is only applied if the MatchesType() method is true for a given Type
Declaration Syntax
C# Visual Basic Visual C++
public interface TypeInterceptor : InstanceInterceptor
Public Interface TypeInterceptor _
    Implements InstanceInterceptor
public interface class TypeInterceptor : InstanceInterceptor
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | MatchesType(Type) | Does this TypeInterceptor apply to the given type?
 | Process(Object) | (Inherited from InstanceInterceptor.)


MatchesType Method (type)

MatchesType Method (type)
Namespaces ► StructureMap.Interceptors ► TypeInterceptor ► MatchesType(Type)
StructureMap API
Does this TypeInterceptor apply to the given type?
Declaration Syntax
C# Visual Basic Visual C++
bool MatchesType(
    Type type
)
Function MatchesType ( _
    type As Type _
) As Boolean
bool MatchesType(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Interceptors.TypeInterceptor.MatchesType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Interceptors.TypeInterceptor.MatchesType(System.Type)]


StructureMap.Pipeline Namespace

StructureMap.Pipeline Namespace
Namespaces ► StructureMap.Pipeline
StructureMap API

[Missing <summary> documentation for N:StructureMap.Pipeline]

Declaration Syntax
C# Visual Basic Visual C++
namespace StructureMap.Pipeline
Namespace StructureMap.Pipeline
namespace StructureMap.Pipeline
Types
All Types Classes Interfaces
Icon | Type | Description
 | SmartInstance<(Of <(T>)>)..::.ArrayDefinitionExpression<(Of <(T, ARRAY>)>) | Expression Builder to help define multiple Instances for an Array dependency
 | BuildFrame | Models the current place in an object graph during the construction of an instance. Provides contextual information that can be used to alter the desired construction of child objects
 | BuildPolicy |
 | BuildStack | Provides metadata about the object graph being constructed. More or less a stack trace of the GetInstance() pipeline that can be used for "contextual" object construction
 | CacheInterceptor |
 | ConfiguredInstance..::.ChildArrayExpression |
 | ConfiguredInstance..::.ChildInstanceExpression | Part of the Fluent Interface, represents a nonprimitive argument to a constructure function
 | ConfiguredInstance | An Instance class that builds objects by calling a constructor function on a concrete type and filling setter properties. ConfiguredInstance should only be used for open generic types. Favor SmartInstance{T} for all other usages.
 | ConfiguredInstanceBase<(Of <(T>)>) |
 | ConstructorInstance<(Of <(T>)>) |
 | Copyable |
 | DefaultInstance |
 | SmartInstance<(Of <(T>)>)..::.DependencyExpression<(Of <(T, CHILD>)>) | Expression Builder that helps to define child dependencies inline
 | ExplicitArguments |
 | ExplicitInstance |
 | ExpressedInstance<(Of <(T>)>) | Base class for many of the Instance subclasses to support method chaining in the Registry DSL for common options
 | HttpContextBuildPolicy |
 | HybridBuildPolicy |
 | IBuildInterceptor | Plugin interface to create custom build or lifecycle policies for a Plugin Type
 | IBuildPolicy | An object that specifies a "Policy" about how Instance's are invoked.
 | IConfiguredInstance |
 | IDiagnosticInstance |
 | IInstance |
 | ILocationPolicy |
 | Instance |
 | InstanceMementoPropertyReader |
 | IStructuredInstance |
 | LiteralInstance |
 | Profile |
 | ProfileManager |
 | PropertyExpression<(Of <(T>)>) | Defines the value of a primitive argument to a constructur argument
 | PrototypeInstance |
 | ReferencedInstance |
 | SerializedInstance |
 | SingletonPolicy |
 | SmartInstance<(Of <(T>)>) | Instance that builds objects with by calling constructor functions and using setter properties
 | ThreadLocalStoragePolicy |
 | TypeExtensions |
 | UserControlInstance |


BuildFrame Class

BuildFrame Class
Namespaces ► StructureMap.Pipeline ► BuildFrame
StructureMap API
Models the current place in an object graph during the construction of an instance. Provides contextual information that can be used to alter the desired construction of child objects
Declaration Syntax
C# Visual Basic Visual C++
public class BuildFrame
Public Class BuildFrame
public ref class BuildFrame
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BuildFrame(Type, String, Type) | Initializes a new instance of the BuildFrame class
 | ConcreteType | The actual ConcreteType being created. This will not always be available
 | Equals(BuildFrame) |
 | Equals(Object) | (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | The Name of the Instance being created
 | RequestedType | The requested PluginType of the Instance being create
 | ToString()()() | (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
BuildFrame


BuildFrame Constructor (requestedType, name, concreteType)

BuildFrame Constructor (requestedType, name, concreteType)
Namespaces ► StructureMap.Pipeline ► BuildFrame ► BuildFrame(Type, String, Type)
StructureMap API
Initializes a new instance of the BuildFrame class
Declaration Syntax
C# Visual Basic Visual C++
public BuildFrame(
    Type requestedType,
    string name,
    Type concreteType
)
Public Sub New ( _
    requestedType As Type, _
    name As String, _
    concreteType As Type _
)
public:
BuildFrame(
    Type^ requestedType,
    String^ name,
    Type^ concreteType
)
Parameters
requestedType (Type)

[Missing <param name="requestedType"/> documentation for "M:StructureMap.Pipeline.BuildFrame.#ctor(System.Type,System.String,System.Type)"]

name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Pipeline.BuildFrame.#ctor(System.Type,System.String,System.Type)"]

concreteType (Type)

[Missing <param name="concreteType"/> documentation for "M:StructureMap.Pipeline.BuildFrame.#ctor(System.Type,System.String,System.Type)"]


ConcreteType Property

ConcreteType Property
Namespaces ► StructureMap.Pipeline ► BuildFrame ► ConcreteType
StructureMap API
The actual ConcreteType being created. This will not always be available
Declaration Syntax
C# Visual Basic Visual C++
public Type ConcreteType { get; }
Public ReadOnly Property ConcreteType As Type
public:
property Type^ ConcreteType {
    Type^ get ();
}


Equals Method

Equals Method
Namespaces ► StructureMap.Pipeline ► BuildFrame ► Equals()()()
StructureMap API
Members
Icon | Member | Description
 | Equals(BuildFrame) |
 | Equals(Object) | (Overrides Object.Equals(Object).)


Equals Method (obj)

Equals Method (obj)
Namespaces ► StructureMap.Pipeline ► BuildFrame ► Equals(BuildFrame)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.BuildFrame.Equals(StructureMap.Pipeline.BuildFrame)]

Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    BuildFrame obj
)
Public Function Equals ( _
    obj As BuildFrame _
) As Boolean
public:
bool Equals(
    BuildFrame^ obj
)
Parameters
obj (BuildFrame)

[Missing <param name="obj"/> documentation for "M:StructureMap.Pipeline.BuildFrame.Equals(StructureMap.Pipeline.BuildFrame)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.BuildFrame.Equals(StructureMap.Pipeline.BuildFrame)]


Equals Method (obj)

Equals Method (obj)
Namespaces ► StructureMap.Pipeline ► BuildFrame ► Equals(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.BuildFrame.Equals(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:StructureMap.Pipeline.BuildFrame.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.BuildFrame.Equals(System.Object)]


GetHashCode Method

GetHashCode Method
Namespaces ► StructureMap.Pipeline ► BuildFrame ► GetHashCode()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.BuildFrame.GetHashCode]

Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.BuildFrame.GetHashCode]


Name Property

Name Property
Namespaces ► StructureMap.Pipeline ► BuildFrame ► Name
StructureMap API
The Name of the Instance being created
Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}


RequestedType Property

RequestedType Property
Namespaces ► StructureMap.Pipeline ► BuildFrame ► RequestedType
StructureMap API
The requested PluginType of the Instance being create
Declaration Syntax
C# Visual Basic Visual C++
public Type RequestedType { get; }
Public ReadOnly Property RequestedType As Type
public:
property Type^ RequestedType {
    Type^ get ();
}


ToString Method

ToString Method
Namespaces ► StructureMap.Pipeline ► BuildFrame ► ToString()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.BuildFrame.ToString]

Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.BuildFrame.ToString]


BuildPolicy Class

BuildPolicy Class
Namespaces ► StructureMap.Pipeline ► BuildPolicy
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.BuildPolicy]

Declaration Syntax
C# Visual Basic Visual C++
public sealed class BuildPolicy : IBuildPolicy
Public NotInheritable Class BuildPolicy _
    Implements IBuildPolicy
public ref class BuildPolicy sealed : IBuildPolicy
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | BuildPolicy()()() | Initializes a new instance of the BuildPolicy class
 | Build(BuildSession, Type, Instance) |
 | Clone()()() |
 | Equals(BuildPolicy) |
 | Equals(Object) | (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BuildPolicy


BuildPolicy Constructor

BuildPolicy Constructor
Namespaces ► StructureMap.Pipeline ► BuildPolicy ► BuildPolicy()()()
StructureMap API
Initializes a new instance of the BuildPolicy class
Declaration Syntax
C# Visual Basic Visual C++
public BuildPolicy()
Public Sub New
public:
BuildPolicy()


Build Method (buildSession, pluginType, instance)

Build Method (buildSession, pluginType, instance)
Namespaces ► StructureMap.Pipeline ► BuildPolicy ► Build(BuildSession, Type, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.BuildPolicy.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public Object Build(
    BuildSession buildSession,
    Type pluginType,
    Instance instance
)
Public Function Build ( _
    buildSession As BuildSession, _
    pluginType As Type, _
    instance As Instance _
) As Object
public:
virtual Object^ Build(
    BuildSession^ buildSession,
    Type^ pluginType,
    Instance^ instance
) sealed
Parameters
buildSession (BuildSession)

[Missing <param name="buildSession"/> documentation for "M:StructureMap.Pipeline.BuildPolicy.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.BuildPolicy.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.BuildPolicy.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.BuildPolicy.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)]


Clone Method

Clone Method
Namespaces ► StructureMap.Pipeline ► BuildPolicy ► Clone()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.BuildPolicy.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public IBuildPolicy Clone()
Public Function Clone As IBuildPolicy
public:
virtual IBuildPolicy^ Clone() sealed
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.BuildPolicy.Clone]


Equals Method

Equals Method
Namespaces ► StructureMap.Pipeline ► BuildPolicy ► Equals()()()
StructureMap API
Members
Icon | Member | Description
 | Equals(BuildPolicy) |
 | Equals(Object) | (Overrides Object.Equals(Object).)


Equals Method (obj)

Equals Method (obj)
Namespaces ► StructureMap.Pipeline ► BuildPolicy ► Equals(BuildPolicy)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.BuildPolicy.Equals(StructureMap.Pipeline.BuildPolicy)]

Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    BuildPolicy obj
)
Public Function Equals ( _
    obj As BuildPolicy _
) As Boolean
public:
bool Equals(
    BuildPolicy^ obj
)
Parameters
obj (BuildPolicy)

[Missing <param name="obj"/> documentation for "M:StructureMap.Pipeline.BuildPolicy.Equals(StructureMap.Pipeline.BuildPolicy)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.BuildPolicy.Equals(StructureMap.Pipeline.BuildPolicy)]


Equals Method (obj)

Equals Method (obj)
Namespaces ► StructureMap.Pipeline ► BuildPolicy ► Equals(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.BuildPolicy.Equals(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:StructureMap.Pipeline.BuildPolicy.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.BuildPolicy.Equals(System.Object)]


GetHashCode Method

GetHashCode Method
Namespaces ► StructureMap.Pipeline ► BuildPolicy ► GetHashCode()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.BuildPolicy.GetHashCode]

Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.BuildPolicy.GetHashCode]


BuildStack Class

BuildStack Class
Namespaces ► StructureMap.Pipeline ► BuildStack
StructureMap API
Provides metadata about the object graph being constructed. More or less a stack trace of the GetInstance() pipeline that can be used for "contextual" object construction
Declaration Syntax
C# Visual Basic Visual C++
public class BuildStack
Public Class BuildStack
public ref class BuildStack
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Current | The current BuildFrame
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Parent | The immediate parent BuildFrame
 | Root | The top level of the object graph. Describes the original requested instance
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
BuildStack


Current Property

Current Property
Namespaces ► StructureMap.Pipeline ► BuildStack ► Current
StructureMap API
The current BuildFrame
Declaration Syntax
C# Visual Basic Visual C++
public BuildFrame Current { get; }
Public ReadOnly Property Current As BuildFrame
public:
property BuildFrame^ Current {
    BuildFrame^ get ();
}


Parent Property

Parent Property
Namespaces ► StructureMap.Pipeline ► BuildStack ► Parent
StructureMap API
The immediate parent BuildFrame
Declaration Syntax
C# Visual Basic Visual C++
public BuildFrame Parent { get; }
Public ReadOnly Property Parent As BuildFrame
public:
property BuildFrame^ Parent {
    BuildFrame^ get ();
}


Root Property

Root Property
Namespaces ► StructureMap.Pipeline ► BuildStack ► Root
StructureMap API
The top level of the object graph. Describes the original requested instance
Declaration Syntax
C# Visual Basic Visual C++
public BuildFrame Root { get; }
Public ReadOnly Property Root As BuildFrame
public:
property BuildFrame^ Root {
    BuildFrame^ get ();
}


CacheInterceptor Class

CacheInterceptor Class
Namespaces ► StructureMap.Pipeline ► CacheInterceptor
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.CacheInterceptor]

Declaration Syntax
C# Visual Basic Visual C++
public abstract class CacheInterceptor : IBuildInterceptor,
    IBuildPolicy
Public MustInherit Class CacheInterceptor _
    Implements IBuildInterceptor, IBuildPolicy
public ref class CacheInterceptor abstract : IBuildInterceptor,
    IBuildPolicy
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | CacheInterceptor()()() | Initializes a new instance of the CacheInterceptor class
 | Build(BuildSession, Type, Instance) |
 | clone()()() |
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerPolicy |
 | isCached(String, Type) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | retrieveFromCache(String, Type) |
 | storeInCache(String, Type, Object) |
 | ToString()()() | (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
 | CacheInterceptor
 |  | HttpContextBuildPolicy
 |  | SingletonPolicy
 |  | ThreadLocalStoragePolicy


CacheInterceptor Constructor

CacheInterceptor Constructor
Namespaces ► StructureMap.Pipeline ► CacheInterceptor ► CacheInterceptor()()()
StructureMap API
Initializes a new instance of the CacheInterceptor class
Declaration Syntax
C# Visual Basic Visual C++
protected CacheInterceptor()
Protected Sub New
protected:
CacheInterceptor()


Build Method (buildSession, pluginType, instance)

Build Method (buildSession, pluginType, instance)
Namespaces ► StructureMap.Pipeline ► CacheInterceptor ► Build(BuildSession, Type, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.CacheInterceptor.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public Object Build(
    BuildSession buildSession,
    Type pluginType,
    Instance instance
)
Public Function Build ( _
    buildSession As BuildSession, _
    pluginType As Type, _
    instance As Instance _
) As Object
public:
virtual Object^ Build(
    BuildSession^ buildSession,
    Type^ pluginType,
    Instance^ instance
) sealed
Parameters
buildSession (BuildSession)

[Missing <param name="buildSession"/> documentation for "M:StructureMap.Pipeline.CacheInterceptor.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.CacheInterceptor.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.CacheInterceptor.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.CacheInterceptor.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)]


clone Method

clone Method
Namespaces ► StructureMap.Pipeline ► CacheInterceptor ► clone()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.CacheInterceptor.clone]

Declaration Syntax
C# Visual Basic Visual C++
protected abstract CacheInterceptor clone()
Protected MustOverride Function clone As CacheInterceptor
protected:
virtual CacheInterceptor^ clone() abstract
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.CacheInterceptor.clone]


Clone Method

Clone Method
Namespaces ► StructureMap.Pipeline ► CacheInterceptor ► Clone()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.CacheInterceptor.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public IBuildPolicy Clone()
Public Function Clone As IBuildPolicy
public:
virtual IBuildPolicy^ Clone() sealed
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.CacheInterceptor.Clone]


InnerPolicy Property

InnerPolicy Property
Namespaces ► StructureMap.Pipeline ► CacheInterceptor ► InnerPolicy
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.CacheInterceptor.InnerPolicy]

Declaration Syntax
C# Visual Basic Visual C++
public IBuildPolicy InnerPolicy { get; set; }
Public Property InnerPolicy As IBuildPolicy
public:
virtual property IBuildPolicy^ InnerPolicy {
    IBuildPolicy^ get () sealed;
    void set (IBuildPolicy^ value) sealed;
}


isCached Method (instanceKey, pluginType)

isCached Method (instanceKey, pluginType)
Namespaces ► StructureMap.Pipeline ► CacheInterceptor ► isCached(String, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.CacheInterceptor.isCached(System.String,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected abstract bool isCached(
    string instanceKey,
    Type pluginType
)
Protected MustOverride Function isCached ( _
    instanceKey As String, _
    pluginType As Type _
) As Boolean
protected:
virtual bool isCached(
    String^ instanceKey,
    Type^ pluginType
) abstract
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.CacheInterceptor.isCached(System.String,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.CacheInterceptor.isCached(System.String,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.CacheInterceptor.isCached(System.String,System.Type)]


retrieveFromCache Method (instanceKey, pluginType)

retrieveFromCache Method (instanceKey, pluginType)
Namespaces ► StructureMap.Pipeline ► CacheInterceptor ► retrieveFromCache(String, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.CacheInterceptor.retrieveFromCache(System.String,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected abstract Object retrieveFromCache(
    string instanceKey,
    Type pluginType
)
Protected MustOverride Function retrieveFromCache ( _
    instanceKey As String, _
    pluginType As Type _
) As Object
protected:
virtual Object^ retrieveFromCache(
    String^ instanceKey,
    Type^ pluginType
) abstract
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.CacheInterceptor.retrieveFromCache(System.String,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.CacheInterceptor.retrieveFromCache(System.String,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.CacheInterceptor.retrieveFromCache(System.String,System.Type)]


storeInCache Method (instanceKey, pluginType, instance)

storeInCache Method (instanceKey, pluginType, instance)
Namespaces ► StructureMap.Pipeline ► CacheInterceptor ► storeInCache(String, Type, Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.CacheInterceptor.storeInCache(System.String,System.Type,System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
protected abstract void storeInCache(
    string instanceKey,
    Type pluginType,
    Object instance
)
Protected MustOverride Sub storeInCache ( _
    instanceKey As String, _
    pluginType As Type, _
    instance As Object _
)
protected:
virtual void storeInCache(
    String^ instanceKey,
    Type^ pluginType,
    Object^ instance
) abstract
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.CacheInterceptor.storeInCache(System.String,System.Type,System.Object)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.CacheInterceptor.storeInCache(System.String,System.Type,System.Object)"]

instance (Object)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.CacheInterceptor.storeInCache(System.String,System.Type,System.Object)"]


ToString Method

ToString Method
Namespaces ► StructureMap.Pipeline ► CacheInterceptor ► ToString()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.CacheInterceptor.ToString]

Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.CacheInterceptor.ToString]


ConfiguredInstance Class

ConfiguredInstance Class
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance
StructureMap API
An Instance class that builds objects by calling a constructor function on a concrete type and filling setter properties. ConfiguredInstance should only be used for open generic types. Favor SmartInstance{T} for all other usages.
Declaration Syntax
C# Visual Basic Visual C++
public class ConfiguredInstance : ConfiguredInstanceBase<ConfiguredInstance>
Public Class ConfiguredInstance _
    Inherits ConfiguredInstanceBase(Of ConfiguredInstance)
public ref class ConfiguredInstance : public ConfiguredInstanceBase<ConfiguredInstance^>
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfiguredInstance(InstanceMemento, PluginGraph, Type) | Initializes a new instance of the ConfiguredInstance class
 | ConfiguredInstance(Type, String) | Initializes a new instance of the ConfiguredInstance class
 | ConfiguredInstance(Type) | Initializes a new instance of the ConfiguredInstance class
 | ConfiguredInstance(Type, array<Type>[]()[]) | Initializes a new instance of the ConfiguredInstance class
 | _arrays | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | _children | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | _pluggedType | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | _properties | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | addTemplatedInstanceTo(PluginFamily, array<Type>[]()[]) | (Overrides Instance.addTemplatedInstanceTo(PluginFamily, array<Type>[]()[]).)
 | build(Type, BuildSession) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | Build(Type, BuildSession) | (Inherited from Instance.)
 | canBePartOfPluginFamily(PluginFamily) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | Child<(Of <(CONSTRUCTORARGUMENTTYPE>)>)()()() | Start the definition of a child instance for type CONSTRUCTORARGUMENTTYPE
 | Child(String) | Inline definition of a constructor or a setter property dependency
 | Child<(Of <(CONSTRUCTORARGUMENTTYPE>)>)(String) | Starts the definition of a child instance specifying the argument name in the case of a constructor function that consumes more than one argument of type T
 | ChildArray<(Of <(PLUGINTYPE>)>)(String) | Inline definition of a dependency array like IService[] or IHandler[]
 | ChildArray(String) | Inline definition of a dependency array like IService[] or IHandler[]
 | ChildArray<(Of <(PLUGINTYPE>)>)()()() | Inline definition of a dependency array like IService[] or IHandler[]
 | CtorDependency<(Of <(CONSTRUCTORARGUMENTTYPE>)>)(String) | Inline definition of a constructor dependency
 | doesRecordOnTheStack | (Inherited from Instance.)
 | EnrichWith<(Of <(TYPE>)>)(EnrichmentHandler<(Of <(TYPE>)>)) | Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | findMasterInstance(PluginFamily, String, GraphLog) | (Inherited from Instance.)
 | findPropertyName<(Of <(T>)>)()()() | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | getChild(String, Type, BuildSession) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | getConcreteType(Type) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | getDescription()()() | (Overrides Instance.getDescription()()().)
 | GetGenericType(Type, array<Type>[]()[]) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interceptor | (Inherited from Instance.)
 | markBuildStackFinish(BuildSession) | (Inherited from Instance.)
 | markBuildStackStart(BuildSession, Type) | (Inherited from Instance.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | mergeIntoThis(Copyable) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | Name | (Inherited from Instance.)
 | OnCreation<(Of <(TYPE>)>)(Action<(Of <(TYPE>)>)) | Register an Action to perform on the object created by this Instance before it is returned to the caller
 | preprocess(PluginFamily) | (Overrides Instance.preprocess(PluginFamily).)
 | replaceNameIfNotAlreadySet(String) | (Inherited from Instance.)
 | setChild(String, Instance) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | setChildArray(String, array<Instance>[]()[]) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | setPluggedType(Type) |
 | setProperty(String, String) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | SetterDependency<(Of <(CONSTRUCTORARGUMENTTYPE>)>)(String) | Inline definition of a setter dependency
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WithCtorArg(String) | Configure a primitive constructor argument
 | WithName(String) |
 | WithProperty(String) | Start the definition of a primitive argument to a constructor argument
Inheritance Hierarchy
Object
 | Instance
 |  | ConfiguredInstanceBase <(Of <(ConfiguredInstance>)>)
 |  |  | ConfiguredInstance
 |  |  |  | ExplicitInstance


ConfiguredInstance Constructor

ConfiguredInstance Constructor
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► ConfiguredInstance()()()
StructureMap API
Members
Icon | Member | Description
 | ConfiguredInstance(InstanceMemento, PluginGraph, Type) | Initializes a new instance of the ConfiguredInstance class
 | ConfiguredInstance(Type, String) | Initializes a new instance of the ConfiguredInstance class
 | ConfiguredInstance(Type) | Initializes a new instance of the ConfiguredInstance class
 | ConfiguredInstance(Type, array<Type>[]()[]) | Initializes a new instance of the ConfiguredInstance class


ConfiguredInstance Constructor (memento, graph, pluginType)

ConfiguredInstance Constructor (memento, graph, pluginType)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► ConfiguredInstance(InstanceMemento, PluginGraph, Type)
StructureMap API
Initializes a new instance of the ConfiguredInstance class
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance(
    InstanceMemento memento,
    PluginGraph graph,
    Type pluginType
)
Public Sub New ( _
    memento As InstanceMemento, _
    graph As PluginGraph, _
    pluginType As Type _
)
public:
ConfiguredInstance(
    InstanceMemento^ memento,
    PluginGraph^ graph,
    Type^ pluginType
)
Parameters
memento (InstanceMemento)

[Missing <param name="memento"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.#ctor(StructureMap.InstanceMemento,StructureMap.Graph.PluginGraph,System.Type)"]

graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.#ctor(StructureMap.InstanceMemento,StructureMap.Graph.PluginGraph,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.#ctor(StructureMap.InstanceMemento,StructureMap.Graph.PluginGraph,System.Type)"]


ConfiguredInstance Constructor (pluggedType)

ConfiguredInstance Constructor (pluggedType)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► ConfiguredInstance(Type)
StructureMap API
Initializes a new instance of the ConfiguredInstance class
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance(
    Type pluggedType
)
Public Sub New ( _
    pluggedType As Type _
)
public:
ConfiguredInstance(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.#ctor(System.Type)"]


ConfiguredInstance Constructor (pluggedType, name)

ConfiguredInstance Constructor (pluggedType, name)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► ConfiguredInstance(Type, String)
StructureMap API
Initializes a new instance of the ConfiguredInstance class
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance(
    Type pluggedType,
    string name
)
Public Sub New ( _
    pluggedType As Type, _
    name As String _
)
public:
ConfiguredInstance(
    Type^ pluggedType,
    String^ name
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.#ctor(System.Type,System.String)"]

name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.#ctor(System.Type,System.String)"]


ConfiguredInstance Constructor (templateType, types)

ConfiguredInstance Constructor (templateType, types)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► ConfiguredInstance(Type, array<Type>[]()[])
StructureMap API
Initializes a new instance of the ConfiguredInstance class
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance(
    Type templateType,
    params Type[] types
)
Public Sub New ( _
    templateType As Type, _
    ParamArray types As Type() _
)
public:
ConfiguredInstance(
    Type^ templateType,
    ... array<Type^>^ types
)
Parameters
templateType (Type)

[Missing <param name="templateType"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.#ctor(System.Type,System.Type[])"]

types (array< Type >[]()[])

[Missing <param name="types"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.#ctor(System.Type,System.Type[])"]


addTemplatedInstanceTo Method (family, templateTypes)

addTemplatedInstanceTo Method (family, templateTypes)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► addTemplatedInstanceTo(PluginFamily, array<Type>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstance.addTemplatedInstanceTo(StructureMap.Graph.PluginFamily,System.Type[])]

Declaration Syntax
C# Visual Basic Visual C++
protected override void addTemplatedInstanceTo(
    PluginFamily family,
    Type[] templateTypes
)
Protected Overrides Sub addTemplatedInstanceTo ( _
    family As PluginFamily, _
    templateTypes As Type() _
)
protected:
virtual void addTemplatedInstanceTo(
    PluginFamily^ family,
    array<Type^>^ templateTypes
) override
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.addTemplatedInstanceTo(StructureMap.Graph.PluginFamily,System.Type[])"]

templateTypes (array< Type >[]()[])

[Missing <param name="templateTypes"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.addTemplatedInstanceTo(StructureMap.Graph.PluginFamily,System.Type[])"]


Child Method

Child Method
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► Child()()()
StructureMap API
Members
Icon | Member | Description
 | Child<(Of <(CONSTRUCTORARGUMENTTYPE>)>)()()() | Start the definition of a child instance for type CONSTRUCTORARGUMENTTYPE
 | Child(String) | Inline definition of a constructor or a setter property dependency
 | Child<(Of <(CONSTRUCTORARGUMENTTYPE>)>)(String) | Starts the definition of a child instance specifying the argument name in the case of a constructor function that consumes more than one argument of type T


Child Method

Child<(Of <(CONSTRUCTORARGUMENTTYPE>)>) Method
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► Child<(Of <(CONSTRUCTORARGUMENTTYPE>)>)()()()
StructureMap API
Start the definition of a child instance for type CONSTRUCTORARGUMENTTYPE
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance..::.ChildInstanceExpression Child<CONSTRUCTORARGUMENTTYPE>()

Public Function Child(Of CONSTRUCTORARGUMENTTYPE) As ConfiguredInstance..::.ChildInstanceExpression
public:
generic<typename CONSTRUCTORARGUMENTTYPE>
ConfiguredInstance..::.ChildInstanceExpression^ Child()
Generic Template Parameters
CONSTRUCTORARGUMENTTYPE

[Missing <typeparam name="CONSTRUCTORARGUMENTTYPE"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.Child``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.Child``1]


Child Method (propertyName)

Child<(Of <(CONSTRUCTORARGUMENTTYPE>)>) Method (propertyName)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► Child<(Of <(CONSTRUCTORARGUMENTTYPE>)>)(String)
StructureMap API
Starts the definition of a child instance specifying the argument name in the case of a constructor function that consumes more than one argument of type T
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance..::.ChildInstanceExpression Child<CONSTRUCTORARGUMENTTYPE>(
    string propertyName
)

Public Function Child(Of CONSTRUCTORARGUMENTTYPE) ( _
    propertyName As String _
) As ConfiguredInstance..::.ChildInstanceExpression
public:
generic<typename CONSTRUCTORARGUMENTTYPE>
ConfiguredInstance..::.ChildInstanceExpression^ Child(
    String^ propertyName
)
Generic Template Parameters
CONSTRUCTORARGUMENTTYPE

[Missing <typeparam name="CONSTRUCTORARGUMENTTYPE"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.Child``1(System.String)"]

Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.Child``1(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.Child``1(System.String)]


Child Method (propertyName)

Child Method (propertyName)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► Child(String)
StructureMap API
Inline definition of a constructor or a setter property dependency
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance..::.ChildInstanceExpression Child(
    string propertyName
)
Public Function Child ( _
    propertyName As String _
) As ConfiguredInstance..::.ChildInstanceExpression
public:
ConfiguredInstance..::.ChildInstanceExpression^ Child(
    String^ propertyName
)
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.Child(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.Child(System.String)]


ChildArray Method

ChildArray Method
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► ChildArray()()()
StructureMap API
Members
Icon | Member | Description
 | ChildArray<(Of <(PLUGINTYPE>)>)(String) | Inline definition of a dependency array like IService[] or IHandler[]
 | ChildArray(String) | Inline definition of a dependency array like IService[] or IHandler[]
 | ChildArray<(Of <(PLUGINTYPE>)>)()()() | Inline definition of a dependency array like IService[] or IHandler[]


ChildArray Method

ChildArray<(Of <(PLUGINTYPE>)>) Method
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► ChildArray<(Of <(PLUGINTYPE>)>)()()()
StructureMap API
Inline definition of a dependency array like IService[] or IHandler[]
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance..::.ChildArrayExpression ChildArray<PLUGINTYPE>()

Public Function ChildArray(Of PLUGINTYPE) As ConfiguredInstance..::.ChildArrayExpression
public:
generic<typename PLUGINTYPE>
ConfiguredInstance..::.ChildArrayExpression^ ChildArray()
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildArray``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.ChildArray``1]


ChildArray Method (propertyName)

ChildArray<(Of <(PLUGINTYPE>)>) Method (propertyName)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► ChildArray<(Of <(PLUGINTYPE>)>)(String)
StructureMap API
Inline definition of a dependency array like IService[] or IHandler[]
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance..::.ChildArrayExpression ChildArray<PLUGINTYPE>(
    string propertyName
)

Public Function ChildArray(Of PLUGINTYPE) ( _
    propertyName As String _
) As ConfiguredInstance..::.ChildArrayExpression
public:
generic<typename PLUGINTYPE>
ConfiguredInstance..::.ChildArrayExpression^ ChildArray(
    String^ propertyName
)
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildArray``1(System.String)"]

Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildArray``1(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.ChildArray``1(System.String)]


ChildArray Method (propertyName)

ChildArray Method (propertyName)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► ChildArray(String)
StructureMap API
Inline definition of a dependency array like IService[] or IHandler[]
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance..::.ChildArrayExpression ChildArray(
    string propertyName
)
Public Function ChildArray ( _
    propertyName As String _
) As ConfiguredInstance..::.ChildArrayExpression
public:
ConfiguredInstance..::.ChildArrayExpression^ ChildArray(
    String^ propertyName
)
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildArray(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.ChildArray(System.String)]


CtorDependency Method (propertyName)

CtorDependency<(Of <(CONSTRUCTORARGUMENTTYPE>)>) Method (propertyName)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► CtorDependency<(Of <(CONSTRUCTORARGUMENTTYPE>)>)(String)
StructureMap API
Inline definition of a constructor dependency
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance..::.ChildInstanceExpression CtorDependency<CONSTRUCTORARGUMENTTYPE>(
    string propertyName
)

Public Function CtorDependency(Of CONSTRUCTORARGUMENTTYPE) ( _
    propertyName As String _
) As ConfiguredInstance..::.ChildInstanceExpression
public:
generic<typename CONSTRUCTORARGUMENTTYPE>
ConfiguredInstance..::.ChildInstanceExpression^ CtorDependency(
    String^ propertyName
)
Generic Template Parameters
CONSTRUCTORARGUMENTTYPE

[Missing <typeparam name="CONSTRUCTORARGUMENTTYPE"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.CtorDependency``1(System.String)"]

Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.CtorDependency``1(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.CtorDependency``1(System.String)]


EnrichWith Method (handler)

EnrichWith<(Of <(TYPE>)>) Method (handler)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► EnrichWith<(Of <(TYPE>)>)(EnrichmentHandler<(Of <(TYPE>)>))
StructureMap API
Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance EnrichWith<TYPE>(
    EnrichmentHandler<TYPE> handler
)

Public Function EnrichWith(Of TYPE) ( _
    handler As EnrichmentHandler(Of TYPE) _
) As ConfiguredInstance
public:
generic<typename TYPE>
ConfiguredInstance^ EnrichWith(
    EnrichmentHandler<TYPE>^ handler
)
Generic Template Parameters
TYPE

[Missing <typeparam name="TYPE"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.EnrichWith``1(StructureMap.Interceptors.EnrichmentHandler{``0})"]

Parameters
handler (EnrichmentHandler <(Of <(TYPE>)>))

[Missing <param name="handler"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.EnrichWith``1(StructureMap.Interceptors.EnrichmentHandler{``0})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.EnrichWith``1(StructureMap.Interceptors.EnrichmentHandler{``0})]


getDescription Method

getDescription Method
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► getDescription()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstance.getDescription]

Declaration Syntax
C# Visual Basic Visual C++
protected override string getDescription()
Protected Overrides Function getDescription As String
protected:
virtual String^ getDescription() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.getDescription]


GetGenericType Method (templateType, types)

GetGenericType Method (templateType, types)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► GetGenericType(Type, array<Type>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstance.GetGenericType(System.Type,System.Type[])]

Declaration Syntax
C# Visual Basic Visual C++
public static Type GetGenericType(
    Type templateType,
    params Type[] types
)
Public Shared Function GetGenericType ( _
    templateType As Type, _
    ParamArray types As Type() _
) As Type
public:
static Type^ GetGenericType(
    Type^ templateType,
    ... array<Type^>^ types
)
Parameters
templateType (Type)

[Missing <param name="templateType"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.GetGenericType(System.Type,System.Type[])"]

types (array< Type >[]()[])

[Missing <param name="types"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.GetGenericType(System.Type,System.Type[])"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.GetGenericType(System.Type,System.Type[])]


OnCreation Method (handler)

OnCreation<(Of <(TYPE>)>) Method (handler)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► OnCreation<(Of <(TYPE>)>)(Action<(Of <(TYPE>)>))
StructureMap API
Register an Action to perform on the object created by this Instance before it is returned to the caller
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance OnCreation<TYPE>(
    Action<TYPE> handler
)

Public Function OnCreation(Of TYPE) ( _
    handler As Action(Of TYPE) _
) As ConfiguredInstance
public:
generic<typename TYPE>
ConfiguredInstance^ OnCreation(
    Action<TYPE>^ handler
)
Generic Template Parameters
TYPE

[Missing <typeparam name="TYPE"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.OnCreation``1(System.Action{``0})"]

Parameters
handler (Action <(Of <(TYPE>)>))

[Missing <param name="handler"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.OnCreation``1(System.Action{``0})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.OnCreation``1(System.Action{``0})]


preprocess Method (family)

preprocess Method (family)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► preprocess(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstance.preprocess(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void preprocess(
    PluginFamily family
)
Protected Overrides Sub preprocess ( _
    family As PluginFamily _
)
protected:
virtual void preprocess(
    PluginFamily^ family
) override
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.preprocess(StructureMap.Graph.PluginFamily)"]


setPluggedType Method (pluggedType)

setPluggedType Method (pluggedType)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► setPluggedType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstance.setPluggedType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected void setPluggedType(
    Type pluggedType
)
Protected Sub setPluggedType ( _
    pluggedType As Type _
)
protected:
void setPluggedType(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.setPluggedType(System.Type)"]


SetterDependency Method (propertyName)

SetterDependency<(Of <(CONSTRUCTORARGUMENTTYPE>)>) Method (propertyName)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► SetterDependency<(Of <(CONSTRUCTORARGUMENTTYPE>)>)(String)
StructureMap API
Inline definition of a setter dependency
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance..::.ChildInstanceExpression SetterDependency<CONSTRUCTORARGUMENTTYPE>(
    string propertyName
)

Public Function SetterDependency(Of CONSTRUCTORARGUMENTTYPE) ( _
    propertyName As String _
) As ConfiguredInstance..::.ChildInstanceExpression
public:
generic<typename CONSTRUCTORARGUMENTTYPE>
ConfiguredInstance..::.ChildInstanceExpression^ SetterDependency(
    String^ propertyName
)
Generic Template Parameters
CONSTRUCTORARGUMENTTYPE

[Missing <typeparam name="CONSTRUCTORARGUMENTTYPE"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.SetterDependency``1(System.String)"]

Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.SetterDependency``1(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.SetterDependency``1(System.String)]


WithCtorArg Method (propertyName)

WithCtorArg Method (propertyName)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► WithCtorArg(String)
StructureMap API
Configure a primitive constructor argument
Declaration Syntax
C# Visual Basic Visual C++
public PropertyExpression<ConfiguredInstance> WithCtorArg(
    string propertyName
)
Public Function WithCtorArg ( _
    propertyName As String _
) As PropertyExpression(Of ConfiguredInstance)
public:
PropertyExpression<ConfiguredInstance^>^ WithCtorArg(
    String^ propertyName
)
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.WithCtorArg(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.WithCtorArg(System.String)]


WithName Method (instanceKey)

WithName Method (instanceKey)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► WithName(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstance.WithName(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance WithName(
    string instanceKey
)
Public Function WithName ( _
    instanceKey As String _
) As ConfiguredInstance
public:
ConfiguredInstance^ WithName(
    String^ instanceKey
)
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.WithName(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.WithName(System.String)]


WithProperty Method (propertyName)

WithProperty Method (propertyName)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► WithProperty(String)
StructureMap API
Start the definition of a primitive argument to a constructor argument
Declaration Syntax
C# Visual Basic Visual C++
public PropertyExpression<ConfiguredInstance> WithProperty(
    string propertyName
)
Public Function WithProperty ( _
    propertyName As String _
) As PropertyExpression(Of ConfiguredInstance)
public:
PropertyExpression<ConfiguredInstance^>^ WithProperty(
    String^ propertyName
)
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.WithProperty(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.WithProperty(System.String)]


ConfiguredInstance.ChildArrayExpression Class

ConfiguredInstance..::.ChildArrayExpression Class
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► ConfiguredInstance..::.ChildArrayExpression
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.ConfiguredInstance.ChildArrayExpression]

Declaration Syntax
C# Visual Basic Visual C++
public class ChildArrayExpression
Public Class ChildArrayExpression
public ref class ChildArrayExpression
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConfiguredInstance..::.ChildArrayExpression(ConfiguredInstance, String) | Initializes a new instance of the ConfiguredInstance..::.ChildArrayExpression class
 | Contains(array<Instance>[]()[]) | Configures an array of Instance's for the array dependency
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConfiguredInstance..::.ChildArrayExpression


ConfiguredInstance.ChildArrayExpression Constructor (instance, propertyName)

ConfiguredInstance..::.ChildArrayExpression Constructor (instance, propertyName)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance..::.ChildArrayExpression ► ConfiguredInstance..::.ChildArrayExpression(ConfiguredInstance, String)
StructureMap API
Initializes a new instance of the ConfiguredInstance..::.ChildArrayExpression class
Declaration Syntax
C# Visual Basic Visual C++
public ChildArrayExpression(
    ConfiguredInstance instance,
    string propertyName
)
Public Sub New ( _
    instance As ConfiguredInstance, _
    propertyName As String _
)
public:
ChildArrayExpression(
    ConfiguredInstance^ instance,
    String^ propertyName
)
Parameters
instance (ConfiguredInstance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildArrayExpression.#ctor(StructureMap.Pipeline.ConfiguredInstance,System.String)"]

propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildArrayExpression.#ctor(StructureMap.Pipeline.ConfiguredInstance,System.String)"]


Contains Method (instances)

Contains Method (instances)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance..::.ChildArrayExpression ► Contains(array<Instance>[]()[])
StructureMap API
Configures an array of Instance's for the array dependency
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance Contains(
    params Instance[] instances
)
Public Function Contains ( _
    ParamArray instances As Instance() _
) As ConfiguredInstance
public:
ConfiguredInstance^ Contains(
    ... array<Instance^>^ instances
)
Parameters
instances (array< Instance >[]()[])

[Missing <param name="instances"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildArrayExpression.Contains(StructureMap.Pipeline.Instance[])"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.ChildArrayExpression.Contains(StructureMap.Pipeline.Instance[])]


ConfiguredInstance.ChildInstanceExpression Class

ConfiguredInstance..::.ChildInstanceExpression Class
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance ► ConfiguredInstance..::.ChildInstanceExpression
StructureMap API
Part of the Fluent Interface, represents a nonprimitive argument to a constructure function
Declaration Syntax
C# Visual Basic Visual C++
public class ChildInstanceExpression
Public Class ChildInstanceExpression
public ref class ChildInstanceExpression
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConfiguredInstance..::.ChildInstanceExpression(ConfiguredInstance, String) | Initializes a new instance of the ConfiguredInstance..::.ChildInstanceExpression class
 | ConfiguredInstance..::.ChildInstanceExpression(ConfiguredInstance, String, Type) | Initializes a new instance of the ConfiguredInstance..::.ChildInstanceExpression class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Is(Instance) | Registers a configured instance to use as the argument to the parent's constructor
 | Is(Object) |
 | IsAutoFilled()()() | Directs StructureMap to fill this dependency with the Default Instance of the constructor or property type
 | IsConcreteType<(Of <(T>)>)()()() | Start the definition of a child instance by defining the concrete type
 | IsNamedInstance(String) | Use a previously configured and named instance for the child
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ConfiguredInstance..::.ChildInstanceExpression


ConfiguredInstance.ChildInstanceExpression Constructor

ConfiguredInstance..::.ChildInstanceExpression Constructor
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance..::.ChildInstanceExpression ► ConfiguredInstance..::.ChildInstanceExpression()()()
StructureMap API
Members
Icon | Member | Description
 | ConfiguredInstance..::.ChildInstanceExpression(ConfiguredInstance, String) | Initializes a new instance of the ConfiguredInstance..::.ChildInstanceExpression class
 | ConfiguredInstance..::.ChildInstanceExpression(ConfiguredInstance, String, Type) | Initializes a new instance of the ConfiguredInstance..::.ChildInstanceExpression class


ConfiguredInstance.ChildInstanceExpression Constructor (instance, propertyName)

ConfiguredInstance..::.ChildInstanceExpression Constructor (instance, propertyName)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance..::.ChildInstanceExpression ► ConfiguredInstance..::.ChildInstanceExpression(ConfiguredInstance, String)
StructureMap API
Initializes a new instance of the ConfiguredInstance..::.ChildInstanceExpression class
Declaration Syntax
C# Visual Basic Visual C++
public ChildInstanceExpression(
    ConfiguredInstance instance,
    string propertyName
)
Public Sub New ( _
    instance As ConfiguredInstance, _
    propertyName As String _
)
public:
ChildInstanceExpression(
    ConfiguredInstance^ instance,
    String^ propertyName
)
Parameters
instance (ConfiguredInstance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildInstanceExpression.#ctor(StructureMap.Pipeline.ConfiguredInstance,System.String)"]

propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildInstanceExpression.#ctor(StructureMap.Pipeline.ConfiguredInstance,System.String)"]


ConfiguredInstance.ChildInstanceExpression Constructor (instance, propertyName, childType)

ConfiguredInstance..::.ChildInstanceExpression Constructor (instance, propertyName, childType)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance..::.ChildInstanceExpression ► ConfiguredInstance..::.ChildInstanceExpression(ConfiguredInstance, String, Type)
StructureMap API
Initializes a new instance of the ConfiguredInstance..::.ChildInstanceExpression class
Declaration Syntax
C# Visual Basic Visual C++
public ChildInstanceExpression(
    ConfiguredInstance instance,
    string propertyName,
    Type childType
)
Public Sub New ( _
    instance As ConfiguredInstance, _
    propertyName As String, _
    childType As Type _
)
public:
ChildInstanceExpression(
    ConfiguredInstance^ instance,
    String^ propertyName,
    Type^ childType
)
Parameters
instance (ConfiguredInstance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildInstanceExpression.#ctor(StructureMap.Pipeline.ConfiguredInstance,System.String,System.Type)"]

propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildInstanceExpression.#ctor(StructureMap.Pipeline.ConfiguredInstance,System.String,System.Type)"]

childType (Type)

[Missing <param name="childType"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildInstanceExpression.#ctor(StructureMap.Pipeline.ConfiguredInstance,System.String,System.Type)"]


Is Method

Is Method
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance..::.ChildInstanceExpression ► Is()()()
StructureMap API
Members
Icon | Member | Description
 | Is(Instance) | Registers a configured instance to use as the argument to the parent's constructor
 | Is(Object) |


Is Method (child)

Is Method (child)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance..::.ChildInstanceExpression ► Is(Instance)
StructureMap API
Registers a configured instance to use as the argument to the parent's constructor
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance Is(
    Instance child
)
Public Function Is ( _
    child As Instance _
) As ConfiguredInstance
public:
ConfiguredInstance^ Is(
    Instance^ child
)
Parameters
child (Instance)

[Missing <param name="child"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildInstanceExpression.Is(StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.ChildInstanceExpression.Is(StructureMap.Pipeline.Instance)]


Is Method (value)

Is Method (value)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance..::.ChildInstanceExpression ► Is(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstance.ChildInstanceExpression.Is(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance Is(
    Object value
)
Public Function Is ( _
    value As Object _
) As ConfiguredInstance
public:
ConfiguredInstance^ Is(
    Object^ value
)
Parameters
value (Object)

[Missing <param name="value"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildInstanceExpression.Is(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.ChildInstanceExpression.Is(System.Object)]


IsAutoFilled Method

IsAutoFilled Method
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance..::.ChildInstanceExpression ► IsAutoFilled()()()
StructureMap API
Directs StructureMap to fill this dependency with the Default Instance of the constructor or property type
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance IsAutoFilled()
Public Function IsAutoFilled As ConfiguredInstance
public:
ConfiguredInstance^ IsAutoFilled()
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.ChildInstanceExpression.IsAutoFilled]


IsConcreteType Method

IsConcreteType<(Of <(T>)>) Method
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance..::.ChildInstanceExpression ► IsConcreteType<(Of <(T>)>)()()()
StructureMap API
Start the definition of a child instance by defining the concrete type
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance IsConcreteType<T>()

Public Function IsConcreteType(Of T) As ConfiguredInstance
public:
generic<typename T>
ConfiguredInstance^ IsConcreteType()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildInstanceExpression.IsConcreteType``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.ChildInstanceExpression.IsConcreteType``1]


IsNamedInstance Method (instanceKey)

IsNamedInstance Method (instanceKey)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstance..::.ChildInstanceExpression ► IsNamedInstance(String)
StructureMap API
Use a previously configured and named instance for the child
Declaration Syntax
C# Visual Basic Visual C++
public ConfiguredInstance IsNamedInstance(
    string instanceKey
)
Public Function IsNamedInstance ( _
    instanceKey As String _
) As ConfiguredInstance
public:
ConfiguredInstance^ IsNamedInstance(
    String^ instanceKey
)
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstance.ChildInstanceExpression.IsNamedInstance(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstance.ChildInstanceExpression.IsNamedInstance(System.String)]


ConfiguredInstanceBase(T) Class

ConfiguredInstanceBase<(Of <(T>)>) Class
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>)
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.ConfiguredInstanceBase`1]

Declaration Syntax
C# Visual Basic Visual C++
public abstract class ConfiguredInstanceBase<T> : Instance,
    IConfiguredInstance, IStructuredInstance, Copyable

Public MustInherit Class ConfiguredInstanceBase(Of T) _
    Inherits Instance _
    Implements IConfiguredInstance, IStructuredInstance, Copyable
generic<typename T>
public ref class ConfiguredInstanceBase abstract : public Instance,
    IConfiguredInstance, IStructuredInstance, Copyable
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:StructureMap.Pipeline.ConfiguredInstanceBase`1"]

Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConfiguredInstanceBase<(Of <(T>)>)(InstanceMemento, PluginGraph, Type) | Initializes a new instance of the ConfiguredInstanceBase<(Of <(T>)>) class
 | ConfiguredInstanceBase<(Of <(T>)>)(Type, String) | Initializes a new instance of the ConfiguredInstanceBase<(Of <(T>)>) class
 | ConfiguredInstanceBase<(Of <(T>)>)(Type) | Initializes a new instance of the ConfiguredInstanceBase<(Of <(T>)>) class
 | _arrays |
 | _children |
 | _pluggedType |
 | _properties |
 | addTemplatedInstanceTo(PluginFamily, array<Type>[]()[]) | (Inherited from Instance.)
 | build(Type, BuildSession) | (Overrides Instance.build(Type, BuildSession).)
 | Build(Type, BuildSession) | (Inherited from Instance.)
 | canBePartOfPluginFamily(PluginFamily) | (Overrides Instance.canBePartOfPluginFamily(PluginFamily).)
 | doesRecordOnTheStack | (Inherited from Instance.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | findMasterInstance(PluginFamily, String, GraphLog) | (Inherited from Instance.)
 | findPropertyName<(Of <(T>)>)()()() |
 | getChild(String, Type, BuildSession) |
 | getConcreteType(Type) | (Overrides Instance.getConcreteType(Type).)
 | getDescription()()() | (Inherited from Instance.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interceptor | (Inherited from Instance.)
 | markBuildStackFinish(BuildSession) | (Inherited from Instance.)
 | markBuildStackStart(BuildSession, Type) | (Inherited from Instance.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | mergeIntoThis(Copyable) |
 | Name | (Inherited from Instance.)
 | preprocess(PluginFamily) | (Inherited from Instance.)
 | replaceNameIfNotAlreadySet(String) | (Inherited from Instance.)
 | setChild(String, Instance) |
 | setChildArray(String, array<Instance>[]()[]) |
 | setProperty(String, String) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | validateTypeIsArray<(Of <(PLUGINTYPE>)>)()()() |
Inheritance Hierarchy
Object
 | Instance
 |  | ConfiguredInstanceBase<(Of <(T>)>)
 |  |  | ConfiguredInstance
 |  |  | SmartInstance<(Of <(T>)>)


ConfiguredInstanceBase(T) Constructor

ConfiguredInstanceBase<(Of <(T>)>) Constructor
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► ConfiguredInstanceBase<(Of <(T>)>)()()()
StructureMap API
Members
Icon | Member | Description
 | ConfiguredInstanceBase<(Of <(T>)>)(InstanceMemento, PluginGraph, Type) | Initializes a new instance of the ConfiguredInstanceBase<(Of <(T>)>) class
 | ConfiguredInstanceBase<(Of <(T>)>)(Type, String) | Initializes a new instance of the ConfiguredInstanceBase<(Of <(T>)>) class
 | ConfiguredInstanceBase<(Of <(T>)>)(Type) | Initializes a new instance of the ConfiguredInstanceBase<(Of <(T>)>) class


ConfiguredInstanceBase(T) Constructor (memento, graph, pluginType)

ConfiguredInstanceBase<(Of <(T>)>) Constructor (memento, graph, pluginType)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► ConfiguredInstanceBase<(Of <(T>)>)(InstanceMemento, PluginGraph, Type)
StructureMap API
Initializes a new instance of the ConfiguredInstanceBase<(Of <(T>)>) class
Declaration Syntax
C# Visual Basic Visual C++
protected ConfiguredInstanceBase(
    InstanceMemento memento,
    PluginGraph graph,
    Type pluginType
)
Protected Sub New ( _
    memento As InstanceMemento, _
    graph As PluginGraph, _
    pluginType As Type _
)
protected:
ConfiguredInstanceBase(
    InstanceMemento^ memento,
    PluginGraph^ graph,
    Type^ pluginType
)
Parameters
memento (InstanceMemento)

[Missing <param name="memento"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.#ctor(StructureMap.InstanceMemento,StructureMap.Graph.PluginGraph,System.Type)"]

graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.#ctor(StructureMap.InstanceMemento,StructureMap.Graph.PluginGraph,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.#ctor(StructureMap.InstanceMemento,StructureMap.Graph.PluginGraph,System.Type)"]


ConfiguredInstanceBase(T) Constructor (pluggedType)

ConfiguredInstanceBase<(Of <(T>)>) Constructor (pluggedType)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► ConfiguredInstanceBase<(Of <(T>)>)(Type)
StructureMap API
Initializes a new instance of the ConfiguredInstanceBase<(Of <(T>)>) class
Declaration Syntax
C# Visual Basic Visual C++
protected ConfiguredInstanceBase(
    Type pluggedType
)
Protected Sub New ( _
    pluggedType As Type _
)
protected:
ConfiguredInstanceBase(
    Type^ pluggedType
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.#ctor(System.Type)"]


ConfiguredInstanceBase(T) Constructor (pluggedType, name)

ConfiguredInstanceBase<(Of <(T>)>) Constructor (pluggedType, name)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► ConfiguredInstanceBase<(Of <(T>)>)(Type, String)
StructureMap API
Initializes a new instance of the ConfiguredInstanceBase<(Of <(T>)>) class
Declaration Syntax
C# Visual Basic Visual C++
protected ConfiguredInstanceBase(
    Type pluggedType,
    string name
)
Protected Sub New ( _
    pluggedType As Type, _
    name As String _
)
protected:
ConfiguredInstanceBase(
    Type^ pluggedType,
    String^ name
)
Parameters
pluggedType (Type)

[Missing <param name="pluggedType"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.#ctor(System.Type,System.String)"]

name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.#ctor(System.Type,System.String)"]


_arrays Field

_arrays Field
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► _arrays
StructureMap API

[Missing <summary> documentation for F:StructureMap.Pipeline.ConfiguredInstanceBase`1._arrays]

Declaration Syntax
C# Visual Basic Visual C++
protected Dictionary<string, Instance[]> _arrays
Protected _arrays As Dictionary(Of String, Instance())
protected:
Dictionary<String^, array<Instance^>^>^ _arrays


_children Field

_children Field
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► _children
StructureMap API

[Missing <summary> documentation for F:StructureMap.Pipeline.ConfiguredInstanceBase`1._children]

Declaration Syntax
C# Visual Basic Visual C++
protected Dictionary<string, Instance> _children
Protected _children As Dictionary(Of String, Instance)
protected:
Dictionary<String^, Instance^>^ _children


_pluggedType Field

_pluggedType Field
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► _pluggedType
StructureMap API

[Missing <summary> documentation for F:StructureMap.Pipeline.ConfiguredInstanceBase`1._pluggedType]

Declaration Syntax
C# Visual Basic Visual C++
protected Type _pluggedType
Protected _pluggedType As Type
protected:
Type^ _pluggedType


_properties Field

_properties Field
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► _properties
StructureMap API

[Missing <summary> documentation for F:StructureMap.Pipeline.ConfiguredInstanceBase`1._properties]

Declaration Syntax
C# Visual Basic Visual C++
protected Dictionary<string, string> _properties
Protected _properties As Dictionary(Of String, String)
protected:
Dictionary<String^, String^>^ _properties


build Method (pluginType, session)

build Method (pluginType, session)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► build(Type, BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstanceBase`1.build(System.Type,StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
protected override Object build(
    Type pluginType,
    BuildSession session
)
Protected Overrides Function build ( _
    pluginType As Type, _
    session As BuildSession _
) As Object
protected:
virtual Object^ build(
    Type^ pluginType,
    BuildSession^ session
) override
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.build(System.Type,StructureMap.BuildSession)"]

session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.build(System.Type,StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstanceBase`1.build(System.Type,StructureMap.BuildSession)]


canBePartOfPluginFamily Method (family)

canBePartOfPluginFamily Method (family)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► canBePartOfPluginFamily(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstanceBase`1.canBePartOfPluginFamily(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool canBePartOfPluginFamily(
    PluginFamily family
)
Protected Overrides Function canBePartOfPluginFamily ( _
    family As PluginFamily _
) As Boolean
protected:
virtual bool canBePartOfPluginFamily(
    PluginFamily^ family
) override
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.canBePartOfPluginFamily(StructureMap.Graph.PluginFamily)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstanceBase`1.canBePartOfPluginFamily(StructureMap.Graph.PluginFamily)]


findPropertyName Method

findPropertyName<(Of <(T>)>) Method
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► findPropertyName<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstanceBase`1.findPropertyName``1]

Declaration Syntax
C# Visual Basic Visual C++
protected string findPropertyName<T>()

Protected Function findPropertyName(Of T) As String
protected:
generic<typename T>
String^ findPropertyName()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.findPropertyName``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstanceBase`1.findPropertyName``1]


getChild Method (propertyName, pluginType, buildSession)

getChild Method (propertyName, pluginType, buildSession)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► getChild(String, Type, BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstanceBase`1.getChild(System.String,System.Type,StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
protected virtual Object getChild(
    string propertyName,
    Type pluginType,
    BuildSession buildSession
)
Protected Overridable Function getChild ( _
    propertyName As String, _
    pluginType As Type, _
    buildSession As BuildSession _
) As Object
protected:
virtual Object^ getChild(
    String^ propertyName,
    Type^ pluginType,
    BuildSession^ buildSession
)
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.getChild(System.String,System.Type,StructureMap.BuildSession)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.getChild(System.String,System.Type,StructureMap.BuildSession)"]

buildSession (BuildSession)

[Missing <param name="buildSession"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.getChild(System.String,System.Type,StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstanceBase`1.getChild(System.String,System.Type,StructureMap.BuildSession)]


getConcreteType Method (pluginType)

getConcreteType Method (pluginType)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► getConcreteType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstanceBase`1.getConcreteType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected override Type getConcreteType(
    Type pluginType
)
Protected Overrides Function getConcreteType ( _
    pluginType As Type _
) As Type
protected:
virtual Type^ getConcreteType(
    Type^ pluginType
) override
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.getConcreteType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConfiguredInstanceBase`1.getConcreteType(System.Type)]


mergeIntoThis Method (instance)

mergeIntoThis Method (instance)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► mergeIntoThis(Copyable)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstanceBase`1.mergeIntoThis(StructureMap.Pipeline.Copyable)]

Declaration Syntax
C# Visual Basic Visual C++
protected void mergeIntoThis(
    Copyable instance
)
Protected Sub mergeIntoThis ( _
    instance As Copyable _
)
protected:
void mergeIntoThis(
    Copyable^ instance
)
Parameters
instance (Copyable)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.mergeIntoThis(StructureMap.Pipeline.Copyable)"]


setChild Method (name, instance)

setChild Method (name, instance)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► setChild(String, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstanceBase`1.setChild(System.String,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
protected void setChild(
    string name,
    Instance instance
)
Protected Sub setChild ( _
    name As String, _
    instance As Instance _
)
protected:
void setChild(
    String^ name,
    Instance^ instance
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.setChild(System.String,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.setChild(System.String,StructureMap.Pipeline.Instance)"]


setChildArray Method (name, array)

setChildArray Method (name, array)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► setChildArray(String, array<Instance>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstanceBase`1.setChildArray(System.String,StructureMap.Pipeline.Instance[])]

Declaration Syntax
C# Visual Basic Visual C++
protected void setChildArray(
    string name,
    Instance[] array
)
Protected Sub setChildArray ( _
    name As String, _
    array As Instance() _
)
protected:
void setChildArray(
    String^ name,
    array<Instance^>^ array
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.setChildArray(System.String,StructureMap.Pipeline.Instance[])"]

array (array< Instance >[]()[])

[Missing <param name="array"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.setChildArray(System.String,StructureMap.Pipeline.Instance[])"]


setProperty Method (propertyName, propertyValue)

setProperty Method (propertyName, propertyValue)
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► setProperty(String, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstanceBase`1.setProperty(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected void setProperty(
    string propertyName,
    string propertyValue
)
Protected Sub setProperty ( _
    propertyName As String, _
    propertyValue As String _
)
protected:
void setProperty(
    String^ propertyName,
    String^ propertyValue
)
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.setProperty(System.String,System.String)"]

propertyValue (String)

[Missing <param name="propertyValue"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.setProperty(System.String,System.String)"]


validateTypeIsArray Method

validateTypeIsArray<(Of <(PLUGINTYPE>)>) Method
Namespaces ► StructureMap.Pipeline ► ConfiguredInstanceBase<(Of <(T>)>) ► validateTypeIsArray<(Of <(PLUGINTYPE>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConfiguredInstanceBase`1.validateTypeIsArray``1]

Declaration Syntax
C# Visual Basic Visual C++
protected static void validateTypeIsArray<PLUGINTYPE>()

Protected Shared Sub validateTypeIsArray(Of PLUGINTYPE)
protected:
generic<typename PLUGINTYPE>
static void validateTypeIsArray()
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.Pipeline.ConfiguredInstanceBase`1.validateTypeIsArray``1"]


ConstructorInstance(T) Class

ConstructorInstance<(Of <(T>)>) Class
Namespaces ► StructureMap.Pipeline ► ConstructorInstance<(Of <(T>)>)
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.ConstructorInstance`1]

Declaration Syntax
C# Visual Basic Visual C++
public class ConstructorInstance<T> : ExpressedInstance<ConstructorInstance<T>>

Public Class ConstructorInstance(Of T) _
    Inherits ExpressedInstance(Of ConstructorInstance(Of T))
generic<typename T>
public ref class ConstructorInstance : public ExpressedInstance<ConstructorInstance<T>^>
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:StructureMap.Pipeline.ConstructorInstance`1"]

Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ConstructorInstance<(Of <(T>)>)(Func<(Of <(IContext, T>)>)) | Initializes a new instance of the ConstructorInstance<(Of <(T>)>) class
 | ConstructorInstance<(Of <(T>)>)(Func<(Of <(T>)>)) | Initializes a new instance of the ConstructorInstance<(Of <(T>)>) class
 | addTemplatedInstanceTo(PluginFamily, array<Type>[]()[]) | (Inherited from Instance.)
 | build(Type, BuildSession) | (Overrides Instance.build(Type, BuildSession).)
 | Build(Type, BuildSession) | (Inherited from Instance.)
 | canBePartOfPluginFamily(PluginFamily) | (Inherited from Instance.)
 | doesRecordOnTheStack | (Inherited from Instance.)
 | EnrichWith<(Of <(TYPE>)>)(EnrichmentHandler<(Of <(TYPE>)>)) | Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller (Inherited from ExpressedInstance<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | findMasterInstance(PluginFamily, String, GraphLog) | (Inherited from Instance.)
 | getConcreteType(Type) | (Inherited from Instance.)
 | getDescription()()() | (Overrides Instance.getDescription()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interceptor | (Inherited from Instance.)
 | InterceptWith(InstanceInterceptor) | Register an InstanceInterceptor with this Instance (Inherited from ExpressedInstance<(Of <(T>)>).)
 | markBuildStackFinish(BuildSession) | (Inherited from Instance.)
 | markBuildStackStart(BuildSession, Type) | (Inherited from Instance.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | (Inherited from Instance.)
 | OnCreation<(Of <(TYPE>)>)(Action<(Of <(TYPE>)>)) | Register an Action to perform on the object created by this Instance before it is returned to the caller (Inherited from ExpressedInstance<(Of <(T>)>).)
 | preprocess(PluginFamily) | (Inherited from Instance.)
 | replaceNameIfNotAlreadySet(String) | (Inherited from Instance.)
 | thisInstance | (Overrides ExpressedInstance <(Of <(ConstructorInstance<(Of <(T>)>)>)>).thisInstance.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WithName(String) | Set the name of this Instance (Inherited from ExpressedInstance<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | Instance
 |  | ExpressedInstance <(Of <(ConstructorInstance<(Of <(T>)>)>)>)
 |  |  | ConstructorInstance<(Of <(T>)>)


ConstructorInstance(T) Constructor

ConstructorInstance<(Of <(T>)>) Constructor
Namespaces ► StructureMap.Pipeline ► ConstructorInstance<(Of <(T>)>) ► ConstructorInstance<(Of <(T>)>)()()()
StructureMap API
Members
Icon | Member | Description
 | ConstructorInstance<(Of <(T>)>)(Func<(Of <(IContext, T>)>)) | Initializes a new instance of the ConstructorInstance<(Of <(T>)>) class
 | ConstructorInstance<(Of <(T>)>)(Func<(Of <(T>)>)) | Initializes a new instance of the ConstructorInstance<(Of <(T>)>) class


ConstructorInstance(T) Constructor (func)

ConstructorInstance<(Of <(T>)>) Constructor (func)
Namespaces ► StructureMap.Pipeline ► ConstructorInstance<(Of <(T>)>) ► ConstructorInstance<(Of <(T>)>)(Func<(Of <(T>)>))
StructureMap API
Initializes a new instance of the ConstructorInstance<(Of <(T>)>) class
Declaration Syntax
C# Visual Basic Visual C++
public ConstructorInstance(
    Func<T> func
)
Public Sub New ( _
    func As Func(Of T) _
)
public:
ConstructorInstance(
    Func<T>^ func
)
Parameters
func (Func <(Of <( T >)>))

[Missing <param name="func"/> documentation for "M:StructureMap.Pipeline.ConstructorInstance`1.#ctor(System.Func{`0})"]


ConstructorInstance(T) Constructor (builder)

ConstructorInstance<(Of <(T>)>) Constructor (builder)
Namespaces ► StructureMap.Pipeline ► ConstructorInstance<(Of <(T>)>) ► ConstructorInstance<(Of <(T>)>)(Func<(Of <(IContext, T>)>))
StructureMap API
Initializes a new instance of the ConstructorInstance<(Of <(T>)>) class
Declaration Syntax
C# Visual Basic Visual C++
public ConstructorInstance(
    Func<IContext, T> builder
)
Public Sub New ( _
    builder As Func(Of IContext, T) _
)
public:
ConstructorInstance(
    Func<IContext^, T>^ builder
)
Parameters
builder (Func <(Of <( IContext, T >)>))

[Missing <param name="builder"/> documentation for "M:StructureMap.Pipeline.ConstructorInstance`1.#ctor(System.Func{StructureMap.IContext,`0})"]


build Method (pluginType, session)

build Method (pluginType, session)
Namespaces ► StructureMap.Pipeline ► ConstructorInstance<(Of <(T>)>) ► build(Type, BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConstructorInstance`1.build(System.Type,StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
protected override Object build(
    Type pluginType,
    BuildSession session
)
Protected Overrides Function build ( _
    pluginType As Type, _
    session As BuildSession _
) As Object
protected:
virtual Object^ build(
    Type^ pluginType,
    BuildSession^ session
) override
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ConstructorInstance`1.build(System.Type,StructureMap.BuildSession)"]

session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.ConstructorInstance`1.build(System.Type,StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConstructorInstance`1.build(System.Type,StructureMap.BuildSession)]


getDescription Method

getDescription Method
Namespaces ► StructureMap.Pipeline ► ConstructorInstance<(Of <(T>)>) ► getDescription()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ConstructorInstance`1.getDescription]

Declaration Syntax
C# Visual Basic Visual C++
protected override string getDescription()
Protected Overrides Function getDescription As String
protected:
virtual String^ getDescription() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ConstructorInstance`1.getDescription]


thisInstance Property

thisInstance Property
Namespaces ► StructureMap.Pipeline ► ConstructorInstance<(Of <(T>)>) ► thisInstance
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.ConstructorInstance`1.thisInstance]

Declaration Syntax
C# Visual Basic Visual C++
protected override ConstructorInstance<T> thisInstance { get; }
Protected Overrides ReadOnly Property thisInstance As ConstructorInstance(Of T)
protected:
virtual property ConstructorInstance<T>^ thisInstance {
    ConstructorInstance<T>^ get () override;
}


Copyable Interface

Copyable Interface
Namespaces ► StructureMap.Pipeline ► Copyable
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.Copyable]

Declaration Syntax
C# Visual Basic Visual C++
public interface Copyable
Public Interface Copyable
public interface class Copyable
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Arrays |
 | Children |
 | PluggedType |
 | Properties |


Arrays Property

Arrays Property
Namespaces ► StructureMap.Pipeline ► Copyable ► Arrays
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.Copyable.Arrays]

Declaration Syntax
C# Visual Basic Visual C++
Dictionary<string, Instance[]> Arrays { get; }
ReadOnly Property Arrays As Dictionary(Of String, Instance())
property Dictionary<String^, array<Instance^>^>^ Arrays {
    Dictionary<String^, array<Instance^>^>^ get ();
}


Children Property

Children Property
Namespaces ► StructureMap.Pipeline ► Copyable ► Children
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.Copyable.Children]

Declaration Syntax
C# Visual Basic Visual C++
Dictionary<string, Instance> Children { get; }
ReadOnly Property Children As Dictionary(Of String, Instance)
property Dictionary<String^, Instance^>^ Children {
    Dictionary<String^, Instance^>^ get ();
}


PluggedType Property

PluggedType Property
Namespaces ► StructureMap.Pipeline ► Copyable ► PluggedType
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.Copyable.PluggedType]

Declaration Syntax
C# Visual Basic Visual C++
Type PluggedType { get; }
ReadOnly Property PluggedType As Type
property Type^ PluggedType {
    Type^ get ();
}


Properties Property

Properties Property
Namespaces ► StructureMap.Pipeline ► Copyable ► Properties
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.Copyable.Properties]

Declaration Syntax
C# Visual Basic Visual C++
Dictionary<string, string> Properties { get; }
ReadOnly Property Properties As Dictionary(Of String, String)
property Dictionary<String^, String^>^ Properties {
    Dictionary<String^, String^>^ get ();
}


DefaultInstance Class

DefaultInstance Class
Namespaces ► StructureMap.Pipeline ► DefaultInstance
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.DefaultInstance]

Declaration Syntax
C# Visual Basic Visual C++
public class DefaultInstance : Instance
Public Class DefaultInstance _
    Inherits Instance
public ref class DefaultInstance : public Instance
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DefaultInstance()()() | Initializes a new instance of the DefaultInstance class
 | addTemplatedInstanceTo(PluginFamily, array<Type>[]()[]) | (Inherited from Instance.)
 | build(Type, BuildSession) | (Overrides Instance.build(Type, BuildSession).)
 | Build(Type, BuildSession) | (Inherited from Instance.)
 | canBePartOfPluginFamily(PluginFamily) | (Inherited from Instance.)
 | doesRecordOnTheStack | (Overrides Instance.doesRecordOnTheStack.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | findMasterInstance(PluginFamily, String, GraphLog) | (Inherited from Instance.)
 | getConcreteType(Type) | (Inherited from Instance.)
 | getDescription()()() | (Overrides Instance.getDescription()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interceptor | (Inherited from Instance.)
 | markBuildStackFinish(BuildSession) | (Inherited from Instance.)
 | markBuildStackStart(BuildSession, Type) | (Inherited from Instance.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | (Inherited from Instance.)
 | preprocess(PluginFamily) | (Inherited from Instance.)
 | replaceNameIfNotAlreadySet(String) | (Inherited from Instance.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Instance
 |  | DefaultInstance


DefaultInstance Constructor

DefaultInstance Constructor
Namespaces ► StructureMap.Pipeline ► DefaultInstance ► DefaultInstance()()()
StructureMap API
Initializes a new instance of the DefaultInstance class
Declaration Syntax
C# Visual Basic Visual C++
public DefaultInstance()
Public Sub New
public:
DefaultInstance()


build Method (pluginType, session)

build Method (pluginType, session)
Namespaces ► StructureMap.Pipeline ► DefaultInstance ► build(Type, BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.DefaultInstance.build(System.Type,StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
protected override Object build(
    Type pluginType,
    BuildSession session
)
Protected Overrides Function build ( _
    pluginType As Type, _
    session As BuildSession _
) As Object
protected:
virtual Object^ build(
    Type^ pluginType,
    BuildSession^ session
) override
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.DefaultInstance.build(System.Type,StructureMap.BuildSession)"]

session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.DefaultInstance.build(System.Type,StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.DefaultInstance.build(System.Type,StructureMap.BuildSession)]


doesRecordOnTheStack Property

doesRecordOnTheStack Property
Namespaces ► StructureMap.Pipeline ► DefaultInstance ► doesRecordOnTheStack
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.DefaultInstance.doesRecordOnTheStack]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool doesRecordOnTheStack { get; }
Protected Overrides ReadOnly Property doesRecordOnTheStack As Boolean
protected:
virtual property bool doesRecordOnTheStack {
    bool get () override;
}


getDescription Method

getDescription Method
Namespaces ► StructureMap.Pipeline ► DefaultInstance ► getDescription()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.DefaultInstance.getDescription]

Declaration Syntax
C# Visual Basic Visual C++
protected override string getDescription()
Protected Overrides Function getDescription As String
protected:
virtual String^ getDescription() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.DefaultInstance.getDescription]


ExplicitArguments Class

ExplicitArguments Class
Namespaces ► StructureMap.Pipeline ► ExplicitArguments
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.ExplicitArguments]

Declaration Syntax
C# Visual Basic Visual C++
public class ExplicitArguments
Public Class ExplicitArguments
public ref class ExplicitArguments
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ExplicitArguments(IDictionary<(Of <(String, Object>)>)) | Initializes a new instance of the ExplicitArguments class
 | ExplicitArguments()()() | Initializes a new instance of the ExplicitArguments class
 | Configure(IConfiguredInstance) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Get<(Of <(T>)>)()()() |
 | Get(Type) |
 | GetArg(String) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Has(Type) |
 | Has(String) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | RegisterDefaults(BuildSession) |
 | Set<(Of <(T>)>)(T) |
 | SetArg(String, Object) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ExplicitArguments


ExplicitArguments Constructor

ExplicitArguments Constructor
Namespaces ► StructureMap.Pipeline ► ExplicitArguments ► ExplicitArguments()()()
StructureMap API
Members
Icon | Member | Description
 | ExplicitArguments(IDictionary<(Of <(String, Object>)>)) | Initializes a new instance of the ExplicitArguments class
 | ExplicitArguments()()() | Initializes a new instance of the ExplicitArguments class


ExplicitArguments Constructor

ExplicitArguments Constructor
Namespaces ► StructureMap.Pipeline ► ExplicitArguments ► ExplicitArguments()()()
StructureMap API
Initializes a new instance of the ExplicitArguments class
Declaration Syntax
C# Visual Basic Visual C++
public ExplicitArguments()
Public Sub New
public:
ExplicitArguments()


ExplicitArguments Constructor (args)

ExplicitArguments Constructor (args)
Namespaces ► StructureMap.Pipeline ► ExplicitArguments ► ExplicitArguments(IDictionary<(Of <(String, Object>)>))
StructureMap API
Initializes a new instance of the ExplicitArguments class
Declaration Syntax
C# Visual Basic Visual C++
public ExplicitArguments(
    IDictionary<string, Object> args
)
Public Sub New ( _
    args As IDictionary(Of String, Object) _
)
public:
ExplicitArguments(
    IDictionary<String^, Object^>^ args
)
Parameters
args (IDictionary <(Of <( String, Object >)>))

[Missing <param name="args"/> documentation for "M:StructureMap.Pipeline.ExplicitArguments.#ctor(System.Collections.Generic.IDictionary{System.String,System.Object})"]


Configure Method (instance)

Configure Method (instance)
Namespaces ► StructureMap.Pipeline ► ExplicitArguments ► Configure(IConfiguredInstance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ExplicitArguments.Configure(StructureMap.Pipeline.IConfiguredInstance)]

Declaration Syntax
C# Visual Basic Visual C++
public void Configure(
    IConfiguredInstance instance
)
Public Sub Configure ( _
    instance As IConfiguredInstance _
)
public:
void Configure(
    IConfiguredInstance^ instance
)
Parameters
instance (IConfiguredInstance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.ExplicitArguments.Configure(StructureMap.Pipeline.IConfiguredInstance)"]


Get Method

Get Method
Namespaces ► StructureMap.Pipeline ► ExplicitArguments ► Get()()()
StructureMap API
Members
Icon | Member | Description
 | Get<(Of <(T>)>)()()() |
 | Get(Type) |


Get Method

Get<(Of <(T>)>) Method
Namespaces ► StructureMap.Pipeline ► ExplicitArguments ► Get<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ExplicitArguments.Get``1]

Declaration Syntax
C# Visual Basic Visual C++
public T Get<T>()
where T : class

Public Function Get(Of T As Class) As T
public:
generic<typename T>
where T : ref class
T Get()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Pipeline.ExplicitArguments.Get``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ExplicitArguments.Get``1]


Get Method (type)

Get Method (type)
Namespaces ► StructureMap.Pipeline ► ExplicitArguments ► Get(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ExplicitArguments.Get(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public Object Get(
    Type type
)
Public Function Get ( _
    type As Type _
) As Object
public:
Object^ Get(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Pipeline.ExplicitArguments.Get(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ExplicitArguments.Get(System.Type)]


GetArg Method (key)

GetArg Method (key)
Namespaces ► StructureMap.Pipeline ► ExplicitArguments ► GetArg(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ExplicitArguments.GetArg(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public Object GetArg(
    string key
)
Public Function GetArg ( _
    key As String _
) As Object
public:
Object^ GetArg(
    String^ key
)
Parameters
key (String)

[Missing <param name="key"/> documentation for "M:StructureMap.Pipeline.ExplicitArguments.GetArg(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ExplicitArguments.GetArg(System.String)]


Has Method

Has Method
Namespaces ► StructureMap.Pipeline ► ExplicitArguments ► Has()()()
StructureMap API
Members
Icon | Member | Description
 | Has(Type) |
 | Has(String) |


Has Method (propertyName)

Has Method (propertyName)
Namespaces ► StructureMap.Pipeline ► ExplicitArguments ► Has(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ExplicitArguments.Has(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public bool Has(
    string propertyName
)
Public Function Has ( _
    propertyName As String _
) As Boolean
public:
bool Has(
    String^ propertyName
)
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.ExplicitArguments.Has(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ExplicitArguments.Has(System.String)]


Has Method (type)

Has Method (type)
Namespaces ► StructureMap.Pipeline ► ExplicitArguments ► Has(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ExplicitArguments.Has(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public bool Has(
    Type type
)
Public Function Has ( _
    type As Type _
) As Boolean
public:
bool Has(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Pipeline.ExplicitArguments.Has(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ExplicitArguments.Has(System.Type)]


RegisterDefaults Method (session)

RegisterDefaults Method (session)
Namespaces ► StructureMap.Pipeline ► ExplicitArguments ► RegisterDefaults(BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ExplicitArguments.RegisterDefaults(StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
public void RegisterDefaults(
    BuildSession session
)
Public Sub RegisterDefaults ( _
    session As BuildSession _
)
public:
void RegisterDefaults(
    BuildSession^ session
)
Parameters
session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.ExplicitArguments.RegisterDefaults(StructureMap.BuildSession)"]


Set Method (arg)

Set<(Of <(T>)>) Method (arg)
Namespaces ► StructureMap.Pipeline ► ExplicitArguments ► Set<(Of <(T>)>)(T)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ExplicitArguments.Set``1(``0)]

Declaration Syntax
C# Visual Basic Visual C++
public void Set<T>(
    T arg
)

Public Sub Set(Of T) ( _
    arg As T _
)
public:
generic<typename T>
void Set(
    T arg
)
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Pipeline.ExplicitArguments.Set``1(``0)"]

Parameters
arg (T)

[Missing <param name="arg"/> documentation for "M:StructureMap.Pipeline.ExplicitArguments.Set``1(``0)"]


SetArg Method (key, argValue)

SetArg Method (key, argValue)
Namespaces ► StructureMap.Pipeline ► ExplicitArguments ► SetArg(String, Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ExplicitArguments.SetArg(System.String,System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetArg(
    string key,
    Object argValue
)
Public Sub SetArg ( _
    key As String, _
    argValue As Object _
)
public:
void SetArg(
    String^ key,
    Object^ argValue
)
Parameters
key (String)

[Missing <param name="key"/> documentation for "M:StructureMap.Pipeline.ExplicitArguments.SetArg(System.String,System.Object)"]

argValue (Object)

[Missing <param name="argValue"/> documentation for "M:StructureMap.Pipeline.ExplicitArguments.SetArg(System.String,System.Object)"]


ExplicitInstance Class

ExplicitInstance Class
Namespaces ► StructureMap.Pipeline ► ExplicitInstance
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.ExplicitInstance]

Declaration Syntax
C# Visual Basic Visual C++
public class ExplicitInstance : ConfiguredInstance
Public Class ExplicitInstance _
    Inherits ConfiguredInstance
public ref class ExplicitInstance : public ConfiguredInstance
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExplicitInstance(Type, ExplicitArguments, Instance) | Initializes a new instance of the ExplicitInstance class
 | _arrays | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | _children | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | _pluggedType | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | _properties | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | addTemplatedInstanceTo(PluginFamily, array<Type>[]()[]) | (Inherited from ConfiguredInstance.)
 | build(Type, BuildSession) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | Build(Type, BuildSession) | (Inherited from Instance.)
 | canBePartOfPluginFamily(PluginFamily) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | Child<(Of <(CONSTRUCTORARGUMENTTYPE>)>)()()() | Start the definition of a child instance for type CONSTRUCTORARGUMENTTYPE (Inherited from ConfiguredInstance.)
 | Child(String) | Inline definition of a constructor or a setter property dependency (Inherited from ConfiguredInstance.)
 | ChildArray<(Of <(PLUGINTYPE>)>)(String) | Inline definition of a dependency array like IService[] or IHandler[] (Inherited from ConfiguredInstance.)
 | ChildArray<(Of <(PLUGINTYPE>)>)()()() | Inline definition of a dependency array like IService[] or IHandler[] (Inherited from ConfiguredInstance.)
 | CtorDependency<(Of <(CONSTRUCTORARGUMENTTYPE>)>)(String) | Inline definition of a constructor dependency (Inherited from ConfiguredInstance.)
 | doesRecordOnTheStack | (Inherited from Instance.)
 | EnrichWith<(Of <(TYPE>)>)(EnrichmentHandler<(Of <(TYPE>)>)) | Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller (Inherited from ConfiguredInstance.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | findMasterInstance(PluginFamily, String, GraphLog) | (Inherited from Instance.)
 | findPropertyName<(Of <(T>)>)()()() | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | getChild(String, Type, BuildSession) | (Overrides ConfiguredInstanceBase <(Of <( ConfiguredInstance >)>).getChild(String, Type, BuildSession).)
 | getConcreteType(Type) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | getDescription()()() | (Inherited from ConfiguredInstance.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interceptor | (Inherited from Instance.)
 | markBuildStackFinish(BuildSession) | (Inherited from Instance.)
 | markBuildStackStart(BuildSession, Type) | (Inherited from Instance.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | mergeIntoThis(Copyable) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | Name | (Inherited from Instance.)
 | OnCreation<(Of <(TYPE>)>)(Action<(Of <(TYPE>)>)) | Register an Action to perform on the object created by this Instance before it is returned to the caller (Inherited from ConfiguredInstance.)
 | preprocess(PluginFamily) | (Inherited from ConfiguredInstance.)
 | replaceNameIfNotAlreadySet(String) | (Inherited from Instance.)
 | setChild(String, Instance) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | setChildArray(String, array<Instance>[]()[]) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | setPluggedType(Type) | (Inherited from ConfiguredInstance.)
 | setProperty(String, String) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | SetterDependency<(Of <(CONSTRUCTORARGUMENTTYPE>)>)(String) | Inline definition of a setter dependency (Inherited from ConfiguredInstance.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WithCtorArg(String) | Configure a primitive constructor argument (Inherited from ConfiguredInstance.)
 | WithName(String) | (Inherited from ConfiguredInstance.)
 | WithProperty(String) | Start the definition of a primitive argument to a constructor argument (Inherited from ConfiguredInstance.)
Inheritance Hierarchy
Object
 | Instance
 |  | ConfiguredInstanceBase <(Of <( ConfiguredInstance >)>)
 |  |  | ConfiguredInstance
 |  |  |  | ExplicitInstance


ExplicitInstance Constructor (pluginType, args, defaultInstance)

ExplicitInstance Constructor (pluginType, args, defaultInstance)
Namespaces ► StructureMap.Pipeline ► ExplicitInstance ► ExplicitInstance(Type, ExplicitArguments, Instance)
StructureMap API
Initializes a new instance of the ExplicitInstance class
Declaration Syntax
C# Visual Basic Visual C++
public ExplicitInstance(
    Type pluginType,
    ExplicitArguments args,
    Instance defaultInstance
)
Public Sub New ( _
    pluginType As Type, _
    args As ExplicitArguments, _
    defaultInstance As Instance _
)
public:
ExplicitInstance(
    Type^ pluginType,
    ExplicitArguments^ args,
    Instance^ defaultInstance
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ExplicitInstance.#ctor(System.Type,StructureMap.Pipeline.ExplicitArguments,StructureMap.Pipeline.Instance)"]

args (ExplicitArguments)

[Missing <param name="args"/> documentation for "M:StructureMap.Pipeline.ExplicitInstance.#ctor(System.Type,StructureMap.Pipeline.ExplicitArguments,StructureMap.Pipeline.Instance)"]

defaultInstance (Instance)

[Missing <param name="defaultInstance"/> documentation for "M:StructureMap.Pipeline.ExplicitInstance.#ctor(System.Type,StructureMap.Pipeline.ExplicitArguments,StructureMap.Pipeline.Instance)"]


getChild Method (propertyName, pluginType, buildSession)

getChild Method (propertyName, pluginType, buildSession)
Namespaces ► StructureMap.Pipeline ► ExplicitInstance ► getChild(String, Type, BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ExplicitInstance.getChild(System.String,System.Type,StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
protected override Object getChild(
    string propertyName,
    Type pluginType,
    BuildSession buildSession
)
Protected Overrides Function getChild ( _
    propertyName As String, _
    pluginType As Type, _
    buildSession As BuildSession _
) As Object
protected:
virtual Object^ getChild(
    String^ propertyName,
    Type^ pluginType,
    BuildSession^ buildSession
) override
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.ExplicitInstance.getChild(System.String,System.Type,StructureMap.BuildSession)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ExplicitInstance.getChild(System.String,System.Type,StructureMap.BuildSession)"]

buildSession (BuildSession)

[Missing <param name="buildSession"/> documentation for "M:StructureMap.Pipeline.ExplicitInstance.getChild(System.String,System.Type,StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ExplicitInstance.getChild(System.String,System.Type,StructureMap.BuildSession)]


ExpressedInstance(T) Class

ExpressedInstance<(Of <(T>)>) Class
Namespaces ► StructureMap.Pipeline ► ExpressedInstance<(Of <(T>)>)
StructureMap API
Base class for many of the Instance subclasses to support method chaining in the Registry DSL for common options
Declaration Syntax
C# Visual Basic Visual C++
public abstract class ExpressedInstance<T> : Instance

Public MustInherit Class ExpressedInstance(Of T) _
    Inherits Instance
generic<typename T>
public ref class ExpressedInstance abstract : public Instance
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:StructureMap.Pipeline.ExpressedInstance`1"]

Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ExpressedInstance<(Of <(T>)>)()()() | Initializes a new instance of the ExpressedInstance<(Of <(T>)>) class
 | addTemplatedInstanceTo(PluginFamily, array<Type>[]()[]) | (Inherited from Instance.)
 | build(Type, BuildSession) | (Inherited from Instance.)
 | Build(Type, BuildSession) | (Inherited from Instance.)
 | canBePartOfPluginFamily(PluginFamily) | (Inherited from Instance.)
 | doesRecordOnTheStack | (Inherited from Instance.)
 | EnrichWith<(Of <(TYPE>)>)(EnrichmentHandler<(Of <(TYPE>)>)) | Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | findMasterInstance(PluginFamily, String, GraphLog) | (Inherited from Instance.)
 | getConcreteType(Type) | (Inherited from Instance.)
 | getDescription()()() | (Inherited from Instance.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interceptor | (Inherited from Instance.)
 | InterceptWith(InstanceInterceptor) | Register an InstanceInterceptor with this Instance
 | markBuildStackFinish(BuildSession) | (Inherited from Instance.)
 | markBuildStackStart(BuildSession, Type) | (Inherited from Instance.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | (Inherited from Instance.)
 | OnCreation<(Of <(TYPE>)>)(Action<(Of <(TYPE>)>)) | Register an Action to perform on the object created by this Instance before it is returned to the caller
 | preprocess(PluginFamily) | (Inherited from Instance.)
 | replaceNameIfNotAlreadySet(String) | (Inherited from Instance.)
 | thisInstance |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WithName(String) | Set the name of this Instance
Inheritance Hierarchy
Object
 | Instance
 |  | ExpressedInstance<(Of <(T>)>)
 |  |  | ConstructorInstance<(Of <(T>)>)
 |  |  | LiteralInstance
 |  |  | PrototypeInstance
 |  |  | SerializedInstance
 |  |  | UserControlInstance


ExpressedInstance(T) Constructor

ExpressedInstance<(Of <(T>)>) Constructor
Namespaces ► StructureMap.Pipeline ► ExpressedInstance<(Of <(T>)>) ► ExpressedInstance<(Of <(T>)>)()()()
StructureMap API
Initializes a new instance of the ExpressedInstance<(Of <(T>)>) class
Declaration Syntax
C# Visual Basic Visual C++
protected ExpressedInstance()
Protected Sub New
protected:
ExpressedInstance()


EnrichWith Method (handler)

EnrichWith<(Of <(TYPE>)>) Method (handler)
Namespaces ► StructureMap.Pipeline ► ExpressedInstance<(Of <(T>)>) ► EnrichWith<(Of <(TYPE>)>)(EnrichmentHandler<(Of <(TYPE>)>))
StructureMap API
Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller
Declaration Syntax
C# Visual Basic Visual C++
public T EnrichWith<TYPE>(
    EnrichmentHandler<TYPE> handler
)

Public Function EnrichWith(Of TYPE) ( _
    handler As EnrichmentHandler(Of TYPE) _
) As T
public:
generic<typename TYPE>
T EnrichWith(
    EnrichmentHandler<TYPE>^ handler
)
Generic Template Parameters
TYPE

[Missing <typeparam name="TYPE"/> documentation for "M:StructureMap.Pipeline.ExpressedInstance`1.EnrichWith``1(StructureMap.Interceptors.EnrichmentHandler{``0})"]

Parameters
handler (EnrichmentHandler <(Of <(TYPE>)>))

[Missing <param name="handler"/> documentation for "M:StructureMap.Pipeline.ExpressedInstance`1.EnrichWith``1(StructureMap.Interceptors.EnrichmentHandler{``0})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ExpressedInstance`1.EnrichWith``1(StructureMap.Interceptors.EnrichmentHandler{``0})]


InterceptWith Method (interceptor)

InterceptWith Method (interceptor)
Namespaces ► StructureMap.Pipeline ► ExpressedInstance<(Of <(T>)>) ► InterceptWith(InstanceInterceptor)
StructureMap API
Register an InstanceInterceptor with this Instance
Declaration Syntax
C# Visual Basic Visual C++
public T InterceptWith(
    InstanceInterceptor interceptor
)
Public Function InterceptWith ( _
    interceptor As InstanceInterceptor _
) As T
public:
T InterceptWith(
    InstanceInterceptor^ interceptor
)
Parameters
interceptor (InstanceInterceptor)

[Missing <param name="interceptor"/> documentation for "M:StructureMap.Pipeline.ExpressedInstance`1.InterceptWith(StructureMap.Interceptors.InstanceInterceptor)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ExpressedInstance`1.InterceptWith(StructureMap.Interceptors.InstanceInterceptor)]


OnCreation Method (handler)

OnCreation<(Of <(TYPE>)>) Method (handler)
Namespaces ► StructureMap.Pipeline ► ExpressedInstance<(Of <(T>)>) ► OnCreation<(Of <(TYPE>)>)(Action<(Of <(TYPE>)>))
StructureMap API
Register an Action to perform on the object created by this Instance before it is returned to the caller
Declaration Syntax
C# Visual Basic Visual C++
public T OnCreation<TYPE>(
    Action<TYPE> handler
)

Public Function OnCreation(Of TYPE) ( _
    handler As Action(Of TYPE) _
) As T
public:
generic<typename TYPE>
T OnCreation(
    Action<TYPE>^ handler
)
Generic Template Parameters
TYPE

[Missing <typeparam name="TYPE"/> documentation for "M:StructureMap.Pipeline.ExpressedInstance`1.OnCreation``1(System.Action{``0})"]

Parameters
handler (Action <(Of <(TYPE>)>))

[Missing <param name="handler"/> documentation for "M:StructureMap.Pipeline.ExpressedInstance`1.OnCreation``1(System.Action{``0})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ExpressedInstance`1.OnCreation``1(System.Action{``0})]


thisInstance Property

thisInstance Property
Namespaces ► StructureMap.Pipeline ► ExpressedInstance<(Of <(T>)>) ► thisInstance
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.ExpressedInstance`1.thisInstance]

Declaration Syntax
C# Visual Basic Visual C++
protected abstract T thisInstance { get; }
Protected MustOverride ReadOnly Property thisInstance As T
protected:
virtual property T thisInstance {
    T get () abstract;
}


WithName Method (instanceKey)

WithName Method (instanceKey)
Namespaces ► StructureMap.Pipeline ► ExpressedInstance<(Of <(T>)>) ► WithName(String)
StructureMap API
Set the name of this Instance
Declaration Syntax
C# Visual Basic Visual C++
public T WithName(
    string instanceKey
)
Public Function WithName ( _
    instanceKey As String _
) As T
public:
T WithName(
    String^ instanceKey
)
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.ExpressedInstance`1.WithName(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ExpressedInstance`1.WithName(System.String)]


HttpContextBuildPolicy Class

HttpContextBuildPolicy Class
Namespaces ► StructureMap.Pipeline ► HttpContextBuildPolicy
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.HttpContextBuildPolicy]

Declaration Syntax
C# Visual Basic Visual C++
public class HttpContextBuildPolicy : CacheInterceptor
Public Class HttpContextBuildPolicy _
    Inherits CacheInterceptor
public ref class HttpContextBuildPolicy : public CacheInterceptor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HttpContextBuildPolicy()()() | Initializes a new instance of the HttpContextBuildPolicy class
 | Build(BuildSession, Type, Instance) | (Inherited from CacheInterceptor.)
 | clone()()() | (Overrides CacheInterceptor.clone()()().)
 | Clone()()() | (Inherited from CacheInterceptor.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | HasContext()()() |
 | InnerPolicy | (Inherited from CacheInterceptor.)
 | isCached(String, Type) | (Overrides CacheInterceptor.isCached(String, Type).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | retrieveFromCache(String, Type) | (Overrides CacheInterceptor.retrieveFromCache(String, Type).)
 | storeInCache(String, Type, Object) | (Overrides CacheInterceptor.storeInCache(String, Type, Object).)
 | ToString()()() | (Inherited from CacheInterceptor.)
Inheritance Hierarchy
Object
 | CacheInterceptor
 |  | HttpContextBuildPolicy


HttpContextBuildPolicy Constructor

HttpContextBuildPolicy Constructor
Namespaces ► StructureMap.Pipeline ► HttpContextBuildPolicy ► HttpContextBuildPolicy()()()
StructureMap API
Initializes a new instance of the HttpContextBuildPolicy class
Declaration Syntax
C# Visual Basic Visual C++
public HttpContextBuildPolicy()
Public Sub New
public:
HttpContextBuildPolicy()


clone Method

clone Method
Namespaces ► StructureMap.Pipeline ► HttpContextBuildPolicy ► clone()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.HttpContextBuildPolicy.clone]

Declaration Syntax
C# Visual Basic Visual C++
protected override CacheInterceptor clone()
Protected Overrides Function clone As CacheInterceptor
protected:
virtual CacheInterceptor^ clone() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.HttpContextBuildPolicy.clone]


HasContext Method

HasContext Method
Namespaces ► StructureMap.Pipeline ► HttpContextBuildPolicy ► HasContext()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.HttpContextBuildPolicy.HasContext]

Declaration Syntax
C# Visual Basic Visual C++
public static bool HasContext()
Public Shared Function HasContext As Boolean
public:
static bool HasContext()
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.HttpContextBuildPolicy.HasContext]


isCached Method (instanceKey, pluginType)

isCached Method (instanceKey, pluginType)
Namespaces ► StructureMap.Pipeline ► HttpContextBuildPolicy ► isCached(String, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.HttpContextBuildPolicy.isCached(System.String,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool isCached(
    string instanceKey,
    Type pluginType
)
Protected Overrides Function isCached ( _
    instanceKey As String, _
    pluginType As Type _
) As Boolean
protected:
virtual bool isCached(
    String^ instanceKey,
    Type^ pluginType
) override
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.HttpContextBuildPolicy.isCached(System.String,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.HttpContextBuildPolicy.isCached(System.String,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.HttpContextBuildPolicy.isCached(System.String,System.Type)]


retrieveFromCache Method (instanceKey, pluginType)

retrieveFromCache Method (instanceKey, pluginType)
Namespaces ► StructureMap.Pipeline ► HttpContextBuildPolicy ► retrieveFromCache(String, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.HttpContextBuildPolicy.retrieveFromCache(System.String,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected override Object retrieveFromCache(
    string instanceKey,
    Type pluginType
)
Protected Overrides Function retrieveFromCache ( _
    instanceKey As String, _
    pluginType As Type _
) As Object
protected:
virtual Object^ retrieveFromCache(
    String^ instanceKey,
    Type^ pluginType
) override
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.HttpContextBuildPolicy.retrieveFromCache(System.String,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.HttpContextBuildPolicy.retrieveFromCache(System.String,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.HttpContextBuildPolicy.retrieveFromCache(System.String,System.Type)]


storeInCache Method (instanceKey, pluginType, instance)

storeInCache Method (instanceKey, pluginType, instance)
Namespaces ► StructureMap.Pipeline ► HttpContextBuildPolicy ► storeInCache(String, Type, Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.HttpContextBuildPolicy.storeInCache(System.String,System.Type,System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void storeInCache(
    string instanceKey,
    Type pluginType,
    Object instance
)
Protected Overrides Sub storeInCache ( _
    instanceKey As String, _
    pluginType As Type, _
    instance As Object _
)
protected:
virtual void storeInCache(
    String^ instanceKey,
    Type^ pluginType,
    Object^ instance
) override
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.HttpContextBuildPolicy.storeInCache(System.String,System.Type,System.Object)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.HttpContextBuildPolicy.storeInCache(System.String,System.Type,System.Object)"]

instance (Object)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.HttpContextBuildPolicy.storeInCache(System.String,System.Type,System.Object)"]


HybridBuildPolicy Class

HybridBuildPolicy Class
Namespaces ► StructureMap.Pipeline ► HybridBuildPolicy
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.HybridBuildPolicy]

Declaration Syntax
C# Visual Basic Visual C++
public class HybridBuildPolicy : IBuildInterceptor,
    IBuildPolicy
Public Class HybridBuildPolicy _
    Implements IBuildInterceptor, IBuildPolicy
public ref class HybridBuildPolicy : IBuildInterceptor,
    IBuildPolicy
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | HybridBuildPolicy()()() | Initializes a new instance of the HybridBuildPolicy class
 | Build(BuildSession, Type, Instance) |
 | Clone()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerPolicy |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
HybridBuildPolicy


HybridBuildPolicy Constructor

HybridBuildPolicy Constructor
Namespaces ► StructureMap.Pipeline ► HybridBuildPolicy ► HybridBuildPolicy()()()
StructureMap API
Initializes a new instance of the HybridBuildPolicy class
Declaration Syntax
C# Visual Basic Visual C++
public HybridBuildPolicy()
Public Sub New
public:
HybridBuildPolicy()


Build Method (buildSession, pluginType, instance)

Build Method (buildSession, pluginType, instance)
Namespaces ► StructureMap.Pipeline ► HybridBuildPolicy ► Build(BuildSession, Type, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.HybridBuildPolicy.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public Object Build(
    BuildSession buildSession,
    Type pluginType,
    Instance instance
)
Public Function Build ( _
    buildSession As BuildSession, _
    pluginType As Type, _
    instance As Instance _
) As Object
public:
virtual Object^ Build(
    BuildSession^ buildSession,
    Type^ pluginType,
    Instance^ instance
) sealed
Parameters
buildSession (BuildSession)

[Missing <param name="buildSession"/> documentation for "M:StructureMap.Pipeline.HybridBuildPolicy.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.HybridBuildPolicy.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.HybridBuildPolicy.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.HybridBuildPolicy.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)]


Clone Method

Clone Method
Namespaces ► StructureMap.Pipeline ► HybridBuildPolicy ► Clone()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.HybridBuildPolicy.Clone]

Declaration Syntax
C# Visual Basic Visual C++
public IBuildPolicy Clone()
Public Function Clone As IBuildPolicy
public:
virtual IBuildPolicy^ Clone() sealed
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.HybridBuildPolicy.Clone]


InnerPolicy Property

InnerPolicy Property
Namespaces ► StructureMap.Pipeline ► HybridBuildPolicy ► InnerPolicy
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.HybridBuildPolicy.InnerPolicy]

Declaration Syntax
C# Visual Basic Visual C++
public IBuildPolicy InnerPolicy { get; set; }
Public Property InnerPolicy As IBuildPolicy
public:
virtual property IBuildPolicy^ InnerPolicy {
    IBuildPolicy^ get () sealed;
    void set (IBuildPolicy^ value) sealed;
}


IBuildInterceptor Interface

IBuildInterceptor Interface
Namespaces ► StructureMap.Pipeline ► IBuildInterceptor
StructureMap API
Plugin interface to create custom build or lifecycle policies for a Plugin Type
Declaration Syntax
C# Visual Basic Visual C++
public interface IBuildInterceptor : IBuildPolicy
Public Interface IBuildInterceptor _
    Implements IBuildPolicy
public interface class IBuildInterceptor : IBuildPolicy
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Build(BuildSession, Type, Instance) | (Inherited from IBuildPolicy.)
 | Clone()()() | (Inherited from IBuildPolicy.)
 | InnerPolicy |


InnerPolicy Property

InnerPolicy Property
Namespaces ► StructureMap.Pipeline ► IBuildInterceptor ► InnerPolicy
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.IBuildInterceptor.InnerPolicy]

Declaration Syntax
C# Visual Basic Visual C++
IBuildPolicy InnerPolicy { get; set; }
Property InnerPolicy As IBuildPolicy
property IBuildPolicy^ InnerPolicy {
    IBuildPolicy^ get ();
    void set (IBuildPolicy^ value);
}


IBuildPolicy Interface

IBuildPolicy Interface
Namespaces ► StructureMap.Pipeline ► IBuildPolicy
StructureMap API
An object that specifies a "Policy" about how Instance's are invoked.
Declaration Syntax
C# Visual Basic Visual C++
public interface IBuildPolicy
Public Interface IBuildPolicy
public interface class IBuildPolicy
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Build(BuildSession, Type, Instance) |
 | Clone()()() |


Build Method (buildSession, pluginType, instance)

Build Method (buildSession, pluginType, instance)
Namespaces ► StructureMap.Pipeline ► IBuildPolicy ► Build(BuildSession, Type, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IBuildPolicy.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
Object Build(
    BuildSession buildSession,
    Type pluginType,
    Instance instance
)
Function Build ( _
    buildSession As BuildSession, _
    pluginType As Type, _
    instance As Instance _
) As Object
Object^ Build(
    BuildSession^ buildSession,
    Type^ pluginType,
    Instance^ instance
)
Parameters
buildSession (BuildSession)

[Missing <param name="buildSession"/> documentation for "M:StructureMap.Pipeline.IBuildPolicy.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.IBuildPolicy.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.IBuildPolicy.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.IBuildPolicy.Build(StructureMap.BuildSession,System.Type,StructureMap.Pipeline.Instance)]


Clone Method

Clone Method
Namespaces ► StructureMap.Pipeline ► IBuildPolicy ► Clone()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IBuildPolicy.Clone]

Declaration Syntax
C# Visual Basic Visual C++
IBuildPolicy Clone()
Function Clone As IBuildPolicy
IBuildPolicy^ Clone()
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.IBuildPolicy.Clone]


IConfiguredInstance Interface

IConfiguredInstance Interface
Namespaces ► StructureMap.Pipeline ► IConfiguredInstance
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.IConfiguredInstance]

Declaration Syntax
C# Visual Basic Visual C++
public interface IConfiguredInstance
Public Interface IConfiguredInstance
public interface class IConfiguredInstance
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Build(Type, BuildSession, InstanceBuilder) |
 | GetChild(String, Type, BuildSession) |
 | GetChildrenArray(String) |
 | GetProperty(String) |
 | HasProperty(String) |
 | Name |
 | PluggedType |
 | SetChild(String, Instance) |
 | SetChildArray(String, Type, array<Instance>[]()[]) |
 | SetProperty(String, String) |


Build Method (pluginType, session, builder)

Build Method (pluginType, session, builder)
Namespaces ► StructureMap.Pipeline ► IConfiguredInstance ► Build(Type, BuildSession, InstanceBuilder)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IConfiguredInstance.Build(System.Type,StructureMap.BuildSession,StructureMap.InstanceBuilder)]

Declaration Syntax
C# Visual Basic Visual C++
Object Build(
    Type pluginType,
    BuildSession session,
    InstanceBuilder builder
)
Function Build ( _
    pluginType As Type, _
    session As BuildSession, _
    builder As InstanceBuilder _
) As Object
Object^ Build(
    Type^ pluginType,
    BuildSession^ session,
    InstanceBuilder^ builder
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.Build(System.Type,StructureMap.BuildSession,StructureMap.InstanceBuilder)"]

session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.Build(System.Type,StructureMap.BuildSession,StructureMap.InstanceBuilder)"]

builder (InstanceBuilder)

[Missing <param name="builder"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.Build(System.Type,StructureMap.BuildSession,StructureMap.InstanceBuilder)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.IConfiguredInstance.Build(System.Type,StructureMap.BuildSession,StructureMap.InstanceBuilder)]


GetChild Method (propertyName, pluginType, buildSession)

GetChild Method (propertyName, pluginType, buildSession)
Namespaces ► StructureMap.Pipeline ► IConfiguredInstance ► GetChild(String, Type, BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IConfiguredInstance.GetChild(System.String,System.Type,StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
Object GetChild(
    string propertyName,
    Type pluginType,
    BuildSession buildSession
)
Function GetChild ( _
    propertyName As String, _
    pluginType As Type, _
    buildSession As BuildSession _
) As Object
Object^ GetChild(
    String^ propertyName,
    Type^ pluginType,
    BuildSession^ buildSession
)
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.GetChild(System.String,System.Type,StructureMap.BuildSession)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.GetChild(System.String,System.Type,StructureMap.BuildSession)"]

buildSession (BuildSession)

[Missing <param name="buildSession"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.GetChild(System.String,System.Type,StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.IConfiguredInstance.GetChild(System.String,System.Type,StructureMap.BuildSession)]


GetChildrenArray Method (propertyName)

GetChildrenArray Method (propertyName)
Namespaces ► StructureMap.Pipeline ► IConfiguredInstance ► GetChildrenArray(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IConfiguredInstance.GetChildrenArray(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
Instance[] GetChildrenArray(
    string propertyName
)
Function GetChildrenArray ( _
    propertyName As String _
) As Instance()
array<Instance^>^ GetChildrenArray(
    String^ propertyName
)
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.GetChildrenArray(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.IConfiguredInstance.GetChildrenArray(System.String)]


GetProperty Method (propertyName)

GetProperty Method (propertyName)
Namespaces ► StructureMap.Pipeline ► IConfiguredInstance ► GetProperty(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IConfiguredInstance.GetProperty(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
string GetProperty(
    string propertyName
)
Function GetProperty ( _
    propertyName As String _
) As String
String^ GetProperty(
    String^ propertyName
)
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.GetProperty(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.IConfiguredInstance.GetProperty(System.String)]


HasProperty Method (propertyName)

HasProperty Method (propertyName)
Namespaces ► StructureMap.Pipeline ► IConfiguredInstance ► HasProperty(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IConfiguredInstance.HasProperty(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
bool HasProperty(
    string propertyName
)
Function HasProperty ( _
    propertyName As String _
) As Boolean
bool HasProperty(
    String^ propertyName
)
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.HasProperty(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.IConfiguredInstance.HasProperty(System.String)]


Name Property

Name Property
Namespaces ► StructureMap.Pipeline ► IConfiguredInstance ► Name
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.IConfiguredInstance.Name]

Declaration Syntax
C# Visual Basic Visual C++
string Name { get; }
ReadOnly Property Name As String
property String^ Name {
    String^ get ();
}


PluggedType Property

PluggedType Property
Namespaces ► StructureMap.Pipeline ► IConfiguredInstance ► PluggedType
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.IConfiguredInstance.PluggedType]

Declaration Syntax
C# Visual Basic Visual C++
Type PluggedType { get; }
ReadOnly Property PluggedType As Type
property Type^ PluggedType {
    Type^ get ();
}


SetChild Method (name, instance)

SetChild Method (name, instance)
Namespaces ► StructureMap.Pipeline ► IConfiguredInstance ► SetChild(String, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IConfiguredInstance.SetChild(System.String,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
void SetChild(
    string name,
    Instance instance
)
Sub SetChild ( _
    name As String, _
    instance As Instance _
)
void SetChild(
    String^ name,
    Instance^ instance
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.SetChild(System.String,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.SetChild(System.String,StructureMap.Pipeline.Instance)"]


SetChildArray Method (name, type, children)

SetChildArray Method (name, type, children)
Namespaces ► StructureMap.Pipeline ► IConfiguredInstance ► SetChildArray(String, Type, array<Instance>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IConfiguredInstance.SetChildArray(System.String,System.Type,StructureMap.Pipeline.Instance[])]

Declaration Syntax
C# Visual Basic Visual C++
void SetChildArray(
    string name,
    Type type,
    Instance[] children
)
Sub SetChildArray ( _
    name As String, _
    type As Type, _
    children As Instance() _
)
void SetChildArray(
    String^ name,
    Type^ type,
    array<Instance^>^ children
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.SetChildArray(System.String,System.Type,StructureMap.Pipeline.Instance[])"]

type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.SetChildArray(System.String,System.Type,StructureMap.Pipeline.Instance[])"]

children (array< Instance >[]()[])

[Missing <param name="children"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.SetChildArray(System.String,System.Type,StructureMap.Pipeline.Instance[])"]


SetProperty Method (name, value)

SetProperty Method (name, value)
Namespaces ► StructureMap.Pipeline ► IConfiguredInstance ► SetProperty(String, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IConfiguredInstance.SetProperty(System.String,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
void SetProperty(
    string name,
    string value
)
Sub SetProperty ( _
    name As String, _
    value As String _
)
void SetProperty(
    String^ name,
    String^ value
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.SetProperty(System.String,System.String)"]

value (String)

[Missing <param name="value"/> documentation for "M:StructureMap.Pipeline.IConfiguredInstance.SetProperty(System.String,System.String)"]


IDiagnosticInstance Interface

IDiagnosticInstance Interface
Namespaces ► StructureMap.Pipeline ► IDiagnosticInstance
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.IDiagnosticInstance]

Declaration Syntax
C# Visual Basic Visual C++
public interface IDiagnosticInstance : IInstance
Public Interface IDiagnosticInstance _
    Implements IInstance
public interface class IDiagnosticInstance : IInstance
Members
All Members | Methods | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | AddTemplatedInstanceTo(PluginFamily, array<Type>[]()[]) |
 | CanBePartOfPluginFamily(PluginFamily) |
 | ConcreteType | The actual concrete type of this Instance. Not every type of IInstance can determine the ConcreteType (Inherited from IInstance.)
 | CreateToken()()() |
 | Description | (Inherited from IInstance.)
 | FindInstanceForProfile(PluginFamily, String, GraphLog) |
 | Name | (Inherited from IInstance.)
 | Preprocess(PluginFamily) |


AddTemplatedInstanceTo Method (family, templateTypes)

AddTemplatedInstanceTo Method (family, templateTypes)
Namespaces ► StructureMap.Pipeline ► IDiagnosticInstance ► AddTemplatedInstanceTo(PluginFamily, array<Type>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IDiagnosticInstance.AddTemplatedInstanceTo(StructureMap.Graph.PluginFamily,System.Type[])]

Declaration Syntax
C# Visual Basic Visual C++
void AddTemplatedInstanceTo(
    PluginFamily family,
    Type[] templateTypes
)
Sub AddTemplatedInstanceTo ( _
    family As PluginFamily, _
    templateTypes As Type() _
)
void AddTemplatedInstanceTo(
    PluginFamily^ family,
    array<Type^>^ templateTypes
)
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.IDiagnosticInstance.AddTemplatedInstanceTo(StructureMap.Graph.PluginFamily,System.Type[])"]

templateTypes (array< Type >[]()[])

[Missing <param name="templateTypes"/> documentation for "M:StructureMap.Pipeline.IDiagnosticInstance.AddTemplatedInstanceTo(StructureMap.Graph.PluginFamily,System.Type[])"]


CanBePartOfPluginFamily Method (family)

CanBePartOfPluginFamily Method (family)
Namespaces ► StructureMap.Pipeline ► IDiagnosticInstance ► CanBePartOfPluginFamily(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IDiagnosticInstance.CanBePartOfPluginFamily(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
bool CanBePartOfPluginFamily(
    PluginFamily family
)
Function CanBePartOfPluginFamily ( _
    family As PluginFamily _
) As Boolean
bool CanBePartOfPluginFamily(
    PluginFamily^ family
)
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.IDiagnosticInstance.CanBePartOfPluginFamily(StructureMap.Graph.PluginFamily)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.IDiagnosticInstance.CanBePartOfPluginFamily(StructureMap.Graph.PluginFamily)]


CreateToken Method

CreateToken Method
Namespaces ► StructureMap.Pipeline ► IDiagnosticInstance ► CreateToken()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IDiagnosticInstance.CreateToken]

Declaration Syntax
C# Visual Basic Visual C++
InstanceToken CreateToken()
Function CreateToken As InstanceToken
InstanceToken^ CreateToken()
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.IDiagnosticInstance.CreateToken]


FindInstanceForProfile Method (family, profileName, log)

FindInstanceForProfile Method (family, profileName, log)
Namespaces ► StructureMap.Pipeline ► IDiagnosticInstance ► FindInstanceForProfile(PluginFamily, String, GraphLog)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IDiagnosticInstance.FindInstanceForProfile(StructureMap.Graph.PluginFamily,System.String,StructureMap.Diagnostics.GraphLog)]

Declaration Syntax
C# Visual Basic Visual C++
Instance FindInstanceForProfile(
    PluginFamily family,
    string profileName,
    GraphLog log
)
Function FindInstanceForProfile ( _
    family As PluginFamily, _
    profileName As String, _
    log As GraphLog _
) As Instance
Instance^ FindInstanceForProfile(
    PluginFamily^ family,
    String^ profileName,
    GraphLog^ log
)
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.IDiagnosticInstance.FindInstanceForProfile(StructureMap.Graph.PluginFamily,System.String,StructureMap.Diagnostics.GraphLog)"]

profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Pipeline.IDiagnosticInstance.FindInstanceForProfile(StructureMap.Graph.PluginFamily,System.String,StructureMap.Diagnostics.GraphLog)"]

log (GraphLog)

[Missing <param name="log"/> documentation for "M:StructureMap.Pipeline.IDiagnosticInstance.FindInstanceForProfile(StructureMap.Graph.PluginFamily,System.String,StructureMap.Diagnostics.GraphLog)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.IDiagnosticInstance.FindInstanceForProfile(StructureMap.Graph.PluginFamily,System.String,StructureMap.Diagnostics.GraphLog)]


Preprocess Method (family)

Preprocess Method (family)
Namespaces ► StructureMap.Pipeline ► IDiagnosticInstance ► Preprocess(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IDiagnosticInstance.Preprocess(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
void Preprocess(
    PluginFamily family
)
Sub Preprocess ( _
    family As PluginFamily _
)
void Preprocess(
    PluginFamily^ family
)
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.IDiagnosticInstance.Preprocess(StructureMap.Graph.PluginFamily)"]


IInstance Interface

IInstance Interface
Namespaces ► StructureMap.Pipeline ► IInstance
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.IInstance]

Declaration Syntax
C# Visual Basic Visual C++
public interface IInstance
Public Interface IInstance
public interface class IInstance
Members
All Members | Properties
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | ConcreteType | The actual concrete type of this Instance. Not every type of IInstance can determine the ConcreteType
 | Description |
 | Name |


ConcreteType Property

ConcreteType Property
Namespaces ► StructureMap.Pipeline ► IInstance ► ConcreteType
StructureMap API
The actual concrete type of this Instance. Not every type of IInstance can determine the ConcreteType
Declaration Syntax
C# Visual Basic Visual C++
Type ConcreteType { get; }
ReadOnly Property ConcreteType As Type
property Type^ ConcreteType {
    Type^ get ();
}


Description Property

Description Property
Namespaces ► StructureMap.Pipeline ► IInstance ► Description
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.IInstance.Description]

Declaration Syntax
C# Visual Basic Visual C++
string Description { get; }
ReadOnly Property Description As String
property String^ Description {
    String^ get ();
}


Name Property

Name Property
Namespaces ► StructureMap.Pipeline ► IInstance ► Name
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.IInstance.Name]

Declaration Syntax
C# Visual Basic Visual C++
string Name { get; }
ReadOnly Property Name As String
property String^ Name {
    String^ get ();
}


ILocationPolicy Interface

ILocationPolicy Interface
Namespaces ► StructureMap.Pipeline ► ILocationPolicy
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.ILocationPolicy]

Declaration Syntax
C# Visual Basic Visual C++
public interface ILocationPolicy
Public Interface ILocationPolicy
public interface class ILocationPolicy
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Build(BuildSession, Instance) |


Build Method (session, instance)

Build Method (session, instance)
Namespaces ► StructureMap.Pipeline ► ILocationPolicy ► Build(BuildSession, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ILocationPolicy.Build(StructureMap.BuildSession,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
Object Build(
    BuildSession session,
    Instance instance
)
Function Build ( _
    session As BuildSession, _
    instance As Instance _
) As Object
Object^ Build(
    BuildSession^ session,
    Instance^ instance
)
Parameters
session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.ILocationPolicy.Build(StructureMap.BuildSession,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.ILocationPolicy.Build(StructureMap.BuildSession,StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ILocationPolicy.Build(StructureMap.BuildSession,StructureMap.Pipeline.Instance)]


Instance Class

Instance Class
Namespaces ► StructureMap.Pipeline ► Instance
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.Instance]

Declaration Syntax
C# Visual Basic Visual C++
public abstract class Instance : IDiagnosticInstance,
    IInstance
Public MustInherit Class Instance _
    Implements IDiagnosticInstance, IInstance
public ref class Instance abstract : IDiagnosticInstance,
    IInstance
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Instance()()() | Initializes a new instance of the Instance class
 | addTemplatedInstanceTo(PluginFamily, array<Type>[]()[]) |
 | build(Type, BuildSession) |
 | Build(Type, BuildSession) |
 | canBePartOfPluginFamily(PluginFamily) |
 | doesRecordOnTheStack |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | findMasterInstance(PluginFamily, String, GraphLog) |
 | getConcreteType(Type) |
 | getDescription()()() |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interceptor |
 | markBuildStackFinish(BuildSession) |
 | markBuildStackStart(BuildSession, Type) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name |
 | preprocess(PluginFamily) |
 | replaceNameIfNotAlreadySet(String) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Instance
 |  | ConfiguredInstanceBase<(Of <(T>)>)
 |  | DefaultInstance
 |  | ExpressedInstance<(Of <(T>)>)
 |  | ReferencedInstance


Instance Constructor

Instance Constructor
Namespaces ► StructureMap.Pipeline ► Instance ► Instance()()()
StructureMap API
Initializes a new instance of the Instance class
Declaration Syntax
C# Visual Basic Visual C++
protected Instance()
Protected Sub New
protected:
Instance()


addTemplatedInstanceTo Method (family, templateTypes)

addTemplatedInstanceTo Method (family, templateTypes)
Namespaces ► StructureMap.Pipeline ► Instance ► addTemplatedInstanceTo(PluginFamily, array<Type>[]()[])
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Instance.addTemplatedInstanceTo(StructureMap.Graph.PluginFamily,System.Type[])]

Declaration Syntax
C# Visual Basic Visual C++
protected virtual void addTemplatedInstanceTo(
    PluginFamily family,
    Type[] templateTypes
)
Protected Overridable Sub addTemplatedInstanceTo ( _
    family As PluginFamily, _
    templateTypes As Type() _
)
protected:
virtual void addTemplatedInstanceTo(
    PluginFamily^ family,
    array<Type^>^ templateTypes
)
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.Instance.addTemplatedInstanceTo(StructureMap.Graph.PluginFamily,System.Type[])"]

templateTypes (array< Type >[]()[])

[Missing <param name="templateTypes"/> documentation for "M:StructureMap.Pipeline.Instance.addTemplatedInstanceTo(StructureMap.Graph.PluginFamily,System.Type[])"]


build Method (pluginType, session)

build Method (pluginType, session)
Namespaces ► StructureMap.Pipeline ► Instance ► build(Type, BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Instance.build(System.Type,StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
protected abstract Object build(
    Type pluginType,
    BuildSession session
)
Protected MustOverride Function build ( _
    pluginType As Type, _
    session As BuildSession _
) As Object
protected:
virtual Object^ build(
    Type^ pluginType,
    BuildSession^ session
) abstract
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.Instance.build(System.Type,StructureMap.BuildSession)"]

session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.Instance.build(System.Type,StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.Instance.build(System.Type,StructureMap.BuildSession)]


Build Method (pluginType, session)

Build Method (pluginType, session)
Namespaces ► StructureMap.Pipeline ► Instance ► Build(Type, BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Instance.Build(System.Type,StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
public virtual Object Build(
    Type pluginType,
    BuildSession session
)
Public Overridable Function Build ( _
    pluginType As Type, _
    session As BuildSession _
) As Object
public:
virtual Object^ Build(
    Type^ pluginType,
    BuildSession^ session
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.Instance.Build(System.Type,StructureMap.BuildSession)"]

session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.Instance.Build(System.Type,StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.Instance.Build(System.Type,StructureMap.BuildSession)]


canBePartOfPluginFamily Method (family)

canBePartOfPluginFamily Method (family)
Namespaces ► StructureMap.Pipeline ► Instance ► canBePartOfPluginFamily(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Instance.canBePartOfPluginFamily(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool canBePartOfPluginFamily(
    PluginFamily family
)
Protected Overridable Function canBePartOfPluginFamily ( _
    family As PluginFamily _
) As Boolean
protected:
virtual bool canBePartOfPluginFamily(
    PluginFamily^ family
)
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.Instance.canBePartOfPluginFamily(StructureMap.Graph.PluginFamily)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.Instance.canBePartOfPluginFamily(StructureMap.Graph.PluginFamily)]


doesRecordOnTheStack Property

doesRecordOnTheStack Property
Namespaces ► StructureMap.Pipeline ► Instance ► doesRecordOnTheStack
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.Instance.doesRecordOnTheStack]

Declaration Syntax
C# Visual Basic Visual C++
protected virtual bool doesRecordOnTheStack { get; }
Protected Overridable ReadOnly Property doesRecordOnTheStack As Boolean
protected:
virtual property bool doesRecordOnTheStack {
    bool get ();
}


findMasterInstance Method (family, profileName, log)

findMasterInstance Method (family, profileName, log)
Namespaces ► StructureMap.Pipeline ► Instance ► findMasterInstance(PluginFamily, String, GraphLog)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Instance.findMasterInstance(StructureMap.Graph.PluginFamily,System.String,StructureMap.Diagnostics.GraphLog)]

Declaration Syntax
C# Visual Basic Visual C++
protected virtual Instance findMasterInstance(
    PluginFamily family,
    string profileName,
    GraphLog log
)
Protected Overridable Function findMasterInstance ( _
    family As PluginFamily, _
    profileName As String, _
    log As GraphLog _
) As Instance
protected:
virtual Instance^ findMasterInstance(
    PluginFamily^ family,
    String^ profileName,
    GraphLog^ log
)
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.Instance.findMasterInstance(StructureMap.Graph.PluginFamily,System.String,StructureMap.Diagnostics.GraphLog)"]

profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Pipeline.Instance.findMasterInstance(StructureMap.Graph.PluginFamily,System.String,StructureMap.Diagnostics.GraphLog)"]

log (GraphLog)

[Missing <param name="log"/> documentation for "M:StructureMap.Pipeline.Instance.findMasterInstance(StructureMap.Graph.PluginFamily,System.String,StructureMap.Diagnostics.GraphLog)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.Instance.findMasterInstance(StructureMap.Graph.PluginFamily,System.String,StructureMap.Diagnostics.GraphLog)]


getConcreteType Method (pluginType)

getConcreteType Method (pluginType)
Namespaces ► StructureMap.Pipeline ► Instance ► getConcreteType(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Instance.getConcreteType(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected virtual Type getConcreteType(
    Type pluginType
)
Protected Overridable Function getConcreteType ( _
    pluginType As Type _
) As Type
protected:
virtual Type^ getConcreteType(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.Instance.getConcreteType(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.Instance.getConcreteType(System.Type)]


getDescription Method

getDescription Method
Namespaces ► StructureMap.Pipeline ► Instance ► getDescription()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Instance.getDescription]

Declaration Syntax
C# Visual Basic Visual C++
protected abstract string getDescription()
Protected MustOverride Function getDescription As String
protected:
virtual String^ getDescription() abstract
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.Instance.getDescription]


Interceptor Property

Interceptor Property
Namespaces ► StructureMap.Pipeline ► Instance ► Interceptor
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.Instance.Interceptor]

Declaration Syntax
C# Visual Basic Visual C++
public InstanceInterceptor Interceptor { get; set; }
Public Property Interceptor As InstanceInterceptor
public:
property InstanceInterceptor^ Interceptor {
    InstanceInterceptor^ get ();
    void set (InstanceInterceptor^ value);
}


markBuildStackFinish Method (session)

markBuildStackFinish Method (session)
Namespaces ► StructureMap.Pipeline ► Instance ► markBuildStackFinish(BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Instance.markBuildStackFinish(StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
protected virtual void markBuildStackFinish(
    BuildSession session
)
Protected Overridable Sub markBuildStackFinish ( _
    session As BuildSession _
)
protected:
virtual void markBuildStackFinish(
    BuildSession^ session
)
Parameters
session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.Instance.markBuildStackFinish(StructureMap.BuildSession)"]


markBuildStackStart Method (session, pluginType)

markBuildStackStart Method (session, pluginType)
Namespaces ► StructureMap.Pipeline ► Instance ► markBuildStackStart(BuildSession, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Instance.markBuildStackStart(StructureMap.BuildSession,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected virtual void markBuildStackStart(
    BuildSession session,
    Type pluginType
)
Protected Overridable Sub markBuildStackStart ( _
    session As BuildSession, _
    pluginType As Type _
)
protected:
virtual void markBuildStackStart(
    BuildSession^ session,
    Type^ pluginType
)
Parameters
session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.Instance.markBuildStackStart(StructureMap.BuildSession,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.Instance.markBuildStackStart(StructureMap.BuildSession,System.Type)"]


Name Property

Name Property
Namespaces ► StructureMap.Pipeline ► Instance ► Name
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.Instance.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; set; }
Public Property Name As String
public:
virtual property String^ Name {
    String^ get () sealed;
    void set (String^ value) sealed;
}


preprocess Method (family)

preprocess Method (family)
Namespaces ► StructureMap.Pipeline ► Instance ► preprocess(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Instance.preprocess(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
protected virtual void preprocess(
    PluginFamily family
)
Protected Overridable Sub preprocess ( _
    family As PluginFamily _
)
protected:
virtual void preprocess(
    PluginFamily^ family
)
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.Instance.preprocess(StructureMap.Graph.PluginFamily)"]


replaceNameIfNotAlreadySet Method (name)

replaceNameIfNotAlreadySet Method (name)
Namespaces ► StructureMap.Pipeline ► Instance ► replaceNameIfNotAlreadySet(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Instance.replaceNameIfNotAlreadySet(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected void replaceNameIfNotAlreadySet(
    string name
)
Protected Sub replaceNameIfNotAlreadySet ( _
    name As String _
)
protected:
void replaceNameIfNotAlreadySet(
    String^ name
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Pipeline.Instance.replaceNameIfNotAlreadySet(System.String)"]


InstanceMementoPropertyReader Class

InstanceMementoPropertyReader Class
Namespaces ► StructureMap.Pipeline ► InstanceMementoPropertyReader
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.InstanceMementoPropertyReader]

Declaration Syntax
C# Visual Basic Visual C++
public class InstanceMementoPropertyReader : IArgumentVisitor
Public Class InstanceMementoPropertyReader _
    Implements IArgumentVisitor
public ref class InstanceMementoPropertyReader : IArgumentVisitor
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | InstanceMementoPropertyReader(IConfiguredInstance, InstanceMemento, PluginGraph, Type) | Initializes a new instance of the InstanceMementoPropertyReader class
 | ChildArrayParameter(ParameterInfo) |
 | ChildArraySetter(PropertyInfo, Boolean) |
 | ChildParameter(ParameterInfo) |
 | ChildSetter(PropertyInfo, Boolean) |
 | EnumParameter(ParameterInfo) |
 | EnumSetter(PropertyInfo, Boolean) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | PrimitiveParameter(ParameterInfo) |
 | PrimitiveSetter(PropertyInfo, Boolean) |
 | StringParameter(ParameterInfo) |
 | StringSetter(PropertyInfo, Boolean) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
InstanceMementoPropertyReader


InstanceMementoPropertyReader Constructor (instance, memento, pluginGraph, pluginType)

InstanceMementoPropertyReader Constructor (instance, memento, pluginGraph, pluginType)
Namespaces ► StructureMap.Pipeline ► InstanceMementoPropertyReader ► InstanceMementoPropertyReader(IConfiguredInstance, InstanceMemento, PluginGraph, Type)
StructureMap API
Initializes a new instance of the InstanceMementoPropertyReader class
Declaration Syntax
C# Visual Basic Visual C++
public InstanceMementoPropertyReader(
    IConfiguredInstance instance,
    InstanceMemento memento,
    PluginGraph pluginGraph,
    Type pluginType
)
Public Sub New ( _
    instance As IConfiguredInstance, _
    memento As InstanceMemento, _
    pluginGraph As PluginGraph, _
    pluginType As Type _
)
public:
InstanceMementoPropertyReader(
    IConfiguredInstance^ instance,
    InstanceMemento^ memento,
    PluginGraph^ pluginGraph,
    Type^ pluginType
)
Parameters
instance (IConfiguredInstance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.#ctor(StructureMap.Pipeline.IConfiguredInstance,StructureMap.InstanceMemento,StructureMap.Graph.PluginGraph,System.Type)"]

memento (InstanceMemento)

[Missing <param name="memento"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.#ctor(StructureMap.Pipeline.IConfiguredInstance,StructureMap.InstanceMemento,StructureMap.Graph.PluginGraph,System.Type)"]

pluginGraph (PluginGraph)

[Missing <param name="pluginGraph"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.#ctor(StructureMap.Pipeline.IConfiguredInstance,StructureMap.InstanceMemento,StructureMap.Graph.PluginGraph,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.#ctor(StructureMap.Pipeline.IConfiguredInstance,StructureMap.InstanceMemento,StructureMap.Graph.PluginGraph,System.Type)"]


ChildArrayParameter Method (parameter)

ChildArrayParameter Method (parameter)
Namespaces ► StructureMap.Pipeline ► InstanceMementoPropertyReader ► ChildArrayParameter(ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.InstanceMementoPropertyReader.ChildArrayParameter(System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void ChildArrayParameter(
    ParameterInfo parameter
)
Public Sub ChildArrayParameter ( _
    parameter As ParameterInfo _
)
public:
virtual void ChildArrayParameter(
    ParameterInfo^ parameter
) sealed
Parameters
parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.ChildArrayParameter(System.Reflection.ParameterInfo)"]


ChildArraySetter Method (property, isMandatory)

ChildArraySetter Method (property, isMandatory)
Namespaces ► StructureMap.Pipeline ► InstanceMementoPropertyReader ► ChildArraySetter(PropertyInfo, Boolean)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.InstanceMementoPropertyReader.ChildArraySetter(System.Reflection.PropertyInfo,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public void ChildArraySetter(
    PropertyInfo property,
    bool isMandatory
)
Public Sub ChildArraySetter ( _
    property As PropertyInfo, _
    isMandatory As Boolean _
)
public:
virtual void ChildArraySetter(
    PropertyInfo^ property,
    bool isMandatory
) sealed
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.ChildArraySetter(System.Reflection.PropertyInfo,System.Boolean)"]

isMandatory (Boolean)

[Missing <param name="isMandatory"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.ChildArraySetter(System.Reflection.PropertyInfo,System.Boolean)"]


ChildParameter Method (parameter)

ChildParameter Method (parameter)
Namespaces ► StructureMap.Pipeline ► InstanceMementoPropertyReader ► ChildParameter(ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.InstanceMementoPropertyReader.ChildParameter(System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void ChildParameter(
    ParameterInfo parameter
)
Public Sub ChildParameter ( _
    parameter As ParameterInfo _
)
public:
virtual void ChildParameter(
    ParameterInfo^ parameter
) sealed
Parameters
parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.ChildParameter(System.Reflection.ParameterInfo)"]


ChildSetter Method (property, isMandatory)

ChildSetter Method (property, isMandatory)
Namespaces ► StructureMap.Pipeline ► InstanceMementoPropertyReader ► ChildSetter(PropertyInfo, Boolean)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.InstanceMementoPropertyReader.ChildSetter(System.Reflection.PropertyInfo,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public void ChildSetter(
    PropertyInfo property,
    bool isMandatory
)
Public Sub ChildSetter ( _
    property As PropertyInfo, _
    isMandatory As Boolean _
)
public:
virtual void ChildSetter(
    PropertyInfo^ property,
    bool isMandatory
) sealed
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.ChildSetter(System.Reflection.PropertyInfo,System.Boolean)"]

isMandatory (Boolean)

[Missing <param name="isMandatory"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.ChildSetter(System.Reflection.PropertyInfo,System.Boolean)"]


EnumParameter Method (parameter)

EnumParameter Method (parameter)
Namespaces ► StructureMap.Pipeline ► InstanceMementoPropertyReader ► EnumParameter(ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.InstanceMementoPropertyReader.EnumParameter(System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void EnumParameter(
    ParameterInfo parameter
)
Public Sub EnumParameter ( _
    parameter As ParameterInfo _
)
public:
virtual void EnumParameter(
    ParameterInfo^ parameter
) sealed
Parameters
parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.EnumParameter(System.Reflection.ParameterInfo)"]


EnumSetter Method (property, isMandatory)

EnumSetter Method (property, isMandatory)
Namespaces ► StructureMap.Pipeline ► InstanceMementoPropertyReader ► EnumSetter(PropertyInfo, Boolean)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.InstanceMementoPropertyReader.EnumSetter(System.Reflection.PropertyInfo,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public void EnumSetter(
    PropertyInfo property,
    bool isMandatory
)
Public Sub EnumSetter ( _
    property As PropertyInfo, _
    isMandatory As Boolean _
)
public:
virtual void EnumSetter(
    PropertyInfo^ property,
    bool isMandatory
) sealed
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.EnumSetter(System.Reflection.PropertyInfo,System.Boolean)"]

isMandatory (Boolean)

[Missing <param name="isMandatory"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.EnumSetter(System.Reflection.PropertyInfo,System.Boolean)"]


PrimitiveParameter Method (parameter)

PrimitiveParameter Method (parameter)
Namespaces ► StructureMap.Pipeline ► InstanceMementoPropertyReader ► PrimitiveParameter(ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.InstanceMementoPropertyReader.PrimitiveParameter(System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void PrimitiveParameter(
    ParameterInfo parameter
)
Public Sub PrimitiveParameter ( _
    parameter As ParameterInfo _
)
public:
virtual void PrimitiveParameter(
    ParameterInfo^ parameter
) sealed
Parameters
parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.PrimitiveParameter(System.Reflection.ParameterInfo)"]


PrimitiveSetter Method (property, isMandatory)

PrimitiveSetter Method (property, isMandatory)
Namespaces ► StructureMap.Pipeline ► InstanceMementoPropertyReader ► PrimitiveSetter(PropertyInfo, Boolean)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.InstanceMementoPropertyReader.PrimitiveSetter(System.Reflection.PropertyInfo,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public void PrimitiveSetter(
    PropertyInfo property,
    bool isMandatory
)
Public Sub PrimitiveSetter ( _
    property As PropertyInfo, _
    isMandatory As Boolean _
)
public:
virtual void PrimitiveSetter(
    PropertyInfo^ property,
    bool isMandatory
) sealed
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.PrimitiveSetter(System.Reflection.PropertyInfo,System.Boolean)"]

isMandatory (Boolean)

[Missing <param name="isMandatory"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.PrimitiveSetter(System.Reflection.PropertyInfo,System.Boolean)"]


StringParameter Method (parameter)

StringParameter Method (parameter)
Namespaces ► StructureMap.Pipeline ► InstanceMementoPropertyReader ► StringParameter(ParameterInfo)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.InstanceMementoPropertyReader.StringParameter(System.Reflection.ParameterInfo)]

Declaration Syntax
C# Visual Basic Visual C++
public void StringParameter(
    ParameterInfo parameter
)
Public Sub StringParameter ( _
    parameter As ParameterInfo _
)
public:
virtual void StringParameter(
    ParameterInfo^ parameter
) sealed
Parameters
parameter (ParameterInfo)

[Missing <param name="parameter"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.StringParameter(System.Reflection.ParameterInfo)"]


StringSetter Method (property, isMandatory)

StringSetter Method (property, isMandatory)
Namespaces ► StructureMap.Pipeline ► InstanceMementoPropertyReader ► StringSetter(PropertyInfo, Boolean)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.InstanceMementoPropertyReader.StringSetter(System.Reflection.PropertyInfo,System.Boolean)]

Declaration Syntax
C# Visual Basic Visual C++
public void StringSetter(
    PropertyInfo property,
    bool isMandatory
)
Public Sub StringSetter ( _
    property As PropertyInfo, _
    isMandatory As Boolean _
)
public:
virtual void StringSetter(
    PropertyInfo^ property,
    bool isMandatory
) sealed
Parameters
property (PropertyInfo)

[Missing <param name="property"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.StringSetter(System.Reflection.PropertyInfo,System.Boolean)"]

isMandatory (Boolean)

[Missing <param name="isMandatory"/> documentation for "M:StructureMap.Pipeline.InstanceMementoPropertyReader.StringSetter(System.Reflection.PropertyInfo,System.Boolean)"]


IStructuredInstance Interface

IStructuredInstance Interface
Namespaces ► StructureMap.Pipeline ► IStructuredInstance
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.IStructuredInstance]

Declaration Syntax
C# Visual Basic Visual C++
public interface IStructuredInstance
Public Interface IStructuredInstance
public interface class IStructuredInstance
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetChild(String) |
 | GetChildArray(String) |
 | RemoveKey(String) |


GetChild Method (name)

GetChild Method (name)
Namespaces ► StructureMap.Pipeline ► IStructuredInstance ► GetChild(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IStructuredInstance.GetChild(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
Instance GetChild(
    string name
)
Function GetChild ( _
    name As String _
) As Instance
Instance^ GetChild(
    String^ name
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Pipeline.IStructuredInstance.GetChild(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.IStructuredInstance.GetChild(System.String)]


GetChildArray Method (name)

GetChildArray Method (name)
Namespaces ► StructureMap.Pipeline ► IStructuredInstance ► GetChildArray(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IStructuredInstance.GetChildArray(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
Instance[] GetChildArray(
    string name
)
Function GetChildArray ( _
    name As String _
) As Instance()
array<Instance^>^ GetChildArray(
    String^ name
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Pipeline.IStructuredInstance.GetChildArray(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.IStructuredInstance.GetChildArray(System.String)]


RemoveKey Method (name)

RemoveKey Method (name)
Namespaces ► StructureMap.Pipeline ► IStructuredInstance ► RemoveKey(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.IStructuredInstance.RemoveKey(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
void RemoveKey(
    string name
)
Sub RemoveKey ( _
    name As String _
)
void RemoveKey(
    String^ name
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Pipeline.IStructuredInstance.RemoveKey(System.String)"]


LiteralInstance Class

LiteralInstance Class
Namespaces ► StructureMap.Pipeline ► LiteralInstance
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.LiteralInstance]

Declaration Syntax
C# Visual Basic Visual C++
public class LiteralInstance : ExpressedInstance<LiteralInstance>
Public Class LiteralInstance _
    Inherits ExpressedInstance(Of LiteralInstance)
public ref class LiteralInstance : public ExpressedInstance<LiteralInstance^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | LiteralInstance(Object) | Initializes a new instance of the LiteralInstance class
 | addTemplatedInstanceTo(PluginFamily, array<Type>[]()[]) | (Inherited from Instance.)
 | build(Type, BuildSession) | (Overrides Instance.build(Type, BuildSession).)
 | Build(Type, BuildSession) | (Inherited from Instance.)
 | canBePartOfPluginFamily(PluginFamily) | (Overrides Instance.canBePartOfPluginFamily(PluginFamily).)
 | doesRecordOnTheStack | (Inherited from Instance.)
 | EnrichWith<(Of <(TYPE>)>)(EnrichmentHandler<(Of <(TYPE>)>)) | Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller (Inherited from ExpressedInstance<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | findMasterInstance(PluginFamily, String, GraphLog) | (Inherited from Instance.)
 | getConcreteType(Type) | (Inherited from Instance.)
 | getDescription()()() | (Overrides Instance.getDescription()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interceptor | (Inherited from Instance.)
 | InterceptWith(InstanceInterceptor) | Register an InstanceInterceptor with this Instance (Inherited from ExpressedInstance<(Of <(T>)>).)
 | markBuildStackFinish(BuildSession) | (Inherited from Instance.)
 | markBuildStackStart(BuildSession, Type) | (Inherited from Instance.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | (Inherited from Instance.)
 | Object |
 | OnCreation<(Of <(TYPE>)>)(Action<(Of <(TYPE>)>)) | Register an Action to perform on the object created by this Instance before it is returned to the caller (Inherited from ExpressedInstance<(Of <(T>)>).)
 | preprocess(PluginFamily) | (Inherited from Instance.)
 | replaceNameIfNotAlreadySet(String) | (Inherited from Instance.)
 | thisInstance | (Overrides ExpressedInstance <(Of <(LiteralInstance>)>).thisInstance.)
 | ToString()()() | (Overrides Object.ToString()()().)
 | WithName(String) | Set the name of this Instance (Inherited from ExpressedInstance<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | Instance
 |  | ExpressedInstance <(Of <(LiteralInstance>)>)
 |  |  | LiteralInstance


LiteralInstance Constructor (anObject)

LiteralInstance Constructor (anObject)
Namespaces ► StructureMap.Pipeline ► LiteralInstance ► LiteralInstance(Object)
StructureMap API
Initializes a new instance of the LiteralInstance class
Declaration Syntax
C# Visual Basic Visual C++
public LiteralInstance(
    Object anObject
)
Public Sub New ( _
    anObject As Object _
)
public:
LiteralInstance(
    Object^ anObject
)
Parameters
anObject (Object)

[Missing <param name="anObject"/> documentation for "M:StructureMap.Pipeline.LiteralInstance.#ctor(System.Object)"]


build Method (pluginType, session)

build Method (pluginType, session)
Namespaces ► StructureMap.Pipeline ► LiteralInstance ► build(Type, BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.LiteralInstance.build(System.Type,StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
protected override Object build(
    Type pluginType,
    BuildSession session
)
Protected Overrides Function build ( _
    pluginType As Type, _
    session As BuildSession _
) As Object
protected:
virtual Object^ build(
    Type^ pluginType,
    BuildSession^ session
) override
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.LiteralInstance.build(System.Type,StructureMap.BuildSession)"]

session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.LiteralInstance.build(System.Type,StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.LiteralInstance.build(System.Type,StructureMap.BuildSession)]


canBePartOfPluginFamily Method (family)

canBePartOfPluginFamily Method (family)
Namespaces ► StructureMap.Pipeline ► LiteralInstance ► canBePartOfPluginFamily(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.LiteralInstance.canBePartOfPluginFamily(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool canBePartOfPluginFamily(
    PluginFamily family
)
Protected Overrides Function canBePartOfPluginFamily ( _
    family As PluginFamily _
) As Boolean
protected:
virtual bool canBePartOfPluginFamily(
    PluginFamily^ family
) override
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.LiteralInstance.canBePartOfPluginFamily(StructureMap.Graph.PluginFamily)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.LiteralInstance.canBePartOfPluginFamily(StructureMap.Graph.PluginFamily)]


getDescription Method

getDescription Method
Namespaces ► StructureMap.Pipeline ► LiteralInstance ► getDescription()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.LiteralInstance.getDescription]

Declaration Syntax
C# Visual Basic Visual C++
protected override string getDescription()
Protected Overrides Function getDescription As String
protected:
virtual String^ getDescription() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.LiteralInstance.getDescription]


Object Property

Object Property
Namespaces ► StructureMap.Pipeline ► LiteralInstance ► Object
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.LiteralInstance.Object]

Declaration Syntax
C# Visual Basic Visual C++
public Object Object { get; }
Public ReadOnly Property Object As Object
public:
property Object^ Object {
    Object^ get ();
}


thisInstance Property

thisInstance Property
Namespaces ► StructureMap.Pipeline ► LiteralInstance ► thisInstance
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.LiteralInstance.thisInstance]

Declaration Syntax
C# Visual Basic Visual C++
protected override LiteralInstance thisInstance { get; }
Protected Overrides ReadOnly Property thisInstance As LiteralInstance
protected:
virtual property LiteralInstance^ thisInstance {
    LiteralInstance^ get () override;
}


ToString Method

ToString Method
Namespaces ► StructureMap.Pipeline ► LiteralInstance ► ToString()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.LiteralInstance.ToString]

Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.LiteralInstance.ToString]


Profile Class

Profile Class
Namespaces ► StructureMap.Pipeline ► Profile
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.Profile]

Declaration Syntax
C# Visual Basic Visual C++
public class Profile
Public Class Profile
public ref class Profile
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Profile(String) | Initializes a new instance of the Profile class
 | CopyDefault(Type, Type, PluginFamily) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | FillAllTypesInto(Profile) |
 | FillTypeInto(Type, Instance) |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindMasterInstances(PluginGraph) |
 | GetDefault(Type) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InstanceKeyForProfile(String) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Merge(Profile) |
 | Name |
 | Remove<(Of <(T>)>)()()() |
 | SetDefault(Type, Instance) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Profile


Profile Constructor (name)

Profile Constructor (name)
Namespaces ► StructureMap.Pipeline ► Profile ► Profile(String)
StructureMap API
Initializes a new instance of the Profile class
Declaration Syntax
C# Visual Basic Visual C++
public Profile(
    string name
)
Public Sub New ( _
    name As String _
)
public:
Profile(
    String^ name
)
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Pipeline.Profile.#ctor(System.String)"]


CopyDefault Method (sourceType, destinationType, family)

CopyDefault Method (sourceType, destinationType, family)
Namespaces ► StructureMap.Pipeline ► Profile ► CopyDefault(Type, Type, PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Profile.CopyDefault(System.Type,System.Type,StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
public void CopyDefault(
    Type sourceType,
    Type destinationType,
    PluginFamily family
)
Public Sub CopyDefault ( _
    sourceType As Type, _
    destinationType As Type, _
    family As PluginFamily _
)
public:
void CopyDefault(
    Type^ sourceType,
    Type^ destinationType,
    PluginFamily^ family
)
Parameters
sourceType (Type)

[Missing <param name="sourceType"/> documentation for "M:StructureMap.Pipeline.Profile.CopyDefault(System.Type,System.Type,StructureMap.Graph.PluginFamily)"]

destinationType (Type)

[Missing <param name="destinationType"/> documentation for "M:StructureMap.Pipeline.Profile.CopyDefault(System.Type,System.Type,StructureMap.Graph.PluginFamily)"]

family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.Profile.CopyDefault(System.Type,System.Type,StructureMap.Graph.PluginFamily)"]


FillAllTypesInto Method (destination)

FillAllTypesInto Method (destination)
Namespaces ► StructureMap.Pipeline ► Profile ► FillAllTypesInto(Profile)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Profile.FillAllTypesInto(StructureMap.Pipeline.Profile)]

Declaration Syntax
C# Visual Basic Visual C++
public void FillAllTypesInto(
    Profile destination
)
Public Sub FillAllTypesInto ( _
    destination As Profile _
)
public:
void FillAllTypesInto(
    Profile^ destination
)
Parameters
destination (Profile)

[Missing <param name="destination"/> documentation for "M:StructureMap.Pipeline.Profile.FillAllTypesInto(StructureMap.Pipeline.Profile)"]


FillTypeInto Method (pluginType, instance)

FillTypeInto Method (pluginType, instance)
Namespaces ► StructureMap.Pipeline ► Profile ► FillTypeInto(Type, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Profile.FillTypeInto(System.Type,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public void FillTypeInto(
    Type pluginType,
    Instance instance
)
Public Sub FillTypeInto ( _
    pluginType As Type, _
    instance As Instance _
)
public:
void FillTypeInto(
    Type^ pluginType,
    Instance^ instance
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.Profile.FillTypeInto(System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.Profile.FillTypeInto(System.Type,StructureMap.Pipeline.Instance)"]


FindMasterInstances Method (graph)

FindMasterInstances Method (graph)
Namespaces ► StructureMap.Pipeline ► Profile ► FindMasterInstances(PluginGraph)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Profile.FindMasterInstances(StructureMap.Graph.PluginGraph)]

Declaration Syntax
C# Visual Basic Visual C++
public void FindMasterInstances(
    PluginGraph graph
)
Public Sub FindMasterInstances ( _
    graph As PluginGraph _
)
public:
void FindMasterInstances(
    PluginGraph^ graph
)
Parameters
graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.Pipeline.Profile.FindMasterInstances(StructureMap.Graph.PluginGraph)"]


GetDefault Method (pluginType)

GetDefault Method (pluginType)
Namespaces ► StructureMap.Pipeline ► Profile ► GetDefault(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Profile.GetDefault(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public Instance GetDefault(
    Type pluginType
)
Public Function GetDefault ( _
    pluginType As Type _
) As Instance
public:
Instance^ GetDefault(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.Profile.GetDefault(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.Profile.GetDefault(System.Type)]


InstanceKeyForProfile Method (profileName)

InstanceKeyForProfile Method (profileName)
Namespaces ► StructureMap.Pipeline ► Profile ► InstanceKeyForProfile(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Profile.InstanceKeyForProfile(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public static string InstanceKeyForProfile(
    string profileName
)
Public Shared Function InstanceKeyForProfile ( _
    profileName As String _
) As String
public:
static String^ InstanceKeyForProfile(
    String^ profileName
)
Parameters
profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Pipeline.Profile.InstanceKeyForProfile(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.Profile.InstanceKeyForProfile(System.String)]


Merge Method (destination)

Merge Method (destination)
Namespaces ► StructureMap.Pipeline ► Profile ► Merge(Profile)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Profile.Merge(StructureMap.Pipeline.Profile)]

Declaration Syntax
C# Visual Basic Visual C++
public void Merge(
    Profile destination
)
Public Sub Merge ( _
    destination As Profile _
)
public:
void Merge(
    Profile^ destination
)
Parameters
destination (Profile)

[Missing <param name="destination"/> documentation for "M:StructureMap.Pipeline.Profile.Merge(StructureMap.Pipeline.Profile)"]


Name Property

Name Property
Namespaces ► StructureMap.Pipeline ► Profile ► Name
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.Profile.Name]

Declaration Syntax
C# Visual Basic Visual C++
public string Name { get; }
Public ReadOnly Property Name As String
public:
property String^ Name {
    String^ get ();
}


Remove Method

Remove<(Of <(T>)>) Method
Namespaces ► StructureMap.Pipeline ► Profile ► Remove<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Profile.Remove``1]

Declaration Syntax
C# Visual Basic Visual C++
public void Remove<T>()

Public Sub Remove(Of T)
public:
generic<typename T>
void Remove()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Pipeline.Profile.Remove``1"]


SetDefault Method (pluginType, instance)

SetDefault Method (pluginType, instance)
Namespaces ► StructureMap.Pipeline ► Profile ► SetDefault(Type, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.Profile.SetDefault(System.Type,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetDefault(
    Type pluginType,
    Instance instance
)
Public Sub SetDefault ( _
    pluginType As Type, _
    instance As Instance _
)
public:
void SetDefault(
    Type^ pluginType,
    Instance^ instance
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.Profile.SetDefault(System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.Profile.SetDefault(System.Type,StructureMap.Pipeline.Instance)"]


ProfileManager Class

ProfileManager Class
Namespaces ► StructureMap.Pipeline ► ProfileManager
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.ProfileManager]

Declaration Syntax
C# Visual Basic Visual C++
public class ProfileManager
Public Class ProfileManager
public ref class ProfileManager
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ProfileManager()()() | Initializes a new instance of the ProfileManager class
 | CopyDefaults(Type, Type, PluginFamily) |
 | CurrentProfile |
 | DefaultMachineProfileName |
 | DefaultProfileName |
 | EjectAllInstancesOf<(Of <(T>)>)()()() |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetDefault(Type, String) |
 | GetDefault(Type) |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMachineDefault(Type) |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | ImportFrom(ProfileManager) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Seal(PluginGraph) |
 | SetDefault(String, Type, Instance) |
 | SetDefault(Type, Instance) |
 | SetMachineDefault(Type, Instance) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
ProfileManager


ProfileManager Constructor

ProfileManager Constructor
Namespaces ► StructureMap.Pipeline ► ProfileManager ► ProfileManager()()()
StructureMap API
Initializes a new instance of the ProfileManager class
Declaration Syntax
C# Visual Basic Visual C++
public ProfileManager()
Public Sub New
public:
ProfileManager()


CopyDefaults Method (basicType, templatedType, family)

CopyDefaults Method (basicType, templatedType, family)
Namespaces ► StructureMap.Pipeline ► ProfileManager ► CopyDefaults(Type, Type, PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ProfileManager.CopyDefaults(System.Type,System.Type,StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
public void CopyDefaults(
    Type basicType,
    Type templatedType,
    PluginFamily family
)
Public Sub CopyDefaults ( _
    basicType As Type, _
    templatedType As Type, _
    family As PluginFamily _
)
public:
void CopyDefaults(
    Type^ basicType,
    Type^ templatedType,
    PluginFamily^ family
)
Parameters
basicType (Type)

[Missing <param name="basicType"/> documentation for "M:StructureMap.Pipeline.ProfileManager.CopyDefaults(System.Type,System.Type,StructureMap.Graph.PluginFamily)"]

templatedType (Type)

[Missing <param name="templatedType"/> documentation for "M:StructureMap.Pipeline.ProfileManager.CopyDefaults(System.Type,System.Type,StructureMap.Graph.PluginFamily)"]

family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.ProfileManager.CopyDefaults(System.Type,System.Type,StructureMap.Graph.PluginFamily)"]


CurrentProfile Property

CurrentProfile Property
Namespaces ► StructureMap.Pipeline ► ProfileManager ► CurrentProfile
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.ProfileManager.CurrentProfile]

Declaration Syntax
C# Visual Basic Visual C++
public string CurrentProfile { get; set; }
Public Property CurrentProfile As String
public:
property String^ CurrentProfile {
    String^ get ();
    void set (String^ value);
}


DefaultMachineProfileName Property

DefaultMachineProfileName Property
Namespaces ► StructureMap.Pipeline ► ProfileManager ► DefaultMachineProfileName
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.ProfileManager.DefaultMachineProfileName]

Declaration Syntax
C# Visual Basic Visual C++
public string DefaultMachineProfileName { get; set; }
Public Property DefaultMachineProfileName As String
public:
property String^ DefaultMachineProfileName {
    String^ get ();
    void set (String^ value);
}


DefaultProfileName Property

DefaultProfileName Property
Namespaces ► StructureMap.Pipeline ► ProfileManager ► DefaultProfileName
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.ProfileManager.DefaultProfileName]

Declaration Syntax
C# Visual Basic Visual C++
public string DefaultProfileName { get; set; }
Public Property DefaultProfileName As String
public:
property String^ DefaultProfileName {
    String^ get ();
    void set (String^ value);
}


EjectAllInstancesOf Method

EjectAllInstancesOf<(Of <(T>)>) Method
Namespaces ► StructureMap.Pipeline ► ProfileManager ► EjectAllInstancesOf<(Of <(T>)>)()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ProfileManager.EjectAllInstancesOf``1]

Declaration Syntax
C# Visual Basic Visual C++
public void EjectAllInstancesOf<T>()

Public Sub EjectAllInstancesOf(Of T)
public:
generic<typename T>
void EjectAllInstancesOf()
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "M:StructureMap.Pipeline.ProfileManager.EjectAllInstancesOf``1"]


GetDefault Method

GetDefault Method
Namespaces ► StructureMap.Pipeline ► ProfileManager ► GetDefault()()()
StructureMap API
Members
Icon | Member | Description
 | GetDefault(Type, String) |
 | GetDefault(Type) |


GetDefault Method (pluginType)

GetDefault Method (pluginType)
Namespaces ► StructureMap.Pipeline ► ProfileManager ► GetDefault(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ProfileManager.GetDefault(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public Instance GetDefault(
    Type pluginType
)
Public Function GetDefault ( _
    pluginType As Type _
) As Instance
public:
Instance^ GetDefault(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ProfileManager.GetDefault(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ProfileManager.GetDefault(System.Type)]


GetDefault Method (pluginType, profileName)

GetDefault Method (pluginType, profileName)
Namespaces ► StructureMap.Pipeline ► ProfileManager ► GetDefault(Type, String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ProfileManager.GetDefault(System.Type,System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public Instance GetDefault(
    Type pluginType,
    string profileName
)
Public Function GetDefault ( _
    pluginType As Type, _
    profileName As String _
) As Instance
public:
Instance^ GetDefault(
    Type^ pluginType,
    String^ profileName
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ProfileManager.GetDefault(System.Type,System.String)"]

profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Pipeline.ProfileManager.GetDefault(System.Type,System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ProfileManager.GetDefault(System.Type,System.String)]


GetMachineDefault Method (pluginType)

GetMachineDefault Method (pluginType)
Namespaces ► StructureMap.Pipeline ► ProfileManager ► GetMachineDefault(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ProfileManager.GetMachineDefault(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public Instance GetMachineDefault(
    Type pluginType
)
Public Function GetMachineDefault ( _
    pluginType As Type _
) As Instance
public:
Instance^ GetMachineDefault(
    Type^ pluginType
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ProfileManager.GetMachineDefault(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ProfileManager.GetMachineDefault(System.Type)]


ImportFrom Method (source)

ImportFrom Method (source)
Namespaces ► StructureMap.Pipeline ► ProfileManager ► ImportFrom(ProfileManager)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ProfileManager.ImportFrom(StructureMap.Pipeline.ProfileManager)]

Declaration Syntax
C# Visual Basic Visual C++
public void ImportFrom(
    ProfileManager source
)
Public Sub ImportFrom ( _
    source As ProfileManager _
)
public:
void ImportFrom(
    ProfileManager^ source
)
Parameters
source (ProfileManager)

[Missing <param name="source"/> documentation for "M:StructureMap.Pipeline.ProfileManager.ImportFrom(StructureMap.Pipeline.ProfileManager)"]


Seal Method (graph)

Seal Method (graph)
Namespaces ► StructureMap.Pipeline ► ProfileManager ► Seal(PluginGraph)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ProfileManager.Seal(StructureMap.Graph.PluginGraph)]

Declaration Syntax
C# Visual Basic Visual C++
public void Seal(
    PluginGraph graph
)
Public Sub Seal ( _
    graph As PluginGraph _
)
public:
void Seal(
    PluginGraph^ graph
)
Parameters
graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.Pipeline.ProfileManager.Seal(StructureMap.Graph.PluginGraph)"]


SetDefault Method

SetDefault Method
Namespaces ► StructureMap.Pipeline ► ProfileManager ► SetDefault()()()
StructureMap API
Members
Icon | Member | Description
 | SetDefault(String, Type, Instance) |
 | SetDefault(Type, Instance) |


SetDefault Method (profileName, pluginType, instance)

SetDefault Method (profileName, pluginType, instance)
Namespaces ► StructureMap.Pipeline ► ProfileManager ► SetDefault(String, Type, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ProfileManager.SetDefault(System.String,System.Type,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetDefault(
    string profileName,
    Type pluginType,
    Instance instance
)
Public Sub SetDefault ( _
    profileName As String, _
    pluginType As Type, _
    instance As Instance _
)
public:
void SetDefault(
    String^ profileName,
    Type^ pluginType,
    Instance^ instance
)
Parameters
profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Pipeline.ProfileManager.SetDefault(System.String,System.Type,StructureMap.Pipeline.Instance)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ProfileManager.SetDefault(System.String,System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.ProfileManager.SetDefault(System.String,System.Type,StructureMap.Pipeline.Instance)"]


SetDefault Method (pluginType, instance)

SetDefault Method (pluginType, instance)
Namespaces ► StructureMap.Pipeline ► ProfileManager ► SetDefault(Type, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ProfileManager.SetDefault(System.Type,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetDefault(
    Type pluginType,
    Instance instance
)
Public Sub SetDefault ( _
    pluginType As Type, _
    instance As Instance _
)
public:
void SetDefault(
    Type^ pluginType,
    Instance^ instance
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ProfileManager.SetDefault(System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.ProfileManager.SetDefault(System.Type,StructureMap.Pipeline.Instance)"]


SetMachineDefault Method (pluginType, instance)

SetMachineDefault Method (pluginType, instance)
Namespaces ► StructureMap.Pipeline ► ProfileManager ► SetMachineDefault(Type, Instance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ProfileManager.SetMachineDefault(System.Type,StructureMap.Pipeline.Instance)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetMachineDefault(
    Type pluginType,
    Instance instance
)
Public Sub SetMachineDefault ( _
    pluginType As Type, _
    instance As Instance _
)
public:
void SetMachineDefault(
    Type^ pluginType,
    Instance^ instance
)
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ProfileManager.SetMachineDefault(System.Type,StructureMap.Pipeline.Instance)"]

instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.ProfileManager.SetMachineDefault(System.Type,StructureMap.Pipeline.Instance)"]


PropertyExpression(T) Class

PropertyExpression<(Of <(T>)>) Class
Namespaces ► StructureMap.Pipeline ► PropertyExpression<(Of <(T>)>)
StructureMap API
Defines the value of a primitive argument to a constructur argument
Declaration Syntax
C# Visual Basic Visual C++
public class PropertyExpression<T>
where T : IConfiguredInstance

Public Class PropertyExpression(Of T As IConfiguredInstance)
generic<typename T>
where T : IConfiguredInstance
public ref class PropertyExpression
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:StructureMap.Pipeline.PropertyExpression`1"]

Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | PropertyExpression<(Of <(T>)>)(IConfiguredInstance, String) | Initializes a new instance of the PropertyExpression<(Of <(T>)>) class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | EqualTo(Object) | Sets the value of the constructor argument
 | EqualToAppSetting(String) | Sets the value of the constructor argument to the key/value in the AppSettings
 | EqualToAppSetting(String, String) | Sets the value of the constructor argument to the key/value in the AppSettings when it exists. Otherwise uses the provided default value.
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
PropertyExpression<(Of <(T>)>)


PropertyExpression(T) Constructor (instance, propertyName)

PropertyExpression<(Of <(T>)>) Constructor (instance, propertyName)
Namespaces ► StructureMap.Pipeline ► PropertyExpression<(Of <(T>)>) ► PropertyExpression<(Of <(T>)>)(IConfiguredInstance, String)
StructureMap API
Initializes a new instance of the PropertyExpression<(Of <(T>)>) class
Declaration Syntax
C# Visual Basic Visual C++
public PropertyExpression(
    IConfiguredInstance instance,
    string propertyName
)
Public Sub New ( _
    instance As IConfiguredInstance, _
    propertyName As String _
)
public:
PropertyExpression(
    IConfiguredInstance^ instance,
    String^ propertyName
)
Parameters
instance (IConfiguredInstance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.PropertyExpression`1.#ctor(StructureMap.Pipeline.IConfiguredInstance,System.String)"]

propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.PropertyExpression`1.#ctor(StructureMap.Pipeline.IConfiguredInstance,System.String)"]


EqualTo Method (propertyValue)

EqualTo Method (propertyValue)
Namespaces ► StructureMap.Pipeline ► PropertyExpression<(Of <(T>)>) ► EqualTo(Object)
StructureMap API
Sets the value of the constructor argument
Declaration Syntax
C# Visual Basic Visual C++
public T EqualTo(
    Object propertyValue
)
Public Function EqualTo ( _
    propertyValue As Object _
) As T
public:
T EqualTo(
    Object^ propertyValue
)
Parameters
propertyValue (Object)

[Missing <param name="propertyValue"/> documentation for "M:StructureMap.Pipeline.PropertyExpression`1.EqualTo(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.PropertyExpression`1.EqualTo(System.Object)]


EqualToAppSetting Method

EqualToAppSetting Method
Namespaces ► StructureMap.Pipeline ► PropertyExpression<(Of <(T>)>) ► EqualToAppSetting()()()
StructureMap API
Members
Icon | Member | Description
 | EqualToAppSetting(String) | Sets the value of the constructor argument to the key/value in the AppSettings
 | EqualToAppSetting(String, String) | Sets the value of the constructor argument to the key/value in the AppSettings when it exists. Otherwise uses the provided default value.


EqualToAppSetting Method (appSettingKey)

EqualToAppSetting Method (appSettingKey)
Namespaces ► StructureMap.Pipeline ► PropertyExpression<(Of <(T>)>) ► EqualToAppSetting(String)
StructureMap API
Sets the value of the constructor argument to the key/value in the AppSettings
Declaration Syntax
C# Visual Basic Visual C++
public T EqualToAppSetting(
    string appSettingKey
)
Public Function EqualToAppSetting ( _
    appSettingKey As String _
) As T
public:
T EqualToAppSetting(
    String^ appSettingKey
)
Parameters
appSettingKey (String)
The key in appSettings for the value to use.
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.PropertyExpression`1.EqualToAppSetting(System.String)]


EqualToAppSetting Method (appSettingKey, defaultValue)

EqualToAppSetting Method (appSettingKey, defaultValue)
Namespaces ► StructureMap.Pipeline ► PropertyExpression<(Of <(T>)>) ► EqualToAppSetting(String, String)
StructureMap API
Sets the value of the constructor argument to the key/value in the AppSettings when it exists. Otherwise uses the provided default value.
Declaration Syntax
C# Visual Basic Visual C++
public T EqualToAppSetting(
    string appSettingKey,
    string defaultValue
)
Public Function EqualToAppSetting ( _
    appSettingKey As String, _
    defaultValue As String _
) As T
public:
T EqualToAppSetting(
    String^ appSettingKey,
    String^ defaultValue
)
Parameters
appSettingKey (String)
The key in appSettings for the value to use.
defaultValue (String)
The value to use if an entry for appSettingKey does not exist in the appSettings section.
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.PropertyExpression`1.EqualToAppSetting(System.String,System.String)]


PrototypeInstance Class

PrototypeInstance Class
Namespaces ► StructureMap.Pipeline ► PrototypeInstance
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.PrototypeInstance]

Declaration Syntax
C# Visual Basic Visual C++
public class PrototypeInstance : ExpressedInstance<PrototypeInstance>
Public Class PrototypeInstance _
    Inherits ExpressedInstance(Of PrototypeInstance)
public ref class PrototypeInstance : public ExpressedInstance<PrototypeInstance^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | PrototypeInstance(ICloneable) | Initializes a new instance of the PrototypeInstance class
 | addTemplatedInstanceTo(PluginFamily, array<Type>[]()[]) | (Inherited from Instance.)
 | build(Type, BuildSession) | (Overrides Instance.build(Type, BuildSession).)
 | Build(Type, BuildSession) | (Inherited from Instance.)
 | canBePartOfPluginFamily(PluginFamily) | (Overrides Instance.canBePartOfPluginFamily(PluginFamily).)
 | doesRecordOnTheStack | (Inherited from Instance.)
 | EnrichWith<(Of <(TYPE>)>)(EnrichmentHandler<(Of <(TYPE>)>)) | Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller (Inherited from ExpressedInstance<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | findMasterInstance(PluginFamily, String, GraphLog) | (Inherited from Instance.)
 | getConcreteType(Type) | (Inherited from Instance.)
 | getDescription()()() | (Overrides Instance.getDescription()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interceptor | (Inherited from Instance.)
 | InterceptWith(InstanceInterceptor) | Register an InstanceInterceptor with this Instance (Inherited from ExpressedInstance<(Of <(T>)>).)
 | markBuildStackFinish(BuildSession) | (Inherited from Instance.)
 | markBuildStackStart(BuildSession, Type) | (Inherited from Instance.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | (Inherited from Instance.)
 | OnCreation<(Of <(TYPE>)>)(Action<(Of <(TYPE>)>)) | Register an Action to perform on the object created by this Instance before it is returned to the caller (Inherited from ExpressedInstance<(Of <(T>)>).)
 | preprocess(PluginFamily) | (Inherited from Instance.)
 | replaceNameIfNotAlreadySet(String) | (Inherited from Instance.)
 | thisInstance | (Overrides ExpressedInstance <(Of <(PrototypeInstance>)>).thisInstance.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WithName(String) | Set the name of this Instance (Inherited from ExpressedInstance<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | Instance
 |  | ExpressedInstance <(Of <(PrototypeInstance>)>)
 |  |  | PrototypeInstance


PrototypeInstance Constructor (prototype)

PrototypeInstance Constructor (prototype)
Namespaces ► StructureMap.Pipeline ► PrototypeInstance ► PrototypeInstance(ICloneable)
StructureMap API
Initializes a new instance of the PrototypeInstance class
Declaration Syntax
C# Visual Basic Visual C++
public PrototypeInstance(
    ICloneable prototype
)
Public Sub New ( _
    prototype As ICloneable _
)
public:
PrototypeInstance(
    ICloneable^ prototype
)
Parameters
prototype (ICloneable)

[Missing <param name="prototype"/> documentation for "M:StructureMap.Pipeline.PrototypeInstance.#ctor(System.ICloneable)"]


build Method (pluginType, session)

build Method (pluginType, session)
Namespaces ► StructureMap.Pipeline ► PrototypeInstance ► build(Type, BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.PrototypeInstance.build(System.Type,StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
protected override Object build(
    Type pluginType,
    BuildSession session
)
Protected Overrides Function build ( _
    pluginType As Type, _
    session As BuildSession _
) As Object
protected:
virtual Object^ build(
    Type^ pluginType,
    BuildSession^ session
) override
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.PrototypeInstance.build(System.Type,StructureMap.BuildSession)"]

session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.PrototypeInstance.build(System.Type,StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.PrototypeInstance.build(System.Type,StructureMap.BuildSession)]


canBePartOfPluginFamily Method (family)

canBePartOfPluginFamily Method (family)
Namespaces ► StructureMap.Pipeline ► PrototypeInstance ► canBePartOfPluginFamily(PluginFamily)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.PrototypeInstance.canBePartOfPluginFamily(StructureMap.Graph.PluginFamily)]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool canBePartOfPluginFamily(
    PluginFamily family
)
Protected Overrides Function canBePartOfPluginFamily ( _
    family As PluginFamily _
) As Boolean
protected:
virtual bool canBePartOfPluginFamily(
    PluginFamily^ family
) override
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.PrototypeInstance.canBePartOfPluginFamily(StructureMap.Graph.PluginFamily)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.PrototypeInstance.canBePartOfPluginFamily(StructureMap.Graph.PluginFamily)]


getDescription Method

getDescription Method
Namespaces ► StructureMap.Pipeline ► PrototypeInstance ► getDescription()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.PrototypeInstance.getDescription]

Declaration Syntax
C# Visual Basic Visual C++
protected override string getDescription()
Protected Overrides Function getDescription As String
protected:
virtual String^ getDescription() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.PrototypeInstance.getDescription]


thisInstance Property

thisInstance Property
Namespaces ► StructureMap.Pipeline ► PrototypeInstance ► thisInstance
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.PrototypeInstance.thisInstance]

Declaration Syntax
C# Visual Basic Visual C++
protected override PrototypeInstance thisInstance { get; }
Protected Overrides ReadOnly Property thisInstance As PrototypeInstance
protected:
virtual property PrototypeInstance^ thisInstance {
    PrototypeInstance^ get () override;
}


ReferencedInstance Class

ReferencedInstance Class
Namespaces ► StructureMap.Pipeline ► ReferencedInstance
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.ReferencedInstance]

Declaration Syntax
C# Visual Basic Visual C++
public class ReferencedInstance : Instance,
    IEquatable<ReferencedInstance>
Public Class ReferencedInstance _
    Inherits Instance _
    Implements IEquatable(Of ReferencedInstance)
public ref class ReferencedInstance : public Instance,
    IEquatable<ReferencedInstance^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ReferencedInstance(String) | Initializes a new instance of the ReferencedInstance class
 | addTemplatedInstanceTo(PluginFamily, array<Type>[]()[]) | (Inherited from Instance.)
 | build(Type, BuildSession) | (Overrides Instance.build(Type, BuildSession).)
 | Build(Type, BuildSession) | (Inherited from Instance.)
 | canBePartOfPluginFamily(PluginFamily) | (Inherited from Instance.)
 | doesRecordOnTheStack | (Overrides Instance.doesRecordOnTheStack.)
 | Equals(ReferencedInstance) |
 | Equals(Object) | (Overrides Object.Equals(Object).)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | findMasterInstance(PluginFamily, String, GraphLog) | (Overrides Instance.findMasterInstance(PluginFamily, String, GraphLog).)
 | getConcreteType(Type) | (Inherited from Instance.)
 | getDescription()()() | (Overrides Instance.getDescription()()().)
 | GetHashCode()()() | (Overrides Object.GetHashCode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interceptor | (Inherited from Instance.)
 | markBuildStackFinish(BuildSession) | (Inherited from Instance.)
 | markBuildStackStart(BuildSession, Type) | (Inherited from Instance.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | (Inherited from Instance.)
 | preprocess(PluginFamily) | (Inherited from Instance.)
 | ReferenceKey |
 | replaceNameIfNotAlreadySet(String) | (Inherited from Instance.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | Instance
 |  | ReferencedInstance


ReferencedInstance Constructor (referenceKey)

ReferencedInstance Constructor (referenceKey)
Namespaces ► StructureMap.Pipeline ► ReferencedInstance ► ReferencedInstance(String)
StructureMap API
Initializes a new instance of the ReferencedInstance class
Declaration Syntax
C# Visual Basic Visual C++
public ReferencedInstance(
    string referenceKey
)
Public Sub New ( _
    referenceKey As String _
)
public:
ReferencedInstance(
    String^ referenceKey
)
Parameters
referenceKey (String)

[Missing <param name="referenceKey"/> documentation for "M:StructureMap.Pipeline.ReferencedInstance.#ctor(System.String)"]


build Method (pluginType, session)

build Method (pluginType, session)
Namespaces ► StructureMap.Pipeline ► ReferencedInstance ► build(Type, BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ReferencedInstance.build(System.Type,StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
protected override Object build(
    Type pluginType,
    BuildSession session
)
Protected Overrides Function build ( _
    pluginType As Type, _
    session As BuildSession _
) As Object
protected:
virtual Object^ build(
    Type^ pluginType,
    BuildSession^ session
) override
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ReferencedInstance.build(System.Type,StructureMap.BuildSession)"]

session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.ReferencedInstance.build(System.Type,StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ReferencedInstance.build(System.Type,StructureMap.BuildSession)]


doesRecordOnTheStack Property

doesRecordOnTheStack Property
Namespaces ► StructureMap.Pipeline ► ReferencedInstance ► doesRecordOnTheStack
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.ReferencedInstance.doesRecordOnTheStack]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool doesRecordOnTheStack { get; }
Protected Overrides ReadOnly Property doesRecordOnTheStack As Boolean
protected:
virtual property bool doesRecordOnTheStack {
    bool get () override;
}


Equals Method

Equals Method
Namespaces ► StructureMap.Pipeline ► ReferencedInstance ► Equals()()()
StructureMap API
Members
Icon | Member | Description
 | Equals(ReferencedInstance) |
 | Equals(Object) | (Overrides Object.Equals(Object).)


Equals Method (referencedInstance)

Equals Method (referencedInstance)
Namespaces ► StructureMap.Pipeline ► ReferencedInstance ► Equals(ReferencedInstance)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ReferencedInstance.Equals(StructureMap.Pipeline.ReferencedInstance)]

Declaration Syntax
C# Visual Basic Visual C++
public bool Equals(
    ReferencedInstance referencedInstance
)
Public Function Equals ( _
    referencedInstance As ReferencedInstance _
) As Boolean
public:
virtual bool Equals(
    ReferencedInstance^ referencedInstance
) sealed
Parameters
referencedInstance (ReferencedInstance)

[Missing <param name="referencedInstance"/> documentation for "M:StructureMap.Pipeline.ReferencedInstance.Equals(StructureMap.Pipeline.ReferencedInstance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ReferencedInstance.Equals(StructureMap.Pipeline.ReferencedInstance)]


Equals Method (obj)

Equals Method (obj)
Namespaces ► StructureMap.Pipeline ► ReferencedInstance ► Equals(Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ReferencedInstance.Equals(System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
public override bool Equals(
    Object obj
)
Public Overrides Function Equals ( _
    obj As Object _
) As Boolean
public:
virtual bool Equals(
    Object^ obj
) override
Parameters
obj (Object)

[Missing <param name="obj"/> documentation for "M:StructureMap.Pipeline.ReferencedInstance.Equals(System.Object)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ReferencedInstance.Equals(System.Object)]


findMasterInstance Method (family, profileName, log)

findMasterInstance Method (family, profileName, log)
Namespaces ► StructureMap.Pipeline ► ReferencedInstance ► findMasterInstance(PluginFamily, String, GraphLog)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ReferencedInstance.findMasterInstance(StructureMap.Graph.PluginFamily,System.String,StructureMap.Diagnostics.GraphLog)]

Declaration Syntax
C# Visual Basic Visual C++
protected override Instance findMasterInstance(
    PluginFamily family,
    string profileName,
    GraphLog log
)
Protected Overrides Function findMasterInstance ( _
    family As PluginFamily, _
    profileName As String, _
    log As GraphLog _
) As Instance
protected:
virtual Instance^ findMasterInstance(
    PluginFamily^ family,
    String^ profileName,
    GraphLog^ log
) override
Parameters
family (PluginFamily)

[Missing <param name="family"/> documentation for "M:StructureMap.Pipeline.ReferencedInstance.findMasterInstance(StructureMap.Graph.PluginFamily,System.String,StructureMap.Diagnostics.GraphLog)"]

profileName (String)

[Missing <param name="profileName"/> documentation for "M:StructureMap.Pipeline.ReferencedInstance.findMasterInstance(StructureMap.Graph.PluginFamily,System.String,StructureMap.Diagnostics.GraphLog)"]

log (GraphLog)

[Missing <param name="log"/> documentation for "M:StructureMap.Pipeline.ReferencedInstance.findMasterInstance(StructureMap.Graph.PluginFamily,System.String,StructureMap.Diagnostics.GraphLog)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ReferencedInstance.findMasterInstance(StructureMap.Graph.PluginFamily,System.String,StructureMap.Diagnostics.GraphLog)]


getDescription Method

getDescription Method
Namespaces ► StructureMap.Pipeline ► ReferencedInstance ► getDescription()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ReferencedInstance.getDescription]

Declaration Syntax
C# Visual Basic Visual C++
protected override string getDescription()
Protected Overrides Function getDescription As String
protected:
virtual String^ getDescription() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ReferencedInstance.getDescription]


GetHashCode Method

GetHashCode Method
Namespaces ► StructureMap.Pipeline ► ReferencedInstance ► GetHashCode()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ReferencedInstance.GetHashCode]

Declaration Syntax
C# Visual Basic Visual C++
public override int GetHashCode()
Public Overrides Function GetHashCode As Integer
public:
virtual int GetHashCode() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ReferencedInstance.GetHashCode]


ReferenceKey Property

ReferenceKey Property
Namespaces ► StructureMap.Pipeline ► ReferencedInstance ► ReferenceKey
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.ReferencedInstance.ReferenceKey]

Declaration Syntax
C# Visual Basic Visual C++
public string ReferenceKey { get; }
Public ReadOnly Property ReferenceKey As String
public:
property String^ ReferenceKey {
    String^ get ();
}


SerializedInstance Class

SerializedInstance Class
Namespaces ► StructureMap.Pipeline ► SerializedInstance
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.SerializedInstance]

Declaration Syntax
C# Visual Basic Visual C++
public class SerializedInstance : ExpressedInstance<SerializedInstance>
Public Class SerializedInstance _
    Inherits ExpressedInstance(Of SerializedInstance)
public ref class SerializedInstance : public ExpressedInstance<SerializedInstance^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SerializedInstance(Object) | Initializes a new instance of the SerializedInstance class
 | addTemplatedInstanceTo(PluginFamily, array<Type>[]()[]) | (Inherited from Instance.)
 | build(Type, BuildSession) | (Overrides Instance.build(Type, BuildSession).)
 | Build(Type, BuildSession) | (Inherited from Instance.)
 | canBePartOfPluginFamily(PluginFamily) | (Inherited from Instance.)
 | doesRecordOnTheStack | (Inherited from Instance.)
 | EnrichWith<(Of <(TYPE>)>)(EnrichmentHandler<(Of <(TYPE>)>)) | Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller (Inherited from ExpressedInstance<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | findMasterInstance(PluginFamily, String, GraphLog) | (Inherited from Instance.)
 | getConcreteType(Type) | (Inherited from Instance.)
 | getDescription()()() | (Overrides Instance.getDescription()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interceptor | (Inherited from Instance.)
 | InterceptWith(InstanceInterceptor) | Register an InstanceInterceptor with this Instance (Inherited from ExpressedInstance<(Of <(T>)>).)
 | markBuildStackFinish(BuildSession) | (Inherited from Instance.)
 | markBuildStackStart(BuildSession, Type) | (Inherited from Instance.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | (Inherited from Instance.)
 | OnCreation<(Of <(TYPE>)>)(Action<(Of <(TYPE>)>)) | Register an Action to perform on the object created by this Instance before it is returned to the caller (Inherited from ExpressedInstance<(Of <(T>)>).)
 | preprocess(PluginFamily) | (Inherited from Instance.)
 | replaceNameIfNotAlreadySet(String) | (Inherited from Instance.)
 | thisInstance | (Overrides ExpressedInstance <(Of <(SerializedInstance>)>).thisInstance.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WithName(String) | Set the name of this Instance (Inherited from ExpressedInstance<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | Instance
 |  | ExpressedInstance <(Of <(SerializedInstance>)>)
 |  |  | SerializedInstance


SerializedInstance Constructor (template)

SerializedInstance Constructor (template)
Namespaces ► StructureMap.Pipeline ► SerializedInstance ► SerializedInstance(Object)
StructureMap API
Initializes a new instance of the SerializedInstance class
Declaration Syntax
C# Visual Basic Visual C++
public SerializedInstance(
    Object template
)
Public Sub New ( _
    template As Object _
)
public:
SerializedInstance(
    Object^ template
)
Parameters
template (Object)

[Missing <param name="template"/> documentation for "M:StructureMap.Pipeline.SerializedInstance.#ctor(System.Object)"]


build Method (pluginType, session)

build Method (pluginType, session)
Namespaces ► StructureMap.Pipeline ► SerializedInstance ► build(Type, BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.SerializedInstance.build(System.Type,StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
protected override Object build(
    Type pluginType,
    BuildSession session
)
Protected Overrides Function build ( _
    pluginType As Type, _
    session As BuildSession _
) As Object
protected:
virtual Object^ build(
    Type^ pluginType,
    BuildSession^ session
) override
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.SerializedInstance.build(System.Type,StructureMap.BuildSession)"]

session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.SerializedInstance.build(System.Type,StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SerializedInstance.build(System.Type,StructureMap.BuildSession)]


getDescription Method

getDescription Method
Namespaces ► StructureMap.Pipeline ► SerializedInstance ► getDescription()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.SerializedInstance.getDescription]

Declaration Syntax
C# Visual Basic Visual C++
protected override string getDescription()
Protected Overrides Function getDescription As String
protected:
virtual String^ getDescription() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SerializedInstance.getDescription]


thisInstance Property

thisInstance Property
Namespaces ► StructureMap.Pipeline ► SerializedInstance ► thisInstance
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.SerializedInstance.thisInstance]

Declaration Syntax
C# Visual Basic Visual C++
protected override SerializedInstance thisInstance { get; }
Protected Overrides ReadOnly Property thisInstance As SerializedInstance
protected:
virtual property SerializedInstance^ thisInstance {
    SerializedInstance^ get () override;
}


SingletonPolicy Class

SingletonPolicy Class
Namespaces ► StructureMap.Pipeline ► SingletonPolicy
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.SingletonPolicy]

Declaration Syntax
C# Visual Basic Visual C++
public class SingletonPolicy : CacheInterceptor
Public Class SingletonPolicy _
    Inherits CacheInterceptor
public ref class SingletonPolicy : public CacheInterceptor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SingletonPolicy()()() | Initializes a new instance of the SingletonPolicy class
 | Build(BuildSession, Type, Instance) | (Inherited from CacheInterceptor.)
 | clone()()() | (Overrides CacheInterceptor.clone()()().)
 | Clone()()() | (Inherited from CacheInterceptor.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerPolicy | (Inherited from CacheInterceptor.)
 | isCached(String, Type) | (Overrides CacheInterceptor.isCached(String, Type).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | retrieveFromCache(String, Type) | (Overrides CacheInterceptor.retrieveFromCache(String, Type).)
 | storeInCache(String, Type, Object) | (Overrides CacheInterceptor.storeInCache(String, Type, Object).)
 | ToString()()() | (Inherited from CacheInterceptor.)
Inheritance Hierarchy
Object
 | CacheInterceptor
 |  | SingletonPolicy


SingletonPolicy Constructor

SingletonPolicy Constructor
Namespaces ► StructureMap.Pipeline ► SingletonPolicy ► SingletonPolicy()()()
StructureMap API
Initializes a new instance of the SingletonPolicy class
Declaration Syntax
C# Visual Basic Visual C++
public SingletonPolicy()
Public Sub New
public:
SingletonPolicy()


clone Method

clone Method
Namespaces ► StructureMap.Pipeline ► SingletonPolicy ► clone()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.SingletonPolicy.clone]

Declaration Syntax
C# Visual Basic Visual C++
protected override CacheInterceptor clone()
Protected Overrides Function clone As CacheInterceptor
protected:
virtual CacheInterceptor^ clone() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SingletonPolicy.clone]


isCached Method (instanceKey, pluginType)

isCached Method (instanceKey, pluginType)
Namespaces ► StructureMap.Pipeline ► SingletonPolicy ► isCached(String, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.SingletonPolicy.isCached(System.String,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool isCached(
    string instanceKey,
    Type pluginType
)
Protected Overrides Function isCached ( _
    instanceKey As String, _
    pluginType As Type _
) As Boolean
protected:
virtual bool isCached(
    String^ instanceKey,
    Type^ pluginType
) override
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.SingletonPolicy.isCached(System.String,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.SingletonPolicy.isCached(System.String,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SingletonPolicy.isCached(System.String,System.Type)]


retrieveFromCache Method (instanceKey, pluginType)

retrieveFromCache Method (instanceKey, pluginType)
Namespaces ► StructureMap.Pipeline ► SingletonPolicy ► retrieveFromCache(String, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.SingletonPolicy.retrieveFromCache(System.String,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected override Object retrieveFromCache(
    string instanceKey,
    Type pluginType
)
Protected Overrides Function retrieveFromCache ( _
    instanceKey As String, _
    pluginType As Type _
) As Object
protected:
virtual Object^ retrieveFromCache(
    String^ instanceKey,
    Type^ pluginType
) override
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.SingletonPolicy.retrieveFromCache(System.String,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.SingletonPolicy.retrieveFromCache(System.String,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SingletonPolicy.retrieveFromCache(System.String,System.Type)]


storeInCache Method (instanceKey, pluginType, instance)

storeInCache Method (instanceKey, pluginType, instance)
Namespaces ► StructureMap.Pipeline ► SingletonPolicy ► storeInCache(String, Type, Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.SingletonPolicy.storeInCache(System.String,System.Type,System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void storeInCache(
    string instanceKey,
    Type pluginType,
    Object instance
)
Protected Overrides Sub storeInCache ( _
    instanceKey As String, _
    pluginType As Type, _
    instance As Object _
)
protected:
virtual void storeInCache(
    String^ instanceKey,
    Type^ pluginType,
    Object^ instance
) override
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.SingletonPolicy.storeInCache(System.String,System.Type,System.Object)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.SingletonPolicy.storeInCache(System.String,System.Type,System.Object)"]

instance (Object)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.SingletonPolicy.storeInCache(System.String,System.Type,System.Object)"]


SmartInstance(T) Class

SmartInstance<(Of <(T>)>) Class
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>)
StructureMap API
Instance that builds objects with by calling constructor functions and using setter properties
Declaration Syntax
C# Visual Basic Visual C++
public class SmartInstance<T> : ConfiguredInstanceBase<SmartInstance<T>>

Public Class SmartInstance(Of T) _
    Inherits ConfiguredInstanceBase(Of SmartInstance(Of T))
generic<typename T>
public ref class SmartInstance : public ConfiguredInstanceBase<SmartInstance<T>^>
Generic Template Parameters
T
The concrete type constructed by SmartInstance
Members
All Members | Constructors | Methods | Properties | Fields
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SmartInstance<(Of <(T>)>)()()() | Initializes a new instance of the SmartInstance<(Of <(T>)>) class
 | _arrays | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | _children | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | _pluggedType | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | _properties | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | addTemplatedInstanceTo(PluginFamily, array<Type>[]()[]) | (Inherited from Instance.)
 | build(Type, BuildSession) | (Overrides ConfiguredInstanceBase <(Of <(SmartInstance<(Of <(T>)>)>)>).build(Type, BuildSession).)
 | Build(Type, BuildSession) | (Inherited from Instance.)
 | canBePartOfPluginFamily(PluginFamily) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | CtorDependency<(Of <(CTORTYPE>)>)()()() | Inline definition of a constructor dependency. Select the constructor argument by type. Do not use this method if there is more than one constructor arguments of the same type
 | CtorDependency<(Of <(CTORTYPE>)>)(String) | Inline definition of a constructor dependency. Select the constructor argument by type and constructor name. Use this method if there is more than one constructor arguments of the same type
 | doesRecordOnTheStack | (Inherited from Instance.)
 | EnrichWith(EnrichmentHandler<(Of <(T>)>)) | Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller
 | EnrichWith<(Of <(PLUGINTYPE>)>)(EnrichmentHandler<(Of <(PLUGINTYPE>)>)) | Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | findMasterInstance(PluginFamily, String, GraphLog) | (Inherited from Instance.)
 | findPropertyName<(Of <(T>)>)()()() | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | getChild(String, Type, BuildSession) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | getConcreteType(Type) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | getDescription()()() | (Overrides Instance.getDescription()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interceptor | (Inherited from Instance.)
 | InterceptWith(InstanceInterceptor) | Register an InstanceInterceptor with this Instance
 | markBuildStackFinish(BuildSession) | (Inherited from Instance.)
 | markBuildStackStart(BuildSession, Type) | (Inherited from Instance.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | mergeIntoThis(Copyable) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | Name | (Inherited from Instance.)
 | OnCreation(Action<(Of <(T>)>)) | Register an Action to perform on the object created by this Instance before it is returned to the caller
 | preprocess(PluginFamily) | (Inherited from Instance.)
 | replaceNameIfNotAlreadySet(String) | (Inherited from Instance.)
 | setChild(String, Instance) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | setChildArray(String, array<Instance>[]()[]) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | setProperty(String, String) | (Inherited from ConfiguredInstanceBase<(Of <(T>)>).)
 | SetProperty(Action<(Of <(T>)>)) | Set simple setter properties
 | SetterDependency<(Of <(SETTERTYPE>)>)(Expression<(Of <(Func<(Of <(T, SETTERTYPE>)>)>)>)) | Inline definition of a setter dependency. The property name is specified with an Expression
 | SetterDependency<(Of <(SETTERTYPE>)>)()()() | Inline definition of a setter dependency. Only use this method if there is only a single property of the SETTERTYPE
 | TheArrayOf<(Of <(CHILD>)>)()()() | Inline definition of a dependency on an Array of the CHILD type. I.e. CHILD[]. This method can be used for either constructor arguments or setter properties
 | TheArrayOf<(Of <(CHILD>)>)(String) | Inline definition of a dependency on an Array of the CHILD type and the specified setter property or constructor argument name. I.e. CHILD[]. This method can be used for either constructor arguments or setter properties
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | WithCtorArg(String) | Define a primitive constructor argument
 | WithName(String) | Sets the name of this Instance
 | WithProperty(Expression<(Of <(Func<(Of <(T, Object>)>)>)>)) | Define a primitive setter property by specifying the property name with an expression
 | WithProperty(String) | Define a primitive setter property by specifying the property name
Inheritance Hierarchy
Object
 | Instance
 |  | ConfiguredInstanceBase <(Of <(SmartInstance<(Of <(T>)>)>)>)
 |  |  | SmartInstance<(Of <(T>)>)


SmartInstance(T) Constructor

SmartInstance<(Of <(T>)>) Constructor
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► SmartInstance<(Of <(T>)>)()()()
StructureMap API
Initializes a new instance of the SmartInstance<(Of <(T>)>) class
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance()
Public Sub New
public:
SmartInstance()


build Method (pluginType, session)

build Method (pluginType, session)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► build(Type, BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.SmartInstance`1.build(System.Type,StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
protected override Object build(
    Type pluginType,
    BuildSession session
)
Protected Overrides Function build ( _
    pluginType As Type, _
    session As BuildSession _
) As Object
protected:
virtual Object^ build(
    Type^ pluginType,
    BuildSession^ session
) override
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.build(System.Type,StructureMap.BuildSession)"]

session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.build(System.Type,StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.build(System.Type,StructureMap.BuildSession)]


CtorDependency Method

CtorDependency Method
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► CtorDependency()()()
StructureMap API
Members
Icon | Member | Description
 | CtorDependency<(Of <(CTORTYPE>)>)()()() | Inline definition of a constructor dependency. Select the constructor argument by type. Do not use this method if there is more than one constructor arguments of the same type
 | CtorDependency<(Of <(CTORTYPE>)>)(String) | Inline definition of a constructor dependency. Select the constructor argument by type and constructor name. Use this method if there is more than one constructor arguments of the same type


CtorDependency Method

CtorDependency<(Of <(CTORTYPE>)>) Method
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► CtorDependency<(Of <(CTORTYPE>)>)()()()
StructureMap API
Inline definition of a constructor dependency. Select the constructor argument by type. Do not use this method if there is more than one constructor arguments of the same type
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<(Of <(T>)>)..::.DependencyExpression<T, CTORTYPE> CtorDependency<CTORTYPE>()

Public Function CtorDependency(Of CTORTYPE) As SmartInstance<(Of <(T>)>)..::.DependencyExpression(Of T, CTORTYPE)
public:
generic<typename CTORTYPE>
SmartInstance<(Of <(T>)>)..::.DependencyExpression<T, CTORTYPE>^ CtorDependency()
Generic Template Parameters
CTORTYPE

[Missing <typeparam name="CTORTYPE"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.CtorDependency``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.CtorDependency``1]


CtorDependency Method (constructorArg)

CtorDependency<(Of <(CTORTYPE>)>) Method (constructorArg)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► CtorDependency<(Of <(CTORTYPE>)>)(String)
StructureMap API
Inline definition of a constructor dependency. Select the constructor argument by type and constructor name. Use this method if there is more than one constructor arguments of the same type
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<(Of <(T>)>)..::.DependencyExpression<T, CTORTYPE> CtorDependency<CTORTYPE>(
    string constructorArg
)

Public Function CtorDependency(Of CTORTYPE) ( _
    constructorArg As String _
) As SmartInstance<(Of <(T>)>)..::.DependencyExpression(Of T, CTORTYPE)
public:
generic<typename CTORTYPE>
SmartInstance<(Of <(T>)>)..::.DependencyExpression<T, CTORTYPE>^ CtorDependency(
    String^ constructorArg
)
Generic Template Parameters
CTORTYPE

[Missing <typeparam name="CTORTYPE"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.CtorDependency``1(System.String)"]

Parameters
constructorArg (String)

[Missing <param name="constructorArg"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.CtorDependency``1(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.CtorDependency``1(System.String)]


EnrichWith Method

EnrichWith Method
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► EnrichWith()()()
StructureMap API
Members
Icon | Member | Description
 | EnrichWith(EnrichmentHandler<(Of <(T>)>)) | Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller
 | EnrichWith<(Of <(PLUGINTYPE>)>)(EnrichmentHandler<(Of <(PLUGINTYPE>)>)) | Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller


EnrichWith Method (handler)

EnrichWith<(Of <(PLUGINTYPE>)>) Method (handler)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► EnrichWith<(Of <(PLUGINTYPE>)>)(EnrichmentHandler<(Of <(PLUGINTYPE>)>))
StructureMap API
Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<T> EnrichWith<PLUGINTYPE>(
    EnrichmentHandler<PLUGINTYPE> handler
)

Public Function EnrichWith(Of PLUGINTYPE) ( _
    handler As EnrichmentHandler(Of PLUGINTYPE) _
) As SmartInstance(Of T)
public:
generic<typename PLUGINTYPE>
SmartInstance<T>^ EnrichWith(
    EnrichmentHandler<PLUGINTYPE>^ handler
)
Generic Template Parameters
PLUGINTYPE

[Missing <typeparam name="PLUGINTYPE"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.EnrichWith``1(StructureMap.Interceptors.EnrichmentHandler{``0})"]

Parameters
handler (EnrichmentHandler <(Of <(PLUGINTYPE>)>))

[Missing <param name="handler"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.EnrichWith``1(StructureMap.Interceptors.EnrichmentHandler{``0})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.EnrichWith``1(StructureMap.Interceptors.EnrichmentHandler{``0})]


EnrichWith Method (handler)

EnrichWith Method (handler)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► EnrichWith(EnrichmentHandler<(Of <(T>)>))
StructureMap API
Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<T> EnrichWith(
    EnrichmentHandler<T> handler
)
Public Function EnrichWith ( _
    handler As EnrichmentHandler(Of T) _
) As SmartInstance(Of T)
public:
SmartInstance<T>^ EnrichWith(
    EnrichmentHandler<T>^ handler
)
Parameters
handler (EnrichmentHandler <(Of <( T >)>))

[Missing <param name="handler"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.EnrichWith(StructureMap.Interceptors.EnrichmentHandler{`0})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.EnrichWith(StructureMap.Interceptors.EnrichmentHandler{`0})]


getDescription Method

getDescription Method
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► getDescription()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.SmartInstance`1.getDescription]

Declaration Syntax
C# Visual Basic Visual C++
protected override string getDescription()
Protected Overrides Function getDescription As String
protected:
virtual String^ getDescription() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.getDescription]


InterceptWith Method (interceptor)

InterceptWith Method (interceptor)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► InterceptWith(InstanceInterceptor)
StructureMap API
Register an InstanceInterceptor with this Instance
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<T> InterceptWith(
    InstanceInterceptor interceptor
)
Public Function InterceptWith ( _
    interceptor As InstanceInterceptor _
) As SmartInstance(Of T)
public:
SmartInstance<T>^ InterceptWith(
    InstanceInterceptor^ interceptor
)
Parameters
interceptor (InstanceInterceptor)

[Missing <param name="interceptor"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.InterceptWith(StructureMap.Interceptors.InstanceInterceptor)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.InterceptWith(StructureMap.Interceptors.InstanceInterceptor)]


OnCreation Method (handler)

OnCreation Method (handler)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► OnCreation(Action<(Of <(T>)>))
StructureMap API
Register an Action to perform on the object created by this Instance before it is returned to the caller
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<T> OnCreation(
    Action<T> handler
)
Public Function OnCreation ( _
    handler As Action(Of T) _
) As SmartInstance(Of T)
public:
SmartInstance<T>^ OnCreation(
    Action<T>^ handler
)
Parameters
handler (Action <(Of <( T >)>))

[Missing <param name="handler"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.OnCreation(System.Action{`0})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.OnCreation(System.Action{`0})]


SetProperty Method (action)

SetProperty Method (action)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► SetProperty(Action<(Of <(T>)>))
StructureMap API
Set simple setter properties
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<T> SetProperty(
    Action<T> action
)
Public Function SetProperty ( _
    action As Action(Of T) _
) As SmartInstance(Of T)
public:
SmartInstance<T>^ SetProperty(
    Action<T>^ action
)
Parameters
action (Action <(Of <( T >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.SetProperty(System.Action{`0})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.SetProperty(System.Action{`0})]


SetterDependency Method

SetterDependency Method
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► SetterDependency()()()
StructureMap API
Members
Icon | Member | Description
 | SetterDependency<(Of <(SETTERTYPE>)>)(Expression<(Of <(Func<(Of <(T, SETTERTYPE>)>)>)>)) | Inline definition of a setter dependency. The property name is specified with an Expression
 | SetterDependency<(Of <(SETTERTYPE>)>)()()() | Inline definition of a setter dependency. Only use this method if there is only a single property of the SETTERTYPE


SetterDependency Method

SetterDependency<(Of <(SETTERTYPE>)>) Method
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► SetterDependency<(Of <(SETTERTYPE>)>)()()()
StructureMap API
Inline definition of a setter dependency. Only use this method if there is only a single property of the SETTERTYPE
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<(Of <(T>)>)..::.DependencyExpression<T, SETTERTYPE> SetterDependency<SETTERTYPE>()

Public Function SetterDependency(Of SETTERTYPE) As SmartInstance<(Of <(T>)>)..::.DependencyExpression(Of T, SETTERTYPE)
public:
generic<typename SETTERTYPE>
SmartInstance<(Of <(T>)>)..::.DependencyExpression<T, SETTERTYPE>^ SetterDependency()
Generic Template Parameters
SETTERTYPE

[Missing <typeparam name="SETTERTYPE"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.SetterDependency``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.SetterDependency``1]


SetterDependency Method (expression)

SetterDependency<(Of <(SETTERTYPE>)>) Method (expression)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► SetterDependency<(Of <(SETTERTYPE>)>)(Expression<(Of <(Func<(Of <(T, SETTERTYPE>)>)>)>))
StructureMap API
Inline definition of a setter dependency. The property name is specified with an Expression
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<(Of <(T>)>)..::.DependencyExpression<T, SETTERTYPE> SetterDependency<SETTERTYPE>(
    Expression<Func<T, SETTERTYPE>> expression
)

Public Function SetterDependency(Of SETTERTYPE) ( _
    expression As Expression(Of Func(Of T, SETTERTYPE)) _
) As SmartInstance<(Of <(T>)>)..::.DependencyExpression(Of T, SETTERTYPE)
public:
generic<typename SETTERTYPE>
SmartInstance<(Of <(T>)>)..::.DependencyExpression<T, SETTERTYPE>^ SetterDependency(
    Expression<Func<T, SETTERTYPE>^>^ expression
)
Generic Template Parameters
SETTERTYPE

[Missing <typeparam name="SETTERTYPE"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.SetterDependency``1(System.Linq.Expressions.Expression{System.Func{`0,``0}})"]

Parameters
expression (Expression <(Of <( Func <(Of <( T, SETTERTYPE>)>)>)>))

[Missing <param name="expression"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.SetterDependency``1(System.Linq.Expressions.Expression{System.Func{`0,``0}})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.SetterDependency``1(System.Linq.Expressions.Expression{System.Func{`0,``0}})]


TheArrayOf Method

TheArrayOf Method
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► TheArrayOf()()()
StructureMap API
Members
Icon | Member | Description
 | TheArrayOf<(Of <(CHILD>)>)()()() | Inline definition of a dependency on an Array of the CHILD type. I.e. CHILD[]. This method can be used for either constructor arguments or setter properties
 | TheArrayOf<(Of <(CHILD>)>)(String) | Inline definition of a dependency on an Array of the CHILD type and the specified setter property or constructor argument name. I.e. CHILD[]. This method can be used for either constructor arguments or setter properties


TheArrayOf Method

TheArrayOf<(Of <(CHILD>)>) Method
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► TheArrayOf<(Of <(CHILD>)>)()()()
StructureMap API
Inline definition of a dependency on an Array of the CHILD type. I.e. CHILD[]. This method can be used for either constructor arguments or setter properties
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<(Of <(T>)>)..::.ArrayDefinitionExpression<T, CHILD> TheArrayOf<CHILD>()

Public Function TheArrayOf(Of CHILD) As SmartInstance<(Of <(T>)>)..::.ArrayDefinitionExpression(Of T, CHILD)
public:
generic<typename CHILD>
SmartInstance<(Of <(T>)>)..::.ArrayDefinitionExpression<T, CHILD>^ TheArrayOf()
Generic Template Parameters
CHILD

[Missing <typeparam name="CHILD"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.TheArrayOf``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.TheArrayOf``1]


TheArrayOf Method (ctorOrPropertyName)

TheArrayOf<(Of <(CHILD>)>) Method (ctorOrPropertyName)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► TheArrayOf<(Of <(CHILD>)>)(String)
StructureMap API
Inline definition of a dependency on an Array of the CHILD type and the specified setter property or constructor argument name. I.e. CHILD[]. This method can be used for either constructor arguments or setter properties
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<(Of <(T>)>)..::.ArrayDefinitionExpression<T, CHILD> TheArrayOf<CHILD>(
    string ctorOrPropertyName
)

Public Function TheArrayOf(Of CHILD) ( _
    ctorOrPropertyName As String _
) As SmartInstance<(Of <(T>)>)..::.ArrayDefinitionExpression(Of T, CHILD)
public:
generic<typename CHILD>
SmartInstance<(Of <(T>)>)..::.ArrayDefinitionExpression<T, CHILD>^ TheArrayOf(
    String^ ctorOrPropertyName
)
Generic Template Parameters
CHILD

[Missing <typeparam name="CHILD"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.TheArrayOf``1(System.String)"]

Parameters
ctorOrPropertyName (String)

[Missing <param name="ctorOrPropertyName"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.TheArrayOf``1(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.TheArrayOf``1(System.String)]


WithCtorArg Method (argumentName)

WithCtorArg Method (argumentName)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► WithCtorArg(String)
StructureMap API
Define a primitive constructor argument
Declaration Syntax
C# Visual Basic Visual C++
public PropertyExpression<SmartInstance<T>> WithCtorArg(
    string argumentName
)
Public Function WithCtorArg ( _
    argumentName As String _
) As PropertyExpression(Of SmartInstance(Of T))
public:
PropertyExpression<SmartInstance<T>^>^ WithCtorArg(
    String^ argumentName
)
Parameters
argumentName (String)

[Missing <param name="argumentName"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.WithCtorArg(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.WithCtorArg(System.String)]


WithName Method (instanceKey)

WithName Method (instanceKey)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► WithName(String)
StructureMap API
Sets the name of this Instance
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<T> WithName(
    string instanceKey
)
Public Function WithName ( _
    instanceKey As String _
) As SmartInstance(Of T)
public:
SmartInstance<T>^ WithName(
    String^ instanceKey
)
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.WithName(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.WithName(System.String)]


WithProperty Method

WithProperty Method
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► WithProperty()()()
StructureMap API
Members
Icon | Member | Description
 | WithProperty(Expression<(Of <(Func<(Of <(T, Object>)>)>)>)) | Define a primitive setter property by specifying the property name with an expression
 | WithProperty(String) | Define a primitive setter property by specifying the property name


WithProperty Method (expression)

WithProperty Method (expression)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► WithProperty(Expression<(Of <(Func<(Of <(T, Object>)>)>)>))
StructureMap API
Define a primitive setter property by specifying the property name with an expression
Declaration Syntax
C# Visual Basic Visual C++
public PropertyExpression<SmartInstance<T>> WithProperty(
    Expression<Func<T, Object>> expression
)
Public Function WithProperty ( _
    expression As Expression(Of Func(Of T, Object)) _
) As PropertyExpression(Of SmartInstance(Of T))
public:
PropertyExpression<SmartInstance<T>^>^ WithProperty(
    Expression<Func<T, Object^>^>^ expression
)
Parameters
expression (Expression <(Of <( Func <(Of <( T, Object >)>)>)>))

[Missing <param name="expression"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.WithProperty(System.Linq.Expressions.Expression{System.Func{`0,System.Object}})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.WithProperty(System.Linq.Expressions.Expression{System.Func{`0,System.Object}})]


WithProperty Method (propertyName)

WithProperty Method (propertyName)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► WithProperty(String)
StructureMap API
Define a primitive setter property by specifying the property name
Declaration Syntax
C# Visual Basic Visual C++
public PropertyExpression<SmartInstance<T>> WithProperty(
    string propertyName
)
Public Function WithProperty ( _
    propertyName As String _
) As PropertyExpression(Of SmartInstance(Of T))
public:
PropertyExpression<SmartInstance<T>^>^ WithProperty(
    String^ propertyName
)
Parameters
propertyName (String)

[Missing <param name="propertyName"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.WithProperty(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.WithProperty(System.String)]


SmartInstance(T).ArrayDefinitionExpression(T, ARRAY) Class

SmartInstance<(Of <(T>)>)..::.ArrayDefinitionExpression<(Of <(T, ARRAY>)>) Class
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► SmartInstance<(Of <(T>)>)..::.ArrayDefinitionExpression<(Of <(T, ARRAY>)>)
StructureMap API
Expression Builder to help define multiple Instances for an Array dependency
Declaration Syntax
C# Visual Basic Visual C++
public class ArrayDefinitionExpression<T, ARRAY>

Public Class ArrayDefinitionExpression(Of T, ARRAY)
generic<typename T, typename ARRAY>
public ref class ArrayDefinitionExpression
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:StructureMap.Pipeline.SmartInstance`1.ArrayDefinitionExpression`2"]

ARRAY

[Missing <typeparam name="ARRAY"/> documentation for "T:StructureMap.Pipeline.SmartInstance`1.ArrayDefinitionExpression`2"]

Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Contains(Action<(Of <(IInstanceExpression<(Of <(UTT>)>)>)>)) | Nested Closure that allows you to add an unlimited number of child Instances
 | Contains(array<Instance>[]()[]) | Specify an array of Instance objects directly for an Array dependency
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SmartInstance<(Of <(T>)>)..::.ArrayDefinitionExpression<(Of <(T, ARRAY>)>)


Contains Method

Contains Method
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>)..::.ArrayDefinitionExpression<(Of <(T, ARRAY>)>) ► Contains()()()
StructureMap API
Members
Icon | Member | Description
 | Contains(Action<(Of <(IInstanceExpression<(Of <(UTT>)>)>)>)) | Nested Closure that allows you to add an unlimited number of child Instances
 | Contains(array<Instance>[]()[]) | Specify an array of Instance objects directly for an Array dependency


Contains Method (arrayInstances)

Contains Method (arrayInstances)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>)..::.ArrayDefinitionExpression<(Of <(T, ARRAY>)>) ► Contains(array<Instance>[]()[])
StructureMap API
Specify an array of Instance objects directly for an Array dependency
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<T> Contains(
    params Instance[] arrayInstances
)
Public Function Contains ( _
    ParamArray arrayInstances As Instance() _
) As SmartInstance(Of T)
public:
SmartInstance<T>^ Contains(
    ... array<Instance^>^ arrayInstances
)
Parameters
arrayInstances (array< Instance >[]()[])

[Missing <param name="arrayInstances"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.ArrayDefinitionExpression`2.Contains(StructureMap.Pipeline.Instance[])"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.ArrayDefinitionExpression`2.Contains(StructureMap.Pipeline.Instance[])]


Contains Method (action)

Contains Method (action)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>)..::.ArrayDefinitionExpression<(Of <(T, ARRAY>)>) ► Contains(Action<(Of <(IInstanceExpression<(Of <(UTT>)>)>)>))
StructureMap API
Nested Closure that allows you to add an unlimited number of child Instances
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<T> Contains(
    Action<IInstanceExpression<ARRAY>> action
)
Public Function Contains ( _
    action As Action(Of IInstanceExpression(Of ARRAY)) _
) As SmartInstance(Of T)
public:
SmartInstance<T>^ Contains(
    Action<IInstanceExpression<ARRAY>^>^ action
)
Parameters
action (Action <(Of <( IInstanceExpression <(Of <( ARRAY >)>)>)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.ArrayDefinitionExpression`2.Contains(System.Action{StructureMap.Configuration.DSL.Expressions.IInstanceExpression{`2}})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.ArrayDefinitionExpression`2.Contains(System.Action{StructureMap.Configuration.DSL.Expressions.IInstanceExpression{`2}})]


SmartInstance(T).DependencyExpression(T, CHILD) Class

SmartInstance<(Of <(T>)>)..::.DependencyExpression<(Of <(T, CHILD>)>) Class
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>) ► SmartInstance<(Of <(T>)>)..::.DependencyExpression<(Of <(T, CHILD>)>)
StructureMap API
Expression Builder that helps to define child dependencies inline
Declaration Syntax
C# Visual Basic Visual C++
public class DependencyExpression<T, CHILD>

Public Class DependencyExpression(Of T, CHILD)
generic<typename T, typename CHILD>
public ref class DependencyExpression
Generic Template Parameters
T

[Missing <typeparam name="T"/> documentation for "T:StructureMap.Pipeline.SmartInstance`1.DependencyExpression`2"]

CHILD

[Missing <typeparam name="CHILD"/> documentation for "T:StructureMap.Pipeline.SmartInstance`1.DependencyExpression`2"]

Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Is(Action<(Of <(IInstanceExpression<(Of <(UTT>)>)>)>)) | Nested Closure to define a child dependency inline
 | Is(Instance) | Shortcut to set an inline dependency to an Instance
 | Is(UTT) | Shortcut to set an inline dependency to a designated object
 | Is<(Of <(CONCRETETYPE>)>)()()() | Shortcut method to define a child dependency inline
 | IsTheDefault()()() | Set an Inline dependency to the Default Instance of the Property type Used mostly to force an optional Setter property to be filled by StructureMap
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
SmartInstance<(Of <(T>)>)..::.DependencyExpression<(Of <(T, CHILD>)>)


Is Method

Is Method
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>)..::.DependencyExpression<(Of <(T, CHILD>)>) ► Is()()()
StructureMap API
Members
Icon | Member | Description
 | Is(Action<(Of <(IInstanceExpression<(Of <(UTT>)>)>)>)) | Nested Closure to define a child dependency inline
 | Is(Instance) | Shortcut to set an inline dependency to an Instance
 | Is(UTT) | Shortcut to set an inline dependency to a designated object
 | Is<(Of <(CONCRETETYPE>)>)()()() | Shortcut method to define a child dependency inline


Is Method

Is<(Of <(CONCRETETYPE>)>) Method
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>)..::.DependencyExpression<(Of <(T, CHILD>)>) ► Is<(Of <(CONCRETETYPE>)>)()()()
StructureMap API
Shortcut method to define a child dependency inline
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<T> Is<CONCRETETYPE>()
where CONCRETETYPE :

Public Function Is(Of CONCRETETYPE As ) As SmartInstance(Of T)
public:
generic<typename CONCRETETYPE>
where CONCRETETYPE :
SmartInstance<T>^ Is()
Generic Template Parameters
CONCRETETYPE

[Missing <typeparam name="CONCRETETYPE"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.DependencyExpression`2.Is``1"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.DependencyExpression`2.Is``1]


Is Method (instance)

Is Method (instance)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>)..::.DependencyExpression<(Of <(T, CHILD>)>) ► Is(Instance)
StructureMap API
Shortcut to set an inline dependency to an Instance
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<T> Is(
    Instance instance
)
Public Function Is ( _
    instance As Instance _
) As SmartInstance(Of T)
public:
SmartInstance<T>^ Is(
    Instance^ instance
)
Parameters
instance (Instance)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.DependencyExpression`2.Is(StructureMap.Pipeline.Instance)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.DependencyExpression`2.Is(StructureMap.Pipeline.Instance)]


Is Method (action)

Is Method (action)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>)..::.DependencyExpression<(Of <(T, CHILD>)>) ► Is(Action<(Of <(IInstanceExpression<(Of <(UTT>)>)>)>))
StructureMap API
Nested Closure to define a child dependency inline
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<T> Is(
    Action<IInstanceExpression<CHILD>> action
)
Public Function Is ( _
    action As Action(Of IInstanceExpression(Of CHILD)) _
) As SmartInstance(Of T)
public:
SmartInstance<T>^ Is(
    Action<IInstanceExpression<CHILD>^>^ action
)
Parameters
action (Action <(Of <( IInstanceExpression <(Of <( CHILD >)>)>)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.DependencyExpression`2.Is(System.Action{StructureMap.Configuration.DSL.Expressions.IInstanceExpression{`2}})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.DependencyExpression`2.Is(System.Action{StructureMap.Configuration.DSL.Expressions.IInstanceExpression{`2}})]


Is Method (value)

Is Method (value)
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>)..::.DependencyExpression<(Of <(T, CHILD>)>) ► Is(UTT)
StructureMap API
Shortcut to set an inline dependency to a designated object
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<T> Is(
    CHILD value
)
Public Function Is ( _
    value As CHILD _
) As SmartInstance(Of T)
public:
SmartInstance<T>^ Is(
    CHILD value
)
Parameters
value (CHILD)

[Missing <param name="value"/> documentation for "M:StructureMap.Pipeline.SmartInstance`1.DependencyExpression`2.Is(`2)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.DependencyExpression`2.Is(`2)]


IsTheDefault Method

IsTheDefault Method
Namespaces ► StructureMap.Pipeline ► SmartInstance<(Of <(T>)>)..::.DependencyExpression<(Of <(T, CHILD>)>) ► IsTheDefault()()()
StructureMap API
Set an Inline dependency to the Default Instance of the Property type Used mostly to force an optional Setter property to be filled by StructureMap
Declaration Syntax
C# Visual Basic Visual C++
public SmartInstance<T> IsTheDefault()
Public Function IsTheDefault As SmartInstance(Of T)
public:
SmartInstance<T>^ IsTheDefault()
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.SmartInstance`1.DependencyExpression`2.IsTheDefault]


ThreadLocalStoragePolicy Class

ThreadLocalStoragePolicy Class
Namespaces ► StructureMap.Pipeline ► ThreadLocalStoragePolicy
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.ThreadLocalStoragePolicy]

Declaration Syntax
C# Visual Basic Visual C++
public class ThreadLocalStoragePolicy : CacheInterceptor
Public Class ThreadLocalStoragePolicy _
    Inherits CacheInterceptor
public ref class ThreadLocalStoragePolicy : public CacheInterceptor
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | ThreadLocalStoragePolicy()()() | Initializes a new instance of the ThreadLocalStoragePolicy class
 | Build(BuildSession, Type, Instance) | (Inherited from CacheInterceptor.)
 | clone()()() | (Overrides CacheInterceptor.clone()()().)
 | Clone()()() | (Inherited from CacheInterceptor.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | InnerPolicy | (Inherited from CacheInterceptor.)
 | isCached(String, Type) | (Overrides CacheInterceptor.isCached(String, Type).)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | retrieveFromCache(String, Type) | (Overrides CacheInterceptor.retrieveFromCache(String, Type).)
 | storeInCache(String, Type, Object) | (Overrides CacheInterceptor.storeInCache(String, Type, Object).)
 | ToString()()() | (Inherited from CacheInterceptor.)
Inheritance Hierarchy
Object
 | CacheInterceptor
 |  | ThreadLocalStoragePolicy


ThreadLocalStoragePolicy Constructor

ThreadLocalStoragePolicy Constructor
Namespaces ► StructureMap.Pipeline ► ThreadLocalStoragePolicy ► ThreadLocalStoragePolicy()()()
StructureMap API
Initializes a new instance of the ThreadLocalStoragePolicy class
Declaration Syntax
C# Visual Basic Visual C++
public ThreadLocalStoragePolicy()
Public Sub New
public:
ThreadLocalStoragePolicy()


clone Method

clone Method
Namespaces ► StructureMap.Pipeline ► ThreadLocalStoragePolicy ► clone()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ThreadLocalStoragePolicy.clone]

Declaration Syntax
C# Visual Basic Visual C++
protected override CacheInterceptor clone()
Protected Overrides Function clone As CacheInterceptor
protected:
virtual CacheInterceptor^ clone() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ThreadLocalStoragePolicy.clone]


isCached Method (instanceKey, pluginType)

isCached Method (instanceKey, pluginType)
Namespaces ► StructureMap.Pipeline ► ThreadLocalStoragePolicy ► isCached(String, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ThreadLocalStoragePolicy.isCached(System.String,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected override bool isCached(
    string instanceKey,
    Type pluginType
)
Protected Overrides Function isCached ( _
    instanceKey As String, _
    pluginType As Type _
) As Boolean
protected:
virtual bool isCached(
    String^ instanceKey,
    Type^ pluginType
) override
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.ThreadLocalStoragePolicy.isCached(System.String,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ThreadLocalStoragePolicy.isCached(System.String,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ThreadLocalStoragePolicy.isCached(System.String,System.Type)]


retrieveFromCache Method (instanceKey, pluginType)

retrieveFromCache Method (instanceKey, pluginType)
Namespaces ► StructureMap.Pipeline ► ThreadLocalStoragePolicy ► retrieveFromCache(String, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ThreadLocalStoragePolicy.retrieveFromCache(System.String,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
protected override Object retrieveFromCache(
    string instanceKey,
    Type pluginType
)
Protected Overrides Function retrieveFromCache ( _
    instanceKey As String, _
    pluginType As Type _
) As Object
protected:
virtual Object^ retrieveFromCache(
    String^ instanceKey,
    Type^ pluginType
) override
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.ThreadLocalStoragePolicy.retrieveFromCache(System.String,System.Type)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ThreadLocalStoragePolicy.retrieveFromCache(System.String,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.ThreadLocalStoragePolicy.retrieveFromCache(System.String,System.Type)]


storeInCache Method (instanceKey, pluginType, instance)

storeInCache Method (instanceKey, pluginType, instance)
Namespaces ► StructureMap.Pipeline ► ThreadLocalStoragePolicy ► storeInCache(String, Type, Object)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.ThreadLocalStoragePolicy.storeInCache(System.String,System.Type,System.Object)]

Declaration Syntax
C# Visual Basic Visual C++
protected override void storeInCache(
    string instanceKey,
    Type pluginType,
    Object instance
)
Protected Overrides Sub storeInCache ( _
    instanceKey As String, _
    pluginType As Type, _
    instance As Object _
)
protected:
virtual void storeInCache(
    String^ instanceKey,
    Type^ pluginType,
    Object^ instance
) override
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Pipeline.ThreadLocalStoragePolicy.storeInCache(System.String,System.Type,System.Object)"]

pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.ThreadLocalStoragePolicy.storeInCache(System.String,System.Type,System.Object)"]

instance (Object)

[Missing <param name="instance"/> documentation for "M:StructureMap.Pipeline.ThreadLocalStoragePolicy.storeInCache(System.String,System.Type,System.Object)"]


TypeExtensions Class

TypeExtensions Class
Namespaces ► StructureMap.Pipeline ► TypeExtensions
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.TypeExtensions]

Declaration Syntax
C# Visual Basic Visual C++
public static class TypeExtensions
Public NotInheritable Class TypeExtensions
public ref class TypeExtensions abstract sealed
Members
All Members | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | GetReferenceTo(Type) |
Inheritance Hierarchy
Object
TypeExtensions


GetReferenceTo Method (type)

GetReferenceTo Method (type)
Namespaces ► StructureMap.Pipeline ► TypeExtensions ► GetReferenceTo(Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.TypeExtensions.GetReferenceTo(System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public static ReferencedInstance GetReferenceTo(
    Type type
)
Public Shared Function GetReferenceTo ( _
    type As Type _
) As ReferencedInstance
public:
static ReferencedInstance^ GetReferenceTo(
    Type^ type
)
Parameters
type (Type)

[Missing <param name="type"/> documentation for "M:StructureMap.Pipeline.TypeExtensions.GetReferenceTo(System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.TypeExtensions.GetReferenceTo(System.Type)]


UserControlInstance Class

UserControlInstance Class
Namespaces ► StructureMap.Pipeline ► UserControlInstance
StructureMap API

[Missing <summary> documentation for T:StructureMap.Pipeline.UserControlInstance]

Declaration Syntax
C# Visual Basic Visual C++
public class UserControlInstance : ExpressedInstance<UserControlInstance>
Public Class UserControlInstance _
    Inherits ExpressedInstance(Of UserControlInstance)
public ref class UserControlInstance : public ExpressedInstance<UserControlInstance^>
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | UserControlInstance(String) | Initializes a new instance of the UserControlInstance class
 | addTemplatedInstanceTo(PluginFamily, array<Type>[]()[]) | (Inherited from Instance.)
 | build(Type, BuildSession) | (Overrides Instance.build(Type, BuildSession).)
 | Build(Type, BuildSession) | (Inherited from Instance.)
 | canBePartOfPluginFamily(PluginFamily) | (Inherited from Instance.)
 | doesRecordOnTheStack | (Inherited from Instance.)
 | EnrichWith<(Of <(TYPE>)>)(EnrichmentHandler<(Of <(TYPE>)>)) | Register a Func to potentially enrich or substitute for the object created by this Instance before it is returned to the caller (Inherited from ExpressedInstance<(Of <(T>)>).)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | findMasterInstance(PluginFamily, String, GraphLog) | (Inherited from Instance.)
 | getConcreteType(Type) | (Inherited from Instance.)
 | getDescription()()() | (Overrides Instance.getDescription()()().)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Interceptor | (Inherited from Instance.)
 | InterceptWith(InstanceInterceptor) | Register an InstanceInterceptor with this Instance (Inherited from ExpressedInstance<(Of <(T>)>).)
 | markBuildStackFinish(BuildSession) | (Inherited from Instance.)
 | markBuildStackStart(BuildSession, Type) | (Inherited from Instance.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Name | (Inherited from Instance.)
 | OnCreation<(Of <(TYPE>)>)(Action<(Of <(TYPE>)>)) | Register an Action to perform on the object created by this Instance before it is returned to the caller (Inherited from ExpressedInstance<(Of <(T>)>).)
 | preprocess(PluginFamily) | (Inherited from Instance.)
 | replaceNameIfNotAlreadySet(String) | (Inherited from Instance.)
 | thisInstance | (Overrides ExpressedInstance <(Of <(UserControlInstance>)>).thisInstance.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Url |
 | WithName(String) | Set the name of this Instance (Inherited from ExpressedInstance<(Of <(T>)>).)
Inheritance Hierarchy
Object
 | Instance
 |  | ExpressedInstance <(Of <(UserControlInstance>)>)
 |  |  | UserControlInstance


UserControlInstance Constructor (url)

UserControlInstance Constructor (url)
Namespaces ► StructureMap.Pipeline ► UserControlInstance ► UserControlInstance(String)
StructureMap API
Initializes a new instance of the UserControlInstance class
Declaration Syntax
C# Visual Basic Visual C++
public UserControlInstance(
    string url
)
Public Sub New ( _
    url As String _
)
public:
UserControlInstance(
    String^ url
)
Parameters
url (String)

[Missing <param name="url"/> documentation for "M:StructureMap.Pipeline.UserControlInstance.#ctor(System.String)"]


build Method (pluginType, session)

build Method (pluginType, session)
Namespaces ► StructureMap.Pipeline ► UserControlInstance ► build(Type, BuildSession)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.UserControlInstance.build(System.Type,StructureMap.BuildSession)]

Declaration Syntax
C# Visual Basic Visual C++
protected override Object build(
    Type pluginType,
    BuildSession session
)
Protected Overrides Function build ( _
    pluginType As Type, _
    session As BuildSession _
) As Object
protected:
virtual Object^ build(
    Type^ pluginType,
    BuildSession^ session
) override
Parameters
pluginType (Type)

[Missing <param name="pluginType"/> documentation for "M:StructureMap.Pipeline.UserControlInstance.build(System.Type,StructureMap.BuildSession)"]

session (BuildSession)

[Missing <param name="session"/> documentation for "M:StructureMap.Pipeline.UserControlInstance.build(System.Type,StructureMap.BuildSession)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.UserControlInstance.build(System.Type,StructureMap.BuildSession)]


getDescription Method

getDescription Method
Namespaces ► StructureMap.Pipeline ► UserControlInstance ► getDescription()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Pipeline.UserControlInstance.getDescription]

Declaration Syntax
C# Visual Basic Visual C++
protected override string getDescription()
Protected Overrides Function getDescription As String
protected:
virtual String^ getDescription() override
Return Value

[Missing <returns> documentation for M:StructureMap.Pipeline.UserControlInstance.getDescription]


thisInstance Property

thisInstance Property
Namespaces ► StructureMap.Pipeline ► UserControlInstance ► thisInstance
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.UserControlInstance.thisInstance]

Declaration Syntax
C# Visual Basic Visual C++
protected override UserControlInstance thisInstance { get; }
Protected Overrides ReadOnly Property thisInstance As UserControlInstance
protected:
virtual property UserControlInstance^ thisInstance {
    UserControlInstance^ get () override;
}


Url Property

Url Property
Namespaces ► StructureMap.Pipeline ► UserControlInstance ► Url
StructureMap API

[Missing <summary> documentation for P:StructureMap.Pipeline.UserControlInstance.Url]

Declaration Syntax
C# Visual Basic Visual C++
public string Url { get; }
Public ReadOnly Property Url As String
public:
property String^ Url {
    String^ get ();
}


StructureMap.Source Namespace

StructureMap.Source Namespace
Namespaces ► StructureMap.Source
StructureMap API

[Missing <summary> documentation for N:StructureMap.Source]

Declaration Syntax
C# Visual Basic Visual C++
namespace StructureMap.Source
Namespace StructureMap.Source
namespace StructureMap.Source
Types
All Types Classes Enumerations
Icon | Type | Description
 | BasicXmlMementoSource | Generic implementation of an XmlMementoSource
 | DirectoryXmlMementoSource | Implementation of MementoSource that stores and retrieves an XmlInstanceMemento per file in a named directory. DirectoryXmlMementoSource is meant to simplify complicated object graph configurations by isolating each instance to a separate editable file.
 | EmbeddedFolderXmlMementoSource |
 | MementoSourceType |
 | MemoryMementoSource | An in-memory MementoSource
 | SingleEmbeddedXmlMementoSource |
 | TemplatedMementoSource |
 | XmlAttributeFileMementoSource | Stores Attribute-normalized InstanceMemento's in an external file
 | XmlAttributeInstanceMemento | An implementation of InstanceMemento that stores properties as Xml attributes Limited functionality
 | XmlFileMementoSource | Implementation of XmlMementoSource that reads InstanceMemento's from an external file. Useful to break the StructureMap.config file into smaller pieces.
 | XmlMementoCreator |
 | XmlMementoSource | Base class for all MementoSource classes that store InstanceMemento's as node-normalized Xml
 | XmlMementoStyle |
 | XmlNodeInstanceMemento | Implementation of InstanceMemento that stores information in a node-normalized Xml format.
 | XmlTemplater |


BasicXmlMementoSource Class

BasicXmlMementoSource Class
Namespaces ► StructureMap.Source ► BasicXmlMementoSource
StructureMap API
Generic implementation of an XmlMementoSource
Declaration Syntax
C# Visual Basic Visual C++
public class BasicXmlMementoSource : XmlMementoSource
Public Class BasicXmlMementoSource _
    Inherits XmlMementoSource
public ref class BasicXmlMementoSource : public XmlMementoSource
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | BasicXmlMementoSource(XmlNode, String) | Initializes a new instance of the BasicXmlMementoSource class
 | containsKey(String) | (Inherited from XmlMementoSource.)
 | createMemento(XmlNode) | (Inherited from XmlMementoSource.)
 | DefaultMemento | (Inherited from MementoSource.)
 | Description | (Overrides MementoSource.Description.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Family | (Inherited from MementoSource.)
 | fetchInternalMementos()()() | (Inherited from XmlMementoSource.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllMementos()()() | Retrieves an array of all InstanceMemento's stored by this MementoSource (Inherited from MementoSource.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMemento(String) | Retrieves the named InstanceMemento (Inherited from MementoSource.)
 | getRootNode()()() | (Overrides XmlMementoSource.getRootNode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | KeyAttribute | (Inherited from XmlMementoSource.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NodeName | (Inherited from XmlMementoSource.)
 | ResolveMemento(InstanceMemento) | (Inherited from MementoSource.)
 | retrieveMemento(String) | (Inherited from XmlMementoSource.)
 | SourceType | The type of MementoSource (Inherited from MementoSource.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeAttribute | (Inherited from XmlMementoSource.)
Inheritance Hierarchy
Object
 | MementoSource
 |  | XmlMementoSource
 |  |  | BasicXmlMementoSource


BasicXmlMementoSource Constructor (Node, NodeName)

BasicXmlMementoSource Constructor (Node, NodeName)
Namespaces ► StructureMap.Source ► BasicXmlMementoSource ► BasicXmlMementoSource(XmlNode, String)
StructureMap API
Initializes a new instance of the BasicXmlMementoSource class
Declaration Syntax
C# Visual Basic Visual C++
public BasicXmlMementoSource(
    XmlNode Node,
    string NodeName
)
Public Sub New ( _
    Node As XmlNode, _
    NodeName As String _
)
public:
BasicXmlMementoSource(
    XmlNode^ Node,
    String^ NodeName
)
Parameters
Node (XmlNode)

[Missing <param name="Node"/> documentation for "M:StructureMap.Source.BasicXmlMementoSource.#ctor(System.Xml.XmlNode,System.String)"]

NodeName (String)

[Missing <param name="NodeName"/> documentation for "M:StructureMap.Source.BasicXmlMementoSource.#ctor(System.Xml.XmlNode,System.String)"]


Description Property

Description Property
Namespaces ► StructureMap.Source ► BasicXmlMementoSource ► Description
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.BasicXmlMementoSource.Description]

Declaration Syntax
C# Visual Basic Visual C++
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () override;
}


getRootNode Method

getRootNode Method
Namespaces ► StructureMap.Source ► BasicXmlMementoSource ► getRootNode()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.BasicXmlMementoSource.getRootNode]

Declaration Syntax
C# Visual Basic Visual C++
protected override XmlNode getRootNode()
Protected Overrides Function getRootNode As XmlNode
protected:
virtual XmlNode^ getRootNode() override
Return Value

[Missing <returns> documentation for M:StructureMap.Source.BasicXmlMementoSource.getRootNode]


DirectoryXmlMementoSource Class

DirectoryXmlMementoSource Class
Namespaces ► StructureMap.Source ► DirectoryXmlMementoSource
StructureMap API
Implementation of MementoSource that stores and retrieves an XmlInstanceMemento per file in a named directory. DirectoryXmlMementoSource is meant to simplify complicated object graph configurations by isolating each instance to a separate editable file.
Declaration Syntax
C# Visual Basic Visual C++
public class DirectoryXmlMementoSource : MementoSource
Public Class DirectoryXmlMementoSource _
    Inherits MementoSource
public ref class DirectoryXmlMementoSource : public MementoSource
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | DirectoryXmlMementoSource(String, String, XmlMementoStyle) | Stores an Xml InstanceMemento per file in a directory
 | containsKey(String) | (Overrides MementoSource.containsKey(String).)
 | createMemento(XmlDocument) |
 | DefaultMemento | (Inherited from MementoSource.)
 | Description | (Overrides MementoSource.Description.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Family | (Inherited from MementoSource.)
 | fetchInternalMementos()()() | (Overrides MementoSource.fetchInternalMementos()()().)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllMementos()()() | Retrieves an array of all InstanceMemento's stored by this MementoSource (Inherited from MementoSource.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMemento(String) | Retrieves the named InstanceMemento (Inherited from MementoSource.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveMemento(InstanceMemento) | (Inherited from MementoSource.)
 | retrieveMemento(String) | (Overrides MementoSource.retrieveMemento(String).)
 | SourceType | (Overrides MementoSource.SourceType.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | Validate()()() |
Inheritance Hierarchy
Object
 | MementoSource
 |  | DirectoryXmlMementoSource


DirectoryXmlMementoSource Constructor (directory, extension, mementoStyle)

DirectoryXmlMementoSource Constructor (directory, extension, mementoStyle)
Namespaces ► StructureMap.Source ► DirectoryXmlMementoSource ► DirectoryXmlMementoSource(String, String, XmlMementoStyle)
StructureMap API
Stores an Xml InstanceMemento per file in a directory
Declaration Syntax
C# Visual Basic Visual C++
public DirectoryXmlMementoSource(
    string directory,
    string extension,
    XmlMementoStyle mementoStyle
)
Public Sub New ( _
    directory As String, _
    extension As String, _
    mementoStyle As XmlMementoStyle _
)
public:
DirectoryXmlMementoSource(
    String^ directory,
    String^ extension,
    XmlMementoStyle mementoStyle
)
Parameters
directory (String)
A ";" delimited list of directories to look for mementos. DirectoryXmlMementoSource will use the FIRST directory it finds
extension (String)
The file extension of the InstanceMemento files without a dot. Typically "xml"
mementoStyle (XmlMementoStyle)
NodeNormalized or AttributeNormalized


containsKey Method (instanceKey)

containsKey Method (instanceKey)
Namespaces ► StructureMap.Source ► DirectoryXmlMementoSource ► containsKey(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.DirectoryXmlMementoSource.containsKey(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected internal override bool containsKey(
    string instanceKey
)
Protected Friend Overrides Function containsKey ( _
    instanceKey As String _
) As Boolean
protected public:
virtual bool containsKey(
    String^ instanceKey
) override
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Source.DirectoryXmlMementoSource.containsKey(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.DirectoryXmlMementoSource.containsKey(System.String)]


createMemento Method (doc)

createMemento Method (doc)
Namespaces ► StructureMap.Source ► DirectoryXmlMementoSource ► createMemento(XmlDocument)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.DirectoryXmlMementoSource.createMemento(System.Xml.XmlDocument)]

Declaration Syntax
C# Visual Basic Visual C++
protected virtual InstanceMemento createMemento(
    XmlDocument doc
)
Protected Overridable Function createMemento ( _
    doc As XmlDocument _
) As InstanceMemento
protected:
virtual InstanceMemento^ createMemento(
    XmlDocument^ doc
)
Parameters
doc (XmlDocument)

[Missing <param name="doc"/> documentation for "M:StructureMap.Source.DirectoryXmlMementoSource.createMemento(System.Xml.XmlDocument)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.DirectoryXmlMementoSource.createMemento(System.Xml.XmlDocument)]


Description Property

Description Property
Namespaces ► StructureMap.Source ► DirectoryXmlMementoSource ► Description
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.DirectoryXmlMementoSource.Description]

Declaration Syntax
C# Visual Basic Visual C++
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () override;
}


fetchInternalMementos Method

fetchInternalMementos Method
Namespaces ► StructureMap.Source ► DirectoryXmlMementoSource ► fetchInternalMementos()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.DirectoryXmlMementoSource.fetchInternalMementos]

Declaration Syntax
C# Visual Basic Visual C++
protected override InstanceMemento[] fetchInternalMementos()
Protected Overrides Function fetchInternalMementos As InstanceMemento()
protected:
virtual array<InstanceMemento^>^ fetchInternalMementos() override
Return Value

[Missing <returns> documentation for M:StructureMap.Source.DirectoryXmlMementoSource.fetchInternalMementos]


retrieveMemento Method (instanceKey)

retrieveMemento Method (instanceKey)
Namespaces ► StructureMap.Source ► DirectoryXmlMementoSource ► retrieveMemento(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.DirectoryXmlMementoSource.retrieveMemento(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected override InstanceMemento retrieveMemento(
    string instanceKey
)
Protected Overrides Function retrieveMemento ( _
    instanceKey As String _
) As InstanceMemento
protected:
virtual InstanceMemento^ retrieveMemento(
    String^ instanceKey
) override
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Source.DirectoryXmlMementoSource.retrieveMemento(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.DirectoryXmlMementoSource.retrieveMemento(System.String)]


SourceType Property

SourceType Property
Namespaces ► StructureMap.Source ► DirectoryXmlMementoSource ► SourceType
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.DirectoryXmlMementoSource.SourceType]

Declaration Syntax
C# Visual Basic Visual C++
public override MementoSourceType SourceType { get; }
Public Overrides ReadOnly Property SourceType As MementoSourceType
public:
virtual property MementoSourceType SourceType {
    MementoSourceType get () override;
}


Validate Method

Validate Method
Namespaces ► StructureMap.Source ► DirectoryXmlMementoSource ► Validate()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.DirectoryXmlMementoSource.Validate]

Declaration Syntax
C# Visual Basic Visual C++
public void Validate()
Public Sub Validate
public:
void Validate()


EmbeddedFolderXmlMementoSource Class

EmbeddedFolderXmlMementoSource Class
Namespaces ► StructureMap.Source ► EmbeddedFolderXmlMementoSource
StructureMap API

[Missing <summary> documentation for T:StructureMap.Source.EmbeddedFolderXmlMementoSource]

Declaration Syntax
C# Visual Basic Visual C++
public class EmbeddedFolderXmlMementoSource : MementoSource
Public Class EmbeddedFolderXmlMementoSource _
    Inherits MementoSource
public ref class EmbeddedFolderXmlMementoSource : public MementoSource
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | EmbeddedFolderXmlMementoSource(XmlMementoStyle, String, String, String) | Implementation of MementoSource that stores and retrieves an XmlInstanceMemento per Embedded Resource file in a named namespace. EmbeddedFolderXmlMementoSource is meant to simplify complicated object graph configurations by isolating each instance to a separate editable file.
 | containsKey(String) | (Overrides MementoSource.containsKey(String).)
 | DefaultMemento | (Inherited from MementoSource.)
 | Description | (Overrides MementoSource.Description.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Family | (Inherited from MementoSource.)
 | fetchInternalMementos()()() | (Overrides MementoSource.fetchInternalMementos()()().)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllMementos()()() | Retrieves an array of all InstanceMemento's stored by this MementoSource (Inherited from MementoSource.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMemento(String) | Retrieves the named InstanceMemento (Inherited from MementoSource.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveMemento(InstanceMemento) | (Inherited from MementoSource.)
 | retrieveMemento(String) | (Overrides MementoSource.retrieveMemento(String).)
 | SourceType | The type of MementoSource (Inherited from MementoSource.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | MementoSource
 |  | EmbeddedFolderXmlMementoSource


EmbeddedFolderXmlMementoSource Constructor (style, assemblyName, folderPath, extension)

EmbeddedFolderXmlMementoSource Constructor (style, assemblyName, folderPath, extension)
Namespaces ► StructureMap.Source ► EmbeddedFolderXmlMementoSource ► EmbeddedFolderXmlMementoSource(XmlMementoStyle, String, String, String)
StructureMap API
Implementation of MementoSource that stores and retrieves an XmlInstanceMemento per Embedded Resource file in a named namespace. EmbeddedFolderXmlMementoSource is meant to simplify complicated object graph configurations by isolating each instance to a separate editable file.
Declaration Syntax
C# Visual Basic Visual C++
public EmbeddedFolderXmlMementoSource(
    XmlMementoStyle style,
    string assemblyName,
    string folderPath,
    string extension
)
Public Sub New ( _
    style As XmlMementoStyle, _
    assemblyName As String, _
    folderPath As String, _
    extension As String _
)
public:
EmbeddedFolderXmlMementoSource(
    XmlMementoStyle style,
    String^ assemblyName,
    String^ folderPath,
    String^ extension
)
Parameters
style (XmlMementoStyle)
NodeNormalized or AttributeNormalized
assemblyName (String)
The name of the Assembly with the embedded resources
folderPath (String)
The root namespace of all of the mementos.
extension (String)
The file extension of the memento files - "xml"


containsKey Method (instanceKey)

containsKey Method (instanceKey)
Namespaces ► StructureMap.Source ► EmbeddedFolderXmlMementoSource ► containsKey(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.EmbeddedFolderXmlMementoSource.containsKey(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected internal override bool containsKey(
    string instanceKey
)
Protected Friend Overrides Function containsKey ( _
    instanceKey As String _
) As Boolean
protected public:
virtual bool containsKey(
    String^ instanceKey
) override
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Source.EmbeddedFolderXmlMementoSource.containsKey(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.EmbeddedFolderXmlMementoSource.containsKey(System.String)]


Description Property

Description Property
Namespaces ► StructureMap.Source ► EmbeddedFolderXmlMementoSource ► Description
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.EmbeddedFolderXmlMementoSource.Description]

Declaration Syntax
C# Visual Basic Visual C++
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () override;
}


fetchInternalMementos Method

fetchInternalMementos Method
Namespaces ► StructureMap.Source ► EmbeddedFolderXmlMementoSource ► fetchInternalMementos()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.EmbeddedFolderXmlMementoSource.fetchInternalMementos]

Declaration Syntax
C# Visual Basic Visual C++
protected override InstanceMemento[] fetchInternalMementos()
Protected Overrides Function fetchInternalMementos As InstanceMemento()
protected:
virtual array<InstanceMemento^>^ fetchInternalMementos() override
Return Value

[Missing <returns> documentation for M:StructureMap.Source.EmbeddedFolderXmlMementoSource.fetchInternalMementos]


retrieveMemento Method (instanceKey)

retrieveMemento Method (instanceKey)
Namespaces ► StructureMap.Source ► EmbeddedFolderXmlMementoSource ► retrieveMemento(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.EmbeddedFolderXmlMementoSource.retrieveMemento(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected override InstanceMemento retrieveMemento(
    string instanceKey
)
Protected Overrides Function retrieveMemento ( _
    instanceKey As String _
) As InstanceMemento
protected:
virtual InstanceMemento^ retrieveMemento(
    String^ instanceKey
) override
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Source.EmbeddedFolderXmlMementoSource.retrieveMemento(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.EmbeddedFolderXmlMementoSource.retrieveMemento(System.String)]


MementoSourceType Enumeration

MementoSourceType Enumeration
Namespaces ► StructureMap.Source ► MementoSourceType
StructureMap API

[Missing <summary> documentation for T:StructureMap.Source.MementoSourceType]

Declaration Syntax
C# Visual Basic Visual C++
public enum MementoSourceType
Public Enumeration MementoSourceType
public enum class MementoSourceType
Members
Member | Description
ConfigInstance |
Embedded |
External |


MemoryMementoSource Class

MemoryMementoSource Class
Namespaces ► StructureMap.Source ► MemoryMementoSource
StructureMap API
An in-memory MementoSource
Declaration Syntax
C# Visual Basic Visual C++
public class MemoryMementoSource : MementoSource
Public Class MemoryMementoSource _
    Inherits MementoSource
public ref class MemoryMementoSource : public MementoSource
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | MemoryMementoSource()()() | Initializes a new instance of the MemoryMementoSource class
 | AddMemento(InstanceMemento) |
 | containsKey(String) | (Overrides MementoSource.containsKey(String).)
 | DefaultMemento | (Inherited from MementoSource.)
 | Description | (Overrides MementoSource.Description.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Family | (Inherited from MementoSource.)
 | fetchInternalMementos()()() | (Overrides MementoSource.fetchInternalMementos()()().)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllMementos()()() | Retrieves an array of all InstanceMemento's stored by this MementoSource (Inherited from MementoSource.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMemento(String) | Retrieves the named InstanceMemento (Inherited from MementoSource.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveMemento(InstanceMemento) | (Inherited from MementoSource.)
 | retrieveMemento(String) | (Overrides MementoSource.retrieveMemento(String).)
 | SourceType | The type of MementoSource (Inherited from MementoSource.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | MementoSource
 |  | MemoryMementoSource


MemoryMementoSource Constructor

MemoryMementoSource Constructor
Namespaces ► StructureMap.Source ► MemoryMementoSource ► MemoryMementoSource()()()
StructureMap API
Initializes a new instance of the MemoryMementoSource class
Declaration Syntax
C# Visual Basic Visual C++
public MemoryMementoSource()
Public Sub New
public:
MemoryMementoSource()


AddMemento Method (Memento)

AddMemento Method (Memento)
Namespaces ► StructureMap.Source ► MemoryMementoSource ► AddMemento(InstanceMemento)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.MemoryMementoSource.AddMemento(StructureMap.InstanceMemento)]

Declaration Syntax
C# Visual Basic Visual C++
public void AddMemento(
    InstanceMemento Memento
)
Public Sub AddMemento ( _
    Memento As InstanceMemento _
)
public:
void AddMemento(
    InstanceMemento^ Memento
)
Parameters
Memento (InstanceMemento)

[Missing <param name="Memento"/> documentation for "M:StructureMap.Source.MemoryMementoSource.AddMemento(StructureMap.InstanceMemento)"]


containsKey Method (Key)

containsKey Method (Key)
Namespaces ► StructureMap.Source ► MemoryMementoSource ► containsKey(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.MemoryMementoSource.containsKey(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected internal override bool containsKey(
    string Key
)
Protected Friend Overrides Function containsKey ( _
    Key As String _
) As Boolean
protected public:
virtual bool containsKey(
    String^ Key
) override
Parameters
Key (String)

[Missing <param name="Key"/> documentation for "M:StructureMap.Source.MemoryMementoSource.containsKey(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.MemoryMementoSource.containsKey(System.String)]


Description Property

Description Property
Namespaces ► StructureMap.Source ► MemoryMementoSource ► Description
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.MemoryMementoSource.Description]

Declaration Syntax
C# Visual Basic Visual C++
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () override;
}


fetchInternalMementos Method

fetchInternalMementos Method
Namespaces ► StructureMap.Source ► MemoryMementoSource ► fetchInternalMementos()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.MemoryMementoSource.fetchInternalMementos]

Declaration Syntax
C# Visual Basic Visual C++
protected override InstanceMemento[] fetchInternalMementos()
Protected Overrides Function fetchInternalMementos As InstanceMemento()
protected:
virtual array<InstanceMemento^>^ fetchInternalMementos() override
Return Value

[Missing <returns> documentation for M:StructureMap.Source.MemoryMementoSource.fetchInternalMementos]


retrieveMemento Method (Key)

retrieveMemento Method (Key)
Namespaces ► StructureMap.Source ► MemoryMementoSource ► retrieveMemento(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.MemoryMementoSource.retrieveMemento(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected override InstanceMemento retrieveMemento(
    string Key
)
Protected Overrides Function retrieveMemento ( _
    Key As String _
) As InstanceMemento
protected:
virtual InstanceMemento^ retrieveMemento(
    String^ Key
) override
Parameters
Key (String)

[Missing <param name="Key"/> documentation for "M:StructureMap.Source.MemoryMementoSource.retrieveMemento(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.MemoryMementoSource.retrieveMemento(System.String)]


SingleEmbeddedXmlMementoSource Class

SingleEmbeddedXmlMementoSource Class
Namespaces ► StructureMap.Source ► SingleEmbeddedXmlMementoSource
StructureMap API

[Missing <summary> documentation for T:StructureMap.Source.SingleEmbeddedXmlMementoSource]

Declaration Syntax
C# Visual Basic Visual C++
public class SingleEmbeddedXmlMementoSource : XmlMementoSource
Public Class SingleEmbeddedXmlMementoSource _
    Inherits XmlMementoSource
public ref class SingleEmbeddedXmlMementoSource : public XmlMementoSource
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | SingleEmbeddedXmlMementoSource(String, XmlMementoStyle, String, String) | Retrieves Xml InstanceMemento's from an xml file stored as an embedded resource in an assembly.
 | SingleEmbeddedXmlMementoSource(String, XmlMementoStyle, Assembly, String) | Initializes a new instance of the SingleEmbeddedXmlMementoSource class
 | containsKey(String) | (Inherited from XmlMementoSource.)
 | createMemento(XmlNode) | (Inherited from XmlMementoSource.)
 | DefaultMemento | (Inherited from MementoSource.)
 | Description | (Overrides MementoSource.Description.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Family | (Inherited from MementoSource.)
 | fetchInternalMementos()()() | (Inherited from XmlMementoSource.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllMementos()()() | Retrieves an array of all InstanceMemento's stored by this MementoSource (Inherited from MementoSource.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMemento(String) | Retrieves the named InstanceMemento (Inherited from MementoSource.)
 | getRootNode()()() | (Overrides XmlMementoSource.getRootNode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | KeyAttribute | (Inherited from XmlMementoSource.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NodeName | (Inherited from XmlMementoSource.)
 | ResolveMemento(InstanceMemento) | (Inherited from MementoSource.)
 | retrieveMemento(String) | (Inherited from XmlMementoSource.)
 | SourceType | The type of MementoSource (Inherited from MementoSource.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeAttribute | (Inherited from XmlMementoSource.)
Inheritance Hierarchy
Object
 | MementoSource
 |  | XmlMementoSource
 |  |  | SingleEmbeddedXmlMementoSource


SingleEmbeddedXmlMementoSource Constructor

SingleEmbeddedXmlMementoSource Constructor
Namespaces ► StructureMap.Source ► SingleEmbeddedXmlMementoSource ► SingleEmbeddedXmlMementoSource()()()
StructureMap API
Members
Icon | Member | Description
 | SingleEmbeddedXmlMementoSource(String, XmlMementoStyle, String, String) | Retrieves Xml InstanceMemento's from an xml file stored as an embedded resource in an assembly.
 | SingleEmbeddedXmlMementoSource(String, XmlMementoStyle, Assembly, String) | Initializes a new instance of the SingleEmbeddedXmlMementoSource class


SingleEmbeddedXmlMementoSource Constructor (nodeName, style, assembly, path)

SingleEmbeddedXmlMementoSource Constructor (nodeName, style, assembly, path)
Namespaces ► StructureMap.Source ► SingleEmbeddedXmlMementoSource ► SingleEmbeddedXmlMementoSource(String, XmlMementoStyle, Assembly, String)
StructureMap API
Initializes a new instance of the SingleEmbeddedXmlMementoSource class
Declaration Syntax
C# Visual Basic Visual C++
public SingleEmbeddedXmlMementoSource(
    string nodeName,
    XmlMementoStyle style,
    Assembly assembly,
    string path
)
Public Sub New ( _
    nodeName As String, _
    style As XmlMementoStyle, _
    assembly As Assembly, _
    path As String _
)
public:
SingleEmbeddedXmlMementoSource(
    String^ nodeName,
    XmlMementoStyle style,
    Assembly^ assembly,
    String^ path
)
Parameters
nodeName (String)

[Missing <param name="nodeName"/> documentation for "M:StructureMap.Source.SingleEmbeddedXmlMementoSource.#ctor(System.String,StructureMap.Source.XmlMementoStyle,System.Reflection.Assembly,System.String)"]

style (XmlMementoStyle)

[Missing <param name="style"/> documentation for "M:StructureMap.Source.SingleEmbeddedXmlMementoSource.#ctor(System.String,StructureMap.Source.XmlMementoStyle,System.Reflection.Assembly,System.String)"]

assembly (Assembly)

[Missing <param name="assembly"/> documentation for "M:StructureMap.Source.SingleEmbeddedXmlMementoSource.#ctor(System.String,StructureMap.Source.XmlMementoStyle,System.Reflection.Assembly,System.String)"]

path (String)

[Missing <param name="path"/> documentation for "M:StructureMap.Source.SingleEmbeddedXmlMementoSource.#ctor(System.String,StructureMap.Source.XmlMementoStyle,System.Reflection.Assembly,System.String)"]


SingleEmbeddedXmlMementoSource Constructor (nodeName, style, assemblyName, path)

SingleEmbeddedXmlMementoSource Constructor (nodeName, style, assemblyName, path)
Namespaces ► StructureMap.Source ► SingleEmbeddedXmlMementoSource ► SingleEmbeddedXmlMementoSource(String, XmlMementoStyle, String, String)
StructureMap API
Retrieves Xml InstanceMemento's from an xml file stored as an embedded resource in an assembly.
Declaration Syntax
C# Visual Basic Visual C++
public SingleEmbeddedXmlMementoSource(
    string nodeName,
    XmlMementoStyle style,
    string assemblyName,
    string path
)
Public Sub New ( _
    nodeName As String, _
    style As XmlMementoStyle, _
    assemblyName As String, _
    path As String _
)
public:
SingleEmbeddedXmlMementoSource(
    String^ nodeName,
    XmlMementoStyle style,
    String^ assemblyName,
    String^ path
)
Parameters
nodeName (String)
Designates the nodes that are memento nodes
style (XmlMementoStyle)
NodeNormalized or AttributeNormalized
assemblyName (String)
The name of the Assembly the file is embedded into
path (String)
The path to the embedded resource within the file


Description Property

Description Property
Namespaces ► StructureMap.Source ► SingleEmbeddedXmlMementoSource ► Description
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.SingleEmbeddedXmlMementoSource.Description]

Declaration Syntax
C# Visual Basic Visual C++
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () override;
}


getRootNode Method

getRootNode Method
Namespaces ► StructureMap.Source ► SingleEmbeddedXmlMementoSource ► getRootNode()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.SingleEmbeddedXmlMementoSource.getRootNode]

Declaration Syntax
C# Visual Basic Visual C++
protected override XmlNode getRootNode()
Protected Overrides Function getRootNode As XmlNode
protected:
virtual XmlNode^ getRootNode() override
Return Value

[Missing <returns> documentation for M:StructureMap.Source.SingleEmbeddedXmlMementoSource.getRootNode]


TemplatedMementoSource Class

TemplatedMementoSource Class
Namespaces ► StructureMap.Source ► TemplatedMementoSource
StructureMap API

[Missing <summary> documentation for T:StructureMap.Source.TemplatedMementoSource]

Declaration Syntax
C# Visual Basic Visual C++
public class TemplatedMementoSource : MementoSource
Public Class TemplatedMementoSource _
    Inherits MementoSource
public ref class TemplatedMementoSource : public MementoSource
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | TemplatedMementoSource(MementoSource, MementoSource) | Default Constructor
 | containsKey(String) | (Overrides MementoSource.containsKey(String).)
 | DefaultMemento | (Inherited from MementoSource.)
 | Description | (Overrides MementoSource.Description.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Family | (Inherited from MementoSource.)
 | fetchInternalMementos()()() | (Overrides MementoSource.fetchInternalMementos()()().)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllMementos()()() | Retrieves an array of all InstanceMemento's stored by this MementoSource (Inherited from MementoSource.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMemento(String) | Retrieves the named InstanceMemento (Inherited from MementoSource.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ResolveMemento(InstanceMemento) | (Overrides MementoSource.ResolveMemento(InstanceMemento).)
 | retrieveMemento(String) | (Overrides MementoSource.retrieveMemento(String).)
 | SourceType | The type of MementoSource (Inherited from MementoSource.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
 | MementoSource
 |  | TemplatedMementoSource


TemplatedMementoSource Constructor (innerSource, templateSource)

TemplatedMementoSource Constructor (innerSource, templateSource)
Namespaces ► StructureMap.Source ► TemplatedMementoSource ► TemplatedMementoSource(MementoSource, MementoSource)
StructureMap API
Default Constructor
Declaration Syntax
C# Visual Basic Visual C++
public TemplatedMementoSource(
    MementoSource innerSource,
    MementoSource templateSource
)
Public Sub New ( _
    innerSource As MementoSource, _
    templateSource As MementoSource _
)
public:
TemplatedMementoSource(
    MementoSource^ innerSource,
    MementoSource^ templateSource
)
Parameters
innerSource (MementoSource)
MementoSource that contains the Memento Templates
templateSource (MementoSource)
MementoSource that contains instances consisting of Template valuee


containsKey Method (instanceKey)

containsKey Method (instanceKey)
Namespaces ► StructureMap.Source ► TemplatedMementoSource ► containsKey(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.TemplatedMementoSource.containsKey(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected internal override bool containsKey(
    string instanceKey
)
Protected Friend Overrides Function containsKey ( _
    instanceKey As String _
) As Boolean
protected public:
virtual bool containsKey(
    String^ instanceKey
) override
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Source.TemplatedMementoSource.containsKey(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.TemplatedMementoSource.containsKey(System.String)]


Description Property

Description Property
Namespaces ► StructureMap.Source ► TemplatedMementoSource ► Description
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.TemplatedMementoSource.Description]

Declaration Syntax
C# Visual Basic Visual C++
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () override;
}


fetchInternalMementos Method

fetchInternalMementos Method
Namespaces ► StructureMap.Source ► TemplatedMementoSource ► fetchInternalMementos()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.TemplatedMementoSource.fetchInternalMementos]

Declaration Syntax
C# Visual Basic Visual C++
protected override InstanceMemento[] fetchInternalMementos()
Protected Overrides Function fetchInternalMementos As InstanceMemento()
protected:
virtual array<InstanceMemento^>^ fetchInternalMementos() override
Return Value

[Missing <returns> documentation for M:StructureMap.Source.TemplatedMementoSource.fetchInternalMementos]


ResolveMemento Method (memento)

ResolveMemento Method (memento)
Namespaces ► StructureMap.Source ► TemplatedMementoSource ► ResolveMemento(InstanceMemento)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.TemplatedMementoSource.ResolveMemento(StructureMap.InstanceMemento)]

Declaration Syntax
C# Visual Basic Visual C++
public override InstanceMemento ResolveMemento(
    InstanceMemento memento
)
Public Overrides Function ResolveMemento ( _
    memento As InstanceMemento _
) As InstanceMemento
public:
virtual InstanceMemento^ ResolveMemento(
    InstanceMemento^ memento
) override
Parameters
memento (InstanceMemento)

[Missing <param name="memento"/> documentation for "M:StructureMap.Source.TemplatedMementoSource.ResolveMemento(StructureMap.InstanceMemento)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.TemplatedMementoSource.ResolveMemento(StructureMap.InstanceMemento)]


retrieveMemento Method (instanceKey)

retrieveMemento Method (instanceKey)
Namespaces ► StructureMap.Source ► TemplatedMementoSource ► retrieveMemento(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.TemplatedMementoSource.retrieveMemento(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected override InstanceMemento retrieveMemento(
    string instanceKey
)
Protected Overrides Function retrieveMemento ( _
    instanceKey As String _
) As InstanceMemento
protected:
virtual InstanceMemento^ retrieveMemento(
    String^ instanceKey
) override
Parameters
instanceKey (String)

[Missing <param name="instanceKey"/> documentation for "M:StructureMap.Source.TemplatedMementoSource.retrieveMemento(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.TemplatedMementoSource.retrieveMemento(System.String)]


XmlAttributeFileMementoSource Class

XmlAttributeFileMementoSource Class
Namespaces ► StructureMap.Source ► XmlAttributeFileMementoSource
StructureMap API
Stores Attribute-normalized InstanceMemento's in an external file
Declaration Syntax
C# Visual Basic Visual C++
public class XmlAttributeFileMementoSource : XmlFileMementoSource
Public Class XmlAttributeFileMementoSource _
    Inherits XmlFileMementoSource
public ref class XmlAttributeFileMementoSource : public XmlFileMementoSource
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlAttributeFileMementoSource(String, String, String) | Initializes a new instance of the XmlAttributeFileMementoSource class
 | containsKey(String) | (Inherited from XmlMementoSource.)
 | createMemento(XmlNode) | (Inherited from XmlMementoSource.)
 | DefaultMemento | (Inherited from MementoSource.)
 | Description | (Inherited from XmlFileMementoSource.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Family | (Inherited from MementoSource.)
 | fetchInternalMementos()()() | (Inherited from XmlMementoSource.)
 | FilePath | (Inherited from XmlFileMementoSource.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllMementos()()() | Retrieves an array of all InstanceMemento's stored by this MementoSource (Inherited from MementoSource.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMemento(String) | Retrieves the named InstanceMemento (Inherited from MementoSource.)
 | getRootNode()()() | (Inherited from XmlFileMementoSource.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | KeyAttribute | (Inherited from XmlMementoSource.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NodeName | (Inherited from XmlMementoSource.)
 | ResolveMemento(InstanceMemento) | (Inherited from MementoSource.)
 | retrieveMemento(String) | (Inherited from XmlMementoSource.)
 | SourceType | The type of MementoSource (Inherited from MementoSource.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeAttribute | (Inherited from XmlMementoSource.)
 | XPath | (Inherited from XmlFileMementoSource.)
Inheritance Hierarchy
Object
 | MementoSource
 |  | XmlMementoSource
 |  |  | XmlFileMementoSource
 |  |  |  | XmlAttributeFileMementoSource


XmlAttributeFileMementoSource Constructor (filePath, xpath, nodeName)

XmlAttributeFileMementoSource Constructor (filePath, xpath, nodeName)
Namespaces ► StructureMap.Source ► XmlAttributeFileMementoSource ► XmlAttributeFileMementoSource(String, String, String)
StructureMap API
Initializes a new instance of the XmlAttributeFileMementoSource class
Declaration Syntax
C# Visual Basic Visual C++
public XmlAttributeFileMementoSource(
    string filePath,
    string xpath,
    string nodeName
)
Public Sub New ( _
    filePath As String, _
    xpath As String, _
    nodeName As String _
)
public:
XmlAttributeFileMementoSource(
    String^ filePath,
    String^ xpath,
    String^ nodeName
)
Parameters
filePath (String)

[Missing <param name="filePath"/> documentation for "M:StructureMap.Source.XmlAttributeFileMementoSource.#ctor(System.String,System.String,System.String)"]

xpath (String)

[Missing <param name="xpath"/> documentation for "M:StructureMap.Source.XmlAttributeFileMementoSource.#ctor(System.String,System.String,System.String)"]

nodeName (String)

[Missing <param name="nodeName"/> documentation for "M:StructureMap.Source.XmlAttributeFileMementoSource.#ctor(System.String,System.String,System.String)"]


XmlAttributeInstanceMemento Class

XmlAttributeInstanceMemento Class
Namespaces ► StructureMap.Source ► XmlAttributeInstanceMemento
StructureMap API
An implementation of InstanceMemento that stores properties as Xml attributes Limited functionality
Declaration Syntax
C# Visual Basic Visual C++
public class XmlAttributeInstanceMemento : InstanceMemento
Public Class XmlAttributeInstanceMemento _
    Inherits InstanceMemento
public ref class XmlAttributeInstanceMemento : public InstanceMemento
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlAttributeInstanceMemento(XmlNode) | Initializes a new instance of the XmlAttributeInstanceMemento class
 | ConcreteKey | The named type of the object instance represented by the InstanceMemento. Translates to a concrete type (Inherited from InstanceMemento.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindPlugin(PluginFamily) | (Inherited from InstanceMemento.)
 | getChild(String) | (Overrides InstanceMemento.getChild(String).)
 | GetChildMemento(String) | Returns the named child InstanceMemento (Inherited from InstanceMemento.)
 | GetChildrenArray(String) | (Overrides InstanceMemento.GetChildrenArray(String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | getPluggedType()()() | (Inherited from InstanceMemento.)
 | GetProperty(String) | Retrieves the named property value as a string (Inherited from InstanceMemento.)
 | getPropertyValue(String) | (Overrides InstanceMemento.getPropertyValue(String).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | innerConcreteKey | (Overrides InstanceMemento.innerConcreteKey.)
 | InnerElement |
 | innerInstanceKey | (Overrides InstanceMemento.innerInstanceKey.)
 | InstanceKey | The named key of the object instance represented by the InstanceMemento (Inherited from InstanceMemento.)
 | IsDefault | Is the InstanceMemento a reference to the default instance of the plugin type? (Inherited from InstanceMemento.)
 | IsReference | (Overrides InstanceMemento.IsReference.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadChildInstance(String, PluginGraph, Type) | (Overrides InstanceMemento.ReadChildInstance(String, PluginGraph, Type).)
 | readInstance(PluginGraph, Type) | (Inherited from InstanceMemento.)
 | ReadInstance(PluginGraph, Type) | (Inherited from InstanceMemento.)
 | ReferenceKey | (Overrides InstanceMemento.ReferenceKey.)
 | SetConcreteKey(String) |
 | Substitute(InstanceMemento) | (Overrides InstanceMemento.Substitute(InstanceMemento).)
 | TemplateName | Gets the referred template name (Inherited from InstanceMemento.)
 | ToString()()() | (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
 | InstanceMemento
 |  | XmlAttributeInstanceMemento


XmlAttributeInstanceMemento Constructor (node)

XmlAttributeInstanceMemento Constructor (node)
Namespaces ► StructureMap.Source ► XmlAttributeInstanceMemento ► XmlAttributeInstanceMemento(XmlNode)
StructureMap API
Initializes a new instance of the XmlAttributeInstanceMemento class
Declaration Syntax
C# Visual Basic Visual C++
public XmlAttributeInstanceMemento(
    XmlNode node
)
Public Sub New ( _
    node As XmlNode _
)
public:
XmlAttributeInstanceMemento(
    XmlNode^ node
)
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.Source.XmlAttributeInstanceMemento.#ctor(System.Xml.XmlNode)"]


getChild Method (key)

getChild Method (key)
Namespaces ► StructureMap.Source ► XmlAttributeInstanceMemento ► getChild(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlAttributeInstanceMemento.getChild(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected override InstanceMemento getChild(
    string key
)
Protected Overrides Function getChild ( _
    key As String _
) As InstanceMemento
protected:
virtual InstanceMemento^ getChild(
    String^ key
) override
Parameters
key (String)

[Missing <param name="key"/> documentation for "M:StructureMap.Source.XmlAttributeInstanceMemento.getChild(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlAttributeInstanceMemento.getChild(System.String)]


GetChildrenArray Method (Key)

GetChildrenArray Method (Key)
Namespaces ► StructureMap.Source ► XmlAttributeInstanceMemento ► GetChildrenArray(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlAttributeInstanceMemento.GetChildrenArray(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public override InstanceMemento[] GetChildrenArray(
    string Key
)
Public Overrides Function GetChildrenArray ( _
    Key As String _
) As InstanceMemento()
public:
virtual array<InstanceMemento^>^ GetChildrenArray(
    String^ Key
) override
Parameters
Key (String)

[Missing <param name="Key"/> documentation for "M:StructureMap.Source.XmlAttributeInstanceMemento.GetChildrenArray(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlAttributeInstanceMemento.GetChildrenArray(System.String)]


getPropertyValue Method (key)

getPropertyValue Method (key)
Namespaces ► StructureMap.Source ► XmlAttributeInstanceMemento ► getPropertyValue(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlAttributeInstanceMemento.getPropertyValue(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected override string getPropertyValue(
    string key
)
Protected Overrides Function getPropertyValue ( _
    key As String _
) As String
protected:
virtual String^ getPropertyValue(
    String^ key
) override
Parameters
key (String)

[Missing <param name="key"/> documentation for "M:StructureMap.Source.XmlAttributeInstanceMemento.getPropertyValue(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlAttributeInstanceMemento.getPropertyValue(System.String)]


innerConcreteKey Property

innerConcreteKey Property
Namespaces ► StructureMap.Source ► XmlAttributeInstanceMemento ► innerConcreteKey
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlAttributeInstanceMemento.innerConcreteKey]

Declaration Syntax
C# Visual Basic Visual C++
protected override string innerConcreteKey { get; }
Protected Overrides ReadOnly Property innerConcreteKey As String
protected:
virtual property String^ innerConcreteKey {
    String^ get () override;
}


InnerElement Property

InnerElement Property
Namespaces ► StructureMap.Source ► XmlAttributeInstanceMemento ► InnerElement
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlAttributeInstanceMemento.InnerElement]

Declaration Syntax
C# Visual Basic Visual C++
public XmlElement InnerElement { get; }
Public ReadOnly Property InnerElement As XmlElement
public:
property XmlElement^ InnerElement {
    XmlElement^ get ();
}


innerInstanceKey Property

innerInstanceKey Property
Namespaces ► StructureMap.Source ► XmlAttributeInstanceMemento ► innerInstanceKey
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlAttributeInstanceMemento.innerInstanceKey]

Declaration Syntax
C# Visual Basic Visual C++
protected override string innerInstanceKey { get; }
Protected Overrides ReadOnly Property innerInstanceKey As String
protected:
virtual property String^ innerInstanceKey {
    String^ get () override;
}


IsReference Property

IsReference Property
Namespaces ► StructureMap.Source ► XmlAttributeInstanceMemento ► IsReference
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlAttributeInstanceMemento.IsReference]

Declaration Syntax
C# Visual Basic Visual C++
public override bool IsReference { get; }
Public Overrides ReadOnly Property IsReference As Boolean
public:
virtual property bool IsReference {
    bool get () override;
}


ReadChildInstance Method (name, graph, childType)

ReadChildInstance Method (name, graph, childType)
Namespaces ► StructureMap.Source ► XmlAttributeInstanceMemento ► ReadChildInstance(String, PluginGraph, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlAttributeInstanceMemento.ReadChildInstance(System.String,StructureMap.Graph.PluginGraph,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public override Instance ReadChildInstance(
    string name,
    PluginGraph graph,
    Type childType
)
Public Overrides Function ReadChildInstance ( _
    name As String, _
    graph As PluginGraph, _
    childType As Type _
) As Instance
public:
virtual Instance^ ReadChildInstance(
    String^ name,
    PluginGraph^ graph,
    Type^ childType
) override
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Source.XmlAttributeInstanceMemento.ReadChildInstance(System.String,StructureMap.Graph.PluginGraph,System.Type)"]

graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.Source.XmlAttributeInstanceMemento.ReadChildInstance(System.String,StructureMap.Graph.PluginGraph,System.Type)"]

childType (Type)

[Missing <param name="childType"/> documentation for "M:StructureMap.Source.XmlAttributeInstanceMemento.ReadChildInstance(System.String,StructureMap.Graph.PluginGraph,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlAttributeInstanceMemento.ReadChildInstance(System.String,StructureMap.Graph.PluginGraph,System.Type)]


ReferenceKey Property

ReferenceKey Property
Namespaces ► StructureMap.Source ► XmlAttributeInstanceMemento ► ReferenceKey
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlAttributeInstanceMemento.ReferenceKey]

Declaration Syntax
C# Visual Basic Visual C++
public override string ReferenceKey { get; }
Public Overrides ReadOnly Property ReferenceKey As String
public:
virtual property String^ ReferenceKey {
    String^ get () override;
}


SetConcreteKey Method (concreteKey)

SetConcreteKey Method (concreteKey)
Namespaces ► StructureMap.Source ► XmlAttributeInstanceMemento ► SetConcreteKey(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlAttributeInstanceMemento.SetConcreteKey(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public void SetConcreteKey(
    string concreteKey
)
Public Sub SetConcreteKey ( _
    concreteKey As String _
)
public:
void SetConcreteKey(
    String^ concreteKey
)
Parameters
concreteKey (String)

[Missing <param name="concreteKey"/> documentation for "M:StructureMap.Source.XmlAttributeInstanceMemento.SetConcreteKey(System.String)"]


Substitute Method (memento)

Substitute Method (memento)
Namespaces ► StructureMap.Source ► XmlAttributeInstanceMemento ► Substitute(InstanceMemento)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlAttributeInstanceMemento.Substitute(StructureMap.InstanceMemento)]

Declaration Syntax
C# Visual Basic Visual C++
public override InstanceMemento Substitute(
    InstanceMemento memento
)
Public Overrides Function Substitute ( _
    memento As InstanceMemento _
) As InstanceMemento
public:
virtual InstanceMemento^ Substitute(
    InstanceMemento^ memento
) override
Parameters
memento (InstanceMemento)

[Missing <param name="memento"/> documentation for "M:StructureMap.Source.XmlAttributeInstanceMemento.Substitute(StructureMap.InstanceMemento)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlAttributeInstanceMemento.Substitute(StructureMap.InstanceMemento)]


ToString Method

ToString Method
Namespaces ► StructureMap.Source ► XmlAttributeInstanceMemento ► ToString()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlAttributeInstanceMemento.ToString]

Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlAttributeInstanceMemento.ToString]


XmlFileMementoSource Class

XmlFileMementoSource Class
Namespaces ► StructureMap.Source ► XmlFileMementoSource
StructureMap API
Implementation of XmlMementoSource that reads InstanceMemento's from an external file. Useful to break the StructureMap.config file into smaller pieces.
Declaration Syntax
C# Visual Basic Visual C++
public class XmlFileMementoSource : XmlMementoSource
Public Class XmlFileMementoSource _
    Inherits XmlMementoSource
public ref class XmlFileMementoSource : public XmlMementoSource
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlFileMementoSource(String, String, String) | Default constructor
 | XmlFileMementoSource(String, String, String, XmlMementoStyle) | Initializes a new instance of the XmlFileMementoSource class
 | containsKey(String) | (Inherited from XmlMementoSource.)
 | createMemento(XmlNode) | (Inherited from XmlMementoSource.)
 | DefaultMemento | (Inherited from MementoSource.)
 | Description | (Overrides MementoSource.Description.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Family | (Inherited from MementoSource.)
 | fetchInternalMementos()()() | (Inherited from XmlMementoSource.)
 | FilePath |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllMementos()()() | Retrieves an array of all InstanceMemento's stored by this MementoSource (Inherited from MementoSource.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMemento(String) | Retrieves the named InstanceMemento (Inherited from MementoSource.)
 | getRootNode()()() | (Overrides XmlMementoSource.getRootNode()()().)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | KeyAttribute | (Inherited from XmlMementoSource.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NodeName | (Inherited from XmlMementoSource.)
 | ResolveMemento(InstanceMemento) | (Inherited from MementoSource.)
 | retrieveMemento(String) | (Inherited from XmlMementoSource.)
 | SourceType | The type of MementoSource (Inherited from MementoSource.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeAttribute | (Inherited from XmlMementoSource.)
 | XPath |
Inheritance Hierarchy
Object
 | MementoSource
 |  | XmlMementoSource
 |  |  | XmlFileMementoSource
 |  |  |  | XmlAttributeFileMementoSource


XmlFileMementoSource Constructor

XmlFileMementoSource Constructor
Namespaces ► StructureMap.Source ► XmlFileMementoSource ► XmlFileMementoSource()()()
StructureMap API
Members
Icon | Member | Description
 | XmlFileMementoSource(String, String, String) | Default constructor
 | XmlFileMementoSource(String, String, String, XmlMementoStyle) | Initializes a new instance of the XmlFileMementoSource class


XmlFileMementoSource Constructor (FilePath, XPath, NodeName)

XmlFileMementoSource Constructor (FilePath, XPath, NodeName)
Namespaces ► StructureMap.Source ► XmlFileMementoSource ► XmlFileMementoSource(String, String, String)
StructureMap API
Default constructor
Declaration Syntax
C# Visual Basic Visual C++
public XmlFileMementoSource(
    string FilePath,
    string XPath,
    string NodeName
)
Public Sub New ( _
    FilePath As String, _
    XPath As String, _
    NodeName As String _
)
public:
XmlFileMementoSource(
    String^ FilePath,
    String^ XPath,
    String^ NodeName
)
Parameters
FilePath (String)
Path to the xml file that contains the instance configuration
XPath (String)
XPath expression to the parent node that contains the InstanceMemento nodes. If empty, it defaults to the top node
NodeName (String)
The name of the nodes that are InstanceMemento nodes. Useful to store different types of instances in the same file


XmlFileMementoSource Constructor (FilePath, XPath, NodeName, style)

XmlFileMementoSource Constructor (FilePath, XPath, NodeName, style)
Namespaces ► StructureMap.Source ► XmlFileMementoSource ► XmlFileMementoSource(String, String, String, XmlMementoStyle)
StructureMap API
Initializes a new instance of the XmlFileMementoSource class
Declaration Syntax
C# Visual Basic Visual C++
public XmlFileMementoSource(
    string FilePath,
    string XPath,
    string NodeName,
    XmlMementoStyle style
)
Public Sub New ( _
    FilePath As String, _
    XPath As String, _
    NodeName As String, _
    style As XmlMementoStyle _
)
public:
XmlFileMementoSource(
    String^ FilePath,
    String^ XPath,
    String^ NodeName,
    XmlMementoStyle style
)
Parameters
FilePath (String)

[Missing <param name="FilePath"/> documentation for "M:StructureMap.Source.XmlFileMementoSource.#ctor(System.String,System.String,System.String,StructureMap.Source.XmlMementoStyle)"]

XPath (String)

[Missing <param name="XPath"/> documentation for "M:StructureMap.Source.XmlFileMementoSource.#ctor(System.String,System.String,System.String,StructureMap.Source.XmlMementoStyle)"]

NodeName (String)

[Missing <param name="NodeName"/> documentation for "M:StructureMap.Source.XmlFileMementoSource.#ctor(System.String,System.String,System.String,StructureMap.Source.XmlMementoStyle)"]

style (XmlMementoStyle)

[Missing <param name="style"/> documentation for "M:StructureMap.Source.XmlFileMementoSource.#ctor(System.String,System.String,System.String,StructureMap.Source.XmlMementoStyle)"]


Description Property

Description Property
Namespaces ► StructureMap.Source ► XmlFileMementoSource ► Description
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlFileMementoSource.Description]

Declaration Syntax
C# Visual Basic Visual C++
public override string Description { get; }
Public Overrides ReadOnly Property Description As String
public:
virtual property String^ Description {
    String^ get () override;
}


FilePath Property

FilePath Property
Namespaces ► StructureMap.Source ► XmlFileMementoSource ► FilePath
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlFileMementoSource.FilePath]

Declaration Syntax
C# Visual Basic Visual C++
public string FilePath { get; }
Public ReadOnly Property FilePath As String
public:
property String^ FilePath {
    String^ get ();
}


getRootNode Method

getRootNode Method
Namespaces ► StructureMap.Source ► XmlFileMementoSource ► getRootNode()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlFileMementoSource.getRootNode]

Declaration Syntax
C# Visual Basic Visual C++
protected override XmlNode getRootNode()
Protected Overrides Function getRootNode As XmlNode
protected:
virtual XmlNode^ getRootNode() override
Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlFileMementoSource.getRootNode]


XPath Property

XPath Property
Namespaces ► StructureMap.Source ► XmlFileMementoSource ► XPath
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlFileMementoSource.XPath]

Declaration Syntax
C# Visual Basic Visual C++
public string XPath { get; }
Public ReadOnly Property XPath As String
public:
property String^ XPath {
    String^ get ();
}


XmlMementoCreator Class

XmlMementoCreator Class
Namespaces ► StructureMap.Source ► XmlMementoCreator
StructureMap API

[Missing <summary> documentation for T:StructureMap.Source.XmlMementoCreator]

Declaration Syntax
C# Visual Basic Visual C++
public class XmlMementoCreator
Public Class XmlMementoCreator
public ref class XmlMementoCreator
Members
All Members | Constructors | Methods
Public Protected |  | Instance Static | Declared Inherited
Icon | Member | Description
 | XmlMementoCreator(XmlMementoStyle, String, String) | Initializes a new instance of the XmlMementoCreator class
 | CreateMemento(XmlNode) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
XmlMementoCreator


XmlMementoCreator Constructor (style, typeAttribute, keyAttribute)

XmlMementoCreator Constructor (style, typeAttribute, keyAttribute)
Namespaces ► StructureMap.Source ► XmlMementoCreator ► XmlMementoCreator(XmlMementoStyle, String, String)
StructureMap API
Initializes a new instance of the XmlMementoCreator class
Declaration Syntax
C# Visual Basic Visual C++
public XmlMementoCreator(
    XmlMementoStyle style,
    string typeAttribute,
    string keyAttribute
)
Public Sub New ( _
    style As XmlMementoStyle, _
    typeAttribute As String, _
    keyAttribute As String _
)
public:
XmlMementoCreator(
    XmlMementoStyle style,
    String^ typeAttribute,
    String^ keyAttribute
)
Parameters
style (XmlMementoStyle)

[Missing <param name="style"/> documentation for "M:StructureMap.Source.XmlMementoCreator.#ctor(StructureMap.Source.XmlMementoStyle,System.String,System.String)"]

typeAttribute (String)

[Missing <param name="typeAttribute"/> documentation for "M:StructureMap.Source.XmlMementoCreator.#ctor(StructureMap.Source.XmlMementoStyle,System.String,System.String)"]

keyAttribute (String)

[Missing <param name="keyAttribute"/> documentation for "M:StructureMap.Source.XmlMementoCreator.#ctor(StructureMap.Source.XmlMementoStyle,System.String,System.String)"]


CreateMemento Method (node)

CreateMemento Method (node)
Namespaces ► StructureMap.Source ► XmlMementoCreator ► CreateMemento(XmlNode)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlMementoCreator.CreateMemento(System.Xml.XmlNode)]

Declaration Syntax
C# Visual Basic Visual C++
public InstanceMemento CreateMemento(
    XmlNode node
)
Public Function CreateMemento ( _
    node As XmlNode _
) As InstanceMemento
public:
InstanceMemento^ CreateMemento(
    XmlNode^ node
)
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.Source.XmlMementoCreator.CreateMemento(System.Xml.XmlNode)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlMementoCreator.CreateMemento(System.Xml.XmlNode)]


XmlMementoSource Class

XmlMementoSource Class
Namespaces ► StructureMap.Source ► XmlMementoSource
StructureMap API
Base class for all MementoSource classes that store InstanceMemento's as node-normalized Xml
Declaration Syntax
C# Visual Basic Visual C++
public abstract class XmlMementoSource : MementoSource
Public MustInherit Class XmlMementoSource _
    Inherits MementoSource
public ref class XmlMementoSource abstract : public MementoSource
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlMementoSource(String, String, String, XmlMementoStyle) | Initializes a new instance of the XmlMementoSource class
 | containsKey(String) | (Overrides MementoSource.containsKey(String).)
 | createMemento(XmlNode) |
 | DefaultMemento | (Inherited from MementoSource.)
 | Description | String description of the MementoSource. Used in the StructureMap-Client UI. (Inherited from MementoSource.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Family | (Inherited from MementoSource.)
 | fetchInternalMementos()()() | (Overrides MementoSource.fetchInternalMementos()()().)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetAllMementos()()() | Retrieves an array of all InstanceMemento's stored by this MementoSource (Inherited from MementoSource.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetMemento(String) | Retrieves the named InstanceMemento (Inherited from MementoSource.)
 | getRootNode()()() |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | KeyAttribute |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | NodeName |
 | ResolveMemento(InstanceMemento) | (Inherited from MementoSource.)
 | retrieveMemento(String) | (Overrides MementoSource.retrieveMemento(String).)
 | SourceType | The type of MementoSource (Inherited from MementoSource.)
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
 | TypeAttribute |
Inheritance Hierarchy
Object
 | MementoSource
 |  | XmlMementoSource
 |  |  | BasicXmlMementoSource
 |  |  | SingleEmbeddedXmlMementoSource
 |  |  | XmlFileMementoSource


XmlMementoSource Constructor (NodeName, TypeAttribute, KeyAttribute, style)

XmlMementoSource Constructor (NodeName, TypeAttribute, KeyAttribute, style)
Namespaces ► StructureMap.Source ► XmlMementoSource ► XmlMementoSource(String, String, String, XmlMementoStyle)
StructureMap API
Initializes a new instance of the XmlMementoSource class
Declaration Syntax
C# Visual Basic Visual C++
public XmlMementoSource(
    string NodeName,
    string TypeAttribute,
    string KeyAttribute,
    XmlMementoStyle style
)
Public Sub New ( _
    NodeName As String, _
    TypeAttribute As String, _
    KeyAttribute As String, _
    style As XmlMementoStyle _
)
public:
XmlMementoSource(
    String^ NodeName,
    String^ TypeAttribute,
    String^ KeyAttribute,
    XmlMementoStyle style
)
Parameters
NodeName (String)

[Missing <param name="NodeName"/> documentation for "M:StructureMap.Source.XmlMementoSource.#ctor(System.String,System.String,System.String,StructureMap.Source.XmlMementoStyle)"]

TypeAttribute (String)

[Missing <param name="TypeAttribute"/> documentation for "M:StructureMap.Source.XmlMementoSource.#ctor(System.String,System.String,System.String,StructureMap.Source.XmlMementoStyle)"]

KeyAttribute (String)

[Missing <param name="KeyAttribute"/> documentation for "M:StructureMap.Source.XmlMementoSource.#ctor(System.String,System.String,System.String,StructureMap.Source.XmlMementoStyle)"]

style (XmlMementoStyle)

[Missing <param name="style"/> documentation for "M:StructureMap.Source.XmlMementoSource.#ctor(System.String,System.String,System.String,StructureMap.Source.XmlMementoStyle)"]


containsKey Method (Key)

containsKey Method (Key)
Namespaces ► StructureMap.Source ► XmlMementoSource ► containsKey(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlMementoSource.containsKey(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected internal override bool containsKey(
    string Key
)
Protected Friend Overrides Function containsKey ( _
    Key As String _
) As Boolean
protected public:
virtual bool containsKey(
    String^ Key
) override
Parameters
Key (String)

[Missing <param name="Key"/> documentation for "M:StructureMap.Source.XmlMementoSource.containsKey(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlMementoSource.containsKey(System.String)]


createMemento Method (nodeChild)

createMemento Method (nodeChild)
Namespaces ► StructureMap.Source ► XmlMementoSource ► createMemento(XmlNode)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlMementoSource.createMemento(System.Xml.XmlNode)]

Declaration Syntax
C# Visual Basic Visual C++
protected InstanceMemento createMemento(
    XmlNode nodeChild
)
Protected Function createMemento ( _
    nodeChild As XmlNode _
) As InstanceMemento
protected:
InstanceMemento^ createMemento(
    XmlNode^ nodeChild
)
Parameters
nodeChild (XmlNode)

[Missing <param name="nodeChild"/> documentation for "M:StructureMap.Source.XmlMementoSource.createMemento(System.Xml.XmlNode)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlMementoSource.createMemento(System.Xml.XmlNode)]


fetchInternalMementos Method

fetchInternalMementos Method
Namespaces ► StructureMap.Source ► XmlMementoSource ► fetchInternalMementos()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlMementoSource.fetchInternalMementos]

Declaration Syntax
C# Visual Basic Visual C++
protected override sealed InstanceMemento[] fetchInternalMementos()
Protected Overrides NotOverridable Function fetchInternalMementos As InstanceMemento()
protected:
virtual array<InstanceMemento^>^ fetchInternalMementos() override sealed
Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlMementoSource.fetchInternalMementos]


getRootNode Method

getRootNode Method
Namespaces ► StructureMap.Source ► XmlMementoSource ► getRootNode()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlMementoSource.getRootNode]

Declaration Syntax
C# Visual Basic Visual C++
protected abstract XmlNode getRootNode()
Protected MustOverride Function getRootNode As XmlNode
protected:
virtual XmlNode^ getRootNode() abstract
Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlMementoSource.getRootNode]


KeyAttribute Property

KeyAttribute Property
Namespaces ► StructureMap.Source ► XmlMementoSource ► KeyAttribute
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlMementoSource.KeyAttribute]

Declaration Syntax
C# Visual Basic Visual C++
public string KeyAttribute { get; }
Public ReadOnly Property KeyAttribute As String
public:
property String^ KeyAttribute {
    String^ get ();
}


NodeName Property

NodeName Property
Namespaces ► StructureMap.Source ► XmlMementoSource ► NodeName
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlMementoSource.NodeName]

Declaration Syntax
C# Visual Basic Visual C++
public string NodeName { get; }
Public ReadOnly Property NodeName As String
public:
property String^ NodeName {
    String^ get ();
}


retrieveMemento Method (Key)

retrieveMemento Method (Key)
Namespaces ► StructureMap.Source ► XmlMementoSource ► retrieveMemento(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlMementoSource.retrieveMemento(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected override InstanceMemento retrieveMemento(
    string Key
)
Protected Overrides Function retrieveMemento ( _
    Key As String _
) As InstanceMemento
protected:
virtual InstanceMemento^ retrieveMemento(
    String^ Key
) override
Parameters
Key (String)

[Missing <param name="Key"/> documentation for "M:StructureMap.Source.XmlMementoSource.retrieveMemento(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlMementoSource.retrieveMemento(System.String)]


TypeAttribute Property

TypeAttribute Property
Namespaces ► StructureMap.Source ► XmlMementoSource ► TypeAttribute
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlMementoSource.TypeAttribute]

Declaration Syntax
C# Visual Basic Visual C++
public string TypeAttribute { get; }
Public ReadOnly Property TypeAttribute As String
public:
property String^ TypeAttribute {
    String^ get ();
}


XmlMementoStyle Enumeration

XmlMementoStyle Enumeration
Namespaces ► StructureMap.Source ► XmlMementoStyle
StructureMap API

[Missing <summary> documentation for T:StructureMap.Source.XmlMementoStyle]

Declaration Syntax
C# Visual Basic Visual C++
public enum XmlMementoStyle
Public Enumeration XmlMementoStyle
public enum class XmlMementoStyle
Members
Member | Description
NodeNormalized |
AttributeNormalized |


XmlNodeInstanceMemento Class

XmlNodeInstanceMemento Class
Namespaces ► StructureMap.Source ► XmlNodeInstanceMemento
StructureMap API
Implementation of InstanceMemento that stores information in a node-normalized Xml format.
Declaration Syntax
C# Visual Basic Visual C++
public class XmlNodeInstanceMemento : InstanceMemento
Public Class XmlNodeInstanceMemento _
    Inherits InstanceMemento
public ref class XmlNodeInstanceMemento : public InstanceMemento
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlNodeInstanceMemento(XmlNode, String, String) | Initializes a new instance of the XmlNodeInstanceMemento class
 | ConcreteKey | The named type of the object instance represented by the InstanceMemento. Translates to a concrete type (Inherited from InstanceMemento.)
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | FindPlugin(PluginFamily) | (Inherited from InstanceMemento.)
 | getChild(String) | (Overrides InstanceMemento.getChild(String).)
 | GetChildMemento(String) | Returns the named child InstanceMemento (Inherited from InstanceMemento.)
 | GetChildrenArray(String) | (Overrides InstanceMemento.GetChildrenArray(String).)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | getPluggedType()()() | (Overrides InstanceMemento.getPluggedType()()().)
 | GetProperty(String) | Retrieves the named property value as a string (Inherited from InstanceMemento.)
 | getPropertyValue(String) | (Overrides InstanceMemento.getPropertyValue(String).)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | innerConcreteKey | (Overrides InstanceMemento.innerConcreteKey.)
 | innerInstanceKey | (Overrides InstanceMemento.innerInstanceKey.)
 | InstanceKey | The named key of the object instance represented by the InstanceMemento (Inherited from InstanceMemento.)
 | IsDefault | Is the InstanceMemento a reference to the default instance of the plugin type? (Inherited from InstanceMemento.)
 | IsReference | (Overrides InstanceMemento.IsReference.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | ReadChildInstance(String, PluginGraph, Type) | (Overrides InstanceMemento.ReadChildInstance(String, PluginGraph, Type).)
 | readInstance(PluginGraph, Type) | (Inherited from InstanceMemento.)
 | ReadInstance(PluginGraph, Type) | (Inherited from InstanceMemento.)
 | ReferenceKey | (Overrides InstanceMemento.ReferenceKey.)
 | Substitute(InstanceMemento) | (Overrides InstanceMemento.Substitute(InstanceMemento).)
 | TemplateName | Gets the referred template name (Inherited from InstanceMemento.)
 | ToString()()() | (Overrides Object.ToString()()().)
Inheritance Hierarchy
Object
 | InstanceMemento
 |  | XmlNodeInstanceMemento


XmlNodeInstanceMemento Constructor (Node, TypeAttribute, KeyAttribute)

XmlNodeInstanceMemento Constructor (Node, TypeAttribute, KeyAttribute)
Namespaces ► StructureMap.Source ► XmlNodeInstanceMemento ► XmlNodeInstanceMemento(XmlNode, String, String)
StructureMap API
Initializes a new instance of the XmlNodeInstanceMemento class
Declaration Syntax
C# Visual Basic Visual C++
public XmlNodeInstanceMemento(
    XmlNode Node,
    string TypeAttribute,
    string KeyAttribute
)
Public Sub New ( _
    Node As XmlNode, _
    TypeAttribute As String, _
    KeyAttribute As String _
)
public:
XmlNodeInstanceMemento(
    XmlNode^ Node,
    String^ TypeAttribute,
    String^ KeyAttribute
)
Parameters
Node (XmlNode)

[Missing <param name="Node"/> documentation for "M:StructureMap.Source.XmlNodeInstanceMemento.#ctor(System.Xml.XmlNode,System.String,System.String)"]

TypeAttribute (String)

[Missing <param name="TypeAttribute"/> documentation for "M:StructureMap.Source.XmlNodeInstanceMemento.#ctor(System.Xml.XmlNode,System.String,System.String)"]

KeyAttribute (String)

[Missing <param name="KeyAttribute"/> documentation for "M:StructureMap.Source.XmlNodeInstanceMemento.#ctor(System.Xml.XmlNode,System.String,System.String)"]


getChild Method (Key)

getChild Method (Key)
Namespaces ► StructureMap.Source ► XmlNodeInstanceMemento ► getChild(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlNodeInstanceMemento.getChild(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected override InstanceMemento getChild(
    string Key
)
Protected Overrides Function getChild ( _
    Key As String _
) As InstanceMemento
protected:
virtual InstanceMemento^ getChild(
    String^ Key
) override
Parameters
Key (String)

[Missing <param name="Key"/> documentation for "M:StructureMap.Source.XmlNodeInstanceMemento.getChild(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlNodeInstanceMemento.getChild(System.String)]


GetChildrenArray Method (Key)

GetChildrenArray Method (Key)
Namespaces ► StructureMap.Source ► XmlNodeInstanceMemento ► GetChildrenArray(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlNodeInstanceMemento.GetChildrenArray(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
public override InstanceMemento[] GetChildrenArray(
    string Key
)
Public Overrides Function GetChildrenArray ( _
    Key As String _
) As InstanceMemento()
public:
virtual array<InstanceMemento^>^ GetChildrenArray(
    String^ Key
) override
Parameters
Key (String)

[Missing <param name="Key"/> documentation for "M:StructureMap.Source.XmlNodeInstanceMemento.GetChildrenArray(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlNodeInstanceMemento.GetChildrenArray(System.String)]


getPluggedType Method

getPluggedType Method
Namespaces ► StructureMap.Source ► XmlNodeInstanceMemento ► getPluggedType()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlNodeInstanceMemento.getPluggedType]

Declaration Syntax
C# Visual Basic Visual C++
protected override string getPluggedType()
Protected Overrides Function getPluggedType As String
protected:
virtual String^ getPluggedType() override
Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlNodeInstanceMemento.getPluggedType]


getPropertyValue Method (Key)

getPropertyValue Method (Key)
Namespaces ► StructureMap.Source ► XmlNodeInstanceMemento ► getPropertyValue(String)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlNodeInstanceMemento.getPropertyValue(System.String)]

Declaration Syntax
C# Visual Basic Visual C++
protected override string getPropertyValue(
    string Key
)
Protected Overrides Function getPropertyValue ( _
    Key As String _
) As String
protected:
virtual String^ getPropertyValue(
    String^ Key
) override
Parameters
Key (String)

[Missing <param name="Key"/> documentation for "M:StructureMap.Source.XmlNodeInstanceMemento.getPropertyValue(System.String)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlNodeInstanceMemento.getPropertyValue(System.String)]


innerConcreteKey Property

innerConcreteKey Property
Namespaces ► StructureMap.Source ► XmlNodeInstanceMemento ► innerConcreteKey
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlNodeInstanceMemento.innerConcreteKey]

Declaration Syntax
C# Visual Basic Visual C++
protected override string innerConcreteKey { get; }
Protected Overrides ReadOnly Property innerConcreteKey As String
protected:
virtual property String^ innerConcreteKey {
    String^ get () override;
}


innerInstanceKey Property

innerInstanceKey Property
Namespaces ► StructureMap.Source ► XmlNodeInstanceMemento ► innerInstanceKey
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlNodeInstanceMemento.innerInstanceKey]

Declaration Syntax
C# Visual Basic Visual C++
protected override string innerInstanceKey { get; }
Protected Overrides ReadOnly Property innerInstanceKey As String
protected:
virtual property String^ innerInstanceKey {
    String^ get () override;
}


IsReference Property

IsReference Property
Namespaces ► StructureMap.Source ► XmlNodeInstanceMemento ► IsReference
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlNodeInstanceMemento.IsReference]

Declaration Syntax
C# Visual Basic Visual C++
public override bool IsReference { get; }
Public Overrides ReadOnly Property IsReference As Boolean
public:
virtual property bool IsReference {
    bool get () override;
}


ReadChildInstance Method (name, graph, childType)

ReadChildInstance Method (name, graph, childType)
Namespaces ► StructureMap.Source ► XmlNodeInstanceMemento ► ReadChildInstance(String, PluginGraph, Type)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlNodeInstanceMemento.ReadChildInstance(System.String,StructureMap.Graph.PluginGraph,System.Type)]

Declaration Syntax
C# Visual Basic Visual C++
public override Instance ReadChildInstance(
    string name,
    PluginGraph graph,
    Type childType
)
Public Overrides Function ReadChildInstance ( _
    name As String, _
    graph As PluginGraph, _
    childType As Type _
) As Instance
public:
virtual Instance^ ReadChildInstance(
    String^ name,
    PluginGraph^ graph,
    Type^ childType
) override
Parameters
name (String)

[Missing <param name="name"/> documentation for "M:StructureMap.Source.XmlNodeInstanceMemento.ReadChildInstance(System.String,StructureMap.Graph.PluginGraph,System.Type)"]

graph (PluginGraph)

[Missing <param name="graph"/> documentation for "M:StructureMap.Source.XmlNodeInstanceMemento.ReadChildInstance(System.String,StructureMap.Graph.PluginGraph,System.Type)"]

childType (Type)

[Missing <param name="childType"/> documentation for "M:StructureMap.Source.XmlNodeInstanceMemento.ReadChildInstance(System.String,StructureMap.Graph.PluginGraph,System.Type)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlNodeInstanceMemento.ReadChildInstance(System.String,StructureMap.Graph.PluginGraph,System.Type)]


ReferenceKey Property

ReferenceKey Property
Namespaces ► StructureMap.Source ► XmlNodeInstanceMemento ► ReferenceKey
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlNodeInstanceMemento.ReferenceKey]

Declaration Syntax
C# Visual Basic Visual C++
public override string ReferenceKey { get; }
Public Overrides ReadOnly Property ReferenceKey As String
public:
virtual property String^ ReferenceKey {
    String^ get () override;
}


Substitute Method (memento)

Substitute Method (memento)
Namespaces ► StructureMap.Source ► XmlNodeInstanceMemento ► Substitute(InstanceMemento)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlNodeInstanceMemento.Substitute(StructureMap.InstanceMemento)]

Declaration Syntax
C# Visual Basic Visual C++
public override InstanceMemento Substitute(
    InstanceMemento memento
)
Public Overrides Function Substitute ( _
    memento As InstanceMemento _
) As InstanceMemento
public:
virtual InstanceMemento^ Substitute(
    InstanceMemento^ memento
) override
Parameters
memento (InstanceMemento)

[Missing <param name="memento"/> documentation for "M:StructureMap.Source.XmlNodeInstanceMemento.Substitute(StructureMap.InstanceMemento)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlNodeInstanceMemento.Substitute(StructureMap.InstanceMemento)]


ToString Method

ToString Method
Namespaces ► StructureMap.Source ► XmlNodeInstanceMemento ► ToString()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlNodeInstanceMemento.ToString]

Declaration Syntax
C# Visual Basic Visual C++
public override string ToString()
Public Overrides Function ToString As String
public:
virtual String^ ToString() override
Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlNodeInstanceMemento.ToString]


XmlTemplater Class

XmlTemplater Class
Namespaces ► StructureMap.Source ► XmlTemplater
StructureMap API

[Missing <summary> documentation for T:StructureMap.Source.XmlTemplater]

Declaration Syntax
C# Visual Basic Visual C++
public class XmlTemplater
Public Class XmlTemplater
public ref class XmlTemplater
Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | XmlTemplater(XmlNode) | Initializes a new instance of the XmlTemplater class
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | SubstituteTemplates(XmlNode, InstanceMemento) |
 | Substitutions |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
XmlTemplater


XmlTemplater Constructor (templateNode)

XmlTemplater Constructor (templateNode)
Namespaces ► StructureMap.Source ► XmlTemplater ► XmlTemplater(XmlNode)
StructureMap API
Initializes a new instance of the XmlTemplater class
Declaration Syntax
C# Visual Basic Visual C++
public XmlTemplater(
    XmlNode templateNode
)
Public Sub New ( _
    templateNode As XmlNode _
)
public:
XmlTemplater(
    XmlNode^ templateNode
)
Parameters
templateNode (XmlNode)

[Missing <param name="templateNode"/> documentation for "M:StructureMap.Source.XmlTemplater.#ctor(System.Xml.XmlNode)"]


SubstituteTemplates Method (node, memento)

SubstituteTemplates Method (node, memento)
Namespaces ► StructureMap.Source ► XmlTemplater ► SubstituteTemplates(XmlNode, InstanceMemento)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Source.XmlTemplater.SubstituteTemplates(System.Xml.XmlNode,StructureMap.InstanceMemento)]

Declaration Syntax
C# Visual Basic Visual C++
public XmlNode SubstituteTemplates(
    XmlNode node,
    InstanceMemento memento
)
Public Function SubstituteTemplates ( _
    node As XmlNode, _
    memento As InstanceMemento _
) As XmlNode
public:
XmlNode^ SubstituteTemplates(
    XmlNode^ node,
    InstanceMemento^ memento
)
Parameters
node (XmlNode)

[Missing <param name="node"/> documentation for "M:StructureMap.Source.XmlTemplater.SubstituteTemplates(System.Xml.XmlNode,StructureMap.InstanceMemento)"]

memento (InstanceMemento)

[Missing <param name="memento"/> documentation for "M:StructureMap.Source.XmlTemplater.SubstituteTemplates(System.Xml.XmlNode,StructureMap.InstanceMemento)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Source.XmlTemplater.SubstituteTemplates(System.Xml.XmlNode,StructureMap.InstanceMemento)]


Substitutions Property

Substitutions Property
Namespaces ► StructureMap.Source ► XmlTemplater ► Substitutions
StructureMap API

[Missing <summary> documentation for P:StructureMap.Source.XmlTemplater.Substitutions]

Declaration Syntax
C# Visual Basic Visual C++
public string[] Substitutions { get; }
Public ReadOnly Property Substitutions As String()
public:
property array<String^>^ Substitutions {
    array<String^>^ get ();
}


StructureMap.Util Namespace

StructureMap.Util Namespace
Namespaces ► StructureMap.Util
StructureMap API

[Missing <summary> documentation for N:StructureMap.Util]

Declaration Syntax
C# Visual Basic Visual C++
namespace StructureMap.Util
Namespace StructureMap.Util
namespace StructureMap.Util
Types
All Types Classes
Icon | Type | Description
 | Cache<(Of <(KEY, VALUE>)>) |


Cache(KEY, VALUE) Class

Cache<(Of <(KEY, VALUE>)>) Class
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>)
StructureMap API

[Missing <summary> documentation for T:StructureMap.Util.Cache`2]

Declaration Syntax
C# Visual Basic Visual C++
public class Cache<KEY, VALUE> : IEnumerable<VALUE>,
    IEnumerable
where VALUE : class

Public Class Cache(Of KEY, VALUE As Class) _
    Implements IEnumerable(Of VALUE), IEnumerable
generic<typename KEY, typename VALUE>
where VALUE : ref class
public ref class Cache : IEnumerable<VALUE>,
    IEnumerable
Generic Template Parameters
KEY

[Missing <typeparam name="KEY"/> documentation for "T:StructureMap.Util.Cache`2"]

VALUE

[Missing <typeparam name="VALUE"/> documentation for "T:StructureMap.Util.Cache`2"]

Members
All Members | Constructors | Methods | Properties
Public Protected |  | Instance Static |  | Declared Inherited
Icon | Member | Description
 | Cache<(Of <(KEY, VALUE>)>)()()() | Initializes a new instance of the Cache<(Of <(KEY, VALUE>)>) class
 | Cache<(Of <(KEY, VALUE>)>)(Func<(Of <(KEY, VALUE>)>)) | Initializes a new instance of the Cache<(Of <(KEY, VALUE>)>) class
 | Clear()()() |
 | Count |
 | Each(Action<(Of <(VALUE>)>)) |
 | Each(Action<(Of <(KEY, VALUE>)>)) |
 | Equals(Object) | Determines whether the specified Object is equal to the current Object. (Inherited from Object.)
 | Exists(Predicate<(Of <(VALUE>)>)) |
 | Fill(KEY, VALUE) |
 | Finalize()()() | Allows an Object to attempt to free resources and perform other cleanup operations before the Object is reclaimed by garbage collection. (Inherited from Object.)
 | Find(Predicate<(Of <(VALUE>)>)) |
 | First |
 | GetAll()()() |
 | GetEnumerator()()() |
 | GetHashCode()()() | Serves as a hash function for a particular type. (Inherited from Object.)
 | GetKey |
 | GetType()()() | Gets the Type of the current instance. (Inherited from Object.)
 | Has(KEY) |
 | MemberwiseClone()()() | Creates a shallow copy of the current Object. (Inherited from Object.)
 | Remove(KEY) |
 | Retrieve(KEY) |
 | Store(KEY, VALUE) |
 | ToString()()() | Returns a String that represents the current Object. (Inherited from Object.)
Inheritance Hierarchy
Object
Cache<(Of <(KEY, VALUE>)>)


Cache(KEY, VALUE) Constructor

Cache<(Of <(KEY, VALUE>)>) Constructor
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► Cache<(Of <(KEY, VALUE>)>)()()()
StructureMap API
Members
Icon | Member | Description
 | Cache<(Of <(KEY, VALUE>)>)()()() | Initializes a new instance of the Cache<(Of <(KEY, VALUE>)>) class
 | Cache<(Of <(KEY, VALUE>)>)(Func<(Of <(KEY, VALUE>)>)) | Initializes a new instance of the Cache<(Of <(KEY, VALUE>)>) class


Cache(KEY, VALUE) Constructor

Cache<(Of <(KEY, VALUE>)>) Constructor
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► Cache<(Of <(KEY, VALUE>)>)()()()
StructureMap API
Initializes a new instance of the Cache<(Of <(KEY, VALUE>)>) class
Declaration Syntax
C# Visual Basic Visual C++
public Cache()
Public Sub New
public:
Cache()


Cache(KEY, VALUE) Constructor (onMissing)

Cache<(Of <(KEY, VALUE>)>) Constructor (onMissing)
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► Cache<(Of <(KEY, VALUE>)>)(Func<(Of <(KEY, VALUE>)>))
StructureMap API
Initializes a new instance of the Cache<(Of <(KEY, VALUE>)>) class
Declaration Syntax
C# Visual Basic Visual C++
public Cache(
    Func<KEY, VALUE> onMissing
)
Public Sub New ( _
    onMissing As Func(Of KEY, VALUE) _
)
public:
Cache(
    Func<KEY, VALUE>^ onMissing
)
Parameters
onMissing (Func <(Of <( KEY, VALUE >)>))

[Missing <param name="onMissing"/> documentation for "M:StructureMap.Util.Cache`2.#ctor(System.Func{`0,`1})"]


Clear Method

Clear Method
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► Clear()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Util.Cache`2.Clear]

Declaration Syntax
C# Visual Basic Visual C++
public void Clear()
Public Sub Clear
public:
void Clear()


Count Property

Count Property
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► Count
StructureMap API

[Missing <summary> documentation for P:StructureMap.Util.Cache`2.Count]

Declaration Syntax
C# Visual Basic Visual C++
public int Count { get; }
Public ReadOnly Property Count As Integer
public:
property int Count {
    int get ();
}


Each Method

Each Method
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► Each()()()
StructureMap API
Members
Icon | Member | Description
 | Each(Action<(Of <(VALUE>)>)) |
 | Each(Action<(Of <(KEY, VALUE>)>)) |


Each Method (action)

Each Method (action)
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► Each(Action<(Of <(VALUE>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Util.Cache`2.Each(System.Action{`1})]

Declaration Syntax
C# Visual Basic Visual C++
public void Each(
    Action<VALUE> action
)
Public Sub Each ( _
    action As Action(Of VALUE) _
)
public:
void Each(
    Action<VALUE>^ action
)
Parameters
action (Action <(Of <( VALUE >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Util.Cache`2.Each(System.Action{`1})"]


Each Method (action)

Each Method (action)
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► Each(Action<(Of <(KEY, VALUE>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Util.Cache`2.Each(System.Action{`0,`1})]

Declaration Syntax
C# Visual Basic Visual C++
public void Each(
    Action<KEY, VALUE> action
)
Public Sub Each ( _
    action As Action(Of KEY, VALUE) _
)
public:
void Each(
    Action<KEY, VALUE>^ action
)
Parameters
action (Action <(Of <( KEY, VALUE >)>))

[Missing <param name="action"/> documentation for "M:StructureMap.Util.Cache`2.Each(System.Action{`0,`1})"]


Exists Method (predicate)

Exists Method (predicate)
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► Exists(Predicate<(Of <(VALUE>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Util.Cache`2.Exists(System.Predicate{`1})]

Declaration Syntax
C# Visual Basic Visual C++
public bool Exists(
    Predicate<VALUE> predicate
)
Public Function Exists ( _
    predicate As Predicate(Of VALUE) _
) As Boolean
public:
bool Exists(
    Predicate<VALUE>^ predicate
)
Parameters
predicate (Predicate <(Of <( VALUE >)>))

[Missing <param name="predicate"/> documentation for "M:StructureMap.Util.Cache`2.Exists(System.Predicate{`1})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Util.Cache`2.Exists(System.Predicate{`1})]


Fill Method (key, value)

Fill Method (key, value)
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► Fill(KEY, VALUE)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Util.Cache`2.Fill(`0,`1)]

Declaration Syntax
C# Visual Basic Visual C++
public void Fill(
    KEY key,
    VALUE value
)
Public Sub Fill ( _
    key As KEY, _
    value As VALUE _
)
public:
void Fill(
    KEY key,
    VALUE value
)
Parameters
key (KEY)

[Missing <param name="key"/> documentation for "M:StructureMap.Util.Cache`2.Fill(`0,`1)"]

value (VALUE)

[Missing <param name="value"/> documentation for "M:StructureMap.Util.Cache`2.Fill(`0,`1)"]


Find Method (predicate)

Find Method (predicate)
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► Find(Predicate<(Of <(VALUE>)>))
StructureMap API

[Missing <summary> documentation for M:StructureMap.Util.Cache`2.Find(System.Predicate{`1})]

Declaration Syntax
C# Visual Basic Visual C++
public VALUE Find(
    Predicate<VALUE> predicate
)
Public Function Find ( _
    predicate As Predicate(Of VALUE) _
) As VALUE
public:
VALUE Find(
    Predicate<VALUE>^ predicate
)
Parameters
predicate (Predicate <(Of <( VALUE >)>))

[Missing <param name="predicate"/> documentation for "M:StructureMap.Util.Cache`2.Find(System.Predicate{`1})"]

Return Value

[Missing <returns> documentation for M:StructureMap.Util.Cache`2.Find(System.Predicate{`1})]


First Property

First Property
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► First
StructureMap API

[Missing <summary> documentation for P:StructureMap.Util.Cache`2.First]

Declaration Syntax
C# Visual Basic Visual C++
public VALUE First { get; }
Public ReadOnly Property First As VALUE
public:
property VALUE First {
    VALUE get ();
}


GetAll Method

GetAll Method
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► GetAll()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Util.Cache`2.GetAll]

Declaration Syntax
C# Visual Basic Visual C++
public VALUE[] GetAll()
Public Function GetAll As VALUE()
public:
array<VALUE>^ GetAll()
Return Value

[Missing <returns> documentation for M:StructureMap.Util.Cache`2.GetAll]


GetEnumerator Method

GetEnumerator Method
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► GetEnumerator()()()
StructureMap API

[Missing <summary> documentation for M:StructureMap.Util.Cache`2.GetEnumerator]

Declaration Syntax
C# Visual Basic Visual C++
public IEnumerator<VALUE> GetEnumerator()
Public Function GetEnumerator As IEnumerator(Of VALUE)
public:
virtual IEnumerator<VALUE>^ GetEnumerator() sealed
Return Value

[Missing <returns> documentation for M:StructureMap.Util.Cache`2.GetEnumerator]


GetKey Property

GetKey Property
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► GetKey
StructureMap API

[Missing <summary> documentation for P:StructureMap.Util.Cache`2.GetKey]

Declaration Syntax
C# Visual Basic Visual C++
public Func<VALUE, KEY> GetKey { get; set; }
Public Property GetKey As Func(Of VALUE, KEY)
public:
property Func<VALUE, KEY>^ GetKey {
    Func<VALUE, KEY>^ get ();
    void set (Func<VALUE, KEY>^ value);
}


Has Method (key)

Has Method (key)
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► Has(KEY)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Util.Cache`2.Has(`0)]

Declaration Syntax
C# Visual Basic Visual C++
public bool Has(
    KEY key
)
Public Function Has ( _
    key As KEY _
) As Boolean
public:
bool Has(
    KEY key
)
Parameters
key (KEY)

[Missing <param name="key"/> documentation for "M:StructureMap.Util.Cache`2.Has(`0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Util.Cache`2.Has(`0)]


Remove Method (key)

Remove Method (key)
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► Remove(KEY)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Util.Cache`2.Remove(`0)]

Declaration Syntax
C# Visual Basic Visual C++
public void Remove(
    KEY key
)
Public Sub Remove ( _
    key As KEY _
)
public:
void Remove(
    KEY key
)
Parameters
key (KEY)

[Missing <param name="key"/> documentation for "M:StructureMap.Util.Cache`2.Remove(`0)"]


Retrieve Method (key)

Retrieve Method (key)
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► Retrieve(KEY)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Util.Cache`2.Retrieve(`0)]

Declaration Syntax
C# Visual Basic Visual C++
public VALUE Retrieve(
    KEY key
)
Public Function Retrieve ( _
    key As KEY _
) As VALUE
public:
VALUE Retrieve(
    KEY key
)
Parameters
key (KEY)

[Missing <param name="key"/> documentation for "M:StructureMap.Util.Cache`2.Retrieve(`0)"]

Return Value

[Missing <returns> documentation for M:StructureMap.Util.Cache`2.Retrieve(`0)]


Store Method (key, value)

Store Method (key, value)
Namespaces ► StructureMap.Util ► Cache<(Of <(KEY, VALUE>)>) ► Store(KEY, VALUE)
StructureMap API

[Missing <summary> documentation for M:StructureMap.Util.Cache`2.Store(`0,`1)]

Declaration Syntax
C# Visual Basic Visual C++
public void Store(
    KEY key,
    VALUE value
)
Public Sub Store ( _
    key As KEY, _
    value As VALUE _
)
public:
void Store(
    KEY key,
    VALUE value
)
Parameters
key (KEY)

[Missing <param name="key"/> documentation for "M:StructureMap.Util.Cache`2.Store(`0,`1)"]

value (VALUE)

[Missing <param name="value"/> documentation for "M:StructureMap.Util.Cache`2.Store(`0,`1)"]


AddRegistry Method

AddRegistry Method
Namespaces ► StructureMap ► InitializationExpression ► AddRegistry()()()
StructureMap API
Members
Icon | Member | Description
 | AddRegistry<(Of <(T>)>)()()() | Creates and adds a Registry object of type T.
 | AddRegistry(Registry) | Imports all the configuration from a Registry object


Child Method

Child Method
Namespaces ► StructureMap.Pipeline ► ExplicitInstance ► Child()()()
StructureMap API
Members
Icon | Member | Description
 | Child<(Of <(CONSTRUCTORARGUMENTTYPE>)>)()()() | Start the definition of a child instance for type CONSTRUCTORARGUMENTTYPE
 | Child(String) | Inline definition of a constructor or a setter property dependency


InstanceOf Method

InstanceOf Method
Namespaces ► StructureMap ► InitializationExpression ► InstanceOf()()()
StructureMap API
Members
Icon | Member | Description
 | InstanceOf<(Of <(T>)>)()()() | Adds an additional, non-Default Instance to the PluginType T.
 | InstanceOf(Type) | Adds an additional, non-Default Instance to the designated pluginType This method is mostly meant for open generic types


CreateProfile Method

CreateProfile Method
Namespaces ► StructureMap ► InitializationExpression ► CreateProfile()()()
StructureMap API
Members
Icon | Member | Description
 | CreateProfile(String) | Expression Builder to define the defaults for a named Profile. Each call to CreateProfile is additive.
 | CreateProfile(String, Action<(Of <(ProfileExpression>)>)) | An alternative way to use CreateProfile that uses ProfileExpression as a Nested Closure. This usage will result in cleaner code for multiple declarations


ForRequestedType Method

ForRequestedType Method
Namespaces ► StructureMap ► ConfigurationExpression ► ForRequestedType()()()
StructureMap API
Members
Icon | Member | Description
 | ForRequestedType(Type) | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. This method is specifically meant for registering open generic types
 | ForRequestedType<(Of <(PLUGINTYPE>)>)()()() | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms


InstanceOf Method

InstanceOf Method
Namespaces ► StructureMap ► ConfigurationExpression ► InstanceOf()()()
StructureMap API
Members
Icon | Member | Description
 | InstanceOf<(Of <(T>)>)()()() | Adds an additional, non-Default Instance to the PluginType T.
 | InstanceOf(Type) | Adds an additional, non-Default Instance to the designated pluginType This method is mostly meant for open generic types


ChildArray Method

ChildArray Method
Namespaces ► StructureMap.Pipeline ► ExplicitInstance ► ChildArray()()()
StructureMap API
Members
Icon | Member | Description
 | ChildArray<(Of <(PLUGINTYPE>)>)(String) | Inline definition of a dependency array like IService[] or IHandler[]
 | ChildArray<(Of <(PLUGINTYPE>)>)()()() | Inline definition of a dependency array like IService[] or IHandler[]


ForRequestedType Method

ForRequestedType Method
Namespaces ► StructureMap ► InitializationExpression ► ForRequestedType()()()
StructureMap API
Members
Icon | Member | Description
 | ForRequestedType(Type) | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. This method is specifically meant for registering open generic types
 | ForRequestedType<(Of <(PLUGINTYPE>)>)()()() | Expression Builder used to define policies for a PluginType including Scoping, the Default Instance, and interception. BuildInstancesOf() and ForRequestedType() are synonyms


Equals Method

Equals Method
Namespaces ► StructureMap ► ConfigurationExpression ► Equals()()()
StructureMap API
Members
Icon | Member | Description
 | Equals(Registry) |
 | Equals(Object) | (Overrides Object.Equals(Object).)


MemberwiseClone Method

MemberwiseClone Method
Namespaces ► StructureMap.Diagnostics ► DoctorRunner ► MemberwiseClone()()()
StructureMap API
Members
Icon | Member | Description
 | MemberwiseClone(Boolean) | Creates a shallow copy of the current MarshalByRefObject object.
 | MemberwiseClone()()() | Creates a shallow copy of the current Object.


CreateProfile Method

CreateProfile Method
Namespaces ► StructureMap ► ConfigurationExpression ► CreateProfile()()()
StructureMap API
Members
Icon | Member | Description
 | CreateProfile(String) | Expression Builder to define the defaults for a named Profile. Each call to CreateProfile is additive.
 | CreateProfile(String, Action<(Of <(ProfileExpression>)>)) | An alternative way to use CreateProfile that uses ProfileExpression as a Nested Closure. This usage will result in cleaner code for multiple declarations


Equals Method

Equals Method
Namespaces ► StructureMap ► InitializationExpression ► Equals()()()
StructureMap API
Members
Icon | Member | Description
 | Equals(Registry) |
 | Equals(Object) | (Overrides Object.Equals(Object).)


CreateInstance Method

CreateInstance Method
Namespaces ► StructureMap.Diagnostics ► ValidationBuildSession ► CreateInstance()()()
StructureMap API
Members
Icon | Member | Description
 | CreateInstance(Type, Instance) | (Overrides BuildSession.CreateInstance(Type, Instance).)
 | CreateInstance(Type, String) |
 | CreateInstance(Type) |